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T he last tab of the Tiled Clones

dialog is labelled “Trace” and,

unsurprisingly, it's used for tracing

existing drawings or bitmap

images to create an array of clones

that are related to some aspect of

the underlying image. Initially it

looks complex, but it's actually far

simpler than it appears.

After using the Reset button in

the dialog, most of the fields in

this tab become disabled. To

activate tracing mode, you have to

first check the box on the top line.

From then on it's just a case of

choosing the options you want

from each of the three numbered

sections. These can be broadly

described as:

• Which aspect of the image do

you want to use as your source of

data values?

• How do you want to modify

those values?

• What features of the clones do

you want those values to apply to?

To demonstrate, I ' ll use the

familiar face of La Giaconda as a

background image, with a red

round-cornered square as the

selected parent object for cloning.

When tracing, the clones are first

placed, sized and rotated in

accordance with the other tabs in

the dialog, then the background

image is tested underneath each

clone's position to extract a value

that will be used to further adjust

the clone.

In section 1 , we need to tell

Inkscape what value to extract.

You can choose from a general

color value or one of the individual

components of that color – Red,

Green, Blue, Hue, Saturation or

Lightness. There's also an option

for Opacity, which extracts the

alpha value from the underlying

image. This section results in a

single number for each clone. If “L”

was chosen, for example, the dark

parts of the image will yield a low

number, whereas the light parts

yield a high number.

Section 2 gives you the

opportunity to modify the

collection of numbers that you've

created in section 1 . You can adjust

the “gamma”, which allows you to

shift the midpoint of the number

range. This is best adjusted in small

amounts once you've seen what

the output looks like. Positive

numbers will shift the mid-point

upwards, negative values will shift

it downwards. For example, when

tracing a dark image using the “L”

channel, you might want to shift

the mid-point down – to better

center the range within the values

you're extracting. When tracing a

light image, on the other hand, you

might want to shift it upwards.

The Randomise field, as you

might expect, just modifies each

value from section 1 by a random

number. The value in this field

represents the maximum amount

of randomness that is allowed. The

Invert checkbox swaps low values

for high values, and vice versa. It's

used when you want low numbers

from your light areas, and high

numbers from the dark areas, for

example.

Finally, section 3 is where we

tell Inkscape what to do with the

extracted, adjusted values. For

each clone, you can use the

corresponding number to modify

any combination of Presence (the

probability that the clone is

created or not) , Colour, Size and

Opacity. The latter two are the

easiest to explain: in both cases

the original parent element

represents the maximum value

that is allowed. None of your

clones can get any larger, or more

opaque, than the parent. Instead,

the generated values are used to

reduce the size of the clone, or

reduce its opacity (making it more

transparent).
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Let's take a look at an example.

I 've traced the Lightness values of

La Giaconda, adjusting them with a

Gamma of -1 .0, and finally applying

the results to the Size and Opacity

of the clones. The parent object is

in the top left, and you can see

that dark areas (where “L” is low)

result in small reductions of size

and opacity. Light areas (where “L”

is large) result in much bigger

reductions. Checking the Invert

control would have resulted in the

opposite effect: large, opaque

clones in the light areas and small,

transparent ones in the dark areas.

The Presence option in section

3 is, in my opinion, broken. A

sensible way for this to work would

be for values above a certain

threshold to result in a clone being

drawn, with values below that

threshold producing no clone.

That's not what happens though.

Rather the value is used to adjust

the probability that a clone will be

drawn. Whether it actually is drawn

or not then comes down to

(weighted) luck. With “L” selected

in section 1 , it becomes likely that

clones will be drawn in dark areas,

and less likely they'll be drawn in

light areas, but as it's all down to

chance, it makes the results

somewhat unpredictable. To make

matters worse, the presence

calculation, in all its randomness, is

performed every time you click the

“Create” button. Click it again and

the arrangement will be different.

Another click, another

arrangement. Just take a look at

this example – all three images

were taken using exactly the same

settings, just by clicking the button

three times. With such radically

different results from the same

input values, it's no wonder I

question the benefit of this

“feature”.

The Colour checkbox is perhaps

the most useful of all the options

in section 3. To use it you first have

to unset the fill of your parent

object, just as we did last time

when using the “Colour” tab. This

option is a little different to the

others because it doesn't use the

value from section 1 . Instead, it

takes the RGB value of the pixels

under the clone and, after

adjusting them in accordance with

section 2, applies the resultant

color to the clone. A picture

describes it far better than a lot of

words.

This effect usually works best

with a large number of fairly small

clones. That combination can bring

a lesser computer to its knees

fairly quickly, though, so be careful

before you hit the Create button.

One limitation of this dialog is

that each of the four options in

section 3 is tied to a single set of

manipulations in section 2. You
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can't have Opacity set directly by

the “L” value, whilst also having

Size modified by the inverted

value, or use a different gamma for

the Colour and Presence. It's not

usually a problem, but if you do

need such combinations then

you've little choice but to use the

Tiled Clones dialog as a starting

point, then manually adjust each

clone afterwards.

The Trace tab can be used in

conjunction with the other tabs if

you want to add some rotation to

your clones, or perhaps adjust

their size or spacing. The latter can

be especially useful if you need to

tighten up the array when using

the Size checkbox in section 3. You

should also bear in mind that the

examples I 've given here are

deliberately simplistic. Your parent

object can be almost any shape or

group. The background you're

tracing, similarly, can be a

collection of objects rather than a

bitmap image. Just remember that

cloning complex parents takes

more processing power and

memory, so prepare for

slowdowns or even crashes if you

push the complexity or number of

clones too high.

To conclude our look at the

Tiled Clones dialog, I 'm going to

return to a couple of controls that I

skipped over previously. The first is

the “Use saved size and position of

the tile” checkbox at the bottom of

the dialog. Remember how

Inkscape uses the bounding box of

the parent as the basic unit of

measurement throughout this

dialog? This checkbox overrides

that default to instead use the

“saved” bounding box dimensions –

where “saved” just means “the last

value used before you checked this

box”.

Consider our color trace of La

Giaconda. By using 1 6 rows and 1 1

columns, my particular rounded

square covers the space quite

nicely. But what if I decide to

rotate the square to make a

diamond? Doing that increases the

size of the bounding box, so my 1 6

rows and 1 1 columns now spills

well over the edges of the

background image.

One obvious solution is to

reduce just the number of rows

and columns, but that still leaves

me with big gaps between the

tiles. I could tweak the values in

the Shift tab to compensate, but as

I already had a tile placement that

suited my needs, it's easier just to

tell Inkscape to “save” that and re-

use it for subsequent tiled clones.

Returning to the image as it was

previously (by pressing CTRL-Z a

few times) gets me back to a tile

layout I 'm happy with. At this point

I can tick the “Use saved size...”

checkbox to use that layout even

while I change other parameters in

the dialog, or make modifications

that will alter the size of the

parent's bounding box. Rotating

the parent again, and adding a

little variation with the Randomise

field in the Rotation tab, produces

a much better result.

The last control to cover in the

Tiled Clones dialog is actually the

first one. It's the pop-up menu on

the Symmetry tab, which

determines how the tiles are

initially arranged, prior to any

adjustments from the other tabs.

Mathematically speaking, there are

1 7 possible symmetries for a two-

dimensional pattern – see the

Wikipedia page for “Wallpaper

group” for more technical details.

These symmetries are based on

translating (moving), rotating and

reflecting the parent object to

create a repeating pattern, and the



full circle magazine #96 34 contents ^

Mark uses Inkscape to create three
webcomics, 'The Greys' , 'Monsters,
Inked' and 'Elvie' , which can all be
found at
http://www.peppertop.com/

HOWTO - INKSCAPE
pop-up lists each symmetry by its

mathematical title in “short”

notation (such as “P1 ”) followed by

a description of the symmetry

(such as “simple translation”) .

So far, I 've only used P1 for this

tutorial, because it's the simplest

to understand when used with the

other tabs in the dialog. Other

symmetries can quickly lead to

complex (and confusing) results,

but they can be useful if you want

to create tiled patterns or

kaleidoscopic art. Some work best

with triangular arrangements of

objects, others with more

rectangular parents.

Unfortunately, however, it's

very easy to confuse Inkscape

when using more complex

symmetries. Even something as

simple as switching your document

from portrait to landscape mode

can result in wildly misplaced

clones. The following page shows

examples of all 1 7 symmetries, but

several of these had to be created

in a fresh document and imported

into the final image in order for

them to work as expected. In a

couple of cases, I was never able to

produce the expected

arrangement. They came close, but

I had to manually arrange the

clones a little to get the correct

result. I 've outlined those ones in

red. If you do want to use the

advanced symmetries, I

recommend checking out this page

in the official manual, which

contains a similar set of images but

with a little more detail:

http://tavmjong.free.fr/INKSCAPE/

MANUAL/html/Tiles-

Symmetries.html

http://www.peppertop.com/shop/
http://tavmjong.free.fr/INKSCAPE/MANUAL/html/Tiles-Symmetries.html
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O ver the past few instalments,

I 've detailed the workings of

the Tiled Clones dialog. As well as

producing some interesting, and

often kaleidoscopic, visual effects,

this dialog can be useful for

creating particular arrangements

of objects. Because the dialog's

units are based on the bounding

box of the parent object (rather

than using explicitly stated

dimensions) , this approach isn't

terribly useful for positioning

objects at specific coordinates or

locations, so the next few articles

will look at the different tools

Inkscape provides for these kinds

of manipulations.

It's important to remember,

however, that Inkscape is not a

“computer aided design” (CAD)

program, of the sort used by

architects or engineers. If you want

to create technical drawings that

could be used by builders or

manufacturing companies, there

are other Open Source programs

that might serve you better, such

as FreeCAD, OpenSCAD, or QCAD.

With each release, Inkscape gains

more functionality in this area –

such as the new Measure tool in

0.91 – but it's still a long way from

a fully fledged CAD application.

With that limitation in mind, we'll

start with the most obvious form

of positioning: snapping to a grid.

Inkscape is rather flexible when

it comes to grids. You can have

more than one active at a time,

and each one can be either

rectangular (based on horizontal

and vertical lines) , or axonometric

(vertical lines, plus two sets of

angled lines) . Usually, however, it's

easiest to work with just one grid

at a time, most commonly a

rectangular one. Launch Inkscape

to create a new document, and, if

there's no grid visible, try pressing

“#” or use View > Grid to enable

the display of the default grid. To

edit this grid, or to add a new one,

use the File > Document

Properties menu, then select the

Grids tab.

To create a new grid, select

either Rectangular or Axonometric

from the pop-up menu at the top,

then click the New button. Each

grid gets its own tab in the

“Defined grids” section, with

slightly different icons for the two

grid types – but the icons are

always blue, regardless of the

color of your grid lines. They're

named automatically, with no easy

mechanism to change the name,

and no distinction in naming

between the two grid types. The

use of similar, identically-colored

icons and fixed, generic names

means that managing numerous

grids is less than straightforward,

so it's best to stick with just one or

two. The tab bar isn't scrollable –

the dialog just grows in size if you

start to add too many; and there's

also a practical limit imposed by

the UI .

Each grid has three checkboxes

that control snapping and visibility.

These are in addition to the View >

Grid option (toggled via the “#”

key), so, for a grid to be visible, you

need both of the top two

checkboxes to be enabled and the

View > Grid toggle to be on. Think

of the toggle as a global way of

showing and hiding all the possible

grids at once, with the checkboxes

being a way to more finely control

what each individual grid

contributes.

The first checkbox, “Enabled”,

simply switches the entire grid on

and off. With it unchecked, the

remaining options are all disabled

and the grid plays no part in

snapping or display. You might use

this if you have multiple grids so

that only one is switched on at a

time – typically when swapping

between rectangular and

axonometric within the same

drawing.
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The second checkbox, “Visible”,

has only a visual effect. With this

unchecked, the grid will not be

displayed, but can still play a part

in snapping if the grid is enabled

via the first checkbox. As it can be

difficult and frustrating to snap to

a grid you can't see, I strongly

recommend always leaving this

option checked.

The third checkbox, “Snap to

visible grid lines only”, is slightly

misleading with its labelling –

though the tooltip is clearer. This

checkbox concerns grid lines that

are automatically suppressed as

you zoom out. If you were to zoom

out far enough, the grid lines

would become so dense that they

just appear as a solid colored

background. Inkscape avoids this

by hiding grid lines that would be

drawn too densely, and would have

been a hindrance rather than a

help. With this option unchecked,

you can still snap to these

suppressed lines, but I recommend

leaving it enabled so that you snap

to only visible grid lines. This may

require you to zoom in a little to

get the precise snapping point

you're looking for, but it's usually a

good trade-off against the

frustration of constantly mis-

snapping to invisible grid lines.

The remaining options in the

dialog are used to define the

displayed lines, and are fairly self-

descriptive. You can position the

origin of the grid – 0,0 is good for

most drawings – and define the

spacing between grid lines in both

the x and y directions. As most

people usually need a square grid

it would be good to have an option

to link these values, but it's no

great hardship to simply enter the

same value into each field. You can

set the color, and opacity for the

grid lines – it's usually best to keep

the opacity low so that they are

less dominant on the screen, and

less likely to be mistaken for real

lines in your drawing. By setting

different colors or opacities for

major and minor grid lines, you can

create a “graph paper” effect. This

becomes visible only when you're

zoomed in closely enough, and, if

you do decide to use this feature,

it's best to make the major lines

more opaque than the minor ones.

Set the “Major grid line every” field

to 0 if you want to disable this

feature. Finally, the “Show dots

instead of lines” checkbox does

exactly what it describes, and

results in a more lightweight view

of the grid. Setting this option, or

changing the line colors, can make

it easier to work with multiple

grids that are all active at the same

time, should you need to.

The options for creating an

axonometric grid are broadly

similar to those for creating a

rectangular one. There's only a

single entry for spacing, and a

couple of new fields for defining

the angles of the x and z axes. The

default values of 30° are fine for

isometric drawings, though you

might want to use 45° for an

“oblique” projection. Setting either

of these too close to 0° or 90°

results in rendering problems. Any

value outside this range is capped,

though that isn't reflected in the

displayed number. Unfortunately,

there's no “Show dots instead of

lines” option for axonometric

grids.

Also missing is the ability to

create logarithmic or polar grids.

Both are possible via extensions –

though these create “real” SVG

objects, rather than Inkscape grids,

so they can't be toggled with the

“#” key, and have to be snapped to

via object snapping, not grid

snapping. If you do have need of

these grid types, however, you can

find them under Extensions >

Render. In 0.48, you're looking for

the Cartesian Grid and Polar Grid

entries, whereas in 0.91 they've

both been moved into an extra

“Grids” submenu. The image on the

next page (top right) gives an

example of grids produced using

these extensions.

Going back to Inkscape's

rectangular and axonometric grids,

the setup we've done so far just

lets you visually align objects. To

really use them as layout tools,

you'll also need to enable

snapping. As with grids, there's a
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global toggle for snapping: press

the “%” key (Shift-5 on my

keyboard) to trigger it, use the

View > Snap menu entry, or click

on the first icon on the Snap

Controls Bar (button 1 in the

screenshot below).

With snapping enabled, you

also need to have either button 2

or 3 (or both) enabled. These

dictate what parts of your drawing

can be snapped: button 2 enables

the snapping of bounding box

corners, and kicks in when you

resize or move an object using the

Select tool; button 3 enables the

snapping of nodes and handles, so

has an effect when you initially

draw an object, or subsequently

edit it using the appropriate

object-specific tool. Enabling

either button makes a few others

available that you can use to

enable more specific snappings –

such as snapping the center point

of a bounding box, rather than just

its corners – but most of the time I

find that one of the main two

buttons is good enough.

As well as defining which parts

of an object should snap, we also

have to tell Inkscape what we want

them to snap to. Button 4 enables

snapping to the grid. The button

after it enables snapping to

guidelines (covered in Part 1 6 of

this series) – I usually leave this

enabled as it has no effect unless

you specifically add some

guidelines, in which case you

probably want it switched on

anyway. The other button in this

section enables snapping to the

page border, which I find to be less

useful for my own projects.

There's one final setting to look

at (shown left) regarding snapping,

so it's back to File > Document

Properties, but this time select the

Snap tab.

Within this panel, you can set

how voracious Inkscape is in its

efforts to snap. For each section,

the “Always snap” option means

exactly that: snap to the nearest

snapping point, regardless of how

far away it might be. This is useful

if you absolutely have to draw to

the grid to ensure dimensional

accuracy. More generally, however,

“Snap only when closer than”

offers a good trade-off between

accuracy and freedom. With this

mode enabled, you can freely place

your objects, nodes and handles,

unless they get close to a snapping

point, in which case they will jump

to that location. Exactly how close

is set by the “Snap distance” slider.

The values are measured in screen

pixels, so zooming has an effect on

the effective “hit area” in which

snapping occurs: zoom in to give

yourself more freedom, or zoom

out to make snapping more likely.

Within File > Inkscape

Preferences (Edit > Preferences in

0.91 ) , there are “Grids” and

“Snapping” panels that offer a few

other options. The defaults are

usually fine for most users, but if
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you find yourself heavily using

grids or snapping, it might be

worth taking a look to see if any of

these settings can improve your

workflow.

With a grid visible and snapping

enabled, you should find it quite

easy to create shapes that stick to

the grid intersections. When you

need to place nodes off the grid,

you can either press the “%” to

disable snapping (whilst leaving

the grid visible) , or more easily (on

a US or UK keyboard, at least) you

can press “#” to turn the grid off

entirely, removing it as a snap

target. Often, however, there's a

requirement to place objects

relative to one another, rather

than to an absolute grid; that will

be the subject of the next

instalment...

NNEEWW SSPPEECCIIAALL EEDDIITTIIOONNSS PPAAGGEE

I t's not perfect, by any stretch of the imagination, but this new page on the site links to the most

popular Special Edition topics. As of writing there are links to GIMP, Inkscape, LibreOffice,

Python and Scribus Special Editions.

http://fullcirclemagazine.org/special-editions/

http://www.peppertop.com/shop/
http://fullcirclemagazine.org/special-editions/
http://fullcirclemagazine.org/special-editions/
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O ne common requirement

when creating vector

drawings is to align objects relative

to one another. You might want a

circle that's centered within a

square, or a triangle that touches

the top of the page. A related

requirement is to distribute

several objects evenly, with

identical gaps between each of

them. These types of

arrangements are made easy with

Inkscape's Align and Distribute

dialog.

This dialog can be opened via

the Object menu, the icon to the

right of the main “Commands”

toolbar, or by pressing CTRL-SHIFT-

A. The screenshot was taken from

version 0.91 and has a few minor

differences to the 0.48 version

that's still in many distributions'

repositories: the buttons I 've

outlined in red are new to 0.91 ,

and a few of the other icons have

moved to new positions. For this

article, I ' ll be concentrating on the

Align section at the top of the

dialog, which hasn't significantly

changed between versions.

Let's start with an extremely

simple alignment task: to center a

circle in the middle of a page. Start

by drawing a circle anywhere in the

workspace – it doesn't even have

to be inside the page. Now, with

the circle selected, open the Align

and Distribute dialog and select

“Page” from the “Relative to” pop-

up menu. There's no option to

center both horizontally and

vertically at once, so you have to

click the “Center on vertical axis”

button first, followed by the

“Center on horizontal axis” button

afterwards (or vice versa, if you

prefer) . These buttons can be

found, one above the other, in the

two rows of icons within the

“Align” section of the dialog.

That was pretty

straightforward, right? Now create

three or four circles of different

sizes, each with a stroke but no fill.

Select them all and repeat the

previous steps. If all went well you

should now have a series of

concentric circles all centered on

the page. This example image

shows the “before” and “after”

arrangement of some circles that

were centered in this way:

It's important to understand

that you can align more than one

object at the same time. Usually

this reduces the number of steps

you need to perform, but

sometimes it can be confusing

when an inadvertently selected

object disappears behind a larger

shape that you're trying to align.

When dealing with multiple

objects, you sometimes want to

center the whole arrangement,

whilst keeping the individual

elements in the same relative

positions. One approach is to

group them all first: the buttons in

the dialog will align the group, but

won't descend into it to affect the

individual elements. The same

effect can be achieved by enabling

the “Treat selection as group”

checkbox in the dialog before you

click on the alignment buttons,

saving you the trouble of grouping

and then un-grouping your objects

(see illustration on following page,

top left) .

With “Treat selection as group”

unchecked, let's take a look at

some other possibilities. On either

side of the two centering buttons
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you'll find buttons for aligning the

top, bottom, left or right edges of

your objects. In practice, this refers

to the edge of the bounding box

for the objects – either the visual

or the geometric bounding box,

depending on how your Inkscape

preferences are set. Most of the

time this distinction isn't

important, but it can drastically

alter the results when a filter is

applied to your objects and the

visual bounding box is in use.

So far, we've only aligned things

relative to the page. Using the

pop-up menu you can select

various other options. For now

we'll look at “Drawing” and

“Selection Area” (just “Selection”

in 0.48). “Drawing” refers to an

imaginary bounding box that

encompasses everything you've

drawn in your image, whether it's

inside or outside the page

boundary. It stretches from the

left edge of the leftmost object in

your drawing to the right edge of

the rightmost object, and the

equivalent in height. “Selection”,

on the other hand, just refers to

the bounding box that

encompasses all of the currently

selected objects.

In this example, I 've created a

few objects and selected all of

them except for the purple star.

Notice the difference as I use the

“Align left edges” button, first with

the page, then the drawing and

finally the selection.

As well as aligning to the page,

drawing or selection bounding

boxes, objects can also be aligned

relative to one another. To do this

you need to select at least two

objects: one of them will remain

anchored in its original position,

and all the other objects will be

aligned to it. Inkscape offers four

options for choosing which of the

objects will be anchored: the first

object you selected, the last one,

the biggest object or the smallest.

Of these choices I recommend

using only First Selected and Last

Selected. They make it easy to

determine what's going to move,

and what isn't. When trying to

align objects, you've usually got a

good idea of the outcome you're

trying to achieve, so being able to

specify exactly which object is used

as the anchor for alignment is

more useful than some unclear

definition of “bigger” or “smaller”.

For example, suppose you have

a rectangle that you duplicate and

rotate through 90°. Which of the

two is “bigger” and will be used as

the anchor? They're both exactly

the same area, but one is wider

and the other is taller. The answer

depends on what type of
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alignment you choose: the buttons

on the top row, which move the

objects horizontally, consider the

object with the largest width to be

the “biggest”; the buttons on the

second row, which move the

objects vertically, consider the

tallest object to be the “biggest”.

In this example the red rectangle is

a rotated copy of the yellow one,

and the alignment mode was set to

“Biggest object” before each of

the centering buttons was pressed.

Clearly the use of “Biggest

object” and “Smallest object” can

cause problems and confusion if

multiple objects are the same size,

but it can also be misleading when

an optical illusion leads you to

think that (for example) a dark

object is bigger than a similarly

sized light object. There's a similar

problem when selecting multiple

objects at once, then using “First

selected” or “Last selected”

(Inkscape bases its choice of

anchor on the z-index of the items

in that case), leading to my rules

for aligning objects relative to

each other:

• Use “First selected”.

• De-select everything (click in the

work area, away from any objects –

or use Edit > Deselect) .

• Select the object you want to

align to (the anchor).

• Hold shift and drag a rectangle

over the objects you want to align.

• Add or remove individual objects

from the selection by holding

SHIFT as you click on them.

• Click on one alignment button

from the top row and/or one

alignment button from the second

row to move the objects into place.

With that approach you'll

always be in control of which

objects are moved, and where they

move to. The only variation that I

ever use is when the objects I want

to move are already selected –

especially if it's a complex

selection. In that case it's worth

using “Last selected” and just

holding SHIFT whilst clicking on

the anchor object to add it to the

selection. If the anchor is already

selected, you can SHIFT-click to de-

select it, then do the same again to

re-select it, thus making it the last

selected object.

When using First/Last/

Biggest/Smallest you should note

that the behaviour of the “Treat

selection as group” checkbox

changes somewhat – often in a

counter-intuitive way. In these

modes, the anchor object has to be

part of the group, so you might

expect it to move along with

everything else in order to

maintain the relative positions of

objects (as we saw when using the

Page/Drawing/Selection modes).

What actually happens, however, is

that the anchor object remains

stationary and all the other

selected objects move as though

they're grouped. In other words it

becomes a “treat selection as

group, except for the anchor

object” checkbox.

Furthermore, the effect of this

checkbox changes depending on

the layout of your objects. In this

example, I 've drawn three red stars

and one green circle, arranged per

the top image. Using “First

selected” mode I click on the circle,

then hold SHIFT and drag a

rectangle over the stars. Ensuring

that “Treat selection as group” is

checked, a click on the “Center on

vertical axis” button should move

the stars, keeping the circle in

place. Logic might suggest that I ' ll

end up with the second image, but

actually what I get is the third one.

What's going on?

It's our old friend the bounding

box at play once more. Consider

the bounding box of the first

image – it's the total width of the

stars plus the circle. When

centering the selection, it's this

bounding box that's used for the

calculation, even though the circle

won't be moved with the other

objects. The result is that the stars

are moved so that the center of

the original bounding box is

centered with the circle, even

though doing so results in a

smaller bounding box afterwards.

There are two solutions to this

dilemma: the most obvious is to

group the stars then align the

group to the circle with the “Treat

selection as group” checkbox un-

ticked. This turns a complex
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arrangement of four objects into a

simpler problem involving just two

– the circle and the group. It's the

approach I used to produce the

second image in the example. The

other alternative is to click the

“Center on vertical axis” button a

second time: after the first press,

the new bounding box is only as

wide as the stars, so aligning again

(with the checkbox enabled)

results in the expected behaviour.

With everything you've read so

far, you should be able to

understand the behaviour of most

of the alignment buttons in the

dialog, but there are two that defy

the rules: the last button on each

row is purely used to align text

objects.

These buttons align text objects

to the vertical or horizontal

baseline of other text objects.

They ignore any non-text objects in

the selection, pay no attention to

the state of the “Treat as group”

checkbox, and don't even honour

the “Relative to” pop-up. If you're

using Inkscape for some simple

desktop publishing work – perhaps

creating a poster or flyer – then

they can be used to ensure that

different sections of text adhere to

the same baseline (the line that

runs under the text, ignoring any

descenders such as the tail on a

“y”) . This can give a more

professional appearance. An

alternative approach is to drag out

a guide from the ruler (see part

1 6) , enable snapping, and activate

the “Snap text anchors and

baselines” option. Regardless of

your method, if you use multi-line

text, then it's only the baseline of

the first line that is snapped or

aligned to, preventing completely

separate pieces of text from easily

sharing the same “baseline grid” as

you might in a proper DTP program

such as Scribus.

Perhaps the most important

thing to remember about aligning

in Inkscape is that, however you

align your objects, if you end up

with an alignment you're not

happy with, simply press CTRL-Z or

use Edit > Undo to reverse the

action. There's logic to alignment

in Inkscape – even if that logic

doesn't always produce the

outcome you might initially expect.

http://www.peppertop.com/shop/
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L ast time I introduced the Align

and Distribute dialog, but went

only as far as describing the Align

part. This time I 'll continue – not

only onto the Distribute section,

but down through the remaining

sections of the dialog as well. Let's

start with a reminder of what the

dialog looks like, noting that

there's been a little rearrangement

of the buttons between 0.48 and

0.91 , and the ones outlined in red

are new to 0.91 .

Much like the Align section, the

Distribute part of the dialog is split

into two rows of buttons,

governing horizontal and vertical

distribution, respectively. Using

these, you can distribute a number

of objects so that they're spaced

evenly along the horizontal axis or

the vertical axis. If you want to

distribute along both axes – to

create a staircase effect – you'll

need to press a button from each

row in turn.

As you might expect, the

objects to be distributed are the

ones that are selected on the

canvas. Selection order doesn't

matter, and you can't choose the

anchor objects: everything is

calculated implicitly from the

positions of the elements. When

distributing horizontally, for

example, the objects furthest to

the left and right will be left in

place, with all the others being

distributed between them. For

vertical distribution, the rules are

the same, except with the highest

and lowest (by y coordinates)

being left in place.

What this means, in practice, is

that you need to get your first and

last objects into the right place

before trying to use these buttons.

Often that involves snapping to

the grid, or aligning to another

object as described last time. Only

once those are in the right

locations should you select all the

objects you want to distribute –

including the first and last ones –

and then click on one of the

buttons.

The difference between each of

the buttons is quite well

represented by their icons.

Considering each of the five

buttons in the first row (I 'm sure

you can infer the equivalent

functions for the second row), the

buttons move your selected

objects so that:

• The left edges of their bounding

boxes are evenly distributed

• The centers of their bounding

boxes are evenly distributed

• The right edges of their

bounding boxes are evenly

distributed

• The space between each

bounding box is evenly distributed

• The space between baseline

anchors of text objects is evenly

distributed

That last one probably needs a

little more explanation. Much like

the text alignment buttons

mentioned in the previous

instalment, these two text

distribution buttons work only

with a selection of text objects.

When you edit text in Inkscape,

you may notice a small square

below the text you enter. This is

the baseline anchor, and its

position varies depending on the

text justification. These buttons

move your text objects so that the

baseline anchors are evenly

distributed. Before rushing to use

these buttons to distribute your

text, however, do consider

whether that's really what you

want: usually the previous button

(even spaces between objects)

gives a better result.

Often you'll find that the

difference between distribution

options is negligible, especially

when the objects are all similarly

sized. When you start to distribute
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differently sized elements,

however, the differences can be

significant, as you can see from the

image shown below.

Continuing downwards, the

layout of the dialog diverges

between versions 0.48 and 0.91 .

For the latter, the next section of

the dialog is labelled as

“Rearrange”, and consists of six

icons of varying provenance:

• Arrange Connector Network:

Moved from the “Connector

network layout” section in 0.48

• Exchange positions, selection

order: New to 0.91

• Exchange positions, stacking

order: New to 0.91

• Exchange positions, clockwise

rotate: New to 0.91

• Randomise centers: Moved from

the “Distribute” section in 0.48

• Unclump objects: Moved from

the “Distribute” section in 0.48

The first of these works only if

your selected objects form a

network that was created with the

Connector tool (see part 27 of this

series for more details) . It's just a

duplicate of the same button in the

Connector tool controls – except

that this one offers fewer settings.

My advice is to use the dedicated

connector toolbar if you need this

functionality, but really you're

better off using a different

application altogether for anything

more than a trivial connector

layout.

Have you ever wanted to swap

the positions of two objects? To

move the left one to the right, and

the right one to the left, for

example? In that case the three

new buttons in 0.91 are for you.

With two objects selected, their

positions will be swapped, but if

you have more than two things

selected then the first moves to

the position of the second, the

second to the third, the third to

the fourth, and so on. The last

moves to the position of the first.

But what determines which

object is first, second or third?

That's simply down to which

button you click. The first button

bases it on which order the objects

were selected in – so it's best to

hold shift and click on each one

individually to ensure you know

the selection order. The second

button uses the stacking order, or

z-index, of the selected objects.

The one on top is moved to the

position of the one beneath it.

That moves to the position of the

one beneath that, and so on down

the stack. The bottom object is

moved to the position of the

topmost item. Note, however, that

it's just the positions that are

changed, not the z-indexes, so the

stacking order remains the same.

The final button swaps the

positions of the selected objects in

a “clockwise” direction, based on

the x and y coordinates of each

object.

Whilst these buttons are a

welcome addition, I hope that their

functionality will be expanded

further in a future release. There's

no option to reverse the order, for

example. If you want to rotate 1 00

objects one step anti-clockwise

you currently have to do it by

clicking the clockwise button 99

times!

The “Randomise centers”

button does exactly as its name

suggests. Click it and your selected



full circle magazine #99 23 contents ^

HOWTO - INKSCAPE
objects are randomly moved

around. This may be useful if

you've used the Spray tool or Tiled

Clones dialog to create a lot of

objects that you then want to

randomly distribute – but the same

effect can often be better

achieved by using the Randomise

fields in the Tiled Clones dialog, or

with the Tweak tool (see part 22).

The final button in this section

is described as “Unclump objects”.

In practice, it moves your objects a

little in order to more evenly space

the edge-to-edge distances. You

can apply it repeatedly, but it will

eventually reach equilibrium. It can

be useful for neatly arranging

objects in two dimensions – think

of it as a 2D equivalent to the

“equidistant spacing” buttons in

the Distribute section. Be careful if

your objects overlap too much, as

it can tend to pull them all

together into a single pile rather

than separating them out – the

exact opposite of “unclumping” in

my book!

In fact, separating objects out is

really the job of the last section in

this dialog: Remove overlaps. The

spinboxes allow you to specify the

minimum distance between

bounding boxes in both horizontal

and vertical directions, whilst

clicking the button at the right will

actually perform the operation.

You can use the H and V

parameters to push your objects

further apart by setting them to

values greater than 0 (in pixels) .

You can also enter negative values,

but doing so won't pull your

objects closer together: because

this is the minimum spacing, it

simply means that already

overlapping objects can continue

to overlap to some degree. Do

note that the calculations are

based on the rectangular bounding

boxes, though, so if you're working

with objects such as circles you can

sometimes find that their

movements aren't what you

expected. Take a look at the

bounding boxes to see what really

happened.

If you look again at the

screenshot of this dialog, you

might be forgiven for thinking that

I 've covered all of it, but that's only

because you've been misled by a

slight oddity in this dialog. On first

opening it, there's a section at the

bottom labelled “Nodes”, with four

additional buttons – as seen in last

month's screenshot. As you start to

select objects, however, that

section disappears from sight. In

practice, it's still available, but only

when you switch to the Node tool

in the main toolbar. On doing so,

the dialog changes completely to

just show this:

To use this mode, you must first

select some nodes using the Node

tool. You can even select nodes

from multiple different paths, if

you wish. Clicking on the first

button will align the nodes along a

single horizontal line that lies

halfway between the top and

bottom of the nodes' bounding

box . The second button does the

same trick along the vertical axis.

There's no option to align to the

top, bottom, left or right of the

box, nor to the first node selected.

If you need a specific alignment

then the best approach is to set a

guide at the right place, align

horizontally or vertically, then drag

the still selected nodes to the

guide, preferably with snapping

enabled.

Clicking both of the alignment

buttons in succession is a quick

way to collapse all the nodes down

to a single point, and can be

particularly useful for ensuring

that nodes from different paths

are co-located, such as when trying

to fake the appearance of a

connection between more than

two paths at a single point.

Unfortunately all the selected

nodes move, with no option to use

one as an anchor point, so, whilst

it's a quick way to co-locate them,

it's not so useful if you need them

at a specific position. It's also

important to note that this is just a

visual effect – there's no native

support for co-located nodes in

SVG – so you have to take care to

select all the relevant nodes if you

need to move them later.
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The last two buttons in Node

mode distribute the selected

nodes evenly. Like the equivalent

tool for objects, they are

distributed between the nodes

that are positioned furthest to the

left and right (or top and bottom

for vertical distribution).

That concludes our tour of the

Align and Distribute dialog. It may

not offer all the options of a fully-

fledged CAD application, but once

you get used to the features it

does have, it can quickly become

an invaluable addition to your

toolbox. If you want to produce

good looking diagrams with evenly

spaced, neatly-aligned content, it's

well worth spending a little time

becoming familiar with its

capabilities.

PYTHON SPECIAL EDITIONS:

http://fullcirclemagazine.org/issue-py01 / http://fullcirclemagazine.org/issue-py02/

http://fullcirclemagazine.org/python-
special-edition-issue-three/

http://fullcirclemagazine.org/python-
special-edition-volume-four/

http://fullcirclemagazine.org/python-
special-edition-volume-five/

http://fullcirclemagazine.org/python-
special-edition-volume-six/

http://www.peppertop.com/shop/
http://fullcirclemagazine.org/issue-py01/
http://fullcirclemagazine.org/issue-py02/
http://fullcirclemagazine.org/python-special-edition-issue-three/
http://fullcirclemagazine.org/python-special-edition-volume-four/
http://fullcirclemagazine.org/python-special-edition-volume-five/
http://fullcirclemagazine.org/python-special-edition-volume-six/
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T o celebrate the incredible
achievement of 1 00 editions of

Full Circle Magazine, I 'm going to
take a break from the usual
tutorial format, and instead list
1 00 useful tips for working with
Inkscape. Some of these have
previously been mentioned in this
series, others have yet to be
covered – whilst there are a few
that would probably never have
seen the light of day if it wasn't for
this celebratory change of style.

INSTALLING INKSCAPE

1 . The easiest way to getInkscape
onto a Linux machine is simply to
install it from your distro's
repositories. This may still get you
version 0.48.x, but for most
people, that's probably good
enough to work with until your
next major distribution upgrade.

2. The version after 0.48.x is 0.91
– there was a jump in version
number to give a better indication
of how well developed the
program is. If you want to get 0.91
onto an older Debian or Ubuntu
based distro, your best bet is to

install from the Inkscape
Developer's PPA:
https://launchpad.net/~inkscape.d
ev/+archive/ubuntu/stable

3. If you need to use Inkscape on
a Mac, make sure you check out
the official FAQ first as the need
for XQuartz on OSX throws up a
few issues.

4. If you usually use a laptop you
might be tempted to try using the
trackpad with Inkscape. Whilst you
might get away with it for small
creations or edits, for any serious
work with Inkscape you really need
a mouse with at least two buttons
and a clickable scroll wheel.

5. Equally you might think that a
graphics tablet would be a good
purchase, but you really should try
before you buy. Whilst a tablet can
be a real boon for some graphics
programs, such as GIMP, Krita or
MyPaint, the vector nature of
Inkscape makes a tablet far less
useful than you might expect. For
some calligraphic styles it may
work well, but if you just want to
draw something freehand it's

probably easier to use a pencil and
paper, then scan your work and
trace over it manually.

6. Another one for laptop users:
Inkscape's easier to use with a full-
sized keyboard. Some of the
keyboard shortcuts use the
numeric keypad, making them
rather inconvenient on a cut-down
keyboard.

7. That said, version 0.91 does
allow you to configure the
keyboard shortcuts much more
easily than earlier releases, so,

with a bit of work, you might be
able to get away with a smaller
keyboard. Head to Edit >
Preferences > Interface >
Keyboard Shortcuts, then click on
the shortcut you want to change
and press the new key combination
you want to use.

THE BASICS

8. Keep an eye on the status bar!
This is perhaps the most important
tip for using Inkscape, as it not
only tells you what you've
currently got selected, but also

https://launchpad.net/~inkscape.dev/+archive/ubuntu/stable
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offers details about the various
keyboard modifiers you can use
with each tool.

9. Use the context menus on the
status bar widgets for fast access
to some commonly used options
and defaults.

1 0. The spinboxes on the tool
control bar also have useful
context menus. Unfortunately the
spinboxes inside dialogs tend to be
less useful.

1 1 . In 0.91 you can do simple
arithmetic inside spinboxes, saving
you from having to perform the
calculations elsewhere and copy

the results in.

1 2 Can't see an object when you
draw it? Start by checking the
following:
• That your fill and/or stroke both
have a color, and aren't
transparent.
• That your stroke has some
thickness to it.
• That your layer is opaque.
View with filters off (see the

“Filters” section), in case you've
blurred it away to nothingness.
• Is it a circle or arc? Make sure
the arc handles are far enough
apart.
• Check the object dimensions –
perhaps it's just very, very small.

This can happen if you accidentally
release the mouse button whilst
dragging.
• Did you draw it inside an already
clipped group?

1 3. If you've lost your object
entirely, use View > Display Mode >
Outline to see everything, even
transparent objects, as simple
outlines.

1 4. Use the area outside the page
boundary. Objects placed here
won't appear on screen if your SVG
is loaded into a web browser, and
it's easy to omit them when
exporting to a PNG, so this is a
good place to keep temporary
notes, copies of objects that you
might need again, or just to use as
a scratch-pad. I find it to be a great
place to hide the Easter Eggs in my
comics!

KEYBOARD SHORTCUTS

1 5. The keyboard shortcut
preferences of 0.91 offer a useful
way to view the existing shortcuts.
For a more comprehensive
overview, or for 0.48 users, use the
reference document here:
https://inkscape.org/en/doc/keys.h
tml – it's from version 0.46, but

almost everything still applies to
the more recent versions.

1 6. If you're using Linux and
finding that the whole window
moves when you try to ALT-drag an
object, try holding the Windows
key down as well.

1 7. Don't work at full-screen size.
Reduce the size of the window to
speed up redraws, especially when
using filters. Undock dialogs to
make this more practical.

1 8 Selecting an object also
switches the active layer – use this
as a quick way to draw something
on the same layer as an existing
object.

1 9. Use the CTRL key to “control”
your movements:
• When drawing, to keep to
integer ratios. This is the easiest
way to draw circles and squares.
• When moving objects or nodes,
to only move horizontally or
vertically.
• When rotating or skewing, to
only move by fixed amounts, as set
in the preferences.
• When scaling, to scale
proportionally.
• CTRL + drag up/down using the
star/polygon tool to get properly
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aligned shapes.
• Use CTRL+Mouse Wheel to
quickly zoom in and out, regardless
of which tool is currently selected.

20. If you really want fine control
of the zoom level, use the input
field at the far right of the status
bar.

21 . Press and hold Q to quickly
zoom any selected objects to fill
the window. With the object
zoomed, focus a different window
or dialog and release the Q key to
“fix” the zoom at that level. Once
back in the main window, make the
edits you need to, then just tap the
Q key to zoom back out again.

22. Use a middle-click (on the
mouse wheel) to pan. Combined
with the zooming tips above, this
will help you navigate around your
canvas in record time!

23. Press the spacebar to quickly
toggle modes from your current
tool to the selection tool and back.
Be careful on 0.91 , though, where
the default “spacebar activates
pan” setting interferes with this
unless your mouse is absolutely
stationary.

24. Whilst dragging an object

around, press the spacebar to
stamp a copy of it. Unfortunately
0.91 's pan setting also interferes
with this. Again, make sure the
mouse is stationary first.

25. Use the cursor keys to move
selected objects around. Hold ALT
to move by smaller amounts. Most
usefully, hold SHIFT to move in
steps that are independent of your
zoom level. This means you can
move an object “out of the way”,
then zoom in to tweak it, before
moving it back by the same
amount, knowing it will end up in
its original position.

26. Use the “<” and “>” keys to
scale objects, or “[“ and “]” to
rotate them. Hold ALT to scale or
rotate by a smaller amount.

GUIDES

27. Create guides by dragging
from the rulers. Drag from the
ends of the rulers, for a guide
angled at 45°.

28. Move a guide by dragging it
with the mouse. Rotate it by
holding SHIFT while dragging.

29. Double-click on a guide to

bring up a dialog that lets you
make fine adjustments.

30. Delete guides using this
dialog, or by simply moving the
mouse over the guide until it
changes color, then pressing the
delete key. There's also an Edit >
Delete all Guides menu on 0.91 .

31 0 With 0.91 you can change the
color of a guide, and even give it a
label.

32 You can quickly show and hide
all guides using the “|” key.

33. You can also create guides
from objects by selecting the
object then using the Object >
Objects to Guides menu entry. This
doesn't delete the original object
and is especially useful if you need

to match an odd angle in your
design.

34. Edit > Guides Around Page
does the same for the page
outline, putting the guide origins
at the four corners. This is handy if
you want to create a background
rectangle that exactly matches the
page size: just enable snapping to
guides and off you go.

GRIDS & SNAPPING

35. You can create multiple grids
via File > Document Properties >
Grids. They can be either
rectangular or axonometric
(angled, allowing for isometric and
oblique grids) . If you need polar or
logarithmic grids, however, you'll
have to fake it using the options in
the Extensions menu.

36. You can show or hide the
currently active grid(s) by pressing
the “#” key. When the grid is
hidden it isn't used for snapping.

37. If you do want to turn off
snapping entirely, you can toggle it
with the “%” key.

38. Don't enable too many
snapping options at once: it makes
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it tricky to draw as the image
becomes more complex and full of
potential snap points.
39. Use File > Document
Properties > Snap to adjust how
fiercely snapping is applied. With
0.91 there are also a few extra
checkboxes to allow for snapping
to clipping and masking paths,
without you having to release
them first.

PATHS

40. Get familiar with paths.
They're the basic unit of
construction in Inkscape – just
about any other object can be
converted to a path via the Path >
Object to Path or Path > Stroke to
Path menu options. Remember
that this is a one-way conversion,
so keep a copy if you'll need to edit
the original.

41 . When drawing paths with the
Bézier tool, use single clicks to
roughly outline the shape you
want with individual nodes, then
adjust the curves afterwards. It's a
lot easier than trying to drag each
point to bend the path as you go
along.

42. Use Boolean operations to

construct complex shapes out of
simpler ones.

43. Can't bend a path? One or
both of the handles missing?
Holding SHIFT will let you drag the
handle out of the node. If you still
can't bend it, check that you don't
have the Spiro live path effect
present (Path > Path Effect Editor) ,
as this significantly affects the way
that paths can be manipulated.

44. You can select multiple nodes
by dragging a selection rectangle
over them, by SHIFT-clicking on
individual nodes – or a combination
of both. You can also select nodes
from more than one path at a time,
which can sometimes be
invaluable.

45. Click a path segment to select
the nodes at either end. SHIFT-click
path segments to add pairs of
nodes to your selection.

46. Select the nodes at the end of
a path segment then press the
INSERT key, or SHIFT-I , to create a
new node in the middle. The
original nodes and the new ones all
remain selected, so you can press
INSERT multiple times to quickly
create a large number of new
nodes.

47. You can rotate node
selections using the “[“ and “]”
keys. Hover over a node – even one
that's not selected – to use it as
the center of rotation. If you want
to rotate about the center of the
selected nodes, make sure your
mouse pointer is not hovering over
any other node.

48. The “<” and “>” keys also work
on node selections.

49. For a different take on
rotating and scaling node
selections, enable the “Show
transformation handles for
selected nodes” button on the tool
control bar. This will give you
handles like those of the selection
tool, but applying to the selected
nodes rather than whole objects.
Just like the selection handles,
clicking an already selected node
will toggle between the scale
mode and rotate & skew.

50. Hold CTRL-ALT when moving a
node to move it along the path
itself. Unfortunately it works with
only straight path segments, but
does work with multiple nodes
selected – they'll all move in the
same direction as the one you're
dragging. This is great for changing

the size of a path without affecting
its angles.

51 . With multiple nodes selected,
hold ALT when dragging one of
them and the others will move by a
proportional amount, based on
their proximity to the node you're
moving. This can best be seen by
putting lots of nodes on a path,
selecting all of them, then ALT-
dragging a node near the center.

CLIPPING AND MASKING

52. Use clipping to constrain
an object or group to the shape of
a clipping path, with a hard edge.
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This can be used to simulate an
object disappearing below
another.

53. When clipping, always convert
primitive clipping shapes, such as
rectangles or circles, into paths
first. That way you can use node
editing to modify the shape of the
path without having to release the

clip, making it easier to make fine
adjustments.

54. Unfortunately the SVG
standard has no option for an
“inverse” clipping path. Instead you
have to do the job by hand: create
the path you want, then use the
Boolean “Difference” operation to
remove it from a rectangle that

covers the whole object. That gives
you a rectangle with your path cut
out of it, which you can then use to
clip your original object.

55. Use masking, rather than
clipping, where you want a soft
edge or to affect the opacity of the
masked object. Unfortunately you
have to release the mask to make
adjustments.

56. Masks are based on grayscale
values from 0 (black) to 255
(white). Use gradients from white
to transparent instead, to get a
better idea of the effect you'll
have. The transparent parts of the
mask will become transparent in
the final image, the white parts will
be opaque. This makes it slightly
counter-intuitive, because the bits
you can see through the mask will
disappear, and the bits you have
covered up will be visible, but it's
still easier than working with a
black and white mask that
completely obscures the drawing
below.

57. You can use clipping and
masking on bitmap images to
create interesting shaped pictures,
or to crop them to a specific size.

58. Group each image before you

do this, then you can enter the
group and move it around after
clipping in order to adjust the
position.

WORKING WITH BITMAPS

59. Always link your images,
rather than embedding them. If
you want to embed to redistribute
the file, use Extensions > Images >
Embed Images... to convert them
before saving the file with another
name.

60. Right-click on an image and
select Image Properties from the
context menu. Edit the URL to a
relative path if you want to
redistribute your work, or even just
move it around on your hard drive.
In other words, if you want to use
“picture.png” in your drawing, put
it into the same directory as the
Inkscape file, then drag it into your
editing window. Edit the URL to
just read “picture.png” instead of
the full path, and it will continue to
work provided it's kept in the same
directory as the SVG file.

61 . Try to use high-resolution
bitmaps scaled down, rather than
small ones scaled up, if you can. It
gives Inkscape more data to work
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with if you want to export your
final design.

62. When exporting PNG files,
always use File > Export Bitmap
(File > Export PNG Image in 0.91 ) ,
not Save As... Cairo PNG. The latter
loses transparency and sometimes
introduces other issues into the
exported file.

CLONES

63. If you have lots of identical
objects in your image or design,
using clones can significantly
reduce your file size. It also means
that you can modify all of them at
once, simply by changing the
original.

64. Keep an eye out for situations
where you can break your objects
down into smaller sub-units, then
only clone certain parts. When
drawing comics, I 've found this to
be a quick way to produce
characters in similar poses where
only the head or mouth changes.

65. If you've created lots of tiled
clones, you can easily unlink them
by just deleting the original. This
requires your preferences to be
set so that deleting the original

unlinks the clones, rather than
deleting them.

66. If you're having trouble
selecting the original object, select
a clone if it and press SHIFT-D.

67. Transform your clones then
clip or mask them to provide
simple “zoom” or “pan” effects.

68. Group objects before cloning
if you want to clip the original.
Apply the clip to the group and you
can still enter the group to clone
the full-sized, unclipped version
within it. Then just cut and paste
that clone outside the group to
wherever you want it.

69. You can move clones between
layers. Cut them from one layer
and paste into another, or just
select them and use SHIFT-PAGE
UP/DOWN.

70. If you want to copy clones to
another drawing, group them
together with the original first,
otherwise you'll just end up
pasting an “orphan clone”.
Alternatively you can use Edit >
Clone > Unlink Clone to turn them
into real copies first.

TEXT

71 . When creating text, make
sure you click once on the canvas,
then type. Don't click-and-drag a
box. The latter creates “flowed
text” which has compatibility
issues if you're using your image
outside of Inkscape.

72. If you do create flowed text,
use Text > Unflow before
distributing your image.

73. Select characters, or put the
text cursor between them and use
ALT plus the usual keys to move
(arrow keys) and rotate (“[“, “] ”)
parts of the text.

74. To ensure that your image
appears exactly as you expect it to
on other people's machines,
regardless of the fonts they have,
convert text to paths using Path >
Object to Path. This will result in a
group of paths, one for each
individual glyph.

75. If you want a single
compound path, select the text
and use Path > Union (CTRL-+).

76. To put text onto a path, select
both, then use Text > Put on Path.

Use Path > Reverse to switch the
text between the “inside” and
“outside” of the path.

77. Don't use Inkscape's SVG Font
Editor. Unfortunately the SVG Font
format never became mainstream,
and even more peculiarly it's not
supported by Inkscape. Yes, the
Inkscape developers wrote an
editor for a font format that you
can't actually use in Inkscape!

FILTERS

78. Filters are part of the SVG
standard, and can be used to
introduce textures and effects that
just aren't possible with pure
vectors. Creating your own filters
is confusing but the program does
come with a good selection of
predefined filters that are worth
exploring.

79. Each filter consists of a chain
of effects, each with its own
parameters. If you add a filter to an
object, then add another, the
individual chains of both effects
will be combined to create a longer
chain. You can't easily remove one
of the filters after that's
happened, so when auditioning
filters, remember to apply one,
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then undo before applying the
next one.

80. If you do want to use multiple
filters, but still keep the chains
separate, group your objects
between each filter. In other
words, group the objects and apply
filter one, then group the result
and apply filter two to that group,

then group the result... and so on.

81 . Filters slow rendering down –
sometimes quite significantly. Use
the different options in View >
Display Modes to regain some
speed if you don't need to see the
filtered objects all the time. If you
can put the filtered objects onto
another layer, you can speed things

up by hiding that layer temporarily.

82. If you want to regain some
speed, but still see a filtered object
for reference, use Edit > Make a
Bitmap Copy to create a bitmap
“snapshot” of your object. Then
you can use the “No Filters” display
mode and use the bitmap as a
temporary reference point.

83. With 0.91 came the ability for
predefined filters to prompt for
parameters, making it possible for
the filter creator to expose the
main settings to the user. As a
result, some 0.48 filters look like
they've disappeared, but have
actually just been grouped
together into a single filter with
parameters.

84. Many filters have a Live
Preview checkbox. You should
always use this to see what the
result of the filter will look like
before you commit. The “live”
nature means that it can slow
things down, especially when you
want to tweak lots of parameters,
so in that case you can uncheck it,
change the values, then check it
again when you're done to see
what effect your changes will have.

SAVING YOUR WORK

85. Use File > Vacuum Defs (0.48)
or File > Clean Up Document (0.91 )
before saving, to remove behind-
the-scenes fragments of SVG that
are no longer used in your
document. You should definitely
do this before sending the file on
to anyone else.
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86. Are you distributing your file
to other people? Use File >
Document Metadata (0.48) or File
> Document Properties >
Metadata (0.91 ) to set metadata
such as the drawing's title or a list
of contributors' names.

87. Save as Plain SVG if you want
to put a file online without all the
Inkscape metadata. Save an
Inkscape copy as well, though, in
case you have to edit it later.

88. If file size is a concern, save as
Optimised SVG. It loses some
precision, but probably nothing
you'll notice unless you've drawn a
really tiny image. In exchange it
can reduce the file size
considerably. If you need to do this
for lots of images, use the “Scour”
utility from
http://codedread.com/scour/

89. To save storage space on your
server or desktop, use the
compressed (svgz) save options.
The files will be identical to the
originals, but gzipped. The
downside of this is that not all file
managers will show previews for
svgz files, and Firefox won't load
them directly from disk (it will load
them from a web server, though).

90. When saving to other vector
formats, such as PDF, make sure
you convert your text to outlines
first. Do this manually, rather than
just using the checkbox in the
export dialog, as the latter doesn't
always produce the right results
with some fonts.

USING SVGS ONLINE

91 . If you want to keep the file
sizes down on your web host, you
might choose to serve compressed
(svgz) files. Unfortunately the
default configuration for most web
servers doesn't deal with them
correctly. Try it out, and badger
your ISP if it doesn't work. If they
won't fix it globally then, for
Apache at least, you can get it to
work by putting these two lines
into a .htaccess file on your host:

AddType image/svg+xml svg
svgz

AddEncoding gzip svgz

92. If you've got plenty of space
on your host, however, it's
probably not worth trying to serve
svgz files. Most web servers will
gzip files on-the-fly, so this format
is good only for keeping storage
space and server load down, rather

than reducing bandwidth.

93. Are you creating SVGs for
Wikipedia or other mediawiki
based sites? Use Wikimedia's SVG
Check tool to test for common
problems first. This can also be
useful for general checking of
SVGs prior to putting them online.
https://commons.wikimedia.org/wi
ki/Commons:SVG_Check

94. If you're a web developer,
take a look at the structure of a
simple SVG file. It's an XML format,
which opens it to manipulation in
the browser using the usual
Javascript DOM calls. This lets you
insert, remove, move or modify
parts of your SVG image
dynamically. If you haven't done
much work with XML before, you
might need to read up on XML
namespaces – and use the
namespace-aware versions of the
DOM calls – in order to get things
working correctly.

95. SVG supports a standard
called SMIL for animation.
Unfortunately this is being phased
out in some browsers, and was
never supported in Internet
Explorer. There's work on a more
general web animation framework
to replace it, but it's not ready yet.

If you need to animate an SVG file
right now, Javascript is the best
cross-platform way to do it.

FURTHER INFORMATION

96. Obviously one of the best
ways to learn about Inkscape is to
read all the tutorials in Full Circle
Magazine. Another option is the
official Inkscape manual, written
by Tavmjong Bah, Inkscape
developer and member of the W3C
SVG working group. Unfortunately
it hasn't been updated for 0.91 yet,
but almost all the content is still
relevant. You can read it online at
http://tavmjong.free.fr/INKSCAPE/
but it's also available in dead-tree
format if you prefer.

97. There are some great
community resources for Inkscape,
but I 'm going to call out three in
particular:
• http://www.inkscapeforum.com

– a friendly and helpful forum, with
some extremely experienced
Inkscape users.
• http://inkscapecommunity.com

– frequented by many of the same
people as above, but better
organised if you're looking for
tutorials, guides or reference
material.

https://commons.wikimedia.org/wiki/Commons:SVG_Check
http://codedread.com/scour/
http://www.inkscapeforum.com
http://inkscapecommunity.com
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• http://www.inkscapeforum.it – an
Italian forum, but with a small
international section. There are
other localised Inkscape
communities around the globe
though, so if English isn't your first
language, do search to see if

there's already something in your
native tongue. If not, why not start
a site yourself?

98. A bit of a blatant plug, but at
my own site, www.peppertop.com,
you can find over 200 comic strips,

all of them at least partly created
with Inkscape. You can even
download the source to most of
them, so you can see how some of
these tips and tricks have been
used in practice. Every Greys strip
has at least one Easter Egg hidden

in it somewhere, usually to be
found by opening the Inkscape file
and investigating. How many can
you find?

99. Do you know your way round
C++ or Python? Why not consider
becoming an Inkscape developer in
your spare time. See
https://inkscape.org/en/develop/
for more details.

1 00. Not a developer, but still
want to help? There are other ways
to contribute, see
https://inkscape.org/en/contribute
for details. Don't forget that you
can also make a financial donation.

http://www.peppertop.com/shop/
http://www.inkscapeforum.it
http://www.peppertop.com
https://inkscape.org/en/develop/
https://inkscape.org/en/contribute
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A fter last month's special

celebratory detour, we return

to finish the subject of aligning and

positioning objects in Inkscape.

We've already seen a variety of

approaches, from grids and

snapping through to tiled clones

and the Align and Distribute

dialog, but we still have two

dialogs to consider. They both live

near the bottom of the Object

menu: “Transform...”, and

“Arrange...” (“Rows and Columns...”

if you're still using 0.48.x) .

The Transform dialog provides a

more precise approach to moving,

scaling, rotating and skewing

objects when compared with

simply dragging the selection

handles using the mouse. In the

world of SVG, every object can

have a transformation applied to

it. Rotate or skew an object, then

look at it in the XML editor and

you'll see that there's no obvious

“rotate” or “skew” attribute, but

rather a single “transform”

attribute which holds a matrix that

defines the cumulative effects of

any transformations you may have

applied. The details of this matrix

are a little too mathematically

intense for this series, but it's

enough to know that each object

can have its own matrix applied,

and that a single matrix can

combine the effects of moving,

scaling, rotating and skewing into a

single set of numbers. The

Transform dialog is essentially a

more user-friendly way of

tweaking that matrix.

On opening the dialog from the

menu, or using the CTRL-SHIFT-M

shortcut, you'll be presented with

a simple interface featuring a

handful of tabs, each with just a

few fields. This dialog has seen

little change between 0.48 and

0.91 .

The fields on the Move tab

allow you to move your selected

objects by a specific distance,

when the “Relative move”

checkbox is enabled. Disable this,

and you can move your objects to

absolute x and y coordinates. In

addition, the current absolute

coordinates are displayed in the

fields. With 0.91 , just about every

spinbox in Inkscape lets you enter

simple calculations, so there's a

good argument for never enabling

this checkbox in that version. Want

to move your shape 50 pixels to

the right? Just append “+50” to the

number in the “Horizontal” box,

then hit Return and watch the field

update with the newly calculated

value.

Positions and movements are

based on Inkscape's own

coordinate system which has the

positive y axis running upwards

from the bottom of the page

(remember, this is the opposite of

SVG's coordinate system, which

has the origin at the top left, with

the positive y-axis running

downwards). Similarly, the

selected objects are placed such

that the bottom left corner of the

bounding box is at the specified

coordinates, with no option to use

a different corner, or even the

center of the box as the reference

point.

The “Apply to each object

separately” checkbox is effectively

the opposite of the “Treat

selection as group” checkbox in
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the Align and Distribute dialog. If

you select multiple objects and

leave this un-checked, then the

transformation will be applied as

though all the objects were

grouped. With it checked, each

object is individually transformed.

When relatively moving things,

there's little difference, but, for an

absolute move, it results in all the

items being placed at the same

position on the page. It's also

particularly relevant when using

the other tabs, where the results

can differ significantly due to the

state of this checkbox. Consider

the Rotate tab: there's a huge

difference between rotating a

group of separate objects and

rotating each object individually.

The Scale, Rotate and Skew

tabs in this dialog really need no

additional explanation as the fields

are all straightforward to

understand. It's important to note,

however, that only the current

tab's values are used when the

Apply button is clicked. You can't

queue up a collection of

movement, rotation and skewing

to apply as a single operation, but

instead have to press the button

with the Move tab to the fore, then

again with the Rotate tab selected,

and so on.

On the subject of the Rotate

tab, there has been a slight change

with version 0.91 : this release adds

buttons to determine whether

rotations should be clockwise or

anti-clockwise. The corresponding

field accepts both positive and

negative values in either release of

Inkscape, so the buttons just make

the existing functionality more

obvious, rather than adding

anything new.

The last tab, Matrix, allows you

to directly manipulate the six

values in the SVG matrix

transformation. With the “Edit

current matrix” checkbox enabled,

you can modify the transform

that's currently being applied to

the selected element, if there is

one. With this unchecked, any

changes you make in this tab will

be mathematically combined with

the existing matrix to produce a

new, cumulative matrix. If you are

mathematically inclined, and wish

to play around with this tab, I

recommend reading the SVG

specification for coordinate

systems and transformations:

http://www.w3.org/TR/SVG/coords

.html

It's worth noting that SVG's

transform attribute does allow for

a series of individual translate() ,

scale() , rotate() , skewX() and

skewY() functions to be used,

rather than just the matrix()

operation that combines them all.

From an authoring perspective, it

would be far nicer to store a 45°

rotation in the SVG file as

rotate(45), rather than

matrix(0.707,0.707,-

0.707,0.707,0,0) , but there's no

option in Inkscape to do that,

unfortunately.

The last feature we'll consider

in this part of the series is the

dialog that can be found via Object

> Rows and Columns... (0.48) or

Object > Arrange... (0.91 ) . The

latter lays the interface out a little

more neatly and adds a second tab,

so I 'll describe that version. 0.48

users should be able to work out

the differences in the first tab, but

you'll just have to look on in envy

when I describe the Polar

Coordinates options in the second.

Let's start by creating a few

objects to arrange. I 've

deliberately used different sizes,

and semi-randomly placed them.

I 've numbered them from left to

right, top to bottom, to make it

easier to see which object moves

where – once they're arranged

using the dialog.

http://www.w3.org/TR/SVG/coords.html
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On selecting these nine objects

and opening the dialog, it's

possible to set various

combinations of rows and columns,

ranging from 1 x9 to 9x1 . These

fields are dynamic: as items are

added to, or removed from the

selection, the rows and columns

will change; similarly as each field

is manually altered so the other

will change to ensure that you

don't end up with an impossible

combination for the number of

elements that are selected. In this

example, I 've set the arrangement

to 3 rows by 3 columns.

You can think of this dialog as

creating a number of conceptual

cells which are arranged in rows

and columns, then your objects

placed within them. They're

“conceptual” in that they're never

really created, or drawn, on the

canvas, but serve as a tool to more

easily describe how Inkscape

arrives at its final layout. The

height of each cell is determined

by the height of the tallest object

in the row, and the state of the

Equal Height checkbox. If left

unchecked, then the height of each

row is free to change to suit the

tallest object within it; if checked,

all the rows will be the same

height, equal to the tallest object

in any of the rows. An analogous

calculation is carried out to

determine the width of each cell,

too.

With the dimensions of each

cell calculated, they are now

distributed into their final

positions. If the “Fit into selection

box” radio button is active, they

are evenly distributed to fit within

the dimensions of the original

selection's bounding box. This

gives you the ability to distribute

the objects within a specific area

by carefully positioning two

opposing corner objects.

Alternatively you can select the

“Set spacing” option, and enter

values for the X and Y fields. In this

mode the cells will be arranged

with the specified amount of space

between the columns (X value) and

rows (Y value). These numbers can

be negative if you want to make

the cells overlap. Note that 0.48

allows these numbers to be

specified only in pixels whereas

0.91 , as you can see from the

screenshot, has a pop-up menu

from which to choose different

units.

With these imaginary cells

conceptually placed on the canvas,

it's finally time to move your

objects into them. The “Alignment”

buttons let you define how to

place each object within its cell,

allowing for any of nine relative

positions (though you'll probably

just use the center button most of

the time). Note that 0.48 had the

same nine possibilities available,

but laid out as a pair of three-

option radio buttons which

specified the horizontal and

vertical alignments separately.

Having distributed our virtual

cells, and aligned the objects

within them, the result is

something like this:

It's important to understand

how Inkscape chooses the order

for the arrangement. Whereas

other parts of the application use

an object's z-index or selection

order, this dialog is only concerned
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with the placement of the objects

on the canvas. They're ordered

from left to right, top to bottom,

and laid out in the same way. You

can see this effect quite clearly if I

move the blue “8” object up a

little, leaving its z-index the same,

then reapply the arrangement:

Because the objects are laid out

from left to right, top to bottom,

some arrangements can lead to an

empty space in the bottom right

corner. Here are the same nine

objects in a 2x5 arrangement:

Note that there's no way to get

the blank space to be anywhere

other than the bottom right cell. If

you want a different alignment

you'll have to manually alter the

results afterwards. It's also not

possible to have more than one

blank cell – the dynamic nature of

the Rows and Columns fields will

stymie any attempts. Trying to put

these nine objects into a 2x6

arrangement, expecting six objects

on the top row, and three on the

bottom, just leads to the same

result as before and the fields

adjusting themselves to 2x5.

The second tab of this dialog

allows you to place objects in a

polar arrangement. You can either

draw a circle, ellipse or arc as a

guide on which to place your

objects, or you can enter the

parameters for such a shape within

the dialog itself.

The easiest way to do this is to

draw a target shape (circle, ellipse

or arc) that you wish to place your

objects on. Send it to the bottom

of the z-order, then select all the

objects you wish to arrange plus

the target itself. Ensuring that

“First selected...” is active, click the

Arrange button. With our previous

selection of nine rounded

rectangles, and a grey ellipse as

the target, the result is something

like this:

As you can see, the objects have

been arranged anti-clockwise,

starting from the top right. To

make them run clockwise from the

top left, flip the ellipse

horizontally first. For clockwise

from the bottom right, flip it

vertically. For anti-clockwise from

the bottom left, flip it both

horizontally and vertically before

creating the arrangement.

If the target object is your only

circle, ellipse or arc in the

selection, it doesn't really matter

whether you use the “First

selected...” or “Last selected...”

option. If you do have more than

one, however, you should ensure

that you select the target first,
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then add everything else to the

selection (“First Selected...”) or

select everything else, then add

the target to the selection (“Last

selected...”) .

If you don't wish to create an

additional object on the canvas to

use as a target, the

“Parameterized” option reveals

additional fields (shown in the

screenshot) to let you specify the

details of the target arc to use.

Realistically, it's almost always

easier to draw an arc on the canvas

to use as the target. You'll get

visible feedback as to where your

objects will be placed, and you can

simply delete the arc once your

arrangement is done, if you don't

want it left in the drawing.

The specific position of each

object on the target shape is set

using the “Anchor point” section in

the top half of the dialog. You can

specify one of nine positions on

the object's bounding box – so

choosing the top-left button, for

example, would position the

objects such that the top-left

corner of each individual bounding

box is placed on the target. The

center button is the most common

choice here, and is the one I used

for the previous image. An

interesting alternative is to use the

“Object's rotational center” option.

This will position each object so

that its rotational center is placed

on the target, allowing you a finer

degree of control over the

placement of each individual

object.

The “Rotate objects” checkbox

determines whether your objects

will be rotated when they are

arranged, or left with their original

orientation. The previous image

was made with this checked; had it

been left un-checked, all of the

positioned objects would have

retained their original orientation,

such that the numbers would all

have been the right way up.

There's a small bug that you

may have to work around: whilst

writing this article, I found that the

Polar mode would occasionally

place all my objects on top of each

other, rather than spacing them

out around the target shape. I was

able to reliably fix this by undoing

the placement, then shifting the

target object up (SHIFT-Up arrow),

then back down to its previous

position (SHIFT-Down arrow),

before repeating my arrangement

attempt.

That concludes our look at the

myriad ways in which you can

arrange and position objects within

Inkscape. Amongst them there

should be something to suit most

artistic requirements. From

snapping to grids, tiled clones to

polar arrangements, Inkscape has

far more ways to position your

shapes than initially meets the eye.

http://www.peppertop.com
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T his month we're going to start

looking at Live Path Effects

(LPEs). These are a way to add

more powerful capabilities to

paths – such as drawing a pattern

that follows a path (for creating

ropes and chains) , or rendering a

path as though it's been roughly

sketched. There are 1 3 LPEs in

version 0.48, increasing to 1 5 in

0.91 with a slight change of UI as

well.

Let's dive straight in with a

relatively simple LPE: Spiro Spline.

Draw a path using Bézier tool,

consisting of straight lines forming

a simple spiral type of shape.

Something like this:

Now select the path and open

the LPE dialog using the Path >

Path Effects... menu option (Path

Effect Editor... in 0.48). At this

point, the user interface diverges.

To add the Spiro Spline LPE to your

path:

• In 0.48.x, select “Spiro spline”

from the drop-down list of effects

at the top of the dialog, then click

on the Add button next to it.

• In 0.91 , click the “+” button at the

bottom left of the dialog. This will

open another dialog listing the

available effects. Scroll down and

select “Spiro spline,” then click the

Add button. The second dialog will

close, adding the effect to the list

in the main dialog.

With the Spiro Spline effect

added to your path, you might be a

little underwhelmed to see that

there's been no change to the

appearance of your spiral. This is

because the spiro algorithm works

only on paths where some of the

nodes are smooth or symmetrical.

Currently, all the nodes in our

shape are corner/cusp nodes.

Double-click on the path to both

select it and switch to the node

tool, and you should see that all

the nodes have the diamond-

shaped handles that represent

cusp nodes. Press CTRL-A to select

them all, and use the buttons on

the tool control bar to change

them to smooth, symmetrical or

auto-smooth. Immediately you

should see the effects of the spiro

algorithm, as your square spiral

turns into a super-smooth version.

You may be forgiven for

thinking that your new spiral is just

a normal result of switching to

smooth nodes, but that's not the

case. In the LPE dialog, you'll

notice that the Spiro Spline entry

has an “eye” icon next to it. Click

that to toggle the effect on and

off, and you'll notice that the spiro

version of the path is noticeably

smoother than the normal version.

Here's the original (black), smooth

(green), and spiro (purple) versions

of the path – overlaid on top of

each other so you can more easily

see the differences between them.

The real difference comes when

you start to manipulate the path:

spiro splines are indifferent to

changes in the node handles, so

the most practical way to modify

the path is to move the nodes

themselves. The algorithm is a

little unstable, and can sometimes

shoot off into wild shapes as you

do so; undoing your edit, or

moving the nodes a little more, will

generally get things back on track.

For example, this image shows a

green original path, plus the same

path with the spiro LPE added in

purple, demonstrating just how

out-of-control the spiro algorithm

can get!
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As well as moving nodes,

there's one other way to

manipulate spiro paths: straighten

some sections. Simply select the

end nodes of a segment and use

the “Make selected segments

lines” button on the tool control

bar to straighten it. The spiro

algorithm will ensure a smooth

transition between straight and

curved segments. If you need to

introduce a sharp transition into

your path, you first have to convert

one of your smooth nodes into a

corner node. That alone isn't

usually enough to do the job

though – moving the adjacent

node to one side will usually also

alter the path on the opposite side

in an effort to maintain the spiro

path's smoothness. The secret is to

move the handles of the corner

node so that they're no longer co-

linear, then you'll be able to move

the spiro paths on either side as

you would expect, with a sharp

transition occurring at the corner

node.

The spiro algorithm was

originally created by Raph Levien

for font design (see

http://www.levien.com/spiro/ for

more details) , but it can also be

useful for flowing, organic shapes

such as plants, leaves, and...

tentacles. It's so useful, in fact,

that Inkscape has dedicated

buttons on the Bézier and Pencil

toolbars which automatically add

the Spiro Spline LPE to any lines

you draw with them. Select the

Pencil tool and ensure that the

smoothing is set to about 50% - a

little either way won't make much

difference. On the tool control bar

(shown above), enable Spiro mode

using the second button on the

bar:

Now it's time to draw

something on the canvas: the kind

of shape that suits spiro mode. Try

drawing a circle, keeping it as neat

as you can, and finishing in the

starting node. As you draw you'll

see a green line indicating your

path, regardless of your current fill

and stroke settings – don't worry,

that's just a guideline that won't be

visible when you've finished.

Unless you have supernatural

control over your muscles, the

green path is likely to be bumpy

and distorted; yet, on releasing the

mouse button, it will be replaced

with a nicely rounded circle. If your

original path was extremely rough,

you might not get a perfect circle,

but the final shape will certainly be

a lot smoother than your hand-

drawn efforts.

Select the path you've drawn,

and, in the Path Effects dialog, you

should see that the Spiro Spline

effect has been added. Toggle the

visibility button (the eye-shaped

icon) to see how the spiro version

compares with your original path.

Now try the process again with a

different shape – a figure of eight,

or a spiral. As you can see, for

some shapes it's a lot easier to

create something neat and smooth

using spiro mode.

When using the Bézier tool in

spiro mode, the icon on the tool

control bar is the same, but the

drawing process is a little

different. I usually suggest drawing

Bézier paths as a series of straight

line segments by single-clicking to

place each node, then going back

in Node Edit mode to add curves

afterwards. If you take that

approach with spiro mode enabled,

you'll get a series of corner nodes

which, as we've seen, don't really

play a role in the spiro algorithm.

Instead you need to click-and-drag

as you place each node, in order to

set the curves as you go along.

Personally, I find this to be much

harder to control, but give it a try

to see if you're better at it than

me! You can always lay down

straight segments with spiro mode

enabled, then explicitly change

some points into cusp nodes

afterwards. It's not a huge

workflow improvement, but does

save you a trip to the Path Effects

dialog to manually add the LPE.

One big problem with having

spiro buttons on these two tools it

that it's easy for newcomers to

Inkscape to enable them, then

forget about it. A common

question on the support forums is,

“why can't I change the shape of

my path using the node handles?”

The answer is usually because the

Spiro LPE has unintentionally been

added, so watch out for that if you

find yourself similarly stuck.

Let's move on to another LPE:

Gears.

You first have to draw a path

with at least three nodes – to

begin, I ' ll use exactly three so that

http://www.levien.com/spiro/
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it's clear what the relevance of

each one is. With your path drawn

and selected, open the Path

Effects dialog and add the Gears

LPE. You should immediately see

your path replaced by a gear.

Double-click on it so that you can

see the three nodes and move

them around. It should quickly

become apparent that the nodes

are used to set:

1 ) The angle of the first gear tooth,

relative to the center point.

2) The center point of the gear.

3) The radius of the gear (from

the center to the mid-point of the

tooth).

With your gear selected, switch

to the Bézier tool. The start and

end nodes of your path should be

visible: click on the end node, then

double-click somewhere else on

the canvas to add another

segment to your path. Now the

path has four nodes, and you

should find that a second gear has

been added, centered at the new

end node.

You can repeat this process to

add more nodes, and hence more

gears. Applying the Gear LPE to

any path with more than three

nodes follows the same rules: the

first three nodes define the

parameters for the first gear, and

any subsequent nodes set the

center points for additional gears

in the chain. Once you've got a few

gears on screen, switch to the node

tool to move their centers, noting

how Inkscape automatically adjusts

the radius and number of teeth in

the process. Try dragging the first

node around the second one to

crank your gear train into life (after

all, it is a LIVE path effect) .

As well as the values that are

implicitly set by the positions of

the nodes, there are two additional

parameters required to fully

specify the effect. These can be

found at the bottom of the Path

Effects dialog, in fields labelled

“Teeth” (the number of teeth on

the first gear) , and “Phi” (the

“tooth pressure angle” - set it to

about 20 for realistic looking

teeth). Almost all LPEs populate

this part of the dialog with a UI of

some sort, and in some cases the

number of additional parameters is

rather excessive (watch out if

you're working on a small screen!) .

You may have guessed from the

UI that it's possible to apply more

than one LPE to a path. In

programming terms you can think

of an LPE as a function that takes a

path as an input, and produces

another path as an output,

allowing you to chain them

together. Be aware, however, that

the order in which you chain them

is significant. Consider this simple

path, made up of cusp nodes:

If we apply either the Spiro

Spline or Gears LPE to the path we

get the results we'd expect:

But if we apply both LPEs to the

path, the effects differ greatly

depending on the order. We'll start

with the least surprising

combination: Gears first and Spiro

Spline second.

It may not be easy to see, but

the only real effect is that the

teeth of the gears have become

more rounded (though each gear

also has one tooth that's

misshapen). Thinking about our

chain of LPEs the general effect

makes some sense: the first LPE

outputs a composite path in the

shape of the gears, then the spiro

algorithm is applied to that path,

smoothing out any cusp nodes that

are present in it. But what happens

if we apply the Spiro Spline LPE

first, and the Gears LPE second?
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Now we've got a load more

gears! This is because the path that

is created by the Spiro Spline LPE

has more nodes than our original

input path. Although we drew 6

nodes, the spiro version of the

path actually has 1 3, so when the

second LPE runs it creates a lot of

extra gears. We could have

predicted this result had we only

kept an eye on Inkscape's status

bar: when an LPE is active it shows

the number of nodes in the output

path, not the number in the

original path. Try using the Gears

LPE again, and have a look at how

many nodes that generates!

Why not practice drawing

naturalistic curves and mechanistic

gears, then next time we'll

continue to look at some of the

other LPEs that are available.

PYTHON SPECIAL EDITIONS:

http://fullcirclemagazine.org/issue-py01 / http://fullcirclemagazine.org/issue-py02/

http://fullcirclemagazine.org/python-
special-edition-issue-three/

http://fullcirclemagazine.org/python-
special-edition-volume-four/

http://fullcirclemagazine.org/python-
special-edition-volume-five/

http://fullcirclemagazine.org/python-
special-edition-volume-six/

http://www.peppertop.com
http://fullcirclemagazine.org/issue-py01/
http://fullcirclemagazine.org/issue-py02/
http://fullcirclemagazine.org/python-special-edition-issue-three/
http://fullcirclemagazine.org/python-special-edition-volume-four/
http://fullcirclemagazine.org/python-special-edition-volume-five/
http://fullcirclemagazine.org/python-special-edition-volume-six/


29 contents ^

HHOOWW TTOO CCOONNTTRRIIBBUUTTEE

Ful l Circle Team

Edit or - Ronnie Tucker

ronnie@fullcirclemagazine.org

Webmaster - Lucas Westermann

admin@fullcirclemagazine.org

Edit ing & Proof reading

Mike Kennedy, Gord Campbell, Robert

Orsino, Josh Hertel, Bert Jerred, Jim

Dyer and Emily Gonyer

Our thanks go to Canonical, the many

t ranslat ion teams around the world

and Thorst en Wilms for the FCM logo.

FULL CIRCLENEEDSYOU!
A magazine isn't a magazine without art icles and Full Circle is no

except ion. We need your opinions, desktops, stories, how-to's,

reviews, and anything else you want to tell your fellow *buntu users.

Send your art icles to: art icles@fullcirclemagazine.org

We are always looking for new art icles to include in Full Circle. For help and advice

please see the Of f icial Ful l Circle St yle Guide: ht tp:/ /url.fullcirclemagazine.org/75d471

Send your comment s or Linux experiences to: let ters@fullcirclemagazine.org

Hardware/sof tware reviews should be sent to: reviews@fullcirclemagazine.org

Quest ions for Q&A should go to: quest ions@fullcirclemagazine.org

Deskt op screens should be emailed to: misc@fullcirclemagazine.org

... or you can visit our sit e via: fullcirclemagazine.org

FCM#116
Deadl ine:

Sunday 11th Dec 2016.

Release:

Friday 30th Dec 2016.

EPUB Format - Most edit ions have a link to the epub f ile

on that issues download page. If you have any problems

with the epub f ile, email: mobile@fullcirclemagazine.org

Issuu - You can read Full Circle online via Issuu:

ht tp:/ / issuu.com/fullcirclemagazine. Please share and rate

FCM as it helps to spread the word about FCM and Ubuntu.

Magzst er - You can also read Full Circle online via

Magzster: ht tp:/ /www.magzter.com/publishers/Full-Circle.

Please share and rate FCM as it helps to spread the word

about FCM and Ubuntu Linux.

Get t ing Ful l Circle Magazine:

For t he Ful l Circle Weekly News:

You can keep up to date with the Weekly News using the RSS

feed: ht tp:/ / fullcirclemagazine.org/ feed/podcast

Or, if your out and about , you can get the Weekly News via

St itcher Radio (Android/ iOS/web):

ht tp:/ /www.st itcher.com/s?f id=85347&ref id=stpr

and via TuneIn at : ht tp:/ / tunein.com/radio/Full-Circle-Weekly-

News-p855064/

Special Editions - Jonathan Hoskin


