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Preface
Drawing vector graphics in LibreOffice



Who is this user guide for?

This user guide is for users who want to acquire knowledge on LibreOffice Draw and is new to 
drawing or graphics software, but may be familiar with another office software suite, will find this 
user guide very useful.

LibreOffice is an open-source office productivity software suite containing capabilities for word 
processing, spreadsheets, presentations, graphics, databases, and formula editing. Draw is the 
vector graphics drawing module and a wide variety of graphical images can be easily and 
quickly created. Drawings created in Draw can be exported in several file formats, for example, 
PDF, HTML, and numerous graphic formats.

What is in this user guide?

This user guide introduces the main features of Draw module. It is a vector graphics drawing 
tool, but can also be used to edit raster graphics (pixels), for example photographs. A few 
examples of drawing functions are as follows:

Layer management, snap functions and grid-point system
Dimensions and measurement display
Connectors for making organization charts

Draw also includes 3D functions for creation of 3D drawings (with texture and lighting effects), 
drawing and page-style integration, and creation of Bézier curves.

What is LibreOffice?

LibreOffice is a freely available, fully-featured, open source office productivity suite that is 
compatible with other major office suites and is available on a variety of platforms. The native file 
format used is Open Document Format (ODF). However, LibreOffice can also open and save 
documents in many other formats, including those used by versions of Microsoft Office. For more 
information, see the Getting Started Guide.

Minimum requirements for using LibreOffice

LibreOffice 24.8 requires one of the following operating systems:

Linux x64 (deb) and Linux x64 (rpm)
Mac OS X (Aarch64/Apple Silicon)
macOS x86_64 (10.14 Mojave or higher)
Windows x86_64 (Windows 7 or newer required)

For a detailed list of requirements and operating systems supported, see the LibreOffice website, 
https://www.libreoffice.org/get-help/system-requirements/.

How to get LibreOffice

Computers and laptops
Versions of LibreOffice for Windows, Linux, and macOS are freely available and can be 
downloaded from the LibreOffice website at https://www.libreoffice.org/download.

For Linux users LibreOffice is included free with many of the latest distributions, for example 
Ubuntu. Linux versions of LibreOffice may differ in a few features from the descriptions used in 
this user guide.
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LibreOffice is also available for Windows in the Microsoft Store and for macOS in the Apple App 
Store at a low and attractive price. These versions are free software (as in open source), but the 
small charge covers the cost of placing LibreOffice in the app stores. The profits from this sale of 
LibreOffice are invested to support the development of the LibreOffice project.

Tablets, iPads and Chromebooks
To use LibreOffice on tablets, iPads, or Chromebooks, a LibreOffice based app has to be 
downloaded and installed. The app is called Collabora Office, which uses the same technology 
as LibreOffice and is very similar in operation to LibreOffice. For more information, go to the 
Collabora Office website at https://www.collaboraoffice.com.

Installing LibreOffice

Information on installing LibreOffice on the various supported operating systems can be found at 
this web page: https://www.libreoffice.org/get-help/install-howto/. If LibreOffice is acquired 
through official app stores, follow the installation instructions provided by the store.

Setting up and customizing LibreOffice

After installation, change the default settings (options) in LibreOffice to suit working requirements 
and preferences. Go to Tools > Options on the Menu bar (mac OS LibreOffice > Preferences) 
and change the settings as required.

Settings are described in LibreOffice Help and the Getting Started Guide. These two sources 
provide information on how to customize menus, toolbars, and keyboard shortcuts in Draw, add 
new menus and toolbars, and assign macros to events.

Tip

Some settings are intended for power users and programmers. If it is difficult to 
understand what an option does, LibreOffice recommended leaving an option on its 
default setting unless instructions in this user guide recommend changing the 
setting.

Extensions and add-ons

Functionality can be added to LibreOffice with extensions and add-ons. Several extensions are 
installed with the program and other extensions from the official extensions repository, 
https://extensions.libreoffice.org/ or various other sources. See the Getting Started Guide for 
more information on installing extensions and add-ons.

Where to get more help

This user guide, the Help system, and user support systems assume that users are familiar with 
computers and basic functions such as starting a program, opening and saving files.

Help system
LibreOffice comes with an extensive Help system and is used as the first line of support. 
Windows and Linux users can choose to download and install the offline Help for use when not 
connected to the Internet. Offline Help is installed with the MacOS version of LibreOffice.

Preface | 9

https://extensions.libreoffice.org/
https://www.libreoffice.org/get-help/install-howto/
https://www.collaboraoffice.com/


To display the LibreOffice Help, press F1 or go to Help > LibreOffice Help on the Menu bar. If 
the offline help is not installed on a computer, but connected to the Internet, a dialog opens 
giving the option to Read Help Online. Select this option and the default web browser opens at 
the LibreOffice online help pages in the LibreOffice website.

The Help menu includes links to other LibreOffice information and support facilities. The Help 
menu also includes links to other LibreOffice information and support resources.

What's This?

For quick tips when a toolbar is visible, place the cursor over a tool icon to see a small 
tooltip box with a brief explanation of the tool function. For a more detailed explanation, 
select Help > What's This? Also Extended Tips can be activated by going to Tools > 
Options > LibreOffice > General > Help (macOS LibreOffice > Preferences > 
LibreOffice > General > Help) on the Menu bar and selecting the option Extended Tips. 
Extended tips provide a brief description about tools and commands. To display an 
extended tip, use the keyboard Shift+F1, then move the cursor onto a tool or 
command.

User Guides

Opens the default browser at the Documentation page of the LibreOffice website 
https://documentation.libreoffice.org/en/english-documentation/. This web page gives 
access to the LibreOffice User Guides and other useful information that can be opened in 
the default browser. Also, the LibreOffice User Guides are available in PDF format as a 
free download, or to buy as printed copies.

Show Tip of the Day

Opens a small window with a random tip on how to use LibreOffice.

Search Commands

Opens a window where typing a few letters, or the name of a Menu bar command, for 
example, quickly finds where the command is located. Clicking on a command in the 
resulting list may open a relevant dialog or have other effects.

Get Help Online

Opens the default browser at the Ask LibreOffice forum of questions and answers from 
the LibreOffice community, https://ask.libreoffice.org/en/questions/.

Send Feedback

Opens the default browser at the Feedback page of the LibreOffice website 
https://www.libreoffice.org/get-help/feedback/. From this web page, bugs can be 
reported, new features suggested and communicated with other users in the LibreOffice 
community.

Restart in Safe Mode

Opens a dialog window giving options to restart LibreOffice and reset the software to its 
default settings. Restarting in safe mode also provides an opportunity to restore 
LibreOffice from a backup.

Get Involved

Opens the default browser at the Get Involved page of the LibreOffice website, 
https://www.libreoffice.org/community/get-involved/. Choose a topic of interest to help 
improve the program.

Donate to LibreOffice

Opens the default browser at the Donation page of the LibreOffice website, 
https://donate.libreoffice.org/ providing an opportunity to make a donation to support 
LibreOffice.
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License Information

Outlines the licenses under which LibreOffice is made available.

Check for Updates

Opens a dialog and checks the LibreOffice website for updates to version of the 
software. The dialog provides an opportunity to download and install any updates to 
LibreOffice.

About LibreOffice

Opens a dialog and displays information about the version of LibreOffice and the 
operating system being used. This information is often requested if the community is 
asked for help or assistance with the software (in macOS, this option is found under 
LibreOffice on the Menu bar}.

Other free online support
The LibreOffice community not only develops software, but provides free, volunteer-based 
support. See Table 1 and the web page https://www.libreoffice.org/get-help/.  For comprehensive 
online support from the community, look at mailing lists and the Ask LibreOffice website, 
https://ask.libreoffice.org/en/questions/. Other user websites also offer free tips and tutorials.

Table 1: Free support for LibreOffice users

Free LibreOffice support

FAQs
Answers to frequently asked questions 
https://wiki.documentfoundation.org/Faq.

Mailing lists
Free community support is provided by a network of experienced 
users https://www.libreoffice.org/get-help/mailing-lists/.

Questions & Answers 
and Knowledge Base

Free community assistance is provided in a Question & Answer 
formatted web service. Search similar topics or open a new one in 
https://ask.libreoffice.org/en/questions.

The service is available in several other languages; just replace /en/ 
with de, es, fr, ja, ko, nl, pt, tr, and many others in the web address 
above.

Native language 
support

The LibreOffice website in various languages 
https://www.libreoffice.org/community/nlc/.

Mailing lists for native languages 
https://wiki.documentfoundation.org/Local_Mailing_Lists.

Information about social networking 
https://wiki.documentfoundation.org/Website/Web_Sites_services.

Accessibility options
Information about available accessibility options. 
https://www.libreoffice.org/get-help/accessibility/.

OpenOffice Forum
Another forum that provides support for LibreOffice, among other 
open source office suites https://forum.openoffice.org/en/forum/.

Paid support and training
Support and training is available through service contracts from a vendor or consulting firm 
specializing in LibreOffice. For information about certified professional support, see The 
Document Foundation website: https://www.documentfoundation.org/gethelp/support/.

For schools, educational and research institutions, and large organizations, see 
https://www.libreoffice.org/download/libreoffice-in-business/.
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Figure 1: Options LibreOffice dialog — General page

What you see may be different

Illustrations
LibreOffice runs on Windows, Linux, and macOS operating systems. Each operating system has 
several versions and can be customized by users (fonts, colors, themes, window managers). 
The illustrations in this user guide were taken from a variety of computers and operating 
systems. Therefore, some illustrations will not look exactly the same as displayed on a computer 
monitor.

Also, some of the dialogs may differ because of the settings selected in LibreOffice. Either use 
dialogs from the computer system (default) or dialogs provided by LibreOffice. To change to 
using LibreOffice dialogs:

1) Go to Tools > Options > LibreOffice > General (macOS LibreOffice > Preferences > 
LibreOffice > General) on the Menu bar to open the dialog page for general options 
(Figure 1).

2) Select the option Use LibreOffice dialogs in Open/Save dialogs to display the 
LibreOffice dialogs on a computer display.

3) Click OK to save the settings and close the dialog.

Icons
The LibreOffice community has created icons for several icon sets, for example Breeze, Colibre, 
and Sifr. LibreOffice users can select a preferred set of fonts to use. The icons used to illustrate 
tools available in LibreOffice may differ from the ones used in this user guide. Icons in this user 
guide have been taken from a LibreOffice installation set to display the Colibre set of icons.
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Figure 2: Options LibreOffice dialog — View page

Change the icon set used in a LibreOffice installation as follows:

1) On Linux and Windows operating systems, go to Tools > Options > LibreOffice > View 
(macOS LibreOffice > Preferences > LibreOffice > View) on the Menu bar to open the 
dialog page for view options (Figure 2).

2) In Icon Theme, select a font from the options available in the drop-down list.

3) In Icon Size, select the required size from the drop-down lists for Toolbar, Notebookbar 
and Sidebar.

4) Click OK to save the settings and close the dialog.

Notes

Some Linux operating systems, for example Ubuntu, include LibreOffice as part of 
the installation and may not include the required icon set. Icon sets can be 
downloaded from the software repository for the Linux operating system being used.

Some of the previously included icon sets are now available only as extensions. Go 
to https://extensions.libreoffice.org/?Tags%5B%5D=49 or search for specific ones. 
For example, the People Gallery is available from 
https://extensions.libreoffice.org/en/extensions/show/people-gallery.

Using LibreOffice on macOS

Some keystrokes and menu items are different on computers operating macOS from computers 
using Windows and Linux operating systems. Table 2 gives some common substitutions used in 
this user guide. For more information on keyboard shortcuts, see LibreOffice Help and 
Appendix A, Keyboard Shortcuts in this user guide.
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Table 2: Example of macOS keyboard shortcuts

Windows or Linux macOS equivalent Effect

Tools > Options LibreOffice > Preferences Access to setup options

Right-click
Ctrl+click and/or right-click 
depending on computer setup

Opens a context menu

Ctrl or Control
 and/or ⌘ Cmd or Command, 

depending on keyboard
Used with other keys

Alt  and/or ⌥ Alt or Option 
depending on keyboard

Used with other keys

F11 +⌘ T Open the Styles deck in the 
Sidebar

Who wrote this user guide?

This user guide was written by volunteers from the LibreOffice community. Profits from sales of 
the printed edition are used to benefit the community.

Frequently asked questions

How is LibreOffice licensed?

LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public 
License (MPL), see https://www.libreoffice.org/about-us/licenses/. It is based on code 
from Apache OpenOffice made available under the Apache License 2.0 but also includes 
software that differs from version to version under a variety of other Open Source 
licenses. New code is available under LGPL 3.0 and MPL 2.0.

Can LibreOffice be distributed to anyone?

Yes.

Can LibreOffice be sold?

Yes.

Can LibreOffice be used in a business?

Yes.

How many computers can LibreOffice be installed on?

As many as required.

Is LibreOffice available in different languages?

LibreOffice has been translated (localized for more than 80%, both UI and Help) into over 
46 languages, so a required language is probably supported. Localization is well under 
way for another 30+ languages (50-80%) and for another 50+ languages help is more 
than welcome. In addition, over 70 spelling, hyphenation, and thesaurus dictionaries are 
available for languages and dialects that do not have a localized program interface. The 
dictionaries are available from the LibreOffice website at: https://www.libreoffice.org/.

How can LibreOffice be freely available?

LibreOffice is developed and maintained by volunteers and has the backing of several 
organizations. LibreOffice also relies upon donations from its users. To make a donation, 
go to the following web page: https://www.libreoffice.org/donate/.
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Can the programming code from LibreOffice be used when developing a software 
application?

Yes, but follow the parameters set in the MPL and/or LGPL. Read the licenses: 
https://www.mozilla.org/MPL/2.0/.

Why is Java required to run LibreOffice and is it written in Java?

LibreOffice is not written in Java, but written in the C++ language. Java is one of several 
languages that can be used to extend the software. The Java JDK/JRE is only required 
for some features. The most notable one is the HSQLDB relational database engine.

Java is available at no cost. More information and download links to the appropriate 
edition for an operating system can be found at: 
https://java.com/en/download/manual.jsp.

Note

If LibreOffice features requiring Java are to be used, it is important that the correct 
32-bit or 64-bit edition matches the installed version of LibreOffice. If Java is not to 
be used, nearly all of the LibreOffice features can still be used.

How can users contribute to LibreOffice?

Users can help with the development and user support of LibreOffice in many ways, and 
there is no need to be a programmer. To start, check out this webpage: 
https://www.libreoffice.org/community/get-involved/. An interactive web page that guides 
users in contributing with their best skills available at https://whatcanidoforlibreoffice.org.

Can the PDF copy of this user guide be distributed, or printed and copies sold?

Yes, as long as requirements are met for one of the licenses in the copyright statement at 
the beginning of this user guide. There is no need to request special permission. 
LibreOffice requests that users share with the LibreOffice project some of the profits 
made from sales of user guides, in consideration of all the work that LibreOffice 
volunteers have put into producing user guides.

What is new in LibreOffice 24.8?

The LibreOffice 24.8 Release Notes are available at this link 
https://wiki.documentfoundation.org/ReleaseNotes/24.8. Also available at this link are the 
release notes for earlier versions of LibreOffice giving more information on the features included 
in LibreOffice. 
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Introducing Draw



Introduction

Draw is the vector graphics drawing module for LibreOffice for creating and updating a wide 
format of graphic images, including raster graphics (pixels). Vector graphics store and display 
images as assemblies of simple geometric elements such as lines, circles, and polygons, rather 
than a collection of pixels (points on the screen), allowing for easier storage and image scaling.

Draw is fully integrated into the LibreOffice suite simplifying the exachange of graphics between 
all LibreOffice modules. If an image is created in Draw, reusing it in a Writer document is 
relatively easy. For example, select and copy a drawing in Draw, then paste the copied image 
directly into a Writer document. Also, drawings can be worked on directly from within Writer or 
Impress, using a subset functions and tools from Draw.

The functionality of Draw is extensive, but is not designed to rival high-end graphics applications. 
However, Draw has more functionality than drawing tools that are available in the majority of 
other office productivity suites. A few examples of drawing functions are as follows:

Layer management
Magnetic grid-point system
Dimensions and measurement display
Connectors for making organization charts and other diagrams
3D functions for creating small three-dimensional drawings
Drawing and page-style integration
Bézier curves

This Draw user guide is not a course book to be worked through from beginning to end, but a 
reference work used as guidance when greating vector graphics. This user guide describes only 
the functions associated with Draw. Some concepts, such as file management, or the way the 
LibreOffice environment works, are mentioned briefly, but are covered in more detail in the 
Getting Started Guide.

Notes

When LibreOffice is installed on a computer, a menu entry for each module is added 
to the system menu. The exact name and location of these menu entries depends on 
the operating system and user interface being used.

The New icon displayed on the Standard toolbar depends on which LibreOffice 
module is opened when creating a new document, presentation, spreadsheet, or 
drawing.

Main window

Pages pane
In Draw, drawings can be split over several pages using multi-page drawings. These multi-page 
drawings are normally used in presentations. The Pages pane, on the left side of the main 
window, provides an overview pages created in a drawing. If the Pages pane is not visible, 
select View > Page Pane on the Menu bar. To make changes to the page order, drag and drop 
one or more pages displayed in the Pages pane.

Workspace
The large area in the center of the main window (Figure 3) is the Workspace where drawings are 
created. This drawing area can be surrounded with toolbars and information areas. The quantity 
and position of tools varies with the task being carried out, user preferences, and computer 
setup.
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Figure 3: Draw main window

(1) Pages pane
(2) Workspace

(3) Sidebar
(4) Status Bar

(5) Layers Bar

The maximum size of a Draw drawing page is limited by computer setup and the page size that 
that can be set and used in a printer connected to the computer.

Sidebar
The Sidebar for Draw has five main decks and is similar to the Sidebar in other LibreOffice 
modules. To open a deck, click on its icon on the right of the Sidebar, or click on Sidebar 
Settings at the top of the Sidebar and select a deck from the drop-down list. If the Sidebar is not 
visible, select View > Sidebar on the Menu bar, or use the keyboard shortcut Ctrl+F5 
(macOS ⌘+F5).

Properties

Provides panels where properties of a selected object in a drawing are edited and 
updated. Available panels depend on the selected object, but are as follows:

Page Character Paragraph Image
Area Line Effect Shadow
Position and Size Columns. 

Styles

Provides options to edit and apply available Drawing Styles to objects in a drawing. 
When a style is edited or modified, changes are automatically applied to all elements 
formatted using that style. In Draw, Presentation Styles are not available. New drawing 
styles can be added to a drawing.

Gallery

Objects available on the Gallery deck are inserted into a drawing either as a copy or as a 
link. New themes are added to the Gallery. See Chapter 11, Advanced Draw Techniques 
for more information on using the Gallery. The Gallery is divided into the following 
themes:

Arrows BPMN Bullets
Diagrams Flow chart Icons
Network Shapes Sounds. 
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Navigator

On the Navigator deck, pages and objects in a drawing are quickly selected. It is 
recommended to use meaningful names for drawing pages and objects providing easy 
identification and location when using the Navigator.

Shapes

Provides quick selection of some items available on the Drawing toolbar. These Shapes 
are available in the following subtoolbars:

Lines and Arrows Curves and Polygons Connectors
Basic Shapes Symbol Shapes Block Arrows
Flowchart Callouts Stars and Banners
3D Objects.

Status bar
The Status Bar (Figure 4) is located at the bottom of the Workspace in all LibreOffice modules. 
To hide the Status Bar, if required, select View on the Menu bar and deselect Status Bar from 
the submenu.

Note

The measurement units displayed on the Status Bar are set by going to Tools > 
Options > LibreOffice Draw > General (macOS LibreOffice > Preferences > 
LibreOffice > General) on the Menu bar. These measurement units can be different 
to the measurement units set for the rulers displayed in the LibreOffice Draw main 
window.

Slide (drawing) number

Shows the drawing pane number that is selected.

Information area

Shows which action is being carried out, or object type selected.

Master drawing

Indicates the master drawing in use.

Cursor position/Selected object size

Shows different information depending on whether objects are selected or not.

– When no object is selected, the position numbers show the current position (X and Y 
coordinates) of the cursor.

– When an object is selected and being resized, the object size numbers show the 
object size (width and height).

– If an object is selected, the position numbers shows the X and Y coordinates of the 
upper-left corner and the object size number pair displays the object size. These 
numbers do not relate to the object itself, but to the selection outline, which is the 
smallest possible rectangle that can contain the visible object part or parts. See 
Chapter 3, Working with Objects and Object Points for more information.

– When an object is selected, clicking in either of these areas opens the Position and 
Size dialog. See Chapter 4, Changing Object Attributes for more information.

Document scaling factor

Indicates how the drawing appears on the display. The default scaling factor is 1:1. To 
change the scaling factor, right-click on the scaling factor and select a scaling factor from 
the context menu that opens.
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Figure 4: Draw Status Bar

(1) Slide (drawing) number
(2) Information area
(3) Master drawing
(4) Cursor position

(5) Selected object size
(6) Document scaling factor
(7) Unsaved changes
(8) Digital signature

(9) Fit drawing
(10) Zoom slider
(11) Zoom percentage

Unsaved changes

Indicates that the file needs saving. The icon displayed depends on the computer 
operating system and setup. Clicking on this icon opens the Save as dialog if the file is 
new and has not been saved before. If the file has been saved already, then clicking on 
this icon automatically saves the file after any changes have been made.

Digital signature

Indicates if the document is digitally signed. The icon only appears if the drawing has a 
digital signature certificate. After the file has been saved, double clicking on this icon 
opens the digital signatures dialog. See LibreOffice Help for more information on digital 
signature certificates.

Fit drawing

Resizes the drawing so that the whole drawing appears in the Workspace.

Zoom slider/Zoom percentage

Adjusts and indicates the Workspace zoom percentage displayed. Double clicking on 
zoom percentage opens the Zoom & View Layout dialog.

Layers bar
A layer is a workplace where drawing elements and objects can be inserted. By default, the 
Workspace consists of three layers, which are Layout, Controls and Dimension Lines. Tabs 
for the default layers appear at the bottom of the Workspace. Default layers cannot be deleted or 
renamed, but layers can be added as and when necessary.

Tabs for layers appear in the Layers bar at the bottom of the Workspace. Use the Layers bar to 
navigate between layers, add layers as required, or delete layers that have been created. For 
more information on layers, see Chapter 11, Advanced Draw Techniques.

Rulers
Rulers are positioned on the Workspace upper and left-hand sides. If the rulers are not visible, 
select View > Rulers in the Menu bar, or use the keyboard shortcut Ctrl+Shift+R 
(macOS ⌘+Shift+R). The rulers show the size of a selected object on the page using double 
lines (highlighted in Figure 5). Rulers are also used when using object handles and guide lines 
for  positioning of objects.

Page margins in the drawing area are represented on the rulers. Change the margins directly on 
the rulers by dragging with the cursor. Margin areas are normally indicated by a grayed out area 
on the rulers, but this indication does depend on computer and operating system setup.

To change the ruler measurement units, right-click on a ruler and select the measurement unit 
from the drop down list, as shown in Figure 6 for the horizontal ruler. Measurement units for the 
horizontal and vertical rulers can be different measurement units.
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Figure 5: Example of Rulers showing object size

Figure 6: Example of Ruler measurement units

Figure 7: Example of visible toolbar icons on a toolbar
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Toolbars
To display or hide the Draw toolbars, select View > Toolbars on the Menu bar and select the 
required toolbar from the submenu. For example, Standard and Drawing toolbars are shown by 
default, but Line and Filling, and Text Formatting toolbars are not shown.

Appearance of tool icons on toolbars depends on the computer operating system and the 
selection of icon style and size in Tools > Options > LibreOffice > View (macOS LibreOffice > 
Preferences > LibreOffice > View).

The tools available on a toolbar are indicated, either, by highlighting around the tool icon, or a 
check mark as shown by the example in Figure 7. For more information about working with 
toolbars, see Appendix B, Toolbars and the Getting Started Guide. The four main toolbars used 
in Draw are as follows:

Standard toolbar

The Standard toolbar (Figure 8) is similar for all LibreOffice components and is not 
described in detail in this chapter. By default, it is positioned at the top of the Draw main 
window.

Figure 8: Standard toolbar

Figure 9: Drawing toolbar

Figure 10: Line and Filling toolbar
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Figure 11: Text Formatting toolbar

Drawing toolbar

The Drawing toolbar (Figure 9) contains all the necessary functions for drawing various 
geometric and freehand shapes, and for organizing them in the drawing. By default, it is 
positioned on the left of the Draw main window. This toolbar is described in detail in 
Chapter 2, Drawing Basic Shapes.

Line and Filling toolbar

The Line and Filling toolbar (Figure 10) is used to modify the main properties of a 
drawing object. The tools and pull-down lists vary according to the type of object 
selected. For example, to change the style of a line, click on the up and down arrows for 
Line Style and select the required style.

The functions on the Line and Filling toolbar are used to change the color, style, and 
width of the line drawn, the fill color and style, and other properties of a selected object. If 
the selected object is a text frame, the Line and Filling toolbar is replaced by the Text 
Formatting toolbar. For more information, see Chapter, 4 Changing Object Attributes.

Text Formatting toolbar

The Text Formatting toolbar (Figure 11) is similar to the Formatting toolbar in Writer. It is 
only available when text, or a text object, has been selected in a drawing, replacing the 
Line and Filling toolbar. For more information, see Chapter, 4 Changing Object Attributes, 
and Chapter 9 Adding and Formatting Text.

Notes

For more information on the available tools that can be added to a toolbar, see 
Appendix B, Toolbars and the Getting Started Guide. When a tool is added to a 
toolbar, its position on the toolbar (from left to right) is the same as its listed position 
in the Visible Buttons context menu.

When a sub-toolbar is made into a floating toolbar, the tool on the existing toolbar 
remains in the toolbar and always shows the last tool used. This means that the tool 
icon on a screen may differ from the tool icon shown in this guide.

Make sure that all toolbars are docked into the required position in the LibreOffice 
window before using Lock Toolbars or Lock Toolbar Position. There is no 
selection indication on Lock Toolbars when used to lock and unlock the toolbars. 
The locking indication is only indicated by the dotted toolbar handles.

Adding and removing tools

The default set of tools on each toolbar can be added or removed using Visible Buttons as 
follows:

1) Either, right-click in an empty area on the toolbar, or click on the triangle ▼ in the toolbar 
title and select Visible Buttons from the context menu to a submenu of available tools.

2) Click on a tool name in the submenu to add or remove the tool.
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Figure 12: Example of available toolsets

Available toolsets

Some tools on a toolbar have a triangle ▼ on the right side of the tool icon indicating that the 
tool has additional tools available in a subtoolbar. Clicking on this triangle ▼ opens a palette, or 
subtoolbar, of available tools (Figure 12). This palette, or subtoolbar, can be turned into a floating 
toolbar as follows:

1) Click on the dotted line at the top of the toolset.

2) Drag the toolset across the screen to a convenient location, then release the cursor to 
create a floating toolbar.

3) To close a floating toolbar, click on the X on the right of the toolbar title.

Tip

If a tool is going to repeatedly used, double-click on the selected tool. The tool 
becomes active and remains active, allowing for repeated use. To exit from this 
repeat use mode, press the Esc key, or select another tool. Please note that this may 
not work for every tool on every toolbar.

Figure 13: Example of toolbar handles
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Unlocking and locking individual toolbars

By default, when Draw is opened, any docked toolbars are locked into position and have to be 
unlocked before becoming floating toolbars, or repositioned on the main window. The locking 
status of toolbars is indicated by dotted handles at the left end of horizontal toolbars (highlighted 
in Figure 13). For vertically positioned toolbars, these dotted handles are positioned at the 
toolbar top.

1) To unlock a toolbar, right-click in a blank area on the toolbar and select Lock Toolbar 
Position from the context menu. A toolbar handle appears at the end of the toolbar, 
indicating that the toolbar is unlocked and can be moved.

2) To lock a toolbar into position, dock the toolbar into position, then right-click in a blank 
area on the toolbar and select Lock Toolbar Position from the context menu. The 
toolbar handle disappears from the end of the toolbar.

Note

Before unlocking or locking individual toolbars, make sure that ALL toolbars are 
unlocked.

Unlocking and locking all toolbars

All toolbars available in LibreOffice can also be locked into position. This overrides the unlocking 
and locking of individual toolbars.

Unlocking toolbars
1) Make sure all open LibreOffice documents have been saved before unlocking or locking 

all toolbars.

2) To unlock all toolbars, go to View > Toolbars on the Menu bar and select Lock Toolbars 
from the context menu.

3) Select Restart Now from the warning message that opens and all toolbars can now be 
individually unlocked. Toolbar handles appear on individual toolbars that are NOT 
individually locked.

Locking all toolbars
1) To lock all toolbars, go to View > Toolbars on the Menu bar and select Lock Toolbars 

from the context menu.

2) Select Restart Now from the warning message that opens and all toolbars are now 
locked into position. Toolbar handles are no longer displayed on all toolbars.

Undocking toolbars

When Draw is opened, by default, the Standard and Drawing toolbars are already docked into 
their positions at the top of the main window. These toolbars and any other open toolbar can be 
undocked to create floating toolbars as follows:

1) Make sure the toolbar handle is displayed indicating that the toolbar is unlocked. If there 
is no toolbar handle displayed, see “Unlocking and locking individual toolbars” and 
"Unlocking and locking all toolbars" above for more information.

2) Move the cursor over the toolbar handle. The cursor changes shape, normally to a 
grabbing hand, depending on computer setup and operating system.

3) Click on the toolbar handle and drag the toolbar until it is undocked and becomes a 
floating toolbar. This floating toolbar capability is common to all LibreOffice modules.
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Docking toolbars

To dock a floating toolbar, use one of the following methods:

• Press and hold the Ctrl key (macOS ), then double click on the toolbar title. The ⌘
toolbar moves into available space at the top of the Draw main window.

• Click in the toolbar title and drag the toolbar to the docked position required. This can be 
the top, bottom or one of the sides of the Draw main window.

Customizing toolbars

Draw toolbars can be customized by adding or removing commands to or from a toolbar. Also, 
customization allows creation of toolbars for specific purposes. Customizing toolbars is 
additional to using “Adding and removing tools” on page 24. For more information on adding 
customizing toolbars, see Appendix B, Toolbars and the Getting Started Guide.

Choosing and defining colors

Color palette
The Color Palette (Figure 14) is a standard set of colors to use for objects and text in a drawing.

1) Go to View on the Menu bar and select Color Bar to open the Color Palette. The Color 
Palette appears in the main window, next to the Sidebar.

2) Select an object or text.

3) Left click on the color required for the area fill, or text, and change the color of the object 
or text.

4) Right click on the color required for the object, or text box border, and change the border 
color.

5) Go to View on the Menu bar and deselect Color Bar to close the Color Palette.

Figure 14: Color Bar (Color Palette)

Note

Selecting the X at the bottom left of the Color Palette corresponds to no color for an 
object, text, or border.
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Specialized color palettes
In addition to the Color Palette, Draw has several specialized color palettes providing a greater 
selection of color for objects and text; for example chart-palettes, rectangles, arrows, and so on. 
After selecting an object, or text, in a drawing, use one of the following to access the specialized 
color palettes.

• Area or fill color — Color page in the Area dialog, Fill Color on the Drawing or Line and 
Filling toolbar, or Fill in the Area panel in the Properties deck on the Sidebar.

• Line color — Line page in the Line dialog, Line Color on the Drawing or Line and Filling 
toolbar, or Color in the Line panel in the Properties deck on the Sidebar.

• Text color — Font Color tool on the Text Formatting toolbar, or Font Color in the 
Character panel in the Properties deck on the Sidebar.

For more information on selecting a color and a color palette for an object, or text, see 
Chapter 4, Changing Object Attributes, Chapter 9, Adding and Formatting Text, and Chapter 11, 
Advanced Draw Techniques.

Custom colors
In Draw, custom colors can be created using the Color Picker dialog, CMYK values, or RGB 
values to match color schemes used; for example a company color scheme. For more detailed 
information on creating custom colors, color palettes, CMYK settings, RGB settings, and HSB 
settings, refer to Chapter 11, Advanced Draw Techniques.

Grid, snap guides, and helplines

The grid, snap guides, and helplines in Draw act as drawing aids when moving and positioning 
objects in a drawing. These drawing aids can be turned on or off using one of the following 
options:

• Line and Filling toolbar — click on Display Grid, or Helplines While Moving to turn the 
grid or helplines on or off.

• Options toolbar — click on Display Grid, Display Snap Guides, or Helplines While 
Moving to turn the grid, snap guides, or helplines on or off.

• Go to View > Grid and Helplines on the Menu bar and select, or deselect Display Grid, 
or Helplines While Moving on the submenu.

• Go to View > Snap Guides on the Menu bar and select, or deselect Display Snap 
Guides on the submenu.

The grid and snap guides are displayed only on the screen and are not shown on a printed 
drawing, or when the drawing is used in another LibreOffice module. The color, spacing and 
resolution of the grid points can be individually chosen for each axis. Draw also has several snap 
functions to position objects precisely in a drawing.

Helplines show the object position while moving and makes positioning an object much easier. If 
this function is activated, pairs of vertical and horizontal lines enclosing the object are shown 
while moving the object. These helplines extend to the drawing area edges.

For more information on the grid, snap guides, snap functions, and helplines, see Chapter 3, 
Working with Objects and Object Points.
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Introduction

Draw is used for creating 2D and 3D objects and this chapter explains how to create 2D objects. 
For more information on 3D objects, see Chapter 7, Working with 3D Objects. All rectangles, 
lines, and shapes are called objects, which is a common notation in vector drawing software.

Frequently used drawing tools are found on the Drawing toolbar (Figure 15) which is normally 
docked on the left side of the main window. If the toolbar is not visible, go to View > Toolbars on 
the Menu bar and select Drawing from the available options. The Drawing toolbar can be 
unlocked and used as a floating toolbar. Toolbars can also be configured by adding, moving, 
hiding, or deleting tools. See Chapter 1, Introducing Draw for more information.

Drawing basic shapes

Basic shapes, including text, are treated as objects in Draw. The default set of tools available for 
drawing basic shapes on the Drawing toolbar are shown in Figure 15. To add more tools to the 
Drawing toolbar, see Appendix B, Toolbars and the Getting Started Guide for more information.

Some tool icons on the Drawing toolbar change shape according to the last tool used from the 
selection of available tools. Each tool that has a triangle ▼ next to the tool icon indicates that 
more tools are available. See “Drawing geometric shapes” on page 42 for information on the 
available shapes.

When a shape is created, an object selected for editing, or text added to the drawing, the 
information field in the Status Bar (Figure 16) changes to reflect the action taken or in progress. 
See Chapter 1, Introducing Draw for more information on the Status Bar.

Figure 15: Drawing toolbar

Figure 16: Draw Status Bar

(1) Slide (drawing) number
(2) Information area
(3) Master drawing
(4) Cursor position

(5) Selected object size
(6) Document scaling factor
(7) Unsaved changes
(8) Digital signature

(9) Fit drawing
(10) Zoom slider
(11) Zoom percentage

Note

When a basic shape is drawn, or selected for editing, the information area at the left 
side in the Status Bar changes to reflect the present action. For example Line 
created, Text frame xxyy selected, and so on.
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Figure 17: Shapes deck on Sidebar

Creating lines
A straight line is the simplest element or object to create using Draw.

1) Use one of the following options to draw a straight line:

– Click Insert Line on the Drawing toolbar (Figure 15).

– Click on the triangle ▼ next to Lines and Arrows on the Drawing toolbar (Figure 15) 
and select Insert Line from the options available.

– Click Insert Line in the Line and Arrows panel of the Shapes deck on the Sidebar 
(Figure 17).

2) Place the cursor at the starting point on the drawing, then click and drag the cursor to 
draw a straight line.

3) Release the cursor when the required line length is reached and a straight line is 
created. A selection handle appears at each line end. The selection handle at the starting 
point of a line is slightly larger than the selection handle at the end point (highlighted in 
Figure 18).

4) To snap ends of a straight line to the nearest grid point, hold down the Ctrl (macOS  ) ⌘
key while drawing a straight line. This is default behavior of the Ctrl (macOS  ) key.⌘

5) To restrict the drawing angle of a straight line to multiples of 45 degrees (0, 45, 90, 135, 
and so on), hold down the Shift key while drawing a straight line. This is the default 
behavior of the Shift key.

6) To draw a straight line symmetrically outwards in both directions from the start point, hold 
down the Alt (macOS ) key to draw a straight line from the line center.⌥
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Figure 18: Example of line starting point (highlighted)

Notes

If the option View > Snap Guides > Snap to Grid on the Menu bar has been 
selected, holding down the Ctrl (macOS ) key while drawing a straight line ⌘
temporarily deactivates the Snap to Grid option.

If the option When creating or moving objects in the Constrain Objects section of 
Tools > Options > LibreOffice Draw > Grid (macOS LibreOffice > Preferences > 
LibreOffice Draw > Grid) has been selected, holding down the Shift key 
temporarily deactivates this restriction.

Draw classifies both lines and arrows as lines and are created in the same way as 
straight lines. Hovering the cursor over each tool in the Lines and Arrows subtoolbar 
(Figure 22 on page 34), or the Line and Arrows panel in the Shapes deck on the 
Sidebar, indicates what type of line or arrow each tool draws. The information field on 
the Status Bar shows them only as lines.

Formatting lines
When a line is drawn, it uses default attributes for line style, line color, line width and 
transparency. To change any of these attributes to the drawing requirements is as follows:

1) Select the straight line by clicking on it to display the selection handles.

2) To format line style, line color, line width, or transparency select an available option using 
one of the following methods:

– Click on a line selection handle and drag it to increase or decrease the line length.

– Go to Format > Line on the Menu bar to open the Line dialog (Figure 19).

– Use Line Style, Line Width, and Line Color on the Line and Filling toolbar 
(Figure 20).

– Right-click on the line and select Line from the submenu to open the Line dialog.

– Open the Line panel in the Properties deck on the Sidebar (Figure 21).
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Figure 19: Line dialog — Line page

Figure 20: Line and Filling toolbar

Creating arrows
1) Use one of the following methods to create an arrow:

a) Select the type of line or arrow required in the Lines and Arrows panel of the Shapes 
deck on the Sidebar (Figure 17 on page 31).

b) Click on the triangle ▼ next to Lines and Arrows on the Drawing toolbar and select the 
type of line and arrow required from the options in the Lines and Arrows subtoolbar 
(Figure 22).
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c) Place the cursor at the starting point for the line or arrow, then click and drag the cursor. 
The arrowheads are drawn at the line ends when the line is completed.

d) For more information on creating lines and arrows, see “Creating lines” on page 31.

Figure 21: Line panel in Properties deck on Sidebar with Arrowhead styles

Figure 22: Lines and Arrows subtoolbar
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Figure 23: Line dialog — Arrow Styles page

Formatting arrows
1) To format the line used for an arrow, see “Formatting lines” on page 32 for more 

information.

2) To format an arrow using the same arrowhead style for both arrow ends:

a) Select the arrow so that the selection handles are displayed.

b) Go to Format > Line on the Menu bar or right-click on the arrow to open the Line 
dialog (Figure 19 on page 33).

c) Click on Arrow Styles to open the Arrow Styles page in the Line dialog (Figure 23) 
and select an arrow style from the options available in the Arrow style drop-down list.

d) Click OK to apply the arrow style and close the Line dialog.

e) Click in an empty space on the drawing to deselect the arrow.

3) To format an arrow using different arrowhead styles for each arrow end:

a) Select the arrow so that the selection handles are displayed.

b) Open the Line panel on the Properties deck of the Sidebar (Figure 21 on page 34).

c) In the Line panel, click on Arrow Style to open the drop-down list for arrowhead styles.

d) On the Line and Filling toolbar (Figure 20 on page 33), select an arrowhead style from 
the left-hand list of arrowhead styles for the arrow start point.
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e) On the Line and Filling toolbar (Figure 20 on page 33), select an arrowhead style from 
the right-hand list of arrowhead styles for the arrow end point.

f) Click in an empty space on the drawing to deselect the arrow.

Note

The option for selecting different arrowhead styles at each end of an arrow is not 
available in the macOS version of the Line panel on the Properties deck in the 
Sidebar.

Rectangles or squares
1) Use one of the following methods to start drawing a rectangle or square:

– Click on Rectangle on the Drawing toolbar.

– Select the type of rectangle or square in the Basic Shapes panel in the Shapes deck 
on the Sidebar (Figure 17 on page 31).

– Click on the triangle ▼ next to Basic Shapes on the Drawing toolbar (Figure 15 on 
page 30) and select the type of rectangle or square required from the available 
options.

– Select the type of rectangle or square on the Legacy Rectangles toolbar (Figure 24). 
To display the Legacy Rectangles toolbar, go to View > Toolbars on the Menu bar and 
select it.

2) Place the cursor at the starting point for the rectangle or square, then click and drag the 
cursor until the required size is drawn. The rectangle or square is drawn from the starting 
point using the bottom right corner as the anchor point for the cursor.

3) If necessary, use one of the following options to draw a rectangle or square:

– If a rectangle option is selected, hold down the Shift key while dragging the cursor to 
draw a square.

– If a rectangle option is selected, hold down the Alt key while dragging the cursor to 
draw a rectangle from its center.

– If a rectangle option is selected, hold down the Shift and Alt keys while dragging the 
cursor to draw a square from its center.

– If a square option is selected, hold down the Shift key while dragging the cursor to 
draw a rectangle.

– If a square option is selected, hold down the Alt key while dragging the cursor to draw 
a square from its center.

Figure 24: Legacy Rectangles toolbar

Figure 25: Legacy Circles and Ovals toolbar

36 |Draw Guide 24.8



Note

If the option When creating or moving objects is selected in the Constrain Object 
section of Tools > Options > LibreOffice Draw > Grid (macOS LibreOffice> 
Preferences > LibreOffice Draw > Grid), Shift key action is reversed. A square is 
drawn instead of a rectangle. Holding down the Shift key a rectangle is drawn. 
Shift key action reversal also applies to ellipses, circles, arcs, and segments.

Ellipses or circles
1) Use one of the following methods to start drawing an ellipse or circle:

– Click on Ellipse on the Drawing toolbar.

– Select the type of ellipse or circle in the Basic Shapes panel in Shapes deck on the 
Sidebar (Figure 17 on page 31).

– Click on the triangle ▼ next to Basic Shapes on the Drawing toolbar (Figure 15 on 
page 30) and select the type of ellipse or circle required from the drop-down list.

– Select the type of ellipse or circle on the Legacy Circles and Ovals toolbar (Figure 25). 
To display the Legacy Circles and Ovals toolbar, go to View > Toolbars on the Menu 
bar and select it.

2) Place the cursor at the starting point for the ellipse or circle, then click and drag the 
cursor until the required size is drawn. The ellipse or circle is drawn from the starting 
point using the bottom right corner as the anchor point for the cursor.

3) If necessary, use one of the following options while drawing an ellipse or circle:

– If an ellipse option is selected, hold down the Shift key while dragging the cursor to 
draw a circle.

– If an ellipse option is selected, hold down the Alt key while dragging the cursor to 
draw an ellipse from its center.

– If an ellipse option is selected, hold down the Shift and Alt keys while dragging the 
cursor to draw a circle from its center.

– If a circle option is selected, hold down the Shift key while dragging the cursor to 
draw an ellipse.

– If a circle option is selected, hold down the Alt key while dragging the cursor to draw 
a circle from its center.

Tip

To quickly insert an object, press and hold down the Ctrl (macOS ) key, then click⌘  
on an object tool on the Drawing toolbar (Figure 15 on page 30). A standard sized 
object of the selected object is drawn automatically in the center of the Workspace. 
The size, shape, and color used are default settings. These settings can be changed 
to match the drawing requirements. See Chapter 4, Changing Object Attributes for 
more information.

Dimension lines
Dimension lines display a measurement of an object in the drawing, as shown by the example in 
Figure 26. A dimension line does not belong to the object itself, but is positioned close to it. An 
object can have as many dimension lines as necessary to indicate the dimensions of all aspects 
of an object.
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Figure 26: Example of object dimension lines

Figure 27: Dimension Line dialog

To format the display of a dimension line and its components, right-click on the dimension line 
and select Dimensions from the context menu to open the Dimension line dialog (Figure 27).

Note

The measurement units used for dimension lines can be changed. Go to Tools > 
Options > LibreOffice Draw > Grid > General (macOS LibreOffice > Preferences 
> LibreOffice Draw > Grid > General) on the Menu bar and select a measurement 
unit from the available options in the Units of measurement drop-down list.
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Tip

To help in accurately positioning dimension lines on an object, it is recommended to 
use the the horizontal and vertical guide lines. It is also recommended to use the 
Snap to grid option to accurately position objects and dimension lines.

1) Use one of the following options to start drawing a dimension line:

– Click on the triangle ▼ next to Lines and Arrows on the Drawing toolbar and select 
Dimension Line from the drop-down list.

– Click on Dimension Line in the Lines and Arrows panel of the Shapes deck on the 
Sidebar.

2) Place the cursor at the point close to the object to position the dimension line start.

3) Click and drag to draw the dimension line. As the dimension line is drawn, the dimension 
is displayed and automatically calculated.

4) Select the dimension line, then right-click on the dimension line and select Dimensions 
from the context menu to open the Dimension Line dialog.

5) Format the dimension line using the options available in the Dimension Line dialog. For 
more information dimension line options, see Chapter 11, Advanced Draw Techniques.

6) Click OK to save the changes and close the Dimension Line dialog.

7) Click in an empty space on the drawing to deselect the dimension line.

Arcs and segments
1) Use one of the following methods to start drawing an arc or segment (partial circles or 

ellipses):

– Select the type of arc or segment in Curves and Polygon panel in the Shapes deck 
on the Sidebar (Figure 17 on page 31).

– Click on the triangle ▼ next to Basic Shapes on the Drawing toolbar (Figure 15 on 
page 30) and select the type of arc or segment required from the drop-down list.

– Select the type of arc or segment from the Legacy Circles and Ovals toolbar 
(Figure 25 on page 36). To display the Legacy Circles and Ovals toolbar, go to View > 
Toolbars on the Menu bar and select it.

2) Click on and drag the cursor to start creating an arc or segment. Release when the 
required object size is reached.

3) Move the cursor to the position where the arc or segment starts and click to start drawing 
the arc or segment. The Status Bar indicates the angle in degrees.

4) Move the cursor to the end position of where the arc or segment finishes. The Status 
Bar shows the angle in degrees.

5) Click again to complete the arc or segment.

Curves
1) Select the type of curve required using one of the following methods:

– Click on the triangle ▼ next to Curves and Polygons on the Drawing toolbar 
(Figure 15 on page 30) and select the type of curve from the drop-down list.

– Select the type of curve in the Curve and Polygons panel in the Shapes deck on the 
Sidebar (Figure 17 on page 31).
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2) Click, hold and drag the cursor from the starting point to draw a line.

3) Release and continue to drag the cursor to bend the line into the required curve shape.

4) Click to set the curve and position end point of the curve on the drawing.

5) Continue dragging the cursor to draw straight lines at the curve end. Each click sets a 
corner point and allows drawing of another straight line from each corner point.

6) Double-click to end the drawing of a curve and straight lines.

Note

A filled curve and filled polygon automatically joins the last point to the first point 
closing the object. The selected fill type then fill the object. A curve or polygon 
without filling is not closed at the end of the drawing.

Polygons
1) Select the type of polygon required using one of the following methods:

– Click on the triangle ▼ next to Curves and Polygons on the Drawing toolbar 
(Figure 15 on page 30) and select the type of curve from the drop-down list.

– Select the type of curve in the Curve and Polygons panel in the Shapes deck on the 
Sidebar (Figure 17 on page 31).

2) Click, hold and drag the cursor to draw a line between the first and second corner points.

3) Click again to end the drawing between the first and second corner points of the polygon.

4) Move the cursor to draw the next line and click to finish drawing to the next corner point. 
Each click sets a corner point and draws another line.

5) Double-click to end the drawing of a polygon.

Polygons 45°
Like ordinary polygons, these are formed from lines, but the angles between lines are restricted 
to 45 or 90 degrees. If required, hold down the Shift key as the line is drawn so that the line is 
drawn at an angle other than 45 or 90 degrees.

Freeform lines
Using freeform line tools is similar to drawing with a pencil on paper.

1) Click, hold and drag the cursor to the line shape required, then release to complete the 
freeform line drawing.

2) If Freeform Line Filled is selected, the end point is joined automatically to the start point 
and the object is filled with the selected fill.

Note

The points in curves, polygons and freeform lines can be moved and edited. See 
Chapter 3, Working with Objects and Chapter 11, Advanced Draw Techniques for 
more information.
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Figure 28: Example of object gluepoints

Figure 29: Gluepoints toolbar

Gluepoints and connectors

Gluepoints
All Draw objects have gluepoints, which are not normally displayed, and only become visible 
when Connectors is selected on the Drawing toolbar, or a connector tool is selected in the 
Connectors panel on the Shapes deck in the Sidebar.

Most objects have four gluepoints, as shown in the example in Figure 28. More gluepoints can 
be added and customized using the Gluepoints toolbar (Figure 29). Go to View > Toolbars > 
Gluepoints on the Menu bar to open the toolbar.

Gluepoints are not the same as the selection handles of an object. Selection handles are for 
moving or changing the shape of an object. Gluepoints are used to fix or glue a connector to an 
object so that when the object moves, the connector stays fixed to the object. For a more 
detailed description on the use of gluepoints, see Chapter 3, Working with Objects, or Chapter 8, 
Connections, Flowcharts, and Organization Charts.

Connectors
Connectors are lines or arrows whose ends automatically snap to a gluepoint of an object. 
Connectors are not the same as lines and arrows. When objects are moved or reordered, the 
connectors remain attached to a gluepoint. Figure 30 shows an example of two objects and 
connectors between the objects.
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Figure 30: Example of connectors between objects

Draw has several different connectors and connector functions. On the Drawing toolbar, click on 
the triangle ▼ next to Connectors and select a connector type from the drop-down list, or select 
a connector from the Connectors panel in the Shapes deck on the Sidebar. For a more detailed 
description using connectors, see Chapter 8, Connections, Flowcharts, and Organization Charts.

Drawing geometric shapes

The tools for drawing geometric shapes are located on the Drawing toolbar (Figure 15 on 
page 30) and the Shapes deck in the Sidebar (Figure 17 on page 31). The use of these tools for 
geometric shapes is similar to the tools used for drawing rectangles and squares, or ellipses and 
circles. For more information, see “Drawing basic shapes” on page 30.

Clicking on the triangle ▼ to the right of a tool icon on the Drawing toolbar opens a drop-down 
list giving access to the toolset for that shape. If necessary, this drop-down list can be “torn off” 
to create a floating subtoolbar.

• Click and hold on the dotted line at the toolset top (highlighted in Figure 31), then drag it 
across the screen to the Workspace and release to create a floating subtoolbar

• To close a floating subtoolbar, click on the X on the right of the subtoolbar title.

Figure 31: Example of creating a floating subtoolbar
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3D Objects
Clicking on the triangle ▼ to the right of 3D Objects on the Drawing toolbar opens the 
3D-Objects subtoolbar (Figure 32). Alternatively, select the required tool from the 3D-Objects 
panel in the Shapes deck on the Sidebar.

Figure 32: 3D-Objects subtoolbar

Note

The 3D-Objects subtoolbar is identical to the 3D-Objects toolbar available at View > 
Toolbars on the Menu bar.

Basic shapes
Clicking on the triangle ▼ to the right of Basic Shapes on the Drawing toolbar opens the Basic 
Shapes subtoolbar (Figure 33). This subtoolbar also includes rectangle and ellipse tools that are 
identical to the ones already displayed on the Drawing toolbar. Alternatively, select the required 
tool from the Basic Shapes panel in the Shapes deck on the Sidebar.

Figure 33: Basic Shapes subtoolbar

Block arrows
Clicking on the triangle ▼ to the right of Block Arrows on the Drawing toolbar opens the Block 
Arrows subtoolbar (Figure 34). Alternatively, select the required tool from the Block Arrows 
panel in the Shapes deck on the Sidebar.

Figure 34: Block Arrows subtoolbar

Callouts
Clicking on the triangle ▼ to the right of Callout on the Drawing toolbar opens the Callouts 
sub-toolbar (Figure 35). Alternatively, select the required tool from the Callouts panel in the 
Shapes deck on the Sidebar.
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Figure 35: Callouts subtoolbar

Flowcharts
Clicking on the triangle ▼ to the right of Flowchart on the Drawing toolbar opens the Flowchart 
subtoolbar (Figure 36) for symbols. Alternatively, select the required tool from the Flowchart 
panel in the Shapes deck on the Sidebar. For more information on the creation of flowcharts, 
organization charts, and similar planning tools, see Chapter 8 Connections, Flowcharts and 
Organization Charts.

Figure 36: Flowchart subtoolbar

Stars and banners
Clicking on the triangle ▼ to the right of Stars and Banners on the Drawing toolbar opens the 
Stars and Banners subtoolbar (Figure 37). Alternatively, select the required tool from the Stars 
and Banners panel in the Shapes deck on the Sidebar.

Figure 37: Stars and Banners subtoolbar

Symbol shapes
Clicking on the triangle ▼ to the right of Symbol Shapes on the Drawing toolbar opens the 
Symbol Shapes subtoolbar (Figure 38). Alternatively, select the required tool from the Symbol 
Shapes panel in the Shapes deck on the Sidebar.

Figure 38: Symbol Shapes subtoolbar
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Adding, inserting and formatting text

In Draw text can be added, inserted, and formatted to in text boxes, objects, and shapes. For 
more information on how to add, insert, and format text in a drawing, see Chapter 9, Adding and 
Formatting Text.
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Introduction

This chapter explains the tools and functions for modifying existing drawings for creating and 
editing a selected object or a group of selected objects. When several objects are selected, a 
selection frame around the objects corresponds to the smallest rectangle containing all objects. 
This selection frame is also called a selection rectangle, or marquee. Selection handles appear 
on this rectangular frame which is also large enough to contain all objects when that have been 
selected.

Note

The color and shape of selection handles changes depending on the selected tool 
and function when changing object properties. Also, the color of selection handles 
depends on computer operating system and computer set up.

Selecting objects

Direct selection
Direct clicking on an object is the easiest selection method. For objects not filled, click on the 
object border to select it. To select more than one object, hold the Shift key down while clicking 
on objects. To deselect an object, move the cursor into a blank space and click.

Selection by framing
Click and drag the cursor around several objects to create a selection rectangle around several 
objects. Only objects that are within this selection rectangle are selected. Make sure Select on 
the Drawing toolbar (Figure 39) is active when selecting multiple objects.

Selecting hidden objects
Objects located behind other objects and not visible can also be selected. When a hidden object 
is selected, its selection handles appear through the objects covering the selected object.

• Windows, Mac or Linux — press the Tab key to select and cycle through objects in a 
drawing, stopping at the hidden object to select it. To cycle through objects in reverse 
order, press Shift+Tab.

• Windows or Mac only — select an object in front of a hidden object, then press the Alt 
key (macOS ) and click to select the hidden object. If there are several hidden objects, ⌥
keep holding down the Alt key (macOS ) and click until the required object is reached.⌥  
To cycle through objects in reverse order, hold down the Alt+Shift keys (macOS 
⌥+Shift) and click.

Figure 39: Drawing toolbar
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Figure 40: Line and Filling toolbar

Arranging objects
In complex drawings, several objects can be stacked on top of one another. Use one of the 
following methods to rearrange the stacking order by moving an object forward or backward:

• Select an object, go to Shape > Arrange on the Menu bar, or right-click on the object 
and select Arrange from the drop down menu, then use one of the following options:

– Bring to Front (Ctrl+Shift++) (macOS ⌘+Shift++)

– Bring Forward (Ctrl++) (macOS ⌘++)

– Send Backward (Ctrl+–) (macOS ⌘+–)

– Send to Back (Ctrl+Shift+–) (macOS ⌘+Shift+–)

– In Front of Object

– Behind Object

• Select an object, then select one of the Arrange tools at the left end of the Line and 
Filling toolbar (Figure 40). When the cursor hovers over a tool, its function is indicated.

Positioning and adjusting objects

Zoom
For positioning and adjustment of objects, Draw has a zoom function that reduces or enlarges 
the display of the current drawing. For example, zoom in to position objects on a drawing with 
greater accuracy, or zoom out to see the complete drawing. Zooming is controlled using the 
Status Bar, Zoom & View Layout dialog, or Zoom toolbar.

Note

The zoom function is handled differently in a Linux operating system. Drawings 
saved with 100% zoom setting in Windows or macOS are displayed at a larger zoom 
setting than in a Linux operating system.

Status bar

The zoom controls are located on the right side of the Status Bar (Figure 41) for easy access 
when zooming. Use one of the following methods to change the zoom factor:

• Use Fit page to current window to fit the drawing to the open window.
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Figure 41: Status Bar zoom controls

(1) Fit page to current window (2) Zoom slide control (3) Zoom percentage

Figure 42: Zoom & View Layout dialog

• Move the Zoom slide control toward the minus sign (–) on the zoom slide control to 
reduce the zoom factor.

• Move the Zoom slide control toward plus sign (+) on the zoom slide control to increase 
the zoom factor.

• Right-click on the Zoom percentage number and select a zoom option from the context 
menu that opens.

Zoom & View Layout dialog

Open the Zoom & View Layout dialog (Figure 42) using one of the following methods:

• Click on the zoom percentage number in the Status Bar.

• Go to View > Zoom > Zoom on the Menu bar.

The Zoom & View Layout dialog provides the following display options:

Zoom Factor

Sets the zoom factor for displaying the current document and all documents of the same 
type that are subsequently opened.

Optimal

Resizes the display to fit the text width in the document.

Fit width and height

Displays the entire page on the screen.

Fit width

Displays the complete document page width. The top and bottom page edges may not 
be visible.

100%

Displays the document at its actual size.
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Figure 43: Zoom toolbar

Custom

Enter a percentage in the box for the zoom factor to display the document, or use the 
minus (–) or plus (+) signs to change the zoom factor.

Zoom toolbar

Go to View > Toolbars > Zoom on the Menu bar to open the Zoom toolbar (Figure 43). The 
tools available, from left to right, are as follows:

Zoom In

Displays the drawing at twice its current size each time the tool is selected.

Zoom Out

Displays the drawing at half its current size each time the tool is selected.

100%

Displays the drawing at its actual size.

Zoom Previous

Returns the drawing display to the previous zoom factor applied.

Zoom Next

Undo the action of the previous zoom command.

Entire Page

Displays the whole drawing in the Workspace.

Page Width

Displays the complete drawing width. The slide top and bottom edges may not be visible.

Optimal

Resizes the display to include all objects on the drawing.

Object Zoom

Resizes the display to fit the selected object(s).

Zoom & Pan

Zooms in for each click. Ctrl+click (macOS ⌘+click) zooms out for each click. 
Shift+click allows panning of a drawing.

Shift

Moves the drawing within the Workspace. Place the cursor on the drawing and drag to 
move the drawing.

Moving and adjusting object size
When moving an object or changing its size, check the left corner of the Status Bar at the 
bottom of the Workspace (Figure 44). From left to right, this area shows a shape is selected, its 
position on the drawing in X/Y coordinates and object dimensions. The measurement units are 
selected in Tools > Options > LibreOffice Draw > General (macOS Preferences > 
LibreOffice > LibreOffice Draw > General).
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Figure 44: Example of left end of Status Bar with shape selected

Figure 45: Example of moving selected objects

Moving objects

To move an object (or a group of objects), select it, then click within the object borders and drag 
the object. During movement, a ghost object image appears to help with repositioning, as shown 
by the example in Figure 45. When the object reaches its new location, release the object.

Adjusting object size

To change the size of a selected object (or a group of selected objects), move the cursor to a 
selection handle. The cursor changes shape to indicate the direction of movement for that 
selection handle. Click on the selection handle and drag it to change object size. The results 
depend on which selection handle is used, as follows:

• To resize an object in one axis, use a side, top, or bottom handle.

• To resize using both axes, use a corner handle.

As an object size changes, a ghosted object outline appears, as shown by the example in 
Figure 46. When the required object size is reached, release the object.

Note

Pressing and holding the Shift key when resizing an object changes the size to 
maintain the aspect ratio between width and height. This Shift key behavior works 
on all selection handles.

Modifying arcs

The size of an arc is changed by adjusting the positions of the start and end points of an arc. 
The selection handle at the start point of an arc is larger than the end point of an arc.

1) Select an arc, then right click on the arc and select Points from the drop down menu, or 
press the F8 key. Two handles appear at the start and end of the arc, as shown by the 
example in Figure 47
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Figure 46: Example of adjusting object size

Figure 47: Example of modifying arcs

2) Click and drag on the start or end handle to change the arc shape.

3) Release the selected handle when the required arc shape is achieved.

Rotating and slanting objects

Rotating objects

To rotate an object (or a group of objects), select the object and change to rotation mode as 
follows:

1) Select an object, or a group of objects, so that the selection handles are displayed.

2) Use one of the following methods to switch to rotation mode. The selection handles 
change shape and color and a center of rotation indicator appears in the object center, 
as shown by the example in Figure 48.

– Click again on a selected object, or a group of objects. DO NOT double click. A double 
click is used to switch an object into text mode.

– Click on the triangle ▼ on the right of Transformations on the Line and Filling toolbar 
(Figure 40 on page 49) and select Rotate from the pop up menu.
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Figure 48: Example of rotation mode

Figure 49: Transformations toolbar

– Go to View > Toolbars > Transformations on the Menu bar to open the 
Transformations toolbar (Figure 49) and select Rotate.

3) Move the cursor over a corner selection handle and the cursor changes shape to indicate 
rotation mode.

4) Click on the corner selection handle and drag it to rotate the object. Release the 
selection handle when the required object rotation is reached.

Notes

The rotation center is normally located at the center of an object. To change the 
rotation center position, click on the rotation center and drag it until it is at the 
required position. The rotation center can be repositioned outside of the object.

Rotation works in a slightly different way for 3D objects because it occurs in a three 
dimensional space and not in a single plane. See Chapter 7, Working with 3D 
Objects for more information.

Slanting objects

The axis used for slanting an object is the object edge directly opposite the center handle being 
used to slant the object. This axis is fixed in location while the other sides of the object move in 
relation to it as the selection handle is dragged. In Figure 50 the selection handle at the center of 
the object bottom has been used to slant the object.

1) Select an object and use one of the following methods to switch to rotation mode. The 
selection handles change shape and color and a center of rotation indicator appears in 
the object center.

– Click again on a selected object.

– Click on the triangle ▼ on the right of Transformations on the Line and Filling toolbar 
and select Rotate from the pop up menu.
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Figure 50: Example of slanting objects

– Go to View > Toolbars > Transformations on the Menu bar to open the 
Transformations toolbar, then select Rotate.

2) Move the cursor over a selection handle at the midpoint of the object top, bottom, left or 
right sides and the cursor changes shape to indicate slanting direction.

3) Click and drag the selection handle to slant the object. Release the cursor when the 
desired object slant is reached. A ghosted object outline being slanted appears and the 
current angle of slanting is shown in the Status Bar.

Note

Press and hold the Shift key while rotating or slanting  an object restricts 
movement to 15° steps. This is the default behavior of the Shift key. However, if 
When creating or moving objects has been selected in Tools > Options > 
LibreOffice Draw > Grid (macOS LibreOffice > Preferences > LibreOffice Draw > 
Grid), the Shift key action is reversed and rotation or slanting is restricted to 15° of 
movement unless the Shift key is pressed.

Setting exact position, size, rotation and slant
Using the cursor to position and resize objects is not exact. If greater accuracy is required to 
position and size an object, it is recommended to use the Position and Size dialog (Figure 51), or 
the Position and Size panel (Figure 52 on page 57) in the Properties deck on the Sidebar.

• To open the Position and Size dialog, select an object and use one of the following 
methods:

– Go to Format > Position and Size on the Menu bar.

– Right-click on the object and select Position and Size from the context menu.

– Use the keyboard shortcut F4.

• To open the Position and Size panel in the Properties deck on the Sidebar, select an 
object, then click on Properties on the Sidebar and click on the chevron > on the 
Position and Size title bar to open the panel.
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Figure 51: Position and Size dialog

Position and Size

Position

Specifies the position of a selected object location on a page. The units of measurement 
used for X//Y coordinates, and object width and height are set by going to Tools > 
Options > LibreOffice Draw > General (macOS LibreOffice > Preferences > 
LibreOffice Draw > General).

Position X

Enter the horizontal distance required to move an object relative to the base point 
selected in the grid.

Position Y

Enter the vertical distance required to move an object relative to the base point 
selected in the grid.

Base point

Select a base point in the grid and then enter the amount required to shift an object 
relative to the base point that is selected in the Position Y and Position X boxes. The 
base points correspond to the selection handles on an object. This option is only 
available in the Position and Size dialog.

Size

Specify the amount required to resize a selected object with respect to a selected base 
point.
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Figure 52: Position and Size panel in Properties deck on Sidebar

Width

Enter a width for a selected object.

Height

Enter a height for a selected object.

Keep ratio

Maintains proportions when resizing a selected object.

Base point

Select a base point in the grid, and then enter the new size dimensions for a selected 
object in the Width and Height boxes. This option is only available in the Position and 
Size dialog.

Protect

This option is only available in the Position and Size dialog.

Position

Prevents changes to position or size for a selected object.
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Size

Prevents object resizing.

Adapt

When selected allows the size of a text box to adjust and match the size of text being 
entered into a text box. This option is only available in the Position and Size dialog for 
text boxes.

Fit width to text

Expands an object width to the text width, if the object is smaller than the text.

Fit height to text

Expands an object height to the text height, if the object is smaller than the text.

Note

The position and size default location for a base point is the upper left corner of the 
drawing area. This base point can be temporarily changed to make positioning or 
dimensioning simpler by clicking on a position corresponding to the required base 
point location. This change in base point is only valid for single use and the base 
point is reset to the default position of top left corner when the Position and Size 
dialog is closed.

Rotating objects

To accurately rotate an object, click on the Rotation tab of the Position and Size dialog to open 
the Rotation page (Figure 53). The options allow the rotation angle and pivot point location to be 
defined. Alternatively, use the available options for rotation in the Position and Size panel in the 
Properties deck on the Sidebar (Figure 52).

Pivot Point

A selected object is rotated around a specified pivot point and this option is only available 
in the Position and Size dialog. The default position for the pivot point is the center of an 
object. The pivot point can be moved from its default position by changing the setting for 
Position X and/or Position Y, or selecting a position in Default settings.

Figure 53: Position and Size dialog — Rotation page
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Position X

Enter a horizontal distance from the page left edge to change the pivot point position.

Position Y

Enter a vertical distance from the page top edge to change the pivot point position.

Default settings

Select the pivot point position. Default position is the center of an object. Changing the 
pivot point is valid for single use only and is reset to the default central position when 
the Position and Size dialog is closed.

Rotation Angle

Specify the number of degrees required to rotate a selected object. This option is only 
available in the Position and Size dialog.

Angle

Enter the number of degrees that required to rotate the selected object.

Default settings

Click on the indicator to rotate the object. The number of degrees rotated is shown in 
the Angle box.

Slant and corner radius

To accurately set a corner radius or slant angle of an object, click on the Slant & Corner Radius 
tab of the Position and Size dialog (Figure 54) to open the Slant & Corner Radius page. 
Options for slant and corner radius are only available in the Position and Size dialog.

Corner Radius

This option is only available for the corners of a rectangular or square object that has 
been created using the Legacy Rectangles toolbar. This toolbar is optional and is opened 
by going to View > Toolbars > Legacy Rectangles on the Menu bar. If this option is 
grayed out, the corner radius cannot set.

Radius

Enter the circle radius that is to be used to round corners. The larger the value for 
corner radius set, rounded corners become more visible.

Slant

Slants the selected object along the object bottom edge.

Angle

Enter the slant axis angle. The slant angle relates to how much an object inclines or 
slants from its normal vertical position on a drawing.

Figure 54: Position and Size dialog — Slant & Corner Radius page
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Figure 55: Example of corner point adjustment

Control Point 1/Control Point 2

These control points are special handles or dots that are available on some shapes and 
are used to change the properties of a shape. If these options are grayed out, then the 
shape does not have a special handle and coordinates cannot be set.

Enter a value to set the special handle X and Y coordinates in relation to the shape top 
left corner. The example shown in Figure 55 shows the shape change after adjusting the 
X coordinate of Control Point 1 of the special handle.

Note

For more information on control points, see “Changing object shape” on page 67.

Using grid and snap functions

Position objects accurately using the grid and snap functions available in Draw. It is 
recommended to use the highest practical zoom value for a drawing when using the grid and 
snap functions. Two different functions can be used at the same time, for example, snapping to a 
guide line and page edge. It is recommended to only activate snap functions that are required.

Configuring grid and snap
To configure the grid and snap functions in a drawing, go to Tools > Options > LibreOffice 
Draw > Grid (macOS LibreOffice > Preferences > LibreOffice Draw > Grid) on the Menu bar 
to open the Options LibreOffice Grid dialog (Figure 56). Grid and snap functions are displayed 
and selected using one of the following methods:

• Using the Options LibreOffice Grid dialog.

• Right clicking on a drawing and selecting options from the context menu.

• Using the tools on the Options toolbar (Figure 57). If the Options toolbar is not open, go 
to View > Toolbars > Options on the Menu bar.

Grid and snap functions
Grid

Specifies the settings for a drawing configurable grid to determine the exact position of 
objects. Also, this grid can be set to match the snap grid. If the snap grid is activated, but 
have to move or create individual objects without snap positions, keep the Shift key 
pressed to deactivate this function.
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Figure 56: Options LibreOffice Draw dialog — Grid page

Figure 57: Options toolbar

Snap to grid

Specifies whether to move frames, drawing elements, and controls only between grid 
points. To change the snap grip status only for the current action, drag an object while 
holding down the Ctrl key (macOS ).⌘

Visible grid

Specifies whether to display the grid.

Resolution

Horizontal

Defines the unit of measure for the spacing between grid points on the X-axis.

Vertical

Defines the grid points spacing in the desired unit of measurement on the Y-axis.

Synchronize axes

Specifies whether to change the current grid settings symmetrically. The resolution and 
subdivision for the X and Y axes remain the same.

Subdivision

Horizontal

Specify the number of intermediate spaces between grid points on the X-axis.

Vertical

Specify the number of intermediate spaces between grid points on the Y-axis.
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Snap

To snap lines

Snaps the edge of a dragged object to the nearest snap line when the object is 
released. This setting can also be defined using Snap to Snap Guides on the Options 
toolbar.

To the page margins

Specifies whether to align the graphic object contour to the nearest page margin. The 
cursor or a contour line of the graphics object must be in the snap range. This function 
can also be accessed using Snap to Page Margins in the Options toolbar.

To object frame

Specifies whether to align the graphic object contour to the border of the nearest 
graphic object. The cursor or a contour line of the graphics object must be in the snap 
range. This function can also be accessed with Snap to Object Border in the Options 
toolbar.

To object points

Specifies whether to align the graphic object contour to the points of the nearest 
graphic object. This only applies if the cursor or a contour line of the graphics object is 
in the snap range. This function can also be accessed with Snap to Object Points in 
the Options toolbar.

Snap range

Defines the snap distance between the cursor and the object contour. Snaps to a snap 
point if the cursor is closer than the distance selected.

Constrain Objects

When creating or moving objects

Specifies that graphic objects are restricted vertically, horizontally or diagonally (45°) 
when creating or moving them. This setting can be temporarily deactivated by pressing 
the Shift key.

Extend edges

Specifies that a square is created based on the longer side of a rectangle when the 
Shift key is pressed before releasing the object. This also applies to an ellipse where 
a circle is created based on the ellipse longest diameter. When Extend edges is not 
selected, a square or a circle is created based on the shorter side or diameter.

When rotating

Specifies that graphic objects can only be rotated within the rotation angle that is 
selected. To rotate an object outside the defined angle, press the Shift key when 
rotating. Release the object when the desired rotation angle is reached.

Point reduction

Defines the angle for point reduction. When working with polygons, this is useful for 
reducing editing points.

Snap to grid

Using Snap to Grid

Snap to Grid is used when moving an object onto a grid point in a drawing. This function is 
selected using one of the following methods:

• Go to View > Snap Guides > Snap to Grid on the Menu bar.

• Right-click on a drawing and select Snap Guides > Snap to Grid from context menu.

• Click on Snap to Grid on the Options toolbar.
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Displaying grid

Use one of the following methods to display or hide the grid in a drawing:

• Go to View > Grid and Helplines > Display Grid on the Menu bar.

• Click on Display Grid on the Options toolbar.

• Right-click on a drawing and select Grid and Helplines > Display Grid from the context 
menu.

• Select Visible grid in the Options LibreOffice Draw Grid dialog.

Changing color of grid points

By default and depending on the computer setup, grid points are gray and not always easy to 
see. Change the grid point color as follows:

1) Go to Tools > Options > LibreOffice > Application Colors (macOS LibreOffice > 
Preferences > LibreOffice > Application Colors) to open the Application Colors dialog 
(Figure 58).

2) Go to Drawing/Presentation and select a more suitable color for the grid from the 
drop-down list.

3) Click on OK to save the changes and close the dialog.

Figure 58: Options LibreOffice dialog — Application Colors page
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Figure 59: New Snap Guide dialog

Snap points and lines
Snap lines and snap points are not part of the grid, but are inserted to position an object at a 
specific place in a drawing. Snap lines can either be horizontally or vertically and appear as 
dashed lines. Snap points appear as small crosses with dashed lines. Snap points and snap 
lines do not appear in printed output.

Inserting snap points and snap lines

To insert a snap point or snap line, go to Insert > Snap Guide on the Menu bar to open the New 
Snap Guide dialog (Figure 59).

Position

Sets the position of a selected snap point or line relative to the top left page corner.

X:

Enter the amount of space required between the snap point or line and the page left 
edge.

Y:

Enter the amount of space required between the snap point or line and the page top 
edge.

Type

Specifies the type of snap object being inserted.

Point

Inserts a snap point.

Vertical

Inserts a vertical snap line.

Horizontal

Inserts a horizontal snap line.

Displaying snap points and lines

Use one of the following methods to display snap points and lines in a drawing:

• Go to View > Snap Guides > Display Snap Guides on the Menu bar.

• Click on Display Snap Guides in the Options toolbar.

• Right-click on a drawing and select Snap Guides > Display Snap Guides from the 
context menu.
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Figure 60: Edit Snap Point dialog

Figure 61: Edit Snap Line dialog

Editing snap points

1) Right-click on the snap point and select Edit Snap Point from the context menu to open 
the Edit Snap Point dialog (Figure 60).

2) Enter new X and Y coordinate settings for the snap point and click OK.

3) Alternatively, click and drag a snap point to a new position on a drawing.

Editing snap lines

1) Right-click on the snap line and select Edit Snap Line from the context menu to open 
the Edit Snap Line dialog (Figure 61).

2) Enter a new X coordinate setting for vertical snap lines or a new Y coordinate setting for 
horizontal snap lines and click OK.

3) Alternatively, click and drag a snap line to a new position on a drawing.

Deleting snap points and lines

• To delete a snap point, drag it back to a ruler or right-click on the snap point and select 
Delete Snap Point from the context menu.

• To delete a snap line, drag it back to the ruler or right-click on the snap line and select 
Delete Snap Line from the context menu.

Configuring snap range

To configure the snap range of when an object snaps to a position in the drawing:

1) Go to Tools > Options > LibreOffice Draw > Grid (macOS LibreOffice > Preferences 
> LibreOffice Draw > Grid) on the Menu bar to open the Options LibreOffice Grid 
dialog.

2) Enter the number of pixels to set the proximity of when the object will snap into position 
in the Snap range box. The default setting is 5 pixels.
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3) Click OK to set the new snap range and close the dialog.

Using Helplines

Helplines are a Draw function for positioning of objects. Helplines are displayed while the object 
is being moved. Helplines extend from the object edges to the rulers at the top and left side of a 
drawing and do not have a snap function (Figure 62).

1) Go to Tools > Options > LibreOffice Draw > View (macOS LibreOffice > Preferences 
> LibreOffice Draw > View) on the Menu bar to open the Options LibreOffice Draw View 
dialog (Figure 63).

2) Select Helplines when moving option or click Helplines While Moving in the Options 
toolbar.

3) Click OK to save the selection and close the dialog.

Figure 62: Example of using helplines when moving objects

Figure 63: Options LibreOffice Draw View dialog
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Changing object shape

Regular shapes
When creating regular shapes in a drawing, some shapes have one or more control dots 
displayed in a different color to the selection handles after selecting an object. When the cursor 
hovers over one of these dots, it changes shape. Click and drag a control dot to modify the 
object shape. For example, increasing corner radius of a rounded rectangle or square, changes 
the angles of an arc, and so on. Control dots have different functions according for each shape.

Note

After converting a regular shape to a curve or polygon, the shape of a regular shape 
can be changed and points can be edited. See “Curves and polygons” on page 70 
and “Editing points” on page 71 for more information.

Basic shapes

The following basic shapes on the Basic Shapes subtoolbar (Figure 64), listed in Table 3, have 
control dots.

Figure 64: Basic Shapes subtoolbar

Table 3: Basic shapes with control dots

Basic Shapes Control dot description

Rectangle, Rounded
Changes the curve radius that replaces the angled corners of a 
rectangle or square.

Square, Rounded
Changes the curve radius that replaces the angled corners of a 
rectangle or square.

Parallelogram Changes the internal angles between the sides.

Trapezoid Changes the internal angles between the sides.

Circle Pie Changes the size of the filled sector.

Block Arc Changes both internal diameter and size of the filled area.

Isosceles Triangle Changes the shape and type of the triangle.

Hexagon Changes the internal angles between the sides.

Octagon Changes the internal angles between the sides.

Cylinder Changes the perspective.

Cube Changes the perspective.

Folded Corner Changes the folded corner size.

Cross Changes the thickness of the cross four arms.

Frame Changes the frame thickness.

Ring Changes the ring internal diameter.

Chapter 3,  Working with Objects | 67



Symbol shapes

The following symbol shapes on the Symbol Shapes subtoolbar (Figure 65), listed in Table 4, 
have control dots.

Figure 65: Symbol Shapes subtoolbar

Table 4: Symbol shapes with control dots

Symbol Shapes Control dot description

Smiley Face Changes the smile on the face.

Heart Changes the symbol shape.

Sun Changes the symbol shape.

Moon Changes the symbol shape.

Prohibited Changes the ring thickness and the diagonal bar.

Square Bevel Changes the bevel thickness.

Octagon Bevel Changes the bevel thickness.

Diamond Bevel Changes the bevel thickness.

Double Bracket Changes the bracket curvature.

Left Bracket Changes the bracket curvature.

Right Bracket Changes the bracket curvature.

Double Brace Changes the bracket curvature.

Left Brace Changes the brace curvature and the position of the point.

Right Brace Changes the brace curvature and the position of the point.

Block arrows

The following block arrows on the Block Arrows subtoolbar (Figure 66), listed in Table 5, have 
control dots.

Figure 66: Block Arrows subtoolbar

Table 5: Block arrows with control dots

Block Arrows Control dot description

Right Arrow Changes the arrow shape and thickness.

Left Arrow Changes the arrow shape and thickness.
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Block Arrows Control dot description

Down Arrow Changes the arrow shape and thickness.

Up Arrow Changes the arrow shape and thickness.

Left and Right Arrow Changes the arrow shape and thickness.

Up and Down Arrow Changes the arrow shape and thickness.

Circular Arrow Changes the arrow shape and thickness.

4-way Arrow Changes the arrow shape and thickness.

Chevron Changes the angle between the sides and the shape.

Pentagon Changes the angle between the sides and the shape.

Striped Right Arrow Changes the arrow shape and thickness.

Up, Right and Down Arrow Changes the arrow shape and thickness.

Notched Right Arrow Changes the arrow shape and thickness.

Up and Right Arrow Changes the arrow shape and thickness.

Right Arrow Callout Changes the callout shape and thickness.

Left Arrow Callout Changes the callout shape and thickness.

Down Arrow Callout Changes the callout shape and thickness.

Up Arrow Callout Changes the callout shape and thickness.

Left and Right Arrow Callout Changes the callout shape and thickness.

Up and Down Arrow Callout Changes the callout shape and thickness.

4-way Arrow Callout Changes the callout shape and thickness.

Up and Right Arrow Callout Changes the callout shape and thickness.

Callouts

For all callouts on the Callouts subtoolbar (Figure 67) use control dots to change length, position 
and angle of a pointer.

Figure 67: Callouts subtoolbar

Stars and banners

The following stars and banners on the Stars and Banners subtoolbar (Figure 68), listed in 
Table 6, have control dots.

Figure 68: Stars and Banners subtoolbar

Table 6: Stars and banners with control dots

Stars and Banners Control dot description

4-Point Star Changes the star points thickness and shape.
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Stars and Banners Control dot description

8-Point Star Changes the star points thickness and shape.

24-Point Star Changes the star points thickness and shape.

Vertical Scroll Changes the scroll width and shape.

Horizontal Scroll Changes the scroll width and shape.

Doorplate Changes the inward curvature of the corners.

Curves and polygons

Bézier curves

The editing of curves and polygons depends on the mathematics of Bézier curves1. Fully 
explaining Bézier curves goes beyond the scope of this Draw Guide. For more information on 
drawing and manipulating Bézier curves, see Chapter 11, Advanced Draw Techniques.

Editing a Bézier curve is the movement of points or tangents passing through a point. Each 
tangent has a control point at each end and a junction point where it meets a curve. The relative 
angle and distance between control points determines the curve shape. Figure 69 shows what 
happens to a square and moving only one point on the square.

Converting objects to curve or polygon

When changing the shape of an object and before modifying the points on an object, it must be 
converted to a curve or a polygon. Depending on what kind of shape and effect required, use 
one of the following methods to create a curve or a polygon:

• After selecting an object, go to Shape > Convert on the Menu bar and select either To 
Curve or To Polygon.

• Right click on an object and select Convert > To Curve or To Polygon from the context 
menu.

Figure 69: Example of creating different shapes using tangent points

1 Bézier curves were invented by Pierre Bézier, who developed the technique in the 1960s while 
working as an engineer for the Renault car manufacturer. The technology was intended to make 
modeling the surface of vehicles easier.
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Figure 70: Edit Points toolbar

Editing points
Many different shapes can be created by moving either the point, or one or both of the round 
handle points at either end of the tangent, as shown in Figure 69. Points can be added, deleted, 
or points type changed using tools available on the Edit Points toolbar (Figure 70). 

1) Convert a shape to a curve or polygon.

2) Select the converted object and then select the points editing mode using one of the 
following methods:

– Go to Edit > Points on the Menu bar.

– Click on Toggle Edit Point Mode on the Standard toolbar.

– Right click on the converted object and select Toggle Edit Point Mode from the 
context menu.

– Use the keyboard shortcut F8.

3) Click on an object point to change the object shape. The Edits Points toolbar opens and 
the tools become active when a point is selected. Tangents also appear attached to the 
selected point.

4) Use the various tools on the Edit Points toolbar to add, delete, or change the point type.

5) Click and drag a point to move the point and change object shape.

6) If the selected object is a curve, click on and drag the round points at the end of a 
tangent to change the object shape.

7) When satisfied with the shape, click outside of the object to cancel points editing mode 
and close the Edit Points toolbar.

Point types
The available tools on the Edit Points toolbar depend on the object and type of object point that 
has been selected.

Move Points

Activates a mode allowing movement of points. Click and drag the selected point to 
another location.

Insert Points

Activates the insert mode for inserting points. A point is inserted onto a selected object 
each time a click is made. The object also changes shape to include a new point into the 
object border. Inserted points are a smooth point.

Delete Points

Deletes points from the selected object. Select Delete Points and then click on a point to 
delete. To delete several points, hold down the Shift key as each point is selected for 
deletion, then click on Delete Points.
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Convert To Curve

Converts a curve into a straight line, or a straight line into a curve. If a single point is 
selected, the curve before the point is converted. If two points are selected, the curve 
between both points is converted. If more than two points are selected and each time 
Convert to Curve is clicked, a different portion of the curve is converted. If necessary, 
round points are converted into corner points and corner points are converted into round 
points.

If a curve section is a straight line, the line end points have a maximum of one control 
point each. They cannot be modified to round points unless the straight line is converted 
back to a curve.

Close Bézier

Closes a curve by connecting the last point with the first point. This is indicated by an 
enlarged square.

Split Curve

Select the point or points, then click on Split Curve.

Corner Point

Converts a selected point or points into corner points. Corner points have two movable 
control points, which are independent from each other. A curved line does not go straight 
through a corner point, but creates a corner.

To create a corner point, a smooth or a symmetrical point must be inserted first and then 
converted to a corner point by clicking on Corner Point.

Smooth Transition

Converts a corner point, or symmetrical point into a smooth point. Both control points of a 
corner point are aligned in parallel and are only moved simultaneously. Control points 
may maybe different lengths, allowing variation in the degree of curvature.

Tangents
Before using tangents on an object, it must be converted to a curve. Tangents are only used on 
curves. If an object has been converted to a polygon and a tangent is added, the object is 
automatically converted to a curve.

Note

The tangent angle relates to an object shape that is changed by selecting a tangent 
control point at the end of a tangent and moving it. As the tangent angle is changed, 
the object shape changes in response.

Symmetric transition

Symmetric transition converts a corner or smooth point into a symmetrical point. Tangents have 
the same length and are aligned in a straight line, as shown in Figure 71. Tangents can only be 
moved simultaneously and the degree of curvature is the same in both directions.

1) Convert an object to a curve or polygon.

2) Select the converted object and open the Edit Points toolbar.

3) Select a point to change to a symmetrical point.

4) Click on Symmetric Transition in the Edit Points toolbar. The straight line on each side 
of the symmetric transition point is converted to a curve.
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5) Click and drag a tangent control handle to change the object curvature and shape. Any 
change to one tangent is carried over symmetrically to the other tangent.

Smooth transition

Converts selected points into corner points. Tangents are aligned in a straight line and move 
simultaneously. Tangents can have different lengths with the curvature controlled by the longest 
tangent which is the largest curvature, as shown in Figure 72.

1) Convert the object to a curve or polygon.

2) Select the converted object and open the Edit Points toolbar.

3) Select the point to be changed to a symmetrical point.

4) Click on Smooth Transition on the Edit Points toolbar.

5) Click and drag a tangent control handle to change the object shape. This creates an 
asymmetric tangent with the largest curvature on the tangent longest side.

Figure 71: Example of symmetric transition

Figure 72: Example of smooth transition
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Figure 73: Example of changing corner point

Corner point

Converts a selected point or points into corner points. Corner points have two movable control 
points, independent from each other. It is possible to independently change the angle on each 
side of a tangent using the tangent central point as a corner point, as shown in Figure 73.

1) Convert the object to a curve or polygon.

2) Select the converted object and open the Edit Points toolbar.

3) Select the point to be changed to a corner point.

4) Click on Corner Point on the Edit Points toolbar.

5) Click and drag the end of a tangent to change its angle. Each tangent can be moved 
independently creating spikes and troughs in an object shape.

Points

Moving points

When moving points, the object border on both sides of the point follows the point movement 
changing the object shape. This also referred to as distorting objects.

1) Convert the object to a curve or a polygon.

2) Select the converted object and open the Edit Points toolbar.

3) Select the point to be changed to a symmetrical point.

4) Click on Move Points on the Edit Points toolbar.

5) Place the cursor on the selected point, then click and drag the point creating a new 
shape. Figure 74 illustrates how a different shape is created from a circle by dragging the 
left hand side point to the left.

Inserting points

A smooth point is inserted into a selected object each time there is a click. Clicking and dragging 
an inserted point changes object shape at the new point, as shown in Figure 75.
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Figure 74: Example of moving points

Figure 75: Example of inserting and moving points

1) Convert the object to a curve or a polygon.

2) Select the converted object and open the Edit Points toolbar.

3) Click on Insert Points on the Edit Points toolbar.

4) Click on the object border, or inside the object, to insert a point, then drag the cursor to 
move the inserted point and create a new shape.

5) Release the inserted point when the required shape is created.

6) If required, click and drag the end of a tangent to change its angle. Each tangent can be 
moved independently creating spikes and troughs in an object shape.

Deleting points

Figure 76 is an example of what happens when three points on the left were deleted from a 
circle. The left image is a the full circle and the right image is where three points have been 
deleted creating a new shape.

1) Convert the object to a curve or a polygon.

2) Switch the selected object into editing points mode and open the Edit Points toolbar.

3) To delete a single point, proceed as follows

a) Select the point for deletion.
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Figure 76: Example of deleting points

b) Click on Delete Points on the Edit Points toolbar.

4) To delete several points at the same time, proceed as follows:

a) Hold down the Shift key.

b) Select all the points for deletion.

c) Click on Delete Points on the Edit Points toolbar.

Eliminating points

Eliminate Points on the Edit Points toolbar only functions on lines with multiple points. These 
lines are created when a curve is converted to a line using Convert to Curve. An example of 
creating a straight line and eliminating points is shown in Figure 77.

1) Convert the curve to a curve or a polygon.

2) Switch the curve into editing points mode and open the Edit Points toolbar.

3) Select the curve with multiple points and convert to a line, see “Converting curves or 
lines” below.

4) Select the point or points on the line for elimination. The selected point is emphasized.

5) Select Eliminate Points on the Edit Points toolbar.

6) Accurately position the cursor over the selected point, then click and drag the selected 
point. As the cursor is dragged, a dotted line forms between the neighboring points.

7) When this dotted line appears to be a straight line between the neighboring points, 
release the selected point. The selected point is eliminated and a straight line now exists 
between the neighboring points.

Converting curves or lines
Curves and lines are converted using Convert to Curve on the Edit Points toolbar. When a 
curve is converted to a line, a straight line is created between selected points on a curve. When 
a line is converted to a curve, a curve is created between selected points on a line. An example 
of converting a curve to a line is shown in Figure 77.

1) Convert the object to a curve or a polygon.

2) Switch the object into editing points mode and open the Edit Points toolbar.
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Figure 77: Example of converting curve to a line

(1) Curve with points displayed.
(2) Sections between points converted to lines.

(3) Points deleted to create a line section.

3) Select the points for converting from curve to line or from line to curve.

4) Click on Convert to Curve on the Edit Points toolbar. Between the selected points, a 
curve is converted into a line or a line is converted into a curve.

5) Delete a point on the converted line to create a straight line.

Splitting objects
1) Convert the object to a curve or a polygon.

2) Switch the object into editing points mode and open the Edit Points toolbar.

3) Select the point or points on the object where it is to be split. Keep the Shift key 
pressed down when selecting more than one point.

4) Click on Split Curve on the Edit Points toolbar to split or cut the object border at the 
selected point. If the object is filled, it will be emptied because the object border is no 
longer closed, as shown in Figure 78.

5) Deselect the object, then drag the cut segment and move it away from the original object.

Note

The point where the object was split is now larger than the remaining points visible 
on the object.

Closing objects
1) Select an open object (Figure 79).

2) Switch the object into editing points mode and open the Edit Points toolbar.
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Figure 78: Example of splitting objects

Figure 79: Example of closing objects

3) Select a point where the object has been split. Note that the start point of an object is 
larger than the other points visible on the object.

4) Click on Close Bézier in the Edit Points toolbar to close the object. If the open object 
was originally a closed and filled object, then the original color fills the object when it is 
closed.

78 |Draw Guide 24.8



Draw Guide 24.8

Chapter 4, 
Changing Object Attributes



Formatting lines

In Draw, the term Line indicates a freestanding segment (line), outer edge or border of a shape, 
or an arrow. The properties of a line that can be modified are style, width, color, and type of 
arrowhead.

Note

For more information on using color when formatting lines, line styles, arrows, and 
arrow styles, see “Working with area fills” on page 92.

Line and Filling toolbar
1) Select a line in the drawing.

2) If necessary, go to View > Toolbars on the Menu bar and select Line and Filling from 
the drop-down list to open the Line and Filling toolbar (Figure 80).

3) Click on the triangle ▼ to the right of Line Style and select a line style from one of the 
options in the drop-down list.

4) Either type the line width in the Line Thickness text box, or use the up and down arrows 
to change the line width.

5) Click on the triangle ▼ to the right of Line Color and select a color from one of the 
available color palettes.

6) If necessary, click on Shadow to add a shadow to the line. The shadow applied uses the 
settings set in the Shadow page of the Line dialog (Figure 85 on page 84).

7) If necessary, select from the Select start and end arrowheads for lines drop-down list 
the arrowhead type for each end of the line and change the line into an arrow. The left 
drop-down list adds an arrow head to the beginning of the line. The right drop-down list 
adds an arrow head to the end of the line.

8) Deselect the line to save the changes to the line.

Sidebar
1) Select a line in the drawing.

2) Click on Properties on the Sidebar to open the Properties deck.

3) Click on Line to open the Line panel (Figure 81).

Figure 80: Line and Filling toolbar
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Figure 81: Line panel in Properties deck on Sidebar

4) In Line, click on Select start and end arrowheads for lines to open the drop-down lists 
for arrowhead types for each end of the line and change the line into an arrow.

– Left drop-down list adds an arrowhead to the beginning of the line.

– Right drop-down list adds an arrowhead to the end of the line.

5) In Line, select the type of line required from the Line Style drop-down list.

6) In Thickness, select a line width from the options available in the Select the width of the 
line drop-down list, or enter a width in the Custom Line Thickness text box.

7) In Color, click on the triangle ▼ to the right of Line Color and select a color from one of 
the available color palettes.

8) If required, in Transparency enter a percentage amount for line transparency.

9) If required, in Corner style select a corner style for the line from the drop-down list.

10) If required, in Cap style select a cap style for line ends from the drop-down list.

11) Deselect the line to save changes made to the line.

12) If necessary, click on More Options on the right of the title bar and open the Line dialog 
(Figure 82) for more control over formatting lines.

Line dialog
1) Make sure a line is selected on a drawing.

2) Open the Line dialog (Figure 82) using one of the following methods:

– Go to Format > Line on the Menu bar.

– Right-click on the line and select Line from the context menu.

– Click on More Options on the right of the Line panel title on the Sidebar.

3) Format the line using the options available in the Line dialog. A preview box at the bottom 
of the dialog shows the effect of the changes on a line.

4) Click OK to save the changes and close the dialog.
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Figure 82: Line dialog — Line page

Line properties
The Line page in the Line dialog is where the basic parameters of the line are set. It is divided 
into three sections as follows.

Line properties

Style

Select a line style from the drop-down list.

Color

Select a predefined color from one of the available color palettes.

Thickness

Specifies the thickness of the line.

Transparency

Sets the transparency of a line. Figure 83 is an example of the effects of different 
percentages in transparency levels to lines when placed over an object.

Arrow Styles

This section is only applicable to individual lines and is not used for lines that are the 
borders of an object.

Start style

Select from the drop-down list an arrow style or arrowhead for the start of a line.
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Figure 83: Example of line transparencies

Figure 84: Example of arrow endings

(1) Default ending (2) Centered ending

End style

Select from the drop-down list an arrow style or arrowhead for the end of a line.

Width

Specifies the thickness of the arrow endings.

Center

Moves the center of the arrow endings to the end point of the line. Figure 84 is an 
example of the effects of selecting this option.

Synchronize ends

Makes the two line ends identical.

Corner and Cap Styles

Determines how the connection between two segments of a line looks. To appreciate the 
difference between these styles, choose a thick line style and observe how the preview 
changes.

Corner style

Select the shape to be used at the corners of the line. For a small angle between lines, 
a mitered shape is replaced with a beveled shape.

Cap style

Select the style of the line end caps. The caps are added to inner dashes as well.

Line shadows
The Shadow page of the Line dialog (Figure 85) provides options to add and format a shadow 
for a selected line. The settings on this dialog page are also used for shadows applied to other 
objects. See “Working with shadows” on page 107 for more information.

To quickly apply a shadow to a line, click on Shadow on the Line and Filling toolbar. Using the 
Shadow tool creates a shadow using the settings from the Shadow page of the Line dialog.
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Figure 85: Line dialog — Shadow page

Figure 86: Line dialog — Line Styles page
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Line styles
When creating several lines in a drawing with the same format, using line styles reduce the 
requirement of formatting individual lines. LibreOffice includes line styles for use drawings. Line 
styles can be created, saved, or deleted. The Line Styles page in the Line dialog (Figure 86) 
provides the options for using LibreOffice line styles and for creating, or changing line styles.

Creating line styles

1) Create a line in a drawing.

2) Open the Line dialog using one of the following methods:

– Go to Format > Line on the Menu bar.

– Right-click on the line and select Line from the context menu.

3) Click on Line Styles in the Line dialog to open the Line Styles page.

4) In the Line style drop-down list, select a pre-defined line style to use as a starting point 
for creating a line style. An example of the line style appears in the box at the bottom of 
the dialog page. This example changes as changes are made to a line style.

5) In the Type drop-down menus, select either Dots or Dash.

– For one line type, select the same type in both Type boxes.

– For alternate line types within a single line, select different types in each Type box.

6) In the Number boxes, specify the number of dots or dashes selected in Type. For 
different sized groups of dots or dashes, set a different quantity in each Number box.

7) In the Length boxes, specify the Dash length as a percentage of the line. The Length 
option is not available for Dots.

8) In the Spacing box, specify the spacing between the dashes and/or dots as a percentage 
of the line. The Spacing option is not available if the option Fit to line width is selected.

9) If required, select Fit to line width so that the new style fits the line width when used in a 
drawing.

10) For the current document only, create a new line style, or modify a line style as follows:

a) Click on Add or Modify to open the Name dialog.

b) Enter a unique name for the new or modified line style.

c) Click on OK to save the new or modified line style and close the Name dialog.

11) Click on OK to close the Line dialog and the new line style is ready for use in the current 
drawing only.

Notes

To use the new or modified line style in other drawings, the line style must be saved 
using Save Line Styles.

When creating or modifying line styles, it is recommended to use a unique name for 
the line style. This prevents a LibreOffice line style from being overwritten and 
causing formatting problems in other drawings or documents that use LibreOffice line 
styles.

Saving line styles

1) Create a new line style, but do not close the Line dialog.
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2) Click on Save Line Styles on the Line Styles page to open a file browser window at the 
correct location for saving line styles.

3) Enter a unique filename using the file extension SOD for the line style in the Name box.

4) Click on Save to save the line style and close the file browser window. The new line style 
is now available for use in new drawings and documents.

Importing line styles

LibreOffice line styles are installed during the installation of LibreOffice. Compatible line styles 
can also be imported and used in LibreOffice. Any line styles added to LibreOffice must use the 
file extension SOD for the style to be recognised by LibreOffice.

1) Create a line in a drawing.

2) Open the Line dialog and click on Line Styles to open the Line Styles page.

3) Click on Load Line Styles at the bottom right of the Line Styles page to open a file 
browser window at the correct location for line styles.

4) Select a style from the list of saved styles in the file browser window. The file extension 
for line styles is SOD.

5) Click Open to load the line style into LibreOffice. The line style becomes available for 
other LibreOffice drawings and documents.

6) Click OK to close the Line dialog and save any changes made.

Deleting line styles

1) Open the Line dialog and click on Line Styles to open the Line Styles page.

2) Select the line style for deletion from the Line style drop-down list.

3) Click on Delete and confirm the deletion by clicking on Yes in the confirmation dialog.

4) Click OK to close the Line dialog and save any changes made.

Note

When deleting line styles, make sure the line style is not used in another document. 
It is recommended to only delete line styles that have been created, or imported. DO 
NOT delete LibreOffice line styles. This prevents any formatting problems in other 
documents where a LibreOffice line style has been used.

Arrow styles
Use the Arrow Styles page (Figure 87) in the Line dialog to create new arrow styles, modify 
existing arrow styles, or load previously saved arrow styles.

Creating arrow styles

Any shape can be used as an arrowhead, but the shape must be convertible to a curve. A curve 
is something drawn without lifting a pencil. For example, a star can be converted to a curve, but 
a smiley face cannot.

1) Select a shape, or create a shape that can be converted to a curve for use as a new 
arrowhead. The part of the shape that is going to be point of the arrowhead must be at 
the top of the shape.
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Figure 87: Line dialog — Arrow Styles page

Figure 88: Example of creating an arrowhead

2) Select the shape and convert to a curve using one of the following methods:

– Right-click on the shape and select Convert > To Curve from the context menu.

– Go to Shape > Convert > To Curve on the Menu bar.

3) With the shape selected, open the Arrow Styles page in the Line dialog.
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4) Click on Add and type a unique name for the new arrow style in the Name dialog that 
opens, then click OK. The new arrowhead style is displayed in the preview box of the 
Line dialog and is listed the bottom of the Arrow style drop-down list.

5) Click OK to save the changes and close the Line dialog. The new arrow style is available 
only in the current document.

Notes

The point in an arrowhead being created must be positioned at the top of the shape. 
If necessary, rotate the shape until the point is at the top of the shape as shown in 
Figure 88.

Some shapes cannot be used as an arrowhead. This is indicated by rectangular 
blocks appearing at each end of the line in the preview box on the Line Styles page 
in the Line dialog.

When creating an arrow style, it is recommended to use a unique name for the arrow 
style. This prevents one of the LibreOffice arrow styles from being overwritten and 
causing formatting problems in other drawings that use the LibreOffice arrow styles.

The new arrow style created is available only for use in the current drawing. To use 
the new arrow style in other drawings, the arrow style must be saved using the Save 
Arrow Styles option.

Saving arrow styles

1) Create a new arrow style as described in “Creating arrow styles” on page 86, but do not 
close the Line dialog.

2) Click on the Save arrow styles icon on the Arrow Styles page to open a file browser 
window at the correct location for saving arrow styles.

3) Enter a unique filename using the file extension SOE for the arrow style.

4) Click on Save to save the arrow style and close the file browser window. The new arrow 
style is now available for use in new documents.

Importing arrow styles

LibreOffice provides standard arrow styles when installed on a computer. However, compatible 
arrow styles can be imported and used in LibreOffice. Any arrow styles installed in LibreOffice 
must use the file extension SOE.

1) Open the Line dialog and click on Arrow Styles to open the Arrow Styles page.

2) Click on the Load arrow styles icon on the Arrow Styles page to open a file browser 
window at the correct location for arrow styles.

3) Select an arrow style from the list of saved styles in the file browser window

4) Click Open to load the arrow style into the drawing. The arrow style also becomes 
available for other LibreOffice documents.

5) Click OK to close the Line dialog and save any changes made.

Deleting arrow styles

1) Open the Line dialog and click on Arrow Styles to open the Arrow Styles page.

2) Select the arrow style for deletion from the Arrow style drop-down list.

3) Click on Delete and confirm the deletion by clicking on Yes in the confirmation dialog that 
opens.
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4) Click OK to close the Line dialog and save any changes made.

Note

When deleting arrow styles, make sure the arrow style is not used in another 
document. It is recommended to only delete arrow styles that have been created, or 
imported. Do not to delete one of the LibreOffice predefined arrow styles to prevent 
formatting problems in other documents using LibreOffice arrow styles.

Area fills

Area fill refers to the inside of an object that has an unbroken border, for example a rectangle, 
circle, star, pentagon and so on. An area fill can be None, Color, Gradient, Image, Pattern, or 
Hatch, as shown by the examples in Figure 89. Also, an area fill can be partly or wholly 
transparent and throw a shadow.

The Area dialog provides tools and options for selecting and editing area fills. Area fills are also 
available in drop-lists in the Area panel in the Properties deck on the Sidebar and in Area 
Style/Filling on the Line and Filling toolbar, but have reduced options and different fill types.

Area dialog formatting
1) Make sure the object is selected in a drawing.

2) Open the Area dialog (Figure 90) using one of the following methods:

– Go to Format > Area on the Menu bar.

– Click on Area in the Line and Filling toolbar.

– Right-click on the selected object and select Area from the context menu.

– Click on More Options on the right of the Area panel title on the Sidebar.

Figure 89: Example of area fill types

(1) None
(2) Color

(3) Gradient
(4) Image

(5) Pattern
(6) Hatch
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Figure 90: Area dialog — Area Color page

3) Click on Area to open the Area page. 

4) Select the type of area fill from the available options (None, Color, Gradient, Image, 
Pattern, or Hatch).

5) Select the required area fill options that become available for each type of area fill 
selected.

6) Click OK to close the Area dialog and save the changes to the area fill.

Sidebar formatting
1) Make sure an object with an area fill is selected in a drawing.

2) Click on Properties on the Sidebar, then click on the down chevron ˅ on the left of the 
Area panel titlebar to open the Area panel (Figure 91).

3) Select a fill type (None, Color, Gradient, Hatching, Bitmap, or Pattern) from the Fill: 
drop-down list.

4) Select a fill effect from the options available for each fill type from the Fill: drop-down list.

5) If required, select a transparency type and a transparency percentage from the 
Transparency drop-down lists.

6) Deselect the object to save the changes to the area fill.
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Figure 91: Area panel in Properties deck on Sidebar

Note

The type of transparency effect selected for an area fill changes the options available 
for a transparency in the Area panel on the Sidebar.

Line and Filling toolbar formatting
1) If Line and Filling toolbar (Figure 80 on page 80) is not open, go to View > Toolbars > 

Line and Filling on the Menu bar.

2) Select an object so that the selection handles are displayed.

3) Select a fill type (None, Color, Gradient, Hatching, Bitmap, or Pattern) from the Area 
Style/Filling drop-down list.

4) Select a fill effect from the options available for each fill type from the drop-down list. The 
fill effects available change for each fill type selected.

5) Deselect the object to save the changes to the area fill.
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Working with area fills

Note

The following instructions for area fills use the Area dialog as the main method of 
selecting and editing an area fill. The tools and options available in the Area panel in 
the Properties deck on the Sidebar and on the Line and Filling toolbar are similar, but 
have reduced options and different names.

Color fills

Selecting color fill

1) Make sure the object is selected in a drawing.

2) Open the Area page on the Area dialog (Figure 90 on page 90), then click on Color to 
open the options available for a color fill.

3) In Colors, select the required palette from the available options in the Palette drop-down 
list.

4) Click on the color required in the selected palette. All color fills available are solid colors. 
The Active preview box shows the present color fill of a selected object. After selecting a 
color, a preview of the selected color appears in the New preview box.

5) Alternatively, use one of the following methods to select a color.

– Enter the individual RGB values, on a 0 to 255 scale, in the appropriate text box.

– Enter the Hex number of a color in the Hex text box.

– If a color has been used before, then select the required color from the colors available 
in Recent Colors.

6) To revert back to the original color, click on Reset to remove any changes made.

7) Click OK to close the Area dialog and save the changes.

Creating custom colors using Area dialog

1) Select a filled object to create a color.

2) Open the Area dialog and click on Area to open the Area page, then click on Color to 
open the options available for a color fill.

3) Create a custom color using one of the following methods:

4) Specify the values of Red (R), Green (G), and Blue (B) on a 0 to 255 scale.

5) Click on Pick to open the Pick a Color dialog (Figure 92), see “Creating custom colors 
using Pick a Color dialog” below.

6) Click on Add in Custom Palette and enter a name for the color in the Name dialog that 
opens.

7) Click OK to close the Name dialog and the color is added to Custom Palette.

8) Click OK to close the Area dialog and save the changes. The new custom color appears 
as a fill in the selected object and is available for use in other drawings or documents.

Creating custom colors using Pick a Color dialog

1) Select a filled object to create a color.
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Figure 92: Pick a Color dialog

2) Open the Pick a Color dialog (Figure 92) using one of the following methods:

– Click on Pick on the Color page of the Area dialog.

– Click on the triangle ▼ next to Fill Color in the Area panel of the Properties deck on 
the Sidebar and select Custom Color.

– Click on the triangle ▼ next to Fill Color on the Line and Filling toolbar and select 
Custom Color.

3) Create a custom color using one of the following methods.

– Select a color range from the colored bar, then, using the cursor, move the target in 
the colored box until the cursor is on the color required.

– Enter values for Red (R), Green (G), and Blue (B) in the RGB text boxes.

– Alternatively, if known, enter the Hex# number in the text box. Hex numbers are 
normally used when a specific color has been created for a company logo or company 
name.

– Alternatively, enter values for Hue (H), Saturation (S), and Brightness (B) in the HSB 
text boxes. HSB values do not change the color, but how a color looks.

– Alternatively, enter values for Cyan (C), Magenta (M), Yellow (Y), and Key (K) (black) 
in the CMYK text boxes.

Note

A preview of the color being created is shown on the left side of the original color box 
below the color selection box. Changing one set of color values also changes the 
color values in the other sets of color values.
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4) Click OK to close the Pick a Color dialog and save the changes.

5) Click on Add in Custom Palette and enter a name for the color in the Name dialog that 
opens.

6) Click OK to close the Name dialog and the color is added to Custom Palette.

7) Click OK to save the changes and close the Area dialog. The new color appears as a fill 
in the selected object and is available for use in other drawings or documents.

Deleting custom colors

1) Select a filled object that uses the color fill for deletion.

2) Open the Area dialog using one of the following methods:

– Go to Format > Area on the Menu bar.

– Right-click on the object and select Area from the context menu.

– Click on More Options on the right of the Area panel title on the Sidebar.

3) Click on Area, then click on Color to open the Color page.

4) In Colors, select Custom from the Palette drop-down list.

5) Select the color for deletion and click on Delete. There is no confirmation given when 
deleting a color.

6) Click OK to save the changes and close the Area dialog.

Note

Only custom colors available in the custom palette can be deleted using the Area 
dialog. Colors available in the default LibreOffice color palettes cannot be deleted.

Gradient fills
Several predefined gradients are included when LibreOffice is installed. It is recommended to 
create custom gradients that match requirements rather than modifying any predefined 
gradients. Predefined gradients may have been used in other objects in a drawing or other 
documents.

Custom gradients are saved with a unique name allowing the custom gradient to be used in 
other drawings or documents. Custom gradients are placed at the end of the gradients displayed 
in the Gradient box on the Gradient page of the Area dialog (Figure 93).

Selecting gradient fills

The following procedure to select a gradient for an area fill uses the Area dialog. Using the tools 
on the Line and Filling Toolbar, and the Area panel in the Properties deck on the Sidebar is a 
similar procedure, but the available options are reduced.

1) Make sure the object to be filled is selected in a drawing.

2) Open the Area dialog and click on Area to open the Area page, then click on Gradient to 
open the options available for a gradient fill.

3) In Gradient, select the required gradient from the list of available gradients and the 
gradient appears in Preview.
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Figure 93: Area dialog — Area Gradient page

4) To override the default gradient transition of a selection, deselect Automatic in Options 
and then enter the values for Type, Increment, Center, Angle, Border, From Color and To 
Color to modify the gradient to the requirements. As changes are made, the gradient 
displayed in Preview also changes indicating how the gradient will look. For more 
information on gradient options, see Table 7: Gradient options.

5) Click OK to close the Area dialog and save the changes. The gradient area fill then 
appears in the selected object.

Note

Selecting and modifying a gradient only allows the gradient to be used in the drawing 
being created. If a modified gradient is to be used in other drawings or documents, 
then create a custom gradient and save it with a unique name. See “Creating custom
gradients” on page 96.

Table 7: Gradient options

Gradient property Meaning

Linear gradient
The color transitions from the starting color to the end color in a straight 
line.

Axial gradient
The color transitions from the starting color to the end color from the 
object center to the object edges in two opposite directions.
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Gradient property Meaning

Radial gradient
The color transitions from the starting color to the end color in a circular 
pattern.

Ellipsoid gradient
The color transitions from the starting color to the end color in an 
elliptical pattern.

Quadratic gradient
The color transitions from the starting color to the end color from the 
object edges to the object center in four directions.

Square gradient
The color transitions from the starting color to the end color from the 
object edges to the object center in a square pattern.

Increment
Enter the number of steps for blending the two colors of the gradient. 
By default this is set to Automatic.

Center X
For Radial, Ellipsoid, Square and Rectangular gradients, modify these 
values to set the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Square and Rectangular gradients, modify these 
values to set the vertical offset of the gradient center.

Angle For all gradient types, modifies the angle of the gradient axis.

Border
Increase this value to make the gradient start further away from the 
border of the shape.

From Color
The start color for the gradient. In the edit box enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.

To Color
The end color for the gradient. In the edit box enter the intensity of the 
color: 0% corresponds to black, 100% to the full color.

Creating custom gradients

To use a modified gradient in other drawings or documents, a custom gradient has to be saved 
with a unique name.

1) Make sure the object is selected in a drawing.

2) Open the Area dialog and click on Area to open the Area page, then click on Gradient to 
open the options available for a gradient fill.

3) Select a gradient and modify it using the options given in  Table 7: Gradient options. As 
changes are made, the gradient displayed in Preview also changes indicating how the 
modified gradient looks.

4) Click on Add to open a Name dialog.

5) Enter a unique name for the new gradient, then click OK to close the Name dialog. The 
custom gradient is placed at the end of the gradients displayed in Gradient and 
becomes available for use in other drawings and documents.

6) Click OK to close the Area dialog and save the changes.

Modifying custom gradients

1) Make sure the object is selected in a drawing.

2) Open the Area dialog and click on Area to open the Area page, then click on Gradient to 
open the options available for a gradient fill.

3) Select a custom gradient in Gradient. Custom gradients appear below the predefined 
gradients in Gradient.
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4) Enter the new values for the gradient options that need to be changed. See  Table 7: 
Gradient options for more information on gradient options. Depending on the type of 
gradient selected, some options may not be available.

5) If necessary and to revert back to the original gradient, click on Reset and any changes 
made are removed.

6) Click on Modify to permanently change the selected custom gradient. There is no 
confirmation given when modifying a custom gradient.

7) Click OK to close the Area dialog and save the changes.

Note

Using the Modify option on the Gradient page in the Area dialog permanently 
changes a gradient and cannot be undone. It is recommended to only modify custom 
gradients and not the default LibreOffice gradients.

Renaming gradients

1) Select the object that uses the gradient that is going to be renamed.

2) Open the Area dialog and click on Area to open the Area page, then click on Gradient to 
open the options available for a gradient fill.

3) Right-click on the gradient and select Rename from the context menu.

4) Enter a name for the gradient in the Name dialog that opens.

5) Click OK save the change and close the Name dialog.

6) Click OK to save the changes and close the Area dialog.

Deleting custom gradients

1) Select an object that uses a gradient fill.

2) Open the Area page on the Area dialog, then click on Gradient.

3) In the Gradient box, select the custom gradient for deletion.

4) Right click on the gradient and select Delete from the context menu.

5) Click on Yes to confirm the deletion.

6) Click OK to save the changes and close the Area dialog.

Note

It is recommended to only rename or delete custom gradients that have been 
created. Deleting or renaming a predefined gradient that is installed with LibreOffice 
may cause problems in drawings and documents that use one of the gradients.

Advanced gradient controls

LibreOffice provides advanced gradient controls on the Transformations toolbar (Figure 94).

1) Make sure the object is selected in a drawing.

2) Open the Area page on the Area dialog, then click on Gradient.

3) Go to View > Toolbars > Transformations on the Menu bar, or click on 
Transformations in the Line and Filling toolbar to open the Transformations toolbar.
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Figure 94: Transformations toolbar

Figure 95: Example of using interactive gradient tool

4) Click on Interactive gradient tool in the Transformations toolbar. This displays a dashed 
line connecting two colored squares (Figure 95) filled with colors in the From Color and 
To Color being used for the selected gradient.

5) Select the type of gradient required for the object from the options in the Type drop-down 
list. Properties available for adjustment depend on the gradient type selected, as 
explained below. Moving the squares has different effects depending on gradient type, 
see Table 8: Changing gradient properties for information.

6) Click OK to save the changes and close the Area dialog.

Note

Moving the squares creates different effects depending on the type of gradient. For 
example, for a linear gradient, the start and end squares of the gradient are always 
situated either side of the center point of the object.

Table 8: Changing gradient properties

Gradient type Changing gradient properties

Linear
Move From Color square to change where the gradient starts (border value). 
Move To Color square to change the orientation (angle value).

Axial
Move To Color square to change both the angle and border properties of the 
gradient. Only the To Color square can be moved.

Radial
Move From Color square to modify the border property to set the width of the 
gradient circle. Move To Color square to change the point where the gradient 
ends (Center X and Center Y values).

Ellipsoid
Move From Color square to modify the border property to set the size of the 
gradient ellipsoid. Move To Color square to change the angle of the ellipsoid 
axis and the axis itself.

Quadratic
Move From Color square to modify the border property to set the size of the 
gradient square or rectangle and the angle of the gradient shape. Move To 
Color square to change the center of the gradient.

98 |Draw Guide 24.8



Gradient type Changing gradient properties

Square
Move From Color square to modify the border property to set the size of the 
gradient square or rectangle and the angle of the gradient shape. Move To 
Color square to change the center of the gradient.

Image fills
Several predefined images are included when LibreOffice is installed on a computer. The content 
of the supplied images cannot be edited, but the display settings can be changed. Also, images 
can be imported from other sources.

Selecting images

The following procedure to select an image for an area fill uses the Image page of the Area 
dialog (Figure 96). Using the tools on the Line and Filling Toolbar, and the Area panel in the 
Properties deck on the Sidebar is a similar procedure, but available options are reduced.

1) Make sure the object is selected in a drawing.

2) Open the Area dialog and click on Area to open the Area page, then click on Image to 
open the options available for an image fill.

3) In Image, select the required image from the list of available images and it appears in 
Preview. Alternatively, click on Add/Import to open a file browser window, then select a 
file to use as an image fill.

Figure 96: Area dialog — Area Image page
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4) If necessary, change the values in Style, Size, Position, Tiling Position, and Tiling Offset 
to modify the image. For more information on image options, see Table 9: Image options.

5) If necessary and to revert back to the original image, click on Reset and any changes 
made are removed.

6) Click OK to close the Area dialog and save the changes. The image fill then appears in 
the selected object.

Table 9: Image options

Bitmap option Meaning

Style — Custom position/size
When this option is selected, the position and size of the 
image in the object can be specified.

Style — Tiled
When this option is selected, the image is tiled to fill the area. 
The size of the image used for the tiling is determined by the 
Size settings

Style — Stretched
When this option is selected, an image is stretched to fill the 
object area.

Size — Width
Sets the width of the image. For example, 100% means that 
the image is resized to occupy the whole fill area width, 50% 
means that the width of the image is half that of the fill area.

Size — Height
Sets the height of the image. For example, 100% means that 
the image is resized to occupy the whole fill area height, 50% 
means that the height of the image is half that of the fill area.

Size — Scale
When selected, image size is given as a percentage for Width 
and Height. When deselected, the actual size of the image is 
given for Width and Height.

Position Specifies the anchoring point of the image.

Tiling Position — X-Offset

Sets the offset for the width of the image in percentage values. 
50% offset means that LibreOffice Draw places the middle part 
of the image width at the anchor point and start tiling from 
there.

Tiling Position — Y-Offset

Sets the offset for the height of the image in percentage 
values. 50% offset means that LibreOffice Draw places the 
middle part of the image height at the anchor point and start 
tiling from there.

Tiling Offset
Offsets the columns of tiled images by the percentage entered 
in the box so that two subsequent columns of images are not 
aligned.

Editing images

1) Select an object for editing that contains an image as a fill, or insert an image into a 
selected object

2) Open the Area dialog and click on Area to open the Area page, then click on Image to 
open the options available for an image fill.

3) Select an image from the options available in Image to use and edit as a fill. Note that 
imported images are also available. The selected image appears in Preview.

4) Change the values for Style, Size, Position, Tiling Position, and Tiling Offset to the 
requirements. For more information on image options, see Table 9: Image options. 
Examples of image or bitmap fills and the properties used are shown in Figure 97.
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Figure 97: Examples of image fill

(1) Original image.
(2) Width/height 25% scaled. Anchor top left corner. No offset.
(3) Width/height 25% scaled. Anchor top right. Row offset 50%.

5) If necessary and to revert back to the original image, click on Reset and any changes 
made are removed.

6) Click OK to save the changes and close the Area dialog.

Note

Supplied images cannot be edited, but the display settings for placement and tiling 
can be changed.

Importing images

1) Select an object to import an image into the object.

2) Open the Area dialog and click on Area to open the Area page, then click on Image to 
open the options available for an image fill.

3) Click on Add/Import and a file browser window opens.

4) Navigate to the directory containing the image file, then select the file and click Open.

5) Enter a unique name for the new image in the Name dialog that opens, then click OK to 
close the Name dialog. The imported image appears at the bottom of the images 
displayed in Image.

6) Select the imported image in Image.

7) Click OK to save the changes and close the Area dialog. The imported image fill appears 
in the selected object.

Renaming images

1) Select an object to import an image into the object.
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2) Open the Area dialog and click on Area to open the Area page, then click on Image to 
open the options available for an image fill.

3) Right-click on the selected image and select Rename from the context menu.

4) Enter a new name for the image in the Name dialog that opens.

5) Click OK to save the change and close the Name dialog.

6) Click OK to save the changes and close the Area dialog.

Deleting images

1) Make sure the object containing an image fill is selected in a drawing.

2) Open the Area page on the Area dialog, then click on Image.

3) Right click on the selected image being deleted, then select Delete from the context 
menu.

4) Click on Yes to confirm the deletion.

5) Click OK to save the changes and close the Area dialog.

Note

It is recommended to only rename or delete images that have been created or 
imported. Renaming or deleting images installed with LibreOffice may cause 
problems in documents that uses one of these images.

Pattern fills
Several LibreOffice pattern fills are installed during a LibreOffice installation. Custom patterns 
can also be created and modified in LibreOffice.

Selecting pattern fills

The following procedure selects a pattern for an area fill using the Area dialog. The tools on the 
Line and Filling Toolbar, and the Area panel in the Properties deck on the Sidebar have a similar 
procedure, but the available options are reduced.

1) Make sure the object is selected in a drawing.

2) Open the Area dialog and click on Area to open the Area page, then click on Pattern to 
open the options available for a pattern fill (Figure 98).

3) In Pattern, select the required pattern and the selected pattern appears in Preview.

4) changes are made, the pattern displayed in Preview also changes indicating how the 
pattern will look. Any changes will affect only the object being filled.

5) If necessary and to revert back to the original pattern, click on Reset and any changes 
made are removed.

6) Click OK to close the Area dialog and save the changes. The pattern fill then appears in 
the selected object.

Creating custom patterns

1) Make sure the object containing a pattern fill is selected in a drawing.

2) Open the Area dialog and click on Area to open the Area page.

3) Select the required pattern in Pattern to use as a starting point and the selected pattern 
appears in Preview.
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Figure 98: Area dialog — Area Pattern page

4) In Options, select a color from the available color palettes for the Foreground Color and 
Background Color. The pattern remains the same, but the colors change.

5) In Pattern Editor, click on individual squares to change the color from Foreground Color 
to Background Color, or from Background Color to Foreground Color creating a new 
pattern.

6) In Preview, check the pattern being created to see if the desired effect is being achieved.

7) Click on Add to open a Name dialog.

8) Enter a unique name for the new pattern, then click OK to close the Name dialog. The 
custom pattern is placed at the end of the patterns displayed in Pattern and becomes 
available for use in other drawings and documents.

9) If necessary, to revert back to the original pattern, click on Reset and any changes made 
are removed.

10) Click OK to close the Area dialog and save the changes.

Modifying custom patterns

1) Make sure the object containing a pattern fill is selected in a drawing.

2) Open the Area dialog and click on Area to open the Area page, then click on Pattern.

3) Select a custom pattern from the patterns displayed in Pattern and the selected pattern 
appears in Preview. Custom patterns are located below predefined patterns in Pattern.
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4) In Pattern Editor, click on each square to change the color from Foreground Color to 
Background Color, or from Background Color to Foreground Color modifying the selected 
pattern.

5) If necessary, to revert back to the original pattern, click on Reset and any changes made 
are removed.

6) Click on Modify to permanently change the selected custom pattern. There is no 
confirmation given when modifying a custom pattern.

7) Click OK to close the Area dialog and save the changes.

Note

To use a modified pattern in other drawings or documents, the custom pattern has to 
be saved with a unique name.

Using the Modify option on the Pattern page in the Area dialog permanently 
changes a pattern and cannot be undone. It is recommended to only modify custom 
patterns and not the LibreOffice patterns that were installed.

Renaming patterns

1) Select an object that contains a pattern, or insert a pattern into the selected object.

2) Open the Area dialog and click on Area to open the Area page, then click on Pattern to 
open the options available for a pattern fill. The selected pattern appears in Pattern 
Editor.

3) Right-click on the pattern for renaming in Preview and select Rename from the context 
menu.

4) Enter a name for the pattern in the Name dialog that opens.

5) Click OK to save the renaming and close the Name box.

6) Click OK to save the changes and close the Area dialog.

Deleting custom patterns

1) Select an object that contains a pattern, or insert a pattern into the selected object.

2) Open the Area dialog and click on Area to open the Area page, then click on Pattern to 
open the options available for a pattern fill. The selected pattern appears in Pattern 
Editor.

3) Right-click on the pattern for deletion in the Preview box and select Delete from the 
context menu.

4) Click on Yes to confirm the deletion.

5) Click OK to save the changes and close the Area dialog.

Note

It is recommended to only modify, delete or rename custom patterns that have been 
created. Modifying, deleting or renaming one of the LibreOffice patterns that are 
installed may cause problems in drawings and documents using one of the patterns.

104 |Draw Guide 24.8



Figure 99: Area dialog — Area Hatch page

Hatch fills
Hatch fills are similar to pattern fills, but use lines instead of squares. Several predefined hatch 
fills are included when LibreOffice is installed on a computer. Custom hatch fills can also be 
created and modified.

Selecting hatch fills

The following procedure to select a hatch for an area fill uses the Area dialog. Using the tools on 
the Line and Filling Toolbar, and the Area panel in the Properties deck on the Sidebar is similar, 
but the available options are reduced.

1) Make sure the object is selected in a drawing.

2) Open the Area dialog and click on Area to open the Area page, then click on Hatch to 
open the options available for a hatch fill (Figure 99).

3) Select a hatch from the options shown in Hatch and the selected hatch fill appears in 
Preview.

4) If necessary to revert back to the original hatch fill, click on Reset and any changes 
made are removed.

5) Click OK to close the Area dialog and save the changes. The hatch fill then appears in 
the selected object.
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Creating custom hatch fills

1) Make sure the object is selected in a drawing.

2) Open the Area dialog and click on Area to open the Area page, then click on Hatch to 
open the options available for a hatch fill.

3) Select the required hatch fill in Hatch as a starting point and the selected hatch fill 
appears in Preview.

4) Change the values for Spacing, Angle, Line type, Line color, and Background color to 
edit the hatch fill to the requirements. For more information on hatch fill options, see 
“Table 10: Hatch fill options”.

5) Click on Add to open a Name dialog.

6) Enter a unique name for the new hatch fill, then click OK to close the Name dialog. The 
custom hatch fill is placed at the end of the hatch fills displayed in Hatch and becomes 
available for use in other drawings and documents.

7) Click OK to close the Area dialog and save the changes. The new hatch fill appears in 
the selected object.

Table 10: Hatch fill options

Hatching option Meaning

Spacing
Determines the spacing between two lines of the hatch fill. As the value is 
changed, the preview window is updated.

Angle
Use the mini map below the numerical value to quickly set the angle 
formed by the line to multiples of 45 degrees. If the required angle is not a 
multiple of 45 degrees, enter the desired value in the edit box.

Line type Set single, double, or triple line for the style of the hatch fill.

Line color Use the list to select the color of the lines that will form the hatch fill.

Background color When selected, adds a color fill behind the lines used for the hatch fill.

Note

Using the Modify option on the Hatch page in the Area dialog permanently changes 
a hatch fill and cannot be undone. It is recommended to only modify custom hatches 
and not the LibreOffice hatches that were installed.

Modifying custom hatch fills

1) Make sure the object is selected in a drawing.

2) Open the Area dialog and click on Area to open the Area page, then click on Hatch to 
open the options available for a hatch fill.

3) Select a custom hatch fill in Hatch and the selected hatch fill appears in Preview. 
Custom hatch fills are located below the predefined hatch fills in Hatch.

4) Change the values for Spacing, Angle, Line type, Line color, and Background color to 
edit the hatch fill. For more information on hatch options, see “Table 10: Hatch fill 
options”.

5) If necessary to revert back to the original hatch fill, click on Reset and any changes 
made are removed.

6) Click on Modify to permanently change the selected custom hatch fill. There is no 
confirmation given when modifying a custom hatch fill.
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7) Click OK to close the Area dialog and save the changes.

Renaming hatch fills

1) Select the object that contains the hatch fill that is to be renamed.

2) Open the Area dialog and click on Area to open the Area page, then click on Hatch to 
open the options available for a hatch fill.

3) Right-click on the hatch fill displayed in Hatch and select Rename from the context 
menu.

4) Enter a name for the hatch fill in the Name dialog that opens.

5) Click OK to save the renaming and close the Name dialog.

6) Click OK to save the changes and close the Area dialog.

Deleting custom hatch fills

1) Select an object that uses the hatch fill for deletion.

2) Open the Area page on the Area dialog, then click on Hatch.

3) In Hatch, select the custom hatch fill for deletion.

4) Right-click on the hatch fill and select Delete from the context menu. Click on Yes to 
confirm the deletion.

5) Click OK to save the changes and close the Area dialog.

Note

It is recommended to only modify, rename or delete hatch fills that have been 
created. Modifying, renaming or deleting hatch fills that were installed with 
LibreOffice may cause problems in documents that use one of these hatch fills.

Working with shadows

Shadow options
Shadows can be applied to objects such as lines, shapes and text. The options available for 
shadows are as follows:

Position

Select one of nine points determining the direction in which the shadow is cast.

Distance or Angle

Determines the offset distance between the object and the shadow.

Color

Sets the color used for the shadow.

Blur

Sets how much the edges of a shadow are blurred or softened.

Transparency

Determines the amount of transparency for the shadow: 0% opaque shadow, 100% 
transparent shadow.
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Figure 100: Area dialog — Shadow page

Note

For more control when applying shadows, use the Shadow page in Area or Line 
dialogs. The following information uses the Shadow page in the Area dialog 
(Figure 100), but can also be applied to the Shadow page in the Line dialog and the 
Shadow panel in Properties deck on the Sidebar.

Default shadows
To quickly apply a shadow to an object, select the object and click on Shadow in the Line and 
Filling toolbar. The shadow applied to an object uses the default shadow settings in LibreOffice.

Formatting shadows
For a more control when adding shadows to an object, use the Shadow page, as follows, on the 
Area dialog and Line dialog.

1) Select an object where a shadow is going to be applied.

2) Open the Area dialog and click on Shadow to open the Shadow page (Figure 100).

3) Select Use shadow in Properties and the shadow options become active.

4) Select from one of nine points the direction in which the shadow is going to be cast in 
relation to the object.

5) In Color, select the color palette from the drop-down list of available palettes and then 
select the color required for the shadow.

6) In Distance, enter a distance to set spacing between the object and the shadow.

7) In Blur, enter a value to soften the edges of the shadow.

8) In Transparency, enter a percentage for the shadow transparency.

9) Click OK to close the Area or Line dialog and save the changes.

Sidebar shadow formatting
1) Select an object where a shadow is going to be applied.

2) Click on Properties to open the Properties deck on the Sidebar.
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Figure 101: Shadow panel in Properties deck on Sidebar

3) Click on Shadow to open the Shadow panel (Figure 101) in the Properties deck.

4) Select Enable and the shadow options become active.

5) In Angle, select from one of the options in the drop-down list to set the direction of where 
the shadow is going to be cast in relation to the object.

6) In Color, select the color palette from the drop-down list of available palettes and then 
select the color required for the shadow.

7) In Distance, enter a distance to set spacing between the object and the shadow.

8) In Blur, enter a value to soften the edges of the shadow.

9) In Transparency, move the slider or enter a percentage in the text box to set the shadow 
transparency.

10) Deselect the object to save the changes made.

Working with transparencies

Transparencies can be applied to objects and shadows. In Draw, two types of transparencies 
can be applied to an object – uniform and gradient. Transparencies can be applied to area fills, 
gradients, shadows and lines.
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Figure 102: Area dialog — Area Transparency page

• For gradient transparencies and an example of combining a color gradient with a 
gradient transparency, see “Gradient fills” on page 94.

• For line transparencies, refer to “Who is this user guide for?” on page 8 for more 
information.

• For shadow transparencies, refer to “Working with shadows” on page 107 for more 
information.

The following example procedure applies a transparency to an object area fill using the Area 
dialog (Figure 102):

1) Make sure the object is selected in a drawing.

2) Open the Area dialog, then click on Transparency to the open the Transparency page 
and access the available options.

3) To create a uniform transparency, select Transparency and enter a percentage in the text 
box.

4) To create a gradient transparency so that the area becomes gradually transparent, select 
Gradient and select the type of gradient transparency from the drop-down list: Linear, 
Axial, Radial, Ellipsoid, Quadratic, or Square. See “Table 7: Gradient options” on page 95 
for more information on gradient types.

5) Set the parameters for the type of the gradient transparency selected above. Refer to 
“Table 11: Transparency parameters” for a description of the transparency properties. 
The parameters available depends type of gradient transparency selected.

6) Click OK to close the Area dialog and save the changes.

Table 11: Transparency parameters

Transparency parameters Meaning

Centre X
For Radial, Ellipsoid, Quadratic and Square gradients. The 
values to set the horizontal offset of the gradient center.

Center Y
For Radial, Ellipsoid, Quadratic and Square gradients. The 
values to set the vertical offset of the gradient center.
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Transparency parameters Meaning

Angle
For Linear, Axial, Ellipsoid, Quadratic and Square gradients. 
Specifies the angle of the gradient axis.

Border
Increase this value to make the gradient start further away from 
the border of the object.

Start value
Value for the starting transparency gradient. 0% is fully opaque, 
100% means fully transparent.

End value
Value for the ending transparency gradient. 0% is fully opaque, 
100% means fully transparent.

Drawing styles

If the same area fill, line thickness, and border properties are to be applied to a set of objects, it 
is recommended to reduce this repetitive by using styles. Styles reduce the risk of format errors 
by allowing format to be defined and applied to multiple objects. For more information on styles, 
see the Writer Guide.

Note

The drawing styles included with Draw cannot be deleted or renamed, but can be 
modified to drawing requirements. Drawing styles can also be hidden when not being 
used in a drawing.

Style categories
All Styles

Displays all drawing styles available for use.

Applied Styles

Only displays drawing styles that have been used in the selected drawing.

Hierarchical Styles

Displays the drawing styles in a hierarchical list (also known as a linked or parent/child 
styles). To view the styles in a sub-level, click on the triangle ► or chevron > next to the 
style name listing the styles available in the sub-level, as shown in Figure 103.

Custom Styles

Displays all user created drawing styles that are available for use.

Hidden Styles

Displays all drawing styles are hidden when not required.

Tips

Hierarchical styles are used when multiple objects differ in one or two options, but 
are otherwise identically formatted. Create a parent style for the objects including 
borders, area fill, font, and so on. Then create a hierarchical or child styles, which 
differ, for example, in fill color. If the font size or the thickness of a border needs to be 
changed, it is sufficient to change the parent style and all the child styles are 
changed accordingly.

At the bottom of the Styles deck on the Sidebar there is a drop-down list allowing 
selection of a style category. The style categories available are Hierarchical, All 
Styles, Hidden Styles, Applied Styles, and Custom Styles.
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Figure 103: Styles deck in Sidebar

Selecting styles
Styles can only be selected and applied to objects using the Styles deck on the Sidebar 
(Figure 103).

1) Select the object for style application.

2) Open the Styles deck on the Sidebar using one of the following methods:

– Go to View > Sidebar on the Menu bar, then click on Styles at the right side of the 
Sidebar.

– Click on Show the Styles Sidebar on the Line and Filling toolbar.

– Go to View > Styles on the Menu bar.

– Use the keyboard shortcut F11.

3) Select a style category from the drop-down list at the bottom of the Styles deck.

4) In the Styles deck, double-click on the style required for the selected object.

5) If necessary, create a custom style, or modify the selected style to drawing requirements.
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Figure 104: Graphic Styles dialog — General page

Note

It is recommended to create custom styles rather than modify drawing styles that 
were installed with LibreOffice. Modifying the LibreOffice drawing styles may cause 
formatting problems if the style has been used in other drawings.

Creating custom styles
Custom styles are placed in All Styles and Custom Styles categories in the Sidebar Styles 
deck. When a custom style is applied to an object, the custom style appears in Applied Styles.

Using Styles deck

1) Open the Styles deck on the Sidebar.

2) Right click on the style required as a starting point to create a custom style and select 
New from the context menu to open the Graphic Styles dialog (Figure 104).

3) Click on Organizer to open the Organizer page in the Graphic Styles dialog.

4) In the Name text box, enter a unique style name.

5) In Inherit from text box, select None from the drop-down list if the new drawing style is 
NOT going to be linked. When an object is created, it uses the Default Drawing Style 
and a new drawing style is linked by default to the Default Drawing Style.

6) If the new style is to inherit settings from an existing style, select a style from the Inherit 
from: drop-down list.

7) Use the available options on the various pages of the Graphic Styles dialog to format and 
categorize a new style.

8) Click OK to save the new style and close the Graphic Styles dialog.

Using New Style from Selection

Using the option New Style from Selection all formatting is applied to an object first and then a 
new drawing style is created using the formatting changes.

1) Select an existing object, or create a new object in a drawing.

2) Format the object using the tools and options from the Graphic Styles dialog, Area 
dialog, Line dialog, Properties deck on the Sidebar, or Line and Filling toolbar.

3) Make sure the object is selected and create the new style using one of the following 
methods:
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– Open the Styles deck on the Sidebar and click on New Style from Selection at the 
top right of the deck.

– Go to Format > Styles > New Style from Selection on the Menu bar.

4) In the New Style from Selection dialog, enter a unique name for the new style. This 
dialog also shows existing custom styles.

5) Click OK to save the new style and close the New Style from Selection dialog.

Modifying styles
1) Select an object in a drawing.

2) Click on Styles on the left of the Sidebar to open the Styles deck.

3) Open the Graphic Styles dialog using one of the following methods:

– Go to Format > Styles > Edit Style on the Menu bar.

– Right-click on the object and select Edit Style from the context menu.

– Right-click on the style that is highlighted in the Styles deck on the Sidebar and select 
Modify from the context menu.

4) Use the options on the various pages of the Graphic Styles dialog to modify the style.

5) Click OK to save the changes and close the Graphic Styles dialog.

Note

It is recommended to only modify custom styles. Modifying the installed LibreOffice 
styles may cause formatting errors in other documents that uses a LibreOffice style.

Editing hierarchical or parent styles
If an object uses a style that is linked to a hierarchical or parent style, then this hierarchical or 
parent style can be edited.

1) Select an object in a drawing that uses a linked style.

2) Open the Graphic Styles dialog and click on Organizer to open the Organizer page in 
the Graphic Styles dialog.

3) Check that the style name in the Inherit from text box is the required hierarchical or 
parent style, then use the options on the various pages in the Graphic Styles dialog to 
edit the style.

4) If the hierarchical or parent style is NOT the style required:

a) Click on Edit Style to the right of the Inherit from text box until the name of the style is 
displayed.

b) Use the options on the various pages in the Graphic Styles dialog to edit the style.

5) Click OK to save the changes and close the Graphic Styles dialog.

Updating styles
Using Update Style allows all formatting to an object to be applied first and then the drawing 
style used for the object is updated.

1) Select the object to update the applied drawing style.

2) Format the object using the tools and options from the Graphic Styles dialog, Area 
dialog, Line dialog, Properties deck on the Sidebar, or Line and Filling toolbar.
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3) Update the drawing style using one of the following methods. There is no confirmation 
when updating a drawing style.

– Open the Styles deck on the Sidebar and click on Update Style at the top right.

– Go to Format > Styles > Update Selected Style on the Menu bar.

Note

Only update custom styles that have been created. Updating drawing styles installed 
with LibreOffice may create formatting errors in other documents that use LibreOffice 
drawing styles.

Applying styles
Drawing styles are applied to an object using the Styles deck on the Sidebar as follows:

1) Select the object to apply a drawing style.

2) Click on Styles on the Line and Filling toolbar, or click on Styles on the Sidebar.

3) Double click on a style name to apply the drawing style to the selected object.

Deleting styles
Drawing styles installed with LibreOffice cannot be deleted, even if the drawing styles are not 
being used. Only custom styles can be deleted.

1) To open a list of styles, use one of the following methods:

– Click on Styles on the Line and Filling toolbar.

– Click on Styles on the Sidebar.

2) Select Applied Styles from the drop-down list at the bottom of the Styles deck on the 
Sidebar.

3) Right click on the style name in the styles list and select Delete from the context menu.

4) If the style is used on an object, a warning message appears stating that the selected 
object will revert back to the default drawing style. Select Yes to confirm deletion of the 
style.

5) If the style is not in use, select Yes to confirm deletion of the style and there is no 
confirmation message.

Note

Before deleting a custom style, it is recommended to make sure the drawing style is 
not in use by checking the list of drawing styles in the Applied Styles category.

Special effects

Note

The tools on the Transformations toolbar are described in the following sections with 
the exception of the In 3-D Rotation Object tool. This tool is described in Chapter 7, 
Working with 3D Objects.
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A number of special effects can be applied to objects in Draw. Several of these effects are 
readily available on the Transformations toolbar. If the Transformations toolbar (Figure 94 on 
page 98) is not open, go to View > Toolbars > Transformations on the Menu bar and select 
Transformations.

Rotating objects

Note

By default, the rotation pivot point is a small circle in the center of the selected 
object. To change the center of object rotation, click and drag the rotation pivot point 
to a new position. The rotation pivot point can be positioned outside of the selected 
object.

Manual rotation

1) Select an object for rotation so that the selection handles are displayed.

2) Use one of the following methods to switch the selected object into rotation mode. The 
selection handles change shape and color when in rotation mode (Figure 105).

– Click again on the selected object.

– Click on the triangle ▼ to the right of Transformations on the Line and Filling and 
select Rotate from the context menu.

– If the Transformations toolbar is open, click on Rotate.

3) Move the cursor over one of the corner handles and the cursor changes shape. Only 
corner selection handles are active for rotation.

4) Click and drag on a corner selection handle to rotate the selected object.

5) To restrict the rotation angles to multiples of 15 degrees, press and hold the Shift key 
while rotating the object. This is useful for rotating objects through 90 deg.

6) When satisfied with the rotation, release the corner selection handle.

Rotation using Sidebar

1) Select the object for rotation so that the selection handles are displayed.

Figure 105: Example of manual rotation
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Figure 106: Position and Size panel in Properties deck on Sidebar

2) Open the Position and Size panel in the Properties deck on the Sidebar (Figure 106).

3) Rotate the object using one of the following options:

– Click on and drag the Rotation Angle indicator in Rotation.

– Enter a rotation angle in the Select the angle for rotation text box.

4) After rotating the object, click outside the object to deselect the object and save the 
changes.

Position and Size dialog

1) Select the object for rotation so that the selection handles are displayed.

2) Open the Position and Size dialog (Figure 107) using one of the following methods:

– Use the keyboard shortcut F4.

– Select Format > Position and Size on the Menu bar.

– Right-click on the object and select Position and Size from the context menu.
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Figure 107: Position and Size dialog — Rotation page

3) Click Rotation to open the Rotation page.

4) If required, in Pivot Point enter a value for Position X and Position Y to move the 
position of the pivot point. The default position of the pivot point is the center of the 
object. Alternatively, select a pivot point from one of the 9 positions in Default settings.

5) In Rotation Angle, rotate the object using one of the following methods:

– In the Angle text box, enter the degrees of rotation required.

– Click on and drag the rotation indicator in Default settings.

6) Click OK to save the changes and close the Position and Size dialog.

Flipping objects

Quick flipping

1) Select the object for flipping to display the selection handles.

2) Use one of the following methods to flip the object vertically or horizontally:

– Right click on the object and select Flip > Horizontally or Flip > Vertically from the 
context menu.

– In Flip on the Position and Size panel in the Properties deck on the Sidebar 
(Figure 106 on page 117), click on Flip Vertically or Flip Horizontally.

– In the Line and Filling toolbar, click on Vertically or Horizontally.

– Go to Shape > Flip > Vertically or Horizontally on the Menu bar.

Flip tool

Using Flip on the Transformations toolbar (Figure 94 on page 98), the position and angle that 
the object flips over can be changed, as shown by the example in Figure 108.

1) Select the object for flipping to display the selection handles.
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Figure 108: Example of using Flip tool

(1) Flip selected (2) Symmetry axis moved (3) Flip result

2) Click on Flip on the Transformations toolbar and the symmetry axis appears as a dashed 
line through the middle of the object. The object is flipped about this symmetry axis.

3) Click and drag one or both ends of the symmetry axis setting the axis orientation.

4) Place the cursor over one of the object selection handles until it changes shape.

5) Click and hold the selection then drag the object across to the other side of the symmetry 
axis until the object appears flipped over. The angle and position of the flip depends on 
the angle and position of the symmetry axis.

6) Release the selection handle and the object is flipped.

Note

Pressing and holding the Shift key while moving the symmetry axis allows rotation 
in 45 degree increments.

Mirror copies
At the moment there is no mirror command available in LibreOffice Draw. However, mirroring an 
object can be emulated by copying and flipping the object as follows:

1) Select the object to copy the object to the clipboard.

2) Flip the object using the procedures in “Flipping objects” on page 118.

3) Click in an empty area on the drawing to deselect the object.

4) Paste the copy of the original object back into its original location creating a mirror copy.

5) If necessary, select both objects and align them using one of the following methods:

– Go to Shape > Align on the Menu bar and use one of the alignment options.

– Right-click the selected objects and select Align from the context menu, then select 
one of the alignment options.

Distorting images
Three tools on the Transformations toolbar (Figure 94 on page 98) allow an object to be 
distorted.

• Distort — distorts an object in perspective.

• Set to circle (slant) and Set in Circle (perspective) — both create a pseudo 3D effect.
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Figure 109: Example of using Set In circle (perspective) tool

(1) Original obect (2) Set in Circle (perspective) distortion

Figure 110: Example of using Set in circle (slant) tool

(1) Original obect (2) Set in circle (slant) distortion

Note

Before distorting an object, the object must be converted to a curve. Transforming an 
object into a curve is a safe operation, but cannot be reversed. To cancel the curve 
conversion, click on Format > Undo on the Menu bar.

Set in circle (perspective)

An example of distorting an object using Set in Circle (perspective) is shown in Figure 109.

1) Select an object and click on Set in Circle (perspective) on the Transformations toolbar.

2) Click Yes to convert the object to a curve. If the object is already a curve, this dialog 
does not appear.

3) Click and drag one of the selection handles to give a pseudo 3D perspective using the 
opposite side as an anchor point. A ghosted image appears as the object is distorted to 
give an indication of how the resulting object will look.

Set to circle (slant)

An example of distorting an object using Set to circle (slant) is shown in Figure 110.

1) Select an object and click on Set to circle (slant) on the Transformations toolbar.

2) Click Yes to convert the object to a curve. If the object is already a curve, this dialog 
does not appear.

3) Click and drag one of the selection handles to give a pseudo 3D perspective using the 
opposite side as an anchor point. A ghosted image appears as the object is distorted to 
give an indication of how the resulting object will look.
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Figure 111: Example of using Distort tool

(1) Original object
(2) Corner distortion

(3) Vertical distortion
(4) Horizontal distortion

Distort

Examples of distorting an object using Distort are shown in Figure 111.

1) Select an object and click on Distort on the Transformations toolbar.

2) Click Yes to convert the object to a curve. If the object is already a curve, this dialog 
does not appear.

3) Click and drag a corner selection handle to distort the object using the opposite corner 
selection handle as an anchor point for the distortion.

4) Click and drag the vertical selection handles to distort the object using the opposite 
vertical side as an anchor point for the distortion.

5) Click and drag the horizontal selection handles to distort the object using the opposite 
horizontal side as an anchor point for the distortion.

Dynamic gradients
Transparency gradients are controlled using the same procedure for color gradients and both 
types of gradient are used together. With a transparency gradient, the direction and degree of 
object fill color changes from opaque to transparent. In a color gradient, the fill changes from one 
color to another, but the degree of transparency remains the same.

Two icons on the Transformations toolbar dynamically control transparency and color gradients. 
Even if an object with a color fill is not assigned transparency, the transparency can be controlled 
by clicking on Interactive transparency tool. This defines a transparency gradient and a 
dashed line connecting two squares appears on the object. Move the two squares to modify the 
gradient. Define the direction of the gradient (vertical, horizontal, or at any angle) and the spot at 
which the transparency begins.
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Figure 112: Example of using Dynamic Gradient tool

A regular color gradient is defined in the same manner. Select an object, then select a gradient 
area fill (see “Gradient fills” on page 94 for more information). The Interactive gradient tool is 
now active on the Transformations toolbar. When clicking on Interactive gradient tool, a 
dashed line connecting two squares appears on the object, just as it does for a transparency 
gradient. In both transparency gradient and gradient fill, click outside the object to set the 
gradient.

In the example shown in Figure 112 a gradient transparency is dynamically adjusted. Direction of 
transparency is changed by moving the white square and the distance over which it is applied by 
moving the colored square.

Note

Moving the squares has different effects, depending on the type of gradient. For 
example, for a linear gradient, the start and end squares of the gradient are always 
situated on either side of the center point of the object.
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Grouping objects

Grouping of objects is similar to placing objects into a container. Objects within a group are 
moved together as one object and any changes made are applied to all objects within the group. 
A group can be ungrouped and the objects that make up the group can be manipulated 
separately.

Temporary grouping
A temporary grouping is when several objects are selected together. Any changes to object 
parameters are applied to all objects within the temporary group. For example, a temporary 
group of objects can be rotated in its entirety. A temporary group is created using one of the 
following methods:

• Click and drag the cursor over several objects surrounding the objects with a selection 
rectangle. This selection rectangle is also known as a marquee, as shown in Figure 113. 
Release the cursor when all the objects required for a temporary group are selected.

• Click the first object, then hold down the Shift key and click on the remaining objects 
required for a temporary group.

• To cancel a temporary group of objects, simply click outside of the selection handles 
displayed around the objects.

Grouping
When objects are grouped, any editing carried out on a group is applied to all objects within the 
group. Click on one object in a group selects the whole group. Objects within a group retain their 
individual properties and can be edited independently. See “Editing individual objects in a group” 
on page 125 for more information.

1) Select objects for a group using one of the following methods. Selection handles appear 
around all objects selected for the group (Figure 114).

– Click on each object required while holding down the Shift key.

– Select Select on the Drawing toolbar and draw a selection rectangle around the 
objects required for the group.

Figure 113: Example of a selection rectangle (marquee)
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Figure 114: Example of grouping objects

– To select all the objects, go to Edit > Select All on the Menu bar, or use the keyboard 
shortcut Ctrl+A (macOS ⌘+A).

2) Create a group of selected objects using one of the following methods:

– Right-click on an object within the selected group and select Group from the context 
menu.

– Go to Shape > Group > Group on the Menu bar.

– Use the keyboard shortcut Ctrl+Shift+G (macOS ⌘+Shift+G).

Ungrouping
1) Select a group of objects and selection handles appear around objects within the group 

(Figure 114).

2) Ungroup a group of objects using one of the following methods:

– Right-click on the selected group and select Ungroup from the context menu.

– Go to Shape > Group > Ungroup on the Menu bar.

– Use the keyboard shortcut Ctrl+Alt+Shift+G (macOS +⌘ ⌥+Shift+G).

Editing individual objects in a group

Note

After entering a group, any other objects outside the group cannot be selected for 
editing. Exit from the selected group first before editing objects outside the group.

An object within a group can be edited individually without ungrouping the objects.

1) Select a group, then enter the group using one of the following methods:

– Right-click on the group and select Enter Group from the context menu.
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Figure 115: Example of editing individual object within a group

– Go to Shape > Group > Enter Group on the Menu bar.

– Use the keyboard shortcut F3.

– Double-click on the selected group.

2) Click on an object to select and individually edit it, as shown in Figure 115.

3) After editing and saving changes to an individual object within a group, exit the group 
using one of the following methods:

– Right-click on the group and select Exit Group from the context menu.

– Go to Shape > Group > Exit Group on the Menu bar.

– Use the keyboard combination Ctrl+F3 (macOS ⌘+F3).

– Double-click outside the group.

Nesting groups
A group of groups can be created and is commonly known as nesting groups. When nested 
groups are created, Draw retains individual group hierarchy, keeping the order in which groups 
were selected. The last individual group selected is on top of all the other groups within a nested 
group. Ungrouping and entering a nested group works the same way as for individual groups.

Tip

If group and ungroup commands are regularly used, or any other command, tools 
can be added to a toolbar. See Appendix B, Toolbars and the Getting Started Guide 
for more information on customizing toolbars.
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Figure 116: Example of area fill in combined objects

(1) Overlapping individual objects (2) Combined individual objects

Figure 117: Example of area fill in combing and splitting objects

(1) Overlapping individual objects
(2) Combined individual objects

(3) Splitting combined objects
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Combining, splitting, breaking, and connecting

Combining objects
Combining objects is a permanent merging of objects creating a new object. The original objects 
are no longer available as individual objects and cannot be edited as individual objects.

1) Select several objects that are overlapping each other.

2) Combine the selected objects into a single object using one of the following methods:

– Right-click on the selection and select Shapes > Combine from the context menu.

– Go to Shape > Combine on the Menu bar.

– Use the keyboard combination Ctrl+Shift+K (macOS ⌘+Shift+K).

The result of combining objects may not be what is expected, but the following explains how 
combining objects works.

• The attributes (for example, area fill) of the resulting object are those of the object at the 
back of the group. In Figure 116, it is the rectangle and in Figure 117 it is the yellow 
rectangle.

• Where objects overlap, the overlapping zone is either filled or empty depending on 
whether the overlap is even numbered or odd numbered. Figure 117 shows where the 
overlap number is even, an empty space is created and where the overlap number is 
odd, a filled area is created.

Splitting combined objects
An object which has been created from combining several objects can be split into individual 
objects. However, the original objects retain the formatting of the combined object and do not 
revert back to their original formatting. Select the combined object and use one of the following 
methods to split a combined object:

• Go to Shape > Split on the Menu bar.

• Use the keyboard shortcut Ctrl+Alt+Shift+K (macOS +⌘ ⌥+Shift+K).

In Figure 117, the individual overlapping objects use Rectangle 1 formatting at the rear of the 
overlapping objects when a combined object is split.

Breaking objects
An object that consists of more than one part can be broken into its individual parts as follows. 
For example, a star is broken into separate lines and the area fill is lost, as shown by the center 
graphic in Figure 118.

1) Select an object that consists of more than one part.

2) Convert the object to a curve or polygon using one of the following methods:

– Go to Shape > Convert > To Curve or To Polygon on the Menu bar.

– Right-click on the object and select Convert > To Curve or To Polygon on the context 
menu.

3) Go to Shape > Break on the Menu bar and the object is broken into individual parts.

4) Move, format or delete the individual parts as necessary, as shown by the right object in 
Figure 118.
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Figure 118: Example of breaking objects

(1) Original object (2) Object broken (3) Individual parts edited

Connecting lines
The individual parts of an object or individual objects can be connected together as follows:

1) Select all the objects that are going to be connected.

1) Go to Shape > Connect on the Menu bar. Individual lines or lines in a border are 
converted to curves and the end points of each line connected.

Closing objects
1) Select an object that has a gap in its border.

2) Right-click on the selected object and select Close Object from the context menu to 
close the gap.

3) Format the area fill created to requirements. See Chapter 4, Changing Object Attributes 
for more information on working with area fills.

Note

The shape created when connecting individual parts or lines is not a closed shape. 
The new shape has to be closed to create an area fill.

Merging, subtracting, or intersecting objects

After selecting more than one object, the merge, subtract, and intersect functions become 
available allowing creation of a new object with a new shape.

Merge
When merging objects, a new object is created with a shape that follows the shape of the 
merged objects. The area fill of the merged object is determined by the area fill of the object that 
is at the rear of all the other objects, as shown in Figure 119.

After selecting several objects, use one of the following methods to merge the objects:

• Go to Shape > Merge on the Menu bar.

• Right-click on the selected objects and select Shapes > Merge from the context menu.
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Subtract
When subtracting objects, the objects at the front are subtracted from the object behind. This 
leaves a blank space the subtracted objects occupied creating a new shape, as shown in 
Figure 120. After selecting several objects that overlap each other, use one of the following 
methods to subtract objects:

• Go to Shape > Subtract on the Menu bar.

• Right-click on the selected objects and select Shapes > Subtract from the context 
menu.

Figure 119: Example of merging objects

Figure 120: Example of subtracting objects

Figure 121: Example of intersecting objects
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Intersect
When intersecting objects, the front objects and the exposed area of the rear object are 
removed. This creates a new object from the area of the rear object that was covered by the 
front objects, as shown in Figure 121. After selecting several objects that overlap each other, use 
one of the following methods to intersect objects:

• Go to Shape > Intersect on the Menu bar.

• Right-click on the selected objects and select Shapes > Intersect from the context 
menu.

Duplication and cross-fading

Duplication
Duplication makes copies of an object while applying a set of changes to the duplicate copies, 
such as color or rotation.

1) Select an object or group of objects, then use one of the following methods to open the 
Duplicate dialog (Figure 122):

– Go to Edit > Duplicate on the Menu bar.

– Go to Shape > Duplicate on the Menu bar.

– Use the keyboard shortcut Shift+F3.

2) Select the umber of copies, placement, enlargement, and the start and end colors for the 
duplicate copies.

Figure 122: Duplicate dialog
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Figure 123: Example of duplication

3) Click OK and duplicate copies are created. An example of a duplication is shown in 
Figure 123. Each duplicate object is a separate object.

4) To group the duplicate objects into one group, see “Who is this user guide for?” on 
page 8.

5) To combine the duplicate objects into one object, see “Combining, splitting, breaking, and
connecting” on page 128.

The following options are available when using the Duplicate dialog:

Number of copies

Enter the number of copies required.

Placement

Sets the position and rotation of duplicated objects in relation to the original object.

X axis

Enter the horizontal distance between centers of a selected object and duplicate 
objects. Positive values shift the duplicate object to the right and negative values shift 
the duplicate object to the left.

Y axis

Enter the vertical distance between the centers of a selected object and duplicate 
objects. Positive values shift the duplicate object down and negative values shift the 
duplicate object up.

Angle

Enter the angle (0 to 359 degrees) required for rotating a duplicate object. Positive 
values rotate duplicate objects in a clockwise direction and negative values in a 
counterclockwise direction.

Enlargement

Sets the size of duplicate objects.

Width

Enter the amount to enlarge or reduce the width of duplicate objects.
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Height

Enter the amount to enlarge or reduce the height of duplicate objects.

Colors

Sets the colors for selected objects and duplicate objects. For more than one copy, these 
colors define the start and end points of a color gradient.

Start

Select a color for a selected object.

End

Select a color for a duplicate object. If making more than one copy, this color is applied 
to the last copy.

Cross-fading
Cross-fading transforms one object shape into another object shape. The result is a new group 
of individual objects that includes the start and end objects. The intermediate steps show the 
transformation from one object shape to another object shape. The cross-fading is carried out 
from the first object selected to the second object selected.

1) Select two objects and go to Shape > Cross-fading on the Menu bar to open the 
Cross-fading dialog (Figure 124).

2) In Settings, select the number of Increments for the transformation.

3) If necessary, in Settings, select Cross-fade attributes and Same orientation.

Figure 124: Cross-fading dialog

Figure 125: Example of cross-fading objects
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4) Click OK to cross-fade the selected objects and close the Cross-fading dialog. An 
example of cross-fading is shown in Figure 125 with Same orientation deselected. The 
object created is a group of objects.

5) To ungroup this group of objects and use the individual objects, see “Ungrouping” on 
page 125.

The following options are available in the Cross-fading dialog:

Increments

Enter the number of steps created between the selected objects.

Cross-fade attributes

Applies cross-fading to the line and fill properties of the selected objects. For example, if 
the selected objects are filled with different colors, a color transition between the two 
colors is applied.

Same orientation

Applies a smooth transition between the selected objects.

Positioning objects

Arranging objects
When combining, merging, subtracting, or intersecting objects, the end result varies depending 
on which object is at the front and which object is at the back. Each new object placed on a 
drawing automatically becomes the front object and all the other objects move backwards in 
positioning order. Arranging objects changes the order of a group of objects. To change the 
arrangement position of an object, select one or more objects and then use one of the following 
methods 

• Right-click on the selected object(s), then select Arrange from the context menu and 
one of the available options.

• Click on the triangle ▼ to the right of Arrange on the Standard toolbar to open the 
Position subtoolbar (Figure 126) and select one of the available tools.

• Click one of the arrangement tools on the Line and Filling toolbar.

• Click on Shape > Arrange on the Menu bar and select an arrangement option.

• Use the Arrange tools in Position and Size panel in the Properties deck on the Sidebar.

• Use a keyboard shortcut available for each arrange option.

The arrangement options available are as follows:

Bring to Front

Brings the selected object to the front of a group of objects (Shift+Ctrl++) 
(macOS ⌘+Shift++).

Bring Forward

Brings the selected object forward one step (Ctrl++) (macOS ⌘++).

Figure 126: Position subtoolbar
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Send Backward

Sends the selected object one step backward (Ctrl+–) (macOS ⌘+–).

Send to Back

Sends the selected object to the back of a group of objects (Shift+Ctrl+–) 
(macOS ⌘+Shift+–).

In Front of Object

Moves the selected object in front of another selected object.

Behind Object

Moves the selected object behind another selected object.

Reverse

Reverses the order of the selected objects. This tool is grayed out if only one object is 
selected.

Aligning objects
To make a drawing look more professional, objects can be aligned with each other. Select one or 
more objects and use one of the following methods to align objects:

• Right-click on the selected object(s), then select Align Objects from the context menu 
and one of the available options.

• Click on one of the alignment tools on the Line and Filling toolbar.

• Go to Shape > Align Objects on the Menu bar and select the alignment required.

• Use the Align tools in the Position and Size panel in the Properties deck on the Sidebar.

• Go to View > Toolbars on the Menu bar and select Align Objects to open the Align 
Objects toolbar (Figure 127).

The alignment tools available are as follows:

Left

Aligns the left edges of the selected objects. If only one object is selected, the left edge 
of the object is aligned to the left page margin.

Centered

Horizontally centers the selected objects. If only one object is selected, the center of the 
object is aligned to the horizontal center of the page.

Right

Aligns the right edges of the selected objects. If only one object is selected, the right 
edge of the object is aligned to the right page margin.

Top

Vertically aligns the top edges of the selected objects. If only one object is selected, the 
top edge of the object is aligned to the top page margin.

Center

Vertically centers the selected objects. If only one object is selected, the center of the 
object is aligned to the vertical center of the page.

Bottom

Vertically aligns the bottom edges of the selected objects. If only one object is selected, 
the bottom edge of the object is aligned to the bottom page margin.
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Figure 127: Align Objects toolbar

Figure 128: Distribute Selection toolbar

Distributing objects
Distributing objects allows three or more objects to be evenly spaced along a horizontal or 
vertical axis. Objects are distributed using the outermost objects as base points for spacing. 
Select at least three objects, then use one of the following methods to distribute the objects:

• Right-click on the selected objects, then select Distribute Selection from the context 
menu and one of the available options.

• Go to View > Toolbars on the Menu bar and select Distribute Selection to open the 
Distribute Selection toolbar (Figure 128).

• Go to Shape > Distribute Selection on the Menu bar and select a distribution option.

• Right-click on the selected objects and select Distribute Selection from the context 
menu, then select a distribution option.

The distribution options available are as follow:

Horizontal Left

Distributes the selected objects so that the left edges of the objects are evenly spaced 
from one another.

Horizontal Center

Distributes the selected objects so that the horizontal centers of the objects are evenly 
spaced from one another.

Horizontal Spacing

Distributes the selected objects horizontally so that the objects are evenly spaced from 
one another.

Horizontal Right

Distributes the selected objects so that the right edges of the objects are evenly spaced 
from one another.

Vertical Top

Distributes the selected objects so that the top edges of the objects are evenly spaced 
from one another.

Vertical Center

Distributes the selected objects so that the vertical centers of the objects are evenly 
spaced from one another.

Vertical Spacing

Distributes the selected objects vertically so that the objects are evenly spaced from one 
another.
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Vertical Bottom

Distributes the selected objects so that the bottom edges of the objects are evenly 
spaced from one another.
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Introduction

Previous chapters in this Draw Guide provide information on vector graphics and the most 
common types of vector graphics in use are as follows:

SVG (Scalable Vector Graphics)

An Extensible Markup Language (XML) based vector image format for two-dimensional 
graphics with support for interactivity and animation.

EPS (Encapsulated PostScript)

A PostScript document format usable as a graphics file format. EPS files are self 
contained, PostScript documents that describe an image or drawing and can be placed 
within another PostScript document.

AI (Adobe Illustrator)

A proprietary file format developed by Adobe Systems for representing single-page 
vector-based drawings in either the EPS or PDF formats.

However, Draw has several functions for handling raster graphics or bitmaps, for example 
photographs and scanned pictures. This includes import, export, and conversion from one 
graphic format to another graphic format. Draw can open the majority of graphic file formats 
using capabilities similar to raster graphics programs like Gimp or Adobe Photoshop. Raster 
graphics are generally images or pictures that use the most common formats in use:

JPG/JPEG (Joint Photographic Experts Group)

JPEG is the most common image format on websites and most digital cameras produce 
JPEG images as default.

GIF (Graphics Interchange Format)

GIF is a bitmap image format that is popular because of its wide support and portability.

PNG (Portable Network Graphics)

PNG is a raster image format which supports lossless data compression and also 
background transparency.

TIF/TIFF (Tagged Image File Format)

TIFF is flexible, adaptable, and capable of storing image data in a lossless format.

BMP (BitMaP)

Also known as bitmap image file, which is a dot matrix data structure.

Importing graphics and images

Inserting
To import graphic or image files into a drawing, go to Insert > Image on the Menu bar to open 
the Insert Image dialog (Figure 129).

Draw contains import filters for the majority of graphic formats. If the file being imported uses a 
graphic format not compatible with LibreOffice import filters, it is recommended to use a free 
graphic conversion program to convert the file into a graphic format that Draw recognizes.

If Preview is selected, a preview of the file is shown on the right-hand side of the Insert Image 
dialog. This makes it easier to select the file required and makes sure that Draw can import the 
graphic file format used.
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Figure 129: Insert Image dialog

Embedding
Embedding graphics into a drawing makes graphics a permanent part of the drawing. Any 
changes made to an embedded graphic only appear in a LibreOffice drawing where the graphic 
has been embedded. The original graphic file is not affected. Embedding is importing a graphic 
into a drawing using one of the following methods:

• Insert Image dialog.

• Copying and pasting.

• Scanning a graphic.

• Dragging and dropping between open files.

The main advantage of embedding graphics into a drawing is that a graphic is always available 
no matter what computer is used to open the drawing.

The main disadvantage of embedding graphics is that it creates large file sizes, which may 
create storage problems if there is limited storage capacity on the computer. Also, if the original 
graphic is altered, the embedded graphic is not updated each time the LibreOffice drawing is 
opened.

Note

When a graphic is embedded into a LibreOffice drawing, make sure that Insert as 
Link is not selected in the Insert Image dialog.
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Figure 130: Confirm Linked Graphic dialog

Linking
Linking to an original graphic does not insert the graphic into a drawing, but creates a link to the 
location of an original graphic file. Each time a LibreOffice drawing is opened, any linked 
graphics are displayed in the drawing.

The main advantage of linking graphic files is that if the original graphic file is altered or 
modified, opening a LibreOffice drawing automatically updates the linked graphic. Also the file 
size of a LibreOffice drawing is smaller and the original graphic is easily edited with specialized 
external applications.

The main disadvantage of linking graphics is that the link must be maintained between a 
LibreOffice drawing and the embedded graphic file for a link to work correctly. If the original 
drawing or graphic file is moved to another computer location, then any links must be updated to 
include the new location.

1) Open the Insert Image dialog.

2) Select Insert as Link in the Insert Image dialog.

3) Select the required graphic or image file and click on Open to open the Confirm Linked 
Graphic dialog (Figure 130).

4) Click on Keep Link to link the file and close the Confirm Linked Graphic dialog.

5) If required, click on Embed Graphic to embed the file instead of linking the file. This also 
closes the Confirm Linked Graphic dialog.

Note

When a graphic or image file is linked in a LibreOffice drawing, the file format of the 
linked graphic or image is not changed.

Editing links
1) Go to Edit > External Links on the Menu bar to open the Edit Links dialog (Figure 131) 

and select the link to be edited.

2) Click on Modify, Break Link, or Update as appropriate.

– Modify — allows changes to the selected link that is between the graphic file in the 
current drawing and the source file.
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Figure 131: Edit Links dialog

– Break Link — breaks the link between the selected linked graphic file and the current 
document. The graphic file version in the drawing becomes embedded into the 
drawing. A confirmation dialog opens asking if the link is to be broken. Click on Yes to 
confirm the breaking of the link.

– Update — updates the selected link so that the most recent version of the linked 
graphic file is displayed in the drawing.

3) Click on Close to save the changes to the link and close the Edit Links dialog.

Scanning
After scanning, scanned graphics and images are inserted and embedded using PNG format 
into a LibreOffice drawing. To insert scanned images, make sure the scanner is configured for 
the computer and supported by SANE for a Linux operating system, or TWAIN for a Windows or 
macOS.

The following procedure is an example only. The actual scanning procedure depends on the 
scanner type, software and computer operating system. Consult the scanner documentation for 
more information.

1) Place a document, drawing, or photograph in the scanner and make sure that the 
scanner is switched on and ready, then use one of the following procedures:

– If this is the first time the scanner has been used with LibreOffice, go to Insert > Media 
> Scan > Select Source on the Menu bar to select the scanner.

– If the scanner has been used before, go to Insert > Image > Scan > Request on the 
Menu bar.

2) Specify the scanning resolution, subject type being scanned, subject size and so on.
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3) When the image has been scanned, Draw places it in the LibreOffice drawing. The 
scanned image can then be edited like any other graphic or image.

Note

If more than one scanner is connected to the computer, the scanner is selected 
when the source is selected. This selection becomes the default source for scanning 
until another scanner is selected and used as the scanning source.

Copying and pasting
Copying and pasting a graphic also embeds a graphic or image file into a LibreOffice drawing. A 
copied graphic can be an image already embedded in another document or drawing, or a 
graphic file such as a drawing, document, or photograph.

1) After copying the graphic file, go to Edit > Paste Special > Paste Special on the Menu 
bar to open the Paste Special dialog.

2) Select the required format for pasting the copied graphic into a LibreOffice drawing. 
Available formats for pasting depend on the type of file copied onto the clipboard.

3) Click OK to paste the graphic file and close the Paste Special dialog.

Note

When copying and pasting images into a LibreOffice drawing, respect the copyright 
and license of any file being copied.

Exporting images

Exporting ODG files

By default Draw saves drawings in the Open Document format ODG and some software 
programs are not compatible with the ODG format. To make drawings compatible with other 
software applications, an ODG file can be exported in several formats. The export procedure 
used depends on the computer setup and computer operating system being used. The following 
procedure is an example export procedure.

1) Open the ODG file being exported.

2) Go to File > Export on the Menu bar and open the Export dialog. An example export 
dialog is shown in Figure 132.

3) Enter a filename for the exported file and navigate to the folder where the exported file is 
to be saved.

4) Select the required file format from the options in the drop-down list.

5) Click Export and the file is exported as a new file in the selected file format.

6) Depending on the file format selected, another dialog may open allowing options to be 
selected for the export format.

7) Depending on the additional dialog that may open, click on Export, Create, or OK and 
the file is exported as a new file in its new format.
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Figure 132: Example export dialog

Figure 133: Example of Export Options dialog

Exporting graphics or images
Exporting individual graphics or images, or a group of graphics or images, from a drawing file is 
similar to exporting files. The following export procedure is an example. Actual procedure 
depends on computer operating system and computer setup.
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1) Open the ODG file that contains the graphic or images for export.

2) In the ODG file, select the graphics or images for export.

3) Go to File > Export on the Menu bar and open the Export dialog. An example export 
dialog is shown in Figure 132.

4) Enter a filename for the exported file and navigate to the folder where the exported file is 
to be saved.

5) Click on Selection in the Export dialog. Selecting may open an example options dialog 
as shown in Figure 133.

6) Enter the required options in the options dialog and click OK to export the file to the 
selected destination. There is no confirmation of export.

Formatting images

Images (raster graphics) are edited and formatted to add or change filters and adjust the 
properties of color, lines, areas, and shadows using one of the following methods:

• Go to Format > Image on the Menu bar and use the tools in the sub-menu that opens.

• Use the tools on the Image toolbar (Figure 134).

• Use the tools available in the Image panel on the Properties deck of the Sidebar.

• Some raster graphics may have a text element. For more information on formatting text, 
see Chapter 9, Adding and Formatting Text.

Note

Formatting changes made to a graphic using LibreOffice tools only appear in the 
drawing where the graphic was modified. Original graphic file is not affected. Raster 
graphics included in a group behave like other objects when the properties of the 
group are edited and formatted.

Naming images
Draw names objects using the insertion order into a drawing, for example Shape 1, Shape 2, 
and so on. It is recommended to rename objects using a unique name. Names make objects 
and images easily identifiable in the Navigator.

1) Select an image, then use one of the following methods to open the Name dialog and 
create a unique name for the selected image:

– Go to Format > Name on the Menu bar.

– Right-click on the image and select Name from the context menu.

2) Enter a name in the Name text box in the Name dialog that opens and click OK.

Figure 134: Image toolbar
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Image toolbar
The Image toolbar (Figure 134) appears when an image or raster graphic object is selected. For 
more information on the Image toolbar and the available tools, see Appendix B, Toolbars. The 
tools listed below for the Image toolbar are an example only.

Position and Size (F4)

Opens the Position and Size dialog. See Chapter 3, Working with Objects for more 
information.

Align Objects

Opens a subtoolbar giving access to alignment tools for aligning selected objects in 
relation to each other. See Chapter 5, Combining Multiple Objects for more information.

Bring to Front

Brings the selected object to the front of a group of objects (Ctrl+Shift++) 
(macOS ⌘+Shift++).

Bring Forward

Brings the selected object forward one step (Ctrl++) (macOS ⌘++).

Send Backward

Sends the selected object one step backward (Ctrl+–) (macOS ⌘+–).

Send to Back

Sends the selected object to the back of a group of objects (Ctrl+Shift+–) 
(macOS ⌘+Shift+–).

In Front of Object

Moves the selected object in front of another selected object.

Behind Object

Moves the selected object behind another selected object.

Reverse

Reverses the order of the selected objects. This tool is grayed out if only one object is 
selected.

Line Style

Opens a drop-down list with different line styles used for the outline of the border. See 
Chapter 4, Changing Object Attributes for more information.

Line Width

Used to change the width of a line. See Chapter 4, Changing Object Attributes for more 
information.

Line Color

Used to change the color of a line. See Chapter 4, Changing Object Attributes for more 
information.

Area Style/Filling

Used to change the type of filling used in a shape. See Chapter 4, Changing Object 
Attributes for more information.

Shadow

Sets the default shadow effect around the picture. The shadow attributes are adjusted 
using the Shadow panel in the Properties deck on the Sidebar. See Chapter 4, Changing 
Object Attributes for more information.
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Filter

Opens the Image Filter toolbar which is described in “Image filters” on page 153.

Image Mode

Changes the display of the image from color to grayscale, black and white, or a 
watermark. This setting affects only the display and printing of the image; the original 
image file remains unchanged. The image mode setting can also be changed using 
Color mode in the Image panel in the Properties deck on the Sidebar (Figure 135).

Default

Image is displayed unaltered in color.

Grayscale

Image is displayed in 256 shades of gray.

Black/White

Image is displayed in black and white.

Figure 135: Image panel in Properties deck on Sidebar

Figure 136: Color subtoolbar
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Watermark

Color, brightness, contrast, and gamma settings are reduced so that the image can be 
used as a watermark (background). The default settings for Watermark can be 
adjusted using the Color subtoolbar (Figure 136).

Crop Image

Crops or trims an image. When using this tool, crop marks appear around the image. 
Drag one or more of these marks to crop the image to the desired size. For more 
information on cropping, see “Cropping images” below.

Vertically

Flips the selected object vertically. See Chapter 4, Changing Object Attributes for more 
information.

Horizontally

Flips the selected object horizontally. See Chapter 4, Changing Object Attributes for 
more information.

Transformations

Opens the Transformations toolbar. See Chapter 4, Changing Object Attributes for more 
information.

Transparency

Adjusts the degree of transparency of the image between 0% (opaque) and 100% (fully 
transparent). The transparency setting can also be adjusted using the Image panel in the 
Properties deck on the Sidebar.

Color

Opens the Color subtoolbar (Figure 136) to adjust the values of the RGB colors, 
brightness, contrast, and Gamma. These adjustments do not affect the original image, 
but the values are stored in LibreOffice Draw as a separate formatting set. The color 
settings can also be adjusted using the Image panel in the Properties deck on the 
Sidebar.

Red, Green, Blue

Select values between –100% (no color) to +100% (full intensity); 0% represents the 
original color value of the image.

Brightness

Select a value between –100% (totally black) and +100% (totally white).

Contrast

Select a value between –100% (minimum) and +100% (maximum).

Gamma

Affects the brightness of the middle color tones. Select a value between 0.10 
(minimum) to 10 (maximum) Try adjusting this value if changing brightness or contrast 
does not give the required result.

Cropping images

Cropping is a method of hiding unwanted areas of an image or changing the size of an image in 
a drawing. Changes made when cropping an image only change the display of the image in a 
drawing and not the original image file.
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Figure 137: Example image in crop mode

Quick cropping
After selecting an image, it can be cropped quickly using one of the following methods:

• Click on Crop Image on the Standard or Image toolbar.

• Go to Format > Image > Crop on the Menu bar.

• Right-click on the image and select Crop from the context menu.

Selection handles appear around the selected image, as shown in the example in Figure 137.

The image is cropped as follows:

• Top, bottom, left, and right selection handles crop the image in one direction only.

• Corner selection handles crop the image vertically and horizontally in two directions.

• To maintain the ratio between vertical and horizontal dimensions, hold down the Shift 
key while moving a selection handle.

Crop dialog
For more control and accuracy over the cropping functions, it is recommended to use the Crop 
dialog (Figure 138). Select an image and go to Format > Image > Crop Dialog on the Menu bar 
to open the Crop dialog.

Crop

Trim or scale the selected image, or add white space around the image.

Keep scale

Maintains the original scale of the image when cropping so that only the size of the 
image changes.

Keep image size

Maintains the image original size when cropping so that only the image scale changes. 
To reduce the image scale, select this option and enter negative values in the cropping 
boxes. To increase the image scale, enter positive values in the cropping boxes.

Left and Right

If Keep scale is selected, enter a positive amount to trim the left or right edge of the 
image, or a negative amount to add white space to the left or right of the image. If 
Keep image size is selected, enter a positive amount to increase the image horizontal 
scale, or a negative amount to decrease the image horizontal scale.
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Figure 138: Crop dialog

Top and Bottom

If Keep scale is selected, enter a positive amount to trim the image top or bottom, or a 
negative amount to add white space above or below the image. If Keep image size is 
selected, enter a positive amount to increase the image vertical scale, or a negative 
amount to decrease the image vertical scale.

Scale

Used to change the image scale as it appears in a drawing.

Width

Enter a percentage value to change the image width.

Height

Enter a percentage value to change the image height.

Image Size

Used to change the image size.

Width

Enter a value for the image width.

Height

Enter a value for the image height.

Original Size

Original size of the image is displayed above the option. Clicking on this option and then 
clicking OK resets the selected image to its original size.
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Note

In the Crop dialog, the Width and Height are treated as independent values. 
Changing one without the other can result in significant distortion of the image and 
this may not be what is required.

Exporting cropped images
If a cropped image is to be used in another drawing, use one of the following methods after 
selecting the cropped image.

Using Export dialog

1) Select the cropped image.

2) Go to File > Export on the Menu bar to open the Export dialog.

3) Navigate to the destination folder, then enter a filename.

4) Click on Selection, then click on Export. See “Exporting images” on page 144 for more 
information.

Using Save

1) Select the cropped image.

2) Go to Format > Image > Save on the Menu bar or right click on the cropped image and 
select Save from the context menu.

3) Click on Yes to save the modified image and open an Image Export dialog.

4) Select the file format required, navigate to the destination folder, and enter a filename.

5) Click on Save to save the cropped image.

Figure 139: Compress Image dialog
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Compressing images
If a large image is inserted into a drawing and resized to fit into the layout of the drawing, the 
complete full-size original image is stored in the drawing file. This preserves the original image, 
possibly resulting in a large file to store or send by mail.

If some loss of image quality can be accepted, the image can be compressed using the following 
procedure. This reduces the data volume while preserving the display in the page layout.

1) Open the Compress Image dialog (Figure 139) using one of the following methods:

– Right-click on the image and select Compress from the context menu.

– Go to Format > Image > Compress on the Menu bar.

2) Select the type of compression and the resolution required.

3) Click on Calculate New Size to update the image information when the Compression 
and Resolution settings are changed.

4) When satisfied with the new settings, click OK to apply the settings.

5) If the resulting image is not acceptable, use one of the following methods to undo the 
changes and select another compression setting.

Image filters

Draw has eleven filter effects that can be applied to selected images and these image filters can 
be combined. Filters always apply to the entire image and it is not possible to use filters on only 
part of the image.

Notes

If an image is embedded into a drawing, any image filters are only applied directly to 
the embedded image and the original image file is not changed. Save the drawing to 
retain any filter effects applied to the embedded image in a drawing.

After a drawing is saved and closed, the effects of image filters become permanent. 
If image filter effects are not satisfactory, use Edit > Undo on the Menu bar to cancel 
the filter effects BEFORE saving the drawing.

When applying image filters to an image, the file size of the image must be taken into 
account. On large file sizes, there is a time lag between applying an image filter and 
the effect to become visible on the image.

Applying image filters
1) Select an image to open the Image toolbar.

2) Apply an image filter using one of the following methods:

– Click on Filter to open the Image Filter subtoolbar (Figure 140), then select an image 
filter to apply.

Figure 140: Image Filter subtoolbar
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– Go to Format > Image > Filter on the Menu bar and select an image filter from the 
context menu.

Image filters

No image filter

Figure 141 is an example image with no image filters applied.

Invert filter

Inverts or reverses the color values of a color image (similar to a color negative), or the 
brightness values of a grayscale image. Apply the filter again to revert to the original graphic 
(Figure 142).

Figure 141: Example image no filter applied

Figure 142: Example image invert filter applied
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Figure 143: Example image smooth filter applied

Figure 144: Smooth dialog

Figure 145: Example image sharpen filter applied
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Smooth filter

Softens or blurs the image by applying a low pass filter. This reduces the contrast between 
neighboring pixels and produces a lack of sharpness making the image appear smoother. The 
effect of the smooth filter can be very subtle. Figure 143 shows the effect of applying a Smooth 
radius of 15 to an image.

Selecting this filter opens the Smooth dialog (Figure 144) where the smooth radius parameter is 
set. The preview in the Smooth dialog shows the effect of applying the Smooth filter to an image.

Sharpen filter

Sharpens the image by applying a high pass filter, adjusting the contrast between neighboring 
pixels. The effect increases if the filter is applied several times making the colors appear faded, 
as shown by the example in Figure 145.

Remove Noise filter

Removes noise by applying a median filter comparing every pixel with its neighbor. It replaces 
any pixel with extreme values that deviate in color by a large amount from the mean value with a 
pixel that has a mean color value. The amount of picture information does not increase each 
time the filter is applied. However, there are fewer contrast changes resulting in an image that 
looks smoother and the effect is very subtle (Figure 146).

Figure 146: Example image remove noise filter applied

Figure 147: Example image solarization filter applied
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Solarization filter

Solarization refers to an effect that looks when there is too much light during photo development 
and the colors have become partly inverted. Dark areas appear light or light areas appear dark. 
In the digital world of photography, solarization creates a change or reversal of color, similar to 
the effect of the Invert image filter. Figure 147 shows the effect of a Solarization filter applied 
using a Threshold value of 50%.

Selecting Solarization opens the Solarization dialog (Figure 148), where the degree of 
solarization (Threshold value) can be specified. Entering a Threshold value above 70% reverses 
the inversion effect on colors. Also, selecting Invert reverses the effect of the Solarization image 
filter, as shown in the preview box in Figure 148.

Aging filter

The Aging filter creates a look that resembles photographs developed in the early days of 
photography (Figure 149). All pixels are set to their gray values. The green and blue color 
channels are then reduced by the amount specified in Aging degree in the Aging dialog. Red 
color channel is not changed. Selecting the Aging filter opens the Aging dialog (Figure 150), 
where the Aging degree can be defined and create an old look for an image.

Figure 148: Solarization dialog

Figure 149: Example image aging filter applied
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Figure 150: Aging dialog

Figure 151: Example image posterize filter applied

Figure 152: Posterize dialog
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Posterize filter

Posterizing reduces the number of colors in an image. For example, a photograph will probably 
look like a painting when the number of colors is reduced (Figure 151). Selecting Posterize 
opens the Posterize dialog (Figure 152) where the number of Poster colors can be defined to 
produce the effect required.

Pop Art filter

Changes the colors of an image by converting the image to a pop-art format (Figure 153).

Charcoal Sketch filter

Displays an image as a charcoal sketch. The contours of the image are drawn in black and the 
original colors are suppressed (Figure 154).

Relief filter

Calculates the edges of an image in relief as if the image is illuminated by a light source 
(Figure 155). Selecting Relief opens the Emboss dialog (Figure 156) where the position of the 
Light source is selected producing shadows that differ in direction and magnitude.

Figure 153: Example image pop art filter applied

Figure 154: Example image charcoal sketch filter applied
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Figure 155: Example image relief filter applied

Figure 156: Emboss dialog

Figure 157: Example image mosaic filter applied
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Figure 158: Mosaic dialog

Mosaic filter

The Mosaic filter joins groups of pixels and converts the pixels into rectangles of a single color 
creating an image that appears to be a mosaic (Figure 157). The larger the individual rectangles 
created, the fewer details in the mosaic graphic.

Selecting this image filter opens the Mosaic dialog (Figure 158), where the number of pixels for 
Width and Height of the tiles is set. Selecting Enhanced edges enhances the edges of each tile, 
creating a sharper definition.

Replacing colors

The Color Replacer is used to replace or change a color of an embedded image for another 
color, or to make a color transparent. Up to four colors can be replaced or changed at the same 
time. Areas of an image cannot be selected for editing as the Color Replacer only works on the 
whole of an image.

Selecting replacement colors can only be from the available color palettes in LibreOffice. Custom 
colors cannot be defined in the Color Replacer, but custom colors can be created before using 
the Color Replacer. For more information on creating custom colors, see Chapter 11, Advanced 
Draw Techniques.

Note

The Color Replacer can only be used on embedded images. If the Color Replacer 
is used on a linked image, the following error message appears “This image is linked 
to a document. Do you want to unlink the image in order to edit it?”. Click on Yes to 
unlink and embed the graphic.

Color Replacer dialog
Pipette

Switches color selection on when selected.

Replace

Replaces selected source colors in a selected image with the colors specified in the 
Replace with boxes.
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Colors

Lists the source colors and the replacement colors.

Source color

Select this checkbox to replace the current Source color with the color that specified in 
the Replace with box.

Tolerance

Set the tolerance for replacing a source color in a source image. To replace colors that 
are similar to the color selected, enter a low value. To replace a wider range of colors, 
enter a higher value.

Replace with

Lists the available color palettes and replacement colors.

Transparency

Replaces transparent areas in the selected image with the color selected.

Figure 159: Color Replacer dialog

Figure 160: Example image before replacing colors
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Figure 161: Example image after replacing colors

Replacing colors

Note

Using the Color Replacer replaces all occurrences of a Source color that are in the 
selected image. Default selection of Transparent in the Replace with boxes removes 
selected color from an image creating transparent areas in a selected image.

1) Select an embedded image.

2) Go to Tools > Color Replacer on the Menu bar to open the Color Replacer dialog 
(Figure 159).

3) Click on Pipette at the top of the Color Replacer dialog to activate the color selection 
mode.

4) Move the cursor over the color to be replaced in the selected image.

5) Click on the color and following happens. A maximum of four colors can be selected in an 
image.

– A preview of a selected color appears in the box next to Pipette each time a color is 
clicked on.

– Each selected color appears in a Source color preview box with a check mark.

6) Enter the amount of tolerance required for replacing each selected color in the Tolerance 
boxes. The default selection is 10% tolerance.

7) In Replace with and for each selected color, select a color palette from the drop-down 
list, then select the required color from the color palette. Transparent is the default 
selection.

8) After selecting up to four colors for replacement, click Replace to replace the colors in 
the selected image. Examples of the original image and after color replacement are 
shown in Figures 160 and 161.

9) There is no preview of the effect. If the result is not satisfactory, select Edit > Undo: 
Image with transparency Color Replacer in the Menu bar and repeat the color 
replacement.

Replacing transparent areas
1) Go to Tools > Color Replacer on the Menu bar to open the Color Replacer dialog.
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2) Select an image with transparent areas.

3) Select Transparency in the Color Replacer dialog so that a check mark appears next to 
Transparency.

4) Select a color palette from the drop-down list next to Transparency, then select a color 
from the selected palette.

5) Click on Replace and the transparent areas are filled with the selected color.

6) There is no preview of the effect. If the result is not satisfactory, select Edit > Undo: 
Image with transparency Color Replacer in the Menu bar and repeat the transparency 
replacement.

Conversion

Contour conversion
Consider the following points before carrying out a contour conversion on an object:

• Contour conversion converts a selected object to a polygon, or a group of polygons, with 
four corner points.

• Converting an image to a contour, the converted image is set as a background graphic.

• If the conversion creates a group of polygons (for example, contour conversion of a text 
object). Enter a polygon group before selecting an individual polygon within a group. For 
more information on working with groups, see Chapter 5, Combining Multiple Objects.

• After converting an image to a contour, the object can no longer be edited normally. The 
converted image has to be edited using Edit > Points on the Menu bar to adjust its 
shape. For more information on editing points, see Chapter 3, Working with Objects.

• Any object editing must be completed before carrying out a contour conversion because 
any further editing is not possible on the converted object.

• No confirmation dialog is provided for a contour conversion.

A contour conversion is carried out as follows:

1) Carry out all necessary editing on the object before converting to a contour.

2) Make sure the object is selected.

3) Convert the object to a contour using one of the following methods:

– Go to Shape > Convert > To Contour on the Menu bar.

– Right-click on a selected object and select Convert > To Contour from context menu.

Polygon conversion
Polygon conversion is used to convert a selected image into a group of polygons filled with color. 
The image is also converted to a vector graphic and can be resized with no loss of image quality 
or distortion of any text. After conversion, the graphic can be broken into groups of polygons and 
then split into individual polygons. Breaking and splitting allows editing or deletion of individual 
colors within the graphic.
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Conversion options and controls

Number of colors

Enter the number of colors to be displayed in the converted image. LibreOffice generates 
a polygon for each occurrence of a color in the image. The range for the number of 
colors is between 8 and 32.

Point reduction

Removes color polygons that are smaller than the pixel value entered. The range for 
point reduction is between 0 and 32 pixels.

Fill holes

Fills the blank areas in the graphic that can be created when applying a point reduction.

Tile size

Enter the size of the rectangle for the background fill. Tile sizes range between 8 and 128 
pixels.

Source image

Preview of the original image.

Vectorized image

Preview of the converted image.

Preview

Creates a preview of the converted image in Vectorized image without applying any 
changes.

OK

Converts the image to a vector graphic consisting of polygons. The result is a metafile in 
SVM format (Star View Metafile) used by LibreOffice and allows transfer of the converted 
image to other LibreOffice documents.

Converting

1) Select an image in a drawing.

2) Convert the image into a polygon using one of the following methods and open the 
Convert to Polygon dialog (Figure 162).

– Go to Shape > Convert > To Polygon on the Menu bar.

– Right-click on the image and select Convert > To Polygon from the context menu.

3) Select Number of colors and Point reduction to be used in the conversion.

4) Select Fill holes to prevent any blank areas appearing in the converted image.

5) Enter the number of pixels to use for Tile size.

6) Click Preview to check how the converted graphic will look.

7) Make any necessary changes to the settings and check the preview again.

8) If the converted image meets the expected requirements, click OK to convert the image 
to a polygon and close the Convert to Polygon dialog.

Breaking

After converting an image to polygons, the vectorized image can be broken into groups of 
polygons. Each polygon group consists of one color and becomes an object that can be used in 
another drawing.
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Figure 162: Convert to Polygon dialog

1) Convert an image to polygons.

2) Make sure the converted image is selected, then use one of the following methods to 
break the image into groups of polygons:

– Go to Shape > Break on the Menu bar.

– Right-click on the image and select Break from the context menu.

3) Click on a color in the image and drag the group of polygons filled with that color out of 
the image to create a new image.

4) Alternatively, press Delete and delete the color from the image.

Splitting

After converting an image to polygons and breaking the image into polygon groups, these 
polygon groups can be split into individual polygons.

1) Convert an image to polygons.

2) Break the image into groups of polygons.

3) Select the image, then use one of the following methods to split the polygon groups into 
individual polygons:

– Go to Shape > Split on the Menu bar.

– Right-click on the image and select Shapes > Split from the context menu.
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– Use the keyboard shortcut Ctrl+Alt+Shift+K (macOS +⌘ ⌥+Shift+K)

4) Select an individual polygon (or several polygons) in the image and drag the polygon 
from the image to create a new image in the drawing.

5) Alternatively, press Delete to delete the selected polygon(s) from the image.

Bitmap conversion
All drawing objects placed into a LibreOffice drawing are vector graphics and these vector 
graphics can be converted to a bitmap (raster graphic) in PNG format. Any transparent areas in 
the original vector graphic are lost during conversion even though the PNG format used by Draw 
supports transparencies. Use one of the following methods to convert a vector graphic to a 
bitmap. No confirmation dialog is provided for a bitmap conversion.

• Go to Shape > Convert > To Bitmap on the Menu bar.

• Right-click on the graphic and select Convert > To Bitmap from the context menu.
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Introduction

Draw does not have the functionality of other drawing or image editing programs, but can 
produce and edit 3D drawings. Using Draw, 3D scenes and extruded 3D shapes are created and 
edited. Depending 3D type selected, there are possibilities for further editing of an object 
(rotation, illumination, perspective, and so on).

• Extruded 3D shapes are simpler to create and edit.

• 3D scenes allow for greater customization.

3D object types

3D scenes
3D scenes are created from objects that use dimensions for the x, y, and z coordinates and can 
contain object types, such as cube, sphere, extrusion object or rotation object. These object 
types do not exist outside a 3D scene.

The Status Bar displays 3D scene selected (Figure 163) when it is selected and has been 
created from a 2D object using body rotation or conversion. Alternatively, it is a ready-made 3D 
object that has been inserted into a drawing.

A 3D scene is similar to a group. Just like a group, a 3D scene is entered for editing individual 
objects within a 3D scene and exited after editing is completed. See Chapter 5, Combining 
Multiple Objects for more information on entering, editing and exiting groups.

When a 3D scene is created from a selection of several 2D objects, a group is automatically 
created as a single 3D scene. Enter this 3D scene so that individual objects within the 3D scene 
can be changed, edited and rotated.

Note

Individual objects cannot be ungrouped when a 3D scene has been created from a 
selection of 2D objects.

3D shapes
2D shapes are flat with only width and height dimensions, but 3D shapes are solid objects that 
have a depth, width, and height. A 3D shape is created when a 2D shape or an object from the 
Fontwork Gallery is converted to 3D using Toggle Extrusion. The Status Bar displays Shape 
selected when this type of 3D object is selected (Figure 164).

Figure 163: Status Bar — information with 3D scene selected

Figure 164: Status Bar — information with 3D shape selected
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3D shapes are viewed and edited in 3D or 2D mode. To edit in 2D mode, switch off extrusion, 
make the editing changes, then switch back to 3D mode using Toggle Extrusion.

Note

Toggle Extrusion is only used when a 2D shape, or a 3D object that has been 
extruded from a 2D shape, or an object from the Fontwork Gallery is selected in a 
drawing. Toggle Extrusion cannot be used for text, lines, arrows, curves, and 
polygons.

Creating 3D objects

Notes

Before creating 3D objects in a drawing, it is recommended that the extra 3D tools 
(To 3D; To 3D Rotation Object; Toggle Extrusion) are added to the Drawing 
toolbar using Visible Buttons or the Customize dialog. For more information on 
using Visible Buttons and the Customize dialog, see Appendix B, Toolbars and the 
Getting Started Guide.

After installing the 3D tools onto the Drawing toolbar, the tools only become available 
for use when a 2D object is selected in a drawing.

Ready made 3D objects can be repositioned, resized, and edited in the same way as 
2D objects. See Chapter 3, Working with Objects for more information.

3D ready made objects
3D ready made objects are 3D scenes inserted into a drawing using one of the following 
methods. The selection and drawing of 3D objects is the same for all methods of inserting a 3D 
ready made object.

• Click on the triangle ▼ to the right of 3D Objects on the Drawing toolbar (Figure 165) 
and select a 3D object from the sub-toolbar that opens.

• Go to View > Toolbars > 3D-Objects on the Menu bar to open the 3D-Objects toolbar 
(Figure 166). This toolbar has the same options available as the 3D Objects sub-toolbar 
on the Drawing toolbar.

• Go to Shapes > Insert > 3D Objects on the Menu bar and select a 3D object from the 
submenu.

• Go to the 3D Objects panel in the Shapes deck on the Sidebar (Figure 167) and select a 
3D object.

Figure 165: Drawing toolbar
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Figure 166: 3D-Objects toolbar

Figure 167: Shapes deck on Sidebar

Converting 2D objects
Conversion tools for converting a 2D object into a 3D object are available as follows:

• On the Drawing toolbar.

• On the Transformations toolbar.

• Right-clicking on the object and selecting from the context menu.

• Goint to Shape on the main Menu bar and selecting Transformations or Convert from 
the context menu.

• Using the 3D Effects dialog.

To convert a 2D object into a 3D object use one of the following tools.

To 3D

Creates a 3D scene containing an extrusion object (Figure 168).

To 3D Rotation Object

Creates a 3D scene using a default rotation axis. The position of the default axis cannot 
be adjusted (Figure 169).
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Figure 168: Example of using To 3D conversion

Figure 169: Example of using To 3D Rotation Object conversion

Figure 170: Example of using In 3D Rotation Object conversion

Figure 171: Example of using Toggle Extrusion
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In 3D Rotation Object

Creates a 3D scene using a rotation axis. The position of the rotation axis can be 
adjusted to create different 3D objects (Figure 170).

Toggle Extrusion

Creates a 3D shape by extruding a 2D object into 3D. Only 3D shapes that have been 
extruded can be converted back to a 2D object (Figure 171).

Convert To Rotation Object

Available in the 3D Effects dialog. Converts a selected 2D object into a 3D rotation 
object. Also, selecting several ungrouped 2D objects can be converted into a single 3D 
rotation object. For more information, see “3D effects” on page 176.

Extrusion
Extrusion converts a 2D object into a 3D scene by extruding a 2D object toward the observer. 
The scene is rotated by 20 degrees around the horizontal axis to make the 3D effect more 
visible. After selecting a 2D object, convert it to a 3D scene using one of the following methods:

• Right-click on the 2D object and select Convert > To 3D from the context menu.

• Click on To 3D in the Drawing toolbar.

• Go to Shape > Convert > To 3D on the Menu bar.

• Click on Convert to 3D in the 3D Effects dialog. For more information, see “3D effects” 
on page 176.

Rotation
To 3D Rotation Object or Convert to Rotation Object converts a 2D object into a 3D scene by 
rotating the object using the left edge of the bounding box around the object as the axis of 
rotation. Examples of 3D conversion using either of these rotation tools are shown in Figure 169. 
The actual 3D scene created depends on the angle and shape of the object being rotated. After 
selecting a 2D object in a drawing, convert it to a 3D scene using rotation using one of the 
following methods:

• Right-click on a 2D object and select Convert > To 3D Rotation Object from the context 
menu.

• Click on To 3D Rotation Object in the Drawing toolbar. By default, To 3D Rotation 
Object is not installed on the Drawing toolbar, but is available for installation in Visible 
Buttons for the Drawing toolbar.

• Go to Shape > Convert > To 3D Rotation Object on the Menu bar.

• Click on Convert To Rotation Object in the 3D Effects dialog. For more information, see 
“3D effects” on page 176.

• Go to Shape > Convert > In 3D Rotation Object on the Menu bar.

Toggle extrusion
Extrusion is where parallel surfaces are moved to create a 3D shape. In Draw, the 2D surface is 
moved forwards out of the drawing level. At the same time the object is slightly tilted and central 
projection turned on, creating the impression of a 3D shape. Draw uses a default value for this 
extrusion (body depth) based on the size of the 2D object. The value can be changed after the 
extrusion, see “Editing 3D objects” on page 175.
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Extrusion conversion is carried out using Toggle Extrusion. Extrusion only works on Basic 
Shapes, Symbol Shapes, Block Arrows, Flowcharts, Callouts, Stars and Banners, and 
Fontwork. These are included as a part of the default set of tools on the Drawing toolbar, or in 
the Shapes deck on the Sidebar.

1) Select a 2D object in a drawing created from Basic Shapes, Symbol Shapes, Block 
Arrows, Flowcharts, Callouts, Stars and Banners, or Fontwork.

2) Click on Toggle Extrusion on the Drawing toolbar to convert the 2D object into a 3D 
shape.

3) To convert a 3D conversion back into a 2D object, select the 3D object and click on 
Toggle Extrusion on the Drawing toolbar.

Note

Extrusion cannot be used on text objects created using Insert Text Box or Insert 
Vertical Text.

Editing 3D objects

Note

Where 3D scenes are created from more than one 2D object, a 3D scene group is 
automatically created. This 3D scene group cannot be ungrouped and any editing 
carried out affects all 3D objects within the group. To edit an individual 3D object 
within this 3D scene group, enter the group. For more information on working with 
groups, see Chapter 5, Combining Multiple Objects.

Position, Size and Rotation
Editing the position, size and rotation of 3D objects is similar to 2D objects. See Chapter 3, 
Working with Objects for more information.

Figure 172: 3D-Settings toolbar

Figure 173: Example of changing 3D settings
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3D settings
Go to View > Toolbars > 3D-Settings on the Menu bar to open the 3D-Settings toolbar 
(Figure 172). The 3D-Settings toolbar activates when a 3D shape is selected created from a 2D 
object using “Toggle extrusion” on page 174.

Any changes made using the editing tools on the 3D-Settings toolbar are applied to the selected 
3D shape immediately displaying the 3D effect. Figure 173 shows an example of tilting left, 
increasing extrusion depth, and changing 3D color using the 3D-Settings toolbar.

The tools available for editing 3D shapes are as follows.

Tilt Down

Tilts an object downward (horizontal axis rotation) by 5 degrees each time the tool is 
used.

Tilt Up

Tilts an object upward (horizontal axis rotation) by 5 degrees each time the tool is used.

Tilt Left

Tilts an object left (vertical axis rotation) by 5 degrees each time the tool is used.

Tilt Right

Tilts the selected object right (vertical axis rotation) by 5 degrees each time the tool is 
used.

Depth

Opens a pop-up menu where the extrusion depth can be set from an object by a fixed or 
custom amount.

Direction

Opens a pop-up menu where the view direction can be set to create an extrusion in 
either a perspective or parallel projection.

Lighting

Opens a pop-up menu where the direction and intensity of the lighting can be set when 
creating an extrusion.

Surface

Opens a pop-up menu where the surfaces of the object can be set as Wire Frame, Matt, 
Plastic, or Metal display.

3D Color

Opens a pop-up menu where the color used for the extrusion can be set. This color does 
not have to be the same as the color used for the original 2D object.

3D effects
The 3D Effects dialog provides options for editing 3D ready made objects, or 3D scenes. This 
dialog is also used to convert a 2D object to 3D using the tools in the bottom left corner of the 
dialog. Open the 3D Effects dialog using one of the following methods:

• Click on 3D Effects on the Standard or Line and Filling toolbar, if this has been added to 
the tollobar.

• Go to Format > 3D-Effects on the Menu bar.

Any 3D effects applied to a 3D scene are not carried out until Assign is selected in the top right 
of the 3D Effects dialog. This allows for all 3D effect changes to be carried out before application 
to a 3D scene.
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Notes

The 3D Effects dialog cannot be used on 3D shapes created using Toggle 
Extrusion because the correct formatting results will not be achieved. If the 3D 
Effects dialog is used in error, remove any incorrect formatting by going to Format > 
Default Formatting on the Menu bar.

Any options grayed out in the pages in the 3D Effects dialog cannot be used for a 
selected object.

3D conversion

In the bottom left corner of the 3D Effects dialog (Figure 174) are tools for converting a 2D object 
into a 3D scene and changing the projection used in a 3D scene.

Convert to 3D

Converts the selected object into a 3D scene. This tool works in the same way as using 
“Extrusion” on page 174.

Convert to Rotation Object

Converts a 2D object into a 3D scene using body rotation. This tool works in the same 
way as using “Rotation” on page 174.

Figure 174: 3D Effects dialog — Geometry page
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Perspective On/Off

Switches perspective projection on or off for a 3D scene. Perspective projection is a 
technique to create a linear illusion of depth. As objects get further away from the viewer, 
a perspective drawing decreases in size at a constant rate.

Note

The 3D Effects dialog has five pages to provide options for Geometry, Shading, 
Illumination, Textures, and Material. The tools to change pages for the different 
types of 3D effects are located at the top of the 3D Effects dialog.

3D Effects — Geometry

Clicking on Geometry in the 3D Effects dialog (Figure 174) opens the options available on the 
Geometry page to change the geometry of a 3D object.

Geometry

Defines the properties of an object in a 3D scene.

Rounded edges

Enter the amount required to round the corners of a 3D shape as shown by the 
example in Figure 175. The default setting for Rounded edges is 10%.

Scaled depth

Enter the amount required to increase or decrease the frontal area of a selected 3D 
object. Figure 176 shows an example where the Scaled depth has been decreased to 
50%, then increased to 150%. The default setting for Scaled depth is 100%.

Figure 175: Example of rounded edges

(1) Original object (2) 10% rounded edges (3) 75% rounded edges

Figure 176: Example of scaled depth

(1) Original object
(2) 50% scaled depth

(3) 100% scaled depth
(4) 150% scaled depth

178 |Draw Guide 24.8



Figure 177: Example of rotation angle

(1) Original object
(2) Converted using To 3D Rotation Object

(3) Rotation angle changed to 180 deg

Figure 178: Example of increasing depth

(1) Original object
(2) Converted using To 3D

(3) Depth increased to 3cm

Rotation angle

Enter the angle in degrees to rotate a 2D object that has been converted to 3D using 
To 3D Rotation Object. Figure 177 shows an example of a 2D circle where the 
Rotation angle is changed to 180 degrees.

Depth

Enter the extrusion depth for the selected 2D object after it has been converted to 3D. 
Figure 178 shows an example of the original object converted to 3D using the tool 
To 3D, then increasing Depth to 3cm.

Segments

Changes the number of segments that LibreOffice Draw uses to draw a 3D object. The 
higher the number of segments, the smoother the object surface is. However, a high 
segment number may increase the time it takes to generate the 3D object on a display. 
Figure 179 shows the difference on a 3D sphere when the segments have been 
increased from 12 to 24 segments horizontally and vertically.

Horizontal

Enter the number of horizontal segments used in the selected 3D object.

Vertical

Enter the number of vertical segments used in the selected 3D object.

Normals

Modifies the rendering style of the 3D surface.
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Figure 179: Example of using segments

(1) 12 segments (2) 24 segments

Figure 180: Examples of object specific, flat, and spherical effects

(1) Object Specific (2) Flat (3) Spherical

Figure 181: Examples of invert normals and double sided illumination

(1) Invert Normals off, Double Sided 
Illumination off

(2) Invert Normals on, Double Sided 
Illumination off

(3) Invert Normals off, Double Sided 
Illumination on

(4) Invert Normals on, Double Sided 
Illumination on

Object-Specific

Renders the 3D surface according to the shape of the object (Figure 180).

Flat

Renders the 3D surface as polygons (Figure 180).

Spherical

Renders a smooth 3D surface regardless of the shape of the object (Figure 180).

Invert Normals

Inverted normal is a normal that is pointing in the wrong direction (Figure 181). This 
tells a computer that an outside face is actually an inside face when it is not. If there is 
a hollow design, an inverted normal can be indicated because both surfaces facing are 
in and out in the same model.
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Double-Sided Illumination

Lights the outside and the inside of the object (Figure 181). This has only an effect, if 
the inside is drawn at all, see Double-Sided. This is a setting for the whole of the 3D 
scene and not for a single object within the scene.

Double-Sided

3D object has outside (front) and inside (back) faces (Figure 181). With Double-Sided 
switched off, only the outside face of the object is rendered. The effect, when looking 
from outside, is that the object is solid, but, when looking from inside, the front face is 
transparent. If there is no view to the inside face, normal for an extruded 3D object 
with solid texture, Double-Sided should be switched off to improve performance during 
rendering. Any 3D object created using rotation often allows an inside view and it is 
recommended that Double-Sided is switched on.

3D Effects — Shading

The Shading page of the 3D Effects dialog (Figure 182) provides options to set the shading, 
shadow, and camera effects on a selected 3D object.

Shading

Specifies the mode of shading applied to a 3D object (Figure 183).

Figure 182: 3D Effects dialog — Shading page
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Figure 183: Examples of shading mode

(1) Gouraud (2) Phong (3) Flat

Figure 184: Examples of shadow surface angle

(1) 0 deg shadow (2) 50 deg shadow

Gouraud

Gouraud shading mode is a method used to simulate the differing effects of light and 
color across the surface of an object. It achieves smooth lighting on low-polygon 
surfaces without the heavy computational requirements of calculating lighting for each 
pixel.

Phong

Phong shading mode is an interpolation technique for surface shading calculating the 
normal of a point in a polygon by interpolating the vertices normals. The angle 
between normal and lighting direction determines how much of the lighting is used to 
color the pixel.

Flat

Flat shading mode refers to depth perception in 3D models or illustrations by varying 
the darkness level. It assigns a single color of shading to a single segment on the 
surface of the object.

Shadow

Adds or removes a shadow from a selected 3D object (Figure 184). A shadow is 
generated only from the first light source. Enter a Surface Angle from the light source to 
the surface between 0 to 90 degrees to cast a shadow.
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Figure 185: Example of using camera angles

(1) Default settings — distance 2.6 
cm; focal length 10 cm

(2) Distance 10 cm; focal length 100 
cm

Camera

Sets the camera options for a selected 3D scene as if a camera is being used to take a 
photograph (Figure 185). Settings affect only central perspective, not parallel projection.

Distance

Enter the distance to leave between the camera and the center of the selected 3D 
scene. The default setting for distance is 2.6cm.

Focal length

Enter the focal length of the camera lens. A small value corresponds to a fisheye lens 
and a large value to a telephoto lens. The default setting for focal length is 10cm.

3D Effects — Illumination

The Illumination page of the 3D Effects dialog (Figure 186) defines how a 3D scene is 
illuminated and illumination settings apply to all 3D objects in a scene. Light source direction, 
color, and ambient light are specified for a 3D scene. By default, one light source is already 
selected when the Illumination page opens. A maximum of eight sources can be used and each 
light source can use a different color.

Light source location and color are shown in the lower right corner of the Illumination page. The 
vertical slider bar adjusts the lighting angle and the horizontal slider bar rotates the light about 
the object. Alternatively, click on the light point and drag the light source to the required position.

To change the preview from a sphere to a cube, click on the small square to the right of the 
horizontal slider bar and below the vertical slider bar. Each light source selected is shown as a 
small colored sphere in the specified color. The larger colored sphere indicates the active light 
source.

Selecting a light source and setting the illumination effects is as follows:

1) Select a Light source to turn the light source on. The icon changes to an illuminated bulb.

2) Click again on the selected light source to adjust the color for the light source.

3) Select a color for the light from one of the color palettes in the Light source drop-down 
list. A different color can be used for each light source selected.
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Figure 186: 3D Effects dialog — Illumination page

4) Select a color from one of the color palettes in the Ambient light drop-down list to set the 
color of the surrounding light.

5) To deselect a light source, select a light source already selected and click on the light 
source again.

3D Effects — Textures

The Textures page of the 3D Effects dialog (Figure 187) shows the surface texture properties 
set for a selected 3D object. The settings in the Textures page are only available if the area fill 
of a 3D object is set to Gradient, Image, Pattern, or Hatch. For more information on changing 
area fill, see Chapter 4, Changing Object Attributes.

Type

Sets the color properties of the texture.

Black & White

Converts the texture to black and white.

Color

Converts the texture to color.

Mode

Shows or hides shading.
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Figure 187: 3D Effects dialog — Textures page

Only Texture

Applies the texture without shading.

Texture and Shading

Applies the texture with shading to lighten or darken the illumination.

Projection X

Sets the options for displaying the texture along the X axis. Only one of the three 
following options can be selected.

Object-Specific

Automatically adjusts the texture for best fit based on the shape and size of the object. 
This is the default setting except for extrusion objects.

Parallel

Applies the texture parallel to the horizontal axis and is mirrored on the rear side of the 
object. This is the default setting for extrusion objects.

Circular

Wraps the horizontal axis of the texture pattern around an object.

Projection Y

Sets the options for displaying the texture along the Y axis. Only one of the three 
following options can be selected.
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Object-Specific

Automatically adjusts the texture for best fit based on the shape and size of the object. 
This is the default setting except for extrusion objects.

Parallel

Applies the texture parallel to the vertical axis and is mirrored on the rear side of the 
object. This is the default setting for extrusion objects.

Circular

Wraps the vertical axis of the texture pattern around an object.

Filtering

Filters out noise that can occur when a texture is applied to a 3D object.

Filtering On/Off

Applies a soft focus filter blurring the texture slightly to remove unwanted speckles.

3D Effects — Material

The settings on the Materials page of the 3D Effects dialog (Figure 188) change the 3D object 
appearance to represent different materials. Materials and Textures can be combined with each 
other to achieve the desired result.

Figure 188: 3D Effects dialog — Materials page
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Material

Assigns a color from a color palette. For custom colors, see Chapter 11, Advanced Draw 
Techniques for more information on creating custom colors.

Favorites

Select a material type for the selected object from the Favorites drop-down list.

Object color

Select a color from one of the color palettes in the Object color drop-down list to apply 
to the object.

Illumination color

Select a color from one of the color palettes in the Illumination color drop-down list. 
This illuminates the object and brightens parts of the object which lie in shadow 
making the object seem more illuminated.

Specular

Sets the light reflection properties for a selected object simulating the reflecting capacity 
of the surface. The position of an illuminated point is determined by the setting of the first 
light source.

Color

Select a color to be reflected from the object from one of the color palettes in the Color 
drop-down list.

Intensity

Enter the intensity of the specular effect as a percentage.

Colors Dialog

Opens the Pick a Color dialog where custom colors are defined using the 2D graphic and 
numerical gradient chart. Any colors created are stored in the custom palette. See 
Chapter 11, Advanced Draw Techniques for more information on creating custom colors.

Note

Metallic and glass surfaces do not simulate well because the appearance of these 
materials is produced using reflection.

Tip

Do not use a very high brightness value for individual colors. Colors are additive and 
it is easy to end up with a colored area that is white.

Combining objects

Multiple 3D objects cannot be combined using Shape > Combine on the Menu bar, or the 
keyboard shortcut Ctrl+Shift+K (macOS ⌘+Shift+K). Multiple 2D objects have to be created 
first, then a single 3D object created as follows (see Chapter 5, Combining Multiple Objects for 
more information on combining objects):

1) Create multiple 2D objects and carry out all necessary editing changes.

2) Make sure all 2D objects are selected to create a single 3D object.

3) Create a single 3D object combining the selected 2D objects using one of the following 
methods (examples of creating 3D objects are shown in Figure 189):

– Click on To 3D or To 3D Rotation Object on the Drawing toolbar.
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Figure 189: Example of creating 3D object from multiple 2D objects

(1) Multiple 2D objects combined
(2) 3D object created using To 3D

(3) 3D object created using To 3D Rotation 
Object

– Right-click on the selected multiple 2D objects and select Convert > To 3D or To 3D 
Rotation Object from the context menu.

– Go to Shape > Convert > To 3D or To 3D Rotation Object on the Menu bar.

Assembling 3D objects

3D objects that each form a separate 3D scene can be combined or assembled into a single 3D 
scene. An example procedure for assembling 3D objects is as follows and shown in Figure 190:

1) Select a 3D object (for example, a cube) from 3D Objects on the Drawing toolbar, or 
Shapes deck on the Sidebar and place it in a drawing.

2) Select a second 3D object (for example, a sphere) from 3D Objects on the Drawing 
toolbar, or Shapes deck on the Sidebar and place it in the drawing.

3) If necessary, set the area fill to None and the lines to Continuous to create wire frame 
objects. This makes it easier to position both objects in the assembled 3D scene.

4) Select the second 3D object (sphere) and go to Edit > Cut on the Menu bar, or right-click 
on the object and select Cut from the context menu.

5) Double-click the first 3D object (cube) to enter the group, or go Shape > Group > Enter 
Group on the Menu bar.

6) Go to Edit > Paste on the Menu bar, or right-click on the first 3D object and select Paste 
from the context menu. The sphere now appears inside the cube and is now part of the 
same group.

7) If required, edit the individual objects, or change their position within the group.

8) Double-click outside the 3D assembled scene to exit the group, or go to Shape > Group 
> Exit Group on the Menu bar.
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Figure 190: Example of assembling 3D objects

Note

The second object also reappears in its original position when Paste is carried out. 
This object is NOT part of the assembled 3D scene and can be deleted if necessary.
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Connectors and gluepoints

Connectors are lines or arrows where the ends of a line, or arrow, automatically lock to a 
connection or gluepoint on the border of an object. Connector lines between objects remain 
connected to objects, even when objects are moved or rearranged. Also, when an object with a 
connector attached is moved or resized, the connector automatically adjusts its shape to 
accommodate the changes. For example, create a flowchart, or an organization chart, using 
connectors instead of simple lines removes the need to redraw lines between objects when 
making changes to a chart.

When a connector is created or selected, the selection handles are different to the normal 
selection handles used on lines or objects. The termination handles of a connector are round at 
the start and end points of a connector, and square in the center of the lines of a connector, as 
shown by the example of a straight connector in Figure 191. The square selection handles on 
the selected connector are used to change the routing of a connector.

Connectors
LibreOffice Draw has a comprehensive selection of connectors, for example, when used in a 
flowchart or organization chart. The default set of connectors can be accessed using one of the 
following methods:

• Click the triangle ▼ to the right of Connectors on the Drawing toolbar to open a pop-up 
toolbar. The Connectors icon changes shape depending on the last connector used.

• Select a connector from the options available in the Connectors panel in the Shapes 
deck on the Sidebar.

Connectors subtoolbar

If required, the connectors on the Drawing toolbar can be displayed as a Connectors subtoolbar 
as follows:

1) Click on the triangle ▼ on the right of Connectors on the Drawing toolbar to open a 
pop-up toolbar.

Figure 191: Example of connectors between objects
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Figure 192: Connectors subtoolbar

(1) Connector Ends with Arrow
(2) Straight Connector Ends with Arrow
(3) Curved Connector Ends with Arrow
(4) Line Connector Ends with Arrow
(5) Connector
(6) Straight Connector
(7) Curved Connector
(8) Line Connector
(9) Connector Starts with Arrow
(10) Straight Connector Starts with Arrow
(11) Curved Connector Starts with Arrow
(12) Line Connector Starts Arrow

(13) Connector Ends with Circle
(14) Straight Connector Ends with Circle
(15) Curved Connector Ends with Circle
(16) Line Connector Ends with Circle
(17) Connector Starts with Circle
(18) Straight Connector Starts with Circle
(19) Curved Connector Starts with Circle
(20) Line Connector Starts with Circle
(21) Connector with Circles
(22) Straight Connector with Circle
(23) Curved Connector with Circle
(24) Line Connector with Circle

2) Click on the line at the top of the pop-up toolbar and drag the subtoolbar onto the 
Workspace.

3) Release the toolbar to create the Connectors subtoolbar (Figure 192).

Connector types and groups

The full range of available connectors are accessed by clicking on the triangle ▼ on the right of 
the Connectors subtoolbar and selecting Visible Buttons from the context menu. Depending on 
the computer system being used, connectors already installed on the Connectors subtoolbar are 
indicated either by a check mark against the name, or the connector icon is highlighted.

Connectors are grouped into four main groups as follows:

Connector

Standard connectors start with Connector. Line segments run vertically and horizontally. 
Creates a connector with one or more 90 degree angle bends.

Line

Line connectors start with Line. Consists of a line segment with two smaller segments at 
the ends and draws a connector that bends near a gluepoint. To adjust the length of the 
line segment between a bend point and a gluepoint, click on the connector and drag the 
selection handle.

Straight

Straight connectors start with Straight. Consists of a single line and draws a straight line 
connector.

Curved

Curved connectors start with Curved. Based on Bézier curves, a curved connector is 
drawn and bends around objects.

Connectors are installed on the Connectors subtoolbar in the same order they appear in the 
Visible Buttons drop-down list. 

Adding connectors to objects

1) Click on the triangle ▼ on the right of Connectors on the Drawing toolbar to open the 
options available for selecting connectors.
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Figure 193: Example of object connector gluepoints

2) Select the type of connector required and move the cursor onto the first object. When the 
cursor is over an object, small crosses appear as gluepoints around the object edges 
replacing the object selection handles, as shown by the example in Figure 193.

3) Position the cursor over a gluepoint, then click and drag the cursor toward another object 
to start creating a connector. When the cursor reaches the target object, small crosses 
appear indicating the gluepoints around the object edges.

4) Move the cursor over the required gluepoint on the target object and release the 
connector to draw the connector. The round selection handles at each end of the 
connector are attached to the gluepoints on each object.

5) If necessary, use the square control handles that appear on the connector to adjust the 
connector route so that it does not cover any other object in the connector route. See 
“Modifying connectors” on page 194 for more information.

Notes

The start and end round selection handles of a connector cannot be swapped. To 
change the start and end points of a connector, the connector has to be deleted and 
a new connector drawn in the opposite direction.

The end point of a connector can also be positioned in an empty part of a drawing 
where it is locked into place. This end point can then be moved and attached to an 
object when required.

Modifying connectors

Connectors can be modified using one of the following methods:

• To detach or reposition a connector, click and drag one of the round selection handles of 
a connector line to a different location.

• To change the connector route between objects so that the connector does not overlap 
any objects on the route, click on one of the square selection handles on the connector 
line and drag it to a new position.
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Figure 194: Connector dialog

• To modify a connector, right-click on the connector and select Connector from the 
context menu to open the Connector dialog (Figure 194). Use this dialog to change 
connector type and connector properties.

The options available in the Connector dialog are as follows:

Type

Select the connector type and group from the drop-down list. See “Connector types and 
groups” on page 193 for more information.

Line skew

Defines the skew of a connector line. The dialog preview displays the result of any 
changes.

Line spacing

Sets the spacing around a connector.

Begin horizontal

Enter the amount of horizontal space required at the beginning of a connector.

End horizontal

Enter the amount of horizontal space required at the end of a connector.

Begin vertical

Enter the amount of vertical space required at the beginning of a connector.

End vertical

Enter the amount of vertical space required at the end of a connector

Preview box

Displays a preview of the selected connector and the objects the connector is connected 
to. The preview changes as changes to the selected connector are made using the 
Connector dialog. A left click zooms in on the preview and a right-click zooms out.
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Figure 195: Gluepoints toolbar

Gluepoints
Gluepoints are not the same as object selection handles. The selection handles are for moving 
or changing the shape of an object (see Chapter 3, Working with Objects for more information). 
Gluepoints are used to fix or glue a connector to an object so that when the object moves, the 
connector stays fixed to that object.

All objects have gluepoints, as shown by the example in Figure 193 on page 194. Gluepoints are 
not normally displayed on an object and only become visible when a connector is selected using 
one of the following methods.

• Select Connectors on the Drawing toolbar. The connector icon displayed on the 
Drawing toolbar is the previous connector type used.

• Select a connector type in the Connectors panel in the Shapes deck on the Sidebar. 

To add, customize or delete gluepoints, go to View > Toolbars > Gluepoints on the Menu bar to 
activate the Gluepoints toolbar (Figure 195). This toolbar only becomes visible after using one of 
the following methods:

• Select Show Gluepoint Functions on the Drawing toolbar.

• Select Edit > Gluepoints on the Menu bar.

Notes

Show Gluepoint Functions on the Drawing toolbar is not part of the default set of 
tools for the Drawing toolbar. To add Show Gluepoint Functions icon to the 
Drawing toolbar, right-click in an empty area on the Drawing toolbar and select 
Visible Buttons > Gluepoints from the context menu.

Each gluepoint added to an object can have only one horizontal position and one 
vertical position. Only one of the horizontal position tools and one of the vertical 
position tools can be selected and used at any one time.

Gluepoint types

When the Gluepoints toolbar opens, only the five tools on the left of Gluepoint Relative are 
active. The remaining six tools on the right of the toolbar only become active when Gluepoint 
Relative is deselected.

Insert Gluepoint

Inserts a gluepoint at the cursor position in an object when the button is clicked.

Exit Direction Left

Connector attaches to the left edge of the selected gluepoint.

Exit Direction Top

Connector attaches to the top edge of the selected gluepoint.

Exit Direction Right

Connector attaches to the right edge of the selected gluepoint.
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Exit Direction Bottom

Connector attaches to the bottom edge of the selected gluepoint.

Gluepoint Relative

When selected, the gluepoint moves when an object is resized maintaining its position 
relative to the object borders. When deselected, a gluepoint can be repositioned after the 
object is resized. This tool is selected by default when the Gluepoint toolbar opens.

The following six tools only become active when Gluepoint Relative is deselected.

Gluepoint Horizontal Left

When an object is resized, the selected gluepoint remains fixed at the left edge of the 
object.

Gluepoint Horizontal Center

When an object is resized, the selected gluepoint remains fixed at the center of the 
object.

Gluepoint Horizontal Right

When an object is resized, the selected gluepoint remains fixed at the right edge of the 
object.

Gluepoint Vertical Top

When an object is resized, the selected gluepoint remains fixed at the top edge of the 
object.

Gluepoint Vertical Center

When an object is resized, the selected gluepoint remains fixed at the vertical center of 
the object.

Gluepoint Vertical Bottom

When an object is resized, the selected gluepoint remains fixed at the bottom edge of the 
object.

Adding gluepoints

By default, objects have four gluepoints, as shown in the example in Figure 193 on page 194. 
Additional gluepoints are added to an object as follows:

1) Go to View > Toolbars > Gluepoints on the Menu bar to activate the Gluepoints toolbar.

2) Make sure no objects are selected and use one of the following methods to open the 
Gluepoints toolbar:

– Select Show Gluepoint Functions on the Drawing toolbar.

– Select Edit > Gluepoints on the Menu bar.

3) Select the object, then click on Insert Gluepoint on the Gluepoints toolbar.

4) Move the cursor to the required position on the selected object and the cursor changes 
shape. Normally this is a cross, but the actual shape used depends on the computer 
setup.

5) Click once to add a gluepoint. To add more gluepoints, move the cursor to a new position 
and click.

6) When adding gluepoints is completed, move the cursor off the selected object and click 
in an empty space to deselect the object.

Chapter 8,  Connections, Flowcharts, and Organization Charts | 197



7) Alternatively, right-click on a gluepoint previously added to the object and select Insert 
Gluepoint from the context menu, then click and drag the new gluepoint to the required 
position.

8) Select the type of gluepoint required from the options available on the Gluepoints toolbar. 
See “Gluepoint types” on page 196 for more information.

Note

For objects with no fill, gluepoints are added to the border of an empty object.

Tip

When adding, moving or customizing gluepoints, it is recommended to use the zoom 
function making it easier to work with gluepoints. See Chapter 3, Working with 
Objects for more information. Also, gluepoints can snap to the grid making it easier to 
position a gluepoint.

Customizing gluepoint exit direction

Customize the exit direction for a gluepoint that is already added to an object as follows:

1) Go to View > Toolbars > Gluepoints on the Menu bar to activate and open the 
Gluepoints toolbar.

2) Double-click on a gluepoint that is already added to an object and select the gluepoint for 
customization.

3) Select the required exit direction for a connector attached to the gluepoint using one of 
the following methods:

– Select the required exit direction on the Gluepoints toolbar.

– Right-click on a gluepoint and select an exit direction from the context menu.

Customizing gluepoint positioning

Note

Only gluepoints that are added to an object can be customized. The default 
gluepoints (example shown in Figure 193 on page 194) included with an object 
cannot be customized or deleted.

Customize the horizontal and vertical positioning for a gluepoint that is already added to an 
object as follow:

1) Go to View > Toolbars > Gluepoints on the Menu bar to activate and open the 
Gluepoints toolbar.

2) Double-click on a gluepoint that on an object to select the gluepoint for customization.

3) Click on Gluepoint Relative on the Gluepoints toolbar to deselect the tool, or right-click 
on the gluepoint and select Gluepoint Relative from the context menu to deselect the 
tool.

4) Select the horizontal and vertical positioning tools required for the gluepoint using one of 
the following methods. Only one horizontal positioning tool and one vertical positioning 
tool can be used at any one time:

– Click and select the required horizontal or vertical positioning tool in the Gluepoints 
toolbar.
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– Right-click on the gluepoint and select the required horizontal and vertical positioning 
from the context menu.

Deleting gluepoints

1) Select a gluepoint for deletion that has previously been added to the object.

2) Press the Delete or Backspace key, or go to Edit > Cut on the Menu bar.

Connector text
Text is easily added and formatted to connectors making a flowchart or organization chart easier 
to follow. See Chapter 9, Adding and Formatting Text for more information on working with and 
formatting text.

Adding text

1) Select a connector and the control points become active.

2) Enter text mode using one of the following methods. A flashing text cursor appears close 
to the connector and the Text Formatting toolbar (Figure 196) opens.

– Click on Insert Text Box or Insert Vertical Text (if added) on the Drawing toolbar.

– Use the keyboard shortcut F2 to create horizontal text on the selected connector.

3) Type the required text for the connector.

4) If necessary, format the connector text. See “Formatting text” on page 199 for more 
information on formatting and editing text text.

5) When adding and formatting text is complete, move the cursor away from the text and 
connector, then click to end text mode. This also closes the Text Formatting toolbar.

Note

With a default installation of LibreOffice, the Insert Text Box and Insert Vertical 
Text tools may not be installed on the Drawing toolbar. To add text tools to the 
Drawing toolbar, right-click in an empty area in the Drawing toolbar and go to Visible 
Buttons, then select Text Box and/or Vertical Text from the context menu.

Formatting text

1) Select a connector with text added and activate the control points to enter text mode. 
See “Adding text” on page 199 for more information on adding text to a connector.

2) Use the tools available on the Text Formatting toolbar, or the options available in Format 
> Text on the Menu bar to format the text. By default, connector text is formatted with 
horizontal central alignment and vertical central positioning for the connector text 
paragraph.

3) Right-click on the connector text and select Text Attributes from the context menu to 
open the Text dialog (Figure 197) and format the connector text using the options 
available in the dialog.

4) Click OK to save the changes to the text and close the Text dialog.

5) Move the cursor away from text and connector, then click to end the text mode. This also 
closes the Text Formatting toolbar.
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Figure 196: Text Formatting toolbar

Figure 197: Text dialog — Text page

Notes

The options available for text animation are not recommended for connector text 
unless the drawing is going to be displayed as part of a presentation. See the 
Impress Guide for more information on text animation.

The options available for text columns are not recommended for connector text. Text 
columns are normally used for text that is placed into a text box when adding 
information to a drawing, or into an object such as a rectangle or circle. For more 
information on text columns, see Chapter 9, Adding and Formatting Text.

The options available in the Text dialog are as follows:

Drawing Object Text

Fit to frame

Resizes the text to fit the entire area of a connector rectangle or frame.

Adjust to contour

Adapts the text flow so that it matches the contours of the selected connector.
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Spacing to Borders

Specify the amount of space to leave between the connector and the borders of the text.

Text Anchor

Select one of nine positions to anchor the text within the connector rectangle.

Full width

Anchors the text to the full width of the connector rectangle. When selected, only the top, 
middle and bottom center positions can be used to anchor the text.

Figure 198: Example flowchart

Chapter 8,  Connections, Flowcharts, and Organization Charts | 201



Figure 199: Flowchart subtoolbar

(1) Flowchart: Process
(2) Flowchart: Alternate Process
(3) Flowchart: Decision
(4) Flowchart: Data
(5) Flowchart: Predefined Process
(6) Flowchart: Internal Storage
(7) Flowchart: Document
(8) Flowchart: Multidocument
(9) Flowchart: Terminator
(10) Flowchart: Preparation
(11) Flowchart: Manual Input
(12) Flowchart: Manual Operation
(13) Flowchart: Connector
(14) Flowchart: Off-page Connector

(15) Flowchart: Card
(16) Flowchart`: Punched Type
(17) Flowchart: Summing Junction
(18) Flowchart: Or
(19) Flowchart: Collate
(20) Flowchart: Sort
(21) Flowchart: Extract
(22) Flowchart: Merge
(23) Flowchart: Stored Data
(24) Flowchart: Delay
(25) Flowchart: Sequential Access
(26) Flowchart: Magnetic Disc
(27) Flowchart: Direct Access Storage
(28) Flowchart: Display

Flowcharts

An example flowchart is shown in Figure 198 and the following basic steps are used when 
creating a flowchart:

• When adding objects or flowchart shapes to a flowchart, see Chapter 2, Drawing Basic 
Shapes for information on how to draw and resize object shapes.

• Add text to each flowchart shape to make it easily identified in the flowchart. See 
Chapter 2, Drawing Basic Shapes and Chapter 11, Advanced Draw Techniques for more 
information.

• Use connector lines in a flowchart. This allows repositioning of an object in a flowchart 
while maintaining connections with the other objects in the flowchart. See “Who is this 
user guide for?” on page 8 for more information.

• Use the zoom, grid, and snap functions to help in positioning objects in a flowchart. See 
Chapter 3, Working with Objects and Object Points for more information.

• Use the alignment and distribution functions to give a flowchart a more professional look. 
See Chapter 5, Combining Multiple Objects for more information.

• Use the Flowchart subtoolbar (Figure 199) and its a large selection of flowchart tools to 
create a flowchart (also known as flow diagrams). Click on Flowchart on the Drawing 
toolbar to open the Flowchart subtoolbar.
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Figure 200: Example organization chart

Organization charts

Draw does not have a toolbar for organization charts, but these charts are easily created using 
basic shapes, flowchart shapes, and connectors. Hierarchy in an organization is easily indicated 
using shading and/or color. When using shading and color in an organization chart, make sure 
the selection provides a good contrast between the text and the shading or color. This makes the 
chart easy to read on a computer display, or in a printed document. An example of an 
organization chart is shown in Figure 200.

• When adding objects to a chart, see Chapter 2, Drawing Basic Shapes for information on 
how to draw and resize object shapes.

• Add text to each object in the organization chart to make it easily identified in the chart. 
See Chapter 2, Drawing Basic Shapes and Chapter 11, Advanced Draw Techniques for 
more information.

• Use connectors in an organization chart. This allows repositioning of an object in a chart 
while maintaining connections with the other objects in the chart. See “Who is this user 
guide for?” on page 8 for more information.

• Use the zoom, grid, and snap functions to help in positioning objects in a chart. See 
Chapter 3, Working with Objects and Object Points for more information.

• Use the alignment and distribution functions to give an organization chart a more 
professional look. See Chapter 5, Combining Multiple Objects for more information.

• Duplicate objects when more than one of the same shape and size is required. See 
Chapter 5, Combining Multiple Objects for more information.
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Introduction

Text used in drawings is placed inside an object or text box. This chapter provides information on 
how to create, format, use, delete text, and information for various types of text that can be 
inserted into a drawing. Also, information is included on how to insert special forms of text such 
as ordered or unordered lists, tables, fields, hyperlinks, columns, and Fontwork.

Note

When selecting text tools to add text to a drawing, Draw automatically switches to 
text mode. Also, the Text Formatting toolbar (Figure 201) automatically opens 
replacing the Line and Filling toolbar at the top of the drawing.

Text mode

Activating text mode
Before text is inserted into a drawing, text mode must be activated using one of the following 
methods.

• For horizontal text only, go to Insert > Text Box on the Menu bar.

• For horizontal text only, use the keyboard shortcut F2.

Click on Insert Text Box for horizontal text, or Insert Vertical Text for vertical text on the 
Drawing toolbar (Figure 202), or Text toolbar (Figure 203).

Adding vertical text
If Insert Vertical Text is not available on the Drawing toolbar (Figure 202), it is added to the 
toolbar as follows:

1) Go to Tools > Options > Language Settings > Languages (macOS LibreOffice > 
Preferences > Language Settings > Languages) on the Menu bar to open the 
Languages page in the Options dialog.

2) In Default Languages for Documents, select the option Asian. Accept the default 
settings for this option.

3) Click OK to close the Options dialog and save the changes.

4) Right-click in an empty area on the Drawing toolbar, or the downward triangle ▼, and 
select Visible Buttons from the context menu.

5) Select Vertical Text from the drop-down list of options to add Insert Vertical Text to the 
Drawing toolbar.

Figure 201: Text Formatting toolbar
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Figure 202: Drawing toolbar

Figure 203: Text toolbar

Adding vertical text
If Insert Vertical Text is not available on the Drawing toolbar (Figure 202), it is added to the 
toolbar as follows:

1) Go to Tools > Options > Language Settings > Languages (macOS LibreOffice > 
Preferences > Language Settings > Languages) on the Menu bar to open the 
Languages page in the Options dialog.

2) In Default Languages for Documents, select the option Asian. Accept the default 
settings for this option.

3) Click OK to close the Options dialog and save the changes.

4) Right-click in an empty area on the Drawing toolbar, or the downward triangle ▼, and 
select Visible Buttons from the context menu.

5) Select Vertical Text from the drop-down list of options to add Insert Vertical Text to the 
Drawing toolbar.

Text toolbar
It is recommended to have the Text toolbar (Figure 203) available in Draw when working with 
text. If the Text toolbar is not available, go to View > Toolbars on the Menu bar and select Text 
from the context menu to add it to the Draw workspace.

Text boxes

Creating text boxes
When text is added to a drawing, a text box is automatically created. By default, the text box 
either expands horizontally to accommodate a single line of horizontal text, or vertically to 
accommodate a single line of vertical text.

Note

Text boxes are only for text and cannot contain illustrations, inline pictures, formulas, 
tables, or objects.
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Figure 204: Example of text information on Status Bar

1) Activate text mode in Draw for horizontal or vertical, see “Activating text mode” on 
page 206. The Text Formatting toolbar automatically opens, replacing the Line and Filling 
toolbar.

2) Click at the approximate position in the drawing to insert the text box. A text box is 
created containing a flashing text cursor for the operating system and computer setup 
being used.

3) Type or paste the text into the text box and the text box expands either horizontally or 
vertically to accommodate a single line of text. Also, the left corner of the Status Bar 
indicates text edit mode and the position of the text cursor (Figure 204).

4) To create multiple lines in the text box, use one of the following methods:

– Press the Enter key at the end of a line of text to create single line paragraphs inside 
the text box. The text box expands to accommodate more lines of text.

– For horizontal text, click and drag the text cursor horizontally creating a text box with 
the approximate width required. As the limits of the text box are reached, the text 
automatically word wraps inside the text box and increases text box height as more 
text lines are added.

– For vertical text, click and drag the text cursor vertically creating a text box with the 
approximate height required. As the limits of the text box are reached, the text 
automatically word wraps inside the text box and increases text box width as more text 
lines are added.

5) Move, resize, rotate or format the text box as required. For more information, see the 
following sections and Chapter 3, Working with Objects.

6) Format the text using the various tools on the Text Formatting toolbar. For more 
information on text formatting, see “Formatting text” on page 217.

7) When adding and formatting text is completed, click outside the text box to save the 
changes and deselect the text box.

Text box borders
By default, when a text box is created, the borders of the text box are only displayed when the 
text box is selected. If necessary, use one of the following methods to create a visible border 
around the text box.
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Figure 205: Line and Filling toolbar

Line and Filling toolbar

1) Click on a text box to select it and display the border indicating that the text box is in edit 
mode.

2) If the Line and Filling toolbar is not visible, go to View > Toolbars > Line and Filling on 
the Menu bar to open the toolbar.

3) In Line Style on the Line and Filling toolbar (Figure 205), select a line style from the 
options in the drop-down list.

4) In Line Thickness on the Line and Filling toolbar, enter a line width for the text box 
border.

5) In Line Color on the Line and Filling toolbar, select a color from one of the available 
color palettes, or create a custom color.

6) Click outside the text box to exit edit mode and save the changes.

Line dialog

1) Click on a text box to select it and display the border indicating that the text box is in edit 
mode.

2) Open the Line dialog (Figure 206) using one of the following methods:

– Right-click on the text box border and select Line from the context menu.

– Go to Format > Line on the Menu bar.

3) Click on Line to open the Line page.

4) Click on Line to open the Line page.

5) In Style, select a line style from the drop-down list to use as a text box border.

6) In Color, select a color for the line style from one of the available color palettes, or create 
a custom color.

7) In Thickness, enter a width for the line style selected.

8) In Transparency, enter a percentage value for the line style, if required.

9) In Corner Style, select the type of corner style from the drop-down list.

10) Click OK to save the changes and close the Line dialog, then click outside the text box to 
exit edit mode.
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Figure 206: Line dialog —  Line page — Text box border

Figure 207: Example of using rounded corners on a text box

Note

For a corner style to be clearly visible in a text box border, it is recommended to set 
the line thickness above 0.35cm, as shown by the example in Figure 207.

Line panel in Sidebar

1) Click on a text box to select it and display the border indicating that the text box is in edit 
mode.

2) In the Sidebar, click on Properties to open the Properties deck in the Sidebar, then click 
on Line to open the Line panel (Figure 208).

3) In Line, select a line style from the drop-down list to use as a text box border.

4) In Thickness, enter a width for the line style selected.
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Figure 208: Line panel in Properties deck on Sidebar for Text Box

5) In Color, select a color for the line style from one of the available color palettes, or create 
a custom color.

6) In Transparency, enter a percentage value for the line style, if required.

7) Click outside the text box to exit edit mode.

Moving text boxes
1) Click on a text box to select it. The border is displayed indicating that the text box is in 

edit mode.

2) Move the cursor over the border. The cursor changes shape to the move symbol for the 
computer setup (for example, a clenched hand).

3) Click on the border and drag the text box to a new position in the drawing. A ghosted 
outline of the text box shows where it will be placed (Figure 209).

4) Release the text box when it is in the required position.

5) To accurately position a text box, use the Position and Size dialog, or the Position and 
Size panel in the Properties deck on the Sidebar. See Chapter 3, Working with Objects 
for more information.

6) When the text box is in the required position, click outside the text box to save the 
changes and deselect the text box.
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Figure 209: Example moving a text box

Figure 210: Example resizing a text box

Resizing text boxes
1) Click on a text box to select it and display the border indicating that the text box is in edit 

mode.

2) Move the cursor over one of the selection handles. The cursor changes shape to the 
resizing symbol for the computer setup (for example, a double-headed arrow). The 
selection handles are used to resize the text box as follows:

3) Corner handles change the width and height of the text box simultaneously.

4) Top and bottom selection handles change the height of the text box.

5) Right and left selection handles change the width of the text box.

6) Click and drag the border to a new position to resize the text box. A ghosted outline of 
the text box shows is displayed as the text box is resized, as shown by the example in 
Figure 210.

7) Release the text box when it reaches the required size.

8) To accurately resize a text box, use the Position and Size dialog, or the Position and 
Size panel in the Properties deck on the Sidebar. See Chapter 3, Working with Objects 
for more information.

9) When the text box is at the required size, click outside the text box to save the changes 
and deselect the text box.

Note

When resizing a text box, press and hold the Shift key to maintain text box 
proportions, then click and drag a selection handle to resize. Release the cursor 
before releasing the Shift key.
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Figure 211: Example rotating a text box

Rotating text boxes

1) Click on a text box to select it and display the border indicating that the text box is in edit 
mode.

2) Click again on the text border and the selection handles change shape and color to 
indicate rotation mode. Also, a rotation point appears in the center of the text box.

3) Click on a corner selection handle and drag to rotate the text box. A ghosted outline of 
the text box being rotated around the rotation point appears and the current angle of 
rotation is shown in the status bar (Figure 211).

4) If required, click and drag the rotation point to a new position and change rotation angle 
of the text box. The rotation point can be positioned outside of the text box.

5) Release the text box when it is at the required rotation angle.

6) To accurately rotate a text box, use the Rotation page in Position and Size dialog, or the 
Position and Size panel in the Properties deck on the Sidebar. See Chapter 3, Working 
with Objects for more information.

Note

When rotating a text box, the top, bottom, and side selection handles are visible, but 
not available for rotating a text box. Also, text boxes cannot be sheared, slanted, or 
flipped vertically/horizontally.

Formatting text boxes
The formatting options available for area fill and box borders of text boxes are the same as other 
objects in a drawing. After formatting a text box to match the drawing requirements, the text 
attributes are formatted to make the text appear correctly inside the text box. See Chapter 3, 
Working with Objects for more information on formatting the area fill or borders of a text box.

1) Select a text box and use one of the following methods to open the Text dialog 
(Figure 212).

– Right-click on the text box and select Text Attributes from the context menu.

– Go to Format > Text Attributes on the Menu bar.

2) Click on Text in the Text dialog to open the Text page and access to the formatting 
options.
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Figure 212: Text dialog — Text page — Drawing Object Text

3) If required, click on Text Animation to open the Text Animation page to access options 
for animating the text. For more information on using text animation in a drawing, see 
“Text animation” on page 228.

4) If required, click on Text Columns to open the Text Columns page to access options for 
creating columns in a text box. For more information on using text columns in a drawing, 
see “Text columns” on page 225.

5) Click OK to save the changes to text attributes and close the Text dialog.

6) Click in a blank space to deselect the text box and end the text editing mode.

Text box formatting options

Drawing Object Text

Fit width to text

Expands or reduces text box width to match the length of the text, if the text box is 
smaller or larger than the text. Can be used with Fit height to text to automatically 
adjust width and height of the text box to the text.

Fit height to text

Expands or reduces text box height to match the height of the text, if the text box is 
smaller or larger than the text. Can be used with Fit width to text to automatically 
adjust width and height of the text box to the text.

Fit to frame

Resizes text width and height to use the entire area of a text box without changing text 
box width or height. This option is not available if Fit width to text and/or Fit height to 
text options are selected.

Spacing to Borders

Specify the amount of space to create margins between the text and the borders of a text 
box.
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Text Anchor

Anchors the text to one of nine positions within a text box. The left and right anchor 
positions can only be selected when Full width is NOT selected. A text anchor only 
determines the position of the text within a text box and does not change the paragraph 
alignment of text inside a text box.

Full width

When selected, text box width expands to fit the longest paragraph of text inside a text 
box as a single line. When selected, only the top, middle or bottom center positions in 
Text Anchor can be used to anchor text inside a text box.

Deleting text boxes
1) Click on the text box so that the selection handles are visible indicating that the text box 

is in edit mode.

2) Press the Delete or Backspace key. The text box is deleted without any warning.

Text in objects

By default, an object is not dynamic when first created in Draw and does not behave like a text 
box. Any text placed inside a Draw object does not word wrap.

To keep text within the borders of an object, use paragraphs, line breaks, smaller text size, 
increasing object size, or a combination of all methods. Actual method method available 
depends on the type of object selected.

Note

Text can be added to most objects. However, text cannot be added to 3D objects, or 
control elements such as buttons.

Adding text to objects
An example of adding text into a object is shown in Figure 213. The top object does not have the 
word wrap option applied and the bottom object has the word wrap option applied.

1) Create an object in a drawing and make sure the object is selected with the selection 
handles displayed.

Figure 213: Example of text word wrap inside an object
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2) Enter text mode on the selected object using one of the following methods:

– Click on Insert Text Box for horizontal text, or Insert Vertical Text for vertical text on 
the Drawing or Text toolbar.

– For horizontal text, double-click on the selected object.

– For horizontal text, use the keyboard shortcut F2.

3) Type or paste text into the selected object.

4) Format the text using the various tools on the Text Formatting toolbar, the panels in the 
Properties deck on the Sidebar, or the options in Format on the Menu bar. For more 
information on text formatting, see “Formatting text” on page 217.

5) If the text goes outside the object borders, access text formatting options for a Draw 
object as follows:

a) Double click on the text inside the selected object to select the text.

b) Right click on the selected text and select Text Attributes to open the Text dialog for 
Drawing Object Text (Figure 212 on page 214).

c) Format the text using the available options. For more information, see "Text options for
objects" on page 217.

6) If required, click on Text Animation to open the Text Animation page and access 
animation options for text. For more information on using text animation in a drawing, see 
“Text animation” on page 228.

7) If required, click on Text Columns to open the Text Columns page and access options 
for creating columns inside an object. For more information on using text columns in a 
drawing, see “Text columns” on page 225.

Figure 214: Text dialog — Text page — Custom Shape
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Note

The Text dialog for Custom Shape Text (Figure 214) used for adding text to objects is 
similar to the Text dialog (Figure 212 on page 214) used for formatting text boxes.

Text options for objects
Custom Shape Text

Word wrap text in shape

Wraps text to fit inside an object. For example, if the width of an object is changed, 
then the height of the object either increases or decreases allowing for an increase or 
decrease in the number of text lines.

Resize shape to fit text

Resizes an object to fit the text that is being entered into the object. For example, if the 
object already contains one multi-line paragraph of text and this option is selected, 
then object width expands and height decreases until the text is a single line of text.

Spacing to Borders

Specify the amount of space to leave between the text and borders of an object.

Text Anchor

Anchors the text to one of nine positions within a text box. The left and right anchor 
positions can only be selected when Full width is not selected. A text anchor only 
determines the position of text within a text box and does not change the paragraph 
alignment of text inside an object.

Full width

When selected, object width expands to fit the longest paragraph of text inside an object 
as a single line. When selected, only the top, middle or bottom center positions in Text 
Anchor can be used to anchor text inside a text box.

Formatting text

Text formatting creates a more professional drawing without distracting elements. Text formatting 
tools are available on the Text Formatting toolbar and drop-down menus in Format on the Menu 
bar. For more information on text formatting, see the Writer Guide.

When several text boxes and/or objects in a drawing require the same text formatting, it is 
recommended to use drawing styles. For more information on using and creating styles, see 
Chapter 4, Changing Object Attributes.

Note

Using Edit > Paste on the Menu bar, or the keyboard shortcut Ctrl+V (macOS 
⌘+V) pastes copied text directly into a drawing creating an OLE object and DOES 
NOT create a Draw object. When creating text boxes, or adding text to Draw objects, 
it is recommended to paste text into Draw objects as unformatted text.

Pasting text
Pasting copied text from another object, drawing, or document into a text box or object, the 
copied text retains formatting from the source drawing or document. This copied text may not 
match text formatting already in use. It is recommended to paste text into a drawing as 
unformatted text, then apply formatting to match the text formatting already used in the target 
drawing.

Chapter 9,  Adding and Formatting Text | 217



1) Copy and paste text as unformatted text into a drawing, or draw object using one of the 
following methods:

– Go to Edit > Paste Special > Paste Unformatted Text on the Menu bar.

– Go to Edit > Paste Special > Paste Special on the Menu bar to open the Paste 
Special dialog. Select Unformatted text and click OK to close the dialog.

– Use the keyboard shortcut Ctrl+Shift+V (macOS ⌘+Shift+V) and the Paste 
Special dialog opens. Select Unformatted text and click OK to close the dialog.

– Click on the triangle ▼ on the right of Paste on the Standard toolbar and select 
Unformatted text from the context menu.

2) Format the pasted text to the drawing requirements, or apply a drawing style. 
Unformatted text is pasted into a text box at the cursor position, or inside a selected 
object and formatted to the default drawing style.

Quick font resizing
After selecting text, increasing or decreasing font size can be quickly carried out using the tools 
Increase Font Size (Ctrl+]) (macOS ⌘+]) and Decrease Font Size (Ctrl+[) (macOS ⌘+[) 
on the Text Formatting toolbar.

Note

When using quick font resizing, any change in font size depends on the standard 
font sizes available for the font in use in the target drawing object.

Selecting text
Text must be selected before it can be formatted using one of the following methods. Any 
formatting changes apply only to the selected text.

• To format all the text in a text box or object, click once on the border of the text box or 
object to display the selection handles. Formatting changes then apply to all text in the 
text box or object.

• To format only part of the text, select text using one of the following methods:

– Click in the text and drag the cursor over the text to highlight the text.

– Double-click on text to select a complete word, or triple-click to select a whole 
paragraph.

– Click in the text, then press and hold the Shift key, then use the arrow keys to select 
text.

Paragraph formatting

Direct formatting

Direct or manual paragraph formatting is applied directly to selected paragraphs. This direct or 
manual formatting overrides any formatting that has been applied using paragraph formatting 
and drawing styles.

1) Select the text (see “Selecting text” on page 218) and format using one of the following 
methods:

– Various formatting tools on the Text Formatting toolbar.
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– Go to Format on the Menu bar and select a formatting option from the drop-down 
menu. Selecting a formatting option opens either a context menu, or dialog providing 
further formatting options to apply to the selected text.

– Use the options available in the Paragraph and Character dialogs.

– Use the options available in the Paragraph and Character panels in the Properties 
deck on the Sidebar.

2) Click outside the text box, or object to deselect the text edit mode.

Paragraph dialog

1) Click anywhere in the paragraph being formatted.

2) Use one of the following methods to open the Paragraph dialog (Figure 215).

– Right-click on the selected text and select Paragraph from the context menu.

– Go to Format > Paragraph on the Menu bar.

3) Use the various options on the tabbed pages of the Paragraph dialog to format the text.

4) Click OK to save the changes and close the Paragraph dialog.

5) Click outside the text box or object to deselect the text.

Note

For information on the various text formatting options available in the pages of the 
Paragraph dialog, refer to the Writer Guide.

Figure 215: Paragraph dialog — Indents & Spacing page
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Figure 216: Paragraph panel in Properties deck on Sidebar

Paragraph panel in Sidebar

Use the Paragraph panel (Figure 216) in the Properties deck on the Sidebar to format 
paragraphs of text. Formatting options are limited, but similar in use to the formatting options 
available in the Paragraph dialog. Any formatting applied to a paragraph using the Paragraph 
panel is immediate.

1) Click anywhere in the paragraph being formatted.

2) On the Sidebar, click on Properties to open the Properties deck.

3) If necessary, click on the expansion symbol on the left of the Paragraph title bar to open 
the Paragraph panel.

4) Format the text using the various options available in the Paragraph panel.

5) If necessary, click on More Options on the right of the title bar to open the Paragraph 
dialog to format text.

Note

For information on the various formatting options available for text in the Paragraph 
panel on the Sidebar, refer to the Writer Guide.

Character formatting

Direct formatting

Direct or manual character formatting is applied directly to selected characters. This direct or 
manual formatting overrides any formatting that has been applied using character or paragraph 
formatting and drawing styles.

1) Select the characters for formatting, see “Selecting text” on page 218 for more 
information.
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2) Format characters using one of the following methods.

– The various formatting tools on the Text Formatting toolbar. Formatting applied to 
characters is immediate.

– Go to Format on the Menu bar. Selecting a formatting option opens either a context 
menu or dialog where further formatting options are selected.

– Use the options available in the Character dialog. Clicking OK on the dialog applies 
the formatting changes.

– Use the options available in the Character panel in the Properties deck on the 
Sidebar. Formatting applied to characters is immediate.

3) Click outside the text box or object to deselect the text.

Character dialog

1) Select the characters for formatting and open the Character dialog (Figure 217) using 
one of the following methods:

– Right-click on the characters and select Character from the context menu.

– Go to Format > Character on the Menu bar.

Figure 217: Character dialog — Fonts page
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Figure 218: Character panel in Properties deck on Sidebar

2) Use the options on the tabbed pages of the Character dialog to format the selected 
characters.

3) Click OK to apply the formatting changes and close the dialog.

4) Click outside the text box or object to deselect the text.

Note

For information on the various formatting options available for characters in the 
pages of the Character dialog, refer to the Writer Guide.

Sidebar Character panel

Use the Character panel (Figure 218) in the Properties deck on the Sidebar to format 
characters. Formatting options are limited, but similar in use to the formatting options available in 
the Character dialog. Any formatting applied to characters using the Character panel is 
immediate. Character formatting options are also available on the Text Formatting toolbar.

1) Select a text box or object so that the selection handles on the border are displayed.

2) On the Sidebar, click on Properties to open the Properties deck.

3) Click on the expansion symbol on the left of the Character title bar to open the 
Character panel.

4) Format the text using the tools in the Character panel.

5) If necessary, click on More Options on the right of the title bar to open the Character 
dialog to format text.

Note

For information on the various formatting options available for characters in the 
Character panel on the Sidebar, refer to the Writer Guide.

Unordered or ordered lists

Unordered (bulleted) and ordered (numbered) lists can be created in text boxes and objects. 
When creating lists in objects, Draw objects are not dynamic and do not automatically expand as 
a list is created. Creating unordered or ordered lists in Draw is similar to Writer. For more 
information on unordered or ordered lists, see the Writer Guide.
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Figure 219: Lists panel in Properties deck on Sidebar

Figure 220: Bullet Library dialog for bullet lists

Figure 221: More Numbers dialog for numbered lists
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Creating lists
Unordered or ordered lists are created in text boxes, or Draw objects as follows:

1) Select all the required text for a list.

2) Create a list using one of the following methods and default settings for lists:

– Click on Toggle Unordered List, or Toggle Ordered List on the Text Formatting 
toolbar.

– Click on Toggle Unordered List, or Toggle Ordered List in the Lists panel in the 
Properties deck on the Sidebar (Figure 219).

– Go to Format > Lists > Unordered List, or Ordered List on the Menu bar.

3) To change the format of the list, click on the triangle ▼ on the right of the list icons and 
select a list style from the options available in the Bullets Library dialog (Figures 220), or 
More Numbers dialog (Figure 221).

Adjusting list item level and position
The level for each item in an unordered or ordered list is demoted or promoted within a list, or 
moved up or down in list order as follows:

1) Click on a list item being demoted, promoted, or moved up or down.

2) Demote a list item down one level at a time using one of the following methods:

– Use the Tab key.

– Go to Format > Lists > Demote on the Menu bar.

– Use Demote in the Lists panel in the Properties deck on the Sidebar.

3) Promote a list item up one level at a time using one of the following methods:

– Use the key combination Shift+Tab.

– Go to Format > Lists > Promote on the Menu bar.

– Use Promote in the Lists panel in the Properties deck on the Sidebar.

4) Change the position of a list item in the list order using one of the following methods:

– Go to Format > Lists > Move Up, or Move Down on the Menu bar.

– Use Move Up, or Move Down in the Lists panel in the Properties deck on the 
Sidebar.

Bullets and Numbering dialog
Use the Bullets and Numbering dialog (Figure 222) for more control over list formatting. Select 
text in a text box or object and open the dialog using one of the following methods:

• Go to Format > Bullets and Numbering on the Menu bar.

• Right-click on the selected text and select Bullets and Numbering from the context 
menu.

• Click on More Options on the right side of Lists panel title bar in the Properties deck on 
the Sidebar.

• Click on More Bullets or More Numbering after clicking on the triangle ▼ on the right of 
Toggle Unordered List, or Toggle Ordered List on the Text Formatting toolbar, or in the 
Lists panel in the Properties deck on the Sidebar.
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Figure 222: Bullets and Numbering dialog

Note

For more information on the options available in the Bullets and Numbering dialog for 
unordered or ordered lists, see the Writer Guide.

Text columns

Text in a drawing can be formatted into columns inside text boxes and objects. However, 
columns cannot be used on separate parts of text inside a text box or object. The whole of the 
text box, or object has to be used for columns. An example of text columns inside a Draw object 
is shown in Figure 223.

The type of columns used in Draw are continuous flow columns. This means that when text 
reaches the bottom of a column, text automatically flows into the next column as more text is 
added.

Text boxes
1) Click the border of a text box to select it so that the selection handles are displayed 

indicating that the text box is in edit mode.
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Figure 223: Example of text columns in a Draw object

Figure 224: Text dialog — Text Columns pagex

2) Open the options for text columns using one of the following methods:

– Right-click in the text box and select Text Attributes from the context menu to open the 
Text dialog, then click on the Text Columns tab to open the Text Columns page 
(Figure 224),

– Click on Columns in Properties on the Sidebar to open the Columns panel 
(Figure 225).

3) Set the number of columns required in the Number of columns box and the required 
spacing between the columns in the Spacing box.

4) Save the changes and deselect the text box using one of the following methods:

– For the Text dialog, click OK to save the changes and close the dialog, then click 
outside the text box to deselect it.

– For the Columns panel in the Properties deck on the Sidebar, click outside the text 
box to deselect it and save the changes.

Note

Any text inside a text box, or drawing object automatically flows into column format 
when the changes are saved.
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Figure 225: Columns panel in Properties deck on Sidebar

Drawing objects
1) Click on an object to select it so that the selection handles are displayed indicating that 

the object is in edit mode.

2) Double-click on the selected object to switch on text edit mode.

3) Open the options for text columns using one of the following methods:

– Right-click in the text box and select Text Attributes from the context menu to open the 
Text dialog, then click on the Text Columns tab to open the Text Columns page 
(Figure 224),

– Click on Columns in Properties on the Sidebar to open the Columns panel 
(Figure 225).

4) Set the number of columns required in the Number of columns box and the required 
spacing between the columns in the Spacing box.

5) Save the changes and deselect the object using one of the following methods:

– For the Text dialog, click OK to save the changes and close the dialog, then click 
outside the object to deselect it.

– For the Columns panel in the Properties deck on the Sidebar, click outside the object 
to deselect it and save the changes.

6) Double-click again on the object to switch on text edit mode.

7) Type or use copy and paste to enter the required text. Any text entered appears in 
column format.

8) If necessary, format the text to the drawing requirements.

9) Click outside the object to deselect it and save the changes.
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Figure 226: Text dialog — Text Animation page

Text animation

Note

Text animation is not recommended in a drawing unless the drawing is going to be 
displayed as part of a presentation. See the Impress Guide for more information on 
text animation.

Creating text animation
1) Right-click on text in a text box, or drawing object and select Text Attributes from the 

context menu to open the Text dialog.

2) Click on Text Animation to open the Text Animation page in the Text dialog 
(Figure 226).

3) In Effect, select how the text appears during the text animation.

4) In Direction, select which direction the text appears from during animation.

5) In Properties, select Start inside for the text to be visible and inside the drawing object 
when applying the animation effect.

6) In Properties, select Text visible when exiting for the text to remain visible after applying 
the animation effect.

7) In Animation cycles, select either Continuous, or enter the number of animation cycles for 
the animated text.

8) In Increment, select the increment value in Pixels for scrolling the text.
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9) In Delay, specify Automatic, or enter the time delay to wait before repeating the 
animation effect.

10) Click OK to save the changes and close the Text dialog.

Text animation options
Effect

Select the animation effect from the drop-down list to apply to the text in the selected 
drawing object. To remove an animation effect, select No Effect.

Direction

Select a scrolling direction for the animated text.

Properties

Start inside

Text is visible and inside the drawing object when applying the animation effect.

Text visible when exiting

Text remains visible after applying the animation effect.

Animation cycles

Set the looping options for the animation effect.

Continuous

Plays the animation effect continuously. To specify the number of times to play the 
animation effect, deselect this check box, and enter the number of cycles in the 
Continuous box.

Increment

Specifies the increment value in the Pixels box for scrolling the text.

Delay

Specifies the amount of time before repeating the animation effect.

Automatic

LibreOffice automatically determines the amount of time before repeating the 
animation effect. To manually assign a delay period, unmark this check box, and then 
enter a time value in the Automatic box.

Text callouts

A text callout is a short line of text connected by a line to highlight, or point out a feature in an 
illustration or drawing. Two types of text callouts (Figure 227) are available –– Callouts for 
horizontal text and Vertical Callouts for vertical text. Text callouts in Draw are a legacy from the 
first versions of LibreOffice and the tools are only available on the Text toolbar (Figure 203 on 
page 207).

Note

Custom shape callouts can also be used by selecting Callout Shapes on the 
Drawing toolbar, or the Callouts panel in the Shapes deck on the Sidebar. These 
custom shape callouts have the same purpose as text callouts, but have different 
options available.
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Figure 227: Examples of horizontal and vertical text callouts

Creating text callouts
1) Click on Callouts for horizontal text, or Vertical Callouts for vertical text on the Text 

toolbar (Figure 203 on page 207).

2) Click in the drawing and drag the cursor to create the callout.

3) Double click in the callout box to enter text mode.

4) Type the required text, then click in a blank space in the drawing. The callout box adjusts 
its size horizontally and/or vertically to fit the text within the callout box.

5) Select the callout and click on the selection handle at the end of the connector line, then 
drag the end of the connector line to the required position.

6) With the callout still selected, click on the callout box and drag it to the required position.

7) If required, with the callout still selected, click on a selection handle on the callout box to 
change the callout box width and height.

8) Click in a blank space in the drawing to deselect the text callout and save the changes.

Note

The Callout page in the Position and Size dialog is only available when a text callout 
has been selected. It is not available for Callout Shapes that are available on the 
Drawing toolbar, or the Callouts panel in the Shapes deck on the Sidebar.

Editing text callouts
1) Double click in the callout box to enter text mode to edit and format the text. See 

“Formatting text” on page 217 for more information on text formatting.

2) Click in a blank space on the drawing to save the changes to the text.

3) Only select the text callout so that the selection handles are displayed.

4) Make sure the text used in the text callout is NOT selected.
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Figure 228: Position and Size dialog — Callout page

5) Right click on the selected text callout and select an option from the context menu to 
change the attributes for position, size, line, and area of the text callout. For more 
information, see Chapter 3, Working with Objects, and Chapter 4, Changing Object 
Attributes.

6) Click on the selection handle at the end of the connector line and drag it to change the 
position of the line end or the length of the connector line.

7) Select the text callout and open the Position and Size dialog (Figure 228) using one of 
the following methods:

– Right-click on the selected callout and select Position and Size from the context 
menu.

– Go to Format > Position and Size on the Menu bar.

– Use the keyboard shortcut F4.

8) Click Callout to open the formatting options available for text callouts.

9) Select the style of text callout from Straight Line, Angled Line, or Angled Connector 
Line.

10) In Spacing, enter the amount of space required between the end of the callout line and 
the callout box.

11) In Extension, select from the available options how the callout line from extends the 
callout box.

12) If From top, or From left has been selected from the Extension drop-down list, enter a 
distance value in the By: box to create a space between the start point of the connector 
line and the callout box.

13) If Horizontal, or Vertical has been selected from the Extension drop-down list, enter a 
position setting from the Position drop-down list to set the position of where the 
connector line is attached to the text callout box.

14) In Length, enter the length of the callout line segment that extends from the callout box 
to the angle point of the connector line.

15) Select Optimal to display the angle point in a connector line at an optimal distance from 
the callout box.

16) Click in a blank space in the drawing to deselect the text callout and save the changes.
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Text callout options
Callout Styles

Select the required callout style from the options available.

Spacing

Enter the amount of space required between the end of the callout line and the callout 
box.

Extension

Select where and how the callout line extends from the callout box.

Length

Enter the length of the callout line segment that extends from the callout box to the 
inflection point of the line.

Optimal

Select this option to display a single line in the optimum position.

Note

The Length option is only available if Angled connector line is selected as the 
callout style and Optimal is not selected.

Tables in Draw

Tables provide information easily and quickly when used in a drawing. Tables can be added 
directly to a drawing eliminating the requirement to embed a Calc spreadsheet, or a Writer text 
table. However, it is recommended to embed a spreadsheet into a drawing, especially when 
greater functionality is required in the table. The tables provided by Draw do have a limited 
functionality.

Inserting tables
Tables are placed at the center of a drawing and cannot be placed into objects or shapes. Also, 
unlike text boxes and other objects, tables cannot be rotated, but can be repositioned.

Notes

When inserting tables into a drawing, the table is created using the default style with 
settings already applied. Currently these defaults are hard coded in LibreOffice. The 
table can be formatted to the drawing requirements after insertion.

If the Table toolbar is not visible, go to View > Toolbars > Table on the Menu bar. 
The Table toolbar is normally docked at the bottom of a Draw window.

Table dialog

1) Go to Insert > Table on the Menu bar to open the Insert Table dialog (Figure 229).

2) Enter the number of rows and columns required.

3) Click OK to insert the table in the center of a drawing and close the dialog.

4) Move the table into position by clicking on the border and dragging it to its new position.
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Figure 229: Insert Table dialog

Figure 230: Table toolbar

Figure 231: Table grid

Table grid

1) Click on Table on the Table toolbar (Figure 230) to open the Table grid (Figure 231).

2) Click and drag the cursor until the required number of columns and rows are selected,

3) Click again to insert the table into the center of a drawing and close the Table grid.

4) If necessary, click on More Options to open the Insert Table dialog to select the number 
of rows and columns required.

5) Move the table into position by clicking on the border and dragging it to its new position.
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Figure 232: Table Design panel in Properties deck on Sidebar

Table Design panel
Several predefined table designs are provided in the Table Design panel in the Properties deck 
on the Sidebar (Figure 232). The Table Design panel is only available when a table is selected.

Inserting table designs

1) Insert a table into a drawing or select a table in a drawing.

2) Click on Table Design in the Properties deck on the Sidebar to open the Table Design 
panel.

3) Select a design for the table from the available design options.

4) Format the rows and columns using the available options in the Table Design panel.

5) Alternatively, right click on the selected table design and select the format options for the 
rows and columns from the context menu.

Creating table designs

1) Insert a table into a drawing, then select the new table.

2) Click on Table Design in the Properties deck on the Sidebar to open the Table Design 
panel, or click on Table Design on the Table toolbar.

3) Click on the plus sign in Table Design panel to create a new design.

4) Make sure the new design is selected, then format the rows and columns from the 
available options listed below the Table Design panel.
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Figure 233: Example table with banded rows and columns

5) Alternatively, right click on the new table design and select the format options for the 
rows and columns from the context menu.

Table design options

Header row

Selected by default. The first row is normally a header row and is displayed with a 
different background from the rest of the table.

Total row

When selected, changes the background of the last row to make it stand out from other 
rows.

Banded rows

Selected by default. Alternate rows have different backgrounds making it easier to read 
data entered into the rows, as shown by the example in Figure 233.

First column

When selected, highlights the first column of the table using a darker background.

Last column

When selected, highlights the last column of the table using a darker background.

Banded columns

When selected, alternate columns are highlighted with dark and light colors.

Table formatting
Format a selected table using the tools and options available on the Table toolbar, by going to 
Format > Table on the Menu bar, or using the options available in the Table Properties dialog.

Table toolbar

The Table toolbar (Figure 230 on page 233) automatically opens when a table is selected 
providing tools for creating and formatting a table. The default docked position for the toolbar is 
at the bottom of the LibreOffice Draw Workspace.

Table

Inserts a new table in a drawing using the Insert Table dialog or the Table grid. See 
“Inserting tables” on page 232 for more information on inserting tables.

Border Style

Changes the line style of the borders of selected cells. Click on the triangle▼ next to 
Border Style to open a drop-down list and select from a range of predefined styles.
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Border Color

Changes the color of the borders of selected cells. Click on the triangle▼ next to Border 
Color to access the available LibreOffice color palettes. Select a color from a range of 
predefined palettes or create a custom color.

Borders

Selects a predefined border configuration for the selected table, or cells. Click on the 
triangle▼ next to Borders to open a drop-down list to select a border configuration.

Area Style/Filling

Select the cells to be filled, then select the type of fill from the drop-down list: None, 
Color, Gradient, Hatching, Bitmap, Pattern, Use Slide Background. 

Fill Color

Select a fill option from the drop-down menu. The fill options change to show the fillings 
available for each Area Style/Filling type.

Merge Cells

Merges the selected cells into one cell. Note that the contents of the merged cells are 
also merged. Alternatively, right-click on selected cells and select Merge Cells from the 
context menu.

Split Cells

Splits a selected cell into multiple cells either horizontally or vertically. Make sure the 
cursor is positioned on a cell, then click on Split Cells to open the Split Cells dialog 
(Figure 234).

In Split cells into, select the number of cells required when splitting a cell and whether to 
split the cell Horizontally or Vertically. If necessary, when splitting horizontally, select Into 
equal proportions to create cells of equal size. The contents of the split cell are kept in 
the original cell (left or top cell).

Optimize

Evenly distributes the selected rows and columns in a table either horizontally or 
vertically. Clicking on Optimize opens a pop-up toolbar which contains the following 
tools:

Minimal Row Height

Determines the minimal row height for selected rows. Minimal row height depends on 
the font size of the smallest character in the row.

Figure 234: Split Cells dialog
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Minimal Column Width

Defines the minimal column width for selected columns. Minimal column width 
depends on the shortest entry within a column.

Optimal Row Height

Determines the optimal row height for selected rows. Optimal row height depends on 
the font size of the largest character in the row.

Optimal Column Width

Defines the optimal column width for selected columns. Optimal column width depends 
on the longest entry within a column.

Distribute Rows Equally

Adjusts the height of the selected rows to match the height of the tallest row in the 
selection.

Distribute Columns Evenly

Adjusts the width of the selected columns to match the width of the widest column in 
the selection. The total width of the table cannot exceed the width of the page.

Align Top, Center Vertically, Align Bottom

Sets the vertical alignment of text in selected cells.

Insert Row Above, Insert Row Below

Click in a cell or cells to select rows and use these two tools to insert a row or rows 
above or below the selected rows. Alternatively, right-click on the selected rows and 
select Insert > Insert Row Above or Insert Row Below.

Insert Column Before, Insert Column After

Click in a cell or cells to select columns and use these two tools to insert a column or 
columns before or after the selected columns. Alternatively, right-click on the selected 
columns and select Insert > Insert Column Before or Insert Column After.

Delete Row, Delete Column, Delete Table

Click in a cell or cells to select rows or columns, then click on a tool to delete the 
selected rows or columns. To delete the whole table, place the cursor in a cell and select 
Delete Table. Alternatively, right-click on the selected cells and select Delete > Delete 
Row, or Delete Column, or Delete Table from the context menu.

Select Table, Select Column, Select Row

Select a table, column, or row if the same attributes are going to be applied to a table, 
column, or row.

Table Design

Clicking on this tool opens the Table Design panel in the Properties deck on the Sidebar. 
See “Table Design panel” on page 234 for more information.

Table Properties

Clicking on this tool opens the Table Properties dialog. Alternatively, right-click on the 
table and select Table Properties from the context menu.

Menu bar

Go to Format > Table on the Menu bar and select a formatting option from the submenu.

Minimal Row Height

Determines the minimal row height for selected rows. Minimal row height depends on the 
font size of the smallest character in the row.
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Optimal Row Height

Determines the optimal row height for selected rows. Optimal row height depends on the 
font size of the largest character in the row.

Distribute Columns Evenly

Adjusts the width of the selected columns to match the width of the widest column in the 
selection. The total width of the table cannot exceed the width of the page.

Select Row

Selects the row or rows where cells have been selected in the table.

Insert Rows

Inserts rows in the table where cells have been selected in the table. 

Delete Row

Deletes rows in the table where cells have been selected in the table.

Minimal Column Width

Defines the minimal column width for selected columns. Minimal column width depends 
on the shortest entry within a column.

Optimal Column Width

Defines the optimal column width for selected columns. Optimal column width depends 
on the longest entry within a column.

Distribute Columns Evenly

Adjusts the width of the selected columns to match the width of the widest column in the 
selection. The total width of the table cannot exceed the width of the page.

Select Column

Selects the column or columns where cells have been selected in the table.

Insert Columns

Inserts columns in the table where cells have been selected in the table. 

Delete Column

Deletes columns in the table where cells have been selected in the table.

Merge Cells

Merges the selected cells into one cell. The contents of the merged cells are also 
merged. Alternatively, right-click on selected cells and select Merge Cells from the 
context menu.

Split Cells

Splits a selected cell into multiple cells either horizontally or vertically. Make sure that the 
cursor is positioned on the cell, then click on Split Cells to open the Split Cells dialog 
(Figure 234 on page 236).

In Split cells into, select the number of cells required when splitting a cell and whether to 
split the cell Horizontally or Vertically. If necessary, when splitting horizontally, select Into 
equal proportions to create cells of equal size. The contents of the split cell are kept in 
the original cell (left or top cell).

Delete Table

To delete the whole table, place the cursor in a cell and select Delete Table. Alternatively, 
right-click on the selected cells and select Delete Table from the context menu.

Select…

Selects the whole table.
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Properties…

Opens the Table Properties dialog.

Table Properties dialog

The Table Properties dialog has five tabbed pages that provide formatting options for Font, Font 
Effects, Borders, Background, and Shadow. Open the Table Properties dialog using one of 
the following methods:

The formatting options on each dialog page are as follows:

Font (Figure 235)

Select the required Family, Style, Size, and Language for text in the table. A sample of 
the font selected is displayed in the preview box. See the Writer Guide for more 
information on fonts.

Font Effects (Figure 236)

Select the required Font Color, Text Decoration, and Effects for the text in the table. A 
sample of the font effects applied to the text is displayed in the preview box. See the 
Writer Guide for more information on font effects.

Borders (Figure 237)

Select the required Line Arrangement, Line, and Padding for the table and cell 
borders. These options are similar to the tools Border Style, Border Color, and 
Borders on the Table toolbar. See Chapter 4, Changing Object Attributes for more 
information on the lines used for table and cell borders.

Figure 235: Table Properties dialog — Font page
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Figure 236: Table Properties dialog — Font Effects page

Figure 237: Table Properties dialog — Borders page
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Figure 238: Table Properties dialog — Background

Figure 239: Table Properties dialog — Shadow page

Background (Figure 238)

Select a background as the area fill for the table and/or selected cells. This dialog page 
provides the same functions as Area Style/Filling tools on the Table toolbar. See 
Chapter 4, Changing Object Attributes for more information on area style and filling used 
for table and cell backgrounds.

Shadow (Figure 239)

Adds a shadow to the table. The options adjust the look and position of the shadow. See 
Chapter 4, Changing Object Attributes for more information on table shadows.
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Figure 240: Position and Size dialog

Table position and size
Tables are placed into boxes when created. This allows tables to be formatted as a LibreOffice 
Draw object. After selecting the table, use one of the following methods to change table position 
and size. See “Text boxes” on page 207 and Chapter 3, Working with Objects for more 
information positioning and resizing.

• Click on the table border and drag the table to a new position.

• Click and drag on a selection handle to change the table size.

• Open the Position and Size dialog and use the options available on the Position and 
Size page (Figure 240). The options available in the Rotation, and Slant & Corner 
Radius pages cannot be used for a table.

After selecting the table, use one of the following methods to open the Position and Size dialog:

• Right-click on the table and select Position and Size from the context menu.

• Go to Format > Position and Size on the Menu bar.

• Use the keyboard shortcut F4.

Note

When the size of a table box is changed, the table and cell contents also increase or 
decrease in size to match the table box size.
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Deleting tables

Whole table

Make sure the table is selected and the selection handles are visible on the table border, then 
delete the table using one of the following methods:

• Go to Format > Table > Delete Table on the Menu bar.

• Select Delete Table on the Table toolbar.

• Right-click on the table and select Delete > Delete Table from the context menu.

Row or column

Click in a table cell to delete the table row or column using one of the following methods. Make 
sure the table selection handles are NOT displayed.

• Go to Format > Table > Delete Row, or Delete Column on the Menu bar

• Select Delete Row, or Delete Column on the Table toolbar.

• Right-click and select Delete > Delete Row, or Delete Column from the context menu.

Cell contents

Delete cell contents in a table as follows:

1) Select the cell or cells.

2) Press the Delete, or Backspace key on the keyboard.

Using fields

Fields allow for the automatic insertion of text into a drawing and are used when creating 
templates and drawing masters. For more information on templates and master drawings, see 
Chapter 11, Advanced Drawing Techniques.

Inserting fields
When a field is created, a text box for the field is inserted into the center of a drawing and can be 
repositioned just like any other text box. See “Text boxes” on page 207 for more information.

1) Go to Insert > Field on the Menu bar and select the type of field required.

2) If required, position and resize the field text box.

3) If required, format the text used for the field information. See “Formatting text” on 
page 217 for more information.

Field types
Date (fixed)

Inserts the current date into a drawing as a fixed field. The date is not automatically 
updated. Available date formats depend on the language setting in Tools > Options > 
Language Settings > Language (macOS LibreOffice > Preferences > Language 
Settings > Language). Right-click on the date field and select the required date format 
from the context menu.
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Date (variable)

Inserts the current date into a drawing as a variable field. The date is automatically 
updated each time the file is opened. Available date formats depend on the language 
setting in Tools > Options > Language Settings > Language (macOS LibreOffice > 
Preferences > Language Settings > Language). Right-click on the date field and select 
the required date format from the context menu.

Time (fixed)

Inserts the current time into a drawing as a fixed field. The time is not automatically 
updated. Available time formats depend on the language setting in Tools > Options > 
Language Settings > Language (macOS LibreOffice > Preferences > Language 
Settings > Language). Right-click on the time field and select the required time format 
from the context menu.

Time (variable)

Inserts the current time into a drawing as a variable field. The time is automatically 
updated each time the file is opened. Available time formats depend on the language 
setting in Tools > Options > Language Settings > Language (macOS LibreOffice > 
Preferences > Language Settings > Language). Right-click on the time field and select 
the required time format from the context menu.

Author

Inserts the first and last names of the author of the drawing. This information is taken 
from values entered in the LibreOffice user data. To modify this information go to Tools > 
Options > LibreOffice > User Data (macOS LibreOffice > Preferences > LibreOffice 
> User Data).

Page Number

Inserts the page number into the current drawing. Alternatively, go to Insert > Page 
Number on the Menu bar. If a page number is to be added to every page in the drawing, 
go to View > Master on the Menu bar and insert the page number field.

Page Title

Inserts the page title. The default name is Page # if the page has not been renamed.

Page Count

Inserts the total number of pages in a drawing.

File Name

Inserts the name of the file used for the drawing. The file name only appears after the file 
has been saved.

Using hyperlinks

When inserting text that can be used as a hyperlink (for example, a website address or URL), 
Draw automatically formats it creating the hyperlink, and applies color and underlining. There are 
four types of hyperlinks and each hyperlink type requires a different procedure when inserting a 
hyperlink.

Note

To prevent LibreOffice from automatically turning website addresses, or URLs into 
hyperlinks, go to Tools > AutoCorrect Options > Options on the Menu bar and 
deselect URL Recognition.
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Figure 241: Hyperlink dialog — Internet page

Tip

To change the color of hyperlinks, go to Tools > Options > LibreOffice > 
Application Colors, scroll to Unvisited links and/or Visited links, select the 
checkboxes, then select new colors from the color palettes for the links and click OK. 
Note this color change changes the color for all hyperlinks across all LibreOffice 
modules.

Internet hyperlink
1) Click in the text box at the required position for the hyperlink.

2) Go to Insert > Hyperlink on the Menu bar, or use the keyboard shortcut Ctrl+K 
(macOS ⌘+K) to open the Hyperlink dialog.

3) Select Internet to open the Internet page of the Hyperlink dialog (Figure 241).

4) In Protocol, select either Web, or FTP.

5) In the URL text box, enter the required web address for the hyperlink.

6) In the Text box, enter a name for the hyperlink.

7) If necessary, enter the details required for Further Settings. See “Further Settings” on 
page 248 for more information.

8) Click Apply to insert the hyperlink and save the selections. If several hyperlinks are 
being created, click Apply after inserting each hyperlink.

9) Click OK to close the Hyperlink dialog.

Mail hyperlink
1) Click in the text box at the required position for the hyperlink.
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Figure 242: Hyperlink dialog — Mail page

2) Go to Insert > Hyperlink on the Menu bar, or use the keyboard shortcut Ctrl+K 
(macOS ⌘+K) to open the Hyperlink dialog.

3) Select Mail to open the Mail page of the Hyperlink dialog (Figure 242).

4) In Recipient text box, enter the email details of the recipient.

5) In the Subject text box, enter a subject title.

6) If required, click on Data Sources to open a data source browser, then drag the email 
receiver data field from the data source browser into the Recipient text box.

7) If required, enter the details required for Further Settings. See “Further Settings” on 
page 248 for more information.

8) Click Apply to insert the hyperlink and save the selections. If several hyperlinks are 
being created, click Apply after inserting each hyperlink.

9) Click OK to close the Hyperlink dialog.

Document hyperlink
Creates a hyperlink to another document or to another place in a document, commonly referred 
to as a bookmark.

1) Click in the text box at the required position for the hyperlink.

2) Go to Insert > Hyperlink on the Menu bar, or use the keyboard shortcut Ctrl+K 
(macOS ⌘+K) to open the Hyperlink dialog.

3) Select Document to open the Document page of the Hyperlink dialog (Figure 243).
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Figure 243: Hyperlink dialog — Document page

Note

Leave Path blank if the link is to a target in the same drawing.

4) In the Path text box, enter the file path for the document.

5) Alternatively, click on Open File to open a file browser and select the file as a target for 
the hyperlink.

6) Optionally, to specify a target in a specific drawing, click on Target in Document to open 
a dialog to select a target. However, if the name of the target is known, type it into the 
Target text box.

7) If required, enter the details required for Further Settings. See “Further Settings” on 
page 248 for more information.

8) Click Apply to insert the hyperlink and save the selections. If several hyperlinks are 
being created, click Apply after inserting each hyperlink.

9) Click OK to close the Hyperlink dialog.

New Document hyperlink
Creates a new document and a hyperlink to the new document.

1) Click in the text box at the required position for the hyperlink.

2) Go to Insert > Hyperlink on the Menu bar, or use the keyboard shortcut Ctrl+K 
(macOS ⌘+K) to open the Hyperlink dialog.

3) Select New Document to open the New Document page of the Hyperlink dialog 
(Figure 244).
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Figure 244: Hyperlink dialog — New Document page

4) In New Document select Edit now to edit the newly created document immediately, or 
Edit later to only create the hyperlink.

5) Select the type of document to create from the File type drop-down list.

6) Click on Select Path to open a file browser and navigate to the folder where the new 
document is going to be saved

7) Select the folder and click on Open. The selected folder appears in the File text box.

8) If necessary, enter the details required for Further Settings. See “Further Settings” on 
page 248 for more information.

9) Click Apply to insert the hyperlink and save the selections. If several hyperlinks are 
being created, click Apply after inserting each hyperlink.

10) Click OK to close the Hyperlink dialog.

Further Settings
The Further Settings section in the Hyperlink dialog is common to all hyperlink types, although 
some options are more relevant to specific types of links.

Frame

Enter a name for the frame in the Frame text box that the linked file opens in, or select a 
predefined frame from the list. If the Frame text box is empty, the linked file opens in the 
current browser window.

Form

Specifies whether the hyperlink is inserted as text, or as a button.

Text

Specifies the visible text, or button caption for the hyperlink.
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Name

Applicable to HTML documents. It specifies the text added as a NAME attribute in the 
HTML code behind the hyperlink.

Editing text hyperlinks
1) Select the hyperlink.

2) Right-click on the hyperlink and select Edit Hyperlink from the context menu to open the 
Hyperlink dialog.

3) Make editing changes using the available options.

4) Click Apply to insert the hyperlink and save the selections. If several hyperlinks are 
being created, click Apply after inserting each hyperlink.

5) Click OK to save the changes and close the Hyperlink dialog.

Note

DO NOT click directly on the hyperlink text when editing or formatting hyperlinks. 
Clicking on the hyperlink text opens the hyperlink.

Formatting hyperlinks
A hyperlink is inserted in the centre of the current slide. To edit the text, the size of a hyperlink 
text box, or to reposition the hyperlink on the slide:

1) Click and drag a selection marquee over the hyperlink text to display a text box border 
and selection handles.

2) Right-click on the selected hyperlink and select the type of formatting required from the 
options available in the context menu.

3) To reposition hyperlink, click and drag on the text border to move the hyperlink on the 
slide.

4) Select Position and Size from the context menu, or use the F4 key to open the Position 
and Size dialog. Options can be selected to move the hyperlink, or resize the text box.

Image maps

An image map defines areas used as hotspots in images which are associated with a URL (web 
address or a file on the computer). Hotspots are the graphic equivalent of text hyperlinks. In 
Draw, clicking on a hotspot opens the linked page in the appropriate program (for example, 
default browser for HTML pages; Writer for ODT files; PDF viewer for PDF files).

Hotspots can be created in various shapes, for example rectangles, ellipses, and polygons. 
Several hotspots can be included in the same image. When a hotspot is clicked on, the URL 
opens in a browser window or frame that has been specified. The text can also be specified as a 
hotspot name that appears when the cursor hovers over a hotspot.

Creating image maps
1) Select an image in a drawing to use as a hotspot.

2) Go to Tools > ImageMap on the Menu bar to open the ImageMap Editor dialog 
(Figure 245). The main part of the dialog shows the selected image where hotspots will 
be defined.
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Figure 245: ImageMap Editor dialog

3) Select the type of hotspot area required from the icons at the top of the ImageMap Editor 
dialog from the options Rectangle, Ellipse, Polygon, or Freeform Polygon.

4) Create the hotspot area in the selected image.

5) Enter the hyperlink address for the hotspot in the Address text box using the address 
format: file:///<path>/document_name#anchor_name.

6) Click on Apply to apply the settings.

7) Click on Save to save the image map to a file.

8) Click on Close in the ImageMap Editor dialog.

Image map tools
Apply

Applies the changes.

Open

Loads an existing image map in the MAP-CERN, MAP-NCSA or SIP StarView file format.

Save

Saves the image map in the MAP-CERN, MAP-NCSA, or SIP StarView file format.
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Select

Selects a hotspot in the image map for editing.

Rectangle, Ellipse, Polygon, Freeform Polygon

Creates a hotspot on the selected image in the shape selected.

Edit Points

Change the shape of the selected hotspot by editing anchor points.

Move Points

Moves individual anchor points of the selected hotspot.

Insert Points

Adds an anchor point at the selected point on the outline of the hotspot.

Delete Points

Deletes a selected anchor point.

Undo

Cancels the previous action.

Redo

Reapplies the previous cancelled action.

Active

Toggles the status of a selected hotspot between active and inactive.

Macro

Assign a macro that runs when the hotspot is clicked on.

Properties

Define the properties of the selected hotspot.

Address

Enter the URL for the file that opens when the selected hotspot is clicked on. The 
address format to be used: file:///<path>/document_name#anchor_name.

Text

Enter the text that is displayed when the cursor hovers over a hotspot. If no text is 
entered, the Address is displayed.

Frame

Enter the name of the target frame for the hotspot. Standard frame name can be 
selected from the drop-down list and used instead.

_blank

Opens in a new browser window.

_self

Default selection and opens in the current window.

_top

File opens in the topmost frame in the hierarchy.

_parent

File opens in the parent frame of the current frame. If there is no parent frame, the 
current frame is used.

Graphic view

Displays the image map so that the hotspots can be selected and edited.
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Note

The value _self for a target frame works on the majority of the occasions. It is not 
recommended to use the other values, if available, unless absolutely necessary.

Fontwork

Fontwork is used to create graphical text as objects in a drawing. Different settings for 
Fontwork (line, area, position, size, and more) are available to match the drawing requirements. 
Fontwork is also available in the Writer, Calc, and Impress modules in LibreOffice. However, 
there are small differences in the way that each LibreOffice module displays Fontwork.

Creating Fontwork
1) Go to Insert > Fontwork on the Menu bar to open the Fontwork Gallery dialog 

(Figure 246) and select a Fontwork style from the dialog.

2) Double click on the selected Fontwork, or select OK. This closes the Fontwork Gallery 
dialog and the selected Fontwork appears in the center of the drawing.

Figure 246: Fontwork Gallery dialog
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Figure 247: Example of creating Fontwork text

Figure 248: Fontwork toolbar

3) Double-click on the Fontwork object to switch on editing mode. The example Fontwork 
text appears in the center of the image in text edit mode, as shown by the example in 
Figure 247.

4) Highlight all of the text in edit mode to select it, then type in the required text to replace 
the highlighted text.

5) Press the Esc key, or click outside the selected area to apply the new text and it appears 
as a Fontwork object in the center of the drawing.

6) If necessary reposition and resize the Fontwork object to the drawing requirements. See 
Cpter 3, Working With Objects and Chapter 4, Changing Object Attributes for more 
information.ha

Fontwork toolbar
When a Fontwork object is selected, the Fontwork toolbar (Figure 248) opens on the Workspace. 
If the toolbar is not visible, go to View > Toolbars > Fontwork on the Menu bar.

The following tools are available for editing a Fontwork object.

Insert Fontwork Text

Opens the Fontwork Gallery dialog.

Fontwork Shape

Changes the shape of a selected Fontwork object. Click on the triangle▼next to 
Fontwork Shape on the Fontwork toolbar to open the Fontwork pop-up toolbar. Select a 
Fontwork shape for the available options. The Fontwork shapes are also available in the 
Fontwork Shape sub-toolbar (Figure 249).

Fontwork Same Letter Heights

Changes the height of characters in a selected Fontwork object. Toggles between normal 
height where the characters have different heights to where all characters have the same 
height.
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Figure 249: Fontwork Shape subtoolbar

Fontwork Alignment

Specifies the text alignment within the frame. Options available are Left Align, Center, 
Right Align, Word Justify, and Stretch Justify.

Fontwork Character Spacing

Selects the spacing between characters and whether kerning pairs should be used. 
Options available are Very Tight, Tight, Normal, Loose, Very Loose, and Custom. For 
Custom spacing, input a percentage value: 100% is normal character spacing; less than 
100% character spacing is tighter; more than 100% character spacing is looser.

Toggle Extrusion

Converts the Fontwork object into a 3D shape using extrusion. See Chapter 7, 3D 
Objects for more information.

Modifying Fontwork
A Fontwork object is treated like any other object in Draw. It can be resized, rotated, skewed, 
slanted, flipped, and so on. For more information on modifying a Fontwork object, see Chapter 3, 
Working With Objects, Chapter 4, Changing Object Attributes, and Chapter 5, Combining 
Multiple Objects.

• Fontwork consists of text, but only minimal text formatting options can be used with 
Fontwork text, for example font type, font size, Bold, or Italic.

• Some of Fontwork shapes can be modified and this is indicated by a dot appearing on a 
selected shape. For example, change angles of a trapezoid, or parallelogram basic 
shapes by moving the dot displayed when the selection handles are visible.
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Introduction

The dialogs and procedures for printing, exporting and emailing drawings from Draw are 
EXAMPLES only. Actual dialogs and procedures do depend on the following:

• Type of computer and how rthe computer is setup.

• Computer operating system and software application being used.

• Type of printer connected to the computer.

• How the printer is connected to the computer, for example cable or wi-fi.

Default printer setup

Before printing any drawings from Draw, it is recommended to setup a default printer that is 
connected to the computer.  An example printer setup procedure for Draw is as follows:

1) Go to File > Printer Settings on the Menu bar to open the Printer Setup dialog. An 
example Printer Setup dialog is shown in Figure 250. 

2) Select the required printer from the printers listed in the Name drop-down list.

3) If necessary, click on Properties in the Printer Setup dialog to open a properties dialog 
for the selected printer to select the options required for paper and the printer.

4) Click OK to save the printer selection and close the Printer Setup dialog.

Figure 250: Example Printer Setup dialog

Figure 251: Standard toolbar with Print Directly installed
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Quick printing

To quickly print a document or drawing, without changing print settings already selected, click on 
Print Directly on the Standard toolbar (highlighted in Figure 251). Print Directly sends the 
entire document to the default printer defined for the computer.

If Print Directly is not visible on the Standard toolbar, it is added to the toolbar as follows:

1) Right-click in an empty area on the Standard toolbar and select Visible Buttons from the 
context menu.

2) Select Print Directly from the list of available tools and the Print Directly tool is added 
to the Standard toolbar.

Linux or Windows printing

For more control over printing when using Linux or Windows operating system, open a Print 
dialog using one of the following methods.

• Go to File > Print on the Menu bar.

• Use the keyboard shortcut Ctrl+P.

• Click on Print on the Standard toolbar.

Notes

The options selected in the Print dialog only apply to the printing of the current 
document open in Draw. Any print options selected in the Print dialog overrides the 
default LibreOffice printer settings that have been set using Tools > Options > 
LibreOffice > Print (macOS LibreOffice > Preferences > LibreOffice > Print) and 
Tools > Options > LibreOffice Draw > Print (macOS LibreOffice > Preferences > 
LibreOffice Draw > Print).

General options
Figure 252 displays an example of printing options that may be available on the General page of 
the Print dialog in Windows/Linux.

Printer

Select the printer to use from the printers available in the drop-down list.

Status:

Indicates if the selected printer is the default printer.

Properties

Click on Properties to open the properties dialog for the printer being used. The 
options available in this dialog depends on the type of printer connected to the 
computer and the computer operating system being used.

Range and Copies

All Pages

Prints all the pages in the document.

Selection

Prints the pages selected in Draw.

Pages

Select the page number(s) to print. For multiple pages, use the format 1, 3, 7 or 1 – 5, 
7, 9 for page number selection.
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Figure 252: Example Print dialog — General page — Windows/Linux

Number of copies

Enter number of printed copies required for the document.

Collation and Paper Sides > Include

Select from the drop-down list Odd and Even Pages, Odd Pages, or Even Pages.

Collation and Paper Sides > Paper sides

Select from the drop-down list Print on one side (simplex), Print on both sides (duplex 
long edge), or Print on both sides (duplex short edge).

Collation and Paper Sides > Order > Collate

Collates multiple printed copies into separate documents. Only available when multiple 
copies of a printed document are required.

Collation and Paper Sides > Order > Create separate print jobs for collated output

Only available when multiple copies of a printed document are required.

Collation and Paper Sides > Order > Print reverse order.

Prints the document pages in reverse order.
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Page Layout

Paper size

Select the paper size to use from drop-down list.

Orientation

Select from the drop-down list Automatic, Portrait, or Landscape.

Pages per sheet

Select from the drop-down list how many pages are printed on one sheet of paper.

Order

Select from the drop-down list the printing order of multiple pages on one sheet of 
paper.

Draw a border around each page

When multiple pages are printed on one sheet of paper, a border is drawn around 
each page.

Brochure

Prints the document so the pages can be folded into a brochure or booklet.

LibreOffice Draw options
Figure 253 displays an example of printing options that may be available on the LibreOffice 
Draw page of the Print dialog for the current drawing being printed:

Contents

When selected, prints the Page name and/or Date and time on the drawing.

Figure 253: Example Print dialog — LibreOffice Draw page — Windows/Linux
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Color

Prints the drawing in Original colors, Grayscale, or Black & white.

Size

Print the drawing using one of the following options:

Original size

Prints the drawing using its original size.

Fit to printable page

Drawing size is changed so that it fits on the paper size used for printing.

Distribute on multiple sheets of paper

Used if the drawing is too large for the paper size being used.

Tile sheet of paper with repeated pages

Used to print multiple copies of a drawing on a page.

macOS printing

For more control over printing using macOS, open and use the Print dialog using one of the 
following methods.

• Go to File > Print on the Menu bar.

• Use the keyboard shortcut ⌘+P.

• Click on Print on the Standard toolbar.

General options
Figure 254 displays an example of the printing options that may be available on the General 
page of the Print dialog in macOS.

Printer

Select the printer to be used from the drop-down list. If the default printer is being used, 
then this printer will already be selected.

Presets

Select from the drop-down list a printing preset. The presets available depend on the 
type of printer connected to the computer. This also includes any custom presets that 
have been created.

Copies

Enter the number of copies to be printed.

Pages

All

Prints all the pages in the document.

Range from

Select a range of page number(s) to print.

Selection

Select the pages to print from the Pages pane.

Print in Color

Select this option to print the drawing in color if the printer selected is capable of color 
printing. Deselect this option to print the drawing in monochrome.
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Figure 254: Example Print dialog — General page — macOS

Double-sided

Select this option to print the drawing double sided if the printer selected is capable of 
double sided printing.

On

When selected, prints the drawing pages double-sided using long edge binding.

On (Short)

When selected, prints the drawing pages double-sided using short edge binding.

LibreOffice options

LibreOffice Draw options

Click on LibreOffice Draw to open the printing options available for Draw (Figure 255).

Print selection only

Prints the selected pages in Pages pane.
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Figure 255: Example Print dialog — LibreOffice Draw page — macOS

Contents

Prints the Page name and/or Date and time on the drawing.

Color

Prints the drawing in Original colors, Grayscale, or Black & white.

Size

Prints the drawing using one of the following options:

Original size

Prints the drawing using its original size.
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Fit to printable page

Drawing size is changed so that it fits on the paper size used for printing.

Distribute on multiple sheets of paper

Used if the drawing is too large for the paper size being used.

Tile sheet of paper with repeated pages

Used to print multiple copies of a drawing on a page.

More options

To access more printing options in Draw, click on More to open the More options page 
(Figure 256).

Figure 256: Example Print dialog — LibreOffice More page — macOS
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Brochure

When selected, prints the document so the pages can be folded into a brochure or 
booklet.

Include

Select which pages to print from the drop-down list: All pages; Front sides/right pages; 
Back sides/left pages. Only available when Brochure is selected.

Use only paper tray from printer preferences

When selected, the printer tray selected on the printer overrides the selected tray in the 
printer properties on the computer.

All Pages

All the pages in the drawing are printed.

Pages

Enter the page number(s) in the text box that are to be printed. For multiple pages, use 
the format 1, 3, 7 or 1 — 5, 7, 9 for page number selection.

Selection

Prints the pages selected in the Pages pane.

Figure 257: Example Print dialog — LibreOffice Media & Quality page — macOS
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Media & Quality options
Click on Media & Quality to open a drop-list down with the following printing options 
(Figure 257).

Feed from

Select from the drop-down list the paper tray to use if the printer has more than one 
paper tray.

Media Type

Select from the drop-down list the paper type that has been loaded into the paper tray 
being used, for example Envelope, Photo, Plain Paper.

Quality

Select the level of printing quality required.

Figure 258: Example Print dialog — LibreOffice Layout page — macOS
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Layout options
Click on Layout to open a drop-list down with the following options for the document printing 
layout (Figure 258).

Pages per sheet

Select from the drop-down list how many pages are printed on one sheet of paper.

Layout Direction

Select the printing order of multiple pages on one sheet of paper.

Border

When multiple pages are printed on one sheet of paper, a border is drawn around each 
page.

Reverse page orientation

If LibreOffice prints the pages in the wrong order, select this option and print the 
document again.

Flip horizontally

If LibreOffice prints the pages in the wrong orientation, select this option and print the 
document again.

Paper Handling options
Click on Paper Handling to open a drop-list with the following options when printing multiple 
page documents (Figure 259).

Collate Sheets

When selected collates multiple printed copies into separate documents.

Pages to Print

Select which pages in the document to print from the drop-down list: All pages; Odd only; 
Even only.

Page Order

Select the page printing order from the drop-down list: Automatic; Normal; Reverse.

Scale to fit paper size

Adjusts the printed page to fit the paper size.

Destination Paper Size

Select a paper size from the options available in the drop-down list. Only available if 
Scale to fit paper size has been selected.

Scale Down Only

Scales down the drawing to fit the page size. Only available if the selected page size is 
smaller than the drawing size.

Watermark options
Provides options to print watermark text on the drawing pages, for example Confidential if the 
document is of a sensitive nature.

Printer info options
Provides information about the printer being used, for example ink levels, printer name, and 
printer location.
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Figure 259: Example Print dialog — LibreOffice Paper Handling page — macOS

Printing examples

The following printing instructions are examples ONLY. Actual printing method may differ from 
these examples because printing depends on computer operating system, computer setup, and 
the connected printer. For more information on printing, see “Linux or Windows printing” on 
page 257, or “macOS printing” on page 260, and the Writer Guide.

Individual page
1) Open the Print dialog and select General to open the General page. 

2) In Printer, Select the printer to use from the drop-down list if more than one printer is 
connected to the computer.

3) In Ranges and Copies, select Pages and enter the page number of the page to be 
printed.
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4) In Ranges and Copies, enter how many copies to be printed in the Number of copies 
box.

5) Click Print to print the individual page and close the Print dialog.

All pages
1) Open the Print dialog and select General to open the General page. 

2) In Printer, select the printer to use from the drop-down list if more than one printer is 
connected to the computer.

3) In Ranges and Copies, select All Pages.

4) In Ranges and Copies, enter how many copies to be printed in the Number of copies 
box.

5) Click Print to print all pages in the document and close the Print dialog.

Range of pages
1) Open the Print dialog and select General to open the General page.

2) In Printer, select the printer to use from the drop-down list if more than one printer is 
connected to the computer.

3) In Ranges and Copies, select Pages and enter the page numbers of the pages to print 
using the format, for example, 1,3,7 or 2–5,7,9.

4) In Ranges and Copies, enter how many copies to be printed in the Number of copies 
box.

5) Click Print to print the selected pages and close the Print dialog.

Selection printing
1) Select the pages in the Pages panel in LibreOffice Draw.

2) Open the Print dialog and select General to open the General page.

3) Select the printer to use from the drop-list if more than one printer is connected to the 
computer.

4) In Ranges and Copies, select Selection and then select Odd and Even Pages, Even 
Pages, or Odd Pages from the Include drop-down list.

5) In Ranges and Copies, enter how many copies to be printed in the Number of copies 
box.

6) Click OK to print the pages and close the Print dialog.

Multiple pages on a single sheet
1) Open the Print dialog and select General to open the General page.

2) In Printer, select the printer to use from the drop-down list if more than one printer is 
connected to the computer.

3) In Page Layout, select the number of pages to print per sheet of paper from the Pages 
per sheet drop-down list. The preview panel shows how the pages will look when printed 
on a page.

4) In Page Layout, select how the multiple pages are printed on a page from the Order 
drop-down list.
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5) If necessary, select Draw a border around each page to distinguish each page printed on 
a sheet of paper.

6) In Ranges and Copies, enter how many copies to be printed in the Number of copies 
box.

7) Click Print to print the document and close the Print dialog.

Brochure printing
In LibreOffice Writer, Impress, and Draw, a document can be printed as a brochure, which is also 
known as booklet printing. The pages are arranged so that when the printed pages are folded in 
half, the pages are in the correct pagination order to form a brochure or booklet.

Tip

Plan a document so it looks professional when printed as a brochure. Choose 
appropriate margins, font sizes, and so on because pages are normally printed at 
half size on a sheet of paper. Experiment to get the best document format to match 
the capabilities of the printer being used.

Simplex printer

1) Open the Print dialog and select General to open the General page.

2) In Printer, select the printer to use from the drop-down list if more than one printer is 
connected to the computer.

3) In Printer, click on Properties to open the properties dialog for the selected printer.

4) In Layout, make sure the printer is set to the same orientation (portrait or landscape) as 
specified in the page setup for the document. Usually the orientation does not matter, but 
is important for brochures to create the correct page layout.

5) In Paper Quality, select the type of paper from the Media drop-down list.

6) If required, in Color, select either Black & White or Color printing option.

7) Click OK to close the properties dialog and return to the Print dialog.

8) In Page Layout, select Brochure.

9) In Range and Copies, select the following:

d) In Include, select Even pages, or Odd pages from the drop-down list.

e) In Paper sides, select Print on one side (simplex) from the drop-down list.

10) Click Print to print the even or odd pages.

11) Take the printed pages out of the printer and put back into the printer in the correct 
orientation to print on the blank side. This may require some testing to find out what the 
correct arrangement is for the selected printer.

12) If the Even Pages were printed, now select Odd Pages in Include. If Odd Pages were 
printed, now select Even Pages in Include.

13) Click Print to finish printing the document as a brochure and close the Print dialog.

14) Make sure the printed pages create a brochure when all the pages are placed in the 
correct order.

Duplex printer

1) Open the Print dialog and select General to open the General page.
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2) In Printer, select the printer to use from the drop-down list if more than one printer is 
connected to the computer.

3) In Printer, click Properties to open the properties dialog for the selected printer.

4) Make sure the printer is set to the same orientation (portrait or landscape) as specified in 
the page setup for the document. Usually the orientation does not matter, but is important 
for brochures to create the correct page layout.

5) In Paper Quality, select the type of paper from the Media drop-down list.

6) If required, in Color, select either Black & White or Color printing option.

7) Click OK to close the properties dialog and return to the Print dialog.

8) In Range and Copies, select the All Pages option.

9) In Range and Copies, select one of the following options from the Paper sides 
drop-down list. Actual options available for duplex printing depend on the printer model 
and the computer system being used:

– Print on both sides (duplex long edge).

– Print on both sides (duplex short edge).

10) In Page Layout, select the Brochure option.

11) Click Print to print the document as a brochure and close the Print dialog.

Black and white or grayscale printing

Printer settings

The following example procedure explains how to print documents in black and white or 
grayscale on a color printer:

1) Open the Print dialog and select General to open the General page.

2) Select the printer to use from the drop-down list if more than one printer is connected to 
the computer.

3) Click on LibreOffice Draw to open the printing options page for LibreOffice Draw.

4) In Color, select Grayscale, or Black & white from the available options.

5) Click Print to print the document and close the Print dialog.

Tips

Some color printers may only allow printing in color regardless of the settings 
selected. More details can be found in the information for the selected printer.

Grayscale is the best option for printing any colored text or graphics in a document 
on a monochrome printer. Colors printed in shades of gray give more detail. When 
printing color in black and white some of this detail is lost.

LibreOffice settings

Use the Print page in the Options LibreOffice Draw dialog to change the LibreOffice settings to 
print all colored text and graphics as grayscale, or black and white.

1) Go to Tools > Options > LibreOffice Draw  > Print (macOS LibreOffice > Preferences 
> LibreOffice Draw > Print) on the Menu bar to open the Options LibreOffice Draw Print 
dialog (Figure 260).
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Figure 260: Options LibreOffice Draw Print dialog

2) In Quality, select either the option Grayscale, or Black & white.

3) Click OK to save the change and close the Options LibreOffice Draw Print dialog.

4) Print the document using one of the above procedures and the document is printed as 
grayscale, or black and white.

Exporting

PDF format
LibreOffice can export documents as a PDF (Portable Document Format) file. This standard file 
format is ideal for sending a file to be viewed on another computer using PDF viewing software.

Directly as PDF

Export the complete document using default PDF settings as follows:

1) Click on Export Directly as PDF on the Standard toolbar, or go to File > Export As > 
Export Directly as PDF on the Menu bar.

2) Enter a file name and location for the PDF file and click on Save to export the file as 
PDF.

Note

The page range, image compression, or other printing options are not available 
when creating a PDF file using Directly as PDF.

Controlling PDF content and quality

For more control over the content and quality when creating a PDF file, use the options available 
in the PDF Options dialog (Figure 261). For more information on available options, see the 
Getting Started Guide.

1) Go to File > Export As > Export as PDF on the Menu bar to open the PDF Options 
dialog.

2) Select the required options available in the various pages of the PDF Options dialog.

3) Click on Export and a file browser window opens.
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Figure 261: PDF Options dialog — General page

4) Navigate to the required location and enter a file name for the PDF being created.

5) Click on Save to export the file as PDF. The file browser window and the PDF Options 
dialog close.

Notes

When exporting in Other formats, a dialog may open providing options that can be 
selected when a LibreOffice Draw file is exported.

The content of the exported file depends on the elements selected on the drawing. If 
no elements are selected, the complete drawing file is exported.

Other formats
LibreOffice can export files in various formats, which are listed in the drop-down list of the file 
browser window. For more information on exporting graphics, see Chapter 6, Editing Pictures.

1) Go to File > Export on the Menu bar to open a file browser window.

2) Navigate to the directory where the drawing is going to be saved.

3) Specify a file name for the exported drawing in the File name text box.

4) Select the required file format from the Save as type drop-down list.

5) Click on Save or Export to save the file and close the file browser window.
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Emailing documents

LibreOffice provides several ways to send documents quickly and easily as an email attachment 
in ODF format (LibreOffice default format), or as a PDF. For more information on emailing 
documents, see the Getting Started Guide.

Open Document format
1) Go to File > Send > Email Document on the Menu bar. LibreOffice opens the default 

email program with the document attached to a new email.

2) In the email program, enter the recipient, subject, and message, then send the email.

PDF format
1) Go to File > Send > E-mail as PDF on the Menu bar. and the PDF Options dialog 

opens.

2) Create a PDF file of the drawing using the options available in the PDF Options dialog, 
see “PDF format” on page 271 for more information. The default email application opens 
with the PDF file attached to a new email.

3) In the email application, enter the recipient, subject, and message, then send the email.

Digital signatures

A digital signature is a mathematical scheme for verifying the authenticity of digital versions of 
drawings or documents.

Signing a drawing digitally, a personal key or certificate is required. This personal key is stored 
on a computer is a combination of a private key and a public key. These keys are added to a 
drawing when a digital signature is applied. A certificate is obtained from a certification authority, 
which may be a private company or a government institution.

Applying a digital signature to a drawing, a checksum is computed from the drawing content plus 
the personal key being used. The checksum and public key are stored together with the drawing.

Opening the drawing on another computer with a recent version of LibreOffice, the program 
computes the checksum again and compares it with the stored checksum. If both checksums 
are the same, the program opens the original, unchanged drawing.

Also, the program can display the public key information from the certificate. This information is 
compared with the public key that is published on the web site of the certificate authority. 
Whenever the drawing is changed, this change breaks the digital signature.

For a more detailed description of how to obtain, use and manage a certificate and signature 
validation, see the LibreOffice Getting Started Guide and Applying Digital Signatures in 
LibreOffice Help (https://help.libreoffice.org/7.1/en-US/text/shared/guide/digitalsign_send.html?
&DbPAR=WRITER&System=UNIX).

Removing personal data

Sometimes it is necessary to remove personal data, versions, notes, hidden information, or 
recorded changes from drawing files before files are distributed, or PDF version is created. Use 
the two following procedures to remove this type of data from a drawing file.
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Figure 262: Options LibreOffice Security dialog

Figure 263: Security Options and Warnings dialog
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Figure 264: Properties dialog — General page

Setting security and warning options
1) Go to Tools > Options > LibreOffice > Security (macOS LibreOffice > Preferences > 

LibreOffice > Security) to open the Options LibreOffice Security dialog (Figure 262).

2) Click on Options to open the Security Options and Warnings dialog (Figure 263).

3) Select the required options to allow LibreOffice to warn when drawing files contain 
sensitive information and/or automatically remove personal information on saving.

4) Click OK to close the Security Options and Warnings dialog and save the selected 
options.

5) Click OK to close the Options LibreOffice Security dialog.

Removing personal data and drawing file information
1) Open a drawing file and go to File > Properties on the Menu bar to open the Properties 

dialog (Figure 264).

2) In the General page, deselect the option Apply user data.

3) Click on Reset Properties to change the following file properties:

– Remove any information in the created and modified fields.

– Delete modification and printing dates.
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– Reset editing time to zero.

– Reset creation date to the current date and time.

– Reset version number to 1.

4) Click OK to save the changes and close the Properties dialog.

Removing version information
To remove version information from a drawing file, use one of the following methods:

1) Go to File > Versions on the Menu bar to open a properties dialog for the drawing file.

2) Select the versions in the Existing Versions list for deletion and click Delete. The dialog 
automatically closes.

3) Go to File > Save As on the Menu bar and save the drawing file using a different name.

Redaction

Documents are redacted to remove or hide any sensitive information. Redaction allows the 
selective disclosure of information in a document while keeping other parts of the document 
secret.

When a redacted document is exported as a new document, any redacted portions are removed 
and replaced by redaction blocks of pixels preventing any attempt to restore or copy the original 
contents. A redacted document is often exported in PDF format for publication, or sharing.

Any documents that are redacted in Writer, Calc, or Impress are automatically transferred as a 
copy to Draw for redaction.

Note

When a redacted document is exported as a new PDF file, all information in the 
redacted areas is removed and replaced by redaction blocks of pixels. The redacted 
areas prevent any attempt to restore, or copy the original contents.

Documents, spreadsheets, or presentations
1) Open the document to be redacted in Writer, Calc or Impress, then go to Tools > Redact 

on the Menu bar and the following happens:

– The document is copied, prepared and transferred to Draw as an untitled file.

– Draw opens with the untitled document displayed.

– Redaction toolbar (Figure 265) automatically opens. If the Redaction toolbar is not 
displayed, go to View > Toolbars on the Menu bar and select Redaction.

2) Go to Tools > Redact on the Menu bar and select either Rectangle or Freeform, or 
click on Rectangle Redaction or Freeform Redaction in the Redaction toolbar.

3) Draw the required shapes to redact the document sensitive areas. The redaction shape 
is gray allowing the sensitive areas in the document to be visible before redaction.

4) Click on Export Preview PDF to create a PDF copy of the document and save as a PDF 
file. Review the sensitive information in the gray redacted areas before redaction is 
finalized.

5) Delete the preview PDF copy after reviewing the redaction areas in the file.
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Figure 265: Redaction toolbar

6) Go to Tools > Redact on the Menu bar and use one of the following options in the 
Redaction toolbar:

– Select either Redacted Export (White), or Redacted Export (Black) option.

– Click on Redacted Export (White), or Redacted Export (Black) icon.

7) Navigate to the folder in the file browser window that opens where the redact document 
is to be saved and enter a name for the document.

8) Click on Save to create the redacted PDF file and the following happens:

– Gray redaction areas are converted to white, or black and the document is exported as 
a PDF

– There is no selectable text in the PDF file and any redacted content is non-existent.

Drawings
Open a drawing file in in Draw and follow Steps 2) thru 8) in “Documents, spreadsheets, or 
presentations” on page 276 to create a redacted PDF copy of the drawing file.
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Drawing pages

Pages pane
Drawings created in Draw can consist of multiple pages and stored as one file on a computer. 
The pages in a drawing are displayed as thumbnails in the Pages pane. Drawing pages can be 
added, renamed, deleted, and arranged in a sequence using the Pages pane.

By default the Pages pane (Figure 266) appears docked on the left of the Workspace. If the 
Pages pane is not visible, go to View > Page Pane on the Menu bar. The Pages pane can 
become a floating window using one of the following methods:

• Windows and Linux only — press and hold the Ctrl key, then double-click in the title 
bar of the Pages pane to create a floating window.

• macOS only — press and hold the  key, then double-click in the title bar of the ⌘ Pages 
pane to create a floating window.

• Windows, Linux and macOS — click in the title bar and drag the Pages pane to create 
a floating window.

To close the Pages pane, click on the X on the right side of the title bar, or deselect View > Page 
Pane in the Menu bar.

Selecting pages
To make a page appear in the Workspace, select a page using one of the following methods:

• Select a page in the Pages pane.

Figure 266: Draw main window

(1) Pages pane
(2) Workspace

(3) Sidebar
(4) Status bar

(5) Layers bar
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Figure 267: Navigator dialog

Figure 268: Navigator deck in Sidebar

• Use the keyboard shortcut F5, or go to View > Navigator on the Menu bar to open the 
Navigator dialog (Figure 267) and select a page from the displayed list.

• Click on Navigator in the Sidebar to open the Navigator deck in the Sidebar (Figure 268) 
and select a page from the displayed list.

Navigating pages
To navigate a multi-page drawing and select a page for editing, use one of the following 
methods:

• Select the required page in the Pages pane.

• Select the required page in the Navigator dialog (Figure 267), or the Navigator deck in 
the Sidebar (Figure 268).

• Go to Page > Navigate on the Menu bar and select one of the following options:

– To First Page — moves to the first page in the drawing.

– To Previous Page — moves backward to the previous page.

– To Next Page — moves forward to the next page.

– To Last Page — moves to the last page in the drawing.

– Go to Page — enter the page number in the text box and press the Enter key to 
move to the selected page.
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Figure 269: Insert Pages dialog

Adding pages

Inserting new page

Insert a new page into a drawing using one of the following methods. A new page is added after 
the selected page in the Pages pane, or at the end of the pages if no page is selected.

• Go to Page > New Page on the Menu bar.

• Right-click in the Pages pane and select New Page from the context menu.

• Right-click on the page displayed in the Workspace and select Page > New Page from 
the context menu.

• Go to Page > Insert Page from File on the Menu bar and open the Insert File dialog. 
Navigate to the folder where the file is located. Select the file and click on Open to open 
the Insert Pages dialog (Figure 269). Select the required pages and click OK.

Duplicating pages

Select a page in the Pages pane, then use one of the following methods to insert the duplicate 
page after the selected page:

• Go to Page > Duplicate Page on the Menu bar.

• Right-click on a page in the Pages pane and select Copy from the context menu. 
Right-click in a blank area of the Pages pane and select Paste from the context menu.

Renaming pages
When pages are inserted into a drawing, they are automatically named as Page 1, Page 2, and 
so on in the Pages pane, Navigator dialog, or Navigator deck in the Sidebar. As the page order 
is changed, pages are automatically renumbered making it difficult to identify the pages.
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It is recommended to give each page a memorable name to identify pages as follows:

1) Select a page for renaming in the Pages pane.

2) Use one of the following methods and rename the selected page:

– Go to Page on the Menu bar and select Rename Page from the submenu.

– Right-click on the selected page in the Pages pane and select Rename Page from the 
context menu.

– Right-click on the page displayed in the Workspace and select Page > Rename Page 
from the context menu.

3) In the Rename Page dialog that opens, enter a new name for the page and click OK.

Changing page order
Use one of the following methods and change the page order in a drawing:

• Select a page thumbnail in the Pages pane, then click and drag the page thumbnail to 
change the page order.

• Select a page thumbnail in the Pages pane, then go to Page > Move on the Menu bar 
and select one of the following options:

– Page to Start — moves the selected page to the beginning of a drawing.

– Page Up — moves selected page up one place in the page order of a drawing.

– Page Down — moves selected page down one place in the page order of a drawing.

– Page to End — moves selected page to the end of a drawing.

Deleting pages
1) Select a page for deletion in the Pages pane.

2) Use one of the following methods to delete the selected page:

– Go to Page > Delete Page on the Menu bar.

– Right-click on the selected page in the Pages pane and select Delete Page from the 
context menu.

– Right-click on the page displayed in the Workspace and select Page > Delete Page 
from the context menu.

Note

When deleting pages in a drawing, there is no confirmation of deletion for the 
selected page.

Master pages

A master page is a page used as a starting point for all drawing pages to control basic formatting 
of pages based on a master page. It is similar to a page style in Writer, or master slide in 
Impress. A drawing with multiple pages can have more than one master page allowing a different 
look assigned to individual pages in a drawing, for example title page, contents page, and 
drawing pages.
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Figure 270: Master View toolbar

Master pages have a defined set of characteristics. For example, background objects (such as 
logos, decorative lines), text formatting, blocks of standard text, and fields such as page 
numbering, date, or filename.

Master page view
Go to View > Master on the Menu bar and open the master page view. This also opens the 
Master View toolbar (Figure 270). If this toolbar does not open, go to View > Toolbars > Master 
View on the Menu bar. To return to normal page mode, click on Close Master View in the 
Master View toolbar, or go to View > Normal on the Menu bar.

Creating master pages
Each drawing created uses the default master page. When a drawing has multiple pages, 
master pages can be created and added to the drawing as follows:

1) Go to View > Master on the Menu bar to open the master page view and the Master 
View toolbar.

2) Create a new master page using one of the following methods. After creation, the new 
master page is automatically selected.

– Click on New Master in the Master View toolbar (Figure 270).

– Go to Page > New Master on the Menu bar.

3) Add the required graphic objects, logos, fields, text and so on to the selected master 
page, then save the drawing.

4) Assign the new master page to a drawing page. See “Changing master pages” on 
page 285 for more information.

5) Rename the master page, see “Renaming master pages” on page 284.

Renaming master pages
Each new master page created has the default name of Default 1, Default 2, and so on. It is 
recommended to rename new master pages. The default master page that was created when 
the drawing was created can also be renamed.

1) Go to View > Master on the Menu bar to open the master page view and the Master 
View toolbar.

2) Use one of the following methods and open the Rename Master Slide dialog:

– Click on Rename Master in the Master View toolbar (Figure 270).

– Right-click on a master page in the Pages pane and select Rename Master from the 
context menu.

3) Enter a name for the master page in the Name text box in the Rename Master dialog.

4) Click OK to save the changes and close the Rename Master Slide dialog.
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Figure 271: Available Master Pages dialog

Changing master pages
When a drawing uses several master pages, each page in the drawing can use a different 
master page.

1) Go to View > Normal on the Menu bar.

2) In the Pages pane, select the page to change the master page.

3) Right-click on the page in the Workspace and select Change Master Page from the 
context menu to open the Available Master Pages dialog (Figure 271).

4) In the Select a Page Design preview box, select a master page design for the selected 
page.

5) If necessary, select Exchange background page to use the selected master page for all 
pages in the drawing.

6) If necessary, select Delete unused backgrounds to delete any master pages shown in 
Select a Page Design preview box that have not been assigned to a page.

7) Click OK to change the selected master page and close the Available Master Pages 
dialog.
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Deleting master pages
Deleting master pages is only available when there is more than one master page in a drawing.

1) Go to View > Master on the Menu bar to open the master page view and the Master 
View toolbar (Figure 270 on page 284).

2) Use one of the following methods to delete a master page. The deletion of the master 
page is immediate and there is no confirmation

– Select and right-click on a master page in the Pages pane and select Delete Master 
from the context menu.

– Click on Delete Master in the Master View toolbar.

– Go to Page > Delete Master on the Menu bar.

Note

The default master page created when the drawing was first created cannot be 
deleted. Also, if the drawing only uses one named master page, then that named 
master page cannot be deleted.

Master pages from templates
Master pages from templates available in LibreOffice can be used for drawings. If the master 
pages from a template use a different page size, the master pages loaded into a drawing are 
adapted to the drawing page size. This may cause some objects to be stretched, or incorrectly 
positioned when adapted to fit the drawing page size.

Figure 272: Load Master Page dialog
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1) Go to View > Master on the Menu bar to open the master page view and the Master 
View toolbar.

2) Right-click on a master page displayed in the drawing and select Change Master Slide 
from the context menu to open the Available Master Pages dialog (Figure 271 on 
page 285).

3) Click on Load… to open the Load Master Page dialog (Figure 272).

4) Select a template category from the list displayed in Categories.

5) Select a template from the list displayed in Templates.

6) If necessary, click on Preview to display a preview of the selected template.

7) Click OK to close the Load Master Slide dialog. The Available Master Slides dialog opens 
displaying the selected template in Select a Slide Design.

8) Select the master page required in Select a Slide Design.

9) If necessary, select Exchange background page to use the selected master page for all 
pages in the drawing.

10) If necessary, select Delete unused backgrounds to delete any master pages shown in 
Select a Slide Design that have not been assigned to a page.

11) Click OK to assign the selected master page to a drawing page and close the Available 
Master Slides dialog.

Inserting fields
1) Go to View > Master on the Menu bar to open the master page view and the Master 

View toolbar.

2) Go to Insert > Field on the Menu bar and select a field type from the options available 
on the submenu. The selected field appears in the middle of the drawing page.

3) Select the inserted field so that the border is displayed.

4) Click on the border and drag the field to the required position.

5) If necessary, format the text used in the field to the drawing requirements. For more 
information, see Chapter 9, Adding and Formatting Text.

The field types that are available for insertion as follows:

Date (fixed)

Inserts the current date into the master page as a fixed field. The date is not 
automatically updated.

Date (variable)

Inserts the current date into the master page as a variable field. The date is automatically 
updated each time the file is opened.

Time (fixed)

Inserts the current time into the master page as a fixed field. The time is not 
automatically updated.

Time (variable)

Inserts the current time into the master page as a variable field. The time is automatically 
updated each time the file is opened.
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Figure 273: Page Properties dialog — Page page

Author

Inserts the first and last names listed in the LibreOffice user data into the active page. Go 
to Tools > Options > LibreOffice > User Data (macOS LibreOffice > Preferences > 
LibreOffice > User Data) on the Menu bar to enter user data details.

Page Number

Inserts the page number into every page of the drawing. To change the number format, 
go to Page > Page Properties on the Menu bar to open the Page Properties dialog 
(Figure 273). Click on the Page tab and select a number format from the drop-down list 
in Layout Settings.

Page Title

Inserts the page title. A page title is created in Normal view by going to Page > Rename 
Page on the Menu bar and entering a title in the Name text box in the Rename Page 
dialog that opens. For more information, see “Renaming pages” on page 282.

Page Count

Inserts the total number of pages in a drawing.

File Name

Inserts the name of the active file. The name only appears after the file has been saved.

Templates

A drawing template is used as the starting point for all new drawings. For example, a template 
can include a company logo, name and information on the first page of a drawing with the 
remaining pages in a drawing only showing the company logo and name. Templates can contain 
anything that regular drawings can contain, such as text, graphics, a set of styles, and so on.

All document types created using LibreOffice are based on templates. If a template is not 
specified when a new document is started, then the default template for that type of document is 
used. This default template uses a set of properties that are hard coded into LibreOffice. If 
necessary, the default template for drawings, which is hard coded into LibreOffice, can be 
changed. See “Default template” on page 291 for more information. For more information on 
templates and obtaining templates from other sources, see the Getting Started Guide.
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The only template available in Draw is the default template and no predefined drawing templates 
are installed with LibreOffice. However, templates can be created using methods described in 
the following sections. Drawing templates can also be installed from other sources, see 
"Importing templates" on page 296 for more information.

Creating templates

Using Save As Template dialog

1) Open a drawing to use as a basis for a template, or open and edit a template to use as a 
basis for a new template.

2) Add any extra content and styles, or edit the content and styles to the template 
requirements.

3) Use one of the following methods to open the Save As Template dialog (Figure 274):

– Go to File > Templates > Save As Template on the Menu bar.

– Click on the triangle ▼ to the right of Save on the Standard toolbar and select Save as 
Template from the drop-down menu.

4) Enter a name for the template in the Enter Template Name text box.

5) Select a template category from the list available in the Select Template Category box.

6) If the new template is to be used as the default template in LibreOffice Draw, select the 
option Set as default template.

7) Click on Save to save the template and close the Save As Template dialog.

Using Save As command

1) Go to File > Save As on the Menu bar, or use the keyboard shortcut Shift+Ctrl+S 
(macOS ⌘+Ctrl+S) to open the Save as dialog.

Figure 274: Save As Template dialog
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2) Navigate to the LibreOffice templates folder. Actual location of the LibreOffice template 
folder depends on the computer system and setup.

3) Enter a filename using the extension OTG in the Name box.

4) From the drop-down list, select ODF Drawing Template (.otg) as the file type.

5) Click on Save to save the template and close the dialog.

Note

When saving a drawing as a template, the template must be saved in the LibreOffice 
templates folder for the template to be recognized and located by the LibreOffice 
Template Manager. See “Template folder location” on page 294 for more information.

Creating drawings from templates

Start Center

Open LibreOffice and create a new drawing from a template displayed in the Start Center using 
one of the following methods:

• Click on Templates in the Start Center to open a display of available templates for all 
LibreOffice applications. Click on the required template and a new document opens 
using the relevant LibreOffice module for the template.

• Click on the triangle ▼ to the right of Templates in the Start Center, then select Draw 
Templates to display Draw templates. Click on the required template and a new drawing 
opens using Draw.

Figure 275: Templates dialog
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Templates dialog

1) Use one of the following methods to open the Templates dialog (Figure 275):

• Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

– Use the keyboard short cut Ctrl+Shift+N (macOS ⌘+Shift+N).

2) Select Drawings from the Filter drop-down list.

3) Select a category from the options available in the All Categories drop-down list.

4) Select a template from the options available in the preview box.

5) Click on Open, or double click on the template to create a new drawing using the 
selected template and close the Template dialog.

6) Go to File > Save As on the Menu bar and save the new drawing as a file using the 
extension ODG.

Default template
If a new drawing is created without selecting a template, LibreOffice creates the drawing using a 
set of properties hard coded into LibreOffice. However, any drawing template can be used as the 
default template for Draw. The selected template must be located in the templates folders used 
for LibreOffice applications and categories. See “Template folder location” on page 294 for more 
information.

Setting default template

1) Use one of the following methods to open the Templates dialog:

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

– Use the keyboard short cut Ctrl+Shift+N (macOS ⌘+Shift+N).

2) Select Drawings from the Filter drop-down list.

3) Select a category from the options available in the All Categories drop-down list.

4) Select a template from the options available in the preview box.

5) Right-click on the selected template and select Set as default from the context menu. 
There is no confirmation that the selected template is now the default template for new 
drawings. The default template is indicated by check mark at the top left corner of the 
template icon.

6) Click on Close to close the Templates dialog. The next time a new drawing is created, it 
uses the new default template.

Note

If a new drawing is suitable to use as the default template, then the drawing must be 
saved as a template first before it can be used as the default template. See “Creating
templates” on page 289 for more information.

Tip

To reset all default templates for all LibreOffice modules, click on Manage in the 
Templates dialog and select Reset All Default Templates from the drop-down list.
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Resetting default template

1) Use one of the following methods to open the Templates dialog:

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

– Use the keyboard short cut Ctrl+Shift+N (macOS ⌘+Shift+N).

2) Select Drawings from the Filter drop-down list.

3) Select a category from the options available in the All Categories drop-down list.

4) Right-click on the default template. The default template is indicated by check mark at 
the top left corner of the template icon.

5) Select Reset Default from the context menu. There is no confirmation that LibreOffice 
Draw has been reset to using LibreOffice default properties. The check mark is removed 
from the template icon.

6) Click on Close to close the Templates dialog. The next time a new drawing is created, it 
uses the LibreOffice default template.

Editing templates
Template styles and template content can be edited and, if necessary, reapplied to drawings that 
were created using that template. Content in a drawing that is not included in the template 
cannot be reapplied.

Note

Templates that were supplied with LibreOffice cannot be deleted. Only templates that 
have been created using LibreOffice, or imported into LibreOffice, can be edited or 
deleted.

Editing

1) Use one of the following methods to open the Templates dialog:

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

– Use the keyboard short cut Ctrl+Shift+N (macOS ⌘+Shift+N).

2) Select a drawing template that was created using LibreOffice, or imported into 
LibreOffice.

3) Right-click on the selected template and select Edit from the context menu to open the 
template in Draw.

4) Edit the template as any other drawing.

5) Go to File > Save on the Menu bar, or use the keyboard shortcut Ctrl+S (macOS ⌘+S) 
to save the template.

6) Alternatively, save the edited template as a new template. See “Creating templates” on 
page 289 for more information.

Updating drawings from modified template

If a drawing is opened and the template has been modified, a confirmation dialog opens asking 
to update the styles in the drawing to the formatting used in the modified template.
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• Select Update Styles to update any styles in the drawing that have been changed in the 
template and close the confirmation dialog.

• Select Keep Old Styles so that styles in the drawing that have been changed in the 
template are not updated. The confirmation dialog closes and does not appear when the 
document is reopened. Also, the drawing is no longer connected to the template.

Note

If Keep Old Styles is selected, the template is still listed under File > Properties > 
General. The template has to be reassigned to reconnect the document to the 
template.

Changing templates assigned to drawings
If necessary, the template originally used for a drawing can be changed to a different template, 
or the original template used for the drawing reassigned.

• To manually change, or reassign a template, create a new drawing from the required 
template and copy the contents from the old drawing into the new drawing.

• Download the Template Changer extension from the LibreOffice website at 
https://extensions.libreoffice.org/extensions?ord=download_d&Tags%5B%5D=47 and 
install it into LibreOffice. Restart LibreOffice to activate the extension. Open the drawing 
and use File > Templates > Change template (current document) on the Menu bar to 
change the template. For more information, see the Getting Started Guide.

Figure 276: Options LibreOffice Paths dialog
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Organizing templates
LibreOffice can only locate templates that are in LibreOffice template folder. Template categories 
can be created and used to organize templates, for example creating separate categories for 
different projects or clients. Templates can also be imported and exported.

Template folder location

The template folder location in LibreOffice varies with the computer operating system. Locating 
the template folder on a computer is as follows:

1) Go to Tools > Options > LibreOffice > Paths (macOS LibreOffice > Preferences > 
LibreOffice > Paths) on the Menu bar to open the Options LibreOffice Paths dialog 
(Figure 276).

2) Scroll down to Templates in Paths used by LibreOffice to identify the template folder 
used by LibreOffice. The following are examples of the template folder location using 
different operating systems:

– Windows 11
C\Users\peter\AppData\Roaming\LibreOffice\4\user\template

– Ubuntu 23.04
/home/peter/.config/libreoffice/4/user/template;/home/peter/Templates

– macOS Ventura 13.5
/Users/peter/Library/Application Support/LibreOffice/4/user/templates

Creating template categories

1) Use one of the following methods to open the Templates dialog:

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

– Use the keyboard short cut Ctrl+Shift+N (macOS ⌘+Shift+N).

2) In the Filter drop-down lists, select Drawings as the application.

3) In Manage, select New Category from the context menu.

4) Enter a name in the Enter new category name text box in the dialog that opens.

5) Click OK to save the new category in LibreOffice and close the dialog.

Note

In LibreOffice template categories, the default options Rename Category and 
Delete Category are grayed out. This indicates that template categories cannot be 
renamed or deleted.

Renaming template categories

Template categories originally installed with LibreOffice cannot be renamed. Only template 
categories that have been created after the LibreOffice installation can be renamed.

1) Use one of the following methods to open the Templates dialog:

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

– Use the keyboard short cut Ctrl+Shift+N (macOS ⌘+Shift+N).

2) In the Filter drop-down lists, select Drawings as the application.
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3) Select the category for renaming from the options available in the All Categories 
drop-down list.

4) In Manage, select Rename Category from the context menutest.

5) Enter a name in the Enter new category name text box in the dialog that opens.

6) Click OK to save the renamed category in LibreOffice and close the dialog.

Deleting template categories

Template categories installed with LibreOffice cannot be deleted. Only template categories that 
have been created after the LibreOffice installation can be deleted.

1) Use one of the following methods to open the Templates dialog:

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

– Use the keyboard short cut Ctrl+Shift+N (macOS ⌘+Shift+N).

2) In the Filter drop-down lists, select Drawings as the application.

3) Select the template category for deletion from the options available in the All Categories 
drop-down list.

4) In Manage, select Delete Category from the drop-down list.

5) Click on Yes in the warning message to confirm the deletion of the category.

Moving templates

1) Use one of the following methods to open the Templates dialog:

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

– Use the keyboard short cut Ctrl+Shift+N (macOS ⌘+Shift+N).

2) In the Filter drop-down lists, select Drawings as the application.

Figure 277: Select Category dialog
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3) Select the template category for moving from the options available in the All Categories 
drop-down list.

4) Right-click on the template that is going to be moved and select Move from the context 
menu to open the Select Category dialog (Figure 277).

5) Select a category from Select from Existing Category, or enter a name for a new 
category in Create a New Category.

6) Click OK to move the template to the selected category and close the Select Category 
dialog.

Importing templates

Using the Extension Manager, templates can be downloaded from many sources, including the 
official LibreOffice template repository. For more information about using the Extension Manager 
to import templates, see the Getting Started Guide.

Save the template on a computer, then import the template into the LibreOffice template folder 
as follows:

1) Use one of the following methods to open the Templates dialog:

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

– Use the keyboard short cut Ctrl+Shift+N (macOS ⌘+Shift+N).

2) In the Filter drop-down lists, select Drawings as the application.

3) Click on Manage and select Import from the context menu to open the Select Category 
dialog (Figure 277).

4) Select a category from Select from Existing Category, or enter a name for a new 
category in Create a New Category.

5) Click OK and a file browser window opens.

6) Navigate to the folder containing the template, select the template and click Open. The 
file browser closes and the template appears in the selected template category in the 
Templates dialog.

Note

Exporting a template does not remove it from the Templates dialog, or template 
folder. Exporting places a copy of the template in the location specified.

Exporting templates

Export a template from a template category to another location in a computer, or network, as 
follows:

1) Use one of the following methods to open the Templates dialog:

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

– Use the keyboard short cut Ctrl+Shift+N (macOS ⌘+Shift+N).

2) In the Filter drop-down lists, select Drawings as the application.

3) Select the required template category from the options available in the All Categories 
drop-down list.
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4) Right-click on the required template and select Export from the context menu to open a 
file browser window.

5) Navigate to the destination folder where the template is going to be exported to.

6) Click OK and the exported template appears in the selected folder.

7) Click on Close to close the Templates dialog.

Deleting templates

1) Use one of the following methods to open the Templates dialog:

– Go to File > New > Templates on the Menu bar.

– Go to File > Templates > Manage Templates on the Menu bar.

– Use the keyboard short cut Ctrl+Shift+N (macOS ⌘+Shift+N).

2) In the Filter drop-down lists, select Drawings as the application.

3) Select the required template category from the options available in the All Categories 
drop-down list.

4) Right-click on the template being deleted and select Delete from the context menu.

5) Click on Yes to confirm the deletion of the template.

6) Click on Close to close the Templates dialog.

Note

Templates installed with LibreOffice cannot be deleted. Only templates that have 
been created or imported after the installation of LibreOffice can be deleted.

Multiple layers

Notes

When a new layer is added, the layer is added to all pages in a drawing. However, 
when an object is added to a layer in a selected page, it is only added to the selected 
drawing page.

If an object is to appear on all drawing pages, for example, a company logo, add the 
object to the master page by going to View > Master on the Menu bar. See “Master 
pages” on page 283 for more information.

Layers in Draw allow assembly of related elements in a drawing. Layers are individual 
workspaces in a drawing that can be hidden from view, prevented from printing, or locked so that 
changes cannot be made.

Layers do not determine the stacking order of objects on a drawing, except for the Controls 
layer. The Controls layer is always in front of all other layers in a drawing. The stacking order of 
objects on a drawing is determined by the order in which objects were added. The stacking order 
of objects are rearranged by going to Shape > Arrange on the Menu bar.

Figure 278: Example of Draw Layers tab
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Layers in a drawing are indicated by tabs located at the bottom of the Workspace and above the 
Status bar, as shown by the example in Figure 278. By default, the Layout tab is always 
selected when a drawing is opened. Click on another tab to select another layer in the drawing.

Default layers

Normal view

In Normal view, LibreOffice Draw provides three default layers that are visible to the user. These 
default layers cannot be deleted or renamed.

Layout

The default workspace where objects are normally placed.

Controls

Used for form controls that have been assigned an action. Objects on this layer are 
always in front of objects on other layers. To prevent form controls from being visible on a 
drawing, deselect the Visible option in the Insert Layer or Modify Layer dialog. To 
prevent form controls from being printed, deselect the Printable option in the Insert 
Layer or Modify Layer dialog.

Dimension Lines

When dimension lines are drawn, the dimension lines are automatically placed on this 
layer. To prevent dimension lines from being visible on a drawing, deselect the Visible 
option in the Insert Layer or Modify Layer dialog. To prevent dimension lines from being 
printed, deselect the Printable option in the Insert Layer or Modify Layer dialog.

Master view

In Master view, LibreOffice provides a single layer, Background objects. This layer is used to 
places objects that appear on every page in a drawing, for example company logo, date, page 
number, drawing title, and so on.

Figure 279: Insert Layer dialog
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Inserting layers
1) Use one of the following methods to open the Insert Layer dialog (Figure 279):

– Right-click the layer tab area at the bottom of the Workspace area and select Insert 
Layer from the context menu.

– Go to Insert > Layer on the Menu bar.

2) Enter meaningful names for the layer in the Name and Title text boxes.

3) If necessary, enter a description for the new layer in the Description text box.

4) Select Visible for the layer to be visible in a drawing. When Visible is not selected, the 
layer is hidden and its name in the layer tab changes color to blue.

5) Select Printable for the layer to print when the drawing is printed. The name of a layer is 
underlined in the layer tab bar when Printable is not selected. For example, not printing 
a layer is useful if the layer is a draft layer for guides or annotations used in creating the 
drawing, but is not required for the final printed output.

6) Select Locked to prevent any objects on a layer from deletion, editing, or moving. No 
additional objects can be added to a locked layer. The name of a locked layer is changes 
to Italic text in the layer tab bar. For example, locking a layer is useful when a base plan 
is to be protected while adding a new layer with other details.

7) Click OK to close the Insert Layer dialog and the new layer automatically becomes active

Modifying layers
1) Select the layer that is going to be modified.

2) Use one of the following methods to open the Modify Layer dialog. The Modify Layer 
dialog is similar to the Insert Layer dialog:

– Right-click the layer tab area at the bottom of the Workspace area and select Modify 
Layer from the context menu.

– Go to Format > Layer on the Menu bar.

– Double click on the layer tab.

3) Make the necessary changes to the attributes for the layer.

4) Click OK to save the changes and close the Modify Layer dialog.

Working with layers

Selecting a layer

Click on the layer name tab in the Layers tab bar to select and activate the layer. Objects added 
to the drawing are only added to the active layer. Form controls are automatically added to the 
Controls layer and dimension lines are automatically added to the Dimension Lines layer.

If there are several layers in a drawing, a layer tab may not be visible on the Layers tab bar. Use 
the navigation icons on the left of the Layers tab bar to navigate to the required layer.

Hiding layers

1) Select the layer that is going to be hidden and open the Modify Layer dialog.

2) Deselect Visible and click OK. The text on the layer name tab changes color to blue. Any 
objects placed on a hidden layer are no longer visible on the other layers of the drawing.

3) Alternatively, hold down the Shift key and click on the layer name tab to hide the layer.
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Showing hidden layers

1) Select the hidden layer that is going to become visible and open the Modify Layer dialog.

2) Select Visible and click OK. The text on the layer name tab changes color to the default 
text color. Any objects placed on a hidden layer are now visible in the other layers of the 
drawing.

3) Alternatively, hold down the Shift key and click on the layer name tab to make the layer 
visible.

Locking layers

1) Select the layer that is going to be locked and open the Modify Layer dialog.

2) Select Locked and click OK. The text on the layer name tab is underlined. Locking a 
layer prevents any modification of the layer.

3) Alternatively, hold down the Ctrl (macOS ) key and click on the name tab to lock the ⌘
layer.

Unlocking layers

1) Select the locked layer and open the Modify Layer dialog.

2) Deselect Locked and click OK. The text on the layer name tab is no longer underlined.

3) Alternatively, hold down the Ctrl (macOS ) key and click on the name tab of the locked⌘  
layer to unlock it.

Note

Only layers that have been added to a drawing can be renamed or deleted. The 
default layers Layout, Controls, and Dimension Lines cannot be renamed or 
deleted.

Renaming layers

1) Select the layer that is going to be renamed and open the Modify Layer dialog.

2) Enter a new name in the Name text box and click OK to save the change.

3) Alternatively, right-click on the name tab of the layer and select Rename Layer from the 
context menu. The text becomes editable allowing the name to be changed. Click 
outside the tab area to save the change.

4) Alternatively, hold down the Alt key (macOS ) and click on the name tab. The text ⌥
becomes editable allowing the name to be changed. Click outside the tab area to save 
the change.

Deleting layers

1) Right-click on the name tab of the layer that is going to be deleted and select Delete 
Layer from the context menu.

2) Confirm the deletion of the layer. The layer and all of the objects on the layer are deleted 
from the drawing.

Moving objects between layers

If objects are selected on a layer, the Status bar indicates how many objects are selected. The 
position of the moved objects does not change in the drawing and the layer where the objects 
have been placed is displayed in the Status bar. Move the selected objects from one layer to 
another layer using one of the following methods:
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• Click and drag the selected objects to the name tab of the destination layer.

• Go to Edit > Cut on the Menu bar, or right-click on the selected objects and select Cut 
from the context menu. Select the destination layer, then go to Edit > Paste on the Menu 
bar, or right-click on the Workspace and select Paste from the context menu.

Dimensioning

Dimensioning objects in Draw and then displaying dimensions creates drawing similar to an 
engineering drawing. When dimensions are created, they are automatically placed on the 
Dimension Lines layer.

Dimensioning objects
1) Dimension an object using one of the following methods. The cursor changes shape 

depending on computer operating and system, for example a cross:

– Click on the triangle ▼ next to Lines and Arrows on the Drawing toolbar to open the 
Lines and Arrows subtoolbar (Figure 280) and click on Dimension Line.

– Click on Dimension Line in the Lines and Arrows panel in the Shapes deck on the 
Sidebar (Figure 281).

2) Position the cursor at one corner of an object, then click and drag the cursor to draw the 
dimension line. To restrict drawing the dimension line in the horizontal or vertical 
direction, hold down the Shift key while dragging the cursor.

3) Release the cursor when the end of the dimension line is reached and the dimension line 
is drawn. The dimension is automatically added (as shown by the example in 
Figure 282). Also, the dimension line is placed automatically on the Dimension Lines 
layer.

4) To edit the text of the dimension, double-click on an unselected dimension line to enter 
text edit mode and make any necessary changes. Click outside the dimension line to 
save the changes.

Figure 280: Lines and Arrows subtoolbar

Figure 281: Lines and Arrows panel in Shapes deck on Sidebar
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5) To configure the dimension line, see “Configuring dimensioning” on page 303.

Note

After editing the dimension text, entering text and then deleting text, save and close 
the drawing. Reopen the drawing to enable dimension automatic measurements.

Figure 282: Example of dimension lines

Figure 283: Graphic Styles dialog — Dimensioning page
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Configuring dimensioning

Drawing object styles

1) Open the Graphics Styles dialog (Figure 283) using one of the following methods:

– Go to Format > Styles > Edit Style on the Menu bar.

– Use the keyboard shortcut F11 (macOS ⌘+T) to open the Styles deck on the Sidebar, 
then right-click on a style and select Modify from the context menu.

– Click on Styles on the Sidebar to open the Styles deck, then right-click on a style and 
select Modify from the context menu.

2) Click on Dimensioning to open the Dimensioning page in the dialog.

3) Make the changes required to dimensioning using the various options in the Line and 
Legend sections on the Dimensioning page.

4) Click OK to save the changes and close the Graphic Styles dialog.

5) To reset the dimensioning options to the default properties of the template, open the 
Graphics Style dialog, then click on Standard.

Dimension line dialog

1) Draw a dimension line. See “Dimensioning objects” on page 301 for more information.

2) Right-click on the dimension line and select Dimensions from the context menu to open 
the Dimension line dialog (Figure 284).

Figure 284: Dimension Line dialog
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3) Make the required changes for dimensioning using the various options in the Dimension 
line dialog.

4) Click OK to save the changes and close the Dimension line dialog.

Dimensioning options

The dimensioning options in the Dimensions page in the Graphics Style dialog and the 
Dimension Line dialog are as follows. The preview in the dialogs changes as the following 
options are changed showing how the dimension line appears in a drawing.

Line

Sets distances between the dimension line, guides and the object.

Line distance

Specifies distance between the dimension line and the object or baseline. A minimum 
of -10mm to a maximum of 10mm can be entered in the text box. The lower the value, 
the closer the dimension line is to the object or baseline.

Guide overhang

Specifies distance the guide extends above or below the dimension line. A minimum of 
-10mm to a maximum of 10mm can be entered in the text box. Positive values cause 
the guide overhang to extend above the dimension line. Negative values cause the 
guide overhang to be below the baseline.

Guide distance

Specifies length of the right and left guides below the dimension line toward the object. 
A minimum of -10mm to a maximum of 10mm can be entered in the text box. Positive 
values extend the guides above the baseline and further away from the object. 
Negative values extend the guides below the baseline and closer to the object.

Left guide

Specifies length of the left guide starting at the dimension line. A minimum of -10mm to 
a maximum of 10mm can be entered in the text box. Positive values extend the guide 
below the dimension line toward the object. Negative values move the guide away 
from the object.

Right guide

Specifies length of the right guide starting at the dimension line. A minimum of -10mm 
to a maximum of 10mm can be entered in the text box. Positive values extend the 
guide below the dimension line toward the object. Negative values move the guide 
away from the object.

Measure below object

Reverses positions and lengths of the dimension line and guides set in Line options.

Decimal places

Specifies number of decimal places used for the display of line properties.

Legend

Sets the properties of the dimension text.

Text position

Determines position of the dimension text to the dimension line and guides. The 
AutoVertical and AutoHorizontal must be deselected before a text position can be 
assigned.

AutoVertical

Determines optimal vertical position for the dimension text.

304 |Draw Guide 24.8



AutoHorizontal

Determines optimal horizontal position for the dimension text.

Parallel to line

Displays, when selected, text parallel to the dimension line or, when deselected, at 90 
degrees to the dimension line.

Show measurement units

Shows or hides dimension measurement units. A measurement unit is selected from 
the drop-down list.

Note

The dimensioning options are linked to the current drawing and any dimensioning 
changes made apply only to the current drawing. New drawings start with the Draw 
standard properties. If the dimensioning options are to be used for future drawings, 
save the drawing as a template.

Tip

When dimensioning objects, it is recommended to use the zoom function, guide lines 
and snap functions so dimension lines can be accurately placed on an object. See 
Chapter 3, Working with Objects and Object Points for more information.

Drawing to scale

In Draw, the Workspace drawing area is normally Letter or A4 page size, depending on the 
computer setup and the default printer connected to the computer. However, depending on the 
actual size of the drawn objects, it is often convenient to reduce or enlarge the drawing by 
scaling (for example 1:10 or 2:1).

Note

When drawing to scale, dimension configuration values in the Graphics Style and 
Dimension Line dialogs are also to scale. For example, a value of 10mm in the dialog 
results in a dimension value of 300mm if the scale has been set to 1:30.

Figure 285: Options LibreOffice Draw dialog — General page
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Figure 286: Example of drawing to scale

To specify the drawing scale go to Tools > Options > LibreOffice Draw > General (macOS 
LibreOffice > Preferences > LibreOffice Draw > General) to open the Options dialog 
(Figure 285), then select a value from the Scale drop-down list. The default setting for this option 
is 1:1. When a change is made to the drawing scale, it is reflected in the horizontal and vertical 
rulers on the Workspace.

Any change in the drawing scale has no effect on the basic drawing operations. Draw 
automatically calculates the necessary values (for example, dimension lines). The spacing of the 
grid points is independent of drawing scale as the grid is only a visual drawing aid and not a 
drawing element.

An increase in scale (for example 1:4) allows large objects to be drawn that would not fit into the 
paper size for a drawing. A decrease in drawing scale (for example 4:1) allows small objects to 
be drawn accurately at an increased size and make them easier to understand. Examples of 
drawing to scale are shown in Figure 286 where all three rectangles are the same size in the 
drawing.

1) Left rectangle — drawn at the default 1:1 scale and dimensioned.

2) Center rectangle — drawing scale changed to 1:4. Dimensions are automatically 
increased by Draw to display the decrease in scale.

3) Right rectangle — drawing scale changed to 4:1. Dimensions are automatically 
decreased by Draw to display the increase in scale.

Multiple views of a drawing

Several views of the same drawing can be opened and used in Draw. These views are displayed 
in separate windows and are useful in displaying different views of the drawing, for example, 
master page and normal page open at the same time. Make sure the correct view is active when 
saving a drawing.

To open a new window for the same drawing file, go to Window > New Window on the Menu 
bar. Any change to a drawing in one window is immediately displayed in all open windows.

The filename for each open window is automatically numbered as shown by the example in 
Figure 287 and the active window has a marker by its filename in the list. If other LibreOffice 
documents are open at the same time, then these documents are also be included in the list. 
Switch between windows by clicking on a name in the list, or by clicking on the window itself if 
visible.
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Figure 287: Example of multiple windows in Draw

Use one of the following methods to close a window:

• Go to Window > Close Window on the Menu bar.

• Use the keyboard shortcut Ctrl+W (macOS ⌘+W).

• Click on File > Close in the Menu bar of the window.

Gallery

Draw includes several images in the Gallery. These images are grouped into themes listed in 
alphabetical order (for example Arrows, BPMN, Bullets, Diagrams, and so on). Click on a 
theme to display its images as icons or in a detailed view.

• To display an icon view of the images in the Gallery deck (Figure 288), click on Icon 
View at the bottom left of the Sidebar.

• To display an detailed view of the images in the Gallery deck (Figure 290), click on 
Detailed View at the bottom left of the Sidebar.

Using the Gallery
1) Click on Gallery on the Sidebar, or go to Insert > Media > Gallery on the Menu bar.

2) Select a theme from the available options.

Figure 288: Gallery deck in Sidebar — Icon View
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Figure 289: Gallery deck in Sidebar — Detailed View

3) Use one of the following methods to place an image into a drawing:

– Click on an image in the Gallery deck and drag the image into a drawing.

– Right-click on an image and select Insert from the context menu. The image is placed 
at the center of a drawing.

– Right-click on an image and select Copy from the context menu then paste the image 
into the drawing. The image is placed at the center of the drawing.

4) Edit the gallery image to the drawing requirements. For more information on editing 
images and pictures, see Chapter 6, Editing Pictures.

Creating themes and adding images
1) Open the Gallery deck on the Sidebar.

2) Click on New at the bottom right of the Gallery deck to open the Properties of New 
Theme dialog (Figure 290).

3) On the General page, enter a name for the theme in the text box.

4) Click on Files to open the Files page (Figure 291).

5) Click on Find Files to open a Select Path dialog.

6) Navigate to the folder that contains the images required and click OK to select the folder 
and the Select Path dialog closes. A list of files contained in the folder now appear in the 
Files page as shown by the example in Figure 291.

7) If necessary, select the file format required for the images from the options available in 
the drop-down list. By default, all formats for image files are selected.

8) If required, click on Preview to display each selected image file.

9) Select the files required for the new theme. If necessary, press the Ctrl key (macOS )⌘  
to select multiple files.
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Figure 290: Properties of New Theme dialog — General page

Figure 291: Properties of New Theme dialog — Files page

10) Click on Add. The selected files disappear from the file list and the images appear in the 
Gallery.

11) If all the files in the list are to be added, click Add All. All files disappear from the list and 
the images appear in the Gallery.

12) Click OK when finished adding files and close the Properties of New Theme dialog. The 
name of the new theme appears in the Gallery deck.

Deleting gallery themes and images
1) Right-click on a theme, or image in the Gallery and select Delete from the context menu.

2) Click on Yes in the confirmation dialog and the theme, or image is deleted from the 
Gallery.
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Notes

If an object is added to a theme, the object loses its connection to Draw graphic 
styles and all properties are set as direct formatting.

Only themes and images that have been added to Draw can be deleted or renamed. 
Themes and images included with the LibreOffice installation cannot be deleted or 
renamed.

An image is a linked file and only the link is deleted from the Gallery. The original 
image file is not deleted.

Updating the Gallery
All images in the Gallery are linked files. Occasionally, it is beneficial to update a theme that has 
been added to Draw to make sure that all files are still accessible. Right-click on a theme that 
has at least one file added to the theme and select Update from the context menu.

Renaming themes
To rename a theme that has been added to LibreOffice Draw, right-click on the theme name and 
select Rename from the context menu.

Colors

Draw (like all LibreOffice modules) uses colors grouped into color palettes. Colors can be 
created to suit drawing requirements. All custom colors created are placed in the custom color 
palette. The following explains the color models that are used to create a custom color.

Red, Green, Blue (RGB)

The RGB color model is based on the additive color model of light waves and is 
designed for electronic displays and computers. This means, the more color added, the 
closer a color moves towards white. RGB is created using scales from 0 to 255. When 
black is used, the values are R=0, G=0, and B=0. When white is used, the values are 
R=255, G=255, and B=255. LibreOffice uses the RGB color model internally for printing 
in all LibreOffice modules.

Cyan, Magenta, Yellow, Key (Black) (CMYK)

The CMYK color model is a subtractive color model where colors are subtracted to 
change, or create a color. It is mainly used in printing, which is why printer ink cartridges 
are labeled CMYK. CMYK works on a scale of 0 to 100. When black is used, the values 
are C=100, M=100, Y=100, and K=100. When white is used, the values are C=0, M=0, 
Y=0, and K=0.

Hue, Saturation, Brightness (HSB)

The HSB color model is an alternative representation of the RGB color model. HSB was 
designed to be more closely aligned with the way human vision perceives color-making 
attributes. Use HSB values to fine tune any custom colors that are created.

Tip

More information on color models and color values can be found at 
https://en.wikipedia.org/wiki/Color_model.
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Figure 292: Color Bar (Color Palette)

Changing colors in objects or lines
When changing colors in objects, color palettes are used to select colors. These color palettes 
are installed with LibreOffice and are used in all the LibreOffice modules. Using color palettes is 
similar across all types of objects, but accessing the color palettes does vary according to the 
type of object selected.

Note

The colors available in the Color Bar are from the Standard color palette that is part 
of the LibreOffice installation.

Color Bar

Although LibreOffice includes tools to precisely specify a color, it also includes a Color Bar 
(Figure 292) to quickly changing color in object area fills, borders, or lines. The Color Bar is also 
called the Color Palette.

1) Select an object in the drawing.

2) Go to View > Color Bar on the Menu bar to open the Color Bar. When the Color Bar 
opens, it is labeled Color Palette.

3) Left click on a color to change the area fill color, or right-click on a color to change the 
border or line color of a selected object.

4) Left click on the X box in the bottom left corner of the Color Bar to remove the color from 
an object fill, or right-click on the X box in the bottom left corner of the Color Bar to 
remove the color from an object border,

5) To close the Color Bar, go to View > Color Bar on the Menu bar and deselect Color 
Bar.

Area dialog

1) Select an object in the drawing.

2) Open the Area dialog (Figure 293) using one of the following methods:

– Go to Format > Area on the Menu bar.

– Right-click on the object and select Area from the context menu.

3) Click on Area, then click on Color to open the Color page.

4) In Colors, select a color palette from the Palette drop-down list.
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Figure 293: Area dialog — Color page

5) Click on a color from the ones displayed in the color palette, or select a color that has 
been previously used from Recent Colors.

6) Click OK to save the changes and close the Area dialog. The selected fill color appears 
in the selected object.

Area panel on the Sidebar

1) Select an object in the drawing.

2) Open the Area panel in the Properties deck on the Sidebar (Figure 294).

3) Select Color from the Fill drop-down list.

4) Click on the triangle ▼ on the right of Fill Color to open the palette last used.

5) If necessary, select a color palette from the available palettes in the drop-down list.

6) Click on a color from the colors displayed in the color palette, or select a color that has 
been previously used from those displayed in Recent. The color palette closes and the 
selected fill color is applied to the object.

Fill Color on the Line and Filling or Drawing toolbars

1) Select an object in the drawing.

2) Click on the triangle ▼ to the right of Fill Color on the Line and Filling toolbar, or the 
Draw toolbar to open the last color palette used.
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Figure 294: Area panel in Properties deck on Sidebar

3) Click on a color from the colors displayed in the color palette, or select a color that has 
been previously used from those displayed in Recent. The color palette closes and the 
selected fill color is applied to the selected object

Line dialog

1) Select a line, or object in the drawing.

2) Open the Line dialog (Figure 295) using one of the following methods:

– Go to Format > Line on the Menu bar.

– Right-click on the line or object and select Line from the context menu.

3) Click on Line to open the Line page.

4) Click on the triangle ▼ to the right of Color in Line Properties to open the last color 
palette used.

5) Select a color palette to use from the available palettes in the drop-down list.

6) Click on a color from the colors displayed in the color palette, or select a color that has 
been previously used from those displayed in Recent. The color palette closes and the 
selected line color is applied to the line or object border.

7) Click OK to save the color change and close the Line dialog.
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Figure 295: Line dialog — Line page

Figure 296: Line panel in Properties deck on Sidebar

Line panel on the Sidebar

1) Select a line, or object in the drawing.

2) Open the Line panel in the Properties deck on the Sidebar (Figure 296).
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3) In Line, click on the triangle ▼ to the right of Color to open the last color palette used.

4) Select a color palette to use from the available palettes in the drop-down list.

5) Click on a color from the colors displayed in the color palette, or select a color that has 
been previously used from those displayed in Recent. The color palette closes and the 
selected line color is applied to the line or object border.

Line Color on the Line and Filling or Drawing toolbars

1) Select a line, or object in the drawing.

2) Click on the triangle ▼ to the right of Line Color on the Line and Filling toolbar, or the 
Draw toolbar to open the last color palette used.

3) Select a color palette to use from the available palettes in the drop-down list.

4) Click on a color from the colors displayed in the color palette, or select a color that has 
been previously used from those displayed in Recent. The color palette closes and the 
selected line color is applied to the line or object border.

Changing text color
Changing text color is very similar to changing the color of an area fill, object border, or line. The 
Text Formatting toolbar automatically opens and replaces the Line and Filling toolbar when text 
is selected in a drawing. If the Text Formatting toolbar does not open, go to View > Toolbars on 
the Menu bar and select Text Formatting.

Character dialog

1) Select a text box, or switch on text mode for a Draw object.

2) Highlight the text characters where the text color is going to be changed.

3) Open the Character dialog (Figure 297) using one of the following methods:

– Go to Format > Character on the Menu bar.

– Right-click on the highlighted text and select Character from the context menu.

4) Click on Font Effects to open the Font Effects page.

5) Click on the triangle ▼ to the right of Font Color to open the last color palette used.

6) Select a color palette to use from the available palettes in the drop-down list.

7) Click on a color from the colors displayed in the color palette, or select a color that has 
been previously used from those displayed in Recent. The color palette closes and the 
selected color is applied to the selected text.

8) Click OK to save the color change and close the Character dialog.

Character panel on the Sidebar

1) Select a text box, or switch on text mode for a Draw object.

2) Highlight the text characters where the text color is going to be changed.

3) Open the Character panel in the Properties deck on the Sidebar (Figure 297).

4) Click on the triangle ▼ to the right of Font Color to open the color palette last used.

5) Select a color palette to use from the available palettes in the drop-down list.

6) Click on a color from the colors displayed in the color palette, or select a color that has 
been previously used from those displayed in Recent. The color palette closes and the 
selected color is applied to the selected text.
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Figure 297: Character dialog — Font Effects page

Figure 297: Character panel in Properties deck on Sidebar
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Figure 298: Pick a Color dialog

Creating colors

Notes

When using the Line or Character dialog to open the Pick a Color dialog, the custom 
color created cannot be saved into the Custom Palette, or renamed with a more 
meaningful name. The custom color created is named using the hex value that is 
displayed in the Pick a Color dialog. Only the Area dialog has the ability to rename 
custom colors and save custom colors into the Custom Palette.

LibreOffice uses the RGB color model for printing in color. The RGB values of a 
selected color are displayed the preview boxes.

Using Pick a Color dialog

1) Select an object, or text and open the Pick a Color dialog (Figure 298) using one of the 
following methods:

– Open the Area dialog, then click on Color to open the Color page and click on Pick.

– Open the Area panel in Properties deck on the Sidebar, click on the triangle ▼to the 
right of Fill Color to open the color palette and click on Custom Color at the bottom of 
the color palette.

– Open the Line dialog, then open a color palette in Color and click on Custom Color 
at the bottom of the color palette.
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– Open the Line panel in Properties deck on the Sidebar, click on the triangle ▼to the 
right of Line Color to open the color palette and click on Custom Color at the bottom 
of the color palette.

– Open the Character dialog, then open a color palette in Font color and click on 
Custom Color at the bottom of the color palette.

– Open the Character panel in Properties deck on the Sidebar, click on the triangle ▼to 
the right of Font Color to open the color palette and click on Custom Color at the 
bottom of the color palette.

2) Select a color range on the vertical color bar in the Pick a Color dialog that approximately 
matches the custom color being created.

3) Click and drag the small target circle in the color box until the color matches the custom 
color required. The values for RGB, HSB and CMYK change as the small target circle is 
dragged around the color box helping to create the exact color, if the color values are 
known.

4) Alternatively, if the color values, or hex number, are known, enter these values in the 
appropriate text box. The values in all the text boxes change to match the new values. 
For example, after entering HSB values, the RGB, CMYK and Hex values also change to 
match.

5) Click OK to save the changes and close the Pick a Color dialog.

Using Area dialog

1) Open the Area dialog and click on Color to open the Color page (Figure 293 on 
page 312).

2) In New, enter the RGB values or, if known, the Hex value into the text boxes. The color 
changes in the preview box to match the values entered.

3) Alternatively, in New, use the minus and plus signs for the RGB values to decrease or 
increase the values. The color changes in the preview box to match the values entered.

4) Click OK to change the color and close the Area dialog.

Adding custom colors
1) Make sure the Area dialog is open at the Color page (Figure 293 on page 312).

2) Select the custom color that is displayed in Recent Colors.

3) In Custom Palette, click on Add to open a Name dialog.

4) Enter a new name for the color in the text box.

5) Click OK to save the changes and close the Name dialog. The custom color appears in 
the Custom Palette.

6) Click OK to close the Area dialog.

Renaming custom colors
Only a custom color can be renamed using the Area dialog as follows:

1) Make sure the Area dialog is open at the Color page (Figure 293 on page 312).

2) Select the custom color that is displayed in the Custom Palette.

3) Click on Add to open a Name dialog.

4) Enter a new name for the custom color in the text box,
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5) Click OK to save the changes and close the Name dialog. A new custom color appears in 
the Custom Palette.

6) Click OK to close the Area dialog.

Notes

Renaming a custom color does not actually rename the custom color, but adds a 
new custom color to the Custom Palette.

Before renaming, deleting, a custom color, make sure the custom color is NOT being 
used in another LibreOffice document.

It is important to use a memorable names for custom colors so that the custom color 
is easily recognized in the Custom Palette. By default, a custom color is given a hex 
number, which makes it difficult identifying colors when there is more than one 
custom color.

Deleting custom colors
Only a custom color can be deleted using the Area dialog as follows:

1) Make sure the Area dialog is open at the Color page (Figure 293 on page 312).

2) Select the custom color that is displayed in the Custom Palette.

3) Click on Delete. There is no confirmation given when deleting custom colors.

4) Click OK to close the Area dialog.

Bézier curves

Bézier2 curves can be used in Draw. A curve is defined by means of a start point, an end point, 
and, where necessary, control points. For points on the curve the terms Nodes and Anchors are 
often used. For more information and an explanation of the mathematical background of Bézier 
curves, see https://en.wikipedia.org/wiki/Bézier_curve.

Figure 299: Example Bézier curve

2 Bézier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer, 
who developed the technique in the 1960s. The technology was intended to make modeling the 
surface of vehicles easier.
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Bézier curves are very useful for experimenting with the shape and form of curves. In point 
mode, the curve alignment can be changed by dragging the points with the cursor. The example 
shown in Figure 299 displays an example of a Bezier curve with the start point selected and a 
control point attached to the start point by a dashed line. Moving control points changes the 
curvature and shape of a Bezier curve.

Drawing Bézier curves
1) Click on Curve in the Curves and Polygons panel in the Shapes deck on the Sidebar, 

or Curves and Polygons on the Drawing toolbar.

2) Click at the start point for the curve and drag the cursor to the approximate position of 
the end point for the curve.

3) Release the cursor and drag the end point of the curve to its end position.

4) Double-click when the end position of the curve is reached and a curve is drawn. The arc 
of the curve is determined by the distance dragged to create the end point.

5) Switch to points editing mode using one of the following methods:

– Go to Edit > Toggle Edit Point Mode on the Menu bar.

– If added to the toolbar, click on Toggle Edit Point Mode on the Drawing toolbar.

– Use the keyboard shortcut F8.

Note

The Edit Points toolbar does not open until a point has been selected on a curve.

6) Open the Edit Points toolbar (Figure 300) using one of the following methods.

– Go to View > Toolbars on the Menu bar and select Edit Points.

– Use the keyboard shortcut F8.

– If added to the toolbar, click on Points on the Drawing toolbar.

7) Click once on the curve to display the start and end points. The start point of the curve is 
larger than the end point.

8) Click on a start or end point to display the control points. Control points appear at the end 
of a dashed line connected to the selected point, as shown in the following examples.

9) Click on the control point and drag it to a new position to change the shape of the curve.

10) When the shape of the curve is satisfactory, release the cursor to fix the curve.

11) Click anywhere on the workspace to deselect the curve and stop editing points.

Figure 300: Edit Points toolbar

Edit Points tools
After the initial opening of the Edit Points toolbar, when an object is selected that has been 
converted to a curve or polygon, the toolbar is displayed. The tools available on the Edit Points 
toolbar allow the editing of a Bézier curve and changing of the curve shape. A point on a Bézier 
curve has to be selected for all the tools on the Edit Points toolbar to become available.
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Move Points

Click and drag on a point to move it to another location.

– The curve on both sides of the point follows the movement and changes shape as the 
selected point changes position.

– Click and drag on the curve between points to move the entire curve without distorting 
the form.

Insert Points

Activates the insert mode when selected and inserts smooth points onto a curve. Insert 
mode remains active after inserting points. Select Move Points to deactivate insert 
mode.

– The inserted point can be moved while insert mode is activated.

– If a corner or symmetrical point is required, insert a smooth point first and convert the 
point to a corner or symmetrical point.

Delete Points

Deletes selected points. If several points are to be deleted, hold down the Shift key 
whilst selecting points and before clicking on Delete Points.

Figure 301: Example converting curved segment to line

Figure 302: Example corner point

Convert To Curve

Converts a curve into a straight line or a straight line into a curve (Figure 301).

– Select a single point and the curved segment after the point converts to a straight line, 
or coverts a straight line segment to a curve after the point.

– When converting a segment from a curve to a straight line, each point at each end of 
the segment becomes a control point similar to the start or end point.
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– When converting a segment from a straight line to a curve, each control point at each 
end of the segment becomes a smooth point.

Close Bézier

Closes a freeform line or curve by connecting the start point with the end point creating 
an object with area fill.

Split Curve

Splits a curve into two or more curves. Select a point or points and click on Split Curve 
to create separate segments of a curve. Deselect the curve, then select a segment to 
move or edit it.

Corner Point

Converts a selected point into a corner point (Figure 302). Corner points have two 
movable control points independent from each other allowing a corner to be created in a 
curve.

Smooth Transition

Converts a corner or symmetrical point into a smooth point (Figure 303). Both control 
points are parallel aligned and can only move simultaneously. The control points may 
differ in length, allowing the curvature degree to be varied.

Symmetric Transition

Converts a corner point or a smooth point into a symmetrical point (Figure 304). Both 
control points are parallel aligned having the same length. These control points can only 
be moved simultaneously and the degree of curvature is the same in both directions.

Eliminate Points

Allows selection of several points before using the Delete Points tool. This is useful 
when deleting a straight line segment to create a complete curve.

Figure 303: Example smooth transition point

Figure 304: Example symmetric transition point
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Figure 305: Example comment in Draw

Adding comments

Comments in Draw are similar to comments in the Writer, Calc and Impress modules. For more 
information about adding, navigating, and replying to comments, see the Getting Started Guide.

Comments in Draw cannot be printed. To reply to a comment in Draw, a new comment has to be 
added to the drawing.

1) Go to Insert > Comment on the Menu bar and a comment box (Figure 305) appears in 
the upper left-hand corner of a drawing. Draw automatically adds the user name and 
date at the bottom of the comment and places a comment marker on the drawing page.

2) Type or paste a comment into the comment text box.

3) To apply basic formatting to the text, right-click on the text and select the formatting 
option from the context menu.

4) To delete a comment, use one of the following methods:

– Right-click in the comment box and select Delete from the context menu.

– Right-click on the comment marker and select Delete from the context menu.

– Click on the triangle ▼ in the bottom right of the comment box and select Delete from 
the context menu.

5) To move a comment, click on the comment marker and drag it to a new position.

6) To hide comments, use one of the following methods:

– Go to View on the Menu bar and deselect Comments to hide the comment and the 
comment marker.

– Click on the drawing outside of the comment to hide the comment. The comment 
marker remains visible.
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7) To show comments, go to View > Comments on the Menu bar and click on the comment 
marker.

Note

For the user name and initials to appear in a comment, enter the user data in Tools 
> Options > LibreOffice > User Data dialog (macOS LibreOffice > Preferences > 
LibreOffice > User Data). If more than one person edits the document, each author 
is automatically allocated a different background color.

Coordinate system

X and Y axes
The x-axis is the horizontal position of an object and the y-axis is the vertical position of an 
object. The rulers do not show a minus sign if there are negative coordinates. However, the 
minus sign for negative coordinates is shown in the position field in the Status Bar and the 
Position and Size dialog.

Workspace
The Draw Workspace is larger than the drawing page. The area outside the drawing page is 
one page width right and left and a half page above and below the drawing page. The size of the 
drawing page is indicated by highlighted portions in the horizontal and vertical rulers.

Objects in Draw can be drawn partly or wholly outside the drawing page and these objects are 
saved with the drawing. However, when the drawing is printed or exported, any object or portion 
of an object not on the drawing page is not included. This allows the Workspace area around 
the drawing page to be used for drafts when creating objects.

Object position
The coordinates of objects and snap guides are shown relative to the origin. The default origin 
for coordinates (0.00/0.00 position) is the top-left corner of the drawing page without margins or 
the top left corner of the drawing page where the margins intersect. To change the default origin, 
click and drag the intersection of the rulers in the top left corner of the Workspace to the desired 
position. Guide lines appear as the intersection is dragged from its default origin to its new 
position. This origin setting is only for the current view and is not saved in the document.

The area inside the default origin is the area used for the grid when the options Snap to Grid 
and Display Grid are selected.

To reset the default origin back to its original setting at the top-left corner of the page, 
double-click in the top-left corner on the Workspace where the horizontal and vertical rulers 
meet.

Accuracy
Draw internally uses integer values in 1/100 mm. This means that it may not be possible to get 
an exact position for 1/8 inch. Also, many dialog fields are restricted to two decimals.

To work with the maximum possible accuracy, go to Tools > Options > LibreOffice Draw > 
General (macOS LibreOffice > Preferences > LibreOffice Draw > General) and set the option 
Unit of measurement to Millimeter. The rulers then show metric units after this option has been 
selected, To use another measurement unit for the rulers, right-click on a ruler and select the 
measurement unit from the context menu. The horizontal and vertical rulers can have different 
measurement units.
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Introduction

By default, commands and tools used in Draw are grouped in a user interface consisting of 
cascading menus and toolbars. The functions and use of these cascading menus and toolbars 
are described in previous chapters of this user guide.

This chapter describes the user interface variants that are available for Draw. A user has the 
option to select a user interface that suits their requirements and methods of creating drawings 
in Draw.

Note

When changing the user interface, the variant can be applied only to Draw, or 
applied to all the modules in LibreOffice.

Selecting user interface variants

1) Go to View > User Interface on the Menu bar to open the Select Your Preferred User 
Interface dialog (Figure 306).

2) In UI variants, select the required variant. An example of the selected user interface is 
shown in the Preview box with a short description.

3) Click on Apply to Draw to apply the selected user interface to LibreOffice Draw only.

4) Alternatively, click on Apply to All to apply the selected user interface to all LibreOffice 
modules. The LibreOffice window changes to match the selected user interface.

5) Click on Close to close the dialog.

Figure 306: Select Your Preferred User Interface dialog

Note

If the option Enable experimental features has been selected in the Tools > 
Options > Advanced (macOS LibreOffice > Preferences > LibreOffice > 
Advanced), several experimental variants appear in UI variants. Being 
experimental, these user interfaces are not described in this chapter.
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Figure 307: Standard Toolbar user interface

Standard Toolbar

The Standard Toolbar user interface is the default view when LibreOffice is installed on a 
computer and Draw is opened for the first time. For more information on the Draw Workspace, 
see Chapter 1, Introducing Draw. Figure 307 shows an example of the default Standard Toolbar 
user interface in Draw and consists of the following:

• Menu bar at the top of the Workspace.

• Standard, and Line and Filling toolbars positioned below the Menu bar.

• Drawing toolbar positioned vertically on the left side of the Workspace.

• Sidebar on the right of the Workspace.

Tabbed

Note

When using the Tabbed user interface, Draw toolbars are no longer visible. If 
required, it is possible to open toolbars by going to View > Toolbars on the Menu 
bar, or select Toolbars on the quick menu.

The Tabbed user interface provides a user interface that is similar to other office software 
applications, for example Microsoft Office. The user interface tabs consist of tools grouped by 
context. This context changes automatically depending on the LibreOffice module and the object 
selected. Figure 308 shows an example of the default Workspace view using the Tabbed user 
interface in Draw.
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Figure 308: Tabbed user interface

Figure 309: Tabbed user interface — Quick Menu

The Tabbed user interface includes a menu bar, tab bar, and tool icons grouped in context for 
use in Draw. If the tool icons on a tab page exceed the width of the Draw window, a double 
chevron >> appears at the right end of the tab row. Click on this double chevron >> to display 
the remaining options for the Tabbed user interface.

At the left end of the Tab bar, icons are available giving access to some commonly used tools — 
Menubar; Open; Save; Undo; Redo. Clicking on Menubar at the left end of the tab bar either 
hides or opens the main menu bar at the top of the Workspace.
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Figure 310: Customize dialog — Notebookbar page

On the right side at the top of the Workspace, click on the 3 horizontal lines (≡) to access 
commonly used commands and links, as shown by the example in Figure 309. Some commands 
have context menus with more commands available. This is indicated by a triangle ►, or a 
single chevron >, on the right of a command.

The Tabbed user interface is customized using the Notebookbar page of the Customize dialog 
(Figure 310) to show or hide the individual tools on the various tabs. Go to Tools > Customize 
on the Menu bar to open the Customize dialog. For more information on customization, see the 
Getting Started Guide and the Writer Guide.

Fixed tabs

File tab

The File tab (Figure 311) provides commands to create new documents and manage existing 
documents. On the right of the File tab there are two menus as follows:

• File — contains the same commands as the tools available on the tab.

• Help — provides links to a variety of resources.
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Figure 311: Tabbed user interface — File tab

Figure 312: Tabbed user interface — Home tab

Figure 313: Tabbed user interface — Insert tab

Home tab

The Home tab (Figure 312) provides tools and commands for cutting, copying, pasting, 
inserting, and formatting all types of objects such as images, tables, charts, text, and so on. 
Also, drawing styles can be applied and updated to match drawing requirements. At the right end 
of the Home tab bar, click on Home to open a drop-down menu containing additional tools.

Insert tab

The Insert tab (Figure 313) provides tools and commands for inserting many types of objects 
such as images, tables, charts, and so on. At the right end of the Insert tab bar, click on Insert 
to open a drop-down menu with some of the same tools.
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Figure 314: Tabbed user interface — Layout tab

Figure 315: Tabbed user interface — Review tab

Layout tab

The Layout tab (Figure 314) provides tools and commands for creating a drawing layout. At the 
right end of the Layout tab bar, click on Layout to open a drop-down menu with some of the 
same tools.

Review tab

The Review tab (Figure 315) provides tools and commands for spell checking text, inserting and 
deleting review comments, and redaction. At the right end of the Review tab bar, click on 
Review to open additional text editing commands. Some of these commands appear only if 
Asian or Complex Text Layout are selected in Tools > Options > Language Settings > 
Languages (macOS LibreOffice > Preferences > Language Settings > Languages).

View tab

The View tab (Figure 316) provides tools and commands for displaying a drawing on screen. At 
the right end of the View tab bar, click View to open a drop-down menu providing additional tools 
for displaying a drawing screen.
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Figure 316: Tabbed user interface — View tab

Figure 317: Tabbed user interface — Tools tab

Extension tab

The Extension tab is a fixed tab containing only the Extension Manager. When selected, the 
Extension Manager dialog opens allowing for installation and deletion of extensions that are 
compatible with LibreOffice.

Tools tab

The Tools tab (Figure 317) provides tools for macros; color replacer; media player; and so on. At 
the right end of the Tools tab bar, click on Tools to open a drop-down menu with some of the 
same tools, plus extra tools for organizing macros and dialogs, image map, data sources, filter 
settings, extension manager, and options.

Additional tabs
The following additional tabs only open when a specific type of object in a drawing is selected. 
These additional tabs are displayed between the View and Extension tabs.

Draw tab

The Draw tab (Figure 318) is only available when a draw object is selected. It provides tools and 
commands for editing, transforming, grouping, aligning, and distributing draw objects. At the right 
end of the Draw tab bar, click on Draw to open a drop-down menu with a similar set of tools and 
commands for editing, transforming and converting draw objects.
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Figure 318: Tabbed user interface — Draw tab

Figure 319: Tabbed user interface — Image tab

Image tab

The Image tab (Figure 319) is only available when an image is selected such as a photograph, 
Fontwork, OLE object, or QR code. It provides tools for working with images, such as cropping, 
borders, area styles, colors, and so on. At the right end of the Image tab bar, click on Image to 
open a drop-down menu with some of the same tools.

Object tab

The Object tab (Figure 320) only becomes available when a compatible object is selected in a 
drawing, for example a chart. It provides tools to position, resize, select colors, and so on for the 
selected compatible object. At the right end of the Object tab bar, click Object to open a menu 
with extra tools and commands matching the type of object selected.

Table tab

The Table tab (Figure 321) only becomes available when a compatible table is selected in a 
drawing. It provides tools to position, resize, select colors, and so on for the selected table. At 
the right end of the Table tab bar, click on Table to open a drop-down menu with extra tools for 
editing a table.
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Figure 320: Tabbed user interface — Object tab

Figure 321: Tabbed user interface — Table tab

Figure 322: Tabbed user interface — Media tab

Media tab

The Media tab (Figure 322) only becomes available when a media object is selected in a 
drawing. It provides tools for positioning and running an audio or video file. At the right end of the 
Media tab bar, click on Media to open a drop-down menu with extra tools for editing a media 
object.
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Single Toolbar & Sidebar

When selected, the Single Toolbar and Sidebar user interfaces (Figure 323 and 324) only show 
the Menu bar with no toolbars. However, toolbars can be added to the user interface by going to 
View > Toolbars on the Menu bar and selecting the required toolbar from the options available. 
For more information on toolbars, see Appendix B, Toolbars and the Getting Started Guide.

Figure 323: Single Toolbar user interface

Figure 324: Sidebar user interface
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Tabbed Compact

The Tabbed Compact user interface uses the same tabs as the Tabbed user interface, but the 
tools on each tab are arranged as a single row of tools. Some of these tools have drop-down 
menus with extra options. Figure 325 shows an example of the File tab in the Tabbed Compact 
user interface. When displayed, clicking on the double chevron >> on the right of the tab bar 
displays more tools and commands for editing an object.

The tab menu on the right of the Tabbed Compact user interface provides the same options as 
the tab menus in the Tabbed user interface, see “Tabbed” on page 327 for more information.

Figure 325: Tabbed Compact user interface

Figure 326: Groupedbar Compact user interface

336 |Draw Guide 24.8



Groupedbar Compact

The Groupedbar Compact user interface provides access to tools and commands in groups 
using icons for frequently used tools and drop-down menus for other tools and commands. 
Figure 326 shows an example of a Compact Groupedbar user interface with a text object 
selected in a LibreOffice Draw document and is organized as sets of tools and menus. The tools 
and menus that are available change to suit the type of object selected. Clicking on the double 
chevron >> displays more tools for editing an object.

Contextual Single

The Contextual Single user interface displays a single toolbar for the type of selected object. 
Figure 327 shows an example of Contextual Single user interface when a drawing object is 
selected. Clicking on the double chevron >> displays more options for editing an object.

Figure 327: Contextual Single user interface
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Introduction

LibreOffice can be used without requiring a pointing device, for example mouse, trackpad, or 
trackball, or keyboard shortcuts. For example, tasks as varied and complex as docking and 
undocking toolbars and windows, or changing the size or position of objects can be carried out 
with keyboard shortcuts. Although LibreOffice has an extensive set of keyboard shortcuts, each 
LibreOffice module has keyboard shortcuts that are specific to that module.

For help with LibreOffice keyboard shortcuts, or using LibreOffice with a keyboard only, search 
the LibreOffice Help using the “shortcut” or “accessibility” as keywords.

Keyboard shortcuts can also be defined in LibreOffice. For example, assign keyboard shortcuts 
to standard Draw functions or macros and save them for use with Draw, or with other modules in 
LibreOffice. To customize keyboard shortcuts, see the Getting Started Guide for more 
information.

macOS keyboard shortcuts

Some keystrokes and menu items are different in macOS from those used in Windows or Linux 
operating systems. This due to the way the different operating systems work and the different 
types of keyboards used. Also, labelling on the keyboards may vary depending on the age of a 
computer and style of keyboard being used. The following information shows the most common 
variations in macOS for keyboard shortcuts and labelling.

Shift, Control and Alt keys

Windows or Linux macOS

Control or Ctrl  or ⌘ Cmd or Command

Alt  or ⌥ Option or Alt

Shift or ⇧ Shift or ⇧

Caps Lock  or ⇪ Caps Lock

Control or Ctrl  or ⌃ Control or Ctrl

Home and End keys

Windows or Linux macOS

Home Fn+Left Arrow

End Fn+Right Arrow

Page Up and Page Down

Windows or Linux macOS

Screen Up Fn+Up Arrow

Page Up  or ⌥ Option or Alt+Fn+Up 
Arrow

Screen Down Fn+Down Arrow

Page Down
 or ⌥ Option or 

Alt+Fn+Down Arrow
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Note

Some keyboard shortcuts are not available for macOS computers and are indicated 
in the following tables by a blank cell.

Draw function key and keyboard shortcuts

Draw function keys

Windows
Linux

macOS Effect

F1 F1 Opens LibreOffice Draw help.

F2 F2 Switches to text edit mode and opens the Text 
Formatting toolbar.

F3 F3 Enters a group of objects for editing.

Shift+F3 Shift+F3 Opens the Duplicate dialog of a selected object.

Ctrl+F3 ⌘+F3 Exits a group of objects.

F4 F4 Opens the Position and Size dialog of a selected 
object.

F5 F5 Opens the Navigator.

F6 F6 Forward navigation of the emphasis within the on 
screen elements.

Shift+F6 Shift+F6 Backward navigation of the emphasis within the on 
screen elements.

F7 F7 Starts the spelling checker. Only available in text 
editing mode.

Shift+F7 Shift+F7 Switches on or off the automatic spell checking. Only 
available in text editing mode.

Ctrl+F7 ⌘+F7 Opens the Thesaurus dialog for the language being 
used. Only available in text editing mode.

F8 F8 Opens the Edit Points toolbar.

Ctrl+Shift+
F8 ⌘+Shift+F8 Fits text to frame of a selected object.

Shift+F10 Shift+F10 Opens the context menu of a selected object.

F11 ⌘+T Opens the Styles deck on the Sidebar.

Draw keyboard shortcuts

Windows
Linux

macOS Effect

Plus (+) Fn+Shift++ Zooms in.

Minus (-) Fn+–– Zooms out.

Times (×) on 
number pad

Times (*) on 
numeric 
keyboard

Fits the drawing to fill the Workspace view.
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Windows
Linux

macOS Effect

Divide (÷) on 
number pad

Divide (/) on 
numeric 
keyboard

Zooms in on the selected object.

Ctrl+Shift
+G ⌘+Shift+G Groups selected objects.

Shift+Ctrl+Al
t+G ⌘+Shift+⌥+G Ungroups selected group.

Ctrl+click ⌘+click Enters a group to edit individual objects in the group. 
Click outside the group to return to normal view.

Ctrl+Shift
+K ⌘+Shift+K Combines selected objects.

Ctrl+Shift+
Alt+K

⌘+Shift+
⌥+K

Splits a selected object that has been combined from 
a group of two or more objects.

Ctrl++ ⌘++ Brings current selection forward.

Ctrl

+Shift++
⌘+Shift++ Brings current selection to the front.

Ctrl+- ⌘+- Sends current selection backward.

Ctrl+
Shift+- ⌘+Shift+- Sends current selection to the back.

Page Up ⌥+Fn+Up 
Arrow

Switches to previous page. No function on the first 
page.

Page Down ⌥+Fn+Down 
Arrow Switches to next page. No function on the last page.

Ctrl+Page Up ⌘+Fn+Up 
Arrow Switches to previous layer.

Ctrl+Page 
Down

⌘+Fn+Down 
Arrow Switches to next layer.

Arrow Arrow Moves a selected object in the direction of the arrow.

Ctrl+Arrow Ctrl+Arrow Moves the page view in the direction of the arrow.

Left Arrow Left Arrow With Pages pane selected, switches to the previous 
page in a drawing. No function on the first page.

Right Arrow Right Arrow With Pages pane selected, switches to the next page 
in a drawing. No function on the last page.

Shift Shift When selecting objects, adds or removes object to or 
from a selection of objects.

Shift Shift
Hold down Shift then click and drag a selection 
handle when resizing an object to maintain the 
proportions of the object.

Shift Shift
Hold down the Shift key while moving a selected 
object to constrain the movement in multiples of 45 
degrees.
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Windows
Linux

macOS Effect

Shift Shift
Hold down the Shift key before selecting several 
adjacent objects or characters. Click at the start of a 
selection, move to the end of the selection.

Ctrl ⌘
Hold down the Ctrl ( ) key, then click and drag a ⌘
selected object to create a copy of the object.

Alt ⌥
Hold down the Alt (⌥) key and draw or resize an 
object from the centre of the object.

Alt ⌥
Hold down the Alt (⌥) key when selecting an 
object that is behind the currently selected object.

Alt+ Shift ⌥+Shift
Hold down the Alt (⌥)+Shift keys when selecting 
an object that is in front of the currently selected 
object.

Tab Tab Selects objects in the order in which they were 
created.

Shift+Tab Shift+Tab Selects objects in the reverse order in which they 
were created.

Esc Esc Exits current mode.

Enter Enter Enters text mode if a text object in the drawing is 
selected.

Ctrl+Enter ⌘+Enter Inserts a new page after the selected page in a 
drawing.

Home Fn+Left Arrow Selects the first page in a drawing.

End
Fn+Right 
Arrow Selects the last page in a drawing.

Editing text keyboard shortcuts

Windows
Linux

macOS Effect

Ctrl+- ⌘+- Inserts a custom hyphen (soft hyphen) in text at the 
cursor position.

Ctrl+Shift
+- ⌘+Shift+- Inserts a non-breaking hyphen (hard hyphen) in text 

at the cursor position. 

Ctrl+Shift+
Space

⌘+Shift+
Space

Inserts a non-breaking space, which is not used for 
hyphenation and is not expanded if the text is 
justified.

Shift+Enter Shift+Enter Inserts a line break without paragraph change.

Left arrow Left arrow Moves the cursor one character to the left.

Shift+Left 
arrow

Shift+Left 
arrow

Moves the cursor one character to the left and 
selects the character.

Ctrl+Left 
arrow ⌥+Left arrow Moves the cursor to the beginning of the previous 

word.

Ctrl+Shift+
Left arrow

⌥+Shift+
Left arrow

Moves the cursor to the left and selects the word on 
the left.
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Windows
Linux

macOS Effect

Right arrow Right arrow Moves the cursor one character to the right.

Shift+Right 
arrow

Shift+Right 
arrow

Moves the cursor one character to the right and 
selects the character.

Ctrl+Right 
arrow

⌥+Right 
arrow Moves the cursor to the beginning of the next word.

Ctrl+Shift+
Right arrow

⌥+Shift+
Right arrow

Moves the cursor to the right and selects the word on 
the right.

Up arrow Up arrow Moves the cursor up one line.

Shift+Up 
arrow

Shift+Up 
arrow

Moves the cursor up one line in the text and selects 
the lines of text.

Ctrl+Up arrow ⌥+Up arrow Moves the cursor to the beginning of the paragraph.

Ctrl+Shift+Up 
arrow

⌥+Shift+Up 
arrow

Moves the cursor to the beginning of the paragraph. 
Selects the text in the paragraph from the cursor 
position to the beginning of the paragraph.

Down arrow Down arrow Moves the cursor down one line.

Shift+Down 
arrow ⌥+Down arrow Moves the cursor down one line in the text and 

selects the lines of text.

Ctrl+Down 
arrow ⌘+Down arrow Moves the cursor to the end of the paragraph.

Ctrl+Shift+
Down arrow

⌥+Shift+
Down arrow

Moves the cursor to the end of the paragraph. 
Selects the text in the paragraph from the cursor 
position to the end of the paragraph.

Ctrl+
Backspace ⌘+Backspace Deletes the text from the cursor position to the 

beginning of the word.

Ctrl+Shift+
Backspace

⌘+Shift+
Backspace

Deletes the text from the cursor position to the 
beginning of the sentence.

Menu function key and keyboard shortcuts

Function key and keyboard shortcuts listed in the following tables are available for each menu 
item on the Menu bar. The tables give menu item or sub-item, operating system validity, and 
effect or purpose of the shortcut.

Note

The menus listed below are in the same order as displayed on the Menu bar from left 
to right.

LibreOffice
The LibreOffice menu is only available for computers using macOS.

Menu item or 
sub-item

macOS Effect

Preferences ⌘+, Opens the Options dialog.

Hide LibreOffice ⌘+H Temporarily hides LibreOffice, but does not close LibreOffice.
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Menu item or 
sub-item

macOS Effect

Exit LibreOffice ⌘+Q Closes LibreOffice. Make sure all LibreOffice files are saved 
before using.

File menu

Menu item or 
sub-item

Windows
Linux

macOS Effect

New Ctrl+N ⌘+N Opens a new drawing.

Templates
Shift+
Ctrl+N ⌘+Shift+N Opens the Drawings category in the 

Templates dialog.

Open Ctrl+O ⌘+O Opens a file browser allowing 
navigation to a folder and file selection.

Manage 
Templates

Shift+
Ctrl+N ⌘+Shift+N Opens the Drawings category in the 

Templates dialog.

Save Ctrl+S ⌘+S Saves the open drawing.

Save As
Ctrl+
Shift+S ⌘+Shift+S

Opens a file browser allowing 
navigation to a folder and save the 
open drawing as a new file.

Print Ctrl+P ⌘+P Opens the Print dialog allowing 
selection of how the drawing is printed.

Exit LibreOffice Ctrl+Q ⌘+Q Closes LibreOffice. Make sure all files 
are saved before using.

Edit Menu

Menu item or 
sub-item

Windows
Linux

macOS Effect

Undo Ctrl+Z ⌘+Z Undoes the previous editing action.

Redo Ctrl+Y ⌘+Y Reverses the action of the last Undo 
command.

Cut Ctrl+X ⌘+X Deletes the selected object and places 
it on the clipboard.

Copy Ctrl+C ⌘+C Copies the selected object to the 
clipboard.

Paste Ctrl+V ⌘+V
Inserts the contents of the clipboard at 
the location of the cursor replacing any 
selected text or objects.

Paste Special 
> Paste 
Special

Ctrl+
Shift+V ⌘+Shift+V

Pastes the contents of the clipboard at 
the cursor position in a format that is 
specified using the Paste Special 
dialog.

Duplicate Shift+F3 Shift+F3
When an object is selected, opens the 
Duplicate dialog providing options for 
duplicating a selected object.

Select All Ctrl+A ⌘+A Selects all the pages and objects in a 
drawing.
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Menu item or 
sub-item

Windows
Linux

macOS Effect

Find Ctrl+F ⌘+F Opens the Find toolbar.

Replace Ctrl+H +⌘ ⌥+F Opens the Find and Replace dialog.

Points F8 F8

Opens the Edit Points toolbar if there is 
an object on the drawing that uses 
editable points, for example a freeform 
line.

Edit Mode
Ctrl+
Shift+M ⌘+Shift+M Allows a read only drawing to be edited 

if the user has writer permission.

View menu

Menu item or 
sub-item

Windows
Linux

macOS Effect

Rulers
Ctrl+
Shift+R ⌘+Shift+R Switches the rulers off and on in the 

Workspace.

Sidebar Ctrl+F5 ⌘+F5 Opens or closes the Sidebar.

Styles F11 ⌘+T Opens or closes the Styles deck on the 
Sidebar.

Navigator F5 F5 Opens the Navigator dialog.

Insert menu

Menu item or 
sub-item

Windows
Linux

macOS Effect

Text Box F2 F2 Switches to text edit mode and opens 
the Text Formatting toolbar.

Comment Ctrl+Alt+C +⌘ ⌥+C
Inserts a new comment box onto the 
selected page.

Hyperlink Ctrl+K ⌘+K Opens the Hyperlink dialog.

Insert non-
breaking space

Ctrl+Shift+S
pace

⌘+Shift+
Space

Inserts a non-breaking space at the 
cursor position.

Insert Narrow 
No-break 
Space

Alt+Shift+
Space

⌥+Shift+
Space

Inserts a narrow non-breaking space at 
the cursor position.

No-width 
Optional Break

Ctrl+/ ⌘+/ Inserts a narrow no-width optional 
break at the cursor position.

Format menu

Menu item or 
sub-item

Windows
Linux

macOS Effect

Bold Ctrl+B ⌘+B Applies Bold format to selected text.

Italic Ctrl+I ⌘+I Applies Italic format to selected text.
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Menu item or 
sub-item

Windows
Linux

macOS Effect

Superscript Ctrl+Shift+P ⌘+Shift+P
Reduces the font size of the selected 
text and raises the text above the 
baseline.

Subscript
Ctrl+
Shift+B

⌘+Shift+B
Reduces the font size of the selected 
text and lowers the text below the 
baseline.

Increase Size Ctrl+] ⌘+] Increases the point size of selected 
text.

Decrease Size Ctrl+[ ⌘+[ Decreases the point size of selected 
text.

Line Spacing 1 Ctrl+1 ⌘+1 Sets the line spacing in a paragraph to 
a single line.

Line Spacing 5 Ctrl+5 ⌘+5 Sets the line spacing in a paragraph to 
one and half lines.

Line Spacing 2 Ctrl+2 ⌘+2 Sets the line spacing in a paragraph to 
two lines.

Left Ctrl+L ⌘+L Sets the paragraph alignment to left 
aligned.

Center Ctrl+E ⌘+E Sets the paragraph alignment to center 
aligned.

Right Ctrl+R ⌘+R Sets the paragraph alignment to right 
aligned.

Justified Ctrl+J ⌘+J Sets the paragraph alignment to 
justified.

Clear Direct 
Formatting

Ctrl+M ⌘+M Removes direct formatting that has 
been applied without using styles.

Edit Style Alt+P ⌥+P
Opens the Graphic Styles dialog to edit 
a selected style.

Manage Styles F11 ⌘+T Opens or closes the Styles deck on the 
Sidebar.

Position and 
Size

F4 F4 Opens the Position and Size dialog of a 
selected object.

Shape menu

Menu item or 
sub-item

Windows
Linux

macOS Effect

Bring to Front
Ctrl+
Shift++ ⌘+Shift++ Moves a selected object to the front of 

other objects.

Bring Forward Ctrl++ ⌘++ Moves a selected object in front of the 
forward object.

Send 
Backward

Ctrl+- ⌘+- Moves a selected object behind the 
backward object.

Send to Back
Ctrl+
Shift+- ⌘+Shift+- Moves a selected object to the back of 

other objects.
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Menu item or 
sub-item

Windows
Linux

macOS Effect

Group
Ctrl+
Shift+G ⌘+Shift+G Groups selected objects.

Ungroup
Ctrl+Alt+
Shift+G

⌘+⌥+Shift
+G Ungroups selected group.

Enter Group F3 F3 Enters a group of objects for editing.

Exit Group Ctrl+F3 ⌘+F3 Exits a group of objects.

Combine
Ctrl+
Shift+K ⌘+Shift+K Combines two or more selected objects 

into a single shape.

Split
Ctrl+Shift+A
lt+K

⌘+⌥+Shift
+K

Splits a combined object into individual 
objects.

Duplicate Shift+F3 Shift+F3
When an object is selected, opens the 
Duplicate dialog providing options for 
duplicating a selected object.

Tools menu

Menu item or 
sub-item

Windows
Linux

macOS Effect

Spelling F7 Starts spelling checker. Only available 
in text editing mode.

Automatic 
Spell Checking

Shift+F7 Shift+F7
Switches on or off the automatic spell 
checking. Only available in text editing 
mode.

Thesaurus Ctrl+F7 ⌘+F7
Opens the thesaurus dialog for the 
language being used. Only available in 
text editing mode.

Extension 
Manager

Ctrl+Alt+E ⌘+⌥+E Opens the Extension Manager dialog.

Options Alt+F12 Opens the Options LibreOffice dialog.

Windows menu

Menu item or 
sub-item

Windows
Linux

macOS Effect

Closes 
Window

Ctrl+W ⌘+W Closes the active window. If there is 
only one window, closes LibreOffice.

Help menu

Menu item or 
sub-item

Windows
Linux

macOS Effect

LibreOffice 
Help

F1 F1 Opens a browser application at the 
LibreOffice Help pages.

Search 
Commands

Shift+Esc Opens a dialog to search for a 
command.
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General function key and keyboard shortcuts

Opening menus and menu items

Windows
Linux

macOS Effect

Esc Esc Closes an open menu.

F6 F6

Repeatedly pressing F6 cycles the focus through the 
following objects:

Menu bar (Windows and Linux operating systems only).

Each toolbar from top to bottom and from left to right.

Each free window from left to right.

Shift+F6 Shift+F6 Repeatedly pressing Shift+F6 cycles the focus in the 
opposite direction.

Ctrl+F6 ⌘+F6 Cycles the focus back to the drawing.

F10 Switches the access on or off for the Menu bar.

Accessing Menu bar commands
• Press F6 selects the first item (File) on the Menu bar.

• Press the right arrow selects the next menu to the right.

• Press the left arrow selects the previous menu to the left.

• Press the Home and End keys selects the first or last item on the Menu bar.

• Press the down arrow to open a selected menu. An additional press on the down arrow 
or up arrow moves the selection through the menu commands.

• Press the right arrow to open any submenus on the selected menu. Submenus are 
indicated by a triangle ► or chevron ˃ next to the menu item.

• Press Enter to execute the selected menu command.

Accessing toolbar commands
• Press F6 repeatedly until the first tool on a toolbar is selected.

• Using the right and left arrows selects a tool on a horizontal toolbar, or the up and down 
arrows selects a tool on a vertical toolbar.

• Pressing the Home key selects the first tool on a toolbar, or the End key selects the last 
tool on a toolbar.

• Pressing Enter activates the selected tool.

• Pressing the right arrow opens any sub-toolbar on a selected toolbar. Sub-toolbars are 
indicated by a triangle ▼ next to the tool.

• Pressing Ctrl+Enter inserts a selected draw object. The draw object is placed in the 
center of the drawing, with a predefined size.

Appendix A,  Keyboard Shortcuts | 349



Controlling dialogs
When any dialog is open, one element (for example a button or option field) indicates focus by 
highlighting, a check mark, or a dotted box around the field or button name.

Windows
Linux

Effect

Enter Activates the selected option. Where no option is selected, 
Enter is the equivalent to clicking on OK.

Esc Closes a dialog without saving any changes made while it 
was open, the equivalent to selecting Cancel.

Up/Down arrow keys
Moves focus up and down a list.
Increases or decreases the value of a variable.
Moves focus vertically within a section of dialog.

Left/Right arrow keys Moves focus horizontally within a section of a dialog.

Tab Advances focus to the next section or element of a dialog.

Shift+Tab Moves the focus to the previous section or element in a 
dialog.

Alt+Down Arrow Shows the options available in a drop-down list.

Spacebar
Checks or selects an empty checkbox.

Clears or deselects a checked checkbox.

Toolbar function key and keyboard shortcuts

The Draw toolbars are listed in the same order displayed in the context menu that opens when 
View > Toolbars is selected on the Menu bar.

Draw provides several toolbars for the creation and editing of drawings. Some tools on the Draw 
toolbars can be activated using a function key, or keyboard shortcut.

Drawing

Tool name
Windows
Linux

macOS Effect

Insert Text Box F2 F2 Switches to text edit mode and opens 
the Text Formatting toolbar.

Edit Points F8 F8

Opens the Edit Points toolbar if there is 
an object on the drawing that uses 
editable points, for example a freeform 
line.

Find

Tool name
Windows
Linux

macOS Effect

Find and 
Replace

Ctrl+H +⌘ ⌥+H Finds and replaces all instances of text 
in a drawing.
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Form Design

Tool name
Windows
Linux

macOS Effect

Bring to Front
Ctrl+
Shift++ ⌘+Shift++ Moves a selected object to the front of 

other objects.

Send to Back
Ctrl+
Shift+- ⌘+Shift+- Moves a selected object to the back of 

other objects.

Group
Ctrl+
Shift+G ⌘+Shift+G Groups selected objects.

Ungroup
Ctrl+Alt+
Shift+G

+⌘ ⌥+Shift+
G Ungroups selected group.

Enter Group F3 F3 Enters a group of objects for editing.

Exit Group Ctrl+F3 ⌘+F3 Exits a group of objects.

Image

Tool name
Windows
Linux

macOS Effect

Position and 
Size

F4 F4 Opens the Position and Size dialog of a 
selected object.

Bring to Front
Ctrl+
Shift++ ⌘+Shift++ Moves a selected object to the front of 

other objects.

Bring Forward Ctrl++ ⌘++ Moves a selected object in front of the 
forward object.

Send 
Backward

Ctrl+- ⌘+- Moves a selected object behind the 
backward object.

Send to Back
Ctrl+
Shift+- ⌘+Shift+- Moves a selected object to the back of 

other objects.

Line and Filling

Tool name
Windows
Linux

macOS Effect

Position and 
Size

F4 F4 Opens the Position and Size dialog of a 
selected object.

Bring to Front
Ctrl+
Shift++ ⌘+Shift++ Moves a selected object to the front of 

other objects.

Bring Forward Ctrl++ ⌘++ Moves a selected object in front of the 
forward object.

Send 
Backward

Ctrl+- ⌘+- Moves a selected object behind the 
backward object.

Send to Back
Ctrl+
Shift+- ⌘+Shift+- Moves a selected object to the back of 

other objects.

Styles F11 ⌘+T Opens the Styles deck on the Sidebar.
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Standard

Tool name
Windows
Linux

macOS Effect

New Ctrl+N ⌘+N Opens a new drawing.

Templates
Ctrl+
Shift+N ⌘+Shift+N Opens the Templates dialog to create a 

new drawing using a template.

Open Ctrl+O ⌘+O
Opens the Open file browser to allow 
navigation to a folder and selection of a 
drawing.

Save Ctrl+S ⌘+S Saves the open document.

Save As
Ctrl+
Shift+S ⌘+Shift+S Opens the Save as file browser to save 

the open drawing as a new drawing.

Edit Mode
Ctrl+
Shift+M ⌘+Shift+M Switches on edit mode when a drawing 

is in read only mode.

Print Ctrl+P ⌘+P Opens the Print dialog to select how to 
print the drawing.

Cut Ctrl+X ⌘+X Deletes the selected object and places 
it on the clipboard.

Copy Ctrl+C ⌘+C Copies the selected object to the 
clipboard.

Paste Ctrl+V ⌘+V Places the object on the clipboard into 
the document.

Clear Ctrl+M ⌃+M Removes direct formatting that has 
been applied without using styles.

Undo Ctrl+Z ⌘+Z Undoes the previous editing action.

Redo Ctrl+Y ⌘+Y Reverses the action of the last Undo 
command.

Spelling F7 F7 Starts the spelling checker. Only 
available in text editing mode.

Auto 
Spellcheck

Shift+F7 Shift+F7
Switches on or off the automatic spell 
checking. Only available in text editing 
mode.

Text Box F2 Switches to text edit mode and opens 
the Text Formatting toolbar.

Insert 
Hyperlink

Ctrl+K Opens the Hyperlink dialog.

Position and 
Size

F4 Opens the Position and Size dialog of a 
selected object.

Edit Points F8

Opens the Edit Points toolbar if there is 
an object on the drawing that uses 
editable points, for example a freeform 
line.
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Standard (Viewing Mode)

Tool name
Windows
Linux

macOS Effect

Save As
Ctrl+
Shift+S ⌘+Shift+S

Opens the Save as file browser so you 
can save the open document as a new 
document.

Edit Mode
Ctrl+
Shift+M ⌘+Shift+M Switches on edit mode when a 

document is in read only mode.

Print Ctrl+P ⌘+P
Opens the Print dialog so that you can 
select how you want to print the 
document.

Copy Ctrl+C ⌘+C Copies the selected object to the 
clipboard.

Find and 
Replace

Ctrl+H +⌘ ⌥+F Opens the Find and Replace dialog.

Text Formatting

Tool name
Windows
Linux

macOS Effect

Increase Ctrl+] ⌘+] Increases the point size of selected 
text.

Decrease Ctrl+[ ⌘+[ Decreases the point size of selected 
text.

Bold Ctrl+B ⌘+B Applies Bold format to selected text.

Italic Ctrl+I ⌘+I Applies Italic format to selected text.

Superscript
Ctrl+
Shift+P ⌘+Shift+P

Reduces the font size of the selected 
text and raises the text above the 
baseline.

Subscript
Ctrl+
Shift+B ⌘+Shift+B

Reduces the font size of the selected 
text and lowers the text below the 
baseline.

Clear Ctrl+M ⌃+M Removes direct formatting that has 
been applied without using styles.

Left Ctrl+L ⌘+L Sets the paragraph alignment to left 
aligned.

Center Ctrl+E ⌘+E Sets the paragraph alignment to center 
aligned.

Right Ctrl+R ⌘+R Sets the paragraph alignment to right 
aligned.

Justified Ctrl+J ⌘+J Sets the paragraph alignment to 
justified.

Select All Ctrl+A ⌘+A Selects all the text in a text box.
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Introduction

Draw provides several toolbars for creating drawings. Each toolbar has a default set of tools 
when LibreOffice is installed on a computer. To improve the usability of a toolbar, additional tools 
can be added, see “Editing toolbars” on page 359 for more information.

Notes

The icons displayed on the Draw toolbars illustrated in this appendix may differ from 
what is displayed on a computer screen. Toolbar icons depend on the computer 
operating system being used and how LibreOffice has been set up. For more 
information on customizing LibreOffice and toolbars, see the Getting Started Guide.

Some toolbars when selected do not display until an object of the correct type is 
selected in a presentation. For example, the Image toolbar only displays when an 
image, or graphic, using an image file format is selected.

When selecting some tools on a toolbar, a subtoolbar may be available providing 
more tools for editing an object. For example, clicking on Color in the Image toolbar 
opens the Color subtoolbar to adjust the color settings of an image.

Using toolbars

Displaying toolbars
Two methods of opening toolbars in Draw are used, as follows:

1) Go to View > Toolbars on the Menu bar. A sub-menu opens with an alphabetical list of 
toolbars available for creating drawings in Draw.

2) Click on a toolbar name to display it and make it active. Active toolbars are indicated by 
highlighting or a check mark next to the toolbar name, depending on computer setup.

Closing toolbars
To close a toolbar, use one of the following methods:

• Go to View > Toolbars on the Menu bar and deselect the toolbar.

• Right-click in a blank area on a toolbar and select Close Toolbar from the context menu.

• Click on the X in the right corner of the title bar of a floating toolbar.

Moving toolbars

Docked toolbars

By default, some toolbars are docked into position in the Draw main window. By default in the 
main window, the Standard toolbar is docked horizontally at the top and the Drawing toolbar is 
docked vertically at the left side. Docked toolbars can be undocked and moved into a new 
docked position on the main window, or left as a floating toolbar.

1) Move the cursor over the small vertical handle at the left end of the toolbar, or horizontal 
handle at the top of a toolbar (highlighted in Figure 328). The cursor changes shape to 
the moving cursor used for the computer system and setup.

2) Alternatively, right click on a docked toolbar and select Undock Toolbar from the context 
menu.
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Figure 328: Example of toolbar moving handles

Figure 329: Example of creating floating subtoolbars

3) Click and drag the toolbar to a new docked position, or leave as a floating toolbar. A 
hashed border appears around the toolbar indicating toolbar position as it is dragged.

4) Release the toolbar when it is in the required position.

Note

If these toolbar moving handles are not not visible at the left end or top of a docked 
toolbar, then the toolbar is locked into position. A docked toolbar must be unlocked 
before it can be moved to a new position in the main window. See “Locking toolbars” 
on page 358 for more information.

Floating toolbars

To move a floating toolbar, click on the title bar and drag it to a new floating location. Release the 
toolbar when it is in the required position. A floating toolbar does not have to be positioned on 
the Draw main window for it to function.

Floating subtoolbars

Some tools on a toolbar have a triangle ▼ to the right of the tool indicating that more tools are 
available on a subtoolbar, for example Symbol Shapes on the Drawing toolbar. Subtoolbars can 
be turned into floating toolbars and moved into a new position as follows:

1) Move the cursor over the horizontal handle at the top of the subtoolbar (highlighted in 
Figure 329). The cursor changes to the moving cursor used for the computer system and 
setup.
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2) Click and drag the subtoolbar to a new location creating a floating subtoolbar.

3) Release the subtoolbar when the required position is reached.

4) To close the floating subtoolbar, right-click on the triangle ▼ in the subtoolbar title bar 
and select Close Toolbar from the context menu.

5) Alternatively, click on the X in the right corner of the title bar of a floating subtoolbar

Docking floating toolbars

To dock a floating toolbar, use one of the following methods:

• Click on the title bar and drag it to a docking position at the top, bottom, left side, or right 
side of the main window. When the toolbar reaches its docking position, a hashed border 
appears at the docking position. Release the toolbar to dock it in the required position.

• Right-click on the toolbar and select Dock Toolbar from the context menu. The toolbar 
moves into a docked position. If the position is not suitable, move the toolbar to a new 
docked position.

• To dock all floating toolbars that are active, right-click on a toolbar and select Dock All 
Toolbars from the context menu.

Locking toolbars

Docked toolbars

When a toolbar has been docked into position, the toolbar can also be locked into position 
preventing the toolbar from becoming a floating toolbar.

• To lock a toolbar into a docked position, right-click in a blank area on the toolbar and 
select Lock Toolbar Position in the context menu. The small vertical or horizontal bar at 
the left end or top of the toolbar disappears indicating that the toolbar is locked.

• To unlock a toolbar, right-click in a blank area on the toolbar and click on Lock Toolbar 
Position in the context menu. A small vertical or horizontal bar appears at the left end or 
top of the toolbar indicating that the toolbar is unlocked. This bar is also is used to move 
the toolbar.

Notes

The Lock Toolbar Position is used for locking and unlocking toolbars is an on/off 
switch.

Some toolbars cannot be docked or locked into position. This is indicated by the 
options Dock Toolbar and/or Lock Toolbar Position being grayed out making both 
options unavailable.

Using the Lock Toolbars option affects all toolbars and subtoolbars available in all 
LibreOffice modules.

Locking toolbars and subtoolbars

To prevent all toolbars and subtoolbars from becoming floating toolbars or subtoolbars, they can 
be locked. Locked toolbars and subtoolbars can be unlocked using the same method below. The 
Lock Toolbars option is used as a lock/unlock switch.

1) Save the drawing that is open in Draw.

2) Go to View > Toolbars on the Menu bar and select Lock Toolbars from the context 
menu.
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3) Select Restart Now in the Restart LibreOffice dialog that opens to activate the Lock 
Toolbars option.

4) To unlock all toolbars and subtoolbars so they can be repositioned, repeat Steps 1 thru 3. 
The Lock Toolbars option is an on/off switch.

Editing toolbars
When LibreOffice is installed on a computer, it includes a set of toolbars suitable for each 
LibreOffice module. Each toolbar has a default set of visible tools. Tools can be added or 
deleted, and toolbars can be customized.

Adding tools

1) Right-click in a blank area on a toolbar, or click on the triangle ▼ on the right of the 
toolbar title bar.

2) Select Visible Buttons from the context menu to display a list of available tools.

3) Click on the tool required and the tool appears in the toolbar. The list of available tools 
closes automatically. A check mark next to the tool, or highlighting around the tool, 
indicates that the tool listed in Visible Buttons is already installed on the toolbar.

Note

When adding tools using Visible Buttons, the tool is added to the toolbar at the 
same position as the tool appears in the Visible Buttons list. That is, the first tool in 
the list appears at the left end of the toolbar and the last tool in the list appears at the 
right end of the toolbar.

Removing tools

1) Right-click in a blank area on a toolbar, or click on the triangle ▼ on the right of the 
toolbar title bar.

2) Select Visible Buttons from the context menu to display a list of available tools.

3) Click on a tool no longer required to deselect and it is removed from the toolbar. The 
highlighting or check mark is also removed. The list of available tools closes 
automatically.

Customizing toolbars
Extra tools and commands that are not available in Visible Buttons can be added to a toolbar 
using customization (View > Toolbars > Customize on the Menu bar). Customization also 
allows the creation of new toolbars if a specific set of tools are required for a specific task. For 
information on customizing toolbars, see the Getting Started Guide.

Toolbars

• To open the default list of toolbars already installed in Draw, go to View > Toolbars on 
the Menu bar. An example of the default list of toolbars in Draw is shown in Figure 330.

• The number of tools visible on a toolbar depends on the computer setup and operating 
system being used to create a drawing.

• The tools displayed on toolbars displayed in this appendix are examples only. Actual 
tools displayed in a toolbar depend on computer setup, operating system and user 
preferences.
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Figure 330: Example of default list of toolbars in Draw

• The tools already installed on a toolbar are indicated in Visible Buttons either by the 
tool icon being highlighted or by a check mark. This indication depends on computer 
setup and computer operating system being used.

• On some toolbars, tool icons may have a triangle ▼ to the right of the icon. Click on this 
triangle ▼ to open a list of options, another toolbar, or a subtoolbar.

• Some tools also have a keyboard shortcut to make the tool available for ues. For a full 
list of keyboard shortcuts available in Draw, see Appendix A, Keyboard Shortcuts.

• Each toolbar and subtoolbar displayed in this appendix shows the full list of available 
tools for that toolbar or subtoolbar.

3D-Objects
The 3D-Objects toolbar (Figure 331) provides the tools for creating 3D objects in a drawing. Go 
to View > Toolbars > 3D-Objects on the Menu bar. Alternatively, clicking on the triangle ▼ next 
to 3D-Objects on the Drawing toolbar opens a subtoolbar providing access to 3D tools.

Figure 331: 3D-Objects toolbar
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(1) Cube
(2) Sphere
(3) Cylinder

(4) Cone
(5) Pyramid
(6) Torus

(7) Shell
(8) Half Sphere

3D-Settings
The tools on the 3D-Settings toolbar (Figure 332) are only active when an object has been 
converted to 3D using Toggle Extrusion and the converted object is selected.

Figure 332: 3D-Settings toolbar

(1) Toggle Extrusion
(2) Tilt Down
(3) Tilt Up
(4) Tilt Left

(5) Tilt Right
(6) Depth
(7) Direction
(8) Lighting

(9) Surface
(10) 3D Color

For the following tools on the 3D-Settings toolbar click on the triangle ▼ on the right of the icon 
for access to various options as follows:

Depth

3D extrusion depth — 0cm; 1cm; 2.5cm; 5cm; 10cm; Infinity; Custom. The measurement 
unit depends on the ruler settings in Tools > Options > LibreOffice Draw > General 
(macOS LibreOffice > Preferences > LibreOffice Draw > General).

Direction

3D extrusion direction and type — Parallel; Perspective.

Lighting

Lighting direction and lighting level of 3D extrusion — Bright; Normal; Dim.

Surface

Surface type of 3D extrusion — Wire Frame; Matt; Plastic; Metal.

3D Color

Color of 3D extrusion. Select a color from one of the available color palettes.

Align Objects
The Align Objects toolbar (Figure 333) provides tools for aligning several objects with each other 
in a drawing.

Figure 333: Align Objects toolbar

The tools available on the Align Objects toolbar, from left to right, are as follows:

Left

Aligns the left edges of selected objects. If only one object is selected in Draw, the left 
edge of the object is aligned to the left page margin.
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Centered

Horizontally centers selected objects. If only one object is selected in Draw, the center of 
the object is aligned to the horizontal center of the page.

Right

Aligns the right edges of selected objects. If only one object is selected in Draw, the right 
edge of the object is aligned to the right page margin.

Top

Vertically aligns top edges of the selected objects. If only one object is selected in Draw, 
the top edge of the object is aligned to the upper page margin.

Center

Vertically centers selected objects. If only one object is selected in Draw, the center of 
the object is aligned to the vertical center of the page.

Bottom

Vertically aligns the bottom edges of selected objects. If only one object is selected in 
Draw, the bottom edge of the object is aligned to the lower page margin.

Comments
The Comments toolbar (Figure 334) provides tools for adding, deleting, editing and navigation of 
comments in a drawing. To use comments, it is recommended to add the name and initials of all 
users in Tools > Options > LibreOffice > User Data (macOS LibreOffice > Preferences > 
LibreOffice > User Data). Adding user names identifies comments that have been inserted.

Figure 334: Comments toolbar

(1) Comment
(2) Previous Comment

(3) Next Comment
(4) Delete Comment

(5) Delete All Comments

Distribute Selection
The Distribute Selection toolbar (Figure 335) provides tools to distribute three or more selected 
objects along a horizontal axis or vertical axis. Also, the spacing between objects can be evenly 
distributed horizontally and vertically.

Figure 335: Distribute Selection toolbar

Distribute Horizontally Left

Distributes the selected objects, so that the left edges of the objects are evenly spaced 
from one another.

Distribute Horizontally Center

Distributes the selected objects, so that the horizontal centers of the objects are evenly 
spaced from one another.
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Distribute Horizontally Spacing

Distributes the selected objects horizontally, so that the objects are evenly spaced from 
one another.

Distribute Horizontally Right

Distributes the selected objects, so that the right edges of the objects are evenly spaced 
from one another.

Distribute Vertically Top

Distributes the selected objects, so that the top edges of the objects are evenly spaced 
from one another.

Distribute Vertically Center

Distributes the selected objects, so that the vertical centers of the objects are evenly 
spaced from one another.

Distribute Vertically Spacing

Distributes the selected objects vertically, so that the objects are evenly spaced from one 
another.

Distribute Vertically Bottom

Distributes the selected objects, so that the bottom edges of the objects are evenly 
spaced from one another.

Drawing
The Drawing toolbar (Figure 336) provides the tools used to create graphic objects in a 
drawings. By default, this toolbar is docked on the left side of the Workspace. Some tool shapes 
on the Drawing toolbar change depending on the last tool that was previously selected and 
used.

If required, click on the triangle ▼ to the right of a tool icon to open a pop-up toolbar, then select 
the required shape to add to a drawing. Click on the handle at the top of a pop-up toolbar and 
drag to an empty area on the main window. For more information, see “Floating subtoolbars” on 
page 357 and Figure 329 on page 357.

 Figure 336: Drawing toolbar

(1) Select
(2) Zoom & Pan
(3) Zoom
(4) Text Box
(5) Vertical Text
(6) Insert Fontwork
(7) Line Color
(8) Fill Color
(9) Line
(10) Rectangle
(11) Ellipse
(12) Line Ends with Arrow
(13) Lines and Arrows
(14) Curves and Polygons

(15) Connectors
(16) Basic Shapes
(17) Symbol Shapes
(18) Block Arrows
(19) Flowchart
(20) Callouts
(21) Stars and Banners
(22) 3D Objects
(23) Position and Size
(24) Rotate
(25) Flip
(26) Align Objects
(27) Arrange

(28) Select at least three objects 
to distribute

(29) Shadow
(30) Crop Image 
(31) Filter
(32) Points F8
(33) Show Gluepoint Function 
(34) To Curve
(35) To Polygon
(36) To 3D
(37) T0 3D Rotation Object
(38) Toggle Extrusion
(39) Insert
(40) Controls
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Edit Points
The Edit Points toolbar (Figure 337) provides tools for editing the points of a curve or polygon, or 
an object that has been converted to a curve or polygon. The toolbar only becomes active when 
an object is selected. Click on Edit Points on the Drawing or Standard toolbar, or use the 
keyboard shortcut F8 to open the toolbar.

Figure 337: Edit Points toolbar

(1) Edit Points
(2) Move Points
(3) Insert Points
(4) Delete Points

(5) Convert to Curve
(6) Close Bezier
(7) Split Curve
(8) Corner Point

(9) Smooth Transition
(10) Symmetric Transition
(11) Eliminate Points

Find
The Find toolbar (Figure 338) opens by default and is docked in the bottom left corner of the 
LibreOffice Draw main window above the Status bar. This toolbar can be undocked from its 
default position and made into a floating toolbar.

Figure 338: Find toolbar

(1) Close Find Bar
(2) Find Text
(3) Find Previous

(4) Find Next
(5) Find All
(6) Match Case

(7) Find and Replace

Fontwork
The Fontwork toolbar (Figure 339) is used to create graphical text objects in a slide and provide 
the tools for editing a graphical text object. This toolbar only becomes active when a Fontwork 
graphical text object has been selected on a drawing. 

Figure 339: Fontwork toolbar

(1) Insert Fontwork Text
(2) Fontwork Shape

(3) Fontwork Same Letter 
Heights

(4) Fontwork Alignment

(5) Fontwork Character Spacing
(6) Toggle Extrusion

Some tools on the Fontwork toolbar have a triangle ▼ to the right of the tool. Click on this 
triangle to open a subtoolbar, or drop-down option list.

Fontwork Shape

Select the required shape for a Fontwork graphical text object from the options available.

Fontwork Alignment

Select the paragraph alignment from the options available.
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Fontwork Character Spacing

Select the required character spacing from the options available.

Form Controls
The Form Controls toolbar (Figure 340) provides the tools required to create an interactive form. 
This allows controls to be added to a form in a drawing. For example, a button that opens a 
document, drawing, spreadsheet, or slide.

Figure 340: Form Controls toolbar

(1) Select
(2) Design Mode
(3) Toggle Form Control 

Wizards
(4) Form Design
(5) Control Properties
(6) Form Properties
(7) Label
(8) Text Box
(9) Check Box

(10) Option Button
(11) List Box
(12) Combo Box
(13) Push Button
(14) Image Button
(15) Formatted Field
(16) Date Field
(17) Numerical Field
(18) Group Box
(19) Time Field

(20) Currency Field
(21) Pattern Field
(22) Table Control
(23) Navigation Bar
(24) Image Control
(25) File Selection
(26) Spin Button
(27) Scrollbar

Form Design
The Form Design toolbar (Figure 341) opens a form in Design Mode so that it can be edited. 
Controls of the form cannot be activated, or its contents edited when in Design Mode. However, 
the position and size of the controls can be changed, properties edited, and controls added or 
deleted in Design Mode.

Figure 341: Form Design toolbar

(1) Select
(2) Control Properties
(3) Form Properties
(4) Position and Size
(5) Form Navigator
(6) Activation Order
(7) Add Field

(8) Automatic Control Focus
(9) Bring to Front
(10) Send to Back
(11) Group
(12) Ungroup
(13) Enter Group
(14) Exit Group

(15) Align Objects
(16) Open in Design Mode
(17) Display Grid
(18) Snap to Grid
(19) Helplines While Moving

Form Navigation
The Form Navigation toolbar (Figure 342) provides tools to edit a database table or control data 
view. The toolbar is normally displayed at the bottom of a document that contains fields that are 
linked to a database. This toolbar is only active when forms are connected to a database, which 
is why an inactivate toolbar is shown in Figure 342.
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The Form Navigation toolbar allows movement within records as well as inserting and deleting 
records. If data is saved in a form, the changes are transferred to the database. This toolbar also 
provides tools providing sort, filter, and search functions for data records.

Figure 342: Form Navigation toolbar

(1) Find Record
(2) Record
(3) Absolute Record
(4) Text -> Record
(5) Total No. of Records
(6) First Record
(7) Previous Record
(8) Next Record

(9) Last Record
(10) New Record
(11) Save Record
(12) Undo: Data entry
(13) Delete Record
(14) Refresh
(15) Refresh Control
(16) Sort

(17) Sort Ascending
(18) Sort Descending
(19) AutoFilter
(20) Apply Filter
(21) Form-Based Filters
(22) Reset Filter/Sort
(23) Data source as Table

Gluepoints
The Gluepoints toolbar (Figure 343) provides tools to insert a gluepoint or modify the properties 
of a gluepoint. A gluepoint is a point where a connector is attached to an object. By default, 
LibreOffice automatically places a gluepoint at the center of each side of the bounding rectangle 
for every object created.

Figure 343: Gluepoints toolbar

(1) Insert Glue Point
(2) Exit Direction Left
(3) Exit Direction Top
(4) Exit Direction Right

(5) Exit Direction Bottom
(6) Glue Point Relative
(7) Glue Point Horizontal Left
(8) Glue Point Horizontal Center

(9) Glue Point Horizontal Right
(10) Glue Point Vertical Top
(11) Glue Point Vertical Center
(12) Glue Point Vertical Bottom

Image
The Image toolbar (Figure 344) provides tools to edit, modify, align, reposition and resize 
images. The toolbar only becomes active and available when an image is selected in a drawing. 
The Image toolbar automatically replaces the Line and Filling toolbar when it becomes active.

Figure 344: Image toolbar
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(1) Position and Size
(2) Align Objects
(3) Left
(4) Centered
(5) Right
(6) Top
(7) Center
(8) Bottom
(9) Arrange
(10) Bring to Front
(11) Bring Forward
(12) Send Backward

(13) Send to Back
(14) In Front of Object
(15) Behind Object
(16) Reverse
(17) Line Style
(18) Line Width
(19) Line Color
(20) Area Style/Filling
(21) Fill Color
(22) Shadow
(23) Filter
(24) Image Mode

(25) Crop
(26) Vertically
(27) Horizontally
(28) Transformations
(29) Transparency
(30) Color
(31) Line
(32) Area
(33) Animation
(34) Interaction

Insert
The Insert toolbar (Figure 345) provides tools for inserting objects into a drawing such as table, 
images, media, formulas, charts, and OLE objects.

Figure 345: Insert toolbar

(1) New Page
(2) Floating Frame
(3) Insert Page from File

(4) Table
(5) Image
(6) Insert Audio or Video

(7) Formula Object
(8) Chart
(9) OLE Object

Legacy Circles and Ovals
The Legacy Circles and Ovals toolbar (Figure 346) provides tools to insert different types of 
circles and ovals into a drawing.

Figure 346: Legacy Circles and Ovals toolbar

(1) Insert Ellipse
(2) Circle
(3) Ellipse Pie
(4) Circle Pie
(5) Ellipse Segment

(6) Circle Segment
(7) Ellipse, Unfilled
(8) Circle, Unfilled
(9) Ellipse Pie, Unfilled
(10) Circle Pie, Unfilled

(11) Ellipse Segment, Unfilled
(12) Circle Segment, Unfilled
(13) Arc
(14) Circle Arc

Legacy Rectangles
The Legacy Rectangles toolbar (Figure 347) provides tools to insert different types of rectangles 
and squares into a slide.

Figure 347: Legacy Rectangles toolbar
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(1) Insert Rectangle
(2) Square
(3) Rectangle, Rounded

(4) Rounded Square
(5) Rectangle, Unfilled
(6) Square, Unfilled

(7) Rounded Rectangle, Unfilled
(8) Rounded Square, Unfilled

Line and Filling
The Line and Filling toolbar (Figure 348) provides tools and drop-down lists for editing lines, 
arrows, and object borders. The tools available depends on the type of object selected for 
editing.

Figure 348: Line and Filling toolbar

(1) Position and Size
(2) Align Objects
(3) Left
(4) Centered
(5) Right
(6) Top
(7) Center
(8) Bottom
(9) Arrange
(10) Bring to Front
(11) Bring Forward
(12) Send Backward

(13) Send to Back
(14) In Front of Object
(15) Behind Object
(16) Reverse
(17) Line Style
(18) Line Width
(19) Line Color
(20) Area Style/Filling
(21) Fill Color
(22) Shadow
(23) Arrow Style
(24) Vertically

(25) Horizontally
(26) Transformations
(27) Line
(28) Area
(29) 3D Effects
(30) Image Map
(31) Animation
(32) Interaction
(33) Show the Styles Sidebar
(34) Display Grid
(35) Helplines While Moving

Master View
The Master View toolbar (Figure 349) provides tools for creating, renaming, deleting, and closing 
the master view. This toolbar is only active when Draw is in master view mode.

Figure 349: Master View toolbar

(1) New Master
(2) Rename Master

(3) Delete Master
(4) Close Master View

Media Playback
The Media Playback toolbar (Figure 350) provides the tools required to insert, view, play, and 
listen to audio and video files. The toolbar only becomes active when an audio or video file is 
selected. LibreOffice Draw supports many different media formats depending on the computer 
operating system being used.
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Figure 350: Media Playback toolbar

(1) Insert Audio or Video
(2) Play
(3) Pause

(4) Stop
(5) Repeat
(6) Position

(7) Mute
(8) Volume
(9) View

Options
The Options toolbar (Figure 351) provides tools for editing various settings for newly created 
presentations, for example how objects snap to the grid when being moved or resized.

Figure 351: Options toolbar

(1) Rotation Mode after Clicking 
Object

(2) Display Grid
(3) Display Snap Guides
(4) Helplines While Moving

(5) Snap to Grid
(6) Snap to Snap Guides
(7) Snap to Page Margins
(8) Snap to Object Borders
(9) Snap to Object Points

(10) Allow Quick Editing
(11) Select Text Area Only
(12) Double-click to edit Text
(13) Modify Object with Attributes
(14) Exit All Groups

Redaction
The Redaction toolbar (Figure 352) is used to block portions of a drawing when protecting 
sensitive information. Redaction helps enterprises and organizations to comply with regulations 
on confidentiality or privacy.

When a redacted drawing is exported, any redacted portions are removed from a drawing and 
replaced by redaction blocks of pixels. This prevents any attempt in restoring or copying the 
original contents. A redacted drawing is often exported as PDF for publication or sharing.

Figure 352: Redaction toolbar

(1) Rectangle
(2) Freeform

(3) Redacted Export (White)
(4) Redacted Export (Black)

(5) PDF

Standard
The Standard toolbar (Figure 353) is common to all LibreOffice components providing the most 
common tools used for creating and editing documents using LibreOffice. The Standard toolbar 
differs between LibreOffice components to allow for the toolsets required when creating different 
types of documents.
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Figure 353: Standard toolbar

(1) Load URL
(2) New
(3) Templates
(4) Open
(5) Open Remote
(6) Save
(7) Save As
(8) Email
(9) Edit Mode
(10) Export Directly as PDF
(11) Print Directly
(12) Print
(13) Cut
(14) Copy
(15) Paste

(16) Clone Formatting
(17) Clear
(18) Undo
(19) Redo
(20) Find and Replace
(21) Spelling
(22) Auto Spellcheck
(23) Zoom & Pan
(24) Zoom
(25) Display Grid
(26) Helplines While Moving
(27) Display Views
(28) Views Tab Bar
(29) Format Slide
(30) Master Slide

(31) Start from First Slide
(32) Start from Current Slide
(33) Table
(34) Insert Image
(35) Insert Audio or Video
(36) Insert Chart
(37) Text Box
(38) Insert Special Characters
(39) Vertical Text
(40) Insert Fontwork Text
(41) Insert Hyperlink
(42) Show Draw Function
(43) Interaction
(44) LibreOffice Help
(45) What’s That

Standard (Viewing Mode)
The Standard (Viewing Mode) toolbar (Figure 354) provides tools for saving, editing, and 
distributing a drawing.

Figure 354: Standard (ViewingMode) toolbar

(1) Save As
(2) Edit Mode
(3) Read Only Mode
(4) Email

(5) Export Directly as PDF
(6) EPUB
(7) Print Directly
(8) Print

(9) Copy 
(10) Find and Replace
(11) Zoom

Table
The Table toolbar (Figure 355) provides tools and options to edit and format a table inserted into 
a drawing. This toolbar only becomes active when a table is selected.

Figure 355: Table toolbar
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(1) Table
(2) Border Style
(3) Border Color
(4) Borders (Shift to overwrite)
(5) Area Style/Filling
(6) Fill Color
(7) Merge Cells
(8) Split Cells

(9) Optimize
(10) Align Top
(11) Center Vertically
(12) Align Bottom
(13) Insert Row Above
(14) Insert Row Below
(15) Insert Column Before
(16) Insert Column After

(17) Delete Row
(18) Delete Column
(19) Delete Table
(20) Select Table
(21) Select Column
(22) Select Row
(23) Table Design
(24) Table Properties

Text
The Text toolbar (Figure 356) provides tools to insert text boxes and callouts into a drawing.

Figure 356: Text toolbar

(1) Insert Text Box 
(2) Fit Text in Text Box Size

(3) Callouts
(4) Insert Vertical Text

(5) Fit Vertical Text to Frame
(6) Vertical Callouts

Text Formatting
The Text Formatting toolbar (Figure 357) provides tools for formatting text and alignment 
commands. This toolbar becomes active when text in a text box or graphic object has been 
selected and it automatically replaces the Line and Filling toolbar.

Figure 357: Text Formatting toolbar

(1) Font Name
(2) Font Size
(3) Increase Font Size
(4) Decrease Font Size
(5) Bold
(6) Italic
(7) Underline
(8) Double Underline
(9) Strikethrough
(10) Overline
(11) Superscript
(12) Subscript
(13) Toggle Shadow
(14) Apply outline attribute to font
(15) Clear Direct Formatting

(16) lowercase
(17) UPPERCASE
(18) SMALL CAPITALS

(19) Font Color
(20) Character Highlighting Color
(21) Toggle Unordered List
(22) Toggle Ordered List
(23) Outline Format
(24) Align Left
(25) Align Center 
(26) Align Right 
(27) Justified
(28) Align Top
(29) Center Vertically
(30) Align Bottom

(31) Set Line Spacing
(32) Character Spacing
(33) Increase Paragraph Spacing
(34) Decrease Paragraph 

Spacing
(35) Text direction from left to 

right
(36) Text direction from top to 

bottom
(37) Left-To-Right
(38) Right-To-Left
(39) Select All
(40) Character
(41) Paragraph

Transformations
The Transformations toolbar (Figure 358) provides tools to modify the shape, orientation, or fill of 
selected objects.
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Figure 358: Transformations toolbar

(1) Rotate
(2) Flip
(3) In 3D Rotation Object

(4) Set in Circle (perspective)
(5) Set to circle (slant)
(6) Distort

(7) Interactive transparency tool
(8) Interactive gradient tool

Zoom
The Zoom toolbar (Figure 359) provides tools to reduce or enlarge the screen display of the 
current drawing.

Figure 359: Zoom toolbar

(1) Zoom In
(2) Zoom Out
(3) 100%
(4) Zoom Previous

(5) Zoom Next
(6) Entire Page
(7) Page Width
(8) Optimal View

(9) Object Zoom
(10) Zoom & Pan
(11) Shift

Subtoolbars

3D-Objects
Click on the triangle ▼ to the right of 3D-Objects on the Drawing toolbar to open the 3D-Objects 
subtoolbar (Figure 360), then select a 3D object to add to a drawing. The 3D-Objects subtoolbar 
is identical to the 3D-Objects toolbar available at View > Toolbars on the Menu bar.

Figure 360: 3D-Objects subtoolbar

(1) Cube
(2) Sphere
(3) Cylinder

(4) Cone
(5) Pyramid
(6) Torus

(7) Shell
(8) Half Sphere

Align Objects
To make a drawing look more professional, objects can be aligned with each other using one of 
the following methods to align objects. Select one or more objects before opening the Align 
Objects subtoolbar (Figure 361).

Figure 361: Align Objects subtoolbar
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The Align Objects subtoolbar is also available as a toolbar. Go to View > Toolbars > Align 
Objects on the Main menu bar. The alignment tools available are as follows:

Left

Aligns the left edges of the selected objects. If only one object is selected, the left edge 
of the object is aligned to the left page margin.

Centered

Horizontally centers the selected objects. If only one object is selected, the center of the 
object is aligned to the horizontal center of the page.

Right

Aligns the right edges of the selected objects. If only one object is selected, the right 
edge of the object is aligned to the right page margin.

Top

Vertically aligns the top edges of the selected objects. If only one object is selected, the 
top edge of the object is aligned to the top page margin.

Center

Vertically centers the selected objects. If only one object is selected, the center of the 
object is aligned to the vertical center of the page.

Bottom

Vertically aligns the bottom edges of the selected objects. If only one object is selected, 
the bottom edge of the object is aligned to the bottom page margin.

Basic Shapes
Click on the triangle ▼ to the right of Basic Shapes on the Drawing toolbar to open the Basic 
Shapes subtoolbar (Figure 362), then select a basic shape to add to a drawing.

Figure 362: Basic Shapes subtoolbar

(1) Rectangle
(2) Rectangle, Rounded
(3) Square
(4) Square, Rounded
(5) Parallelogram
(6) Trapezoid
(7) Ellipse
(8) Circle

(9) Circle Pie
(10) Circle Segment
(11) Arc
(12) Block Arc
(13) Isosceles Triangle
(14) Right Triangle
(15) Diamond
(16) Regular Pentagon

(17) Hexagon
(18) Octagon
(19) Cylinder
(20) Cube
(21) Folded Corner
(22) Cross
(23) Frame
(24) Ring

Block Arrows
Click on the triangle ▼ to the right of Block Arrows on the Drawing toolbar to open the Block 
Arrows subtoolbar (Figure 363), then select a block arrow to add to a drawing.
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Figure 363: Block Arrows subtoolbar

(1) Right Arrow
(2) Left Arrow
(3) Down Arrow
(4) Up Arrow
(5) Left and Right Arrow
(6) Up and Down Arrow
(7) Circular Arrow
(8) S-shaped Arrow
(9) Split Arrow

(10) Right or Left Arrow
(11) 4-way Arrow
(12) Corner Right Arrow
(13) Chevron
(14) Pentagon
(15) Striped Right Arrow
(16) Up, right and Down Arrow
(17) Notched Right Arrow
(18) Up and Right Arrow

(19) Right Arrow Callout
(20) Left Arrow Callout
(21) Down Arrow Callout
(22) Up Arrow Callout
(23) Left and Right Arrow Callout
(24) Up and Down Arrow Callout
(25) 4-way Arrow Callout
(26) Up and Right Arrow Callout

Callouts
Click on the triangle ▼ to the right of Callouts on the Drawing toolbar to open the Callouts 
sub-toolbar (Figure 364), then select a callout to add to a drawing.

Figure 364: Callouts subtoolbar

(1) Rectangular Callout
(2) Rounded Rectangular 

Callout

(3) Round Callout
(4) Cloud
(5) Line Callout 1

(6) Line Callout 2
(7) Line Callout 3

Color
The Color subtoolbar (Figure 365) provides tools to edit the color properties of a selected object. 
After selecting an image or graphic to open the Image toolbar, click on Color on the Image 
toolbar.

Figure 365: Color subtoolbar

The tools available on the Color subtoolbar are as follows:

Red

Specifies the proportion of red RGB color components for the selected graphic object. 
Values from -100% (no red) to +100% (full red) are possible.
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Green

Specifies the proportion of green RGB color components for the selected graphic object. 
Values from -100% (no green) to +100% (full green) are possible.

Blue

Specifies the proportion of blue RGB color components for the selected graphic. Values 
from -100% (no blue) to +100% (full blue) are possible.

Brightness

Specifies the brightness for the selected graphic object. Values from -100% (only black) 
to +100% (only white) are possible.

Contrast

Specifies the contrast for viewing the selected graphic image. Values from -100% (no 
contrast at all) to +100% (full contrast) are possible.

Gamma

Specifies the gamma value for the view of the selected object, which affects the 
brightness of the mid-tone values. Values from 0.10 (minimum Gamma) to 10 (maximum 
Gamma) are possible.

Connectors
Click on the triangle ▼ to the right of Connectors on the Drawing toolbar to open the 
Connectors sub-toolbar (Figure 366), then select a connector to add to a drawing.

Figure 366: Connectors subtoolbar

(1) Connector Ends with Arrow
(2) Straight Connector Ends 

with Arrow
(3) Curved Connector Ends with 

Arrow
(4) Line Connector Ends with 

Arrow
(5) Connector
(6) Straight Connector
(7) Curved Connector
(8) Line Connector
(9) Connector Starts with Arrow

(10) Straight Connector starts 
with Arrow

(11) Curved Connector Starts 
with Arrow

(12) Line Connector Starts Arrow
(13) Connector Ends with Circle
(14) Straight Connector Ends 

with Circle
(15) Curved Connector Ends with 

Circle
(16) Line Connector Ends with 

Circle
(17) Connector Starts with Circle

(18) Straight Connector starts 
with Circle

(19) Curved Connector Starts 
with Circle

(20) Line Connector Starts with 
Circle

(21) Connector with Circles
(22) Straight Connector with 

Circle
(23) Curved Connector with 

Circle
(24) Line Connector with Circle

Curves and Polygons
Click on the triangle ▼ to the right of Curves and Polygons on the Drawing toolbar to open the 
Curves and Polygons sub-toolbar (Figure 367), then select a curve or polygon to add to a 
drawing.

Figure 367: Curves and Polygons subtoolbar
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(1) Curve, Filled
(2) Polygon, Filled
(3) Polygon (45°), Filled

(4) Freeform Line, Filled
(5) Curve
(6) Polygon

(7) Polygon (45°)
(8) Freeform Line

Distribute Selection
Distributing objects allows three or more objects to be evenly spaced along a horizontal or 
vertical axis. Objects are distributed using the outermost objects as base points for spacing. 
Select at least three objects, then use one of the following methods to distribute the objects:

• Right-click on the selected objects, then select Distribute Selection from the context 
menu and one of the available options.

• Go to View > Toolbars on the Menu bar and select Distribute Selection to open the 
Distribute Selection subtoolbar (Figure 368).

• Go to Shape > Distribute Selection on the Menu bar and select a distribution option.

• Right-click on the selected objects and select Distribute Selection from the context 
menu, then select a distribution option.

Figure 368: Distribute Selection subtoolbar

The Distribute subtoolbar is also available as a toolbar. Go to View > Toolbars > Distribute 
Selecttion on the Main menu bar. The distribution options available are as follow:

Horizontal Left

Distributes the selected objects so that the left edges of the objects are evenly spaced 
from one another.

Horizontal Center

Distributes the selected objects so that the horizontal centers of the objects are evenly 
spaced from one another.

Horizontal Spacing

Distributes the selected objects horizontally so that the objects are evenly spaced from 
one another.

Horizontal Right

Distributes the selected objects so that the right edges of the objects are evenly spaced 
from one another.

Vertical Top

Distributes the selected objects so that the top edges of the objects are evenly spaced 
from one another.

Vertical Center

Distributes the selected objects so that the vertical centers of the objects are evenly 
spaced from one another.

Vertical Spacing

Distributes the selected objects vertically so that the objects are evenly spaced from one 
another.
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Vertical Bottom

Distributes the selected objects so that the bottom edges of the objects are evenly 
spaced from one another.

Flowchart
Click on the triangle ▼ to the right of Flowchart on the Drawing toolbar to open the Flowchart 
sub-toolbar (Figure 369), then select a flowchart shape to add to a drawing.

Figure 369: Flowchart subtoolbar

(1) Flowchart: Process
(2) Flowchart: Alternate 

Process
(3) Flowchart: Decision
(4) Flowchart: Data
(5) Flowchart: Predefined 

Process
(6) Flowchart: Internal Storage
(7) Flowchart: Document
(8) Flowchart: Multidocument
(9) Flowchart: Terminator
(10) Flowchart: Preparation

(11) Flowchart: Manual Input
(12) Flowchart: Manual Operation
(13) Flowchart: Connector
(14) Flowchart: Off-page 

Connector
(15) Flowchart: Card
(16) Flowchart: Punched Tape
(17) Flowchart: Summing 

Junction
(18) Flowchart: Or
(19) Flowchart: Collate
(20) Flowchart: Sort

(21) Flowchart: Extract
(22) Flowchart: Merge
(23) Flowchart: Stored Data
(24) Flowchart: Delay
(25) Flowchart: Sequential 

Access
(26) Flowchart: Magnetic Disc
(27) Flowchart: Direct Access 

Storage
(28) Flowchart: Display

Figure 370: Fontwork Shape subtoolbar

(1) Plain Text
(2) Wave
(3) Inflate
(4) Stop
(5) Curve Up
(6) Curve Down
(7) Triangle Up
(8) Triangle Down
(9) Fade Right
(10) Fade Left

(11) Fade Up
(12) Fade Down
(13) Slant Up
(14) Slant Down
(15) Fade Up and Right
(16) Fade Up and Left
(17) Chevron Up
(18) Chevron Down
(19) Arch Up (Curve)
(20) Arch Down (Curve)

(21) Arch Left (Curve)
(22) Arch Right (Curve)
(23) Circle (Curve)
(24) Open Circle (Curve)
(25) Arch Up (Pour)
(26) Arch Down (Pour)
(27) Arch Left (Pour)
(28) Arch Right (Pour)
(29) Circle (Pour)
(30) Open Circle (Pour)
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Fontwork Shape
Clicking on the triangle ▼ to the right of Fontwork Shape on the Fontwork toolbar opens the 
Fontwork Shape subtoolbar (Figure 370). Select the required shape to change how a Fontwork 
text shape appears in a drawing.

Image Filter
Clicking on the triangle ▼ to the right of Filter on the Image toolbar opens the Image Filter 
sub-toolbar (Figure 371). Select the required filter to change how an image appears on the 
display.

Figure 371: Image Filter subtoolbar

The filters available on the Image Filter subtoolbar are as follows:

Invert

Inverts the color values of a color image, or the brightness values of a greyscale image. 
Apply the filter again to revert the effect.

Smooth

Softens or blurs the image by applying a low pass filter.

Sharpen

Sharpens the image by applying a high pass filter.

Remove Noise

Removes noise by applying a median filter.

Solarization

Opens a dialogue box for defining solarization. Solarization refers to an effect that looks 
like what can happen when there is too much light during photo development. The colors 
become partly inverted.

Aging

All pixels are set to their gray values, and then the green and blue color channels are 
reduced by the amount specified. The red color channel is not changed.

Posterize

Opens a dialogue box to determine the number of poster colors. This effect is based on 
the reduction of the number of colors. It makes photos look like paintings.

Pop Art

Converts an image to a pop-art format.

Charcoal Sketch

Displays the image as a charcoal sketch. The contours of the image are drawn in black, 
and the original colors are suppressed.

Relief

Displays a dialogue box for creating reliefs. Selecting the position of the imaginary light 
source determines the type of shadow created, and how the graphic image looks in 
relief.
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Mosaic

Joins small groups of pixels into rectangular areas of the same color. The larger the 
individual rectangles are, the fewer details the graphic image has.

Lines and Arrows
Click on the triangle ▼ to the right of Lines and Arrows on the Drawing toolbar to open the 
Lines and Arrows sub-toolbar (Figure 372), then select a line or arrow to add to a drawing.

Figure 372: Lines and Arrows subtoolbar

(1) Line Ends with Arrow
(2) Line with Circle/Arrow
(3) Line with Square/Arrow
(4) Line with Arrows

(5) Line Starts with Arrow
(6) Line with Arrow/Circle
(7) Line with Arrow/Square
(8) Insert Line

(9) Dimension Line
(10) Line (45°)

Position
Click on the triangle ▼ to the right of Arrange on the Line and Filling toolbar to open the Position 
subtoolbar (Figure 373), then select the position of a selected object in a drawing.

Figure 373: Position subtoolbar

(1) Bring to Front
(2) Bring Forward
(3) Send Backward

(4) Send to Back
(5) In Front of Object
(6) Behind Object

(7) Reverse

Stars and Banners
Click on the triangle ▼ to the right of Stars and Banners on the Drawing toolbar to open the 
Stars and Banners sub-toolbar (Figure 374), then select a star or arrow to add to a drawing.

Figure 374: Stars and Banners subtoolbar

(1) 4-Point Star
(2) 5-Point Star
(3) 6-Point Star
(4) 8-Point Star

(5) 12-Point Star
(6) 24-Point Star
(7) Explosion
(8) Vertical Scroll

(9) Horizontal Scroll
(10) Signet
(11) Doorplate
(12) 6-Point Star, Concave

Symbol Shapes
Click on the triangle ▼ to the right of Symbol Shapes on the Drawing toolbar to open the 
Symbol Shapes sub-toolbar (Figure 375), then select a symbol shape to add to a drawing.
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Figure 375: Symbol Shapes subtoolbar

(1) Smiley Face
(2) Heart
(3) Sun
(4) Moon
(5) Cloud
(6) Lightning Bolt

(7) Flower
(8) Prohibited
(9) Puzzle
(10) Square Bevel
(11) Octagon Bevel
(12) Diamond Bevel

(13) Double Bracket
(14) Left Bracket
(15) Right Bracket
(16) Double Brace
(17) Left Brace
(18) Right Brace
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Draw Guide

Working With Vector Graphics

About this book:

This book covers the main features of Draw, the vector graphics component of LibreOffice. 
Using Draw, a wide variety of graphical images can be created.

Vector graphics store and display a picture as simple geometric elements such as lines, circles, 
and polygons rather than as a collection of pixels (points on the screen). This permits simpler 
storage and supports precise scaling of the picture elements.

Draw is fully integrated into LibreOffice. This simplifies exchanging graphics with Writer, Calc, 
and Impress. Images can be exported in many formats for use in other programs.

About the authors:

This book was written by volunteers from the LibreOffice community. Profits from the sales of 
the printed edition are used to benefit the community.

A PDF version of this book can be downloaded free from:
https://documentation.libreoffice.org/en/

About LibreOffice:

LibreOffice is the free, libre, and open source personal productivity suite from The 
Documentation Foundation. It runs on Windows, macOS, and GNU/Linux. Support and 
documentation is free from a large, dedicated community of users, contributors, and developers.

Get involved as a volunteer and work in many areas: development, quality assurance, 
documentation, translation, user support, and more.

Download LibreOffice for free from:
https://libreoffice.org/downloads/

For commercial use:

Work with certified LibreOffice professionals for any business needs, from deployment or 
conversion from other office suits, staff training, or custom development needs.

For information on professional support services, go to
https://www.libreoffice.org/get-help/professional-support/

https://documentation.libreoffice.org/en/
https://libreoffice.org/downloads/
https://www.libreoffice.org/get-help/professional-support/
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