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Formula and Equation Editor for LibreOffice



Who is this guide for?

LibreOffice Math module is the formula and equation editor included with LibreOffice. Any
LibreOffice user who wants to learn how to insert formulas and equations using Math will find the
Math User Guide very useful.

In LibreOffice, formulas can be inserted as objects into the LibreOffice documents created using
Writer, Impress, Draw, or Calc. Regardless of the document type, formula objects are edited
using Math.

For more information and an introduction to all of the LibreOffice modules, see the Getting
Started Guide.

}? Note

Math is not capable of evaluating mathematical equations or performing calculations.
For more information on formulas and equations, see the Calc Guide.

What is LibreOffice?

LibreOffice is a freely available, fully-featured, open source office productivity suite that is
compatible with other major office suites and is available on a variety of platforms. The native file
format used is Open Document Format (ODF). However, LibreOffice can also open and save
documents in many other formats, including those used by versions of Microsoft Office. For more
information, see the Getting Started Guide.

Minimum requirements for using LibreOffice

LibreOffice 25.2 requires one of the following operating systems:

Linux x64 (deb) and Linux x64 (rpm)

Mac OS X (Aarch64/Apple Silicon)

macOS x86_64 (10.14 Mojave or higher)
Windows x86_64 (Windows 7 or newer required)

For a detailed list of requirements and operating systems supported, see the LibreOffice website,
https://www.libreoffice.org/get-help/system-requirements/.

How to get LibreOffice

Computers and laptops

Versions of LibreOffice for Windows, Linux, and macQOS are freely available and can be
downloaded from the LibreOffice website at https://www.libreoffice.org/download.

For Linux users LibreOffice is included free with many of the latest distributions, for example
Ubuntu. Linux versions of LibreOffice may differ in a few features from the descriptions used in
this user guide.

LibreOffice is also available for Windows in the Microsoft Store and for macOS in the Apple App

Store at a low and attractive price. These versions are free software (as in open source), but the
small charge covers the cost of placing LibreOffice in the app stores. The profits from this sale of
LibreOffice are invested to support the development of the LibreOffice project.
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Tablets, iPads and Chromebooks

To use LibreOffice on tablets, iPads, or Chromebooks, a LibreOffice based app has to be
downloaded and installed. The app is called Collabora Office, which uses the same technology
as LibreOffice and is very similar in operation to LibreOffice. For more information, go to the
Collabora Office website at https://www.collaboraoffice.com.

Installing LibreOffice

Information on installing LibreOffice on the various supported operating systems can be found at
this web page: https://www.libreoffice.org/get-help/install-howto/. If LibreOffice is acquired
through official app stores, follow the installation instructions provided by the store.

Setting up and customizing LibreOffice

After installation, change the default settings (options) in LibreOffice to suit working requirements
and preferences. Go to Tools > Options on the Menu bar (mac OS LibreOffice > Preferences)
and change the settings as required.

Settings are described in LibreOffice Help and the Getting Started Guide. These two sources
provide information on how to customize menus, toolbars, and keyboard shortcuts in Draw, add
new menus and toolbars, and assign macros to events.

_Tip

Some settings are intended for power users and programmers. If it is difficult to

understand what an option does, LibreOffice recommended leaving an option on its

default setting unless instructions in this user guide recommend changing the
setting.

Extensions and add-ons

Functionality can be added to LibreOffice with extensions and add-ons. Several extensions are
installed with the program and other extensions from the official extensions repository,
https://extensions.libreoffice.org/ or various other sources. See the Getting Started Guide for
more information on installing extensions and add-ons.

Where to get more help

This user guide, other LibreOffice user guides, the Help system, and user support systems
assume that users are familiar with computers and basic functions such as starting a program,
opening and saving files.

Help system

LibreOffice comes with an extensive Help system and is used as the first line of support.
Windows and Linux users can choose to download and install the offline Help for use when not
connected to the Internet. Offline Help is installed with the MacOS version of LibreOffice.

To display the LibreOffice Help, press F1 or go to Help > LibreOffice Help on the Menu bar. If
offline help is not installed on a computer, but connected to the Internet, a dialog opens giving
the option to Read Help Online. Select this option and the default web browser opens at the
LibreOffice online help pages in the LibreOffice website.
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The Help menu includes links to other LibreOffice information and support facilities. The Help
menu also includes links to other LibreOffice information and support resources.

What's This?
For quick tips when a toolbar is visible, place the cursor over a tool icon to see a small
tooltip box with a brief explanation of the tool function. For a more detailed explanation,
select Help > What's This? Also Extended Tips can be activated by going to Tools >
Options > LibreOffice > General > Help (macOS LibreOffice > Preferences >
LibreOffice > General > Help) on the Menu bar and selecting the option Extended Tips.
Extended tips provide a brief description about tools and commands. To display an
extended tip, use the keyboard Shift+F1, then move the cursor onto a tool or
command.

User Guides

Opens the default browser at the Documentation page of the LibreOffice website
https://documentation.libreoffice.org/en/english-documentation/. This web page gives
access to the LibreOffice User Guides and other useful information that can be opened in
the default browser. Also, the LibreOffice User Guides are available in PDF format as a
free download, or to buy as printed copies.

Show Tip of the Day

Opens a small window with a random tip on how to use LibreOffice.

Search Commands
Opens a window where typing a few letters, or the name of a Menu bar command, for
example, quickly finds where the command is located. Clicking on a command in the
resulting list may open a relevant dialog or have other effects.

Get Help Online
Opens the default browser at the Ask LibreOffice forum of questions and answers from
the LibreOffice community, https://ask.libreoffice.org/en/questions/.

Send Feedback

Opens the default browser at the Feedback page of the LibreOffice website
https:/www.libreoffice.org/get-help/feedback/. From this web page, bugs can be
reported, new features suggested and communicated with other users in the LibreOffice
community.

Restart in Safe Mode
Opens a dialog window giving options to restart LibreOffice and reset the software to its
default settings. Restarting in safe mode also provides an opportunity to restore
LibreOffice from a backup.

Get Involved
Opens the default browser at the Get Involved page of the LibreOffice website,
https://www.libreoffice.org/community/get-involved/. Choose a topic of interest to help
improve the program.

Donate to LibreOffice
Opens the default browser at the Donation page of the LibreOffice website,
https://donate.libreoffice.org/ providing an opportunity to make a donation to support
LibreOffice.

License Information
Ouitlines the licenses under which LibreOffice is made available.
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Check for Updates

Opens a dialog and checks the LibreOffice website for updates to version of the
software. The dialog provides an opportunity to download and install any updates to
LibreOffice.

About LibreOffice

Opens a dialog and displays information about the version of LibreOffice and the
operating system being used. This information is often requested if the community is
asked for help or assistance with the software (in macOS, this option is found under
LibreOffice on the Menu bar}.

Other free online support

The LibreOffice community not only develops software, but provides free, volunteer-based
support. See Table 1 and the web page https://www.libreoffice.org/get-help/. For comprehensive
online support from the community, look at mailing lists and the Ask LibreOffice website,
https://ask.libreoffice.org/en/questions/. Other user websites also offer free tips and tutorials.

Table 1: Free support for LibreOffice users

Free LibreOffice support

FAQs Answers to frequently asked questions
https://wiki.documentfoundation.org/Fagq.

Mailing lists Free community support is provided by a network of experienced

users https://www.libreoffice.org/get-help/mailing-lists/.

Free community assistance is provided in a Question & Answer
formatted web service. Search similar topics or open a new one in
Questions & Answers | https://ask.libreoffice.org/en/questions.

and Knowledge Base | The service is available in several other languages; just replace /en/
with de, es, fr, ja, ko, nl, pt, tr, and many others in the web address
above.

The LibreOffice website in various languages
https://www.libreoffice.org/community/nlc/.

Native language Mailing lists for native languages

support https://wiki.documentfoundation.org/Local_Mailing_Lists.

Information about social networking
https://wiki.documentfoundation.org/Website/Web_Sites _services.

Information about available accessibility options.
https://www.libreoffice.org/get-help/accessibility/.

Another forum that provides support for LibreOffice, among other
open source office suites https://forum.openoffice.org/en/forum/.

Accessibility options

OpenOffice Forum

Paid support and training

Support and training is available through service contracts from a vendor or consulting firm
specializing in LibreOffice. For information about certified professional support, see The
Document Foundation website: https://www.documentfoundation.org/gethelp/support/.

For schools, educational and research institutions, and large organizations, see
https://www.libreoffice.org/download/libreoffice-in-business/.
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What you see may be different

lllustrations

LibreOffice runs on Windows, Linux, and macOS operating systems. Each operating system has
several versions and can be customized by users (fonts, colors, themes, window managers).
The illustrations in this user guide were taken from a variety of computers and operating
systems. Therefore, some illustrations will not look exactly the same as displayed on a computer
monitor.

Also, some of the dialogs may differ because of the settings selected in LibreOffice. Either use
dialogs from the computer system (default) or dialogs provided by LibreOffice. To change to
using LibreOffice dialogs:

1) Go to Tools > Options > LibreOffice > General (macOS LibreOffice > Preferences >
LibreOffice > General) on the Menu bar to open the dialog page for general options
(Figure 1).

2) Select the option Use LibreOffice dialogs in Openl/Save dialogs to display the
LibreOffice dialogs on a computer display.

3) Click OK to save the settings and close the dialog.

Options - LibreOffice - General *
T 3 search Help
B LibreOffice [l Extendexd tips
| User Diata (] Wiarn if bocal help is not installed
e
View Opeeny/S.ave Disbogs
Print [ Use LibreCHffice disogs
Paths
Fonts Docummient Status
Security [ Printing sets “document modified” status
Arpernee Year (Two Digits
Cessimil
Advanced Interpret as years between 1030 -3 and 2000
i‘“l"" 'Dspdam Help Improve LibreOfHice
il
h F i
OpenclL [ send crash reparts to The Docurment Foundation
B Load/Save LibwresOf i Qhusichestarter
[ Languages and Locales [ Load LibweCfice during system start-up
B LibreCihce Math e
B LibreOffics Base Libre0Hfice File Associstions
& Charts Windows Default apps

Internet
I:I Perform check for default file associations on start-up

Figure 1: Options LibreOffice dialog — General page

Icons

The LibreOffice community has created icons for several icon sets, for example Breeze, Colibre,
and Sifr. LibreOffice users can select a preferred set of fonts to use. The icons used to illustrate

tools available in LibreOffice may differ from the ones used in this user guide. Icons in this user

guide have been taken from a LibreOffice installation set to display the Colibre set of icons.

Change the icon set used in a LibreOffice installation as follows:

1) On Linux and Windows operating systems, go to Tools > Options > LibreOffice > View
(macOS LibreOffice > Preferences > LibreOffice > View) on the Menu bar to open the
dialog page for view options (Figure 2).

2) In Icon Theme, select a font from the options available in the drop-down list.
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3) In Icon Size, select the required size from the drop-down lists for Toolbar, Notebookbar
and Sidebar.

4) Click OK to save the settings and close the dialog.

r
Options - LibreOffice - View *
Type to search leon Theme Graphics Chitpast

B LibreOffice Therme ||'_,|:|||b|g :l il Use hardware acceleratsan
Llser Diata — - Lkse anti-shaung
General lcon Size B s Sica for all rendering
Toslbar |La-'ge p | B Force Skia software rendering
Print — Sida s cumrently enabied.
Notebaookbar: |Lamge w
Paths Lag [~ Copy siia.log
Fonts Sidebar ||..1|'1]I"' j
Security Fomt Lists
Monsse :
Appearance B Show preview of fonts
Accessibility Middle button: |ﬂu1.umd!u. scrolleng i | B Screen font antiakasing
Advanced from: B pixels
Basic IDE
Online Update
OpenCL
B Load Save
B Languages and Locales
B LibreDffice Math

T S S Domrn

Figure 2: Options LibreOffice dialog — View page

/? Notes

Some Linux distributions include LibreOffice as part of the installation and may not
include all the icon sets mentioned above. You should be able to download other
icon sets from the software repository for your Linux distribution.

The Galaxy, Oxygen, and Tango icon sets are no longer included as part of the
standard installation package for Windows, macOS, or Linux. You can download and
install them as extensions from https://extensions.libreoffice.org/.

Some of the previously included gallery sets are now available only as extensions.
For example, the People Gallery is available from
https://extensions.libreoffice.org/en/extensions/show/people-gallery.

Using LibreOffice on macOS

Some keystrokes and menu items are different on computers operating macOS from computers
using Windows and Linux operating systems. Table 2 gives some common substitutions used in

this user guide. For more information on keyboard shortcuts, see LibreOffice Help.

Table 2: Example of macOS keyboard shortcuts

Windows or Linux

macOS equivalent

Effect

Tools > Options

LibreOffice > Preferences

Access to setup options

Right-click

Ctr l+click and/or right-click
depending on computer setup

Opens a context menu

CtrlorControl

and/or Cmd or Command,
depending on keyboard

Used with other keys

Alt

and/or Alt or Option
depending on keyboard

Used with other keys

Fi11

Gg)+T

Open the Styles deck in the
Sidebar

Preface | 11



https://extensions.libreoffice.org/
https://extensions.libreoffice.org/en/extensions/show/people-gallery

Who wrote this user guide?

This user guide was written by volunteers from the LibreOffice community. Profits from sales of
the printed edition are used to benefit the community.

Frequently asked questions

How is LibreOffice licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public
License (MPL), see https://www.libreoffice.org/about-us/licenses/. It is based on code
from Apache OpenOffice made available under the Apache License 2.0 but also includes
software that differs from version to version under a variety of other Open Source
licenses. New code is available under LGPL 3.0 and MPL 2.0.

Can LibreOffice be distributed to anyone?

Yes.

Can LibreOffice be sold?
Yes.

Can LibreOffice be used in a business?
Yes.

How many computers can LibreOffice be installed on?
As many as required.

Is LibreOffice available in different languages?

LibreOffice has been translated (localized for more than 80%, both Ul and Help) into over
46 languages, so a required language is probably supported. Localization is well under
way for another 30+ languages (50-80%) and for another 50+ languages help is more
than welcome. In addition, over 70 spelling, hyphenation, and thesaurus dictionaries are
available for languages and dialects that do not have a localized program interface. The
dictionaries are available from the LibreOffice website at: https://www.libreoffice.org/.

How can LibreOffice be freely available?

LibreOffice is developed and maintained by volunteers and has the backing of several
organizations. LibreOffice also relies upon donations from its users. To make a donation,
go to the following web page: https://www.libreoffice.org/donate/.

Can the programming code from LibreOffice be used when developing a software
application?
Yes, but follow the parameters set in the MPL and/or LGPL. Read the licenses:
https://lwww.mozilla.org/MPL/2.0/.

Why is Java required to run LibreOffice and is it written in Java?

LibreOffice is not written in Java, but written in the C++ language. Java is one of several
languages that can be used to extend the software. The Java JDK/JRE is only required
for some features. The most notable one is the HSQLDB relational database engine.

Java is available at no cost. More information and download links to the appropriate
edition for an operating system can be found at:
https://java.com/en/download/manual.jsp.
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ﬁ Note

If LibreOffice features requiring Java are to be used, it is important that the correct
32-bit or 64-bit edition matches the installed version of LibreOffice. If Java is not to
be used, nearly all of the LibreOffice features can still be used.

How can users contribute to LibreOffice?

Users can help with the development and user support of LibreOffice in many ways, and
there is no need to be a programmer. To start, check out this webpage:

https://www.libreoffice.org/community/get-involved/. An interactive web page that guides
users in contributing with their best skills available at https://whatcanidoforlibreoffice.org.

Can the PDF copy of this user guide be distributed, or printed and copies sold?

Yes, as long as requirements are met for one of the licenses in the copyright statement at
the beginning of this user guide. There is no need to request special permission.
LibreOffice requests that users share with the LibreOffice project some of the profits
made from sales of user guides, in consideration of all the work that LibreOffice
volunteers have put into producing user guides.

What is new in LibreOffice 25.2?

The LibreOffice 25.2 Release Notes are available at this link
https://wiki.documentfoundation.org/ReleaseNotes/25.2. Also available at this link are the
release notes for earlier versions of LibreOffice giving more information on the features included
in LibreOffice.
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Math Guide 25.2

Chapter 1,
Creating and Editing
Formulas



Introduction

Math is a formula editor included as a separate LibreOffice module and is used to create or edit
formulas (equations), in a symbolic form. These formulas can then be used in LibreOffice
documents or as stand-alone objects. An example of the opening window for Math is shown in
Figure 3. When using Math, the Elements panel in the Sidebar also opens (Figure 4).

7 Note

The images used in this document are examples ONLY. Actual images displayed
when using Math does depend on computer setup and the computer operating
system being used.

When creating formulas in Math, a markup language is used to represent formulas and this
markup language is designed to be easily read wherever possible. For example, when the text
df(x) over dx = ln(x)+tan™-1(x"2) into the Formula Editor, the following formula appears
in the Formula Preview.

x)

d
fdx

Using the Formula Editor in Math, a formula is created as a separate file for insertion into a
formula library. Alternatively, formulas can be directly inserted into a document when using
Writer, Calc, Impress, or Draw. For more information see the user guides for the specific
LibreOffice module being used.

=In(x)+tan""(x°)

B Untitled 1 — LibreOffice Math =

File Edit View Format Tools Window Help
R-E-BE-20& XBRo-C-0iaaaaQd olly w

: Hements T X

Unary/Binary Operators <]

+d -0 =0 =0

a+0 0-0 00 axQ

@S g ®mos

0«0 3 & 0:0

x)

df 5r=1n(x)+tan™ () 0/0 Oel Lel TeQ

Oe0 Oed 0-0 Y4
oy

-0 0aAQ ava

(1)

df(x) over dx = In(x)+tannr-1(xA2)

(2) (3)

Figure 3: Math opening window
(1) Formula Preview (2) Formula Editor (3) Sidebar
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O<0 0OJO 0.0 0O
040 o-»0 0--0 Q-0

:I g j |CDrrespDnd5 To (Left)

=0 =040 Ud=0

d<0 O=0 O< Ozx4d
Q=<0 O=0 0«0 Ox0

Figure 4: Sidebar Elements panel — Relations page

Formulas in documents or files

Formulas as separate documents or files

As characters are entered the markup language, the formula being created appears in the
Formula Preview window during and after input of the markup language, as shown in Figure 3.
For more information on creating formulas as a separate document or file, see “Creating
formulas” on page 19.

1) Use one of the following methods to create a formula as a separate document or file:
— In the LibreOffice Start Center, click on Math Formula.
— Go to File > New > Formula on the Menu bar.

— On the Standard toolbar, click the triangle to the right of the New icon and select
Formula from the context menu.

— When Math is open, use the keyboard shortcut Ctr I+N (macOS g]+N).
2) When the formula is completed as a new document or file, save the formula in ODF
format.
Formulas in LibreOffice documents

A formula can also be created and inserted directly into a Writer, Calc, Draw, or Impress
document. An example of creating a formula in a Writer document is shown in Figure 5. The
formula box is automatically selected ready for a formula to be entered or edited.
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df(x) over dx = In(x)+tann-1(xA2) into the Formula Editor, the following formula appea:
in the Formula Preview:f
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Using the Formula Editor in Math, a formula is created as a separate file for insertion into a
formula library. Alternatively, formulas can be directly inserted into a document when using
Writer, Calc, Impress, or Draw. For more information see the user guides for the specific
LibreOffice module being used.|

1721

| f( x) over dx = Lln(x)+tann-1(x"2 )

Figure 5: Example of creating a formula in Writer

Depending on the LibreOffice module being used when inserting a formula, the cursor position
changes of where to insert the formula.

* In Writer, click in the paragraph where the formula is being inserted.
 In Calc, click in the spreadsheet cell where the formula is being inserted.

* In Draw and Impress, the formula is automatically inserted into the center of the drawing
or slide.

Formulas are inserted as OLE objects into documents, as follows:

1) Go to Insert > OLE Object > Formula Object on the Menu bar to open the Formula
Editor.

2) Alternatively, go to Insert > OLE Object > OLE Object on the Menu bar to open the
Insert OLE Object dialog (Figure 6).

a) Select Create new, then select LibreOffice XX Formula in Object Type.
b) Click OK to open the Formula Editor.
3) Create or edit the formula in the Formula Editor.

4) When the formula has been created or edited, close the Formula Editor using one of the
following methods:

— Press the Esc key.

— Click outside the formula in the document. Double-click on the formula in the
document to open the Formula Editor again to edit the formula.
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Figure 6: Insert OLE Object dialog
For more information on inserting formulas as OLE objects, refer to the following:

Chapter 2, Formulas in Writer
Chapter 3, Formulas in Calc, Draw, and Impress
Writer, Calc, Draw, or Impress Guides.

_Tips

If formulas are frequently inserted into documents, it is recommended to add
Formula Object tool to the Standard toolbar, or create a keyboard shortcut. For
more information, see Chapter 4, Customization or the Getting Started Guide.

Using the Elements panel on the Sidebar, or the context menus to create a formula
is a convenient way to learn the markup language used used to create formulas.

When using the Elements panel on the Sidebar, it is recommended to have
Extended Tips selected in LibreOffice Options. Extended Tips helps in identifying the
categories and symbols used in formulas. Go to Tools > Options > LibreOffice >
General (macOS LibreOffice > Preferences > LibreOffice > General) on the Menu
bar and select Extended Tips in the Help section.

Creating formulas

Formulas are created using one of the following methods:

* In the Elements panel on the Sidebar (Figure 4 on page 17), select a category from the
context menu, then select a formula element from the available options.

* Right-click in the Formula Editor (Figure 3 on page 16) and select a category from the
context menu, then select a formula element from the drop-down list.

» Enter markup language directly in the Formula Editor.

Elements panel

The Elements panel (Figure 4 on page 17) on the Sidebar is a visual tool for creating and
formatting formulas. It organizes mathematical symbols and operators into categories, which are

available in a drop-down list for each category.
1) Select View > Elements on the Menu bar to open the Elements panel in the Sidebar.
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2) Select the category required for the formula from the Categories drop-down list at the top
of the Elements panel.

3) Select the symbol required from the options available in the Elements panel. The
available symbols change according to the selected category.

4) After selecting a symbol, the symbol appears in Formula Preview and the Formula Editor
is updated with the markup language used for the selected symbol.

5) Alternatively, select an example from the Examples list in the Categories drop-down list
on the Sidebar (Figure 7).

Elements n

187 (2)ll~e™[[8 7l

Figure 7: Sidebar Elements panel — Examples page

Context menu

The Formula Editor also provides a context menu to access categories and markup language
options when creating a formula. An example is shown in Figure 8.

1) Right-click in the Formula Editor to open the context menu.
2) Select a category from the options listed in the context menu.
3) Select a markup language option from the options available in the drop-list.

)? Note

The Elements panel and the context menu in the Formula Editor provide the most
common options and symbols used in formulas. Other options and symbols not listed
have to be entered manually using markup language. For a complete list of
commands and symbols available in Math, see Appendix A, Commands Reference.
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Figure 8: Example of Category Options in Formula Editor

Markup language

Markup language is entered directly into the Formula Editor. For example, typing 5 times 4 into
the Formula Editor creates a simple formula. Using markup language is the recommended
method for creating formulas. Table 3 shows examples of using markup language to enter
commands. For a full list of commands that can be used in the Formula Editor, see Appendix A,
Commands Reference.

Table 3: Example commands using markup language

Display Command Display Command
a=b a=b Ja sqrt {a}
a’ a2 a, an
ff(x)dx int f(x) dx > a, sum a n
a<b a<=b o0 infinity
axb a times b Xy x cdot y
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Greek characters

Using markup language

Greek characters are commonly used in formulas, but cannot be entered into a formula using
the Elements panel in the sidebar, or the context menu in the Formula Editor. Use English
names for Greek characters in markup language when entering Greek characters into a formula.
See Appendix A, Commands Reference for a list of Greek characters that can be entered using
markup language.

* For a lowercase Greek character, type a percentage % sign, then type the character
name in lowercase using the English name. For example, typing %lambda creates the
Greek character A.

* For an UPPERCASE Greek character, type a percentage % sign, then type the character
name in UPPERCASE using English. For example, typing %LAMBDA creates the Greek
character A.

» For an italic Greek character, type a percentage % sign followed by the i character, then
type the English name of the Greek character in lower or UPPER case. For example,
typing %iTHETA creates the italic Greek character @.

Symbols dialog
Greek characters can also be entered into a formula using the Symbols dialog.
1) Make sure the cursor is at the correct position in the Formula Editor.

2) Go to Tools > Symbols on the Menu bar, or click Symbols in the Tools toolbar
(Figure 9) to open the Symbols dialog.

Tools v X
RQeaQaQ QIS 9

Figure 9: Tools toolbar
3) Select Greek in the Symbol set drop-down list (Figure 10).
Symbols X

Symbol set:

BeraezH
® I KAMNE
OnNOPITYS®
X¥YQa§py s
e {n 8 1 x A
pvEompce
T UVvVO XY VYo
g ¢ w o €

ALPHA

Figure 10: Symbols dialog — Greek
4) For italic characters, select iGreek in the Symbol drop-down list (Figure 11).
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Figure 11: Symbols dialog — iGreek

5) Double-click the Greek character required, or select the Greek character and click Insert.
When selected, the name of the character is shown below the symbol list.

6) Click on Close to close the Symbols dialog.

Formula examples

Example 1
A simple formula 5X4 is created in Math as follows:

1) Make sure the cursor is located and flashing in the Formula Editor.
2) Enter Multiplication symbol using one of the following methods:

— Select the category Unary/Binary Operators in the Elements panel on the Sidebar,
then select the Multiplication icon.

— Right-click in the Formula Editor and select Unary/Binary Operators, then a times b
from the context menu.

— Using markup language, type 5 times 4 in the Formula Editor.

}? Note

The first two methods above place the formula text <?> times <?>in the Formula
Editor and the symbol O xO appears in the document. The third method above,
using markup language in the Formula Editor, places the formula directly into the
document and it is not necessary to carry out the following steps.

3) Select the first placeholder <?> before the word times in the Formula Editor and replace
with the character 5. The formula in the document updates automatically.

4) Select the second placeholder <?> after the word times in the Formula Editor and
replace it with the character 4. The formula in the document updates automatically.

}? Note

If necessary, to prevent a formula in a document from updating automatically, go to
View on the Menu bar and deselect AutoUpdate Display. The formula can be
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updated manually when necessary. Press the F9 key or select View > Update on the
Menu bar.

Example 2

The formula for Pi m =~ 3.14159 where value is rounded to 5 decimal places is created as
follows. The Greek character (pi) is known, but the required markup language Similar Or
Equal symbol = is not known.

1) Make sure the cursor is located and flashing in the Formula Editor.
2) Enter %p1i in the Formula Editor to create the Greek character for Pi (11).

3) Select the category Relations, then select the symbol Is Similar Or Equal using one
of the following methods:

— In the Elements panel on the Sidebar, select Relations from the drop-down list and
then select the Is Similar Or Equal icon O=0.

— Right-click in the Formula Editor and select Relations > a simeq b from the context
menu.

4) Delete the first placeholder symbol <?> before the word simeq in the Formula Editor.

5) Select the second placeholder symbol <?> after the word simeq in the Formula Editor
and enter 3.14159 to delete the second placeholder symbol. The formula now appears in
the document.

Editing formulas

How a formula is edited and opening formula editing mode depends on whether the formula is in
Math or another LibreOffice module.

1) To select the formula and open Formula Editor using one of the following methods:

— In Math, double-click on a formula element in the formula that appears in Formula
Preview to select the formula element in the Formula Editor, or directly select a
formula element in the Formula Editor.

— In Writer, Calc, Impress, or Draw, double-click on the formula, or right-click on the
formula and select Edit in the context menu, to open the Formula Editor and enter
editing mode. The cursor is positioned at the start of the formula in the Formula Editor.

/? Note

If a formula element cannot be selected using the cursor, click on Formula Cursor in
the Tools toolbar (Figure 9 on page 22) to activate the formula cursor.

2) Select the formula element to be changed using one of the following methods:

— Click on the formula element in Formula Preview, then position the cursor at the
beginning of the formula element in Formula Editor and select the formula element.

— Double-click on the formula element in Formula Preview to select the formula element.

— Position the cursor in the Formula Editor at the formula element to edited, then select
the formula element.

— Double-click directly on the formula element in the Formula Editor to select it.
3) Make all necessary changes to the selected formula element.

4) Go to View > Update on the Menu bar, press the F9 key, or click on Update on the Tools
toolbar to update the formula.
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5) Save the changes to the formula using one of the following methods:
— In Math, save the changes to the formula after editing before closing Math.

— In Writer, Calc, Impress, or Draw, click anywhere in the document away from the
formula to exit editing mode and save the document.

Formula layout

Using braces

Math knows does not use order of operation within a formula. Braces (curly brackets) have to be
used to define the order of formula operations. The following examples show how braces are
used in a formula.

Example 1

2
2 over x + 1 creates the formula —+1
X

Math recognized the 2 before and the x after the over command belong to a fraction and has
represented them accordingly. If x+1 is required rather than X to be a denominator, x+1 must be
bracketed together using braces to create the correct formula. Inserting braces as shown in

2 over {x + 1} creates the correct result where x+1 now the denominator: %1
X

Example 2

-1
— 1 over 2 creates the formula >

Math has recognized the minus sign as a prefix for the 1 and has placed it as the numerator of
the fraction. If it is required that the whole fraction is negative with the minus sign in front of the
fraction, the fraction must be placed in braces to instruct Math that all the characters are part of
the whole fraction. Adding braces into the markup language

— {1 over 2} creates the whole fraction negative —%

Example 3
Braces are used in markup language to define the formula layout and are not displayed or
printed. If braces used within a formula are to be printed, use the commands lbrace and
rbrace within the markup language.

X
x over {—x + 1} gives the formula
{ i —-x+1

Replace the braces with lbrace and rbrace in the markup language as follows:

x over lbrace —x + 1 rbrace creates the formula {—:—+1}
Brackets (parentheses) and matrices
To use a matrix in a formula, the matrix command has to be used.

Example 1

To create a simple example of a 2x2 matrix. In matrices, rows are separated by two hashes (##)
and entries within each row are separated by one hash (#).
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(@ b

(matrix { a# b## c#d } g

Example 2
Normally, when brackets are used within a matrix, the brackets do not scale as the matrix
increases in size. The following example shows a formula where the parentheses do not scale to
the size of the resulting matrix.

(matrix { a# b #H# c#d }) (g Z)

Example 3
To solve this problem, Math provides scalable brackets that change in size to match the matrix
size. The commands left( and right) have to be used to create scalable brackets around a
matrix. The following example shows how to create a matrix with scalable parentheses.

left( matrix { a # b ## c # d } right) (“ Z)
c
Scalable brackets can be used with any formula element, such as fraction, square root, and so
on.

To create a matrix where some values are empty, the grave accent (°) is used so that Math
places a small space in the position where grave accent (') has been placed, as shown in the
following example:

left( matrix { 1 # 2 # 3 ## 4 # ° #6 } right) (1 2 3)

4 6

. Tips

Use the commands left[ and right] to obtain square brackets. A list of all
brackets available within Math can be found in Appendix A, Commands Reference.

If all brackets are to be scalable, go to Format > Spacing on the Menu bar to open
the Spacing dialog. Click on Category and select Brackets from the drop-down list,
then select the option Scale all brackets from the drop-down list.

Unpaired brackets

When using brackets in a formula, Math expects that for every opening bracket there will be a
closing bracket. If a closing bracket is not used, Math places an inverted question mark next to
where the closing bracket should have been placed.

For example, lbrace a; b creates ( because the right bracket rbrace is missing. This inverted
question mark disappears when all brackets are paired. This is corrected by using lbrace a;

b rbrace, which creates {a;b]. However, there are cases where an unpaired bracket is
required.

Non scalable brackets

A backslash \ is placed before a non scalable bracket to indicate that the subsequent character
is not a bracket, but a literal character.

Example
The unpaired brackets in the formula [ a; b [ results in an inverted question mark being entered
because Math expects that [ will be closed by ]. To correct the error, use a backslash for every
bracket into the Formula Editor.
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\ [ a; b \ [ createsthe formula [a;b[ .

Scalable brackets

To create unpaired scalable brackets or braces in a formula, the markup commands left,
right, and none are used.

Example

The following formula uses the stack command to create a two-line formula and adds a bracket
only to the right side of the stack. This effect is achieved by using the left Lbrace command
combined with the right none command. The first command indicates that the left bracket is a
lbrace and the second command none tells Math that there is no right bracket added to the
right side of the formula.

abs x = left lbrace stack {x "for" x >= 0 # -x "for" x < 0} right none

Ix|= xforx=0
—xforx<0

Recognizing functions

In the normal installation of Math, Math creates functions using normal characters and variables
in jtalic characters. However, if Math fails to recognize a function, Math can be forced to
recognize that a function has been entered. Using the markup command func before a function
forces Math to recognize following text as a function.

For a full list of functions available in Math, see Appendix A, Commands Reference.

Some Math functions have to be followed by a number or variable. If a number or variable is
missing, Math places an inverted question mark where the missing number or variable should
be. To remove the inverted question mark and correct the formula, enter a number, variable, or
pair of empty brackets as a placeholder.

_-Tip

Navigate through formula errors using the function key F3 to move to the next error,

or use the function key combination Shift+F3 to move to the previous error.

Multiple line formulas

x=3
y=1
is to use the Enter key. However, when the Enter key is used, the markup language in the

Formula Editor goes to a new line, but the resulting formula does not have two lines. To add a
new line into a formula, the markup command newline has to be used

When creating a formula that requires more than one line, for example , the first reaction

Table 4 shows how the markup command newline is used to add a new line to a formula. The
first example simply adds an Enter command to break the line in the markup language. This
does not create a new line in the formula. The second example uses the newline command.
The newline command creates a two-line formula.

Table 4: Examples of multiple line formulas

Markup Language Resulting Formula
X =3 — o, —
y=1 x=3y=1

X = 3 newline y =1

x=3
y=1
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It is not possible in Math to create multiple line formulas when a line ends with an equals sign
and continue the formula on a new line. A term on the right side of the equals sign must be
entered to create multiple line formulas.

If a multiple line formula is required to have an equals sign at the end of a line without a term
after the equals sign, use empty quotes “”, empty braces {}, grave character °, or tilde
character .

By default, the alignment of a multiple line formula is center aligned. For more information on
alignment using the equals sign, see “Aligning formulas using equals sign” on page 30.

Formula element spacing

Spacing between elements in a formula is not set by using space characters in the markup
language. To add spaces into a formula, use one of the following options:

« Grave = to add a small space.
* Tilde ~ to add a large space.
» Space characters between quotes “ ”. Space characters are considered as text.

7 Note

Any spaces at the end of a line in the markup language are ignored by default. For
more information, see Chapter 4, Customization.

Adding limits to summations and integrals

The sum and int commands are used for summations and integrals with the parameters from
and to used to set the lower and upper limits. The parameters from and to can be used singly or
together as shown by the following examples. For more information on the sum and int
commands, see Appendix A, Commands Reference.

Table 5 shows how to add upper and lower bounds to summations and integrals. Note that
brackets are used to define which parts of the formula correspond to the desired bounds.

Table 5: Example of using summations and integrals

Markup Language Resulting Formula

sum from k =1 to n a_k ZGk

k=1
sum to infinity 2"~{-n} i "
sum from{ i=1 } to{ n } sum from{ j=1; i <> j } 3 i X
tO{ m } Xfij i=1 j=1;i#j ¥
int from 0 to x f(t) dt [ f(t)de

0
int 0~x f(t) dt [ fle)ae
int from Re f _g[f
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Adding derivatives

When adding derivatives to a formula, indicate in Math that it is a fraction by using the over
command. The over command is combined with the character d for a total derivative, or the
partial command for a partial derivative to achieve the effect of a derivative. Braces {} are
used on each side of elements to enclose the elements and make the derivative as shown in
Table 6.

Table 6: Examples of adding derivatives

Markup Language Resulting Formula

{df} over {dx} ﬁ
dx

: . of
{partial f} over {partial y} 6—
Yy

A i o°f
{partial”2 f} over {partial t"2} ?
t

}? Note

To write function names with primes, as is normal in school notation, add the
symbols to the catalog first. For more information, see Chapter 4, Customization.

Markup language characters as normal characters

Characters that are used as controls in markup language cannot be entered directly as normal
characters. Control characters are: %, {, }, & |, _, ~and". Forexample, 2% = 0.02
cannot be entered into markup language and expect the same characters to appear in a formula.
To overcome this limitation in markup language, use one of the following methods:

» Use double quotes to mark that character as text, for example 2"%"= 0.02 displays in a
formulaas 2%=0.02 . However, double quotes cannot be used to enter a double quote
character as text, see “Text in formulas” below.

+ Add the character to the Math Catalog, for example the double quote character.

» Use commands, for example lbrace and rbrace for literal braces.

7 Note

The Special Characters dialog used by other LibreOffice modules is not available in
Math. If special characters are required in Math, then it is recommended to add the
characters to the Math Catalog. See Chapter 4, Customization for more information.

Text in formulas

To include text in a formula, enclose any text in double-quotes, for example x " for " x >= 0
in markup language creates the formula x for x>0 . All characters, except double quotes, can
be used in text.

However, if double quotes are required in formula text, any text text created in Writer must be
contained within typographic double quotes. The text is then copied and pasted as the text into
the Formula Editor as shown in Figure 12.
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An example showing “double quotes” in formula text.

s An example showing “double guotes” in formula text. :

"An example showing *“double quotes”™ in formula text."

Figure 12: Example of using double quotes to create formula text

* The font used for text in a formula is the default font that has been set in the Fonts
dialog. For more information on how to change fonts used in formulas, see Appendix A,
Commands Reference.

» By default, text alignment is left-justified in formulas. For more information, see Appendix
A, Commands Reference.

Formatting text in formulas

Formatting commands are not interpreted within text used in formulas. To use formatting
commands within formula text, the text flow must be broken by using double quotes in the
Formula Editor.

Example
Enter the following text in the Formula Editor using markup language to create text in a formula:

"In " color blue bold "isosceles" "triangles, the base angles are
equal”

In isosceles triangles, the base angles are equal

The example above shows how markup language is used to change the text color to blue and
use bold text for the word “isosceles” in the formula. Note that the commands are applied to any
text placed between the double quotes. The formatting command color blue bold is not
applied to the rest of the text in the example because it is a separate quote block.

Aligning formulas using equals sign

Math does not have a command for aligning formulas on a character. However, a matrix can be
used to align formulas on the equals sign (=) character. The markup commands alignr, alignl
and alignc are used to align each value inside a matrix to the right, left or center, respectively.

Example

The following uses a matrix to align formulas on the equals sigh and uses alignment
commands to align the contents of each position within the matrix. The spacing on each
side of the equals sign cab be reduced if the inter-column spacing of the matrix is
adjusted. See “Adjusting formula spacing” on page 34 for more information.

matrix{ alignr x+y # {}={} # alignl 2 ## alignr x x+y = 2
# {}={} # alignl 2-y } X = 2-y
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/? Note

The empty braces each side of the equals sign are required. The equals sign is a
binary operator and requires an expression on each side. Spaces, or characters ™ or
~ on each side of the equals sign can be used, but it is recommended to use braces
because braces are easier to see within markup language.

Changing formula appearance

7 Note

Only the default font or font size can be changed in a formula. Any formulas that
were already inserted into a document will continue to use the previous settings for
default font and font size. The font and font size of these previously inserted formulas
have to be changed individually to use the new setting for default font and font size.

Tip

m

The extension Formatting of All Math Formulas can be used to change font name
and font size for all or selected formulas in a document. The extension and
instructions for use can be downloaded from the LibreOffice website using the
following link: https://extensions.libreoffice.org/en/extensions/show/formatting-of-all-
math-formulas.

Formula font size

Changing formula font size
To change the font size used in a formula already inserted into a LibreOffice document:
1) Click in the markup language in the Formula Editor.
2) Go to Format > Font size on the Menu bar to open the Font Sizes dialog (Figure 13).

Font Sizes
Base size: 12 pt =
Relative Sizes
Text: 100% .
Indexes: 60% .
Functions: 100% -
Operators:  100% =
Limits: 60% =
Help Default oK Cancel

Figure 13: Font Sizes dialog

3) Select a different font size from the options available in Base size, or enter a new font
size in the text box.
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4) Click OK to save the changes and close the dialog.

Example
Default font size 12pt: m =~ 3.14159

Font size changed to 18pt: T ~ 3.14159

Default formula font size
To change the default font size used for all formulas in a LibreOffice document:

1) Before inserting any formulas into a document, go to Format > Font size on the Menu
bar to open the Font Sizes dialog (Figure 13).

2) Select a different font size from the options available in Base size, or enter a new font
size in the text box.

3) Click on Default and select Yes in the conformation dialog that opens to save the
change in font size.

4) Click on OK to save the changes and close the Font Sizes dialog. Any new formulas
created will use the new base size font for formulas.

Font size options

The Font Sizes dialog ((Figure 13) specifies the font sizes used in a formula. Change the base
size and all elements in the formula created after the change will use the new base font size.

Base size

All elements of a formula are proportionally scaled to the base size. To change the base
size, select or type in the desired point (pt) size. You can also use other units of measure
or other metrics, which are then automatically converted to points.

Relative Sizes
Determines the relative sizes for each type of element with reference to the base size.

Text
Select the text size in a formula relative to the base size.

Indexes
Select the relative size for indexes in a formula in proportion to the base size.

Functions
Select the relative size for names and function elements in a formula in proportion to
the base size.

Operators
Select the relative size of the mathematical operators used in a formula in proportion
to the base size.

Limits
Select the relative size for the limits in a formula in proportion to the base size. This is
used to determine the size for commands from and to used in summations and
integrals.

Default

Select Default to save any changes to the font size options. The new font sizes are then
used as default for all new formulas.
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Formula fonts

Changing formula fonts
To change the fonts used for a formula in a LibreOffice document:
1) Click in the markup language in the Formula Editor.

2) Go to Format > Fonts on the Menu bar to open the Fonts dialog (Figure 14).

Fonts X

(<[]

Variables:  [Liberation Serif, ltalic

K

Functions: [Liberation Serif

<

Numbers: ‘Liberation Serif

Text: [Liberation Serif V]
Custom Fonts

Serif: [Liberation Serif ]

Sans-serif: ‘Liberation Sans v |

Fixed-width: lLiberation Mono

Help Modify ~ Default Cancel

Figure 14: Fonts dialog

L<

3) Select a new font for each of the various options in the drop-down lists in the Fonts
dialog.

4) If the font required does not appear in the drop-down list, click Modify and select the
option from the context menu to open a fonts dialog.

5) Select the font required and click OK to add the font to the drop-down list for the selected
option.

6) Click OK to save the changes and close the Fonts dialog.

Default formula fonts
To change the default fonts used for all formulas in a LibreOffice document:

1) Before inserting any formulas into a document, go to Format > Font size on the Menu
bar to open the Fonts dialog (Figure 14).

2) Select a new font for each the various options from the drop-down lists.

3) If the font required does not appear in the drop-down list, select Modify and then select
an option from the context menu to open a fonts dialog.

4) Select the font required and click OK to add the new font to the drop-down list for the
selected option.

5) Click on Default and select Yes in the conformation dialog that opens to save the
change in font type.

6) Click OK to save the changes and close the Fonts dialog.
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Formula font options

Formula Fonts
Defines the fonts used for the variables, functions, numbers and inserted text used for
formula elements.
Variables
Selects the fonts used for the variables in a formula.
Functions
Selects the fonts used for the function names and properties.
Numbers
Selects the fonts for the numbers in a formula.
Text
Defines the font used for text in a formula.
Custom Fonts
Defines fonts to format text components in a formula. The three basic fonts Serif,
Sans-serif and Fixed-width are available. Other fonts can be added using the Modify
option. All fonts installed on a computer system are available for use.
Serif
Specifies the font used for a serif font format.
Sans
Specifies the font used for a sans font format.
Fixed
Specifies the font used for a fixed font format.
Modify
Select an option from the context menu to access the Fonts dialog to define the font and
font attributes for a formula and for any custom fonts being used.
Default

Click on Default to save any changes as the default for all new formulas. A confirmation
message appears before any changes are saved.

ﬁ Notes

When a new font is used for a formula, the old font remains available and can be
selected again.

Variables are written in italics. For all other formula elements, the basic font form is
used. The font style can be altered in the formula by using the commands italic or
bold. To stop using an italic or bold font, use nitalic or nbold after the variable

Adjusting formula spacing

The alignment settings determine how formula elements located above one another are aligned
horizontally relative to each other.

Current formula spacing
To change the spacing used in the current formula in a LibreOffice document:
1) Click in the markup language in the Formula Editor.
2) Go to Format > Spacing on the Menu bar to open the Spacing dialog (Figure 15).
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3) Click Category and select one of the options from the drop-down list. The options in the
Spacing dialog change depending on which category is selected.

4) Enter new values for the spacing category and click OK.
5) Check the spacing format in the formula. If the spacing format is not correct, repeat the
steps above.
Default formula spacing
To change the default spacing used for all formulas in a LibreOffice document:

1) Before inserting any formulas into a document, go to Format > Spacing on the Menu bar
to open the Spacing dialog (Figure 15).

2) Click Category and select one of the options from the drop-down list. The options in the
Spacing dialog change according to the category selected.

3) Make the required changes to the category option, then click Default and confirm the
changes to the formula spacing. Any new formulas created will use the new spacing for
formulas.

4) Click OK to save the changes and close the Spacing dialog.

Spacing X
Spacing

Spacing: hﬂ% o

Line spacing: 5% 5 %+ b

Root spacing: 0% <

Help Default Category ~ Cancel

Figure 15: Spacing dialog

7 Note

Only new formulas inserted after the change in formula spacing will use the new
setting for formula spacing. For any formulas inserted into a document before the
default spacing was changed, the new default spacing will not be applied. The
formula spacing on each formula already inserted into a document will have to be
changed manually.

Formula spacing options

Use the Category options available in the Spacing dialog (Figure 15) to change the spacing for
a formula element. The dialog that opens depends on the selected category. A preview window
displays which spacing is being changed.
Category
Select a category to change the formula spacing.

Spacing
Defines the spacing between variables and operators, lines, and root signs and radicals.
Spacing
Determines the spacing between variables and operators
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Line Spacing
Determines the spacing between lines.
Root Spacing
Determines the spacing between the root sign and radicals.
Indexes
Defines the spacing for superscript and subscript indexes.

Superscript
Determines the spacing for superscript indexes.
Subscript
Determines the spacing for subscript indexes.
Fractions
Defines the spacing between the fraction bar and the numerator or denominator.

Numerator
Determines the spacing between the fraction bar and the numerator.
Denominator
Determines the spacing between the fraction bar and the denominator.
Fraction Bars
Defines the excess length and line weight of the fraction bar.

Excess length
Determines the excess length of the fraction line.
Weight
Determines the weight of the fraction line.
Limits
Defines the spacing between the sum symbol and the limit conditions.
Upper limit
Determines the spacing between the sum symbol and the upper limit.
Lower limit
Determines the spacing between the sum symbol and the lower limit.
Brackets
Defines the spacing between brackets and the content.

Excess size (left/right)

Determines the vertical distance between the upper edge of the contents and the
upper end of the brackets.

Spacing
Determines the horizontal distance between the contents and the upper end of the
brackets.

Scale all brackets

Scales all types of brackets. If ( a over b) is entered into the Formula Editor, the
brackets surrounds the whole height of the argument.

Excess size

Adjusts the percentage excess size. At 0% the brackets are set so that they surround
the argument at the same height. The higher the value that is entered, the larger the
vertical gap between the contents of the brackets and the external border of the
brackets. The option can only be used in combination with Scale all brackets.
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Matrices
Defines the relative spacing for the elements in a matrix.
Line spacing
Determines the spacing between matrix elements in a row.
Column spacing
Determines the spacing between matrix elements in a column.
Symbols
Defines the spacing of symbols in relation to variables

Primary height
Defines the height of the symbols in relation to the baseline.
Minimum spacing
Determines the minimum distance between a symbol and variable.
Operators
Defines the spacing between operators and variables or numbers.

Excess size
Determines the height from the variable to the operator upper edge.
Spacing
Determines the horizontal distance between operators and variables.
Borders
Adds a border to a formula. This option is particularly useful if you want to integrate the
formula into a text file in LibreOffice Writer by combining mathematical formulas and text
inside the same paragraph.
Left
The left border is positioned between the formula and background.
Right
The right border is positioned between the formula and background.
Top
The top border is positioned between the formula and background.
Bottom
The bottom border is positioned between the formula and background.
Preview Field
Displays a preview of the current selection.

Default

Saves any changes as default settings for all new formulas. A security response will
appear before saving these changes.

7 Notes

When adding formulas into a LibreOffice document, there may be spacing between
the formula and surrounding text, even if all formula borders are set to zero. This is
because formulas are OLE objects embedded into a frame that, by default, adds
0.2 cm to the left and right of the formula.

Extra spacing can be removed using one of two methods. First method is to edit the
object properties by right-clicking the formula and then going to Properties > Wrap

to adjust the Spacing fields to the required values. The second method is to change
the spacing options for the formula frame style or create a new style. For more
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information on changing the formula spacing, see Chapter 2, Formulas in Writer. For
more information on how to edit styles in general, see the Writer Guide.

Example

Math objects are combined with text by removing all spacing both from the formula and
the frame style surrounding it. Because spacing is set to zero, the spacing between text
and formulas is achieved by simply adding a space character using the keyboard space
bar.

“Let ¢; be a cost matrix and XUE{O; 1} be a decision variable defined for i=1,2,...,m
origins and for j=1,2,...,n destinations”.

Adjusting formula alignment

The formula alignment is used for determining how formula elements are located above one
another and aligned horizontally relative to each formula element.

}? Notes

It is not possible to align formulas on a character and formula alignment cannot be
used to align text elements. Text elements are always aligned to the left.

It is possible to align sections of a formula using the commands alignl, alignc and
alignr. Using these commands, matrices and text elements in a formula can be
aligned.

Current formula alignment
To change the alignment used for a formula in a LibreOffice document:
1) Click in the markup language in the Formula Editor.
2) Go to Format > Alignment on the Menu bar to open the Alignment dialog (Figure 16).
3) Select Left, Centered, or Right for horizontal alignment.
Alignment

Horizontal
O Left
O Centered
O Right

Help Default OK Cancel

Figure 16: Alignment dialog

4) Select OK and check the result in the Formula Preview. If necessary, repeat steps 1 to 3
to correct the formula alignment.

Default formula alignment

To change the default alignment used for all formulas in a LibreOffice document:
1) Click in the markup language in the Formula Editor.
2) Go to Format > Alignment on the Menu bar to open the Alignment dialog (Figure 16).
3) Select Left, Centered, or Right for horizontal alignment.

4) Select Default and confirm the changes to the formula alignment. Any new formulas
created will use the new formula alignment.
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5) Select OK and check the result in the Formula Preview. If necessary, repeat steps 1 to 4
to correct the formula alignment.

ﬁ Note

Only formulas inserted after changing in formula alignment use the new default
settings. For any formulas already inserted into a document before the default
alignment was changed, the new default alignment is not applied. The formula
alignment on each formula already inserted into a document has to be changed
manually.

Changing formula color

The color of formula characters can be changed using markup language. Use the command
color followed by a color name, RGB value, or HTML hex value.

* The color command only works if the color command immediately follows the color
name, RGB value, or hex value. For example, entering color red 5 times 4 gives the
result 5X4 . Only the number 5 is colored red.

» To change the color of the whole formula, the complete formula has to be placed inside
brackets. For example, entering color red {5 times 4} gives the result 5x4 .
Named colors
For information on the named colors available in Math, see Appendix A. These colors are listed
in the Attributes category of the Elements panel on the Sidebar (Figure 4 on page 17).
RGB values

RGB (Red, Green and Blue) values for colors are from 0 to 255. To use RGB values, enter the
command color rgb R G B followed by the RGB values of the required color.

Example

In this example, the formula element decision variable uses a color defined with the
RGB values of 160, 82, 45.

"Let " x ij "bea" color rgb 160 82 45 "decision variable
problem under consideration”

“ "inthe
Creates the following in a formula:

Let x; be a decision variable in the problem under consideration

Hex values

HTML colors can be used in a formula and these are defined using a hex number. Use the
command hex 000000, where 00000 is the corresponding hex number for the color required.
For example, using the command color hex FFO000 decision creates the output decision.

Background color

It is not possible to use a background color for formulas. The formula background color is, by
default, the same color as the document or frame where the formula has been inserted. In
Writer, object properties can be used to change the background color of a formula. For more
information, see Chapter 2, Formulas in Writer.
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Formula library

If formulas are going to be regularly inserted documents, a formula library can be created using
the Formula Editor. Individual formulas are saved as separate files using the ODF format file
type ODF, or the MathML format for file type MML. Math, Writer, Calc, Draw, or Impress can be
used to create formulas and added to a formula library.

ﬁ Note

MathML 2.0 stands for Mathematical Markup Language (MathML) Version 2.0.
MathML is an XML format that describes mathematical notation and enables the use
of mathematics in the World Wide Web. For more information on MathML format,
visit the website at https://www.w3.org/TR/MathML2/overview.html.

Using Math

1) Create a computer folder to contain formula files and give the folder a memorable name,
for example Formula Library.

2) Go to File > New > Formula on the Menu bar, or click on Math Formula in the Start
Center to open LibreOffice Math and the Formula Editor. See “Formulas as separate
documents or files” on page 17 for more information.

3) Create the formula required.

4) Go to File > Save As on the main Menu bar, or use the keyboard shortcut
Ctr1+Shift+S (macOS (%]+Shift+S) to open the Save As dialog.

5) Navigate to the folder created for a formula library.
6) Type a memorable name for the formula in the file name or save as box.

7) Select in the File type drop-down list select ODF Formula (.odf) or MathML 2.0 (.mm1) as
the file type for the formula.

8) Click Save to save the formula and close the Save As dialog.

Using Writer, Calc, Draw, or Impress

1) Create a computer folder to contain formula files and give the folder a memorable name,
for example Formula Library.

2) Open a document using Writer, Calc, Draw, or Impress.

3) Go to Insert > Object > Formula Object on the Menu bar to open the Formula Editor
and create a formula. See “Formulas in LibreOffice documents” on page 17 for more
information.

4) Right-click on the formula object and select Save Copy as in the context menu to open a
Save As dialog.

5) Navigate to the folder you have created for your formula library.
6) Type a memorable name for your formula in the File name box.

7) Select in the File type drop-down list either ODF Formula (.odf) or MathML 2.0 (.mml) as
the file type for the formula.

8) Click Save to save the formula and close the Save As dialog.
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Using a formula library

A formula in the formula library cannot be inserted into a document by dragging and dropping, or
by using Insert > File on the Menu bar. A formula from the formula library must be inserted into a

document as an OLE object.
1) Open a document using Writer, Calc, Draw, or Impress.

2) Go to Insert > OLE Object > OLE Object on the Menu bar to open the Insert OLE
Object dialog (Figure 17).

3) Select the option Create from file.
4) Click Search to open the file browser and navigate to the formula library folder.

Insert OLE Object

(O Create new © Create from file
File
(] Link to file Search...

[ Display as icon

Help OK Cancel

Figure 17: Insert OLE Object dialog — Create from file page

5) Select the file for formula required and click Open in the file browser, or double-click on
the formula required.

If required, select the option Link to file or Display as icon.

Click OK to insert the formula as an OLE object in the document and close the Insert OLE
Object dialog.
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Introduction

When a formula is inserted into a document, Writer inserts the formula into a frame and treats
the formula as an OLE object. For more information on creating and editing formulas, refer to
Chapter 1, Creating and Editing Formulas.

* When a formula is selected for editing, the Writer Formula Editor opens, as shown by the
example in Figure 18.

» Double-clicking on an inserted formula opens Math with the formula selected for editing
in the Math Formula Editor.

7 Note

This chapter explains what options can changed for a formula within a Writer
document. See the Writer Guide for information on how to change the settings for
frame styles for OLE objects.

E Lorem Ipsum.odt — LibreOffice Wiiter — (m] X
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labore et dolore magna aliqua. Senectus et netus et malesuada. Quis ipsum suspendisse
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df(x) over dx = ln(x)+tanA-1(xA2) %DELTA t' = { ¥DELTA t } over sqrt{ 1 - vA2 over cA2 } l

Figure 18: Example formula selected for editing in Writer

Automatic formula humbering

Automatic numbering of formulas to create formula cross references can only be carried out in
Writer. The AutoText entry fn (formula numbered) is used to automatically add a numbered
cross reference to formulas.

Numbering
1) Start a new line in a document at the required position for the formula.

2) Type fn and press the F3 key to insert a two column table with no borders. The left
column contains a sample formula and the right column contains the cross reference
number, as shown by the following example.

E=mc’ 1)

3) Delete the sample formula and insert the required formula into the left column.
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Formula cross referencing
1) Click in the document at the position where a cross reference for a formula is required.
2) Go to Insert > Cross-reference on the Menu bar to open the Fields dialog (Figure 19).
3) Click on Cross-references, then select Text in Type.
4) In Selection, select the formula number required for the cross reference.

5) In Refer using, select Referenced text, then click on Insert to insert the cross reference
for the selected formula.

6) Click on Close to close the Fields dialog.

Fields

Document  Cross-references  Functions Docinformation  Varables Database

Type Selection

Set Reference -
Filter Selection

| |Insert Reference
| |Headings )]
Numbered Paragraphs
Text

Bookmarks

Styles

Refer using:
Page number (unstyled)
Chapter

Referenced text
“Above®/“Below”
Page number (styled)
Category and Number
Caption Text

Number Value

Name (1)

Help Insert Close

Figure 19: Fields dialog — Cross-references — Referenced text

7 Note

To use square parentheses instead of curved parentheses, or require the cross
reference number to be separated from the formula by tabs instead of using a table,
see the Writer Guide for more information.

Anchoring and aligning formulas

Anchoring position

A formula is an object when inserted into a Writer document. The default anchoring for a formula
is As character when inserted into a document. To change the formula anchoring in a document:

1) Right-click on the selected formula and select Anchor from the context menu.

2) Select an anchoring option from the context menu. The anchoring options available are
To paragraph, To character, or As character.

3) Alternatively, right-click on the selected formula and select Properties from the context
menu, or go to Format > Frame and Object > Properties on the Menu bar to open the
OLE Object dialog (Figure 20).
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4) Make sure Position and Size is selected, then select a new anchoring position from the

options available in Anchor. The anchoring options available are To page, To paragraph,
To character, or As character.

5) Click OK to save the changes and close the OLE Object dialog.

OLE Object

Position and Size  Options Wrap Hyperink Borders Area Transparency Macro

Size Anchor Preview
Width 1736 pt . OTopage
“ © o paragraph’
Relative to |Entire paragraph area ‘ o O To character
‘ O As character
Height 50.9 pt = —
Relative to |Entire paragraph area |
Original Size
Positi
Horizontal |Center v| by 00pt to |Paragraph text area ~ ]

() Mirror on even pages

Vertical Top v| by 00pt - to |Paragraph text area j
a Keep inside text boundaries

Figure 20: OLE Object dialog — Position and Size page

Vertical alignment

The normal default setting for vertical alignment for formulas is to use the text base line as a

reference. This default setting can be changed by modifying the frame style for formulas, see the
Writer Guide for more information.

1) Make sure the To paragraph or To character option for formula anchoring is selected to

change vertical formula alignment. Vertical alignment is NOT available for the As
character anchoring option.

2) Right-click on the selected formula and select Align Objects from the context menu.

3) Select a vertical alignment option from the context menu. The options available are Align
Top to Anchor, Align Middle to Anchor, and Align Bottom to Anchor.

4) Alternatively, right-click on the selected formula and select Properties from the context

menu, or go to Format > Frame and Object > Properties on the Menu bar to open the
Object dialog (Figure 20).

5) Make sure Position and Size is selected, then select a new vertical alignment from the
options available in Position Vertical. The vertical alignment options available are
Center, Top, Bottom, or From bottom.

6) If the From bottom option is selected for vertical alignment, enter a plus or minus value
for vertical alignment.
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7) Select the type of text alignment from the drop-down list in Position Vertical. The text
alignment options available are Base line, Character, and Row.

8) Click OK to save the changes and close the OLE Object dialog.

Horizontal alignment

The normal default setting for horizontal alignment for formulas is to use the text base line as a
reference. This default setting can be changed by modifying the frame style for formulas, see the
Writer Guide for more information.

1) Right-click on the selected formula and select Align Objects from the context menu.

2) Select a horizontal alignment option from the context menu. The options available are
Left, Centered, and Right.

3) Alternatively, right-click on the selected formula and select Properties from the context
menu, or go to Format > Frame and Object > Properties on the Menu bar to open the
Object dialog (Figure 20).

4) Make sure Position and Size is selected, then select a new horizontal alignment from
the options available in Position Horizontal. The horizontal alignment options available
are Left, Right, Center, or From left.

5) If the From left option is selected for horizontal alignment, enter a plus or minus value for
horizontal alignment.

6) Select the type of text alignment from the drop-down list in Position Horizontal. The text
alignment options available are Entire paragraph area, Left of paragraph text area, Right
of paragraph text area, Left of page text area, Right of page text area, Entire page, Page
text area, and Character.

7) Click OK to save the changes and close the OLE Object dialog.

Object wrap and spacing

A formula, when inserted into a document, has text wrap and spacing on each side of the
formula. The default settings used for wrap and spacing is set within the frame style for formulas.
This default settings can be changed by modifying the formula frame style, see the Writer Guide
for more information.

Object wrap
To individually adjust the wrap for a formula positioned in a Writer document:

1) Make sure the To paragraph or To character option for formula anchoring is selected to
change object wrap. Object wrap is NOT available for the As character anchoring option.

2) Right-click on the selected formula and select Wrap from the context menu.

3) Select a wrap option from the context menu. The options available are None, Parallel,
Optimal, Before, After, Through In Background and Edit Contour.

4) Right-click on the selected formula and select Properties in the context menu, or go to
Format > Frame and Object > Properties to open the Object dialog.

5) Click on Wrap to open the Wrap page in the Object dialog (Figure 21).

6) In Settings, select the type of wrap required for the formula. The options available are
Wrap Off, Before, After, Parallel, Through and Optimal.

7) Click OK to save the changes and close the Object dialog.
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OLE Object X

Position and Size  Options Wrap  Hyperlink Borders Area  Transparency Macro

| Settings
ap Off O Before O After
| O Parallel O Through O Optimal
| Spacing Options
| Left: 0.0 pt = First paragraph
ry n background
Right  0.0pt : ackgroun
Contour
foE 00pt =z Outside only
Bottom: 0.0 pt % 8 Allow overlap

Figure 21: OLE Object dialog — Wrap page

Object spacing
To individually adjust the spacing for a formula positioned in a Writer document:
1) Right-click on the selected formula and select Align Objects from the context menu.

2) Select a horizontal alignment option from the context menu. The options available are
Left, Centered, and Right.

3) Right-click on the selected formula and select Properties in the context menu, or go to
Format > Frame and Object > Properties to open the Object dialog.

4) Click on Wrap to open the Wrap page in the Object dialog (Figure 21).
5) In Spacing, enter the spacing value for Left, Right, Top, and Bottom spacing.
6) Click OK to save the changes and close the Object dialog.

Text mode

When large formulas are placed within a line of text, the formula elements can be higher than
the text height. To make large formulas easier to read, it is recommended to always insert large
formulas into a separate paragraph to separate a formula from the text.

5

.1

i=2

If it is necessary to place a large formula within a line of text, double-click on the formula to open
the Formula Editor and then go to Format > Text Mode on the Menu bar. The Formula Editor
reduces the formula size to match text height, as shown in the following example.

The same formula embedded into a line of text using text mode format Y., i :

Background and borders

The default setting for background (area fill) and borders for formulas is set by the Formula
frame style. For more information on changing the background and borders for Formula frame
style, see the Writer Guide. If required, individual formulas in a document can use different
backgrounds and borders.
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/? Note

The size of the frame that a formula is placed in when inserted into a document
cannot be changed. The frame size for a formula depends on the setting of the
formula font size. See Chapter 1, Creating and Editing Formulas for more
information.

The following example is a formula using background color and borders. Note that the
background and border properties are part of the Math OLE object and cannot be defined using
markup language.

df%=ln(x)+tan_1(x2)At': At

2
Y

2
c

1—

Backgrounds
1) Select a formula in a document to change the background.

2) Right-click on the formula and select Properties from the context menu, or go to Format
> Frame and Object > Properties on the Menu bar to open the OLE Object dialog.

3) Click on Area, then select the type of fill required for the formula from the available
options (Figure 22). The options available are None, Color, Gradient, Image, Pattern, and
Hatch.

OLE Object

Positionand Size  Options Wrap Hyperlink Borders Area  Transparency Macro

None Gradient Image Pattern Hatch

Colors Active New
: - = - -
| HEEEEEEERE
| EEEEEEEEEN
R 114 R 114 =
u 1 G 19 =
EEEEEEEEE - 2
EEEEEEEEE - I
AEEEEEEEEEN
AEEEEEEEEEEE Hex T729cf Hex 729fcf
AEEEEEEEEEEE
AEEEEEEEEEEE Pick ©
Recent Colors
O
Custom Palette
Add Delete
Help Reset oK Cancel

Figure 22: OLE Object dialog — Area page

4) After selecting the background type, select the properties for the formula background.
The area properties change depending on the type of area fill selected.

5) Click OK to save the changes and close the OLE Object dialog.
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Borders
1) Select a formula in a document to change the borders.

2) Right-click on the formula and select Properties from the context menu, or go to Format
> Frame and Object > Properties on the Menu bar to open the OLE Object dialog.

3) Click on Borders, then select the of border properties required for the formula from the
available options (Figure 23). The options available are Line Arrangement, Line,
Padding, and Shadow Type.

4) Click OK to save the changes and close the OLE Object dialog.

OLE Object X

Position and Size  Options Wrap  Hyperlink Borders Area Transparency Macro

| Line Arrangement Padding
presets: | O[T 2|1 left  00pt £
User-defined: Right  0.0pt =
Top: 0.0pt =
Bottom: 0.0pt =
.Synchromzze
Line Shadow Style
Style: ~ Position: @| (] H 0 H ] | O
Color: I Black % Color: Gray v
Thickness: Distance: 5pt

Figure 23: OLE Object dialog — Borders page

Quick formula insertion

If the markup language for a formula is available, the formula can be quickly inserted into a
document without opening the Formula Editor:

df(x) over dx = In(x)+tan™-1(x"2) %DELTAt' = { %DELTAt } over sqrt{ 1 - v*2 over c"2 }
At

df%:m(x)ﬂan-w)mv:

X 2

v
1-=
c
1) Copy the formula markup language required, then paste into the document at the
required position, as shown by the above example.

2) Select all of the formula markup language.

3) Go to Insert > OLE Object on the Menu bar and select Formula Object to create a
formula using the selected markup language. The formula is inserted replacing formula
markup language.
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Introduction

When a formula is inserted into a Calc, Draw, or Impress document, the formula is inserted as
an OLE object without any background (area fill) or borders. For more information on creating
and editing formulas, please refer to Chapter 1, Creating and Editing Formulas. Each formula is
inserted into a spreadsheet, drawing, or slide as follows:

* In Calc, formulas are inserted into a selected cell in a spreadsheet with no style assigned
to the formula. For more information, see the Calc Guide.

* In Draw and Impress, formulas are inserted in a central position on a drawing or slide. By
default, formulas are assigned the drawing object style Object with no fill and no line. For
more information on how to modify or assign drawing object styles, see the Draw Guide
or Impress Guide.

Anchoring formulas

Calc

By default, a formula is anchored into a Calc spreadsheet using the option To Page. Change the
default formula anchoring in a Calc spreadsheet as follows:

1) Select the formula in the spreadsheet.

2) Right-click on the formula and select Anchor from the context menu. The anchoring
options available in the context menu are To Cell, To Cell (resize with cell), and To Page.

3) Alternatively, go to Format > Anchor on the Menu bar and select an anchoring option
from To Cell, To Cell (resize with cell), and To Page.

Tip
If a formula is inserted into a Calc spreadsheet and appears out of scale, right click
the formula and select Original Size from the context menu.

=]

Draw and Impress

When a formula is inserted into a drawing or slide, it is inserted as a floating OLE object in the
center of a drawing or slide. The inserted formula is not anchored and can be moved to any
particular position in a drawing or slide. See the Draw Guide or Impress Guide for information on
moving objects in a drawing or slide.

Formula properties

Formulas in Calc, Draw, and Impress can be modified just like any other object that has been
placed in a spreadsheet, drawing, or presentation. However, formula size and changing text
format in a formula cannot be carried out. For more information on how to change properties,
see the Calc Guide, Draw Guide, or Impress Guide. For more information on formula size and
formatting formula text, see Chapter 1, Creating and Editing Formulas.

 For formula backgrounds, use the options in the Area dialog pages.

 For formula borders, use the options in the Line dialog.

ﬁ Note

Formula borders are separate from cell borders in a Calc spreadsheet.
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» To accurately re-position a formula, use the options in the Position and Size dialog.

* In Draw and Impress, arrange, align, group, flip, convert, break, combine, and edit points

can be used for formula objects.

» Text attributes of a formula cannot be changed. The formula text is set when a formula is

created using the Formula Editor.

* Formula size is set by the formula font size when a formula is created. Formula size is
protected in the Position and Size dialog, but this can be deselected if required.

However, it is not recommended as resizing a formula using the Position and Size dialog.

This may distort a formula making it difficult to read.

Formulas in charts

A Calc chart is an OLE object created from a Calc spreadsheet. However, the Formula Editor
cannot be used to create and insert a formula directly into a chart. A formula has to be created,
then copied and pasted into a chart:

1) Create the chart using a Calc spreadsheet. For more information, see the Calc Guide.
2) Click in a spreadsheet cell to deselect a chart.

3) Insert a formula by clicking on Insert > OLE Object > Formula Object on the Menu bar
to open the Formula Editor in Calc.

4) Create the required formula in the Formula Editor.
5) Select the formula and copy the formula.
6) Double-click the chart object to open editing mode, then paste the formula into the chart.

7) Move the formula to the required position inside the chart.

}? Note

To edit a formula, the above procedure has to be repeated to create a new formula,
or edit an existing formula. The new or edited formula is then pasted into the chart.

Chemical formulas

The primary purpose of Math is to create mathematical formulas. However, Math can create
chemical formulas. However, chemical symbols are normally written in uppercase using non-
italic characters. The following table shows examples of chemical formulas.

Construction Example Markup Language

Molecules H,S0, H?2 S04

Isotopes U U lsub 92 lsup 238

lons SO% or SO% SO 4"{2-{}} or SO_4"~{2"-"}

Creating chemical formulas using Math, the font used for variables is changed to a non-italic
font. For more information on changing fonts in a formula, see Chapter 1, Creating and Editing
Formulas.

For reversible reactions in chemical formulas, there is no symbol for a double arrow in Math. If
there is a font available with symbols for use in chemical formulas, then add these symbols to
the Catalog. See Chapter 4, Customization for more information on how to add symbols.
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Introduction

This chapter explains how to customize LibreOffice Math when creating formulas for use in
LibreOffice documents. Also, refer to the Getting Started Guide for more information on
customizing LibreOffice.

Formula Editor and Elements panel

Formula Editor

Floating window

If required, the Formula Editor can become a floating window allowing the Formula Editor to be
positioned at a convenient location when creating formulas.

1) Position the cursor on the frame of the Formula Editor, NOT in the Formula Editor.

2) Press and hold Ctr1 key (macOS (%)) and double-click on the frame. This turns the
Formula Editor into a floating window labelled Commands (Figure 24).

Commands

df(x) over dx = In(x)+tanA-1(xn2) %DELTA t' = { %DELTA t } over sqrt{ 1 -
vA2 over ch2 }

Figure 24: Example of floating Formula Editor window
To return the Formula Editor back to its position in the Math window:

1) Position the cursor on the frame of the Commands floating window, NOT on the title bar
at the top of the window.

2) Press and hold Ctrl key (macOS [s)) and double-click. The floating window closes and
the Formula Editor appears at its previous position in the Math window.
Window static position

The Formula Editor can be positioned at the top or bottom of the Math window. The default
position is the bottom of the Math window.

1) Position the cursor on the frame of the Formula Editor, NOT in the Formula Editor.

2) Press and hold Alt key (macOS [J) and drag the Formula Editor to a new position at the
top or bottom of the Math window.

Elements panel

The Sidebar Elements panel can be used as a floating dialog allowing the Elements panel to be
positioned at a convenient location when creating formulas.

1) Position the cursor on the title bar of the Elements panel on the Sidebar.

2) Press and hold Alt key (macOS ), then double-click to create a floating Elements panel
(Figure 25).
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3) To move the Elements panel back to its position as a Sidebar, press and hold Alt key
(macOS ), then drag the Elements panel back to its Sidebar position.

Elements

Unary/Binary Operators bt ‘

«0 -0 =0 =0

O+0 O-0 400 Ox4d

00 E‘r E’r Q-0

eHE® Mg

3/a Qe Qel Uoed

OeQ Qe Q-0 Y
av i

-0 OaAQ QOva

Figure 25: Example of a floating Elements panel

Adding keyboard shortcuts

Keyboard shortcuts can be added to LibreOffice when creating documents. Following is an
example of how to add a keyboard shortcut for inserting a formula into a LibreOffice document.
For more information on creating keyboard shortcuts, see the Getting Started Guide.

7 Note

When creating new keyboard shortcuts, make sure that the keyboard shortcut is
NOT already in use by LibreOffice or the computer system.

Example keyboard shortcut

1) Go to Tools > Customize on the Menu bar to open the Customize dialog, then click on
Keyboard to access the options available for creating keyboard shortcuts (Figure 26).

2) Select the type of the new keyboard shortcut, as follows:

— Select LibreOffice to create a new keyboard shortcut for all components of
LibreOffice.

— Select Math to create a new keyboard shortcut for Math.
3) In the Category, select Insert.
4) In the Function, select Import Formula.
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Menus Toolbars Context Menus Keyboard  Events

Shortcut O LibreOffice
_ ©O Math

F2 i )
F3 Next Error e
F4 Next Marker
5 Delete
° Load
F7
FS SGUE...
F9 Update
Fi0
c11
Functions
Type to search
Category Funetion Keys

Application 75% I

BASIC 100%

Controls 150%

Documents 200%

Edit una:OptionsSecurityDialog

Format Juno:WidgetTestDhalog

Insert About LibreOffice

Math | |Absolute Record ]

Help 0K Cancel

Figure 26: Customize dialog — Keyboard page
5) In Keys, select the key or keyboard combination required for the new keyboard shortcut.
6) Select Modify and the new keyboard shortcut appears in Keys.
7) If required, continue to add keyboard shortcuts using Steps 1) to 6).
8) Click OK to save the keyboard shortcuts and close the Customize dialog.

Customize dialog options for keyboard shortcuts
LibreOffice
Displays shortcut keys that are common to all LibreOffice modules.
Math
Displays the keyboard shortcuts available in Math.
Assign
Assigns the keyboard shortcut to an action.
Delete
Deletes the selected element or elements without requiring confirmation.

Load
Replaces a shortcut key configuration with one that has been saved.
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Save

Saves the current shortcut key configuration, so that you can load it later.
Reset

Resets any modified keyboard shortcut to the default setting.
Shortcut Keys

Lists the available keyboard shortcuts and any associated commands. To assign or
modify a keyboard shortcut select a listed keyboard shortcut has to be selected first.

Functions
Type a function name in the text field to search for the function in the keyboard shortcuts.

Category
Lists the available categories for functions.

Function
Lists the available function categories for keyboard shortcuts.

Keys
Displays the keyboard shortcut keys that is assigned to a selected function.

Catalog customization

If a symbol is regularly used and is not available in Math, it can be added to the Symbols dialog
(Figure 27) using the Edit Symbols dialog (Figure 28). Symbols can be modified, have names
assigned, or redefined.

Adding symbols

1) Go to Tools > Symbols on the Menu bar or click on Symbols on the Tools toolbar to
open the Symbols dialog (Figure 27).

Symbols X

Symbol set:

BeracezHx
@ I KAMNIE
OnpePiIiITYG®
X¥YQapyés
e { n B8 1 x A
wviéompc
0 Tve Y Ve
v ¢ o o €
ALPHA

Figure 27: Symbols dialog — Greek page

2) In Symbol set select a font to use for the new symbol from the available options in the
drop-down list.

3) Click on Edit to open Edit Symbols dialog (Figure 28).
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Figure 28: Edit Symbols dialog

4) Select the symbol character required and it appears in the preview box. If necessary,
scroll down in the preview box to locate the required symbol.

5) In Symbol, enter a memorable name for the required symbol.

6) In Symbol set, select a symbol set in the drop-down for the selected symbol, or create a
new name for the selected symbol.

7) In Font and if required, select a font for the selected symbol.
8) In Subset, select a subset from the available options for the selected symbol.

9) In Style and if required, select a font style from the available options for the selected
symbol.

10) Click on Add, to add the symbol to Math.
11) If required, click on Modify after making any changes to an existing symbol.
12) If required, click on Delete if an existing symbol is no longer required.

13) Click on OK to close the Edit Symbols dialog. The new symbol and, if created, new
symbol set are now available for use.

7 Notes

When a new symbol is added to the catalog, a percentage sign (%) followed by the
name of the symbol is typed into the markup language in the Formula Editor and the
symbol appears in the formula. Symbol names are case sensitive, for example,
%prime is a different symbol to %Prime.
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There are numerous free fonts available that contain several symbols if the required
symbol is not available on the computer. For example, the STIX font was developed
for use in mathematical and technical texts. Also, DejaVu and Lucida fonts have a
wide range of symbols.

By default, only user defined symbols that are used in the document are stored with
the document. It is useful to embed all user defined symbols so that when a
document is transferred to another computer it is available for editing. Go to Tools >
Options > LibreOffice Math > Settings (macOS LibreOffice > Preferences >
LibreOffice Math > Settings) on the Menu bar and uncheck Embed only used
symbols (smaller file size) in Miscellaneous Options.

Editing symbols

Changing symbol names

1) In the Edit Symbols dialog (Figure 28), select the symbol name that is to be changed in
the Old symbol drop-down list. The symbol appears in the left preview box at the bottom
of the dialog.

2) Type a new name for the symbol in the Symbol text box, or select a new name from the
Symbol drop-down list. The new symbol name appears in the right preview pane.

3) Click Modify to change the symbol name, click OK to close the Edit Symbols dialog.

Moving symbols

1) In Old symbol set, select the symbol set from the options available in the drop-down list
in the Edit Symbols dialog (Figure 28).

2) Select a symbol from options available in the Old symbol drop-down list. In the left
preview box of the dialog, the name, symbol, and symbol set are displayed.

3) In Symbol, select a symbol name from the drop-down list.

4) In Symbol set, select the required symbol set from the drop-down list. In the right
preview box at the bottom of the dialog, the name, symbol, and symbol set are displayed.

5) If required, select an option from the drop-down lists in Font, Subset, and Style.
6) Click on Modify and the symbol is moved to the new symbol set.
7) Click on OK to close the Edit Symbols dialog.

Deleting symbols

1) In Old symbol set, select the symbol set from the options available in the drop-down list
in the Edit Symbols dialog (Figure 28).

1) In Old symbol, select the symbol for deletion from the drop-down list. The selected
symbol appears in the left preview pane at the bottom of the Edit Symbols dialog.

2) Click on Delete and the symbol is deleted from the symbol set without any confirmation.
3) Click on OK to close the Edit Symbols dialog.

}? Note

To delete a symbol set all of the symbols in the selected set have to be deleted. The
last symbol is deleted, the symbol set is also deleted.
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Symbol options

Old symbol
Select the name of a symbol from the drop-down list. The symbol, symbol name, and
symbol set are displayed in the left preview box at the bottom of the dialog.

Old symbol set
Displays the name of the current symbol set. A different symbol set can be selected from
the options in the drop-down list.

Symbol
Displays the name of the selected symbol set. Select a name from the options available
in the drop-down list or type a name for a newly added symbol when modifying or
deleting symbols.

Symbol set
The drop-down list displays the names of the available symbol sets.

Font

Displays the name of the selected font for symbols. When changing fonts for symbols,
select from the options in the drop-down list.

Subset
Displays the name of the selected subset for symbol fonts. When changing font subset
for symbols, select from the options in the drop-down list.

Style
Displays the name of the selected style for symbol fonts. When changing font style for
symbols, select from the options in the drop-down list.

Add

Click on Add to save and add the symbol displayed in the right preview box to the
selected symbol set. The Symbol or Symbol name displayed in the Symbol list must be
unique before the Add option becomes available. Symbol and Symbol Set names can
only be used once.

Modify

Click on Modify to replace the symbol displayed in the left preview box with the new
name after carrying out any modifications to a symbol.

Delete

Click on Delete to delete the symbol displayed in the left preview box from the selected
symbol set. There is no confirmation of deletion. Deleting the last symbol in a symbol set
also deletes the symbol set.

Formula spacing

The grave accent (') inserts an additional small space and the tilde (~) inserts an additional large
space into formulas. However, in a LibreOffice basic installation, these symbols are ignored
when they occur at the end of a formula. When working with running text in a formula, it may be
necessary to also include spacing at the end of formulas. This customization is only required
when working with a Math document and is not required when inserting a formula into another
LibreOffice module.

To add spacing at the end of formula in Math, go to Tools > Options > LibreOffice Math >
Settings (macOS LibreOffice > Preferences > LibreOffice Math > Settings) on the Menu bar
and uncheck Ignore ~ and "~ at the end of the line in Miscellaneous Options.
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Scaling of code

By default, the code in the Formula Editor input window is scaled to 100%. To change the scaling
factor go to Tools > Options > LibreOffice Math > Settings (macOS LibreOffice >
Preferences > LibreOffice Math > Settings) and change the percentage in the Scaling code
input window in Miscellaneous Options.

For example, to change the scaling to 150%, the code in the input window appears larger. This
setting affects the Formula Editor in all LibreOffice modules. However, the LibreOffice Math
options can only be accessed when using LibreOffice Math. It is not available for editing
formulas in other LibreOffice modules.

Extensions

Creating formulas frequently in documents, LibreOffice can be customized by adding extensions
that are designed to help in the creation of formulas. Extensions are installed using the
Extension Manager. For more information on how to install extensions, see the Getting Started
Guide.

A commonly used extension is Formatting of All Math Formulas. This extension allows
formatting of formulas in Writer, Calc, Draw, or Impress documents. Using this extension the font
names and sizes of all formulas used in LibreOffice documents. For more information on this
extension, go to https://extensions.libreoffice.org/en/extensions/show/formatting-of-all-math-
formulas.
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MathML format

In addition to exporting documents as PDFs, as described in the Getting Started Guide,
LibreOffice offers the possibility of exporting formulas in the MathML format. This allows you or
another person to insert formulas into documents that were created in other software, for
example, Microsoft Office or an internet browser.

7 Note

Some internet browsers do not fully support the MathML format and your formula
may not display correctly.

If you are working on a Math document, go to File > Save as on the Menu bar or use the
keyboard combination Ctr1+Shift+S to open the Save as dialog. Select MathML from the list of
available file formats in File type to save your formula as MathML.

If you are working in another LibreOffice component, right-click on the formula object and select
Save copy as from the context menu to open the Save as dialog. Select MathML from the list of
available file formats in File type to save your formula object as MathML.

In Math you can also import MathML formulas. Use Tools > Import MathML from clipboard on
the Menu bar.

Microsoft file formats

To control how formulas in Microsoft format are imported and exported using LibreOffice, go to
Tools > Options > Load/Save > Microsoft Office on the Menu bar and select or deselect the
options for MathType to LibreOffice Math or reverse.

* [L]: Load and convert the object
* [S]: Convert and save the object

[L]: Load and convert the object

Select this option if Microsoft OLE objects are to be converted into the specified LibreOffice OLE
objects when a Microsoft document is opened in LibreOffice. For formulas, any embedded
MathType objects must not exceed the MathType 3.1 specifications to be successfully loaded
and converted. Information on MathType format can be found at
https://docs.wiris.com/en/mathtype/office_tools/microsoft_office.

If a document containing OMML formulas has been saved in .docx format and then converted to
the older .doc format, then any OMML objects are converted into graphics, which will be
displayed in LibreOffice as graphics.

[S]: Convert and save the object

Select this option if LibreOffice OLE objects are to be converted and saved in Microsoft file
format. LibreOffice converts any formulas into a format that can be read and maodified by
Microsoft Equation Editor and MathType.

When this option is not selected, the formula is treated as an OLE object on conversion into
a .doc format and remains linked to LibreOffice. A double-click on the object in Microsoft Office
will attempt to launch LibreOffice.

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/


https://documentation.libreoffice.org/en/
https://docs.wiris.com/en/mathtype/office_tools/microsoft_office
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Introduction

This appendix lists the functions and commands that are available for use in the Formula Editor
for creating formulas.

Formula commands

The more common formula functions and commands are entered by clicking on the appropriate
icon in the Elements panel on the Sidebar. When no icon displayed in the Elements panel, then
the function or command has to be entered into the Formula Editor using markup language.

)? Note

In the markup language displayed in the following tables, replace the place holder <?
> with the value required in the formula being created.

Unaryl/binary operators

To access the regularly used unary/binary operators when entering markup language into the
Formula Editor, select Unary/Binary Operators in the Elements panel on the Sidebar
(Figure 29). Refer to Table 7 for a complete list of unary/binary operators.

r

Elements

Unary/Binary Operators :‘

+«0 -0 =0 =0

O+0 0-0 Q-0 OxQa

0+ E’r 3’- 0-0

EHg Mg

0/0 OeQd Qed Qo0

OeQ Qo0 1.0 Y4
0

o

- daQ Qvad

Figure 29: Sidebar Elements panel — Unary/Binary Operators page
Table 7: Unary/binary operators

Unary/binary operator Markup language Example formula
Plus + +1
Minus - -1
Plus/minus +- or plusminus +1
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Unary/binary operator Markup language Example formula
Minus/plus -+ or minusplus 1
Addition <> + <?> A+B
Subtraction <> - <> A—B
Multiplication (Dot) <?> cdot <?> A-B
Multiplication <?> times <?> AXB
Multiplication (*) <> * <> Ax*xB
A
Division (Fraction) {<?>} over {<?>} B
. A

Frac (Fraction) frac {<?>} {<?>} B
Division <?> div <?> A+B
Division (Slash) <?> / <?>or <?> slash <?> AlB

L i ; A
Division (Wideslash) {<?>} wideslash {<7>} /B

L . ; B
Division (Counter Wideslash) <?> widebslash <?> A
Concatenate <?> circ <?> Ac°B
Boolean NOT neg <?> —A
Boolean AND <?> and <?>or<?> & <?> AANB
Boolean OR <?> or <?> AVB
Backslash <?> bslash <?> A\B
Slash in circle <?> odivide <?> AQB
Small multiply symbol in circle <?> odot <?> AGB
Subtract symbol in circle <?> ominus <?> ASB
Add symbol in circle <?> oplus <?> A®B
Multiply symbol in circle <?> otimes <7> A®B
User defined binary operator <?> boper ??7??? <> AbinOp B
User defined unary operator uoper 77?77 <?> unOp B

Relations

To access the regularly used relations when entering markup language into the Formula Editor,
select Relations in the Elements panel on the Sidebar (Figure 30). Refer to Table 8 for a
complete list of relations.
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Figure 30: Elements panel in Sidebar — Relations page

Table 8: Relations

Relation Markup language Example formula
Is equal <> = <> A=B
Is not equal <?> <> <?>or<?> neq <?> A#B
Is less than <?> < <?>or<?> 1t <?> A<B
Is less than or equal to <> <= <> A<B
Is less than or equal to <?> leslant <?> A<B
Is greater than <?> > <?>o0r<?> gt <?> A>B
Is greater than or equal to <> >= <> A>B
Is greater than or equal to <?> geslant <?> A=B
Is much less than <?> << <?>or<?> 11 <?> A<B
Is much greater than <?> >> <?>or<?> gg <?> A>B
Is approximately equal <?> approx <?> A~B
Is similar to <?> sim <?> A~B
Is similar to or equal <?> simeq <?> A=B
Is congruent to <?> equiv <?> A=B
Is proportional to <?> prop <?> AxB
Is parallel to <?> parallel <?> A|lB
Is orthogonal to <?> ortho <7?> AlB
Divides <?> divides <?> A|B
Does not divide <?> ndivides <?> AYB
Toward <?> toward <?> A->B
Double arrow left <?> dlarrow <?> A<B
Double arrow left and right <?> dlrarrow <?> A< B
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Relation Markup language Example formula
Double arrow right <?> drarrow <?> A=>B
Precedes <?> prec <?> A<B
Succeeds <?> succ <?> A>B
Precedes or equal to <?> preccurlyeq <?> A<B
Succeeds or equal to <?> succcurlyeq <?> A>=B
Precedes or equivalent to <?> precsim <?> A<B
Succeeds or equivalent to <?> succsim <?> AzB
Not precedes <?> nprec <?> A+4B
Not succeeds <?> nsucc <?> A¥B
Definition <?> def <?> AZB
Corresponding symbol image of |<?> transl <?> A—B
Corresponding symbol original of | <?> transr <?> A-B

Set operations

To access the regularly used set operations when entering markup language into the Formula
Editor, select Set Operations in the Elements panel on the Sidebar (Figure 31). Refer to Table 9

for a complete list of set operations.

Elements

|Set Operations

Jdeld O U=l

anQ dud O\Na /4
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Figure 31: Elements panel in Sidebar — Set Operations page

Table 9: Set operations

Set operation Markup language Example formula
Isin <?> in <?> A€EB
Is not in <?> notin <7?> A¢B
Oowns <?> owns <?>or<?> ni <?> ASB
Intersection <?> intersection <?> ANB
Union <?> union <7?> AUB
) <?> setminus <7?>or
Difference <?> bslash <7> A\B
Quotient set (slash) between
<?> <?>

characters slash AlB
Subset <?> subset <?> AcB
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Set operation Markup language Example formula
Subset or equal to <?> subseteq <?> ACB
Superset <?> supset <?> ADB
Superset or equal to <?> supseteq <?> A2B
Not subset <?> nsubset <?> AZB
Not subset or equal to <?> nsubseteq <7> AZB
Not superset <?> nsupset <?> ADB
Not superset or equal to <?> nsupseteq <?> AZ2B
Empty set emptyset )]
Aleph (cardinal numbers) aleph N
Natural numbers set setN IN
Integers set setZ Z
Set of rational numbers setQ Q
Real numbers set setR R
Complex numbers set setC C
Functions

To access the regularly used functions when entering markup language into the Formula Editor,
select Functions in the Elements panel on the Sidebar (Figure 32). Refer to Table 10 for a
complete list of functions.

[ Elements

lFunctions il
o] o va =
Q- e In(Q)  exp(Q)

log(Q)  #(Q)
sin(d)  cos(d) tan(d)  cot(Q)
sinh(d) cosh(d) tanh(d) coth(Q)

@Ha T Mg

a(@) W@ W@ k@)
L@ w@ =@ =(Q)
(@) shk(Q)  e(@) ()
(@) =@ w@) us(@)
6(Q) @@ =)
*(Q) k(@) 8@ Q)
arcsin() arccos(0) arctan() arccot(Od)
arsinh Q) arcosh(d) artanh(Q) arcoth(Q)

<7>(0)

4

Figure 32: Elements panel in Sidebar — Functions page
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Table 10: Functions

Operation Markup language Example formula
Absolute value abs{<?>} |A
Factorial fact{<?>} Al
Square root sqrt{<?>} \/Z
Nth root nroot{<?>}{<?>} B
Power <> <>} AB
Natural exponential function func e™{<?>} e
Natural logarithm In(<?>) In(A)
Exponential function exp(<?>) exp(A)
Logarithm log(<?>) log(A)
Sine sin(<?>) sin(A)
Cosine cos (<?>) cos(A)
Tangent tan(<?>) tan(A)
Cotangent cot(<?>) cot(A)
Hyperbolic sine sinh(<?>) sinh(A)
Hyperbolic cosine cosh(<?>) cosh(A)
Hyperbolic tangent tanh(<?>) tanh (A)
Hyperbolic cotangent coth(<?>) coth(A)
Inverse sine or arcsine arcsin(<?>) arcsin(A)
Inverse cosine or arccosine arccos(<7>) arccos (A)
Inverse tangent or arctangent arctan(<?>) arctan(A)
Inverse cotangent or arccotangent arccot(<?>) arccot(A)
Inverse or area hyperbolic sine arsinh(<?>) arsinh (A)
Inverse or area hyperbolic cosine arcosh(<?>) arcosh (A)
Inverse or area hyperbolic tangent artanh(<?>) artanh(A)
Inverse or area hyperbolic cotangent arcoth(<?>) arcoth (A)
Back epsilon backepsilon E)
Subscript <?> sub <?> Ag
Operators

To access the regularly used operators when entering markup language into the Formula Editor,
select Operators in the Elements panel on the Sidebar (Figure 33). Refer to Table 11 for a

complete list of operators.
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Elements

|Dp-etatun

lim U

lim

o .j
g limQ  limU

o O

lim inf Q liminf O " e lim inf O

: 0
lim sup 1 lunjsup n ]jmjsup Q l'u‘njsup a

0 O

e R i s g
O

® =& ® Mo

Figure 33: Elements panel in sidebar — Operators page

7 Note

For customized operators, use the command oper followed by the custom operator.

1
For example, entering oper OP from © to 1 A will create the formula QP A .
0

Table 11: Operators

Operation Markup language Example formula
Limes lim <?> lim A
Limes subscript bottom lim from{<?>} <7> h/?l B

A
Limes superscript top lim to{<?>} <7> lim B

B
Limes sup/sub script lim from{<?>} to{<?>} <?> lim C

A
Limes inferior liminf <7> lim inf A
Limes superior limsup <?> lim sup A
Sum sum <?> z a

Sum subscript bottom

sum from{<?>} <?>

> B

Sum superscript top

sum to{<?>} <?>

A

> B

Sum sup/sub script

sum from{<?>} to{<?>} <?>

Product superscript top

prod to{<?>} <7?>

Product prod <?> H A
Product subscript bottom prod from{<?>} <?> 1;[ B
A

Product sup/sub script

prod from{<?>} to{<?>} <?>
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Operation Markup language Example formula
Coproduct coprod <?> H A
Coproduct subscript bottom coprod from{<?>} <?> ]X[ B
A
Coproduct superscript top coprod to{<?>} <7> H B
B
Coproduct sup/sub script coprod from{<?>} to{<?>} <?> H C
A
Integral int <?> f A
Integral subscript bottom int from{<?>} <?> f B
A
A
Integral superscript top int to{<?>} <?> fB
B
Integral sup/sub script int from{<?>} to{<?>} <?> fC
A
Double integrall iint <?> ﬂ A
Double integral subscript bottom | iint from{<?>} <?> ﬂ B
A
A
Double integral superscripttop | iint to{<?>} <?> ﬂ" B
B
Double integral sup/sub script iint from{<?>} to{<?>} <?> ﬂ C
A
Triple integral iiint <?> ﬂf A
Triple integral subscript bottom | iiint from{<?>} <?> ﬂf B
A
A
Triple integral superscript top iiint to{<?>} <?> J‘ﬂ" B
B
o > >
Triple integral sup/sub script Eint Jloie e ﬂf C
) A
Curve integral lint <?> ¢A
Curve integral subscript bottom | lint from{<?>} <?> fﬁB
A
A
Curve integral superscript top lint to{<?>} <?> fﬁB
B
Curve integral sup/sub script lint from{<?>} to{<?>} <?> §ﬁC
A
Double curve integral 1lint <?> # A
Double curve integral subscript - 5 5 B
bottom 1lint from{<?>} <?> ﬁ
Double curve integral superscript : 5 5 A
top 1lint to{<?>} <?> #B
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Operation Markup language Example formula
B
Double curve integral sup/sub 1lint from{<?>} to{<?>} # C
script <> 2
Triple curve integral 1llint <?> fﬁﬁ A
Triple curve integral subscript 3 5 5 B
bottom 11lint from{<?>} <?> Eq;yﬁ
Triple curve integral superscript 3 5 5 A
top 1llint to{<?>} <?> ﬁ;EB
B
Triple curve integral sup/sub 3 5 5 5
script 1llint from{<?>} to{<?>} <7> ﬁJ;C
Attributes

To access the regularly used attributes when entering markup language into the Formula Editor,
select Attributes in the Elements panel on the Sidebar (Figure 35). Refer to Table 12 for a
complete list of attributes.

' Elements “‘i
. = |
a o o a o |
a a a a a & |
a a 0 i=|
g 3 & a u S| P
Q a @|
hide B I size font |
black blue green red
fuchsia gray maroon
navy olive purple teal
rgb hex
coral  midnight crimson
orangered seagreen indigo  hotpink

Figure 34: Elements panel in Sidebar — Attributes page

7 Note

The font command changes the font type. The first placeholder is replaced with the
name of the font and the second placeholder is replaced with the selected formula
values or text. The default fonts are Serif, Sans, or Fixed. If custom fonts have been
added to Math (see Chapter 1, Creating and Editing Formulas), then replace the first
placeholder with the custom font name.
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Table 12: Attributes

Operation Markup language Example formula
Acute accent acute <?> A
Grave accent grave <?> A
Breve breve <7> A
Circle circle <?> A
Dot dot <?> A
Double dot ddot <?> A
Triple dot dddot <7> A
Line above bar <?> A
Vector arrow vec <7> A
Harpoon harpoon <7> A
Tilde tilde <?> A
Circumflex hat <?> A
Reverse circumflex check <7> A
Large vector arrow widevec {<?>} AB
Large harpoon wideharpoon <?> AB
Large tilde widetilde {<?>} ‘AB
Large circumflex widehat {<?>} AB
Line over overline {<7?>} AB
Line below underline {<7?>} AB
Line through overstrike {<7?>} AB
;I'Ora(l:r::g?eresr;ta(é);z;mk placeholder phantom {<?>} A B
Bold font bold <?> AB
Not bold font nbold <?> AB
Italic font ital <?> or italic <?> AB
Not italic font nitalic <?> AB
Resize size <?> {<7>} AB
Change font font <?> {<?>} AB

Operation

Markup language

Example formula

Color aqua (same as cyan)

color aqua {<?>}

Color black color black {<?>} AB
Color blue color blue {<?>} AB
Color coral color coral {<?>}

Color crimson color crimson {<?>} AB
Color cyan color cyan {<?>}

%‘;‘g;r‘:‘:acma (same as Color fuchsia {<?>} AB
Color gray color gray {<?>} AB
Color green color green {<?>} AB

Color hotpink

color hotpink {<?>}

Appendix A, Command Reference | 77




Color indigo color indigo {<?>} AB
Color lavender color lavender {<?>}

Color lime color lime {<?>} AB
Color magenta color magenta {<?>} AB
Color maroon color maroon {<?>} AB
Color midnight color midnightblue {<?>} AB
Color navy color navy {<?>} AB
Color olive color olive {<?>} AB
Color orange color orange {<?>}

Color orangered color orangered {<?>} AB
Color purple color purple {<?>} AB
Color red color red {<?>} AB
Color seagreen color seagreen {<?>} AB
Color silver color silver {<?>}

Color teal color teal {<?>} AB
Color violet color violet {<?>}

Color yellow color yellow {<?>}

Hexadecimal colors color hex 000000 {<?>} AB
RGB colors color rgb R G B {<?>}

Brackets

To access the regularly used brackets when entering markup language into the Formula Editor,
select Brackets in the Elements panel on the Sidebar (Figure 35). Refer to Table 13 for a

complete list of brackets.

Elements

Figure 35: Elements panel in Sidebar — Brackets page

Q

(@) [@Q [@ @ (@ (@aq) [a
Q] a1

@ [a &l @& @ @@ [al
al a3l

—=_ d4aaqa

Qoa 5

Q OL af o8

J
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Table 13: Brackets

Operation Markup language Example formula
]%:(;rllﬂ;)rackets (not displayed in (<75} AB
Round brackets (<?>) (AB)
Left round bracket only \ (<?> (A
Right round bracket only <?>\) A)
Square brackets [<?>] [AB]
Left square bracket only \[<?> [A
Right square bracket only <>\] Al
Double square brackets ldbracket <?> rdbracket | AB]
Left double square bracket only |\ldbracket <?> [A
Right double square bracket only | <?> \rdbracket Al
Braces lbrace <?> rbrace [AB]
Left brace only \lbrace <?> [A
Right brace only <?> \rbrace A}
Angle brackets langle <?> rangle (AB)
Left angle bracket only \langle <?> (A
Right angle bracket only <?> \rangle A)
Operator brackets langle <?> mline <?> rangle (AB|CD)
geiling (upper half square @il = rgaitl [AB]
rackets)
Left ceiling only \lceil <?> [A
Right ceiling only <?> \rceil Al
E:ggrk((altos\;ver half square 1floor <?> rfloor | AB|
Left floor only \lfloor <?> |A
Right floor only <?> \rfloor Al
Single lines lline <?> rline | AB|
Left single line only \lline <?> |A
Right single line only <?> \rline Al
Double lines ldline <?> rdline ||AB|
Left double line only \ldline <?> I|A
Right double line only <?> \rdline Al
Scalable round brackets left ( <?> right ) (%)
Scalable left round bracket only |left ( <?> right none (%
Scalable right round bracket only | Left none <?> right ) %)
Scalable square brackets left [ <?> right ] [%]
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Operation Markup language Example formula
Scalable left square bracket only | left [ <?> right none l%
Scalable right square bracket left none <?> right ] é

only ' 9 B

Scalable double square brackets

left ldbracket <?> right
rdbracket

Scalable left double square
bracket only

left ldbracket <?> right none

Scalable right double square
bracket only

left none <?> right rdbracket

m I |
LA ETES

Scalable braces

left lbrace <?> right rbrace

o>

Scalable left brace only

left lbrace {<?>} right none

Scalable right brace only

left none {<?>} right rbrace

TR

Scalable angle brackets

left langle <?> right rangle

T~
oo | >
\/

Scalable left angle bracket only

left langle {<?>} right none

Scalable right angle bracket only

left none {<?>} right rangle

T~
o J b N

Scalable operator brackets

left langle <?> mline <?>
right none

—
o | >
\/

Scalable left operator bracket

left langle <?> mline <?>
right none

—
o>

wlle!

. left none <?> mline <?> right AlC
Scalable right operator bracket rangle B ‘ D
Scalable ceiling (upper half left lceil <?> right rceil A
square brackets) ’ B
. : : A
Scalable left ceiling left lceil <?> right none B
. . : : A
Scalable right ceiling left none <?> right rceil E

Scalable floor (lower half square
brackets)

left Ufloor <?> right rfloor

| >

Scalable left floor

left lfloor <?> right none

W
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Operation Markup language Example formula
Scalable right floor left none <?> right rfloor %
. . : : : A
Scalable single lines left 1line <?> right rline B
. . : : A
Scalable left single line left 1line <?> right none B
. . . : . A
Scalable right single line left none <?> right rline B
. : : : A
Scalable double lines left ldline <?> right rdline B
. : : A
Scalable left double line left ldline <?> right none B
Scalable right double line left none <?> right rdline %H
D
Scalable top b <?>} overbrace {<?> ~—
op brace {<?>} {<?>} ABC
Scalable bottom brace {<?>} underbrace {<?>} éiq
D

Formats

To access the regularly used formats when entering markup language into the Formula Editor,
select Formats in the Elements panel on the Sidebar (Figure 36). Refer to Table 14 for a

complete list of formats.

|Farm.ats-
a- da
—
a
d
a
Qg

-0 od EI ::II
~ d left center right

g d
a d

]

@ =@ ® M,

Figure 36: Elements panel in Sidebar — Formats page

ﬁ Note

By default, text characters are aligned to the center in a formula. Use the alignl
and alignr commands to align text characters in a formula to the left or right when a
formula has more than one line. Also, use the align commands in conjunction with
the stack commands to align multi-line formulas on a specific formula element, for
example, the equals sign (=).
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Table 14: Formats

Operation Markup language Example formula
L <?>"{<?>} or <?>sup{<?>} or
Power (superscript right) <?>riup{l?>} p{<?>} 20"
- <?> {<?>} or <?>sub{<?>} or

Subscript right <?>rsub{<t=} 204,
Superscript left <?>1sup{<?>} 1990
Subscript left <?>lsub{<?>} 1020
Superscript center <?>csup{<?>} 2100
Subscript center <?>csub{<?>} 21(?
New line newline 1CZI:)))
Small gap : 123 456
Blank or large gap ~ 123 456
No space (suppresses space -
between elements) nospace {<?>} 12+4+5
Align left alignl <?> gBC
Align center alignc <?> Al];C
Align right alignr <?> ABg

. : AB
Vertical stack (2 elements) binom{<?>}{<?>} 12

. AB
Vertical stack (more than 2 stack{<?> # <?> # <75} 12
elements) cD
Matrix stack matrix{<?> # <?> ## <?> # <? AB 12

>} 34 CD
Others

To access the regularly used other commands when entering markup language into the Formula
Editor, select Others in the Elements panel on the Sidebar (Figure 37). Refer to Table 15 for a
complete list of other commands.
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0w g VIAVHEAIXRI pZL5F
E

€ > 13

e Hg e g

Figure 37: Elements panel in Sidebar — Others page
Table 15: Others

Operation Markup language Example formula
Placeholder <?>
Infinity infinity or infty 00
Partial derivative or set margin | partial 0
Nabla vector operator nabla V
:Eegg;[eor;[ieal quantifier, there is at Er—— 3
E())(iset)e(ir;t:al quantifier, there does o i alRie A
Universal guantifier, for all forall Y
H-bar constant hbar fi
Lambda bar lambdabar A
Real part of a complex number | re R
Inmu?ngtl)g?ry part of a complex i R
Weierstrass p function wp @)
Laplace transformation laplace <
Left arrow leftarrow €«
Right arrow rightarrow >
Up arrow uparrow 1T
Down arrow downarrow 4
Ellipsis dotslow
Math axis ellipsis dotsaxis
Vertical ellipsis dotsvert
Upward diagonal ellipsis dotsup or dotsdiag
Downward diagonal ellipsis dotsdown

Greek characters

Greek and italic Greek characters are normally entered into a formula using the Symbols dialog
(Figure 38 and Figure 39). However, if the Greek character is known, type a percentage sign (%)
followed by the Greek character name into the Formula Editor.

» For uppercase Greek characters, type the name using uppercase characters, for
example %BETA B . See Table 16 for a list of uppercase Greek characters.
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» For lowercase Greek characters, type the name using lowercase characters, for example
%beta [3 . See Table 16 for a full list of lowercase Greek characters.

Symbols X

Symbol set:

eraezHs
® I KAMNE
OnNPITYS®
XYQapy é
£ {n 8 1 x A
pv &€ omp ¢
O TV OQ Y Ve
Jd ¢ w p €
ALPHA

Help Edit... Close

Figure 38: Symbols dialog — Greek characters

« ltalic Greek characters, type the character i after the percentage sign (%) and before the
name of the Greek character, for example, %iPI II for uppercase and %ipi for
lowercase m . See Table 17 for a full list of italic Greek characters.

Symbols X

Symbol set:

BsraezH
®© 1 KAMNIE
onpePrrTyae
X PO a By é
e {n 68 1 x A
pv<E&omnmpg
g T v o ¥ ¥
v ¢ mw o €
IALPHA

Help Edit... Close

Figure 39: Symbols dialog — Italic Greek characters
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ﬁ Note

In localized versions of LibreOffice, the names of Greek characters are also
localized. If a document is not localized to the same language, then the names of
Greek characters in the following tables may not work correctly. If this happens, use
the Symbols dialog to select the required Greek character. When selected in the
Symbols dialog, the name of the Greek character is displayed at the bottom of the
Symbols dialog in the correct language.

Table 16: Greek characters

Markup language Lé;’),[; iﬁzf Markup language Lg’z i;i?:f
SSALPHA A %alpha o
%BETA B %beta B
%GAMMA r %sgamma '
%DELTA A %delta )
%EPSILON E %epsilon €
%ZETA Z %zeta (
SETA H %eta n
%THETA ® %theta 0
%I0TA I %iota 1
%KAPPA K %kappa K
%LAMBDA A %lambda A
MU M Ssmu il
%NU N %snu \%
X1 = %xi S
%0MICRON O ssomicron 0
%PI IT %pi Tl
%RHO P %rho p
%SIGMA hX %sigma o
%TAU T Sstau T
%UPSILON Y %supsilon L
%PHI O %phi 0]
%CHI X %chi X
%PSI P %psi U]
%0MEGA Q ‘somega W
Table 17: Italic Greek characters
Markup language Lg;,’; ?';cc?:f Markup language LCO,';:! (:;f’::f
%1ALPHA A %ialpha o
%1BETA B %ibeta B
%1GAMMA r %sigamma Y
%1DELTA A %idelta 1)
%1EPSILON E %iepsilon €
%1ZETA Z %izeta {
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Markup language lé;;,;; i;‘:’;:f Markup language LCO,';; 7_;‘:;:?
%1ETA H %ieta n
%1THETA C %itheta 0
%1I0TA I %iiota l
%1KAPPA K %ikappa K
%iLAMBDA A %ilambda A
%iMU M %imu U
%1NU N %1inu v
%1XI =) %ixi &
%10MICRON O %siomicron o)
%1iPI I1 %ipi T
%1RHO p %irho p
%1SIGMA 2 %isigma g
%1TAU T %itau T
%1iUPSILON Y %iupsilon v
%1PHI (0 %iphi [0}
%1CHI X %ichi X
%iPSI b %ipsi Y
%10MEGA Q %iomega w

Special characters

Special characters are normally entered into a formula using the Symbols dialog (Figure 38 and
Figure 39). However, if the name of the special character is known, type a percentage sign (%)
followed by the special character name into the Formula Editor. Table 18 Shows the full list of
special characters that are available in LibreOffice.

Table 18: Special characters

Markup language Character | Markup language Character
%perthousand %o %tendto -
%snoelement & %infinite o0
%angle < %and A

%or V %notequal #
%identical = %strictlylessthan <
%sstrictlygreaterthan >

7 Note

In localized versions of LibreOffice, the names of special characters are also
localized. If a document is not localized to the same language, then the names of
special characters in Table 18 may not work correctly. If this happens, use the
Symbols dialog to select the required special character. When selected in the
Symbols dialog, the name of the special character is displayed at the bottom of the
Symbols dialog in the correct language.
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Reserved words

Areserved word is a word that is used by LibreOffice as a command in the Math markup
language and cannot be used as a variable name or entered into a formula as text. To use a
reserved word as text in a formula then a reserved word must be placed between double quotes.

For example, consider that to use the words “color purple” in a formula and all the formula
elements are not changed to the color purple. If A purple B is typed into the Formula Editor,
the resulting formula is A (B , which is incorrect and the error is shown by the inverted question
mark. To correct this error, type A "color purple" B inthe Formula Editor using double
quotes each side of the words and the resulting correct formula is A color purple B .

If the italic version of the word “purple” is required, enter A italic{ "color purple" } Binto
the Formula Editor, which creates A color purple B in the formula.
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j LibreOffice

Community

LibreOffice Documentation Team

Math Guide

Using the formula editor

About this book:

Math is a simple formula editor that lets you lay out and display mathematical,
chemical, electrical, or scientific formulas quickly in standard written notation.

It is most commonly used in Writer for text documents, but it can also be used with
other types of documents or stand-alone.

If you have never used LibreOffice before, or you want an introduction to all of its
components, you might like to read the Getting Started Guide first.

About the authors:

This book was written by volunteers from the LibreOffice community. Profits from the
sales of the printed edition are used to benefit the community.

A PDF version of this book can be downloaded free from:
https://documentation.libreoffice.org/en/
About LibreOffice:

LibreOffice is the free, libre, and open source personal productivity suite from The
Documentation Foundation. It runs on Windows, macOS, and GNU/Linux. Support and
documentation is free from a large, dedicated community of users, contributors, and
developers.

Get involved as a volunteer and work in many areas: development, quality assurance,
documentation, translation, user support, and more.

Download LibreOffice for free from:
https://libreoffice.org/downloads/

For commercial use:

Work with certified LibreOffice professionals for any business needs, from deployment
or conversion from other office suits, staff training, or custom development needs.

For information on professional support services, go to
https://www.libreoffice.org/get-help/professional-support/
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