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What is Writer?

What is Writer?

Writer is the word processor component of OpenOffice.org (OOo). In addition to the usual 
features of a word processor (spell checking, thesaurus, hyphenation, autocorrect, find and 
replace, automatic generation of tables of contents and indexes, mail merge, and others), 
Writer provides these important features:

• Templates and styles

• Powerful page-layout methods (including frames, columns, and tables)

• Embedding or linking of graphics, spreadsheets, and other objects

• Built-in drawing tools

• Master documents—to group a collection of documents into a single document

• Change tracking during revisions

• Database integration, including a bibliography database

• Export to PDF, including bookmarks

• And many more

Styles are central to using Writer. Styles enable you to easily format your document 
consistently and to change the format with minimal effort. Often, when you format your 
document in Writer, you are using styles whether you realize it or not. A style is a named set 
of formatting options. Writer defines several types of styles, for different types of elements: 
characters, paragraphs, pages, frames, and lists. The use of styles is described in more detail 
in other chapters in this guide, including Chapter 6 (Introduction to Styles) and Chapter 7 
(Working with Styles).

The other features of Writer listed above are also covered in detail in other chapters of this 
guide.

Starting Writer

If you are reading this document in OpenOffice.org, you already know how to start Writer. 
However, if this is a printed version or a PDF version, you may not know how to start Writer. 
So let’s look at three ways to do that:

• From the system menu

• From an existing document

• From the command line
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Starting from the system menu
Using the system menu is the most common way to start Writer. The system menu is the 
standard menu from which most applications are started. On Windows, it is called the Start 
menu. On GNOME, it is called the Applications menu. On KDE, it is identified by the KDE 
logo. On Mac OS X, it is the Applications menu.

When OpenOffice.org was installed, a menu entry was added to your system menu. The exact 
name and location of this menu entry depends on your graphical environment. This chapter 
looks at Windows, GNOME and KDE on Linux, and Mac OS X. The concepts should easily 
be applicable to another operating system.

Windows

On Windows, the OpenOffice.org menu is located in Programs > OpenOffice.org 2.x, 
where “2.x” corresponds to the version number of OpenOffice.org. Figure 1 shows a typical 
setup on Windows XP. Select OpenOffice.org Writer to start Writer with a blank document.

Figure 1. Starting Writer from the Windows XP Start menu
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Linux/GNOME

GNOME installations differ from one distribution to the next. Most modern distributions 
come with OpenOffice.org already installed. You will find OpenOffice.org under 
Applications > Office, as shown in Figure 2.

Figure 2. Starting Writer from the GNOME Applications menu

Fedora/Red Hat Enterprise Linux comes with OpenOffice.org installed. On the GNOME 
desktop, OOo can be found under Main Menu > Office. If you have installed a newer 
version of OOo, you will find it under Main Menu > Office > More Office Applications.

If you installed by downloading OOo from the http://www.openoffice.org website, it is under 
Applications > Other.
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Linux/KDE

On KDE, OpenOffice.org is installed in its own menu, called Office (see Figure 3).

Figure 3. Starting OOo from KDE start menu

Some Linux distributions install OpenOffice.org in the Office submenu. Mandrake is such a 
distribution. In this case, to launch Writer, choose Office > Word processors > 
OpenOffice.org Writer. Figure 4 illustrates the OOo menu with Math selected.
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Figure 4: Starting OOo from Mandrake's KDE menu

Mac OS X

Go to the folder where you installed OpenOffice.org. You should see its icon in the 
Applications folder (Figure 5). To start Writer, double-click the OpenOffice.org icon.

Figure 5: Starting OpenOffice.org from the Mac Applications folder
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Starting from an existing document
If you installed OpenOffice.org correctly, all Writer documents are associated with the Writer 
application. This means that you can start OpenOffice.org automatically, simply by double-
clicking a Writer document in your favorite file manager (for example, Windows Explorer).

You can spot an OpenOffice.org Writer document by its icon: .

For Windows users

File associations are used to open certain types of files automatically with OpenOffice.org. 
When installing OOo, you could choose to associate Microsoft Office file types with OOo. If 
you chose to do this, then when you double-click on a *.doc file, it opens in OOo Writer.

If you did not associate the file types, then when you double-click on a Microsoft Word 
document, it opens in Microsoft Word (if Word is installed on your computer).

You can use another method to open *.doc files in OOo and save in the *.doc format from 
OOo. See “Opening an existing document” on page 17 for more information.

Using the Quickstarter under Windows
The Quickstarter is an icon that is placed in the Windows system tray during system startup. 
It indicates that OpenOffice.org has been loaded and is ready to use. (The Quickstarter loads 
library *.DLL files required by OOo, thus shortening the startup time for OOo components 
by about half.) If the Quickstarter is disabled, see “Reactivating the Quickstarter” on page 8 
if you want to enable it.

Using the Quickstarter icon

Right-click the Quickstarter icon in the system tray to open a pop-up menu from which you 
can open a new document, open the Templates and Documents dialog box, or choose an 
existing document to open. (See Figure 6.) You can also double-click the Quickstarter icon 
to display the Templates and Documents dialog box.

Figure 6: Quickstarter pop-up menu
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Disabling the Quickstarter

To close the Quickstarter, right-click on the icon in the system tray and then click Exit 
Quickstarter on the pop-up menu. The next time the computer is restarted, the Quickstarter 
will be loaded again.

To prevent OpenOffice.org from loading during system startup, deselect the Load 
OpenOffice.org During System Start-Up item on the pop-up menu. You might want to do 
this if your computer has insufficient memory, for example.

Reactivating the Quickstarter

If the Quickstarter has been disabled, you can reactivate it by selecting the Load 
OpenOffice.org during system start-up checkbox in Tools > Options > OpenOffice.org > 
Memory.

Using the Quickstarter under Linux
Some installations of OpenOffice.org under Linux have a Quickstarter that looks and acts 
like the one described above for Windows (the checkbox on the Memory page is labeled 
Enable systray quickstarter). The Linux Quickstarter is disabled in other installations, but 
it will be operational in future releases.

Preloading OOo under Linux/KDE
In Linux/KDE, you can use KDocker to have OOo loaded and ready for use at startup. 
KDocker is not part of OOo; it is a generic “systray app docker” that is helpful if you open 
OOo often.

Starting from the command line
You may want to start Writer from the command line (using the keyboard instead of the 
mouse). Why? Well, by using the command line, you have more control over what happens 
when Writer is started. For example, using the command line, you can tell Writer to load a 
document and print it immediately, or to start without showing the splash screen.

Note Most users will never need to do this.

There is more than one way to start Writer from the command line, depending on whether 
you have installed a customized version or the standard download from the OOo web site.

If you installed using the download on the OOo web site, you can start Writer by typing at the 
command line:

soffice -writer
or

swriter

Writer will start and create a new document.
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Starting Writer

To see a list of options you can use when starting Writer at the command line, type:

soffice -?

If you have a customized version of OOo (such as the one provided by Linux Mandrake or 
Gentoo), you can start Writer by typing at the command line:

oowriter

Note Although the command syntax differs, the effect is identical: it starts OOo with an 
empty Writer document.

The Writer interface

The main Writer workspace is shown in Figure 7.

Figure 7: The main Writer workspace in Print Layout view

Menus
Menus are located across the top of the Writer window. The main menu selections are File, 
Edit, View, Insert, Format, Table, Tools, Window, and Help. When you click one of the 
main menu names, a list of related options is displayed.

• File contains commands that apply to the entire document such as Open, Save, and 
Export as PDF.

• Edit contains commands for editing the document such as Undo and Find & Replace.

• View contains commands for controlling the display of the document such as Zoom and 
Web Layout.
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The Writer interface

• Insert contains commands for inserting elements into your document such as headers, 
footers, and pictures.

• Format contains commands for formatting the layout of your document, such as Styles 
and Formatting, Paragraph, and Bullets and Numbering.

• Table shows all commands to insert and edit a table in a text document.

• Tools contains functions such as Spellcheck, Customize, and Options.

• Window contains commands for the display window.

• Help contains links to the Help file, What’s This?, and information about the program. See 
“Getting help” on page 22.

Toolbars
Writer has several types of toolbars: docked, floating, and tear-off. Docked toolbars can be 
moved to different locations or made to float, and floating toolbars can be docked.

The top docked toolbar (default position) is called the Standard toolbar. The Standard toolbar 
is consistent across the OpenOffice.org applications.

The second toolbar across the top (default location) is called the Formatting toolbar. It is a 
context-sensitive bar which shows the relevant tools in response to the cursor’s current 
position or selection. For example, when the cursor is on a graphic, the Formatting bar 
provides tools for formatting graphics; when the cursor is in text, the tools are for formatting 
text.

Figure 8. Writer toolbars
Floating toolbars

Writer includes several additional context-sensitive toolbars, whose defaults appear as 
floating toolbars in response to the cursor’s current position or selection. For example, when 
the cursor is in a table, a floating Table toolbar appears, and when the cursor is in a numbered 
or bullet list, the Bullets and Numbering toolbar appears. You can dock these toolbars to the 
top, bottom, or side of the window, if you wish (see “Moving toolbars” on page 11).

Long-click buttons and tear-off toolbars

Buttons with a small triangle to the right will display 
submenus, tear-off toolbars, and other ways of selecting 
things with a long click, depending on the button. 

Figure 9 shows the Paste submenu.
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The Writer interface

Figure 10 shows a tear-off toolbar from the Drawing toolbar.

The tear-off toolbars can be floating or docked along an edge of the screen or in one of the 
existing toolbar areas. To move a floating tear-off toolbar, drag it by the title bar. See 
“Moving toolbars” below.

Figure 10: Example of a tear-off toolbar

Displaying or hiding toolbars

To display or hide toolbars, choose View > Toolbars, then click on the name of a toolbar in 
the list. An active toolbar shows a check mark beside its name. Tear-off toolbars are not listed 
in the View menu.

Moving toolbars

To move a docked toolbar, place the mouse pointer over the toolbar handle, hold down the 
left mouse button, drag the toolbar to the new location, and then release the mouse button 
(Figure 11.

To move a floating toolbar, click on its title bar and drag it to a new location. Figure 12 
shows an example.

Figure 11: Moving a docked toolbar

Figure 12: Moving a floating toolbar
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The Writer interface

Rulers
To show or hide rulers, choose View > Ruler. To show the vertical ruler, choose Tools > 
Options > OpenOffice.org Writer > View and select Vertical ruler.

Figure 13. Turn on the vertical ruler using Tools > Options > OpenOffice.org Writer > View

Changing document views
OpenOffice.org has several ways to view a document: Print Layout, Web Layout, Full 
Screen, and Zoom. You can select these choices on the View menu. The only document view 
option with a submenu is Zoom. When you choose View > Zoom, the following dialog box 
appears.

Figure 14. Selecting a zoom factor
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Changing document views

• Entire Page: Displays the entire page on the screen (text may be too small to read).

• Page Width: Displays the complete width of the document page. The top and bottom 
edges of the page may not be visible.

• Optimal: Resizes the display to fit the width of the text in the document.

• 200%: Displays the document at two times its actual size.

• 150%: Displays the document at one and a half times its actual size.

• 100%: Displays the document at its actual size.

• 75%: Displays the document at 75% of its actual size.

• 50%: Displays the document at half of its actual size.

• Variable: Enter the zoom factor (percentage) at which you want to display the document.

Using dockable/floating windows

Some windows in OpenOffice.org, such as the Navigator and the Styles and Formatting 
window, are dockable. You can move, resize, or dock them to an edge.

To dock a window, do one of the following:

• Click on the title bar of the floating window and 
drag it to the side until you see the outline of a 
box appear in the main window (see Figure 15) 
and then release the window. This method 
depends on your system’s window manager 
settings, so it may not work for you.

• Hold down the Control key and double-click on 
a vacant part of the floating window to dock it 
in its last position. If that does not work, try 
double-clicking without using the Control key.

To undock a window, hold down the Control key and 
double-click on a vacant part of the docked window.

Note The Styles and Formatting window can 
also be docked or undocked by using 
Control+ double-click on the gray area 
next to the icons at the top of the window.

Figure 15: Docking a window
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Using the Navigator

The Navigator displays all objects contained in a document. It provides a very convenient 
way to move around a document and find items in it. The Navigator button is located on the 
Standard toolbar. You can also display the Navigator by choosing Edit > Navigator, or open 
it quickly by pressing F5.

Figure 16. Navigator toolbar icon

The Navigator displays lists of Headings, Tables, Text frames, Graphics, Bookmarks, and 
other items. Click the + sign by any of the lists to display the contents of the list.

If you only want to see the content in a certain category, highlight the category and click the 
Content View icon.

Figure 17. The Navigator

Note The Navigator looks somewhat different in a master document. For more 
information, see Chapter 13 (Working with Master Documents).

The Navigator helps you to reach objects quickly. Double-click the object in the Navigator to 
jump directly to that object’s position in the document, as shown in Figure 18.
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Using the Navigator

Figure 18. Using the Navigator to jump quickly to a heading

Arranging chapters using the Navigator
You can arrange chapters and move headings in the document by using the Navigator.

1) Click the Content View icon to expand the headings, if necessary.

2) Click on the heading in question.

3) Drag the heading to a new location on the Navigator or click the heading in the 
Navigator list, and then click Promote Level, Demote Level, Promote Chapter, or 
Demote Chapter.

Figure 19. Reorganizing with the Navigator
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Creating a new document

Creating a blank document
You can create a new, blank document in Writer in a number of ways:

• Press the Control+N keys. A new empty document opens. If you already have a 
document open, the new document appears in a new window.

• Use File > New > Text Document.

• Click the New button on the main toolbar .

Creating a document from a template
You can use templates to create new documents in Writer. Templates serve as the foundation 
of a set of documents, to make sure they all have a similar layout. For example, all the 
documents of the Writer Guide are based on the same template. As a result, all the documents 
look alike—they have the same headers and footers, use the same fonts, and so on.

Unfortunately, a brand-new OpenOffice.org installation does not contain many templates. It 
is possible for you to add new templates to your installation and use them for new 
documents. This is explained in Chapter 10 (Working with Templates). Many more templates 
can be downloaded from the Internet.

Once you do have templates on your system, you can create new documents based on them 
by using File > New > Templates and Documents. This opens a window where you can 
choose the template you want to use for your document.

The example shown in Figure 20 uses a template called “book” in the My Templates folder. 
Select it, then click the Open button. A new document is created based on the formats 
defined in the template.
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Creating a new document

Figure 20. Creating a document from a template

Opening an existing document

Here is one way to open an existing document in Writer:

1) Click File > Open (or press Control+O).

2) In the file chooser, you can reduce the list of files by selecting the type of file you are 
looking for. If you choose Text documents as the file type, you will only see 
documents Writer understands.

3) Select the file you want, and then click Open.

Note This method opens Word (*.doc) files, as well as OOo files and other formats.

You can also open an existing OOo Writer document using the same methods you would use 
to open any document in your operating system.
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Saving a document

There are three ways to save a document in Writer:

• Press Control+S.

• Select File > Save.

• Click the Save button on the main toolbar.

You also can tell Writer to save your document automatically at regular intervals. To enable 
this, you must configure OpenOffice.org to save all documents automatically.

1) Select Tools > Options. The Options window appears.

2) Select Load/Save > General.

3) Click on Save AutoRecovery information every. This enables the box to set the 
interval. The default value is 30 minutes. Enter the value you want by typing it or by 
pressing the up or down arrow keys.

Saving as a Microsoft Word document
You may need to share your documents with other people who do not use OpenOffice.org, 
but use Microsoft Word instead. Fortunately, OpenOffice.org can read and write Word files. 
To save a document as a Microsoft Word file:

1) First save your document in OpenOffice.org’s format (*.odt). If you do not, any 
changes you made since the last time you saved will only appear in the Microsoft 
Word version of the document.

2) Then click File > Save As. The Save As dialog box (Figure 21) appears.

3) In the Save as type drop-down menu, select the type of Word format you need.

4) Click Save.

From this point on, all changes you make to the document will occur only in the Microsoft 
Word document. You have actually changed the name of your document. If you want to go 
back to working with the OpenOffice.org version of your document, you must open it again.

Tip To have OOo save documents in a default Microsoft Word file format, go to Tools > 
Options > Load/Save > General. There is a section named Default file format. 
Under Document type, select Text document, under Always save as, select your 
preferred file format.
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Saving a document

Figure 21. Saving a file in Microsoft Word format

Printing a document

For more information about printing documents, see Chapter 5 (Printing, Faxing, Exporting, 
and E-mailing).

Quick printing

Click the Print File Directly icon  to send the entire document to the default printer 
defined for your computer.

Controlling printing using the Print dialog box
For more control over printing, use File > Print to display the Print dialog box (Figure 22).
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Printing a document

Figure 22. The Print dialog box

On the Print dialog box, you can choose:

• Which printer to use (if more than one are installed on your system) and the properties 
of the printer—for example, orientation (portrait or landscape), which paper tray to 
use, and what paper size to print on. The properties available depend on the selected 
printer; consult the printer’s documentation for details.

• Which pages to print, how many copies to print, and in what order to print them.

• Use dashes to specify page ranges and commas or semicolons to separate ranges; 
for example, 1, 5, 11–14, 34–40.

• Selection is the highlighted part of a page or pages.

• Which items to print. Click the Options button to display the Printer Options dialog 
box. For details about print options and setting defaults for Writer, see Chapter 5 
(Printing, Faxing, Exporting, and E-mailing).

Previewing pages before printing
The normal page view in Writer shows what each page will look like when printed, but it 
shows only one page at a time. If you are designing a document to be printed double-sided, 
you may want to see what facing pages look like. OOo provides a way to do this in Page 
Preview.

1) Click File > Page Preview, or click the Page Preview button .

The Writer window changes to display the current page and the following page and 
shows the Page Preview toolbar (Figure 23) in place of the Formatting toolbar.
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Printing a document

Figure 23. Page Preview toolbar

2) Click the Book Preview icon  to display left and right pages in their correct 
orientation (facing pages).

3) To print the document in this page view, click the Print page view icon .

4) To choose margins and other options for the printout, click the Print options page 

view icon  to display the Print Options dialog box. For more information, see 
Chapter 5 (Printing, Faxing, Exporting, and E-mailing).

Exporting to PDF

OpenOffice.org can export documents to PDF (Portable Document Format). This industry-
standard file format for file viewing is ideal for sending the file to someone else to view 
using Acrobat Reader or other PDF viewers.

Quick export to PDF

Click the Export Directly as PDF icon  to export the entire document using the default 
PDF settings. You are asked to enter the file name and location for the PDF file, but you do 
not get a chance to choose a page range, the image compression, or other options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as 
PDF. The PDF Options dialog box opens. This dialog box has four pages (General, Initial 
View, User Interface, and Security). Here you can choose which pages to include in the PDF, 
the type of compression to use for images (which affects the quality of images in the PDF), 
and other options. 

Make your selections, and then click Export. Then you are asked to enter the location and 
file name of the PDF to be created, and click Save to export the file.

For more information, see Chapter 5 (Printing, Faxing, Exporting, and E-mailing).
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Getting help

Writer provides several forms of help. In addition to a full Help file, you can choose whether 
to activate tooltips, extended tips, and the Help Agent.

Placing the mouse pointer over any of the icons displays a small box, called a tooltip. It gives 
a brief explanation of the icon’s function. For a more detailed explanation, select Help > 
What’s This? and hold the mouse pointer over the icon you need more help with.

Note
The extended tips option in OOo 2.x cannot be accessed from the Help menu as it 
was in OOo 1.x. Tips and extended tips can be turned on or off from Tools > Options 
> OpenOffice.org > General. What's This? help is a new feature in OOo 2.0.

Figure 24. The Help menu

Closing a document

To close a document, click File > Close.

You can also close a document by clicking on the Close icon on the document window. In 
Windows XP, this button looks like the red X shown in Figure 25.

If more than one OOo window is open, each window looks like the sample shown on the left 
in Figure 25. Closing this window leaves the other OOo windows open.

If only one OOo window is open, it looks like the sample shown on the right in Figure 25. 
Notice the small black X below the large red X. Clicking the small X closes the document 
but leaves OOo open. Clicking the large red X closes OOo completely.

Figure 25. Close icons in Windows XP

If the document has not been saved since the last change, a message box is displayed. Choose 
whether to save or discard your changes.
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Closing a document

Figure 26. Warning about unsaved changes on close

• Save: The document will be saved and then closed.

• Discard: The document will be closed, and all modifications since the last save will be 
lost.

• Cancel: Nothing will happen, and you will return to the document.

Caution Not saving your document could result in the loss of recently made changes, or 
worse still, your entire file.

Closing Writer

To close Writer completely, click File > Exit, or close the last open document as described in 
“Closing a document” on page 22.

If all the documents have been saved, Writer will close immediately. If any documents have 
been modified but not saved, a warning dialog box like the one shown in Figure 26 will 
appear. Follow the procedure in “Closing a document” to save or discard your changes.
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Choosing options that affect all of OOo

Choosing options that affect all of OOo

This section covers some of the settings that apply to all the components of OOo and are 
particularly important when using Writer. Other general options are discussed in Chapter 5 
(Setting Up OpenOffice.org) in the Getting Started guide.

Note The illustrations in this chapter were taken from the English (UK) version of OOo. 
The spelling of some terms may be different from those you see on your screen, 
especially if you are using the default English (US) version.

1) Click Tools > Options. The list in the left-hand box varies depending on which 
component of OOo is open. The illustrations in this chapter show the list as it appears 
when Writer is open.

2) Click the + sign by OpenOffice.org in the left-hand section of the Options – 
OpenOffice.org dialog box. A list of subsections drops down.

Figure 27: OpenOffice.org Options

Note The Back button resets options to the values that were in place when you opened 
OOo. This button has the same behavior on all the Options dialog box pages.

User Data options
Because Writer’s revision features mark your changes and comments with the name or 
initials stored in the User Data page, you will want to ensure that your name and initials 
appear there. To do this:

1) In the Options dialog box, click OpenOffice.org > User Data.

2) Fill in the form on the OpenOffice.org – User Data page (Figure 28) or amend or 
delete any existing incorrect information.
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Figure 28. Filling in User Data

General options
1) In the Options dialog box, click OpenOffice.org > General.

2) On the OpenOffice.org – General page (Figure 29), the options are as described below.

Figure 29. Setting General options for OpenOffice.org

Help - Tips

When Help: Tips are active, one or two words will appear when you hold the cursor over an 
icon or field on the main OOo window, without clicking. This setting also affects the display 
of notes: if both Help: Tips and Extended Tips are turned off, then you won’t see the 
contents of a note when you hold the cursor over the note.
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Help - Extended tips

When Extended tips are active, a brief description of the function of a particular icon or 
menu command or a field on a dialog box appears when you hold the cursor over that item.

Help Agent

To turn off the Help Agent (similar to Microsoft’s Office Assistant), deselect this checkbox. 
To restore the default Help Agent behavior, click Reset Help Agent.

Help formatting

High contrast is an operating system setting that changes the system color scheme to improve 
readability. To display Help in high contrast (if your computer’s operating system supports 
this), choose one of the high-contrast style sheets from the pull-down list. For Windows XP, 
the high-contrast style options are as described below.

High-contrast style Visual effect

Default Black text on white background

High Contrast #1 Yellow text on black background

High Contrast #2 Green text on black background

High Contrast Black White text on black background

High Contrast White Black text on white background

Open/Save dialog boxes

To use the standard Open and Save dialog boxes for your operating system, deselect the Use 
OpenOffice.org dialogs checkbox. When this checkbox is selected, the Open and Save 
dialog boxes supplied with OpenOffice.org will be used. See Chapter 3 (File Management) in 
the Getting Started guide for more about the OOo Open and Save dialog boxes.

Document status

Choose whether printing a document counts as changing the document. If this option is 
selected, then the next time you close the document after printing, the print date is recorded 
in the document properties as a change and you will be prompted to save the document again, 
even if you did not make any other changes.

Year (two digits)

Specifies how two-digit years are interpreted. For example, if the two-digit year is set to 
1930, and you enter a date of 1/1/30 or later into your document, the date is interpreted as 
1/1/1930 or later. An “earlier” date is interpreted as being in the following century; that is, 
1/1/20 is interpreted as 1/1/2020.
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View options
The choices of View options affect the way the document window looks and behaves.

1) In the Options dialog box, click OpenOffice.org > View.

2) On the OpenOffice.org – View page (Figure 30), set the options to suit your personal 
preferences. Some options are described below.

User Interface – Scaling

If the text in the help files or on the menus of the OOo user interface is too small or too large, 
you can change it by specifying a scaling factor. Sometimes a change here can have 
unexpected results, depending on the screen fonts available on your system. However, it does 
not affect the actual font size of the text in your documents.

Figure 30. Choosing View options for the OpenOffice.org applications

User Interface – Icon size and style

The first box specifies the display size of toolbar icons (Automatic, Small, or Large); the 
Automatic icon size option uses the setting for your operating system. The second box 
specifies the icon style (theme); here the Automatic option uses an icon set compatible with 
your operating system and choice of desktop: for example, KDE or Gnome on Linux.

User Interface – Use system font for user interface

If you prefer to use the system font (the default font for your computer and operating system) 
instead of the font provided by OOo for the user interface, select this checkbox.

User interface – Screen font antialiasing

(Not available in Windows, so not shown in Figure 30.) Select this checkbox to smooth the 
screen appearance of text. Enter the smallest font size to apply antialiasing.

Menu – Show icons in menus

Select this option if you want icons as well as words to be visible in menus.
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Font Lists - Show preview of fonts

When you select this option, the font list looks like Figure 31, Left, with the font names 
shown as an example of the font; with the checkbox deselected, the font list shows only the 
font names, not their formatting (Figure 31, Right). The fonts you will see listed are those 
that are installed on your system.

Figure 31. (Left) Font list showing preview; (Right) Font list without preview

Font Lists - Show font history

When you select this option, the last five fonts you have assigned to the current document are 
displayed at the top of the font list.

3D view – Use OpenGL

Specifies that all 3D graphics from Draw and Impress will be displayed in your system using 
OpenGL-capable hardware. If your system does not have OpenGL-capable hardware, this 
setting will be ignored.

3D view – Use OpenGL – Optimized output

Select this option for optimized OpenGL output. Disable the optimization in case of graphical 
errors of 3D output.

3D view – Use dithering

The Use dithering option uses dithering to display additional  colorswhen the computer’s 
graphics system offers less than the optimal 16 million (24-bit) colours. Dithering creates the 
illusion of new colors and shades by varying the pattern of color pixels. Varying the patterns 
of black and white dots, for instance, produces different shades of grey.

Note Internally, 3-D graphics are always created with 16 million colors (24-bit color 
depth) and dithering can be used to compensate when fewer actual colors are 
available. Without dithering, several bits of color information would be omitted, 
leading to significantly reduced image quality.

3D view – Object refresh during interaction

Specifies that if you rotate or move a 3-D object, the full display is rotated or moved and not 
a grid frame.

Tip Press Shift+Control+R to restore or refresh the view of the current document.

30 Chapter 2  Setting up Writer



Choosing options that affect all of OOo

Mouse positioning

Specifies if and how the mouse pointer will be positioned in newly opened dialog boxes.

Middle mouse button

Defines the function of the middle mouse button.

• Automatic scrolling – dragging while pressing the middle mouse button shifts the 
view.

• Paste clipboard – pressing the middle mouse button inserts the contents of the 
“Selection clipboard” at the cursor position.

The “Selection clipboard” is independent of the normal clipboard that you use by Edit > 
Copy/Cut/Paste or their respective keyboard shortcuts. Clipboard and “Selection clipboard” 
can contain different contents at the same time.

Function Clipboard Selection clipboard

Copy content Edit > Copy Control+C Select text, table, or object.

Paste content Edit > Paste Control+V 
pastes at the cursor 
position.

Clicking the middle mouse button 
pastes at the mouse pointer position.

Pasting into another 
document

No effect on the clipboard 
contents.

The last marked selection is the 
content of the selection clipboard.

Print options
Set the print options to suit your default printer and your most common printing method. You 
can change these settings at any time, either through this dialog box or during the printing 
process (by clicking the Options button on the Print dialog box).

1) In the Options dialog box, click OpenOffice.org > Print.

2) On the OpenOffice.org – Print page (Figure 32), look at the Printer warnings section 
near the bottom.

3) Here you can choose whether to be warned if the paper size or orientation specified in 
your document does not match the paper size or orientation available for your printer. 
Having these warnings turned on can be quite helpful, particularly if you work with 
documents produced by people in other countries where the standard paper size is 
different from yours.

Tip If your printouts are coming out incorrectly placed on the page or chopped off at the 
top, bottom, or sides or the printer is refusing to print, the most likely cause is page- 
size incompatibility.
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Figure 32. Choosing general printing options to apply to all OOo components

Path options
You can change the location of files associated with, or used by, OpenOffice.org to suit your 
working situation. In a Windows system, for example, you might want to store documents by 
default somewhere other than My Documents.

1) In the Options dialog, click OpenOffice.org > Paths.

2) To make changes, select an item in the list shown in Figure 33 and click Edit. On the 
Select Paths dialog (not shown), add or delete folders as required, and then click OK 
to return to the Options dialog. Note that many items have at least two paths listed: 
one to a shared folder (which might be on a network) and one to a user-specific folder 
(normally on the user’s personal computer).

Tip You can use the entries in the OpenOffice.org – Paths dialog to compile a list of 
files, such as those containing AutoText, that you need to back up or copy to another 
computer.
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Figure 33. Viewing the paths of files used by OpenOffice.org 

Color options
In the OpenOffice.org – Colors dialog (Figure 34), you can specify colors to use in OOo 
documents. You can select a color from a color table, edit an existing color, or define new 
colors. These colors will then be available in color selection palettes in OOo.

Figure 34. Defining colors to use in color palettes in OOo
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Font options
You can define replacements for any fonts that might appear in your documents. If you 
receive from someone else a document containing fonts that you do not have on your system, 
OpenOffice.org will substitute fonts for those it does not find.  You might prefer to specify a 
different font from the one the program chooses.

1) In the Options dialog, click OpenOffice.org > Fonts.

2) On the OpenOffice.org – Fonts dialog (Figure 35):

• Select the Apply Replacement Table checkbox.

• Select or type the name of the font to be replaced in the Font box. (If you do not 
have this font on your system, it will not appear in the drop-down list in this box, 
so you need to type it in.)

• In the Replace with box, select a suitable font from the drop-down list of fonts 
installed on your computer.

3) The checkmark to the right of the Replace with box turns green. Click on this 
checkmark. A row of information now appears in the larger box below the input boxes. 
Select the checkboxes under Always and Screen.

4) In the bottom section of the dialog, you can change the typeface and size of the font 
used to display source code such as HTML and Basic (in macros).

Figure 35. Defining a font to be substituted for another font
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Security options
Use the OpenOffice.org – Security page (Figure 36) to choose security options for saving 
documents and for opening documents that contain macros.

Figure 36. Choosing security options for opening and saving documents

Security Options section

If you record changes, save multiple versions, or include hidden information or notes in your 
documents, and you do not want some of the recipients to see that information, you can set 
warnings to remind you to remove this information, or you can have OOo remove some 
information automatically. Note that (unless removed) much of this information is retained in 
a file whether the file is in OpenOffice.org’s default OpenDocument format, or has been 
saved to other formats, including PDF.

Remove personal information on saving

Select this checkbox to always remove user data from the file properties when saving the file. 
To manually remove personal information from specific documents, clear this checkbox and 
then use the Delete button under File > Properties > General.

Macro security

Click the Macro Security button to open the Macro Security dialog, where you can adjust 
the security level for executing macros and specify trusted sources.

File sharing options for this document

Select the Open this document in read-only mode checkbox to restrict this document to be 
opened in read-only mode only. This option protects the document against accidental 
changes. It is still possible to edit a copy of the document and save that copy with the same 
name as the original.
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Select the Record changes checkbox to enable recording changes. This is the same as Edit - 
Changes – Record. To allow other users of this document to apply changes, but prevent them 
from disabling change recording, click the Protect button and enter a password. 

Appearance options
Writing, editing, and page layout are often easier to do when you can see as much as possible 
of what's going on in your document. You may wish to make visible such items as text, table, 
and section boundaries, and grid lines (see “Grid options” on page 44). In addition, you 
might prefer different colors (from OOo’s defaults) for such items as note indicators or field 
shadings.

On the OpenOffice.org – Appearance page (Figure 37), you can specify which items are 
visible and the colors used to display various items.

1) In the Options dialog box, click OpenOffice.org > Appearance.

2) To show or hide items such as text boundaries, select or deselect the checkboxes next 
to the names of the items.

3) To change the default colors for items, click the down-arrow in the Color setting 
column by the name of the item and select a color from the pop-up box.

4) To save your color changes as a color scheme, type a name in the Scheme box and 
click Save.

Figure 37. Showing or hiding text, object, and table boundaries
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Choosing options for loading and saving 
documents

You can set the Load/Save options to suit the way you work.

Figure 38: Load/Save options

General Load/Save options
1) If the Options dialog is not already open, click Tools > Options. Click the + sign to 

the left of Load/Save.

2) Choose Load/Save > General.

Most of the choices on the Options – Load/Save – General dialog (Figure 38) are familiar to 
users of other office suites. Some items of interest are described below.

Figure 39. Choosing Load and Save options

Load user-specific settings with the document

When you save a document, certain settings are saved with it. For example, your choice (in 
the options for OOo Writer) of how to update links is affected by the Load user-specific 
settings option. Some settings (printer name, data source linked to the document) are always 
loaded with a document, whether or not this checkbox is selected.
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If you select this option, these document settings are overruled by the user-specific settings of 
the person who opens it. If you deselect this option, users’ personal settings do not overrule 
the settings in the document.

Load printer settings with the document

If this option (new in OOo 2.3) is not selected, the printer settings that are stored with the 
document are ignored when you print it using the Print File Directly icon. The default 
printer in your system will be used instead.

Edit document properties before saving

When you select this option, the Document Properties dialog pops up to prompt you to enter 
relevant information the first time you save a new document (or whenever you use Save As).

Save AutoRecovery information every

Note that AutoRecovery in OpenOffice.org overwrites the original file. If you have also 
chosen Always create backup copy, the original file then overwrites the backup copy.  If 
you have this set, recovering your document after a system crash will be easier; but 
recovering an earlier version of the document may be harder.

Size optimization for XML format (no pretty printing)

OpenOffice.org documents are XML files. When you select this option, OOo writes the XML 
data without indents and line breaks. If you want to be able to read the XML files in a text 
editor in a structured form, deselect this option.

Default file format

If you routinely share documents with users of Microsoft Word, you might want to change 
the Always save as attribute for text documents in the Standard file format section to one of 
the Word document types.

VBA Properties Load/Save options
1) Choose Load/Save > VBA Properties.

2) On the Options – Load/Save – VBA Properties dialog (Figure 40), you can choose 
whether to keep any macros in MSOffice documents that are opened in OOo.

• If you choose Save original Basic code, the macros will not work in OOo but 
are retained if you save the file into Microsoft Office format. 

• If you choose Load Basic code to edit, the changed code is saved in an OOo 
document but is not retained if you save into an MSOffice format.
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Figure 40. Choosing Load/Save VBA Properties

Microsoft Office Load/Save options
1) Choose Load/Save > Microsoft Office.

2) On the Options – Load/Save – Microsoft Office dialog (Figure 41), you can choose 
what to do when importing and exporting Microsoft Office OLE objects (linked or 
embedded objects or documents such as spreadsheets or equations).

Select the [L] checkboxes to convert Microsoft OLE objects into the corresponding 
OpenOffice.org OLE objects when a Microsoft document is loaded into OOo 
(mnemonic: “L” for “load”).

Select the [S] checkboxes to convert OpenOffice.org OLE objects into the 
corresponding Microsoft OLE objects when a document is saved in a Microsoft format 
(mnemonic: “S” for “save”).

Figure 41. Choosing Load/Save Microsoft Office options
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HTML compatibility Load/Save options
Choices made on the Load/Save – HTML Compatibility dialog (Figure 39) affect HTML 
pages imported into OpenOffice.org and those exported from OOo. See HTML documents; 
importing/exporting in the Help for more information.

Figure 42. Choosing HTML compatibility options

Font sizes

Use these fields to define the respective font sizes for the HTML <font size=1> to <font 
size=7> tags, if they are used in the HTML pages. (Many pages no longer use these tags.)

Import - Use 'English (USA)' locale for numbers

When importing numbers from an HTML page, the decimal and thousands separator 
characters differ according to the locale of the HTML page. The clipboard, however, contains 
no information about the locale. If this option (new in OOo 2.3) is not selected, numbers will 
be interpreted according to the Language - Locale setting in Tools > Options > Language 
Settings > Languages (see page ). If this option is selected, numbers will be interpreted as 
for the English (USA) locale.

Import - Import unknown HTML tags as fields

Select this checkbox if you want tags that are not recognized by OOo to be imported as 
fields. For an opening tag, an HTML_ON field will be created with the value of the tag 
name. For a closing tag, an HTML_OFF will be created. These fields will be converted to 
tags in the HTML export.

Import - Ignore font settings

Select this checkbox to have OOo ignore all font settings when importing. The fonts that 
were defined in the HTML Page Style will be used.

Export

To optimize the HTML export, select a browser or HTML standard from the Export box. If 
OpenOffice.org Writer is selected, specific OpenOffice.org Writer instructions are exported.
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Export - OpenOffice.org Basic

Select this checkbox to include OOo Basic macros (scripts) when exporting to HTML format. 
You must activate this option before you create the OpenOffice.org Basic macro; otherwise 
the script will not be inserted. OpenOffice.org Basic macros must be located in the header of 
the HTML document. Once you have created the macro in the OpenOffice.org Basic IDE, it 
appears in the source text of the HTML document in the header.

If you want the macro to run automatically when the HTML document is opened, choose 
Tools > Customize > Events. See Chapter 17 (Getting Started with Macros) for more 
information.

Export - Display warning

When the OpenOffice.org Basic checkbox (see above) is not selected, the Display warning 
checkbox becomes available. If the Display warning checkbox is selected, then when 
exporting to HTML a warning is shown that OpenOffice.org Basic macros will be lost.

Export - Print layout

Select this checkbox to export the print layout of the current document as well. It can be read 
by OpenOffice.org and by Netscape Navigator and Microsoft Internet Explorer 4.0 and 
above.

The HTML filter supports CSS2 (Cascading Style Sheets Level 2) for printing documents. 
These capabilities are only effective if print layout export is activated.

Export - Copy local graphics to Internet

Select this checkbox to automatically upload the embedded pictures to the Internet server 
when uploading using FTP.

Export - Character set

Select the appropriate character set for the export.

Choosing options for Writer

Settings chosen on the pages in the OpenOffice.org Writer section of the Options dialog box 
determine how your Writer documents look and behave while you are working on them.

1) If the Options dialog box is not already open, click Tools > Options.

2) Click the + sign by OpenOffice.org Writer in the left-hand section of the Options – 
OpenOffice.org dialog box. A list of subsections drops down.

General options
The choices on the OpenOffice.org Writer – General page affect the updating of links and 
fields, the units used for rulers and other measurements, whether captions are automatically 
added to selected objects such as tables or figures, paragraph spacing, and tab stop behavior.
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Figure 43: OpenOffice.org Writer Options

1) Choose OpenOffice.org Writer > General on the Options dialog box (Figure 44).

2) Keep in mind the following considerations when selecting options on this page.

Figure 44. Choosing general options for Writer

Update links when loading

Depending on your work patterns, you may not want links to be updated when you load a 
document. For example, if your file links to other files on a network, you won’t want those 
links to update when you are not connected to the network.

Update fields and charts automatically

You may not want fields or charts to update automatically when you are working, because 
that slows down performance.

Settings – Tab stops

The Tab stops setting is also used for the indent distance applied by the Increase Indent and 
Decrease Indent buttons on the Formatting Bar.
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View options
Two pages of options set the defaults for viewing Writer documents: View and Formatting 
Aids (described on page 43).

Choose OpenOffice.org Writer > View on the Options dialog box (Figure 45).

If the items on this page are not self-explanatory, you can easily test their effects in a blank 
document.

This is a good page to check if, for example, you cannot see graphics on the screen or you see 
field codes instead of the text or numbers you are expecting.

Figure 45. Choosing View options for Writer

Formatting Aids options
The display of symbols such as paragraph ends and tabs help you when writing, editing, and 
doing page layout. For example, you might want to know if any blank paragraphs or tabs are 
included or if any tables or graphics are too wide and intrude into the margins of the page.

On the OpenOffice.org Writer – Formatting Aids page (Figure 46), select the required 
checkboxes.

Figure 46. Choosing Formatting Aids options
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Note Direct cursor lets you enter text, images, tables, frames, and other objects in any 
blank area in your document. OOo inserts blank paragraphs and tabs to position the 
text or objects.

This feature is incompatible with rigorous use of styles and can lead to many 
formatting oddities, so it should be avoided by professional writers.

The AutoCorrect tool automatically removes empty paragraphs, tabs, and spaces 
that are inserted by the direct cursor. If you want to use the direct cursor, then 
disable the AutoCorrect tool.

Grid options
Specifying “snap to grid” can be very helpful when you are trying to align several objects 
such as graphics or tables. If the grid intervals (subdivisions) are too large, you may find that 
you do not have enough control in placing the objects.

On the OpenOffice.org Writer – Grid page (Figure 47), you can choose whether to enable this 
feature and what grid intervals to use.

Figure 47. Choosing Grid options

Default fonts
The default fonts specified on the OpenOffice.org Writer – Basic Fonts (Western) page apply 
to both Writer documents and HTML (Web) documents.

1) If you want to change the defaults, do so on the OpenOffice.org Writer – Basic Fonts  
(Western) page (Figure 48). You can, of course, choose other fonts for use in specific 
documents, either by applying direct formatting or by defining and applying styles in 
those documents.

2) When choosing fonts on this page you are not limited to single fonts or to the ones 
shown in the drop-down list. You can specify a “font family”as a comma-separated set 
of fonts that includes those suitable for Windows, Macintosh, Linux, and other 
operating systems. These choices are particularly important in HTML documents.

3) If the document is viewed on a system that does not have the first font specified, it will 
use one of the other fonts if that one is available. Otherwise, it will substitute a font 
that is available on the system.
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4) Type the list of fonts, separated by commas, in the boxes. If you want these defaults to 
apply to the current document only, select that checkbox. The Default button resets the 
values on this page to the defaults installed with OpenOffice.org.

Figure 48. Choosing default fonts

Print options
On the OpenOffice.org Writer – Print page (Figure 49), you can choose which items are 
printed with the document by default. These options are in addition to those on the 
OpenOffice.org – Print page (Figure 32).

Some considerations:

• When you are working on drafts and you want to save printer ink or toner, you might 
want to deselect some of the items in the Contents section.

• The Print black selection causes color text (but not graphics) to print as black on a 
color printer; on a black-and-white printer, this option causes color text to print as 
solid black instead of shades of grey (dithered).

• Contrast Print black with Convert colors to greyscale on the Options – 
OpenOffice.org – Print page (Figure 32), which prints all graphics as greyscale on 
color printers. (On black-and-white printers, color in graphics normally prints as 
greyscale.)

• If you are printing double-sided on a non-duplexing printer, you might choose to print 
only left or right pages, then turn the stack over and print the other pages.

• Depending on how your printer ejects pages (face up or face down), you might need to 
print the pages in reverse order so they stack in the correct order as they are printed.
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Tip You can override any of these defaults when printing a document. Click File > 
Print, then click the Options button on the Print dialog box. The Printer Options 
dialog box that appears is similar to the one shown in Figure 49.

Figure 49. Choosing Print options for Writer

Default table options
On the OpenOffice.org Writer – Table page (Figure 50), you can specify the default table 
behavior.

Figure 50. Choosing default Table options
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Some considerations:

• If most of your tables will require borders or headings, select those checkboxes. If 
most of your tables are used for page layout, deselect borders and headings.

• Number recognition can be very useful if most of your tables contain numerical data; 
Writer will recognize dates or currency, for example, and format the numbers 
appropriately. However, if you want the numbers to remain as ordinary text, this 
feature can be quite irritating, so you will want to deselect it.

• The Keyboard handling section specifies the distances that cells move when you use 
keyboard shortcuts to move them and the size of rows and columns inserted using 
keyboard shortcuts.

• The choices in the Behavior of rows/columns section determine the effects that 
changes to rows or columns have on adjacent rows or columns and the entire table. 
You might need to test these selections to fully understand the effects.

Change tracking options
If you plan to use the change-tracking feature of Writer, use the OpenOffice.org Writer – 
Changes page (Figure 51) to choose the way inserted and deleted material is marked, whether 
and how attribute changes are marked, and whether and how change bars are marked in the 
margins.

Figure 51. Choosing options for tracking changes
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Compatibility options
Do you need to import Microsoft Word documents into OOo Writer? If so, you might want to 
select some or all of the settings on the OpenOffice.org Writer – Compatibility page (Figure
52). If you are not sure about the effects of these settings, leave them as the defaults provided 
by OOo. For information about the settings not described below, see the Help.

Figure 52. Choosing compatibility options

Use printer metrics for document formatting

If this checkbox is selected, the printer specified for the document determines how the 
document is formatted for viewing on screen. The line breaks and paragraph breaks you see 
on screen match those that apply when the document is printed on that printer.

This setting can be useful when several people are reviewing a document that will eventually 
be printed on a specific printer or when the document is exported to PDF (a process that uses 
“Adobe PDF” as the printer).

If this checkbox is not selected, a printer-independent layout will be used for screen display 
and printing.

Add spacing between paragraphs and tables (in current document)

In OpenOffice.org Writer, paragraph spacing is defined differently than it is in MS Word 
documents. If you have defined spacing between two paragraphs or tables, spacing is also 
added in the corresponding MS Word documents.

If this checkbox is selected, MS Word-compatible spacing is added between paragraphs and 
tables in OpenOffice.org Writer documents.
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Add paragraph and table spacing at tops of pages (in current 
document)

You can define paragraphs to have space appear before (above) them. If this checkbox is 
selected, any space above a paragraph will also appear if the paragraph is at the beginning of 
a page or column, if the paragraph is positioned on the first page of the document, or after a 
manual page break.

If you import an MS Word document, the spaces are automatically added during the 
conversion.

Add paragraph and table spacing at bottom of table cells

Specifies that the bottom spacing is added to a paragraph, even when it is the last paragraph 
in a table cell.

Use as Default button

Click this button to use the current settings on this page as the default in OpenOffice.org.

AutoCaption options
Do you want OOo to automatically insert captions for tables, pictures, frames, and OLE 
objects that have been inserted in a Writer document?

Note You may not always want captions for every table, for example, if you use tables for 
layout as well as for tables of data. You can always add captions to individual 
tables, graphics, or other objects (right-click > Caption).

If you do want automatic captions on one or more object types:

1) Choose OpenOffice.org Writer > AutoCaption on the Options dialog box.

2) On the OpenOffice.org Writer – AutoCaption page (Figure 53), select the checkbox 
next to an object you want to be automatically captioned (Picture in the example 
shown).

3) With the item highlighted, specify the characteristics of the caption. The supplied 
categories for captions are Drawing, Illustration, Table, and Text. However, you are 
not limited to the supplied categories. If you want to use another name (for example, 
Figure) for the caption label, type the required term in the box. In the example shown, 
I have added the category “Figure” to the list.

For more information about numbering captions by chapter, character styles, frame styles, 
and other items on the AutoCaption page, see other chapters in the Writer Guide.
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Figure 53. Setting up a new category for automatic captions on graphics

Mail Merge E-mail options
You can produce form letters using Writer and then use the mail merge function to personalize 
those letters and send them to a number of addresses taken from a data source, such as an 
address book. Mail merged documents can be printed and mailed, or sent by e-mail.

Use the Options – OpenOffice.org Writer – Mail Merge E-mail page (Figure 54) to set up the 
user and server information for sending form letters by e-mail. If you are not sure what 
information to put in any of the fields, consult your e-mail program or your Internet service 
provider.

Figure 54: Specifying settings for use when e-mailing mail-merged form letters
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Choosing language settings

You may need to do several things to set the language settings to what you want:

• Install the required dictionaries

• Change some locale and language settings

• Choose spelling options

Install the required dictionaries
OpenOffice.org 2.0 and later versions automatically install several dictionaries with the 
program. To add other dictionaries, use File > Wizards > Install new dictionaries. An OOo 
document will open with links to different languages that you can install. Follow the prompts 
to install them.

Change some locale and language settings
You can change some details of the locale and language settings that OOo uses for all 
documents or for specific documents.

Figure 55: OpenOffice.org Language Options

1) In the Options dialog box, click Language Settings > Languages.

2) On the right-hand side of the Language Settings – Languages page (Figure 56), change 
the User interface, Locale setting, Default currency, and Default languages for 
documents as required. In the example, English (UK) has been chosen for all the 
appropriate settings.

3) If you want the language (dictionary) setting to apply to the current document only, 
instead of being the default for all new documents, select the checkbox labeled For 
the current document only.

4) If necessary, select the checkboxes to enable support for Asian languages (Chinese, 
Japanese, Korean) and support for CTL (complex text layout) languages such as Hindi, 
Thai, Hebrew, and Arabic. If you choose either of these checkboxes, the next time you 
open this page, you will see some extra choices under Language Settings, as shown in 
Figure 57. These choices (Searching in Japanese, Asian Layout, and Complex Text 
Layout) are not discussed here.

5) Click OK to save your changes and close the dialog box.
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Figure 56. Choosing language options

Note If you need to use non-Western languages, and especially if you need to use more 
than one non-Western language in the same document, refer to the tutorial, “OOo in 
a Multi-Lingual Environment.”

Figure 57. Extra setting choices when enhanced language support options are 
selected
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Choose spelling options
To choose the options for checking spelling:

1) In the Options dialog box, click Language Settings > Writing Aids.

2) In the Options section of the Language Settings – Writing Aids page (Figure 58), 
choose the settings that are useful for you. Some considerations:

• If you don’t want spelling checked while you type, deselect Check spelling as 
you type and select Do not mark errors. (To find the second item, scroll down in 
the Options list.)

• If you use a custom dictionary that includes words in all uppercase and words with 
numbers (for example, AS/400), select Check uppercase words and Check 
words with numbers.

• Check special regions includes headers, footers, frames, and tables when 
checking spelling.

• Here you can also check which of the user-defined (custom) dictionaries are 
active, or you can add or remove dictionaries by clicking the New or Delete 
buttons.

Figure 58. Choosing languages, dictionaries, and options for checking spelling
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Controlling Writer’s AutoCorrect functions

Some people find some or all of the items in Writer’s AutoCorrect feature annoying because 
they change what you type when you don’t want it changed. Many people find some of the 
AutoCorrect functions quite helpful; if you do, then select the relevant checkboxes. But if 
you find unexplained changes appearing in your document, this is a good place to look to 
find the cause.

To open the AutoCorrect dialog box, click Tools > AutoCorrect/AutoFormat. (You need to 
have a document open for this menu item to appear.)

In Writer, this dialog box has five tabs, as shown in Figure 59.

Figure 59. The AutoCorrect dialog box in Writer, showing the five tabs and some 
of the choices on the Options tab
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Introduction

Introduction

This chapter covers the basics of working with text in Writer, the word-processing 
component of OpenOffice.org (OOo). It assumes that you are familiar with the use of a 
mouse and keyboard and that you have read about Writer’s menus and toolbars and other 
topics covered in Chapter 1 (Introducing Writer).

We recommend that you also follow the suggestions in Chapter 2 (Setting up Writer) about 
displaying formatting aids, such as end-of-paragraph marks, and selecting other setup 
options.

When you have read this chapter, you should know how to:

• Select, cut, copy, paste, and move text

• Find and replace text

• Insert special characters

• Format paragraphs and characters

• Create numbered or bulleted lists

• Check spelling, use the thesaurus, and choose hyphenation options

• Use the autocorrection, word completion, autotext, and line numbering features

• Track changes and undo and redo changes

Selecting text

Before you can do anything with text, you need to select it. Selecting text in Writer is similar 
to selecting anything in other applications.

In addition to selecting blocks of text, you can select items that are not consecutive.

Selecting items that are not consecutive
To select nonconsecutive items (as shown in Figure 60) using the mouse:

1) Select the first piece of text.

2) Hold down the Control (Ctrl) key and use the mouse to select the next piece of text.

3) Repeat as often as needed.

4) Now you can work with the selected text (copy it, delete it, change the style, or 
whatever).

Note Macintosh users: substitute the Command key when instructions in this chapter say 
to use the Control key.
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To select nonconsecutive items using the keyboard:

1) Select the first piece of text. (For more information about keyboard selection of text, 
see the topic “Navigating and Selecting with the Keyboard” in the OpenOffice.org 
Help (F1) in the Help menu.)

2) Press Shift+F8. This puts Writer in “ADD” mode. The word ADD appears on the 
Status Bar.

3) Use the arrow keys to move to the start of the next piece of text to be selected. Hold 
down the Shift key and select the next piece of text.

4) Repeat as often as needed. Now you can work with the selected text.

5) Press Esc to exit from this mode.

Figure 60: Selecting items that are not next to each other

Cutting, copying, and pasting text

Cutting and copying text in Writer is similar to cutting and copying text in other applications. 
You can copy or move text within a document, or between documents, by dragging or by 
using menu selections, icons, or keyboard shortcuts. You can also copy text from other 
sources such as Web pages and paste it into a Writer document.

To move (cut and paste) selected text using the mouse, drag it to the new location and release 
it. To copy selected text, hold down the Control key while dragging. The text retains the 
formatting it had before dragging.

After selecting text, you can use the mouse or the keyboard for these operations.

Cut: Use Edit > Cut or the keyboard shortcut Control+X or the Cut icon on the toolbar .

Copy: Use Edit > Copy or the keyboard shortcut Control+C or the Copy icon .

Paste: Use Edit > Paste or the keyboard shortcut Control+V or the Paste icon .

The result of a paste operation depends on the source of the text to be pasted. If you simply 
click on the Paste icon, any formatting the text has (such as bold or italics) is retained. Text 
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pasted from Web sites and other sources may also be placed into frames or tables. If you do 
not like the results, click the Undo icon and try again.

To make the pasted text take on the formatting of the surrounding text where it is to be 
pasted, choose either:

• Edit > Paste Special

• or click the triangle to the right of the Paste icon

• or click the Paste icon without releasing the left mouse button

Then select Unformatted text from the resulting menu.

The range of choices on the Paste Special menu varies depending upon the origin and 
formatting of the text (or other object) to be pasted. See Figure 61 for an example with text 
on the clipboard.

Figure 61: Paste menu

This example includes the formatting option DDE link. DDE is an acronym for Dynamic 
Data Exchange, a mechanism whereby selected data in document A can be pasted into 
document B as a linked, ‘live’ copy of the original. It would be used, for example, in a report 
written in Writer containing time-varying data, such as sales results sourced from a Calc 
spreadsheet. The DDE link ensures that, as the source spreadsheet is updated so is the report, 
thus reducing the scope for error and reducing the work involved in keeping the Writer 
document up to date.

Moving paragraphs quickly

1) Put the cursor anywhere in the paragraph.

2) Press Control+Alt.

3) Holding the Control+Alt keys down, press the up-arrow or down-arrow key.

The paragraph will move to a new location either before the previous paragraph or after the 
next paragraph in your document. To move more than one paragraph at a time, select at least 
part of all paragraphs (including the end of the first paragraph you want to move and the start 
of the last) before pressing the Control+Alt+arrow keys.

If you are using Solaris, the key combination is Control+AltGr+arrow keys.
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Tip If your paragraphs suddenly jumped from one place to another, the most likely 
reason is that you have accidentally pressed one of these key combinations.

Note In some machines  the Control+Alt+arrow key combination is reserved for 
screen flipping. You have to deactivate or assign different key combination 
for screen flipping (usually through display / graphics adapter settings in your 
computer) before using this feature.

Finding and replacing text

When looking for certain words in a 3000-word essay, it would be inefficient (and close to 
impossible!) to go through every word manually. Writer has a Find and Replace feature that 
automates the process of searching for text inside a document.

In addition to finding and replacing words and phrases, you can:

• Use wildcards and regular expressions to fine-tune a search.

• Find and replace specific formatting.

• Find and replace paragraph styles.

To display the Find & Replace dialog box (Figure 62), use the keyboard shortcut Control+F 
or select Edit > Find & Replace.

1) Type the text you want to find in the Search for box.

2) To replace the text with different text, type the new text in the Replace with box.

3) You can select various options, such as matching the case, matching whole words only, 
or doing a search for similar words. (See below for some other choices.)

4) When you have set up your search, click Find. To replace text, click Replace instead.

Tip If you click Find All, Writer selects all instances of the search text in the document. 
Similarly, if you click Replace All button, Writer will replace all matches.

Caution Use Replace All with caution; otherwise, you may end up with some hilarious (and 
highly embarrassing) mistakes. A mistake with Replace All might require a manual, 
word-by-word search to fix.
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Figure 62: The Find & Replace dialog box

Use wildcards (regular expressions)
Wildcards (also known as regular expressions) are combinations of characters that instruct 
OOo how to search for something. Regular expressions are very powerful but not very 
intuitive. They can save time and effort by combining multiple finds into one.

Table 1 shows a few of the regular expressions used by OOo.

Tip The online help describes many more regular expressions and their uses.

Note To search for a character that is defined as a wildcard, type a backslash (\) before 
the character. For example, to find the text $5.00, you would conduct a search using 
\$5\.00.

To use wildcards and regular expressions when searching and replacing:

1) On the Find & Replace dialog box, click More Options to see more choices. On this 
expanded dialog box (Figure 63), select the Regular expressions checkbox.

2) Type the search text, including the wildcards, in the Search for box and the 
replacement text (if any) in the Replace with box. Not all regular expressions work as 
replacement characters; the line break (\n) is one that does work.

3) Click Find, Find All, Replace, or Replace All (not recommended).
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Table 1. Examples of search wildcards (regular expressions)

To find
Use this 
expression

Examples and comments

Any single character . b.d finds bad, bud, bid, and bed.

Any string of characters .* b.*d finds bad, brand, and board.

One of the specified 
characters

[xyz] b[iu]n finds bin and bun.

Any single character in 
this range

[x-y] [r-t]eed finds reed, seed, and teed; ranges must 
be in alphabetically ascending order.

Any single character 
except the characters 
inside the brackets

[^x] p[^a]st finds post and pest, but not past.

The beginning of a word \<start \<log finds logbook and logistics, but not 
catalog.

The end of a word end\> log\> finds catalog, but not logistics.

A paragraph marker $ Does not work as a replacement character. Use \n 
instead.

A line break \n Finds a line break that was inserted with Shift
+Enter. When used as a replacement character, it 
inserts a paragraph marker.

Find and replace specific formatting
A very powerful use of Find & Replace takes advantage of the format option. For example, 
you might want to replace underlined words with italics.

On the Find & Replace dialog box (with More Options displayed, as in Figure 63):

1) To search for text with specific formatting, enter the text in the Search for box. To 
search for specific formatting only, delete any text in the Search for box.

2) Click Format to display the Text Format (Search) dialog box. The tabs on this dialog 
box are similar to those on the Paragraph format and Paragraph Style dialog boxes. 
Choose the formats you want to search for and then click OK. The names of selected 
formats appear under the Search for box. For example, you might search for all text in 
14-point bold Helvetica.

3) To replace text, enter the replacement text in the Replace with box.

To search for specific text with specific formatting (for example, the word hello in 
bold), specify the formatting, put the text in the Search for box and leave the Replace 
with box blank.

To remove specific character formatting, click Format, select the Font tab, then select 
the opposite format (for example, No Bold). The No Format button on the Find & 
Replace dialog box clears all previously selected formats.

Chapter 3  Working with Text 61



Finding and replacing text

4) Click Find, Find All, Replace, or Replace All.

Figure 63: Expanded Find & Replace dialog box

Tip Unless you plan to search for other text using those same attributes, click No 
Format to remove the attributes after completing your search. If you forget to do 
this, you may wonder why your next search fails to find words you know are in the 
document.

Find and replace paragraph styles
If you combine material from several sources, you may discover that lots of unwanted 
paragraph styles have suddenly shown up in your document. To quickly change all the 
paragraphs of one (unwanted) style to another (preferred) style:

1) On the expanded Find & Replace dialog box (), select Search for Styles. (If you have 
attributes specified, this checkbox is labeled Including Styles.) The Search for and 
Replace with boxes now contain a list of styles.

2) Select the styles you want to search for and replace.

3) Click Find, Find All, Replace, or Replace All.
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Inserting special characters

A “special” character is one not found on a standard English keyboard. For example, © ¾ æ ç 
ñ ö ø ¢ are all special characters. To insert a special character:

1) Place the cursor in your document where you want the character to appear.

2) Click Insert > Special Character to open the Special Characters dialog box ().

Figure 64: The Special Characters dialog box, where you can insert special characters.

3) Select the characters (from any font or mixture of fonts) you wish to insert, in order; 
then click OK. The selected characters are shown in the lower left of the dialog box. 
As you select each character, it is shown on the lower right, along with the numerical 
code for that character.

Tip Notice that the characters selected appear in the bottom-left corner of the dialog box.

Note Different fonts include different special characters. If you do not find a particular 
special character you want, try changing the Font selection.

Inserting dashes and non-breaking spaces

Non-breaking spaces

To prevent two words from being separated at the end of a line, press Control+spacebar after 
the first word.
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Non-breaking hyphen

You can use a non-breaking hyphen in cases where you do not want the hyphen to appear at 
the end of a line. Examples of non-breaking hyphens are: in a range such as A-Z or the 
hyphens in a telephone number, such as 123-4567. To insert a non-breaking hyphen, press 
Shift+Control+minus sign.

En and em dashes

To enter en and em dashes, use the Replace dashes option under Tools > AutoCorrect > 
Options (Figure 70). This option replaces two hyphens, under certain conditions, with the 
corresponding dash.

Another means of inserting en or em dashes is through the Insert > Special Characters 
menu. Select the U+2013 or U+2014 character, respectively.

Formatting paragraphs

You can apply many formats to paragraphs using the buttons on the Formatting toolbar. 
Figure 65 shows the Formatting toolbar as a floating toolbar, customized to show only the 
buttons for paragraph formatting.

Tip It is highly recommended that you use paragraph styles rather than manually 
formatting paragraphs, especially for long or standardized documents. For 
information on the advantages of styles and how to use them, see Chapter 6 
(Introduction to Styles).

1 Open Styles and 
Formatting Window

5 Align Right 10 Numbering On/Off
6 Justified 11 Bullets On/Off

2 Apply Style 7 Line Spacing: 1 12 Decrease Indent
3 Align Left 8 Line Spacing: 1.5 13 Increase Indent
4 Centered 9 Line Spacing: 2 14 Paragraph format dialog

Figure 65: Formatting toolbar, showing buttons for paragraph formatting

Figure 66 shows examples of the different alignment options.

Figure 66: Different text alignment options
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Setting tab stops and indents
The horizontal ruler shows both the default tab stops and any that you have defined. To set 
the measurement unit and the spacing of default tab stops, go to Tools > Options > 
OpenOffice.org Writer > General.

You can also set or change the measurement unit by right-clicking on the ruler to open a list 
of units, as shown in Figure 67. Click on one of them to change the ruler to that unit.

Figure 67: Ruler showing default tab stops

Double-click on a part of the ruler that is not between the left and right indent icons to open 
the Indents & Spacing page of the Paragraph dialog box. Double-click anywhere between the 
left and right indent icons on the ruler itself to open the Tabs page of the Paragraph dialog 
box (Figure 68).

To fine-tune tab-stop settings, use the Tabs page of the Paragraph dialog box (Figure 68).

Figure 68: Specifying tab stops and fill characters
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Formatting characters

You can apply many formats to characters using the buttons on the Formatting toolbar. 
Figure 69 shows the Formatting toolbar as a floating toolbar, customized to show only the 
buttons for character formatting.

Tip It is highly recommended that you use character styles rather than manually 
formatting characters. For information on the advantages of styles and how to use 
them, see Chapter 6 (Introduction to Styles).

1 Open Styles and 
Formatting Window

6 Italic 12 Font Colour

7 Underline 13 Highlighting

2 Apply Style 8 Superscript 14 Background Colour

3 Font Name 9 Subscript 15 Open Character Format 
Dialog4 Font Size 10 Increase Font

5 Bold 11 Reduce Font

Figure 69: Formatting toolbar, showing buttons for character formatting

Tip To remove manual formatting, select the text and click Format > Default 
Formatting or right-click and select Default Formatting from the pop-up menu.

Autoformatting
Writer can be set to automatically format parts of a document according to the choices made 
on the Options page of the AutoCorrect dialog box (Tools > AutoCorrect > Options). See 
Figure 70.

The Help describes each of these choices and how to activate the autoformats. Some common 
unwanted or unexpected formatting changes include:

• Horizontal lines. If you type three or more hyphens (---), underscores (___) or equal 
signs (===) on a line and then press Enter the paragraph is replaced by a horizontal 
line as wide as the page. The line is actually the lower border of the preceding 
paragraph.

• Bulleted and numbered lists. A bulleted list is created when you type a hyphen (-), 
asterisk (*), or plus sign (+), followed by a space or tab at the beginning of a 
paragraph. A numbered list is created when you type a number followed by a period 
(.), followed by a space or tab at the beginning of a paragraph. Automatic numbering is 
only applied to paragraphs formatted with the Default, Text body or Text body indent 
paragraph styles.
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Tip If you notice unexpected formatting changes occurring in your document, this is the 
first place to look for the cause.

Figure 70: Autoformat choices on the Options page of the AutoCorrect dialog box

To turn autoformatting on or off, go to Format > AutoFormat (Figure 71) and select or 
deselect the items on the submenu.

• While Typing automatically formats the document while you type.

• If While Typing is deselected, you can select Apply to automatically format the file.

• Apply and Edit Changes automatically formats the file and then opens a dialog box 
where you can accept or reject the changes.
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Figure 71: Turning autoformatting on or off

Creating numbered or bulleted lists

There are several ways to create numbered or bulleted lists:

• Use autoformatting, as described above.

• Use list styles, as described in Chapter 7 (Working with Styles).

• Use the Numbering and Bullets icons on the paragraph formatting toolbar (see Figure
65). This method is described here.

To produce a numbered or bulleted list, select the paragraphs in the list and then click on the 
appropriate icon on the toolbar.

Note It is a matter of personal preference whether you type your information first, then 
apply Numbering/Bullets or apply these as you type.

Using the Bullets and Numbering toolbar
You can create a nested list (where one or more list items has a sublist under it, as in an 
outline) by using the buttons on the Bullets and Numbering toolbar (Figure 72). You can 
move items up or down the list, create subpoints, and even change the style of bullets.
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1 Bullets On/Off 7 Move Down (One Level) 
with Sub-points

12 Move Down in 
Sub-points2 Numbering On/Off

3 Numbering Off 8 Insert Unnumbered Entry 13 Restart Numbering
4 Up One Level 9 Move Up 14 Bullets and Numbering
5 Up One Level 10 Move Down
6 Move Up (One Level) 

with Sub-points
11 Move Up in Sub-points

Figure 72: Bullets and Numbering toolbar

Tip It is possible to move a list entry up, together with all of its sub-entries. Do this by 
clicking the Promote One Level With Subpoints button.

Using footnotes and endnotes

Footnotes appear at the bottom of the page on which they are referenced. Endnotes are 
collected at the end of a document.

To work effectively with footnotes and endnotes, you need to:

• Insert footnotes.

• Define the format of footnotes.

• Define the location of footnotes on the page; see Chapter 4 (Formatting Pages).

Inserting footnotes/endnotes
To insert a footnote or an endnote, put the cursor where you want the footnote/endnote 
marker to appear. Then select Insert > Footnote from the menu bar or click the Insert 
Footnote Directly or Insert Endnote Directly icon on the Insert toolbar (see Figure 73).

Figure 73: Using the Insert Footnote Directly icon on the toolbar
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A footnote (or endnote) marker is inserted in the text, and the cursor is relocated to the 
footnote area at the bottom of the page (or to the endnote area at the end of the document). 
Type the footnote or endnote content in this area.

If you use Insert > Footnote, the Insert Footnote dialog box (Figure 74) is displayed. Here 
you can choose whether to use the automatic numbering sequence specified in the footnote 
settings and whether to insert the item as a footnote or an endnote.

Figure 74: Inserting a footnote directly

If you use the Insert Footnote Directly or Insert Endnote Directly icon, the footnote or 
endnote automatically takes on the attributes previously defined in the Footnote Settings 
dialog box (Figure 75).

You can edit an existing footnote or endnote the same way you edit any other text.

To delete a footnote or endnote, delete the footnote marker. The contents of the footnote or 
endnote are deleted automatically, and the numbering of other footnotes or endnotes is 
adjusted automatically.

Defining the format of footnotes/endnotes
To format the footnotes themselves, click Tools > Footnotes. On the Footnote Settings dialog 
box (Figure 75), choose settings as required. The Endnotes page has similar choices.
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Figure 75: Defining footnote formatting

Checking spelling

Writer provides a spelling checker, which can be used in two ways.

AutoSpellcheck checks each word as it is typed and displays a wavy red line under 
any misspelled words. Once the word is corrected, the red wavy line disappears.

 To perform a separate spellcheck on the document (or a text selection) click the 
Spellcheck button. This checks the document or selection and opens the Spellcheck 

dialog box (Figure 76) if any misspelled words are found.

Here are some more features of the spelling checker:

• You can right-click on a word with a wavy underline, to open a powerful context 
menu. If you select from the suggested words on the menu, the selection will replace 
the misspelled word in your text. Other menu options are discussed below.

• You can change the dictionary language (for example, Spanish, French, or German) on 
the Spellcheck dialog box.

• You can add a word to a dictionary. Click Add in the Spellcheck dialog box and pick 
the dictionary to add it to.
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• The Options dialog box of the Spellcheck tool has a number of different options such 
as whether to check uppercase words and words with numbers. It also allows you to 
manage custom dictionaries, that is, add or delete dictionaries and add or delete words 
in a dictionary.

• On the Font page of the Paragraph Styles dialog box, you can set paragraphs to be 
spell-checked in a specific language (different from the rest of the document). See 
Chapter 7 (Working with Styles) for more information.

Figure 76: Selecting a word from dictionary using the Spellcheck dialog box

Using the thesaurus

The thesaurus offers alternative words and phrases. Select the word or phrase you want to 
find alternatives for and select Tools > Language > Thesaurus or press Control+F7. Click 
on a meaning to show alternative words and phrases for that meaning of the word. For 
example, when given the word “house”, the thesaurus offers several meanings, including 
“dwelling”, “legislature”, and “sign of the zodiac”. If you click on “dwelling”, you will see 
“dwelling”, “home”, “domicile”, “abode”, and other alternatives, as shown in Figure 77.

Note If the current language does not have a thesaurus installed, this feature is disabled.
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Figure 77: The thesaurus offers alternatives to words

Hyphenating words

To turn automatic hyphenation of words on or off:

1) Press F11 to open the Styles and Formatting window (Figure 78).

Figure 78: Modifying a style

2) On the Paragraph Styles page of the Styles and Formatting window, right-click on 
Default and select Modify.

3) On the Paragraph Style dialog box, select the Text Flow tab (Figure 79).

4) Under Hyphenation, select or deselect the Automatically checkbox.

5) Click OK to save.
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Figure 79: Turning on automatic hyphenation

Note Turning on hyphenation for the Default paragraph style affects all other paragraph 
styles that are based on Default. You can individually change other styles so that 
hyphenation is not active; for example, you might not want headings to be 
hyphenated. Any styles that are not based on Default are not affected. For more on 
paragraph styles, see Chapter 6 (Introduction to Styles) and Chapter 7 (Working 
with Styles).

You can also set hyphenation choices through Tools > Options > Language Settings > 
Writing Aids. In Options, near the bottom of the dialog box, scroll down to find the 
hyphenation settings (see Figure 80).

Figure 80: Setting hyphenation options

To change the minimal number of characters for hyphenation, the minimum number of 
characters before a line break, or the minimum number of characters after a line break, select 
the item, and then click Edit.

Hyphenate without inquiry specifies that you will never be asked to manually hyphenate 
words that the hyphenation dictionary does not recognize. If this box is not selected, when a 
word is not recognized, a dialog box will open where you can manually enter hyphens.

Hyphenate special regions specifies that hyphenation will also be carried out in footnotes, 
headers, and footers.

Notes Hyphenation options set on the Writing Aids dialog box are effective only if 
hyphenation is turned on through paragraph styles.

Choices on the Writing Aids dialog box for “characters before line break” and 
“characters after line break” override settings in paragraph styles for “characters at 
line end” and “characters at line begin”. This is a bug.
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To enter a conditional hyphen inside a word, press Control+minus sign. The word is 
hyphenated at this position when it is at the end of the line, even if automatic hyphenation for 
this paragraph is switched off.

Using AutoCorrect

Writer’s AutoCorrect function has a long list of common misspellings and typing errors, 
which it corrects automatically. For example, “hte” will be changed to “the”. Select Tools > 
AutoCorrect to open the AutoCorrect dialog box. There you can define what strings of text 
are corrected and how. In most cases, the defaults are fine.

Tip AutoCorrect is automatically turned on. To turn it off, uncheck Format > 
AutoFormat > While Typing.

• To stop Writer replacing a specific spelling, use Tools > AutoCorrect > Replace, 
highlight the word pair and click Delete.

• To add a new spelling to correct, type it into the Replace and With boxes and click 
New.

• See the different pages of the dialog box for the wide variety of other options available 
to fine-tune AutoCorrect.

Tip AutoCorrect can be used as a quick way to insert special characters. For example, 
(c) will be autocorrected to ©. You can add your own special characters.

Using word completion

If Word Completion is enabled, Writer tries to guess which word you are typing and offers to 
complete this word for you. To accept the suggestion, press Enter. Otherwise, continue 
typing.

Tip Many people prefer not to use Word Completion. If you do not want to use it, select 
Tools > AutoCorrect > Word Completion and uncheck Enable word completion.

You can customize word completion from the Tools > AutoCorrect > Word Completion 
page (Figure 81).

• Add (append) a space automatically after an accepted word.

• Show the suggested word as a tip (hovering over the word) rather than completing the 
text as you type.

• Change the maximum number of words remembered for word completion and the 
length of the smallest words to be remembered.

• Delete specific entries from the word completion list.
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• Change the key that accepts a suggested entry—the options are right arrow, End key, 
Return (Enter), Space bar, and Tab.

Figure 81: Customizing word completion

Note Automatic word completion only occurs after you type a word for the second time 
in a document.

Using AutoText

AutoText allows you to assign text, tables, graphics, and other items to a key combination. 
For example, rather than typing out “Senior Management”, you just have to type “sm” and 
press F3. Or you can save a formatted Tip (like the one on the next page) as AutoText and 
then inserting a copy by typing “tip” and pressing F3.

To insert AutoText, type the shortcut and press F3.

To assign some text to an AutoText shortcut:

1) Type the text into your document.

2) Select the text.

3) Go to Edit > AutoText (or press Control+F3).
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4) Enter a name for your shortcut. Writer will suggest a one-letter shortcut, which you 
can change.

5) Click the AutoText button on the right of the AutoText dialog box and select New 
(text only) from the menu.

6) Click Close to return to your document.

Tip If the only option under the AutoText button is Import, either you have not entered 
a name for your AutoText or there is no text selected in the document.

AutoText is especially powerful when assigned to fields. See Chapter 14 (Working with 
Fields) for more information.

Line numbering

Line numbering puts line numbers in the margin. The line numbers are displayed on screen 
and are printed. Figure 82 shows an example with numbering on every line.

Click Tools > Line Numbering and select the Show numbering checkbox in the top left 
corner. Then click OK.

Figure 82: Line numbering example

You can choose how many lines are numbered (for example, every line or every tenth line), 
the numbering type and whether numbers restart on each page. In addition, a text separator 
(any text you choose) can be set on a different numbering scheme (one every 12 lines, for 
example). See Figure 83.
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Figure 83: The Line Numbering dialog box

Undoing and redoing changes

To undo the most recent change, press Control+Z, click the Undo icon  on the Standard 
toolbar, or select Edit > Undo from the menu bar.

The Edit menu shows the latest change that can be undone, as shown in Figure 84.

Figure 84: Edit > Undo last action

Click the small triangle to the right of the Undo icon to get a list of all the changes that can 
be undone (Figure 85). You can select multiple changes and undo them at the same time.

Figure 85: List of actions that can be undone
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After changes have been undone, Redo becomes active. To redo a change, select Edit > 

Redo, or press Control+Y or click on the Redo icon . As with Undo, click on the triangle 
to the right of the arrow to get a list of the changes that can be reapplied.

To modify the number of changes OpenOffice.org remembers, select Tools > Options > 
OpenOffice.org > Memory and change Undo: Number of steps. Be aware that asking OOo 
to remember more changes makes it consume more memory.

Tracking changes to a document

You can use several methods to keep track of changes made to a document.

• Make your changes to a copy of the document (stored in a different folder, under a 
different name, or both), then use Writer to combine the two files and show the 
changes you made. Click Edit > Compare Document. This technique is particularly 
useful if you are the only person working on the document, as it avoids the increase in 
file size and complexity caused by the other methods.

• Save versions that are stored as part of the original file. However, this method can 
cause problems with documents of nontrivial size or complexity, especially if you save 
a lot of versions. Avoid this method if you can.

• Use Writer’s change marks (often called “redlines” or “revision marks”) to show 
where you have added or deleted material or changed formatting. Later, you or another 
person can review and accept or reject each change.

Tip Not all changes are recorded. For example, changing a tab stop from align left to 
align right and changes in formulas (equations) or linked graphics are not recorded.

Preparing a document for review
When you send a document to someone else to review or edit, you may want to prepare it 
first so that the editor or reviewer does not have to remember to turn on the revision marks. 
After you have protected the document, any user must enter the correct password in order to 
turn off the function or accept or reject changes.

1) Open the document. To check whether it contains multiple versions, click File > 
Versions. If multiple versions are listed, save the current version as a separate 
document with a different name and use this new document as the review copy.

2) With the review copy open, make sure that change recording is turned on. The Edit > 
Changes > Record menu item has a check mark next to it when recording is turned 
on.

3) Click Edit > Changes > Protect Records. On the Enter Password dialog box, type a 
password (twice) and click OK.

Note Passwords must contain at least five characters. It is not necessary to password 
protect the document while preparing it for review.
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Recording changes
See Chapter 2 (Setting up Writer) for instructions on setting up how your changes will be 
displayed.

1) To begin tracking (recording) changes, click Edit > Changes > Record.

To show or hide the display of changes, click Edit > Changes > Show.

Tip Hold the mouse pointer over a marked change; you will see a Help Tip showing the 
type of change, the author, date, and time of day for the change. If Extended Tips are 
enabled, you will also see any comments recorded for this change.

2) To enter a comment on a marked change, place the cursor in the area of the change and 
then click Edit > Changes > Comment. (See Figure 86.) In addition to being 
displayed as an extended tip, the comment is also displayed in the list in the Accept or 
Reject Changes dialog box.

Figure 86: Inserting a comment during change recording

To move from one marked change to the next, use the arrow buttons. If no comment 
has been recorded for a change, the Text field is blank.

3) To stop recording changes, click Edit > Changes > Record again.

Inserting notes
To insert a note that is not associated with a recorded change:

1) Place the cursor at the text you want to comment on, then click Insert > Note.

2) On the Insert Note dialog box (Figure 87), type your note. Click the Author button to 
insert your initials and the date and time.
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To view a note, move the mouse pointer over the note marker (displayed as a small yellow 
rectangle). Writer displays the note in a Tip above the text. You can also double-click on the 
note to see it inside the Edit Note dialog box. If you have trouble viewing or selecting notes 
this way, you can use the Navigator instead: expand the list of notes, select the one you want, 
right-click on it, select Note, and then select Edit to display the Edit Note dialog box.

The Edit Note dialog box looks much like the Insert Note dialog box, with the addition of 
forward and back arrow buttons if the document contains more than one note.

Tip You can change the color of the note marker using the Tools > Options > 
OpenOffice.org > Appearance dialog box. (In the Text Document section ─ Note 
Indicator.)

Figure 87: Inserting a note

Accepting or rejecting changes and comments
1) Click Edit > Changes > Accept or Reject. The Accept or Reject Changes dialog box 

(Figure 88) opens.

2) When you select a change in the dialog box, the actual change is highlighted in the 
document, so you can see what the editor changed.

3) Click Accept or Reject to accept or reject the selected change. You can also click 
Accept All or Reject All if you do not want to review the changes individually.

Changes that have not yet been accepted or rejected are displayed in the list. Accepted 
changes are removed from the list and appear in the text without any marking.
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Figure 88: The List tab of the Accept or Reject Changes dialog box

To show only the changes of certain people or only the changes on specific days or various 
other restrictions, use the Filter page (Figure 89) on the Accept or Reject Changes dialog 
box. After specifying the filter criteria, return to the List page to see those changes that meet 
your criteria.

Figure 89: The Filter page of the Accept or Reject Changes dialog box
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Merging modified documents
The processes discussed to this point are effective when you have one reviewer at a time. 
Sometimes, however, multiple reviewers all return edited versions of a document at the same 
time. In this case, it may be quicker to review all of these changes at once, rather than one 
review at a time. For this purpose, you can merge documents in Writer.

To merge documents, all of the edited documents need to have recorded changes in them.

a) Open one copy.

b) Click Edit > Changes > Merge Document and select and insert another copy of the 
document to be merged with the first.

c) After the documents merge, the Accept or Reject Changes dialog box opens, as in 
Figure 88, showing changes by more than one reviewer. If you want to merge more 
documents, close the dialog box and then repeat step 2.

d) Repeat until all copies are merged.

All recorded changes are now included in the open copy. Save this file under another name.

Comparing documents
Sometimes reviewers may forget to record the changes they make. This is not a problem with 
Writer because you can find the changes if you compare documents.

In order to compare documents, you need to have the original document and the one that is 
edited. To compare them:

1) Open the edited document. Select Edit > Compare Document.

2) The Insert dialog box appears. Select the original document and click Insert.

Writer finds and marks the changes and displays the Accept or Reject Changes dialog box. 
From this point, you can go through and accept or reject changes procedure as described 
earlier.

Linking to another part of a document

If you type in references to other parts of the document, those references can easily get out of 
date if you reorganize the order of topics, add or remove material, or reword a heading, OOo 
provides two ways to ensure that your references are up to date, by inserting links to other 
parts of the same document or to a different document.

• Hyperlinks
• Cross-references

The two methods have the same result if you Control+click the link when the document is 
open in OOo: you are taken directly to the cross-referenced item. However, they also have 
two major differences: 
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• The text in a hyperlink does not automatically update if you change the text of the 
linked item (although you can change it manually), but changed text does 
automatically update in a cross-reference.

• When using a hyperlink, you do not have a choice of the content of the link (for 
example text or page number), but when using a cross-reference, you do have several 
choices, including bookmarks.

Using hyperlinks
To insert a cross-reference as a hyperlink in your document, use the Navigator:

1) Open the documents containing the items you want to cross-reference.

2) Open the Navigator (by clicking its icon, choosing Edit > Navigator, or pressing F5.

3) Click the arrow next to the Drag Mode icon, and select Insert as Hyperlink.

4) In the list at the bottom of the Navigator, select the document containing the item that 
you want to cross-reference.

5) In the Navigator list, select the item that you want to insert as a hyperlink.

6) Drag the item to where you want to insert the hyperlink in the document. The name of 
the item is inserted in the document as an active hyperlink.

Using cross-references
To ensure that references update if you reword a heading, caption, or other linked item, use 
automatic cross-references. See “Using automatic cross-references” in Chapter 14 (Working 
with Fields) for details.

Using bookmarks
Bookmarks are listed in the Navigator and can be accessed directly from there with a single 
mouse click. In HTML documents, bookmarks are converted to anchors that you can jump to 
by hyperlink. For more about bookmarks, see “Using bookmarks” in Chapter 14 (Working 
with Fields).

Working with hyperlinks

When you type text (such as a website addresses or URL) that can be used as a hyperlink, 
OOo formats it automatically, creating the hyperlink and applying to the text a color and 
underlining. If this does not happen, you can enable this feature using Tools > AutoCorrect 
> Options and selecting the URL Recognition checkbox.
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Tips If you do not want OOo to convert a specific URL to a hyperlink, select Edit > Undo 
Insert from the menu bar or press Control+Z immediately after the formatting has 
been applied.

To change the color of hyperlinks, go to Tools > Options > OpenOffice.org > 
Appearance, scroll to Unvisited links and/or Visited links, select the checkboxes, 
pick the new colors and click OK. Caution: this will change the color for all 
hyperlinks in all components of OpenOffice.org—this may not be what you want.

In Writer and Calc (but not Draw or Impress), you can also change the Internet link 
character style or define and apply new styles to selected links.

You can also insert and modify links using the Hyperlink dialog (Figure 90). To display the 

dialog, click the Hyperlink icon  on the Standard toolbar or select Insert > Hyperlink 
from the menu bar. To turn existing text into a link, highlight it before opening the Hyperlink 
dialog.

Figure 90. Hyperlink dialog showing details for Internet links

On the left hand side, select one of the four types of hyperlink:

• Internet: a web address, normally starting with http://

• Mail & News: for example an email address.

• Document: the hyperlink points to another document or to another place in the 
presentation.

• New document: the hyperlink creates a new document. 

The top right part of the dialog changes according to the choice made for the hyperlink type. 
A full description of all the choices, and their interactions, is beyond the scope of this chapter. 
Here is a summary of the most common choices used in presentations.
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For an Internet type hyperlink, choose the type of hyperlink (choose between Web, FTP or 
Telnet), and enter the required web address (URL). 

For a Mail and News type hyperlink, specify whether it is a mail or news link, the receiver 
address and for email, also the subject.

For a Document type hyperlink, specify the document path (the Open File button opens a file 
browser); leave this blank if you want to link to a target in the same presentation. Optionally 
specify the target in the document (for example a specific slide). Click on the Target icon to 
open the Navigator where you can select the target, or if you know the name of the target, 
you can type it into the box.

For a New Document type hyperlink, specify whether to edit the newly created document 
immediately or just create it (Edit later) and the type of document to create (text, 
spreadsheet, etc.). For a presentation, Edit now is the more likely choice. The Select path 
button opens a directory picker.

The Further settings section in the bottom right part of the dialog is common to all the 
hyperlink types, although some choices are more relevant to some types of links.

• Set the value of Frame to determine how the hyperlink will open. This applies to 
documents that open in a Web browser.

• Form specifies if the link is to be presented as text or as a button.

• Text specifies the text that will be visible to the user.

• Name is applicable to HTML documents. It specifies text that will be added as a 
NAME attribute in the HTML code behind the hyperlink.

• Event button: this button will be activated to allow OOo to react to events for which 
the user has written some code (macro). This function is not covered in this book.

Editing hyperlinks
From OOo 2.3, to edit a hyperlink, you can either click anywhere in the link text, or position 
the cursor in the link text using the arrow keys, and then open the Hyperlink dialog by 
clicking the Hyperlink icon on the Standard toolbar or selecting Edit > Hyperlink from the 
menu bar. (To activate a hyperlink, it is now necessary to hold down the Ctrl key while 
clicking on the link.)

With OOo 2.2.1 and earlier, clicking on a hyperlink activates the link. Therefore, to edit a 
link, either move the cursor into the link using the keyboard arrow keys, or change the status 
of the link by clicking on the acronym HYP (hyperlink) in the Status bar to change it to SEL 
(select), then open the Hyperlink dialog as described above.

Tip If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until 
you have edited all of them. Be sure to click Apply after each one. When you are 
finished, click Close.
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Switching between insert and overwrite mode

With the keyboard, press Insert to toggle between overwrite mode and insert mode. In insert 
mode, any text after the cursor position moves forward to make room for the text you type; in 
overwrite mode, text after the cursor position is replaced by the text you type. The current 
mode is displayed on the Status Bar.

With the mouse, click in the area on the Status Bar that indicates the current mode in order to 
switch to the other mode.

Counting the words in a selection

Select a block of text and choose Tools > Word Count. OOo displays the number of words 
and characters in the selection as well as the number of words in the document. You can also 
see the number of words and characters (and other information) in the entire document in 
File > Properties > Statistics.
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Introduction

Introduction

Writer provides several ways for you to control page layouts:

• Page styles

• Columns

• Frames

• Tables

• Sections

This chapter describes these methods and some associated things:

• Headers and footers

• Numbering pages

• Changing page margins

Tip Page layout is usually easier if you select the options to show text, object, table, and 
section boundaries in Tools > Options > OpenOffice.org > Appearance and if you 
select the options for paragraph ends, tabs, breaks, and other items in Tools > 
Options > OpenOffice.org Writer > Formatting Aids.

Choosing a layout method

The best layout method depends on what the final document should look like and what sort 
of information will be in the document. Here are some examples. Do not worry if all this 
does not mean much to you now. The techniques mentioned are all described in this chapter.

For a book similar to this user guide with 
one column of text, some figures without 
text beside them, and some other figures 
with descriptive text, use page styles for 
basic layout, and use tables to place figures 
beside descriptive text, when necessary.
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Use page styles (with two columns) for an index 
or other document with two columns of text 
where the text continues from the left-hand 
column to the right-hand column and then to the 
next page, all in sequence (also known as 
snaking columns of text). If the title of the 
document (on the first page) is full-page width, 
put it in a single-column section.

For a newsletter with a complex layout, two 
or three columns on the page, and some 
articles that continue from one page to some 
place several pages later, use page styles for 
basic layout. Place articles in linked frames 
and anchor graphics to fixed positions on the 
page, if necessary.

For a document with terms and translations 
to appear side-by-side in what appear to be 
columns, use a table to keep items lined up 
so you can type in both “columns”.
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Setting up basic page layout using styles

In Writer, page styles define the basic layout of all pages, including page size, margins, the 
placement of headers and footers, borders and backgrounds, number of columns, and so on.

Writer comes with several page styles, which you can build on or modify, and you can define 
new (custom) page styles. You can have one or many page styles in a single document.

Note All pages in a Writer document are based on styles. If you do not specify a page style, 
Writer uses the Default page style.

To change the layout of individual pages, either define a new page style or use one of the 
techniques (sections, frames, or tables) described later in this chapter.

This chapter describes some uses of page styles. Some other uses are discussed in Chapter 6 
(Introduction to Styles). The Page Style dialog box is covered in detail in Chapter 7 (Working 
with Styles).

Tip Any modifications of page styles, including the Default page style, apply only to the 
document you are working on. If you want the changes to be the default for all 
documents, you need to put the changes into a template and make that template the 
default template. See Chapter 10 (Working with Templates) for details.

Inserting a page break without switching the style
In many documents (for example, a multi-page report), you may want the text to flow from 
one page to the next as you add or delete information. Writer does this automatically, unless 
you override the text flow using one of the techniques described earlier.

If you do want a page break in a particular place, for example, to put a heading at the top of a 
new page, here is how to do it:

1) Position the cursor in the paragraph you want to be at the start of the next page. Right-
click and choose Paragraph in the pop-up menu.

2) On the Text Flow page of the Paragraph dialog box (Figure 91), in the Breaks section, 
check Insert. Do not check With Page Style.

Figure 91: Inserting a manual page break
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3) Click OK to position the paragraph at the start of the next page.

Defining a different first page for a document
Many documents, such as letters and reports, have a first page that is different from the other 
pages in the document. For example, the first page of a letterhead typically has a different 
header, as shown in Figure 92, or the first page of a report might have no header or footer, 
while the other pages do. With OOo, you can define the style for the first page and specify 
the style for the following page to be applied automatically.

Figure 92: Letterhead with different page styles for first and following pages

As an example, we can use the First Page and Default page styles that come with OOo. 
Figure 93 shows what we want to happen: the first page is to be followed by the default page, 
and all the following pages are to be in the Default page style.

Figure 93: Flow of page styles
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To set up this sequence:

1) Open the Styles and Formatting window. (You can choose one of the following: click 

the Styles and Formatting icon  located at the left-hand end of the object bar, 
choose Format > Styles and Formatting, or press F11.)

2) On the Styles and Formatting window (Figure 94), click on the Page Styles icon  
(fourth from the left) to display a list of page styles.

3) Right-click on First Page and select Modify from the pop-up menu.

Figure 94: Modifying the First Page style

4) On the Organizer page of the Page Style dialog box (Figure 95), look at the Next Style 
property. This property defines what the page style for the next page will be. It should 
be set to Default, but if it is not, you can change the next style by clicking on the drop-
down button and choosing Default from the list of page styles.

Figure 95: Setting the Next Style property for a page style

5) On the other pages of this dialog box, you can turn on or off the header and footer for 
the first page and define other characteristics, such as columns, a page border, or a 
page background. For more information, see Chapter 7 (Working with Styles).

6) Click OK to save the changes.
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Note You can override the Next Style property by manually inserting a page break and 
specifying a page style or by starting a page with a paragraph or table that has its 
own page style property defined. These techniques are described in “Inserting a
landscape page into a portrait document” on page 96.

Changing page orientation within a document
A document can contain pages in more than one orientation. A common scenario is to have a 
landscape page in the middle of a document, whereas the other pages are in a portrait 
orientation. Here are the steps to achieve it.

Setting up a landscape page style

1) Note the page style that is current and the margin settings. (You can find the margin 
settings on the Page page of the Page Style dialog box, as shown in Figure 98.)

2) Create a new style. (Right-click on the current page style in the Styles and Formatting 
window and choose New, as shown in Figure 96.)

Figure 96: Starting a new page 
style

3) On the Organizer page of the Page Style dialog box (Figure 97), name (by typing in 
the Name field) this new style Landscape and set the Next Style property to 
Landscape (to allow for having more than one sequential landscape page).

Figure 97: Naming the new style and setting the next page style to Landscape
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4) On the Page page of the Page Style dialog box (Figure 98), set the Orientation to 
Landscape. The width and height attributes of the page will automatically change.

5) Change the margins so that they correspond with the margins of the portrait page. That 
is, the portrait top margin becomes the landscape left margin, and so on.

6) Click OK to save the changes.

Figure 98: Setting orientation and margins for a landscape page

Inserting a landscape page into a portrait document

Now that you have defined the Landscape page style, here is how to apply it.

1) Position the cursor in the paragraph or table at the start of the page that is to be set to 
landscape. Right-click and choose Paragraph or Table, respectively, in the pop-up 
menu.

2) On the Text Flow page of the Paragraph dialog box (Figure 99) or the Table Format 
dialog box (Figure 100), select Insert (or Break for a table) and With Page Style. Set 
the Page Style property to Landscape. Click OK to close the dialog box and to apply 
the new page style.

3) Position the cursor in the paragraph or table where the page is to return to portrait 
orientation and change the properties of that paragraph or table properties so that With 
Page Style is the portrait page style that was used before the Landscape page style.

4) Click OK to return to the previous portrait page style.
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Figure 99: Specifying a page break before a paragraph

Figure 100: Specifying a page break before a table

Tip If you need the headers or footers on the landscape pages to be in portrait orientation, 
see “Portrait headers on landscape pages” on page 122.

Changing page margins

You can change page margins in two ways:

• Using the page rulers—quick and easy, but does not have fine control.

• Using the Page Style dialog box—can specify margins to two (fractional) decimal 
places.

Note If you change the margins using the rulers, the new margins affect the page style 
and will be shown in the Page Style dialog box the next time you open it.
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To change margins using the rulers:

1) The shaded sections of the rulers are the margins (see Figure 101). Put the mouse 
cursor over the line between the gray and white sections. The pointer turns into a 
double-headed arrow.

2) Hold down the left mouse button and drag the mouse to move the margin.

Tip The small arrows on the ruler are used for indenting paragraphs. They are often in the 
same place as the page margins, so you need to be careful to move the margin marker, 
not the arrows. Place the mouse pointer between the arrows and, when the pointer 
turns into a double-headed arrow, you can move the margin (the indent arrows will 
move with it).

Figure 101: Moving the 
margins

To change margins using the Page Style dialog box (Figure 98):

1) Right-click anywhere on the page and select Page from the pop-up menu.

2) On the Page page of the dialog box, type the required distances in the Margins boxes.

Using columns to define the page layout

You can use columns for page layout in several ways:

• Define the number of columns on a page, using page styles.

• Switch between one-column and multiple-column layouts on the same page.

• Select existing text and change the number of columns.

Defining the number of columns on a page
It is a good idea to define your basic page style (such as Default) with the most common 
layout to be used in your document, either single-column or multiple-column. You can then 
either define extra page styles for pages with different numbers of columns or use sections 
(described in “Using sections for page layout” starting on page 111) for pages or parts of 
pages with different numbers of columns.
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To define the number of columns on a page:

1) Choose Format > Columns or go to the Columns page of the Page Style dialog box.

2) On the Columns dialog box (Figure 102), choose the number of columns and specify 
any spacing between the columns and whether you want a vertical separator line to 
appear between the columns. You can use one of Writer’s predefined column layouts, 
or you can create a customized column layout. The preview box, located to the right of 
the Settings area, shows how the column layout will look.

3) Notice the Apply to box on the right-hand side of the dialog box. In this case, the 
changes are being applied to the Default page style.

4) Click OK to save the changes.

Figure 102: Defining the number of columns on a page

Using a predefined column layout

The Settings area displays five predefined column layouts. To use one of them, click the 
desired layout.

Specifying the number of columns

If you prefer to create a customized column layout, you must specify the number of columns 
that you want. Enter the desired number in the Columns box in the Settings area.

Distributing text across columns

You can distribute text across the columns in one of two ways:

• Evenly—If you choose to distribute text evenly, Writer will fill the first line of each 
column, followed by the second line of each column, and so on.
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• Newspaper-style—If you choose to distribute text newspaper-style, Writer will fill the 
columns one at a time, beginning with the first column.

To distribute text evenly, check the Evenly distribute contents to all columns check box in 
the Settings area. Clear this check box if you want to distribute text newspaper-style.

Note This check box is not always displayed in the Settings area. See “Changing the
number of columns for existing text” on page 101.

Formatting column width and spacing

To create evenly-spaced columns that are all the same width, check the AutoWidth check 
box in the Width and spacing area.

To customize the width and spacing of the columns, follow these steps:

1) In the Width and spacing area, clear the AutoWidth check box.

2) On the Width line, enter a width for each column.

3) On the Spacing line, enter the amount of space that you want between each pair of 
columns.

If you specify more than three columns, use the arrow keys on the Column line to scroll 
among the columns.

Formatting separator lines

To display separator lines between the columns:

1) Eighteen separator line options exist: None or various lines of thicknesses which range 
from 0.05 to 9 pt). From the Line drop-down list in the Separator line area, select the 
type of line that you want. (1 pt = 1 point = 1/12 pica = 1⁄72 inch = 127⁄360 mm = 

0.3527 mm.)

2) The default format is for the separator lines to have the same height as the columns. If 
you want the separator lines to be shorter than the columns, use the Height box to 
enter the height of the separator lines as a percentage of the height of the columns. For 
example, if you enter 50%, the separator lines will be half as high as the columns.

3) If you entered a height of less than 100%, use the Position drop-down list to select a 
vertical alignment for the separator lines. The vertical-positioning options are: Top, 
Centered, or Bottom.

Reverting to a single-column layout

To revert to a single-column layout, go to the Settings area and either reset the number in the 
Columns box to 1 or click the single-column layout icon.
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Changing the number of columns for existing text
You might want some parts of a page to have one column and other parts of the page to have 
two or more columns. For example, you might have a page-width headline over a three-
column news story.

You can create columns and then type or paste text into them, or you can select some existing 
text and change the number of columns for displaying it.

When you select text and change the number of columns for that text, Writer turns the 
selected text into a section, as described in “Using sections for page layout” on page 111.

Figure 103 shows the Columns dialog box for a selection. Notice that the Apply to box on the 
right-hand side has Selection highlighted and an extra check box (Evenly distribute 
contents to all columns) appears in the upper left-hand part of the dialog box.

As you add text to the section, you will see that the text flows from one column to the next so 
that all the columns adjust to the same height. If this is not what you want, click anywhere in 
the section, then choose Format > Columns to reopen the Columns dialog box, deselect the 
Evenly distribute contents to all columns check box, and click OK to effect the change.

Tip Choose View > Nonprinting Characters (or press Ctrl+F10) to display end of 
paragraph markers (¶). Often, unexpected behavior of columns is due to extra 
paragraphs that are normally invisible to the user but are taking up space.

Figure 103: Specifying columns for a selection
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Using frames for page layout

Frames can be very useful when producing a newsletter or other layout-intensive documents. 
Frames can contain text, tables, multiple columns, pictures, and other objects.

Use frames when you need to:

• Position something in a particular place on a page, for example, a logo or a “stop 
press” news box in one corner of a page.

• Allow text on one page to continue on another page, somewhere more distant than the 
next one, by linking the content of one frame to another so the contents flow between 
them as you edit the text.

• Wrap text around an object, such as a photograph.

Because OpenOffice.org does not allow you to define page styles with recurring frames, 
consider doing some quick sketches of the basic page layouts you need, indicating the 
approximate positions of different frames and their purposes. Try to keep the number of 
different page layouts as low as possible in order to avoid chaos in your design.

Pay special attention to the positioning of frames. Many of the predefined styles default to a 
center alignment. This is the lowest common denominator of design; centering all frames 
looks reasonably good in most cases but is rarely the best choice.

One of the most visually effective ways to position a frame is to align its left margin with that 
of the paragraph above it. To achieve this effect, insert the frame in a blank paragraph of the 
same style as the paragraph above. Then, select Insert > Frame > Type > Position > 
Horizontal > From Left to position the frame exactly where you want it.

You also should think about the type of wrap and the spacing between the frame and text. 
Instead of cramming a frame close to the text, use the Wrap tab to place some white space 
between them.

You can format frames individually or define and apply frame styles—see Chapter 7 
(Working with Styles).

Tip The Help uses the phrase “text frame” for two quite different things with very 
different characteristics: frames (as discussed here) and text objects, which are 
drawing objects similar to lines and boxes.

Creating frames
You can create a frame in several ways, depending on your needs.

• Choose Insert > Frame) to create an empty frame. The Frame dialog box (Figure 105) 
appears. You can click OK and come back to customize it later, or you can set the 
frame’s characteristics at this stage.

• Select text or a graphic, choose Insert > Frame, and click OK to create a frame 
containing the selection. The selected text is automatically deleted from the normal 
text flow and inserted into the frame, and the Frame dialog box appears.
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• Insert a picture or other object by selecting Insert > Picture > From file or Insert > 
Object to start the process to insert a picture or object. The item inserted automatically 
appears in a frame, but the Frame dialog box does not appear.

• Use the Insert Frame Manually icon on the Insert toolbar (go to View > Toolbars > 
Insert to display it), select the number of frames in the drop-down menu, and drag the 
mouse to draw the frame.

Figure 104: Using an icon on the Insert toolbar to create a frame

When you release the mouse button, a box appears where the cursor 
is located in the document. This box represents the frame: an area 
isolated from the main document.

To add content to a frame, first deselect the frame by clicking 
somewhere else on the page. Then, click inside the frame so that the cursor shifts its focus 
there. Now add content just like you would on the main page. When you are done, deselect 
the frame.

Moving, resizing, and changing frame attributes
When an object is added to Writer, it is automatically enclosed in a frame of a predetermined 
type. The frame sets how the object is placed on the page, as well as how it interacts with 
other elements in the document. You can edit the frame by modifying the frame style it uses 
or by using a manual override when a frame is added to the document. Frame styles are 
discussed in Chapter 7 (Working with Styles).

To change the size or location of a frame, first select the frame, then use either the mouse or 
the Frame dialog box (Figure 105). Using the mouse is faster but less accurate. You might use 
the mouse for gross layout and the dialog box for fine-tuning.

You can resize the frame manually (by clicking on the green squares and dragging to the 
appropriate size) or start adding content to it (the frame will resize automatically if you, for 
example, add a large picture to it) or go back to the Frame dialog box and set the size and 
other characteristics.

To change the location of the frame using the mouse, drag and drop one of the edges or 
having the cursor anywhere within the frame. (The I-bar cursor changes to a four-headed 
arrow when properly positioned for a drag-and-drop move.) To change the size of the frame, 
drag one of the handles. Drag a handle on one of the sides to enlarge or reduce the text frame 
in one dimension only; drag a corner handle to enlarge or reduce it in both dimensions.
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These resizing actions distort the proportions of the frame. Holding down the Shift key while 
dragging one of the handles makes the frame keep the same proportions.

You can open the Frame dialog box (Figure 105) at any time by selecting the frame, right-
clicking, and choosing Frame from the pop-up menu.

Figure 105: Frame dialog box

To remove the default border on a newly created frame, open the Frame dialog box, go to the 
Borders page, and under Line Style, select None. Alternatively, you can assign a borderless 
frame style to the frame; see the Chapter 7 (Working with Styles) for information on frame 
styles.

Tip Do not confuse a frame’s border with the text boundaries that are made visible 
using the View menu (by checking View > Text Boundaries).
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Figure 106: Removing the border from a frame

Anchoring a frame
Using the Frame dialog box (or by right-clicking and pointing to Anchor), you can anchor a 
frame to a page, paragraph, or character, or you can anchor it as a character.

To Page

The frame keeps the same position in relation to the page margins. It does not move as you 
add or delete text. This method is useful when the frame does not need to be visually 
associated with a particular piece of text. It is often used when producing newsletters or other 
documents that are very layout-intensive.

To Paragraph

The frame is associated with a paragraph and moves with the paragraph. It may be placed in 
the margin or another location. This method is useful as an alternative to a table for placing 
icons beside paragraphs.

To Character

The frame is associated with a character but is not in the text sequence. It moves with the 
paragraph but may be placed in the margin or another location. This method is similar to 
anchoring to a paragraph.

As Character

The frame is placed in the document like any other character and, therefore, affects the height 
of the text line and the line break. The frame moves with the paragraph as you add or delete 
text before the paragraph. This method is useful for adding a small icon in sequence in a 
sentence. It is also the best method for anchoring a graphic to an empty paragraph so it does 
not move around the page in unexpected ways.
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Linking frames
You can link several frames to each other even when they are on different pages of a 
document. The contents will automatically flow from one to the next. This technique is very 
useful when designing newsletters, where articles may need to be continued on a different 
page.

To link one frame to another:

1) Select the frame to be linked from.

2) Click the Link Frames icon  on the object bar.

3) Click the next frame in the series (which must be empty).

When a linked frame is selected, any existing links are indicated by a faint connecting line, as 
shown in Figure 107. Note that any frame-linking line will not be as clear as illustrated in the 
figure.

Figure 107: Linked frames

Note You cannot link from a frame to more than one other frame.

The height of a frame that is being linked from is fixed; you can change this height manually 
or by using the Frame dialog box, but it does not automatically adjust to the size of the 
contents (that is, the AutoHeight attribute is disabled). Only the last frame of a chain can 
adapt its height to the content.

The Options page of the Frame dialog box (Figure 108) shows the names of the selected 
frame and any frames it is linked to or from. You can change this information here. On this 
page, you can also select check boxes to protect the contents, position, and size of the frame.
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Figure 108: Options page of the Frame dialog box

On the Hyperlink page (Figure 109), you can specify the file for the hyperlink to open. This 
file can be on your machine, a network, or the Internet.

Figure 109: Hyperlink page of the Frame dialog box

The Wrap, Borders, Background, Columns, and Macro pages of the Frame dialog box are the 
same as those for frame styles. Refer to the Chapter 7 (Working with Styles) for details.
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Using tables for page layout

Writer’s tables can serve several purposes, such as holding data as you might see it in a 
spreadsheet, lining up material, and creating more complex page layouts. For information 
about using tables of data, see Chapter 9 (Working with Tables).

This topic describes how to achieve some common layouts by using tables.

Example: Creating sideheads using tables
Sideheads and marginal notes are commonly used in documents from resumes to computer 
user guides. The main body of the text is offset to leave white space (usually on the left-hand 
side) in which the sideheads or notes are placed. The first paragraph is aligned beside the 
sidehead, as in Figure 110.

Example of a 
sidehead

In some cases you may want to put only one or two paragraphs in the 
table itself and the rest of the text and graphics in ordinary paragraphs 
(formatted to line up with the paragraphs in the table) so that text and 
graphics will flow more easily from one page to another when you add or 
delete material.

In other cases, you might put each paragraph in a separate row of the 
table and allow the table to break between pages.

Figure 110: Example of a sidehead

Note Sideheads can also be created by placing text in a frame using the Marginalia frame 
style, as described in the Chapter 7 (Working with Styles).

To create a table for use with a sidehead:

1) Place the cursor where you want the table to appear and choose Insert > Table (Ctrl
+F12).

2) In the Insert Table dialog box (Figure 111), define a one-row, two-column table with 
no border and no heading. Click OK to create the table.
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Figure 111: Defining a two-column borderless table with no header

3) Position the cursor over the central dividing line in the table. The cursor turns into a 
double-headed arrow. Left-click and drag to resize the columns. Alternatively, right-
click and choose Table from the pop-up menu; on the Columns page (Figure 112), 
make the columns the required width.

Figure 112: Defining a two-column table to line up with text offset at 1.2 inches

4) On the Table page of the Table Format dialog box (Figure 113), in the Spacing section, 
make the Above and Below values the same as the Top and Bottom spacing you have 
defined for ordinary paragraphs of text. Click OK to save your settings.
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Figure 113: Defining the space above and below a table

Tip To check the top and bottom spacing for ordinary paragraphs:

Position the cursor in a paragraph and press F11 (unless the Styles and Formatting 
window is already open). Check that the Styles and Formatting window shows 
paragraph styles (top left button).

The current style should be highlighted. If no paragraph style is highlighted, select 
All Styles in the bottom drop-down list. Right-click on it and select Modify from 
the pop-up list.

Go to the Indents & Spacing page and look in the Spacing area for the values in 
Above paragraph and Below paragraph.

You may also want to turn off number recognition so that Writer will not try to format 
numbers if you want them to be plain text. To turn number recognition off:

1) Right-click in the table and then click Number Format on the pop-up menu.

2) On the Number Format dialog box (Figure 114), make sure the Category is set to Text. 
Click OK.

Figure 114: Setting number format to Text
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Tip If you use this table format often, you may want to save it as AutoText, as described in 
Chapter 3 (Working with Text). Select the table (not just the contents) to assign the 
shortcut.

Using sections for page layout

A section is a block of text that has special attributes and formatting. You can use sections to:

• Write-protect text

• Hide text

• Dynamically insert the contents of another document

• Add columns, margin indents, a background color, or a background graphic to a 
portion of your document

• Customize the footnotes and endnotes for a portion of your document

Creating sections
To create a section:

1) Place the cursor at the point in your document where you want to insert the new 
section. Or, select the text that you want to place in the new section.

2) From the main menu, choose Insert > Section. The Insert Section dialog box opens.

3) Click the Section tab, if it is not already displayed. (See Figure 115.)

The Insert Section dialog box has five tabbed pages:

• Use the Section page to set the section’s attributes.

• Use the Columns page to format the section into columns.

• Use the Indents page to set indents in the right and left margins of the section.

• Use the Background page to add color or a graphic to the section’s background.

• Use the Footnotes/Endnotes page to customize the section’s footnotes and endnotes.

At any time, you can reset a tabbed page to its default settings by clicking the Reset button. 
(Note, however, that you cannot reset the Section page. If you wish to undo changes to the 
Section page, you must do so manually.)

Using the Section page
Use the Section page (Figure 115) to set the attributes of the current section.
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Naming sections

Writer automatically enters a name for the current section in the top box of the New section 
area. To change the name, select it and type over it. The name is displayed in the Sections 
category of the Navigator window. If you give your sections meaningful names, you can 
navigate to them more easily.

Figure 115: Inserting a section using the Insert Section dialog box

Linking sections

You can insert the contents of another document into the current section and then have Writer 
update the section whenever the other document is updated. This is called linking the section 
to the other document.

To link the current section to another document, follow these steps:

1) In the Link area (see Figure 116), check the Link check box.

Figure 116: Linking sections

2) Click the (...) button to the right of the File name field. The Insert dialog box opens.
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3) Find and select the document you want to insert and then click the Insert button. The 
Insert dialog box closes and the name of the selected document appears in the File 
name field.

4) If you want to insert only a section of the selected document, select the desired section 
from the Section drop-down list.

Note The section must already exist in the selected document. You cannot create a 
section in the selected document at this point.

You can update links automatically or manually. See “Updating links” on page 120.

Write-protecting sections

To write-protect the current section so that its contents cannot be edited, check the Protect 
check box in the Write protection area ( Figure 118).

Figure 117: Write-protecting sections

Note Write-protection protects only the section’s contents, not its attributes or format.

Password-protecting sections

To prevent others from editing the section’s attributes or format, protect the section with a 
password, as follows:

3) Check the With password check box. The Enter Password dialog box (Figure 118) 
opens.

4) Type a password in the Password field and then confirm the password by typing it 
again in the Confirm field.

5) Click OK. The Enter Password dialog box closes. Anyone who tries to edit the 
section’s attributes or format will be prompted to enter the password.

Figure 118: Password-protecting a section

Note Passwords must contain at least five characters. The OK button remains inactive 
until you have typed five characters.
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Hiding sections

You can hide the current section so that it will not be displayed on the screen or printed. You 
can also specify conditions for hiding the section. For example, you can hide the section only 
from certain users.

Note You cannot hide a section if it is the only content on the page or if the section is in a 
header, footer, footnote, endnote, frame, or table cell.

To hide a section, check the Hide check box in the Hide area (Figure 119).

Figure 119: Hiding sections

To hide the section only under certain conditions, enter the desired conditions in the With 
Condition field. The syntax and operators that you use to enter conditions are the same ones 
that you use to enter formulas. For syntax and a list of operators, see Writer’s online help 
under “conditions”.

If the section is write-protected with a password, the password must be entered to hide or 
reveal the text.

Note Hiding text is not a secure way to stop someone else reading it. It will stop the 
casual reader but will not prevent someone who actively wants to find out what you 
have hidden―even if it is password protected.

Using the Columns page
Use the Columns page of the Insert Section dialog box to format the current section into 
columns. This page is very similar to the Columns dialog box shown in Figure 103 on page 
101. Please refer to that topic for details.

Using the Indents page
Use the Indents page, pictured in Figure 120, to set indents in the right and left margins of the 
current section. Enter the desired left-margin indent in the Before section box. Enter the 
desired right-margin indent in the After section box. The preview box on the right-hand side 
of the page shows you how the section will look with the indents applied.
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Figure 120: Indenting sections

Using the Footnotes/Endnotes page
Use the Footnotes/Endnotes page, pictured in Figure 121, to customize the current section’s 
footnotes and endnotes.

Customizing footnotes

If you want the current section’s footnotes to appear separately from the other footnotes in 
the document, check the Collect at end of text check box in the Footnotes area.

To number the current section’s footnotes separately from the other footnotes in the 
document, follow these steps:

1) In the Footnotes area, make sure that the Collect at end of text check box is checked.

2) Check the Restart numbering check box.

3) If you want the section’s footnotes to start at a number other than 1, enter the desired 
starting number in the Start at spin box.
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Figure 121: Setting footnotes and endnotes for sections

To edit the format of the section’s footnotes, follow these steps:

1) In the Footnotes area, make sure that the Collect at end of text and Restart 
numbering check boxes are checked.

2) Check the Custom format check box.

3) From the drop-down list under and to the right of the Custom format check box, 
select a numbering format for the footnotes.

4) To add text to the selected numbering format, use the Before and After fields. For 
example, if you want the footnote numbers to be preceded by the word “Note” and 
followed by a colon, fill the Before and After fields like this:

Figure 122: Numbering footnotes for sections
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Customizing endnotes

If you want the current section’s endnotes to appear at the end of the section rather than at the 
end of the document, check the Collect at end of section check box in the Endnotes area.

To number the current section’s endnotes separately from the other endnotes in the document, 
follow these steps:

1) In the Endnotes area, make sure that the Collect at end of section check box is 
checked.

2) Check the Restart numbering check box.

3) If you want the section’s endnotes to start at a number other than 1, enter the desired 
starting number in the Start at spin box.

To edit the format of the section’s endnotes, follow these steps:

1) In the Endnotes area, make sure that the Collect at end of section and Restart 
numbering check boxes are checked.

2) Check the Custom format check box.

3) From the drop-down list under and to the right of the Custom format check box, 
select a numbering format for the endnotes.

4) To add text to the selected numbering format, use the Before and After fields, as shown 
above for footnotes (Figure 122).

Using the Background page
Use the Background page to add color or a graphic to the background of the current section. 
This page is similar to the Background pages for paragraphs, frames, tables, and other objects 
in OOo. For more information, refer to Chapter 7 (Working with Styles).

Saving a new section
To save a new section so that it appears in your document, click the Insert button. The Insert 
Section dialog box closes and the new section appears in your document.

Editing and deleting sections
You can edit a section’s attributes and formatting, and you can also delete sections.

Selecting a section

To select the section that you want to edit or delete, follow these steps:

1) From the main menu, choose Format > Sections. The Edit Sections dialog box 
(Figure 123) opens.
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2) The name of the current section appears in the Section area, in the field above the list 
box. If you want to edit or delete a different section, click the name of the desired 
section in the list. The selected section becomes the current section, and its name 
appears in the field above the list box.

Figure 123: Edit Sections dialog box

Editing section attributes

To rename the current section, simply type over its name in the Section area.

From the Edit Sections dialog box, you can also edit the current section’s link, write-protect, 
and hide attributes. To learn how to edit these attributes, see:

“Linking sections” on page 112.

“Write-protecting sections” on page 113.

“Hiding sections” on page 114.

Deleting sections

To delete the current section, click the Remove button.

Note Writer will not prompt you to confirm the delete! To undo a delete, click the Cancel 
button.
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Editing the format of a section

To edit the format of the current section, click the Options button. The Options dialog box 
(Figure 124) opens.

The Options dialog box has four tabbed pages: Columns, Indents, Background, and 
Footnotes/Endnotes. To learn how to use these pages, see:

“Using the Columns page” on page 114.

“Using the Indents page” on page 114.

“Using the Background page” on page 117.

“Using the Footnotes/Endnotes page” on page 115.

To reset a page to its most recently saved settings, click the Reset button.

To save your Options settings and return to the Edit Sections dialog box, click OK.

Figure 124. Options dialog box for sections
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Updating links
You can have Writer update linked sections automatically, and you can also update links 
manually.

Updating links automatically

The default behavior, whenever you open a document that contains links, is for Writer to 
prompt you to update the links. To have Writer update links without prompting you or to turn 
off automatic updating, follow these steps:

1) Choose Tools > Options > OpenOffice.org Writer > General. The dialog box 
displays general text document settings.

2) In the Update area (Figure 125), under Update links when loading, select one of the 
following three options:

Figure 125: Writer > General options settings

• Select Always if you want Writer to update links automatically, without prompting 
you, whenever you open a document that contains links.

• Select On request if you want Writer to prompt you before updating links.

• Select Never if you do not want Writer to update links.

3) Click OK to save your settings. The Options dialog box closes.

Updating links manually

To update a link manually:

1) Open the document that contains the link.

2) Choose Edit > Links. The Edit Links dialog box opens. (See Figure 126.)

3) The list in the Edit Links dialog box displays the names of all the files that are linked 
to the current document. Click the file that corresponds to the link that you want to 
update.

4) Click the Update button. The most recently saved contents of the linked file appear in 
the current document.

5) To close the Edit Links dialog box, click Close.
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Figure 126: Edit Links dialog box

Creating headers and footers

Headers are portions of a document that always appear at the top of a page; footers appear at 
the bottom of a page. Typically, headers display the title or chapter name of a document. To 
insert a header, choose Insert > Header.

Figure 127: Inserting headers and 
footers

Similarly, to insert a footer, choose Footer.

Depending on which option you choose, an area will appear at the top or bottom of the page 
where you can enter text. This text will appear at the top or bottom of every page.
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Items, such as document titles, chapter titles, and page numbers, which often go into headers 
and footers, are best added as fields. That way, if something changes, the headers and footers 
are all updated automatically.

Fields are covered in Chapter 14 (Working with Fields), but one example here may be useful. 
To insert the document title into the header:

1) Select File > Properties > Description, enter a title for your document in the Title 
area, and click OK to close the dialog box.

2) Add a header (Insert > Header > Default).

3) Place the cursor in the header part of the page.

4) Select Insert > Fields > Title. The title should appear on a gray background (which 
does not show when printed and can be turned off).

5) To change the title for the whole document, choose File > Properties > Description.

Portrait headers on landscape pages
When you define a header and footer on a landscape page, they will be aligned with the long 
side of the page. If your landscape pages are going to be inserted between portrait pages, you 
might want the headers and footers to be on the short sides of the landscape pages, so the 
final printed product looks like the contents of the landscape pages have been rotated 90 
degrees on portrait pages.

You can set up portrait headers and footers on landscape pages by using a trick involving 
frames. These are a bit tedious to set up, but once you have done so, you can copy and paste 
them to other landscape pages. There does not appear to be a way to make this part of the 
landscape page style.

To set up portrait headers and footers on landscape pages:

1) Calculate the required margins so the text area of the landscape page is the same size 
as the text area on the portrait pages, taking into account the space for headers and 
footers on the portrait pages. For example, this book uses the margins shown in the 
following table. The landscape right and left margins are 1 cm larger than the portrait 
top and bottom margins, respectively. This difference accounts for the extra space used 
by the portrait header and footer (0.5 cm for the height of the header or footer and a 
0.5 cm gap between the header or footer and the main text).

Portrait page (right page) Landscape page (right page)

Top margin 1.5 cm Right margin 2.5 cm

Bottom margin 1.5 cm Left margin 2.5 cm

Left (inner) margin 2.8 cm Top margin 2.8 cm

Right (outer) margin 1.8 cm Bottom margin 1.8 cm

2) Create the landscape page style.
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3) Measure the distance from the upper and left edges of the page to the upper left-hand 
corner of the space where you want the footer to appear. Measure the width and length 
of the space the footer will occupy (to match footers on portrait pages). See Figure
128.

Figure 128: Measuring the location and size of the footer frame

4) In a blank paragraph in the text, type the footer text or insert fields such as the page 
number or the chapter number and name—to match the footer text and fields on the 
portrait pages. Assign the Footer style to this paragraph so the typeface, font size, and 
tab settings match those of the footers on the portrait pages.

5) Select the text (including the fields) you just entered. Choose Format > Character. 
On the Character dialog box, choose the Position tab (Figure 129) and set Rotation /  
Scaling to 270 degrees (counterclockwise). Click OK.
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Figure 129: Rotating the footer text 270 degrees counterclockwise

6) With the text still selected, choose Insert > Frame. In the Frame dialog box, choose 
the Type tab (Figure 130) and enter the width, height, and horizontal and vertical 
position for the footer.

Figure 130: Defining the size and position of the footer frame

7) If your footer has a line above the text, as in this book, on the Borders page (Figure
131), select a right border and specify the line width and spacing to the frame’s 
contents.
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Figure 131: Specifying the border position, line width, and spacing to contents

8) Click OK to save these settings. The footer should now appear in the required position 
and orientation.

Repeat these steps (using appropriate measurements) to set up a portrait header on the 
landscape page.

Numbering pages

To automatically number pages:

1) Insert a header or footer, as described in “Creating headers and footers” on page 121.

2) Place the cursor in the header or footer where you want the page number to appear and 
choose Insert > Fields > Page Number.

Including the total number of pages
To include the total number of pages (as in page 1 of 12):

3) Type the word page and a space; then insert the page number as above.

4) Press the spacebar once, type the word of and add a space; then choose Insert > Fields 
> Page Count.

Note The Page Count field inserts the total number of pages in the document, as shown 
on the Statistics page of the document’s Properties dialog box (File > Properties). 
If you restart page numbering anywhere in the document, then the total page count 
may not be what you want. See “Problems with restarting page numbering” on page 
127.
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Restarting page numbering
Often you will want to restart the page numbering at 1, for example, on the page following a 
title page or a table of contents. In addition, many documents have the front matter (such as 
the table of contents) numbered with Roman numerals and the main body of the document 
numbered in Arabic numerals, starting with 1.

You can restart page numbering in two ways.

Method 1:

1) Place the cursor in the first paragraph of the new page.

2) Choose Format > Paragraph.

3) On the Text Flow page of the Paragraph dialog box (Figure 99 on page 97), check 
Insert in the Breaks area.

4) In the Type drop-down list, select Page.

5) In the Position drop-down list, select Before or After to position where you want to 
insert the page break.

6) Check With Page Style and specify the page style to use.

7) Specify the page number to start from and then click OK.

Method 2:

1) Place the cursor in the first paragraph of the new page.

2) Choose Insert > Manual break.

3) Page break is the default selected on the Insert Break dialog box (Figure 132).

Figure 132: Restarting page numbering after a manual page break

4) Choose the required page in the Style drop-down list.

5) Check Change page number.

6) Specify the page number to start from and then click OK.
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Changing the format of page numbers
To set the page number to display in Roman numerals, you need to specify the format of 
numbers in the page style. In the Styles and Formatting dialog (press F11 if not already 
displayed) select the Page Styles icon and right-click on the highlighted entry for the current 
style: select Modify... which brings up the Page Style dialog.

On the Page page of the Page Style dialog box, in the Layout settings section (Figure 133), 
select i, ii, iii, ... from the Format drop-down list.

Figure 133: Changing format of page numbers

Problems with restarting page numbering
Restarting page numbering may lead to two problems.

• The Statistics page in the document’s Properties (File > Properties) always displays 
the total number of pages in the document, which may not be what you want to appear 
in the Page Count field.

• When page numbering is restarted, OOo always make sure that an odd-numbered page 
is a right page and an even-numbered page is a left page. It does this by inserting a 
blank page, if necessary. Sometimes this blank page is not desired, particularly when 
creating PDFs or when printing single sided.

Solving the page count problem

Suppose you know exactly how many pages are not to be included in the page count. (You 
want one page to be excluded in the page count for the following example.)

Instead of inserting a Page Count field, you can do the following:

1) Position the cursor where you want the page count to appear.

2) Press F2 to open the formula bar, just above the horizontal ruler in the main Writer 
window (see Figure 134).

3) After the equal sign, type page –1. If you want to exclude multiple pages, substitute 
the number of excluded pages for 1 in the formula.

4) Press Enter to close the formula bar and insert the resulting field into the document.
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Figure 134: Formula bar

If you do not know the total number of pages in advance, then one approach is to create a set 
reference on the last page and then insert a cross reference to it. Refer to Chapter 14 
(Working with Fields) for more information on setting references and inserting cross 
references.)

To create a set reference on the last page:

1) Go to the last page (Ctrl+End).

2) Choose Insert > Cross-reference.

3) On the References page of the Fields dialog box (Figure 135), select Set Reference in 
the Type column.

Figure 135: Setting a reference on the last page of the document

4) In the Name box, enter LastPage.

5) Click Insert. LastPage is now listed in the Selection column.
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To insert a cross-reference to the last page in the header or footer where you want to refer to 
the total number of pages:

1) Position the cursor at the desired location—for example after the space added after of 
in the header or footer, as in page xx of yy.

2) Choose Insert > Cross-reference.

3) On the References page of the Fields dialog box (Figure 136), select Insert Reference 
in the Type column and LastPage in the Selection column. LastPage now appears in 
the Name box.

4) In the Format column, select As page style. Click Insert.

Notes Do not delete the reference set at the end of the document. If you do, the cross-
reference will not work.

If a field, such as a cross-reference, does not automatically update, select the text 
containing the field and press F9.

Figure 136: Inserting a cross-reference to the last page of a document
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Numbering portrait and landscape pages
To create page numbers on portrait and landscape pages in the same place and orientation:

1) Refer to “Portrait headers on landscape pages” on page 122 to create a landscape page 
style and landscape header or footer styles. When creating the page style, check the 
Use dynamic spacing check box in the Spacing area in the Header or Footer pages of 
the Page Style dialog box.

2) Insert the page break and choose the landscape page style; do not change the page 
numbering.

3) In the relevant header or footer, insert the page number field (Insert > Fields > Page 
Number).

Numbering the first page something other than 1
Sometimes you may want to start a document with a page number greater than 1. For 
example, you may be writing a book, with each chapter in a separate file. Chapter 1 may start 
with page 1, but Chapter 2 could begin with page 25 and Chapter 3 with page 51.

Follow these instructions to start the page numbering in a document at a number greater than 
1. (These instructions are for a page number in a footer, but you could use a header instead.)

Tip Do not set a starting page number that is an even number because you will end up 
with a blank page before the first page when you print the file or export it as a PDF.

1) Choose Insert > Footer > [page style] to activate the footer. (If the page style is 
already checked in the Footer menu, point to it and click OK in the OpenOffice.org 
2.0 dialog box that appears. Then point to that page style again to select it.)

2) The cursor is now in the footer. To insert the page number, choose Insert > Fields > 
Page Number. The page number will be 1.

3) Click in the first paragraph in the text area or type a paragraph of text.

4) Choose Format > Paragraph (or right-click and choose Paragraph from the pop-up 
menu) to display the Paragraph dialog box.

5) On the Text Flow page (Figure 99 on page 97), in the Breaks section, select Insert and 
select Page in the Type drop-down list. Select With Page Style and the page style you 
are using for the first page of the document.

6) The Page number field is now active. Type the page number you want to start with. 
Click OK to close the Paragraph dialog box.
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Numbering pages by chapter
Technical documents often include the chapter number with the page number in the header or 
footer. For example, 1-1, 1-2, 1-3, ...; 2-1, 2-2, 2-3, ...

To set up this type of page numbering in OOo, you need to do three things:

1) Ensure that your chapter titles are all identified by the same paragraph style, for 
example, the Heading1 style. 

2) Use Tools > Outline Numbering to tell OOo what paragraph style you are using for 
Level 1 in your outline, and specify “1,2,3” in the Number box. (See Figure 137.)

Figure 137: Specifying paragraph style and numbering for chapter titles

3) Insert the chapter number in your document. To do this:

a) Place the cursor in the header or footer just before the page number you inserted 
earlier, and choose Insert > Fields > Other from the menu bar.

b) On the Fields dialog (Figure 138), go to the Document page. Select Chapter in the 
Type list, Chapter number in the Format list, and 1 in the Layer box. Click 
Insert. 

c) Type a hyphen or other punctuation between the chapter number and the page 
number.

For more information, see “Choosing paragraph styles for outline levels” and “Including 
chapter or section information in page headers” in Chapter 7 (Working with Styles).
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Figure 138: Inserting a chapter number field
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Introduction

General information about printing and faxing documents from OOo is provided in the 
Getting Started guide. This chapter describes some items of particular interest to users of 
Writer.

Quick printing

Click the Print File Directly icon  to send the entire document to the default printer 
defined for your computer.

Note (New in OOo 2.3) You can change the action of the Print File Directly icon to send 
the document to the printer defined for the document instead of the default printer 
for the computer. Go to Tools > Options > Load/Save > General and select the 
Load printer settings with the document checkbox.

Controlling printing

For more control over printing, use File > Print to display the Print dialog box (Figure 139).

Figure 139. The Print dialog box

On the Print dialog box, you can choose:

• Which printer to use (if more than one are installed on your system) and the properties 
of the printer—for example, orientation (portrait or landscape), which paper tray to 
use, and what paper size to print on. The properties available depend on the selected 
printer; consult the printer’s documentation for details.
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• What pages to print, how many copies to print, and in what order to print them. Use 
dashes to specify page ranges and commas or semicolons to separate ranges; for 
example: 1, 5, 11–14, 34–40. Selection is the highlighted part of a page or pages.

• What items to print. Click the Options button to display the Printer Options dialog 
box (Figure 140).

Selecting print options for a document
Selections on the Printer Options dialog box (Figure 140) apply to this printing of this 
document only. To specify default printing options for Writer, see “Selecting default print
options” on page 136.

Some items of interest on the Printer Options dialog box include:

• In the Contents section, you might choose not to print graphics or page background in 
drafts, for example (to save toner or ink).

• In the Pages section, you can choose:

• Print only left (even-numbered) pages or only right (odd-numbered) pages. These 
settings are useful when you want to print on both sides of the page, but do not 
have a printer that handles this automatically.

• Print in reversed page order.

• Brochure—the results of this selection are discussed in “Printing a brochure” on 
page 138.

• In the Notes section, you can choose whether to print any notes that have been added 
to your document (using Insert > Note), and where to print the notes.

Figure 140. Printer Options dialog box
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Selecting default print options
Selections on the Printer Options dialog box over-ride any default settings. To specify default 
settings for printing, use Tools > Options > OpenOffice.org Writer > Print. The page 
displayed contains the same choices as the Printer Options dialog box.

Other printer settings are found in Tools > Options > OpenOffice.org > Print, as shown in 
Figure 141. Use this page to specify quality settings for printing, and whether to have OOo 
warn you if the paper size or orientation of your document does not match the printer 
settings.

Figure 141. Printer options for OpenOffice.org 

Printing in black and white on a color printer
You may wish to print documents in black and white on a color printer, to save expensive 
color ink or toner. Common uses are for drafts or documents to be photocopied in black and 
white. Several choices are available.

To print the current document in black and white or grayscale:

1) Click File > Print to open the Print dialog box (Figure 139).

2) Click Properties to open the properties dialog box for the printer. The available 
choices vary from one printer to another, but you should find an option for Color. See 
your printer’s help or user manual for more information.

3) The choices for color may include black and white or grayscale. Choose one of these. 
Grayscale is best if you have any graphics in the document. Click OK to confirm your 
choice and return to the Print dialog box, then click OK again to print the document.
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To set up OOo to print all color text and graphics as grayscale:

1) Click Tools > Options > OpenOffice.org > Print to display the dialog box shown in 
Figure 141.

2) Select the Convert colors to grayscale checkbox. Click OK to save the change.

To set up OOo Writer to print all color text as black, and all graphics as grayscale:

1) Click Tools > Options > OpenOffice.org Writer > Print.

2) Under Contents, select the Print black checkbox. Click OK to save the change.

Previewing pages before printing
The normal page view in Writer shows you what each page will look like when printed, but it 
shows only one page at a time. If you are designing a document to be printed double-sided, 
you may want to see what facing pages look like. OOo provides a way to do this in Page 
Preview.

1) Click File > Page Preview, or click the Page Preview button .

The Writer window changes to display the current page and the following page, and 
shows the Page Preview toolbar (Figure 142) in place of the Formatting toolbar.

Figure 142. Page Preview toolbar

2) Click the Book Preview icon  to display left and right pages in their correct 
orientation.

3) To print the document in this page view, click the Print page view icon  to open 
the Print dialog box (Figure 139). Choose your options and click OK to print as usual.

4) To choose margins and other options for the printout, click the Print options page 

view icon  to display the Print Options dialog box (Figure 143).

Figure 143. Print Options dialog box
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Printing a brochure

You can print a document with two pages on each side of a sheet of paper, arranged so that 
when the printed pages are folded in half, the pages are in the correct order to form a booklet 
or brochure.

To print a brochure on a single-sided printer:

1) Plan your document so it will look good when printed half size (choose appropriate 
margins, font sizes, and so on). Click File > Print. In the Print dialog box (Figure
139), click Properties and be sure the printer is set to the same orientation (portrait or 
landscape) as specified in the page setup for your document. (Usually the orientation 
does not matter, but it does for brochures.)

2) Click Options. In the Pages section of the Printer Options dialog box (Figure 140), 
choose Brochure and Right pages. Click OK twice to print the first side of each page.

3) Flip the pages and put them back into the printer, in the correct orientation to print on 
the blank side. You may need to experiment a bit to find out what the correct 
arrangement is for your printer.

4) Click File > Print and check Properties to make sure the printer setup is still correct.

5) Click Options again. In the Pages section of the Printer Options dialog box, choose 
Brochure and Left page. Click OK twice to print the second sides.

6) If your printer can do double-sided, then click on the checkboxes for Left pages, 
Right pages, and Brochure, and it should not only do those but collate too.

Printing envelopes

Printing envelopes involves two steps: setup and printing.

To set up an envelope to be printed by itself or with your document:

1) Click Insert > Envelope from the menu bar.

2) In the Envelope dialog box, start with the Envelope tab (Figure 144). Verify, add, or 
edit the information in the Addressee and Sender boxes (the “from” on the envelope).

You can type information directly into the Addressee and Sender boxes, or use the 
right-hand drop-down lists to select the database or table from which you can draw the 
envelope information, if desired. See Chapter 11 (Using Mail Merge) for details on 
how to print envelopes from a database.

3) On the Format page(Figure 145), verify or edit the positioning of the addressee and 
the sender information. The preview area on the lower right shows the effect of your 
positioning choices.
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Figure 144. Choosing addressee and sender information for an envelope

Figure 145. Choosing positioning and size of elements for an envelope
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To format the text of these blocks, click the Edit buttons to the right. In the drop-down 
list you have two choices: Character and Paragraph.

• In Character, you can choose Fonts (Sizes...), Fonts Effects (Underlining, Color...), 
Position (Rotating/scaling...), Hyperlink, Background and more.

• In Paragraph, you can choose Indents & Spacing, Alignment, Text Flow, Tabs, 
Drop Caps, Borders and Backgrounds.

4) In the lower left of this page, choose the envelope format from the drop-down list. The 
width and height of the selected envelope then show in the boxes below the selected 
format. If you chose a pre-existing format, just verify these sizes. If you chose User 
defined in the Format list, then you can edit the sizes.

5) After formatting, go to the Printer page (Figure 146) to choose printer options such as 
envelope orientation and shifting. You may need to experiment a bit to see what works 
best for your printer.

You can also choose a different printer or alter printer setup (for example, specify the 
tray that holds envelopes) for this print job.

Figure 146. Choosing printer options for an envelope

6) When you have finished formatting and are ready to print, click either the New Doc or 
Insert button to finish. New Doc makes only an envelope or starts a new document 
with the envelope. Insert inserts the envelope into your existing document as page 1.

To not proceed with this envelope, click Cancel or press the Esc key. You can also 
click Reset to remove your changes and return to the original settings when the dialog 
box opened.

When the Envelope dialog box closes, you are returned to your document, which now has the 
envelope in the same file as the document. Save this file before you do anything else.

To print the envelope:

1) Choose File > Print from the menu bar.

2) On the Print dialog box, under Print range, choose Pages and type 1 in the box. Click 
OK to print.
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Printing labels

Labels are commonly used for printing address lists (where each label shows a different 
address), but they can also be used for making multiple copies of one label only, for example 
return-address stickers.

To print labels:

1) Choose File > New > Labels on the menu bar. The Labels dialog box opens.

2) On the Labels page (Figure 147), fill in your own label text in the Inscription box, or 
use the Database and Table drop-down lists to choose the required information, as 
described in Chapter 11 (Using Mail Merge).

Figure 147. Labels dialog box, Labels page

3) Select the label stock in the Brand drop-down list. The types for that brand then 
appear in the Type drop-down list. Select the size and type of labels required. You can 
also select User in the Type drop-down list and then make specific selections on the 
Format page (Figure 148).

4) On the Format page (Figure 148), choose the pitch, sizes, margins, columns and rows 
for user-defined labels, or just verify with a brand of label stock you have loaded into 
the printer.

5) When you have finished formatting, click New Document to make your sheet of 
labels or click Cancel (or press the Esc key). You can also click Reset to remove your 
changes and return to the original settings when the dialog box opened.
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Figure 148. Labels dialog box, Format page

6) Click Save to save your new format.

7) On the Options page (Figure 149), choose to print the entire page of labels or one 
single label, then select which one by the column and row. You can also change printer 
setup.

Figure 149. Labels dialog box, Options page

8) You can print right away using the Print File Directly icon on the toolbar or by 
choosing File > Print from the menu bar, or you can save the file to print later.
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Sending a fax

To send a fax directly from OpenOffice.org, you need a fax modem and a fax driver that 
allows applications to communicate with the fax modem.

Sending a fax through the Print dialog box
1) Open the Print dialog box (Figure 139) by choosing File > Print and select the fax 

driver in the Name list.

2) Click OK to open the dialog box for your fax driver, where you can select the fax 
recipient.

Adding a Fax icon to the toolbar (advanced)
You can configure OpenOffice.org so that a single click on an icon automatically sends the 
current document as a fax.

1) Be sure the fax driver is installed. Consult the documentation for your fax modem for 
more information.

2) Choose Tools > Options > OpenOffice.org Writer > Print. The dialog box shown in 
Figure 150 opens.

Figure 150: Setting up OOo for sending faxes

3) Select the fax driver from the Fax list and click OK.

4) Click the arrow icon at the end of the Standard toolbar. In the drop-down menu, 
choose Customize Toolbar. The Toolbars page of the Customize dialog box appears 
(Figure 151). Click Add.
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Figure 151: Customizing a toolbar

5) On the Add Commands dialog box (Figure 152), select Documents in the Category 
list, then select Send Default Fax in the Commands list. Click Add. Now you can see 
the new icon in the Commands list.

6) In the Commands list, click the up or down arrow button to position the new icon 
where you want it. Click OK and then click Close.

Your toolbar now has a new icon to send the current document as a fax.

Figure 152: Adding a command to a toolbar
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Exporting to PDF

OpenOffice.org can export documents to PDF (Portable Document Format). This industry-
standard file format is ideal for sending the file to someone else to view using Adobe Reader 
or other PDF viewers.

Quick export to PDF

Click the Export Directly as PDF icon  to export the entire document using the default 
PDF settings. You are asked to enter the file name and location for the PDF file, but you do 
not get a chance to choose a page range, the image compression, or other options.

Controlling PDF content and quality
For more control over the content and quality of the resulting PDF, use File > Export as 
PDF. The PDF Options dialog box opens. This dialog box has four pages (General, Initial 
View, User Interface, and Security). Make your selections, and then click Export. Then you 
are asked to enter the location and file name of the PDF to be created, and click Save to 
export the file.

General page of PDF Options dialog box

On the General page (Figure 153), you can choose which pages to include in the PDF, the 
type of compression to use for images (which affects the quality of images in the PDF), and 
other options.

Range section

• All: Exports the entire document.

• Pages: To export a range of pages, use the format 3-6 (pages 3 to 6). To export single 
pages, use the format 7;9;11 (pages 7, 9, and 11). You can also export a combination 
of page ranges and single pages, by using a format like 3-6;8;10;12.

• Selection: Exports whatever material is selected.
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Figure 153: General page of PDF Options dialog box

Images section

• Lossless compression:  Images are stored without any loss of quality. Tends to make 
large files when used with photographs. Recommended for other images.

• JPEG compression: Allows for varying degrees of quality. A setting of 90% tends to 
work well with photographs (small file size, little perceptible loss).

• Reduce image resolution: Lower-DPI (dots per inch) images have lower quality.

Note EPS images with embedded previews are exported only as previews. EPS images 
without embedded previews are exported as empty placeholders.

General section

• Tagged PDF: Includes special tags into the corresponding PDF tags. Some tags that 
are exported are table of contents, hyperlinks, and controls. This option can increase 
file sizes significantly.

• Export notes: Exports notes in Writer and Calc documents as PDF notes. You may not 
want this!

• Export bookmarks: Exports bookmarks.
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• Create PDF form - Submit format: Choose the format of submitting forms from 
within the PDF file. This setting overrides the control’s URL property that you set in 
the document. There is only one common setting valid for the whole PDF document: 
PDF (sends the whole document), FDF (sends the control contents), HTML, and 
XML. Most often you will choose the PDF format.

• Export automatically inserted blank pages: If selected, automatically inserted blank 
pages are exported to the PDF. This is best if you are printing the PDF double-sided. 
For example, books usually have chapters set to always start on an odd-numbered 
(right-hand) page. When the previous chapter ends on an odd page, OOo inserts a 
blank page between the two odd pages. This option controls whether to export that 
blank page.

Initial View page of PDF Options dialog box

On the Initial View page (Figure 154), you can choose how the PDF opens by default in a 
PDF viewer. The selections should be self-explanatory.

Figure 154: Initial View page of PDF Options dialog box

User Interface page of PDF Options dialog box

On the User Interface page (Figure 155), you can choose more settings to control how a PDF 
viewer displays the file. Some of these choices are particularly useful when you are creating a 
PDF to be used as a presentation or a kiosk-type display.
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Figure 155: User Interface page of PDF Options dialog box

Window options section

• Resize window to initial page. Causes the PDF viewer window to resize to fit the 
first page of the PDF.

• Center window on screen. Causes the PDF viewer window to be centered on the 
computer screen.

• Open in full screen mode. Causes the PDF viewer to open full-screen instead of in a 
smaller window.

• Display document title. Causes the PDF viewer to display the document’s title in the 
title bar.

User interface options section

• Hide menubar. Causes the PDF viewer to hide the menu bar.

• Hide toolbar. Causes the PDF viewer to hide the toolbar.

• Hide window controls. Causes the PDF viewer to hide other window controls.

Transitions

• Use Transition effects: Not available in Writer; in Impress, this option displays slide 
transition effects as their respective PDF effects.

Bookmarks

• All bookmark levels: All bookmarks will be displayed.

• Visible bookmark levels: From the drop-down list you choose how many levels of 
bookmarks to display.
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Security page of PDF Options dialog box

FromOOo 2.0.4, PDF export includes options to encrypt the PDF (so it cannot be opened 
without a password) and apply some digital rights management (DRM) features.

Figure 156: Security page of PDF Options dialog box

• With an open password set, the PDF can only be opened with the password. Once 
opened, there are no restrictions on what the user can do with the document (for 
example, print, copy, or change it).

• With a permissions password set, the PDF can be opened by anyone, but its 
permissions can be restricted. See Figure 156.

• With both the open password and permission password set, the PDF can only be 
opened with the correct password, and its permissions can be restricted.

Note Permissions settings are effective only if the user’s PDF viewer respects the settings.

Figure 157 shows the pop-up dialog box displayed when you click the Set open password 
button on the Security page of the PDF Options dialog box.

After you set a password for permissions, the other choices on the Security page (shown in 
Figure 156) become available. These selections should be self-explanatory. 
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Figure 157: Setting a password to encrypt a PDF

Exporting to other formats

Writer can export to XHTML (.xhtml), BibTeX (.bib), LaTeX 2e (.tex), and (new in OOo 2.3) 
MediaWiki (.txt).

To export to one of these formats, choose File > Export. On the Export dialog, specify a file 
name for the exported document, then select the required format in the File format list and 
click the Export button.

E-mailing Writer documents

OOo provides several ways to quickly and easily send a Writer document as an e-mail 
attachment in one of three formats: .ODT (OpenDocument Text, OOo’s default format), 
.DOC (Microsoft Word format), or PDF.

To send the current document in .ODT format:

1) Choose File > Send > Document as E-mail. OpenOffice.org opens the e-mail 
program specified in Tools > Options > Internet > E-mail. The document is attached.

2) In your e-mail program, enter the recipient, subject and any text you want to add, then 
send the e-mail.

File > Send > E-mail as OpenDocument Text has the same effect.

If you choose E-mail as Microsoft Word, OOo first creates a .DOC file and then opens your 
e-mail program with the .DOC file attached. Similarly, if you choose E-mail as PDF, OOo 
first creates a PDF using your default PDF settings (as when using the Export Directly as 
PDF toolbar button) and then opens your email program with the .PDF file attached.

E-mailing a document to several recipients

To e-mail a document to several recipients, you can use the features in your e-mail program 
or you can use OOo’s mail merge facilities to extract email addresses from an address book.
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You can use OOo’s mail merge to send e-mail in two ways:

• Use the Mail Merge Wizard to create the document and send it. See Chapter 11 (Using 
Mail Merge) for details.

• Create the document in Writer without using the Wizard, then use the Wizard to send 
it. This method is described here.

To use the Mail Merge Wizard to send a Writer document:

1) Click Tools > Mail Merge Wizard. On the first page of the wizard (Figure 158), 
select Use the current document and click Next.

Figure 158:  Select starting document

2) On the next page (Figure 159), select E-mail message and click Next.

Figure 159:  Select document type

3) On the next page (Figure 160), click the Select Address List button. Select the 
required address list (even if only one is shown) and then click OK. (If the address list 
you need is not shown here, you can click Add to find and add it to the list.)
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Figure 160: Selecting an address list

4) Back on the Select address list page, click Next. On the Create salutation page (Figure
161), deselect the checkbox by This document should contain a salutation.

Figure 161: Deselecting a salutation

5) In the left-hand list, click 8 Save, print or send. OOo displays a “Creating 
documents” message and then displays the Save, print or send page of the Wizard.

6) Select Send merged document as E-Mail. The lower part of the page changes to 
show e-mail settings choices (see Figure 162).

7) Type a subject for your email and click Send documents. OOo sends the e-mails.
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Figure 162: Sending a document as an email message

Digital signing of documents

To sign a document digitally, you need a personal key, the certificate. A personal key is stored 
on your computer as a combination of a private key, which must be kept secret, and a public 
key, which you add to your documents when you sign them. You can get a certificate from a 
certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a kind of checksum is computed from the 
document’s content plus your personal key. The checksum and your public key are stored 
together with the document. 

When someone later opens the document on any computer with a recent version of 
OpenOffice.org, the program will compute the checksum again and compare it with the 
stored checksum. If both are the same, the program will signal that you see the original, 
unchanged document. In addition, the program can show you the public key information 
from the certificate. You can compare the public key with the public key that is published on 
the web site of the certificate authority.

Whenever someone changes something in the document, this change breaks the digital 
signature.
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On Windows operating systems, the Windows features of validating a signature are used. On 
Solaris and Linux systems, files that are supplied by Thunderbird, Mozilla or Firefox are 
used. For a more detailed description of how to get and manage a certificate, and signature 
validation, see “Using Digital Signatures” in the OOo Help.

To sign a document:

1) Choose File > Digital Signatures.

2) If you have not saved the document since the last change, a message box appears. 
Click Yes to save the file.

3) After saving, you see the Digital Signatures dialog box. Click Add to add a public key 
to the document.

4) In the Select Certificate dialog box, select your certificate and click OK. 

5) You see again the Digital Signatures dialog box, where you can add more certificates 
if you want. Click OK to add the public key to the saved file.

A signed document shows an icon  in the status bar. You can double-click the icon to view 
the certificate.
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Introduction

Introduction

What are styles?
Most people are used to writing documents according to physical attributes. For example, 
you might specify the font family, font size, and weight (for example: Helvetica 12pt, bold).

Styles are logical attributes. We use styles every day. For example, there are two styles of 
personal computer: desktop and laptop. Each has its own distinctive set of properties. You 
never say “my computer is a low-weight, one-piece unit with an LCD screen attached to a 
rectangular casing containing the computing components and the keyboard”. Instead, you 
could say that you have a laptop.

OpenOffice.org (OOo) styles are a way to do the same thing for your document. Using styles 
means that you could stop saying—font size 14pt, Times New Roman, bold, centered—and, 
instead, you could start saying “title” for describing that particular font usage. In other words, 
styles means that you shift the emphasis from what the text looks like to what the text is.

Why use styles?
OOo brings a powerful notion of styles. Styles help improve consistency in a document. 
They also make major formatting changes easy. For example, you may decide to change the 
indentation of all paragraphs or change the font of all titles. For a long document, this simple 
task can be prohibitive. Styles make the task easy.

The time is 9:50 A.M. and Jane is finishing the 30-page paper for school 
that is due at 10:00 A.M. She looks over the assignment one more time, and 
suddenly she realizes that:

• The text must use Arial font instead of Times New Roman.

• The headings must be dark blue and indented.

• The title must appear at the top-right of every page except the first.

• Even numbered pages must have a wider right margin, and odd 
numbered pages must have a wider left margin.

Thankfully, Jane used OpenOffice.org and styles. She makes all the changes 
in two minutes and hands in the paper on time.
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Types of styles
OpenOffice.org Writer has five types of styles:

• Paragraph styles affect entire paragraphs represented with those styles.

• Character styles affect a block of text inside a paragraph.

• Page styles affect page formatting (page size, margin, and the like).

• Frame styles affect frames and graphics.

• List styles affect outlines, numbered lists, and bulleted lists.

The first three styles are the most commonly used. These and one type of list style are 
covered in this chapter. Frame styles and more complex list styles are discussed in Chapter 7 
(Working with Styles).

Styles and Formatting window
These styles are available through a floating or dockable window called Styles and 
Formatting, shown in Figure 163. (Press F11 to see it.) The use of the Styles and Formatting 
window is discussed in the next section.

Figure 163. Styles and Formatting window and the types of styles

The default form for Styles and Formatting is a floating window. You can drag it around the 
screen using the mouse, or you can dock it to the left or right side of the main Writer window.
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Using paragraph styles

First steps
The concept of styles and how to use the Styles and Formatting window is best explained 
through an example.

1) Create a new document (choose File > New > Text Document or press Control+N).

2) Type the words First heading in the new document, but do not press Enter so that the 
cursor remains in the same line where you entered the first-level subhead—First 
heading.

3) Click the Styles and Formatting icon  located on the Formatting Bar or press the 
F11 key. This opens the Styles and Formatting window (Figure 164).

4) Make sure the window is showing the Paragraph Styles section (click on the top-left 
icon of the Styles and Formatting window ).

Figure 164. Click on the Styles and Formatting icon  to bring up the window.

Double-click the Heading 1 entry of Styles and Formatting. This will do two things:

• Give the line (actually, its entire paragraph) you typed the Heading 1 style.

• Add Heading 1 to the Apply Style list and display it as the current style.

The Apply Style list is illustrated in Figure 165. It provides direct access to the styles that are 
currently in use in the document.
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Using the Apply Style list
The Apply Style drop-down list, located next to the Styles and Formatting icon on the 
Formatting toolbar, shows the paragraph styles that are currently in use in the document. You 
can select styles from this list, just as you can from the Styles and Formatting window. 

As an exercise, press Enter in order to start a new paragraph, type some text, and select 
Heading 1 in the Apply Styles list. The text acquires the properties of the Heading 1 style. If 
the paragraph style you want is not in the Apply Style list, select More in order to bring up 
the Styles and Formatting window.

Figure 165. Applying paragraph styles

Modifying paragraph styles
The power of styles lies in the ability to modify them to suit your needs.

For the next example, we will need three lines of text with three OOo-supplied paragraph 
styles: Heading 1, Heading 2, and Heading 3. These paragraph styles could be used in 
formatting headings in the framework for a document that will be “fleshed out” afterwards.

Open a new text document for this exercise and type Title on the first line, press the 
Paragraph Styles icon on the Styles and Formatting window, and double-click Heading 1 in 
the drop-down list. Repeat this procedure for the other entries of Figure 166, using the proper 
paragraph style for each. The Heading 1 style should be applied to the “paragraph” 
containing the word “Title”, Heading 2 to “Subtitle 1”, and so on.

Your document should resemble Figure 166.
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Note Heading 1 uses a bold font typeface (with a 115% percentage size), Heading 2 uses 
a 14pt bold italic typeface, and Heading 3 uses a 14pt bold typeface.

Figure 166. Headings 1–3 with default  
styles

So far, you have introduced some basic formatting to your document, using the predefined 
default paragraph styles. Suppose you decide to add the following formatting changes to 
these styles:

• Heading 1 should be centred

• Heading 3 should be indented.

Centre Heading 1

On the Styles and Formatting window, select the Paragraph Styles icon  (if it is not 
already chosen), right-click on Heading 1, and choose Modify (as shown in Figure 167).

Figure 167. Modifying a style

After the Paragraph Style window opens, choose the Alignment tab, select Center (as shown 
in Figure 168), and click OK.

Now, every paragraph marked as Heading 1 will be centered (as shown in Figure 169). If you 
make another Heading 1 entry, it will be centered as well.
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Figure 168. Center Heading 1

Figure 169. The text Title which is formatted as Heading 1 style centred

Indent Heading 3

On the Styles and Formatting window, right-click on the Heading 3 paragraph style and 
choose Modify (as before). After the Paragraph Style window opens, follow the steps below:

1) Click the Indents & Spacing tab.

2) Under the Indent section, set the indentation before the text to 0.60 in, as shown in 
Figure 170. Your display might be different, depending upon what  measurement unit 
was set in the options (Tools > OOo Writer > General > Settings). The inch is the 
basic typographic unit used in this chapter; writers and editors would probably use the 
more precise pica or point units.

Figure 170. Set indentation

The result should resemble Figure 171.
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Figure 171. The text formatted as Heading 3 style is now indented.

Linked styles
Some OOo styles are linked together. This means that a change in one style affects every 
style linked to to it. For example, every Heading style (such as Heading 1, Heading 2) is 
linked with a style called Heading. This relationship is illustrated in Figure 172.

Figure 172. Linked styles

As an example, suppose you want to change the font of not only Heading 1 or Heading 2, but 
all headings. The easiest way to do that is to take advantage of this linking. Open the Styles 
and Formatting window (press F11) and select Heading (see Figure 173).

Figure 173. Select Heading 
style.

Open the Paragraph Style dialog box for the Heading style (right-click > Modify) and select 
the Font tab. Select a font and click OK (see Figure 174).
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Figure 174. Select font for Heading style.

Now, the fonts of all the heading styles (Heading 1 through Heading 10) have been changed 
in a single operation. Your document should now resemble Figure 175.

Figure 175. All Heading styles now have the new font.

Creating custom styles

You have seen that the Styles and Formatting window provides several predefined styles, 
such as Heading 1 and Text body. But what if you need something different, like a poem 
style, that is not in Styles and Formatting? With OOo, you can make your own styles to suit 
your needs.

In this section, we will create a Poem paragraph style, and a Poem Header paragraph style, 
with the following properties:

• Poem: Centred, with font-size 10pt.

• PoemHeading: Centred, bold, with font-size 12pt.

In addition, a PoemHeading style is to be followed by a Poem style. In other words, when 
you press Enter, the next paragraph style in the document changes to Poem.

Note The keen reader may have noticed this behavior already. After you type a heading 
and press Enter, the next style switches to Text body.
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Creating the Poem paragraph style
Our next example uses the Poem style. We use the Default style as a starting point.

1) Click the Styles and Formatting icon  or press F11.

2) Click the Paragraph Styles icon .

3) Right-click Default and choose New (see Figure 176).

Figure 176. Create a new style.

This opens the Paragraph Style dialog box, with the Organizer tab selected. To create a 
custom style, you have to understand and configure the top three entries.

Style fields Description

Name This is the name of the style itself, like Heading 1 or Text body.

Set (type in the text box) the name to Poem.

Next Style This is the default style that follows the Poem style. When you press 
Enter while typing text in the Poem style, this style is used.

Set this value to Poem. When you press Enter, the text will remain in the 
Poem style.

Linked with If the Poem style is linked with another, say Default, then any change in 
Default will affect Poem, just as you saw with Heading in the previous 
section.

For our example, this is not the behaviour we want. Set this entry to 
– None –. This means that Poem is not linked with any other style.

After making these changes, your screen should look like Figure 177.
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Figure 177. Initial configuration for the Poem style. Set the first three entries as shown.

The next step is to configure the alignment and font properties of this style.

• On the Alignment page, select the Centre option.

• On the Font page, select 12pt font-size.

Click OK to save the new Poem style.

Congratulations! You just made your very own style.

Creating the PoemHeading style
Create a new PoemHeading style. Use the same procedure as before, with these changes:

• Next Style: Select Poem, not PoemHeading.

• Linked with: Heading.

The window should look like Figure 178.

Figure 178. Settings for the PoemHeading style

Now set the settings of the new style:

1) On the Alignment page, select Centre

2) On the Font page, choose Bold and size 14pt.

Click OK to save the new PoemHeading style.
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Sample poem
It is a good idea to test out your new styles and see if you are happy with them. Your poem 
should look similar to the one in Figure 179.

Figure 179. Sample poem

Changing the formatting of your styles
One of the main advantages of styles is that they allow the document formatting to be 
changed after the content has been written. For example, suppose you have written a 100-
page book of poetry. Then you decide you don’t like the way the poems look after all. Or, 
perhaps, your publisher doesn’t like it.

To learn about reconfiguring styles, we will make the following changes:

• The Poem style will be indented instead of centred

• Add a PoemAuthor paragraph style based on Poem, except it is bold and has more 
indentation.

Indent Poem and PoemHeading

First, set the Poem style to left alignment:

1) In the Styles and Formatting window, select Poem and right-click and select Modify.

2) On the Alignment page, select Left.

Set the indentation:

1) Click the Indents & Spacing tab.

2) Under Indent, set the indentation before the text to 2in.

Done! Click OK, and you should see the text change. Do the same thing for PoemHeading.
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Create PoemAuthor style

The purpose of this style is to set apart the name of the author from the rest of the poem. You 
already know how to create a new style. Follow the same procedure as before (starting from 
the Poem style). Use the following configuration:

• Name: PoemAuthor

• Next style: Default

• Linked with: Poem

Now, configure PoemAuthor just as you configured Poem, with the following changes:

• Font: Bold

• On the Indents & Spacing page:

• Under Indent, set the Before text field to 3.2 in.

• Under Spacing, set the spacing above the paragraph to 0.2 in. This adds extra space 
between the poem and the name of the author.

Figure 180 shows how the Indents & Spacing page should look at this point. Click OK to 
save the style. Now set the author of the poem (in the example, Anon) to the newly created 
PoemAuthor style, as described in “First steps” on page 158.

Figure 180. Indentation and spacing for the PoemAuthor style.

Final result

After all these changes, the poem should look similar to Figure 181.
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Figure 181. Final result, using three custom styles

Using page styles

Page styles are to pages what paragraph styles are to paragraphs. Just as paragraph styles can 
define paragraph properties (font size, colour, and others), page styles can define page 
properties (margins, page size, header and footers, and others). However, unlike paragraphs, 
which can have directly applied properties, pages only have a page style and no directly 
applied properties.

Real life situation

Christian is a lawyer from California, USA. For his letters, the first page 
has his letterhead, and subsequent pages only identify the recipient, the 
date, and the page number. Christian does this using page styles. He 
also uses page styles to comply with the spacing requirements (such as 
margins) for legal briefs in California State courts.

What page style does a page have?
The page style for the current page is displayed on the status bar (Figure 182).

Figure 182. The current page style is displayed on the status bar.
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Modifying a page style

Open the Styles and Formatting window and click the Page Styles button .

Figure 183. Selecting page styles.

Right-click the currently active page style (Figure 183) and select Modify. The resulting 
window is shown in Figure 184.

Figure 184. Page Style properties.

Mirrored margins for facing pages
You can set up “mirrored” margins for facing pages within one page style. More complex 
differences between right and left pages may require separate page styles; these are discussed 
in Chapter 4 (Formatting Pages).

To set up “mirrored” facing pages, go to the Page page of the Page Style dialog box (Figure
185). Choose Mirrored for Page layout in the Layout settings section and set the inner and 
outer margins in the Margins section.
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Figure 185. Setting up mirrored pages

The Next Style property
You have seen the Next Style property in the context of paragraph styles. This property is 
especially powerful in page styles.

Setting up a title page

Consider a common scenario: you want the document to have a title page that is different 
from the rest of the document:

• It should not have a header or page number.

• The left and right margins should be the same.

For the title page, we can use the First Page page style that comes with OOo, and for the rest 
of the document, we can use the Default page style.

Figure 186 shows the required flow of page styles. On the Organizer page of the Default 
page style, leave the Next Style property set to Default. On the Organizer page of the First  
Page style, make sure that the Next Style property is set to Default.

See “Inserting a header” on page 173 for instructions on setting up the page header.
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Figure 186. Flow of page styles

Manual page breaks
The Next Style property is enough for projects with straightforward pagination requirements 
(for example, reports, letterheads, and small books). But more complex projects require more 
control over page styles. Manual page breaks provide this control.

The idea is simple: you break a sequence of page styles and start a new sequence. To insert a 
page break, choose Insert > Manual Break and choose Page break. This section illustrates 
two scenarios where page breaks are useful.

Example: Chapters

You are writing a book that is divided into chapters. Each chapter starts with a page style 
called New Chapter. The following pages use the Default page style. At the end of the 
chapter, we return to New Chapter for the next chapter.

OOo doesn’t have a New Chapter style, so you must create a custom style (see page 163). 
Suppose that you already have the page styles with the following properties:

Page style Next Style

New Chapter Default

Default Default

This can be seen in the flowchart in Figure 186, but where the New Chapter style replaces the 
First Page style.

At some point, you will want to start a new chapter. Follow these steps:

1) Put the cursor at the end of the chapter, on a blank line of its own.

2) Choose Insert > Manual Break. The Insert Break dialog box (Figure 187) appears.

3) Under Type, choose Page break and under Style, select New Chapter.
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Figure 187. Choose Page break and select the New Chapter page style.

Figure 188 illustrates the flow of page styles when using page breaks.

Figure 188. Page style flow using page breaks

Example: Inserting a page with special formatting

Sometimes you may need to insert a page with special formatting. For example, a landscape 
page or a page with more columns. This can also be done with page breaks. Suppose that the 
current page has the Default page style.

1) Choose Insert > Manual Break.

2) Select the page style (say, Special Page, which was previously created) in the Insert 
Break dialog box.

3) Fill in the contents for this page. Then insert another page break.

4) Then select Default again. The pagination continues on as normal, except that one 
page has been replaced by a different page style.

This concept is illustrated in Figure 189.

Figure 189. Inserting a page with special formatting

172 Chapter 6  Introduction to Styles



Page numbering

Page numbering

Many people first encounter page styles when they want to number pages. OOo has a 
powerful system for numbering pages.

Preliminaries: fields
OOo uses a feature called fields to manage page numbers. To insert a page number field, 
position the cursor where you want to insert the number and choose Insert > Fields > Page 
Number. The page number appears with a grey background.

Note The grey background is simply there to denote a field. This background is not 
printed. Choose View > Field Shadings (or press Ctrl+F8) to toggle this feature on 
or off.

If you have seen lists in OOo, you might have noticed this grey background; OOo lists use 
fields. The page number field always displays the page number for the current page. If you 
see the words “Page number” instead of a number, press Ctrl+F9. This shortcut key toggles 
OOo between displaying the field’s contents (what the field is used for) and the field’s 
results (what the field creates).

Note For a full introduction to fields, see Chapter 14 (Working with Fields).

Inserting a header
What’s so special about headers? The same text in the header appears on all pages with that 
page style. (You can experience this yourself by entering some text into the header.) This 
property of headers (or footers), along with fields, forms the basis of OOo page numbering.

In OOo, headers are specified by page styles.

1) Open the Page Style dialog box for the desired page style (right-click > Modify).

2) Select the Header tab.

3) Under Header, check Header on and click OK (see Figure 190).

Figure 190. Turn on page header.
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At this point you should see the header on the current page. In Figure 191, the header area is 
identified, purely for illustrative purposes. It would normally be empty immediately after 
being turned on, until you insert your own header text and formatting.

Figure 191. A page with a page header

Tip You can also add a header through the Insert menu: Insert > Header > [page style]. 
Likewise, for footers: Insert > Footer > [page style].

Caution The Insert menu can also be used for deleting a pre-existing header or footer for a 
page style. If that page style has a check mark in front of it, pointing to it will open 
an OOo dialog box warning about this and asking whether you want to delete the 
header or footer for that particular page style.

Simple page numbering
The simplest case is to have the page number at the top of every page and nothing more. To 
do this, put the cursor on the header and select Insert > Fields > Page Number (Figure 192).

Figure 192. Page number inserted in the header

Now the correct page number appears on every page.
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More complex variations
There are a lot of interesting variations that you can apply without further knowledge of page 
styles. Here are some suggestions:

• Right-align the header to make the page number appear on the top-right:

• Place the cursor in the header.

• Click the Align Right icon (or right-click anywhere in the header and select 
Alignment > Right).

• Add (type) the word page so the header reads page 1, page 2, and so on. This also 
requires using the Page Number field, discussed earlier (page 173).

• Add the document title so the header reads, for example: Peter’s favourite poems, left 
justified, and page x with right justification, where x is the value of the Page Number 
field. Consider using a tab to separate the title from the page number or, better still, 
use a table to achieve separation of header elements.

• OOo also has a Page Count field (Insert > Fields > Page Count). Using it, you could, 
for example, have a header that reads page 1 of 4.

These variations are all illustrated in Figure 193.

Many more variations are possible. For example, you can use a footer instead of a header to 
make the page number appear at the bottom of the page. You can also include the chapter 
number with the page number: see “Numbering pages by chapter” in Chapter 4 (Formatting 
Pages).

Figure 193. Variations on the simple page numbering method

Example: Restart page numbering—a preface

Some times you want to reset the page number back to 1. A typical example is the preface for 
a book. A standard preface has the following properties:

• Page numbers are displayed in Roman numerals (i, ii, iii, iv, …).

• After the preface ends, the document starts on a Default page.

• The page number resets to 1, and the number format becomes Arabic (1, 2, 3, 4, …).
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Resetting the page number requires page breaks.

First, let’s get the preliminary work done for the Preface style:

1) Create a new page style and name it Preface.

2) Set its Next Style to Preface because a preface could span multiple pages.

3) Add a header to Preface and insert the Page Number field. Make the page numbers 
display as lower-case Roman numerals (i, ii, iii, iv, …):

a) Open the page style window for Preface (if not already open) and click the Header 
tab. Check Header on under Header.

b) Click the Page tab. Under Layout settings, in the Format drop-down list, set the 
format to i, ii, iii, …. (See the bottom right of Figure 194.) Click OK to close the 
dialog box.

Figure 194. Set page number format to Roman numerals.

After the preface is written, we are ready to restart the page numbering in the main body of 
the document to Arabic numerals. Follow these steps:

1) Make an empty paragraph at the very end of the preface.

2) Put the cursor on the blank line.

3) Choose Insert > Manual Break.

4) Select Page break and choose the Default style.

5) Select the Change page number check box and set the new value to 1. Click OK to 
close the dialog box.

These settings are shown in Figure 195.
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Figure 195. Set the new page number to 1 and 
the page style to Default.

Note You cannot assign an odd page number to a left page or an even page number to a 
right page. OOo strongly adheres to the convention that odd page numbers go on 
right-hand pages and even page numbers on left-hand pages.

This change is also reflected on the status bar. The Page section of the status bar now 
includes the entry from the page number field (1), the absolute page number relative to the 
document’s beginning (3) and the document’s total page count (5) (Figure 196).

Figure 196. Page number in the status bar

Example: Different headers on right and left pages

When you insert a header on a page style set up for mirrored pages or right-and-left pages, 
you can have the contents of the header be the same on all pages or be different on the right 
and left pages.

To allow different content in headers, clear the Same content left/right check box in the 
Header area on the Header page of the Page Style dialog box (Figure 197).

Figure 197. Different header content
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Now, you can put the page number on the left-hand edge of the left pages and on the right-
hand edge of the right pages, put the document title on the right-hand page only, or make 
other changes. Figure 198 shows an example.

Figure 198. Different content on left and right pages

Using character styles

Character styles are a complement to paragraph styles. Like paragraph styles, they define text 
properties (font, weight, size), but they usually are applied to blocks of text smaller than a 
paragraph. For example, you can use the Emphasis character style to emphasize a word. A 
couple of character styles used in this document include:

• Key strokes use the custom OOoKeyStroke style. For example:

to set OOo to full screen, press Control+Shift+J.

• Menu paths use the custom OOoMenuPath style. For example:

to turn field shadings on or off, choose View > Field Shadings.

Why use character styles?
Beginning OOo users often wonder, “Why use character styles?” or “How is this different  
from pressing the bold icon to change the font typeface?” The following real-life event 
illustrates the difference.

Real-life situation

Jean is a technical writer from Australia. She learned the value of 
character styles after her publisher told her to unbold menu paths in her 
200-page book. Jean had not used character styles. She had to edit all 
200 pages by hand, with some help from Find & Replace.

This was the last time Jean failed to used character styles.

Character styles do not have as many options as paragraph styles or page styles. Their 
benefits are of a different nature:

• Formatting changes
As Jean’s story illustrates, the ability to make formatting changes throughout a 
document can be important. Character styles provide this.

• Consistency
Character styles help ensure that typesetting guidelines are applied consistently.
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• Focus on content
“Was I supposed to bold keystrokes? How about menus?”
A writer shouldn’t have to remember the answers to these questions. Typesetting 
details distract you from the real content of your work. A properly named custom 
character style (such as OOoKeyStroke or OOoMenuPath) will remove this burden 
from you.

Other ways of using character styles are described elsewhere in the Writer Guide. These uses 
include making chapter numbers, page numbers, or list numbers larger than the surrounding 
text and formatting hyperlinks. When inserting words in different language or words you do 
not want the spell checker to detect as mistakes (for example programming code), character 
styles result quite useful since it is possible to define in the character style properties the 
language to be applied.

Applying character styles
Open the Styles and Formatting window (press F11) and click the second button in the top 
bar . The list of available character styles is displayed. To apply a character style, follow 
these steps:

1) Select the block of text where you wish to apply the style.

2) Double-click the appropriate character style in the Styles and Formatting window.

Some examples include:

This example uses the OOo-supplied Strong Emphasis character style.

Definition: A statement describing the meaning of a word or phrase.

Note One difference between character styles and paragraph styles is the need for 
selecting text (highlighting). Character styles require you to select the text you want 
to apply them to; paragraph styles do not.

Unset/undo character styles

Sometimes, you will want to remove the formatting from a block of text. You must resist the 
temptation to do this manually. This will only cause trouble down the road. There are three 
easy ways to remove character formatting:

• Select the block of text and right-click and choose Default Formatting.

• If you have the Styles and Formatting window open, select the block of text and 
double-click the Default character style.

• Select the block of text, then press Ctrl+Shift+Spacebar.

Note The first method also works for removing manual formatting.
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Migrating to character styles

For people accustomed to formatting text manually, character styles can take some getting 
used to. Here are some suggestions for making the transition easier:

• Never mix character styles and manual formatting. Manual formatting supersedes 
character styles. If you combine them, you may end up wasting hours in frustration 
trying to figure out why your character styles don’t work.

• Right-clicking and choosing Default Formatting removes any text formatting (both 
manual and character styles).

• Realize that clicking the Bold icon in the toolbar is not easier than double-clicking on 
a character style that is preset for bolding the font typeface.

• Leave the Styles and Formatting window open to make character styles easy to access.

Using list (numbering) styles

List styles (also called numbering styles) work with paragraph styles. They define 
indentation, alignment, and the numbering or bullet characters used for numbered or bulleted 
lists. You can define many list styles to use for different purposes, from simple bulleted lists 
to complex multi-level lists.

List styles offer so many choices that they can seem more complex than they really are, and 
new users may easily be confused about where to begin and how to proceed. This section 
introduces one very simple use of a numbered list style. A more complex example is given in 
“Defining the appearance of nested lists” in Chapter 7 (Working with Styles).

Why use list styles?
As with other styles, the main reason is consistency and to speed up your work. Although you 
can create simple lists quickly by clicking the Numbering On/Off or Bullets On/Off icons on 
the Formatting toolbar, and use the icons on the Bullets and Numbering toolbar to create 
quite complex nested lists (as described in Chapter 3), the appearance of the resulting lists 
may not be what you want—and you might want to have more than one style of list. You can 
use the Bullets and Numbering choice on the Format menu to manually format the 
appearance of some or all of the lists, but what if you later need to change their appearance? 

Creating a simple list style
In this example we will create a numbered list style that can be used to number the songs on a 
CD. The numbers are right-aligned and some space is left between the number and the title of 
the track. The final result is illustrated in Figure 199.

The process has two steps:

Step 1: Create the numbered list style.

Step 2. Apply the list style to the paragraphs you want numbered.
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Figure 199: A numbered list of CD tracks 
highlighting the various elements

Step 1: Create the numbered list style.

Before you begin, press F11 to open the Styles and Formatting window, if it is not already 
open.

1) Select the List Styles icon  at the top of the Styles and Formatting window (fifth 
from the left).

2) Right-click in the blank area below the list of styles and choose New; see Figure 200. 
(You could modify one of the existing styles, but it’s easier to remember which style is 
for what special purpose if you create a new one.) The Numbering Style dialog box 
(Figure 201) is displayed. For the CD Tracks list style we need to customize fields in 
the Organizer, the Options and the Position pages.

Note Although the icon at the top of the Styles and Formatting window is labelled List 
Styles, the dialog that opens is labelled Numbering Style.
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Figure 200: Creating a new list  
style

3) The Organizer page of the Numbering Style dialog serves the same purpose as in the 
Paragraph style dialog but has fewer options. Give the new list style a name, for 
example CD Tracks.

4) On the Options page (shown in Figure 201) you can set up parameters for each 
individual level of the structure or for all the levels at once. In this example we need 
only one level (1). The right-hand side of the dialog box shows a preview of what the 
numbered list will look like.

 a) In the Level box, choose 1.

 b) In the Numbering list, choose 1,2,3.

 c) Leave the Before and After boxes blank, or delete anything that is in them.

 d) Leave Character Style as None.

 e) Make sure Start at is 1.

 f) Show sublevels should be greyed out. Do not select the checkbox for Consecutive 
numbering.
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Figure 201: The Options dialog settings for the CD Tracks list style

Tips The numbered list will adopt settings of the underlying paragraph style. If you want 
to use a special font, size, or colour for the numbers, you can create a character 
style and apply it on the Options page.

If you want the word Track to appear before the number, just add it to the Before 
field in the Options dialog. Do not forget to add a space character to separate the 
word from the number.

5) The Position page (Figure 202) provides the following fields:

• Indent: Determines the indentation of the number or bullet area. The indentation is 
measured from the left margin of the paragraph linked to the numbering style. In 
other words, if the paragraph style already has an indentation, when the list style is 
applied the indentations are summed together. When a level different from Level 1 
is selected, if the Relative checkbox is selected, the indentation is applied relative 
to the previous level.

• Spacing to text: This value determines how much space will be used by the 
numbering symbol. OOo will reserve this space even if only part of it is used.

• Minimum spacing numbering <-> text: This is the spacing between the right edge 
of the numbering symbol and the text. If the spacing to text is not sufficient, OOo 
will expand the numbering area. Setting the minimum spacing between numbering 
and text is very useful when right-aligning the numbering or when there is a long 
text before or after the numbering.
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• Numbering alignment: Select in the drop-down menu how the numbering 
(including any text before or after) should be aligned: left, centred, or right.

Figure 202: Setting the alignment and indentation for the CD Tracks list style

As we are creating a simple list, all we need to do in this page is:

 a) In the Level box, choose 1.

 b) For Indent, choose 1.0cm. (You may need to adjust this later.)

 c) For Spacing to text, choose 1.0cm.

 d) For Minimum space..., choose 0.5cm.

 e) For Numbering alignment, choose Right.

6) Do nothing on the other pages of this dialog box.

7) Click OK to save this style.

Step 2. Apply the list style to the paragraphs you want numbered.

Now that the list style is available, it can be quickly applied to any list in the document:

• If starting a new list, before pressing Enter to start a new line double-click on the 
desired list style name in the Styles and Formatting window.

• If you already have a list, select it and then double-click on the desired list style name 
in the Styles and Formatting window. 
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Notes Remember that applying a list style does not affect the characteristics of the 
underlying paragraph, therefore you may want to check if you are satisfied with the 
paragraph style before applying the list style.

If you have previously applied manual formatting to these paragraphs, first select 
all the paragraphs, right-click, and choose Default Formatting; then apply the list 
style you have defined.

Restarting numbering (if required)

If you have more than one list in a chapter, the second and subsequent lists may continue 
numbering from the previous list. To restart at 1, place the cursor anywhere in the paragraph 
you want numbered 1, right-click and choose Restart numbering.

To stop using numbering, click the Numbering On/Off icon on the Standard toolbar.
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Introduction

A style is a set of formats that you can apply to selected pages, text, frames, and other 
elements in your document to quickly change their appearance. When you apply a style, you 
apply a whole group of formats at the same time.

OpenOffice.org Writer supports the following types of styles:

• Page styles include margins, headers and footers, borders, and backgrounds.

• Paragraph styles control all aspects of a paragraph’s appearance, such as text 
alignment, tab stops, line spacing, borders, and character formatting.

• Character styles affect properties of the selected text within a paragraph, such as the 
font and size of text and bold and italic formats.

• Frame styles are used to format graphic and text frames, including borders, 
backgrounds, columns, and how text wraps around the frame.

• List styles apply similar alignment, numbering or bullet characters, and fonts to 
numbered or bulleted lists.

OpenOffice.org (OOo) comes with many predefined styles. You can use the styles as 
provided, modify them, or create new styles, as described in this chapter.

The importance of styles in OpenOffice.org is covered in Chapter 6 (Introduction to Styles). 
That chapter also introduces three of the five types of styles in Writer (page, paragraph, and 
character), and it describes how and why to use them in Writer documents.

This chapter describes the general use of styles in Writer and provides more examples of 
using all five types of styles.

Applying styles

In order to use a style in OpenOffice.org , you need to apply it. OOo provides several ways to 
apply styles:

• Using the Styles and Formatting window.

• Using Fill Format mode.

• Using the Apply Style list.

• Assigning styles to shortcut keys.

• Using AutoFormat—see Chapter 3 (Working with Text).

• Using conditional styles—see page 216.
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Using the Styles and Formatting window
1) To open the Styles and Formatting window (Figure 203), do any one of the following:

• Click on the  icon located at the left-hand end of the object bar.

• Choose Format > Styles and Formatting.

•  Press F11.

Tip You can move the Styles and Formatting window to a convenient position on the 
screen or dock it to an edge.

2) Click on one of the icons at the top left of the Styles and Formatting window to 
display a list of styles in a particular category, such as paragraph or character.

3) To apply a character style to existing text, select the text and then double-click on the 
name of the style in the Character Styles list. To apply any other style, put the cursor 
in the paragraph, frame, or page you want to modify and double-click on the name of 
the style. You can select more than one paragraph or frame and apply the same style to 
all of them at the same time.

Figure 203: Styles and Formatting window for Writer

Tip At the bottom of the Styles and Formatting window is a drop-down list. In Figure
203 it shows Automatic, meaning the list shows only the styles that are applied 
automatically by OOo. You can choose to show all styles or other groups, such as 
custom styles. Starting with OOo2.3, your selection here is saved when you close 
OOo (previously this window always opened with Automatic showing).
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Using Fill Format mode
Use Fill Format to apply a style to many different areas quickly without having to go back to 
the Styles and Formatting window and double-click every time. This method is useful for 
formatting many scattered paragraphs, words, or other items with the same style, and it may 
be easier to use than making multiple selections first and then applying a style to all of them.

1) Open the Styles and Formatting window (Figure 203) and select a style.

2) Click the Fill Format Mode icon 

3) To apply a paragraph, page, or frame style, hover the mouse over the paragraph, page, 
or frame and click. To apply a character style, hold down the mouse button while 
selecting the characters, Clicking on a word applies the character style for that word. 
Repeat step 3 until you made all the changes for that style.

4) To quit the Fill Format mode, click the icon again or press the Esc key.

Caution When this mode is active, a right-click anywhere in the document undoes the last 
Fill Format action. Be careful not to accidentally right-click and mistakenly undo 
actions you want to keep.

Using the Apply Style list
When a style is in use in a document, the style name appears on the Apply Style list (Figure
204) at the left end of the formatting bar, to the right of the Styles and Formatting icon.

To apply a style from this list, click on the desired style or use the up or down arrow keys to 
move through the list, then press Enter to apply the highlighted style.

Tip Select More... at the bottom of the list to open the Styles and Formatting window.

Figure 204: The Apply Style 
list
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Assigning styles to shortcut keys
You can configure shortcut keys to quickly assign styles in your document. Some shortcuts 
are predefined, such as Ctrl+1 for the Heading 1 paragraph style and Ctrl+2 for Heading 2. 
You can modify these shortcuts and create your own.

1) Click Tools > Customize > Keyboard.

2) On the Keyboard page of the Customize dialog box (Figure 205), choose the shortcut 
keys you want to assign a style to. In this example, we have chosen Ctrl+9.

Figure 205. Defining keyboard shortcuts for applying styles

3) In the Functions section at the bottom of the dialog box, scroll down in the Category 
list to Styles. Click the + sign to expand the list of styles.

4) Choose the category of the style. The Function list will display the names of the 
available styles for the selected category. The example in Figure 205 shows some of 
OOo’s predefined paragraph styles.

Chapter 7  Working with Styles 191



Applying styles

5) To assign Ctrl+9 to the Text Body paragraph style, select Text Body in the Function 
list, and then click Modify. Ctrl+9 now appears in the Keys list.

6) When you are done assigning shortcuts, click OK to close the dialog box.

Currently, the only way to use Alt key or multi-key combinations is through a macro. See 
AltKeyHandler.sxw and KeyHandler.sxw, available from 
http://homepages.paradise.net.nz/hillview/OOo/.

Modifying styles

OpenOffice.org provides several ways to modify styles:

• Change a style using the Style dialog box

• Update a style from a selection

• Use AutoUpdate (paragraph and frame styles only)

• Load or copy styles from another document or template

You can change both predefined and custom (user-created) styles.

Tip Any changes made to a style are effective only in the current document. To change 
styles in more than one document, change the template—see Chapter 10 (Working 
with Templates)—or copy the styles into the other documents as described in 
“Copying and moving styles” on page 196.

Changing a style using the Style dialog box
To change an existing style using the Style dialog box, right-click on the style in the Styles 
and Formatting window and select Modify from the pop-up menu.

The dialog box displayed depends on the type of style selected. Figure 206 shows an example 
of the dialog box for a paragraph style. Each style’s dialog box has several tabs. Some 
properties on these dialog boxes are described later in this chapter.
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Figure 206: Example of Paragraph Style dialog box

Updating a style from a selection
Let’s use paragraph styles as an example.

1) Open the Styles and Formatting window.

2) Create a new paragraph (or modify an existing paragraph) and edit all the properties 
you want to go into the style (such as indentation, font properties, alignment, among 
others).

Caution Make sure that there are unique properties in this paragraph. For example, if 
there are two different font sizes or font styles, that particular property will 
remain the same as before.

3) Select the paragraph by clicking anywhere in the paragraph.

4) In the Styles and Formatting window, select the style you want to update (single-click, 
not double-click) and then click on the New Style from Selection icon and select 
Update Style (see Figure 207).
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Figure 207. Updating a style from a selection

The procedure to update another type of style (like character, page, or frame styles) is the 
same. Just select the item in question, select the style you want to update, and choose Update 
Style.

Using AutoUpdate (paragraph and frame styles only)
If the AutoUpdate checkbox is selected on the Organizer page of the Paragraph Style or 
Frame Style dialog box, applying direct formatting to a paragraph or frame using this style in 
your document automatically updates the style itself.

Tip If you are in the habit of manually overriding styles in your document, be sure that 
AutoUpdate is not enabled.

Updating styles from another document or template
You can update styles by copying or loading them from a template or another document. See 
“Copying and moving styles” on page 196.

Creating new (custom) styles

In addition to using the predefined styles provided by OOo, you can add new custom (user-
defined) styles. OOo provides three ways to add styles.

• Create a new style using the Style dialog box.

• Create a new style from a selection.

• Drag and drop a selection to create a new style.

Creating a new style using the Style dialog box
Open the Styles and Formatting window (Figure 203). Right-click on a style and select New. 
The style that you choose will be the basis for this new style. If you do not want too many of 
the options preset for you, choose the Default style.
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The dialog box displayed depends on the type of style selected. Figure 208 shows an example 
of a Style dialog box for a new paragraph style. The dialog boxes and choices for defining 
new styles are the same as for modifying existing styles.

Tip An exception to the above rule is conditional styles, which have a different dialog 
box. See page 216 for more information.

Linking styles

You can link a new style to an existing style. For example, suppose that the style MyStyle 
specifies a font size of 12. Then you create another style (MyStyle2) linked to MyStyle and 
specifies underlined text. If you modify MyStyle to font size 20, MyStyle2 inherits the new 
font size but still underlines the text.

Figure 208: Linking a new paragraph style to an existing style

Tip If styles are linked, changing the base style changes all the linked styles. Sometimes 
this is exactly what you want; other times it is not. It pays to plan ahead. Many 
predefined styles are already linked to other styles.

Creating a new style from a selection
You can create a new style from the formatting of an object in the current document. For 
instance, you can change the formatting of a paragraph or frame until it appears as you like, 
and then you can turn that object’s formatting into a new style. This procedure can save time, 
because you do not have to create a new style as described above and remember all of the 
formatting settings.

1) Change the formatting of the object (paragraph, frame, etc.) to your liking.

2) Open the Styles and Formatting window. From the icons at the top of the window, 
choose the type of style to create (paragraph, character, and so on).

3) In the document, select the item to save as a style.

4) In the Styles and Formatting window, click the New Style from Selection icon.
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5) In the Create Style dialog box, type a name for the new style. The list shows the names 
of existing custom styles of the selected type, if any. Click OK to save the new style.

Dragging and dropping a selection to create a style
You can drag-and-drop a text selection into the Styles and Formatting window to create a 
new style.

1) Open the Styles and Formatting window.

2) Select some text and drag it to the Styles and Formatting window.

3) In the Create Style dialog box, type a name for the new style. The list shows the names 
of existing custom styles of the selected type, if any. Click OK to save the new style.

4) If the Paragraph Styles list is showing in the Styles and Formatting window, a new 
paragraph style will be added to the list. If Character Styles are active, the character 
style will be added to the list.

Copying and moving styles

When you create a style in a document, it is available only within that document. Styles 
always stay with a document. So, for example, if you e-mail a document to another person, 
the styles go with it.

Having created a style, you may want to transfer the style to another document. You can copy 
or move styles from one template or document to another in two ways:

• Using the Template Management dialog box

• Loading styles from a template or document

Using the Template Management dialog box
To copy or move styles using the Template Management dialog:

1) Click File > Templates > Organize.

2) At the bottom of the Template Management dialog box (Figure 209), choose either 
Templates or Documents, as needed. For example, if you are copying styles between 
two documents, both entries should say Documents.

3) To load styles from a file, click the File button. When you return to this window, both 
lists show the selected file as well as all the currently open documents (Figure 210).

4) Double-click on the name of the template or document, and then double-click the 
Styles icon to show the list of individual styles.
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Figure 209: Choosing to copy styles from a document, not a template

Figure 210: Copying a style from one document to another

5) To copy a style, hold down the Control key and drag the name of the style from one 
list to the other.

Caution If you do not hold down the Control key when dragging, the style will be moved 
from one list to the other.  The style will be deleted from the list you are dragging it 
from.

6) Repeat for each style you want to copy or move. When you are finished, click Close.
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Loading styles from a template or document
You can copy styles by loading them from a template or another document. This method 
copies all styles, or groups of styles, at one time.

1) Open the document to copy styles into.

2) In the Styles and Formatting window, click on the New Style from Selection icon, and 
then on Load Styles (see Figure 207).

3) In the Load Styles dialog box (Figure 211), find and select the template to copy styles 
from. Or click on From File and select a document.

4) Select the checkboxes for the types of styles to be copied. If you select Overwrite, the 
styles being copied will replace any styles of the same names in the target document.

5) Click OK to copy the styles.

Figure 211: Loading styles from a template

Deleting styles
It is not possible to delete OOo’s predefined styles from a document or template, even if they 
are not in use. However, custom styles can be deleted.

To delete an unwanted style, right-click on it in the Styles and Formatting window and 
choose Delete. If the style is in use, the message shown in Figure 212 appears.

Figure 212. Deleting an applied style
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Caution Make sure the style is not in use before deletion. Otherwise, all objects with that 
style will return to the default style and retain their formatting as manual 
formatting. This can be very problematic in a long document.

Tip If an unwanted style is in use, use Find & Replace to replace it with a substitute 
style before deleting it.

If the style is not in use, the message shown in Figure 213 appears.

Figure 213. Deleting a style that is not in 
use

Working with paragraph styles

Chapter 6 (Introduction to Styles) covers the basics of using paragraph styles. This chapter 
looks at some advanced properties of paragraph styles and ways that you can use other 
features in OOo in conjunction with paragraph styles to do specific tasks like:

• Controlling page breaks

• Controlling tab stops

• Specifying a relative font size

• Selecting a language for a paragraph style

• Rotating the text in a paragraph style

• Kerning text (a feature that adjusts the letter spacing to make text more readable)

• Using styles in outlining

• Using conditional paragraph styles

Controlling page breaks
Writer automatically flows text from one page to the next. If you do not like the default 
settings, you can change them on the Text Flow page of the Paragraph Style dialog box.
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Automatic page or column breaks

The Options section of the Text Flow page (Figure 214) of the Paragraph Style dialog box 
provides settings to control what happens when a paragraph does not fit on the bottom of a 
page:

Do not split paragraph means that the paragraph is never split across two pages. If it does 
not fit on the bottom of one page, the entire paragraph moves to the top of the next.

Keep with next paragraph is appropriate for headings or the lead-in sentence to a list, to 
ensure that it is not the last paragraph on a page.

Orphan control and Widow control. Widows and orphans are typographic terms. An 
orphan is the first line of a paragraph printed alone at the bottom of a page or column. A 
widow is the last line of a paragraph which appears alone at the top of the next page or 
column. Use these options to allow paragraphs to split across pages or columns but require at 
least 2 or more lines to remain together at the bottom or top of a page or column. You can 
specify how many lines must remain together.

Figure 214: Options for controlling automatic page or column breaks

Required page or column breaks

You can require a paragraph to start on a new page or column and specify the style of the new 
page. A typical use is for chapter titles that you always want to start on a new page. This topic 
is covered in more detail in Chapter 4 (Formatting Pages).

On the Text Flow page of the Paragraph Style dialog box:

1) In the Breaks section, select Insert. Make sure that Type is set to Page and Position to 
Before.

2) Select With Page Style and choose the page style from the list.

3) To continue page numbering from the previous chapter, leave Page number set at 0. To 
start each chapter’s page numbering at 1, set Page number to 1.

4) Click OK.

Figure 215: Setting a paragraph style to always start on a new page
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Controlling tab stops
Using tabs to space out material on a page is not recommended (depending on what you are 
trying to accomplish, a borderless table is usually a better choice), but if you do use tabs, do 
not use the default tabs set in Tools > Options > OpenOffice.org Writer > General (Figure
216); instead, define your own tab settings, as described in this section.

Figure 216: Selecting a default tab stop interval

If you use the default tab interval and then send the document to someone else who has 
chosen a different default tab interval, tabbed material will change to use the other person’s 
tab settings. This may cause a major formatting problem, as illustrated in Figure 217.

Figure 217: Default tab settings might be different

To avoid this problem, specify all the tab settings for the paragraph, using the Tabs page of 
the Paragraph Style dialog box (Figure 218).

Here you can choose the type of tab: left, right, centered, or decimal; the character to be used 
as a decimal point; and the fill character—the characters that appear between the end of the 
text before the tab and the beginning of the text after the tab. A common use of a fill character 
is the dots between a heading and a page number in a table of contents.
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Figure 218: Specifying tab stops for a paragraph style

Specifying a relative font size
If you are creating a style based on another style, you can specify a font size relative to that 
other style—either as a percentage or as a plus or minus point value (-2pt or +5pt). Relative 
font sizes are commonly used for Web pages.

For example, the paragraph style Heading 1 is based on the paragraph style Heading. The 
font size of the paragraph style Heading is 14pt, and the font size of paragraph style Heading 
1 is specified as 115%. Thus the resultant font size of text in a paragraph formatted with 
paragraph style Heading 1 is 14pt x 115% = 16.1pt.

To specify a percentage font size, in the Paragraph Style dialog box, go to the Font tab. In the 
Size box, enter the percentage amount followed by the symbol % (see Figure 219). Similarly, 
you can enter a plus or minus sign followed by the number of points to be added or 
subtracted from the base font size.

To change from a relative font size back to an absolute font size, enter the desired font size in 
points followed by the letters “pt”.

It is also possible to use a Percentage Font size for character styles. See the note on page 203.
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Figure 219: Selecting a type size based on a percentage

Selecting a language for a paragraph style
The language you select for a document (on Tools > Options > Language Settings > 
Languages) determines the dictionary used for spell checking, thesaurus and hyphenation, 
the decimal and thousands delimiter used, and the default currency format.

Within the document, you can apply a separate language to any paragraph style. This setting 
has priority over the language of the whole document. On the Font tab of the Paragraph Style 
dialog box, languages with installed dictionaries are marked in the Language list by a small 
ABC icon (Figure 220). When you check spelling, OOo will use the correct dictionary for 
paragraphs with this style.

Figure 220: Selecting a language for a paragraph style

Note You can assign a language to selected pieces of text in a paragraph using character 
styles, also on the Font page. This assignment has priority over the paragraph style 
and document language.
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Rotating the text in a paragraph style
Two common uses for rotated paragraphs are to put portrait headers and footers on a 
landscape page and to fit headings above narrow table columns (as shown in Figure 221).

Figure 221: A table with rotated headings

Chapter 4 (Formatting Pages) describes how to create portrait headers and footers on 
landscape pages by rotating characters. You can achieve the same effect by defining a 
separate header or footer paragraph style specifically for landscape pages.

As an example, we will apply rotated table headings to a pre-existing table.

1) Create a new paragraph style. Name it Table Heading Rotated.

2) On the Position page of the Paragraph Style dialog box (Figure 222), in the Rotation /  
scaling section, select 90 degrees. Click OK to save the new style.

Figure 222: Rotating a paragraph 90 degrees

3) Select the heading row of the table and apply the new style. Any text in the cells of the 
heading row is now rotated.

4) If the headings are aligned to the top of the cells, you may want to change the 
alignment to the bottom of the cells, as shown in Figure 221. To do this, click the 
Bottom button on the Table toolbar (Figure 223).
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Figure 223: Aligning text to the bottom of cells

Kerning text
Kerning means increasing or decreasing the amount of space between pairs of letters to 
improve the overall appearance of the text. Kerning automatically adjusts the character 
spacing for specific letter combinations (see Figure 224). It is only available for certain font 
types and, for printed documents, only works if your printer supports it.

Figure 224: Kerning disabled (left) and enabled 
(right).

To turn kerning on, go to the Position page of the Paragraph Style dialog box. In the Spacing 
section, select the Pair kerning checkbox (Figure 225).

Figure 225: Turning on kerning of letters in a font

Outline numbering

OpenOffice.org provides two ways to do outline numbering. Although both methods are 
called outline numbering, they serve two quite different purposes:

• Tools > Outline Numbering is for defining the hierarchy of headings. This method 
requires a separate paragraph style for each level of the hierarchy. The paragraph 
styles specified on the Outline Numbering dialog box determine which headings 
appear in the table of contents. Despite the name, headings do not have to be 
numbered. See “Defining a hierarchy of headings” below.

• Numbering Styles are for defining the appearance of lists, both simple lists and 
outlines or nested lists—that is, numbered or bulleted paragraphs, some of which have 
numbered or bulletted sublists under them. This method requires only one paragraph 
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style. These lists can be used for a variety of purposes. See “Working with list
(numbering) styles” on page 213.

A document can use both methods. One document can have only one hierarchy of headings, 
but it can use several numbering styles (both simple and nested) for different purposes.

Defining a hierarchy of headings

Tools > Outline Numbering defines the hierarchy of headings in a document. Headings can 
be numbered or not; typically the first-level headings in a book-length document are chapter 
titles, which may be numbered, but lower-level headings are not numbered. Some heading 
styles (such as those commonly used in engineering documents) number each heading level, 
for example 1, 1.1, 1.2, 2, 2.1, and so on. When chapters or sections are added or deleted, the 
numbering is automatically changed.

Paragraph styles are the key to OOo’s outline numbering feature. The default paragraph 
styles assigned to outline levels are the heading styles supplied with OOo: Heading 1, 
Heading 2, and so on. However, you can substitute any styles you wish, including custom 
(user-defined) styles.

The headings defined using the outline numbering feature can be used for more than the table 
of contents (described in Chapter 12). For example, fields are commonly used to display 
headings in headers and footers of pages (see [insert reference]), and Writer can send the 
outline to Impress.to use as the basis for a presentation (see the Impress Guide for details).

Choosing paragraph styles for outline levels
If you are using the default heading styles for the headings in your outline, and you do not 
want to use heading numbering, you do not need to do anything on the Outline Numbering 
dialog box. The default outline numbering scheme uses the default heading styles (Heading 
1, Heading 2, and so on).

To use custom styles in place of one or more of the default heading styles:

1) Click Tools > Outline Numbering to open the Outline Numbering dialog box (Figure
226).

2) Click the number in the Level box corresponding to the heading for which you want to 
change the paragraph style.

3) In the Numbering: Paragraph Style section, choose from the drop-down list the 
paragraph style you want to assign to that heading level. For example, when setting up 
a chapter in the Writer Guide, you would click Level 1 and choose OOoHeading1 (a 
custom style defined for the OOoAuthors project) to replace Heading 1 and for Level 
2, OOoHeading2 to replace Heading 2..

206 Chapter 7  Working with Styles



Defining a hierarchy of headings

Figure 226: Choosing paragraph styles for outline levels

4) Repeat for each outline level that you want to change. Click OK when done.
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Setting up heading numbering
If you want one or more heading levels to be numbered, many choices are available; this 
example defines a scheme to create headings that look like those in Figure 227.

Figure 227: The numbering scheme to be set up.

Use the Numbering page of the Outline Numbering dialog to define the numbering scheme 
and its appearance. Figure 228 shows the default settings in the Outline Numbering dialog.

Figure 228: Default settings on the Outline Numbering dialog.

1) In the Level list, choose 1. In the Number list, choose 1, 2, 3, ... The result is shown in 
the preview box on the right (see Figure 229).
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Figure 229: Specifying numbering of Level 1 headings.

2) In the Level list, choose 2. In the Number list, choose 1, 2, 3, ... The Show sublevels 
list is now active; it should show 2 (if not, choose 2). The result is shown in Figure
230.

Figure 230: Specifying numbering of Level 2 headings.

3) In the Level list, choose 3. In the Number list, choose 1, 2, 3, ... The Show sublevels 
list should show 3 (if not, choose 3). The result is shown in Figure 231.

Figure 231: Specifying numbering of Level 3 headings.

These choices produce the layout shown in Figure 232. 
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Figure 232: Results of numbering choices for headings

Setting up the indentation of headings
Whether or not the headings are numbered, you may want to change some of their 
formatting. For example, you may want the second and third level headings to be indented 
from the margin. For numbered headings, you may also want the second line of long 
headings to line up with the first word of the heading, not the number. For these changes, use 
the Position page of the Outline Numbering dialog. Figure 233 shows the default version of 
this page.

Figure 233: Default settings on Position page of Outline Numbering dialog.

1) In the Level list, choose 2. Change the value for Indent as shown in Figure 234. You 
may want to use a different value. Notice how the preview area at the bottom of the 
dialog has changed. This change indents the entire heading but does not affect the way 
long headings wrap around; see Figure 235.
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Figure 234: Indenting Level 2 headings.

Figure 235: Result of changes to indentation of Level 2 headings.

2) To change the wrapping behavior of long headings, change the value of Space to text, 
as shown in Figure 236. The result is shown in Figure 237.

Figure 236: Changing the Space to text value to wrap long headings.
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Figure 237: Result of changing Space to text value.

3) In the Level list, choose 3. Change the value for Indent as shown in Figure 238. You 
may also wish to change the Space to text value. The final result is shown in Figure
227.

Figure 238: Indenting Level 3 headings.

Including chapter or section names in page headers
In addition to page numbers, headers and footers often include the name of the chapter or 
section. Because these names change from one chapter or section to the next, you need to use 
a field that displays information relevant to each page.

1) Click Insert > Fields > Other to open the Fields dialog box (Figure 239).

2) On the Document page, select Chapter in the Type list. The Format list now shows 
four choices.

The Chapter field uses the headings defined in the Outline Numbering dialog. The 
Layer box determines which outline level is displayed in the field. For example, Layer 
1 always displays the most recently found heading that has the paragraph style 
selected for Level 1 in the Outline Numbering dialog box, Layer 2 displays the most 
recent heading with the paragraph style selected for Level 2 in outline numbering, and 
so on.
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Figure 239: Including the chapter name in page header

Note A Chapter field in a page header always picks up the highest heading level on a 
page, even if you have specified a lower level in the Layer box. For example, if a 
page has a Heading 1 and a Heading 2 on it, then a Layer 2 Chapter name field in 
the header of that page will display the Heading 1 paragraph, not the first Heading 
2 paragraph, as intended.

In a footer, the layers work as intended.

Working with list (numbering) styles

Use a numbering (list) style to define the appearance of a list, whether a simple list or an 
outline or nested list (sometimes called multi-level numbering). An example of setting up a 
simple list is given in Chapter 6. This section describes how to define a nested list.

Note
OOo uses the terms “numbering style” and “list style” inconsistently, but they are 
the same thing. For example, the tooltip in the Styles and Formatting window says 
“List Styles”, but its style dialog box says “Numbering Style”.
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Defining the appearance of a nested list
A nested list is a numbered or bulleted list with subordinate (usually indented) numbered or 
bulleted lists. Rather than just a list of numbered items (1,2,3...), a nested list may have item 
1, then indented items numbered a,b,c or i,ii,iii or some other numbering method before the 
main number 2. With numbering styles you can achieve any combination of numbering 
formats you want.

As an example, we will use a numbering style to produce the following effect:

  I.  Level-1 list item

      A. Level-2 list item

           i. Level-3 list item

              a) Level-4 list item

You can modify a predefined style, or define a new style. This example uses one of the 
supplied styles, Numbering 1.

1) In the Styles and Formatting window, choose Numbering Styles and select a style such 
as Numbering 1. Right-click on the style and select Modify.

2) On the Numbering Style dialog box, go to the Outline page (Figure 240), where you 
will find that one style matches our requirements. Click once on that style.

Figure 240: Choosing a predefined outline-numbering style
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3) To modify the layout of the list, use the Options tab (Figures 241 and 242). Notice that 
the preview on the right shows the outline selected. In the Level box on the left, select 
1, then 2, 3, and 4 and see how the information in the Numbering and After boxes 
changes.

Use the Options page to set different punctuation; for example, a period (full stop) 
after “a” on level 4 instead of a parenthesis.

Figure 241: Checking the outline numbering for level-1 list items

Figure 242: Numbering style for level-2 list items

4) To make the indentation at each level greater or less than the default, change it on the 
Position page. Select the heading level, then make any changes in the indentation, 
spacing, or numbering alignment.

5) Repeat for each heading level as required, then click OK to save the style.

Tip With outline numbering you can define different bullet styles for the different levels 
of a bullet list. Use the Bullets tab of the Numbering Style dialog box (not shown) to 
select the basic style. Return to the Options tab to customize the bullet for each 
indent level. Here you can set bullets to any character. See the Graphics tab for 
more bullets.
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Applying the different levels of a list-numbered 
paragraph style
To apply the different levels of a list-numbered paragraph style:

1) Type the first paragraph and apply the List 1 style. Notice that the level-1 list number 
is added automatically.

2) Select View > Toolbars > Bullets and Numbering to display the Numbering toolbar 
(Figure 243).

3) Press Enter to start the next paragraph. To make it a level-2 list item, click the Demote 
one level icon on the object bar (Figure 243). The number applied to this paragraph 
has changed to a level-2 number.

4) Continue typing list items, moving each paragraph up or down levels as needed.

1 Bullets On/Off 6 Promote One Level   9 Move Up
2 Numbering On/Off     with Subpoints 10 Move Down
3 Numbering Off 7 Demote One Level 11 Move Up with Subpoints
4 Promote One Level     with Subpoints 12 Move Down with Subpoints
5 Demote One Level 8 Insert Unnumbered Entry 13 Restart Numbering

14 Bullets & Numbering dialog

Figure 243: The Bullets and Numbering toolbar

Tip One option is to enter all the list paragraphs first and apply the levels afterwards.

You can use keyboard shortcuts to move paragraphs up or down the outline levels. 
Place the cursor at the beginning of the numbered paragraph and press:

Tab Down a level
Shift+Tab Up a level

To insert a tab stop at the beginning of a numbered paragraph (that is, after the 
number but before the text), press Control+Tab.

Working with conditional paragraph styles

A conditional paragraph style is another way of formatting text differently in different parts 
of your document. In some cases, you may find it saves time to use conditional styles rather 
than switching between styles as you type.

Making a paragraph style conditional means it changes its formatting depending on where it 
is used. For example, you may want the style MyTextBody to be black by default but turn 
white when inside a frame with a blue background.
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Probably the most common use for conditional formatting is with single style outlining. 
Single-style outlining is a type of outline numbering designed with a Numbering style, rather 
than with Tools > Outline Numbering. Instead of using different styles, it changes the 
number formatting whenever you press the Tab key to create a subordinate heading.

The only trouble with single-style outlining is that all levels look the same. That is where a 
conditional paragraph style comes in handy. Assign the paragraph style to an outline 
numbering style in the Numbering page and then open the Condition page (Figure 244). 
There, you can assign the levels of the outline numbering style to other paragraph styles. 
Then, when you press the Tab key while using the paragraph style, each level of the outline 
takes on different formatting, making single-style outlining even more convenient than it is 
on its own.

Note Predefined styles (other than Text Body) such as Default, Heading 1, and Heading 2 
cannot be set to be conditional.

Caution If you want to make a style conditional, you have to do it while the style 
window still is open for the first time. After the window closes, the 
Condition tab no longer appears in the window.

Defining the conditional style
When you create a conditional style, you are saying “in this condition make this style look 
like that other style”. For example, “When typing into a footer, make this style look like the 
my_footer paragraph style; when typing into a table, make this style look like the table_text 
paragraph style”.

In addition to setting the normal (unconditional) properties of the style, you need to define 
which other style it will look like in different situations. You do this on the Condition tab.

To set up a conditional paragraph style:

1) Define a new paragraph style.

2) Select all the paragraph properties for the style. Do not click OK!

3) Click the Condition tab (Figure 244).
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Figure 244: Condition page for paragraph styles

4) Select the Conditional Style checkbox.

5) Select the first condition in the Context list (left side of the dialog box) and select the 
style you want for this condition in the right-hand list.

6) Click Apply. The name of the paragraph style appears in the middle list.

7) Repeat steps 5 and 6 for each condition you want to have linked to a different style.

8) Click OK.

When the style is selected, you will see that the formatting of your text depends on the 
context.
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Working with frame styles

Frames are often used as containers for text or graphics. To provide consistency in the 
appearance of frames used for similar purposes, it is a good idea to define styles for frames. 
For example, you might want photographs to be enclosed in a frame with a drop-shadowed 
border, line drawings in a frame with a plain border, marginal notes in a frame without a 
border but with a shaded background, and so on.

Writer provides several predefined frame styles, which you can modify as needed; and you 
can define other frame styles. The technique for defining and applying frame styles is similar 
to that for other styles.

Tip There is considerable overlap between the uses of frames and of sections for some 
page layout purposes. You may find it useful to take a look at Chapter 4 (Formatting 
Pages) for information about the use of frames and sections.

How frame styles work
When an object is added to Writer, it is automatically enclosed in a frame of a predetermined 
type. The frame sets how the object is placed on the page, as well as how it interacts with 
other elements in the document. You can edit the frame by modifying the frame style it uses 
or by using a manual override when a frame is added to the document.

Because frames and objects are used together, it sometimes is easy to forget they are separate 
elements. In some cases, such as charts, you can edit the frame and object separately, so the 
distinction is worth remembering.

Unlike other elements that use styles, frames can be defined only partly by their style because 
their use can vary so much. Several elements of frames, such as the anchor and protected 
elements, need to be defined manually for individual frames.

You can format a frame manually when you select Insert > Frame. The dialog box that 
opens contains all the settings available when frame styles are set up, as well as some only 
available when the frame is inserted. As with other styles, the most efficient way to format 
frames is in the Styles and Formatting window.

Planning the styles
If you are using a mix of graphics, you may want to define two related styles, one with a 
border line for graphics with white backgrounds and one without a border for all other 
backgrounds. You also may want to design one or more frames for text only.

Otherwise, the default frame styles (listed in Table 2) cover most users’ needs. The only 
significant addition that many users might need is one or more styles for text frames.
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Table 2. Various frame styles and their uses

Style Comments and Use

Formula The frame style used for formulas. The default includes AutoSize, which 
adjusts the size of the frame to the formula.

Frame The default frame style.

Graphics The default style for graphics. The defaults include autosizing to fit the 
graphic, no text wrap, and a thin border around the frame. These are 
reasonable defaults, except for the border. Unless the background of the 
graphic is white and the document’s background also is white, the border 
usually is unnecessary.

Labels The default style for use with File > New > Labels. It seems to be used by 
OpenOffice.org automatically and is not intended for users at all.

Marginalia A style for placing a frame beside the left margin. As the name suggests, 
the Marginalia style is intended for comments added in the margin of text. 
The style also is useful for creating sideheads—headings against the left 
margin, which often are used in technical documentation. To set up 
sideheads, create body text styles with two inches or more indentation 
from the left. Then, place the cursor at the start of a body text paragraph, 
add the frame, and apply the Marginalia style.

OLE The default style for OLE objects and floating frames. The default places 
the frame at the top and center of a body of text.

Watermark The default style for a watermark, a graphic placed as the background to a 
body of text. The default is a Through wrap, with text passing over the 
frame and anything in it. The graphic should be faint enough that text still 
is readable over top of it.

Formatting frames
You can access frame settings by selecting New or Modify in the Styles and Formatting 
window for a frame style or by selecting Insert > Frame from the menu. Once a frame is 
added to a document, you can double-click the frame to open the Frame dialog box or modify 
the style in the Styles and Formatting window.

Frame settings are available from the following tabbed pages:

• Type page: sets the size and position of the frame. One of the most useful options here 
is AutoSize, which automatically adjusts the frame to the object it contains. If the 
frame style is one used automatically, then this option should be selected.

• Options page: sets whether the contents of the frame are printed and able to be edited 
in a read-only document. The tab also sets the text direction, which is useful if you are 
using the frame for contents in a language that uses right-to-left text direction.

• Wrap page: sets how text is positioned in relation to the frame and how close text 
comes to a frame. If you want the frame contents to stand out from the paragraphs 
around it, set the wrap to None. This probably is the single most important tab for 
frames.
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• Background page: sets the background color or graphic. This tab is useful mostly for 
text frames in complex page layouts, in which a text frame has an appearance different 
from the general background of the page.

• Border page: sets the line around the frame, if any. Many beginning designers make 
the mistake of adding a border to every frame. However, when a colored background 
distinctly marks the division between the frame’s contents and the rest of the page, 
borders are unnecessary.

• Columns page: sets the number of columns used in the frame. This tab can be ignored 
unless the frame is being used for text.

• Macro page: sets a macro to use with the frame. These options are useful only in an 
on-line Writer or HTML document.

Applying frame styles
Whenever you insert an object into a document, it will automatically have a frame around it. 
Some designers like to add frame styles to introduce variation. For example, you could have 
two different frame styles for graphics: one that is centered for small graphics and another 
that is left-aligned for graphics that take up the entire width of the main frame. In such a case, 
you will need to add at least one frame style.

To apply a style to a frame:

1) Select the frame.

2) Bring up the Styles and Formatting window (for example, by pressing F11).

3) Click the Frame Styles icon (the third one from the left).

4) Double-click the frame style you want.

Tip When a frame is selected, the Apply Style list at the left of the formatting toolbar 
displays frame styles. You can use this to change the style of a frame.

Most of a frame’s design can be set in the style. However, the following options must be set 
manually:

• Anchoring: how the frame is positioned in relation to the rest of the page’s contents 
(Format > Anchor).

• Arrangement: the frame’s position in a stack of objects (Format > Arrange).

• Adding a hyperlink: so that a click on the frame opens a Web page or another 
document in an HTML file (Insert > Hyperlink).

The right-click menu also has items for anchoring and arrangement, as well as for wrap and 
alignment (Figure 245).
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Figure 245: A frame’s right-click menu has positioning 
options

Working with page styles

In Writer, page styles define the basic layout of pages, including page size, margins, headers 
and footers, borders and backgrounds, number of columns, and so on.

Writer comes with several page styles, which you can modify as you wish, and you can 
define your own. You can have one or many page styles in a single document.

Note All pages in a Writer document are based on styles. If you do not specify a page style, 
Writer uses the Default page style.

To change the layout of individual pages, either define a new page style or use one of the 
techniques (sections, frames, or tables) described in Chapter 4 (Formatting Pages).

This section describes one use of page styles. Other uses are discussed in Chapter 6 
(Introduction to Styles) and Chapter 4 (Formatting Pages).

Tip Any modifications of page styles, including the Default page style, apply only to the 
document you are working on. If you want the changes to be the default for all 
documents, you need to put the changes into a template and make that template the 
default template. See Chapter 10 (Working with Templates) for details.

Setting up a book chapter sequence of pages
Book chapters typically start on a right-hand page, with the first page of the chapter having a 
different layout from the rest of the pages. The other pages in the chapter are “mirrored” for 
double-sided printing. For example, page numbers in the header or footer may be positioned 
on the outside edge of pages and a wider margin (allowing for binding) may be placed on the 
inside edge.

Table 3 shows the properties of two page styles (Right Page and Default) set up for a typical 
book chapter’s sequence of pages.
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Table 3. Properties of customized page styles to be used in a book chapter

Page Style Desired effect Property: setting
Right Page First page always on the right 

(an odd numbered page)
Page > Page layout > Only right

No header or footer Header > Header > Header on: 
Not selected

Top margin of page larger than 
on other pages

Page > Margins > Top: 6.00cm

Default Mirrored margins Page > Page layout: Mirrored

Header with page number on the 
top outside of the page and 
chapter title in the top middle 
center of the page

Header > Header on: Selected

Header > Header > Same content 
left/right: Not selected

Figure 246 illustrates the transitions from Right Page to Default, with the change of header 
between left and right pages shown by the # symbol.

Figure 246. Right Page and then Default page style with 
different headers for alternate pages.

To apply this page scenario:

1) Set up the page styles.

a) On the Styles and Formatting window, click the Page Styles icon  (fourth from 
left) to display a list of page styles.

b) Right-click on Right Page and select Modify from the pop-up menu.

c) On the Organizer page of the Page Style: Right Page dialog box (Figure 247), 
change Next Style to Default.
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Figure 247. Specifying the next style after the first page of a chapter

d) On the Page page (Figure 248), specify a larger left margin for binding, and a 
larger top margin to move the chapter title down the page.

e) On the Header and Footer pages, be sure the Header on and Footer on 
checkboxes are not selected. Click OK to save your changes.

f) On the Styles and Formatting window, in the list of page styles, right-click on 
Default and select Modify from the pop-up menu.

g) On the Organizer page of the Page Style: Default dialog box, be sure Next Style is 
Default.

Figure 248. Setting page margins and layout for the Right Page style

h) On the Page page of the Page Style: Default dialog box (Figure 249), select 
Mirrored for Page layout and set the Inner and Outer margins to the same width 
as the Left and Right margins, respectively, on the Right Page style.
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Figure 249. Setting page margins and layout for the Default page style

i) On the Header page of the Page Style: Default dialog box (Figure 250), select the 
Header on checkbox and deselect the Same content left/right checkbox. Click 
OK to save your changes.

Figure 250. Setting up the header properties for the Default page style

2) Set up the Heading 1 paragraph style to start on a new right-hand page.

a) In the Styles and Formatting window, right-click on Heading 1 and select Modify.

b) On the Text Flow page of the Paragraph Style dialog box (Figure 251), in the 
Breaks section, select Insert, With Page Style, and Right Page. Click OK to 
save your changes.

Figure 251. Setting a paragraph style to start on a page of a selected style
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3) To start a new chapter, apply the paragraph style Heading 1 to the first paragraph, 
which will be the title of the chapter.

Note By default, paragraph style Heading 1 is assigned to Outline Level 1. The 
assignment of paragraph styles to outline levels is done through Tools > Outline 
Numbering.

4) To set up the headers:

a) On a left page, put the cursor in the header and insert a page number field on the 
left (Insert > Fields > Page Number).

b) Press Tab to put the cursor in the middle and insert a Chapter reference:

Press Control+F2 to display the Fields dialog box (Figure 252).

On the Document page, for Type select Chapter and for Format select Chapter 
name. Make sure that Layer is set to 1, and then click Insert.

Figure 252. Inserting a chapter title into the header of a page

c) On a right page, put the cursor in the header, press Tab, insert a Chapter reference, 
press Tab again, and insert a page number field.

5) If you need to adjust the tab stops for the header, modify the Header paragraph style. 
Do not manually adjust the tab stops.
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Graphics in Writer documents

When you create a text document using OpenOffice.org Writer, you may need to include 
some graphic illustrations.

Graphics in Writer are of three basic types:

• Graphic and image files, including photos, drawings, scanned images, and others

• Diagrams created using Writer’s drawing tools

• Charts created using OOo’s Chart facility

This chapter covers the first two types of graphic illustrations. Most parts of this chapter also 
apply to the other components of OOo.

How to add a graphic from a file

OpenOffice.org can import various vector (line drawing) and raster (bitmap) file formats. The 
most common are GIF, JPEG or JPG, PNG, and BMP. See “Graphic file types supported” on 
page 246 for a full list of supported graphic file types.

Graphics may be downloaded from the Internet, scanned, created with a graphics program, or 
they may be photos taken with a digital camera. Some questions come to mind:

• How is a graphic inserted?

• Should the graphic be included in the document, or should it be linked to the file?

• How can the size of the graphic be adjusted?

• How can the relative position between the graphic and the text be changed?

These questions will be discussed in order.

Inserting a graphic from a file
To insert a graphic image from a file, the file must be already stored in a directory (folder) on 
the computer.

Proceed as follows:

1) Determine the destination for the image. For example, place the cursor at the 
appropriate location in the document.

2) On the main menu, select Insert > Picture > From File. This displays the dialog box 
shown in Figure 253.

3) Navigate to the file to be inserted.

4) Select the file to insert and click Open.
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Figure 253. Insert picture dialog box

Note At the bottom of the Insert picture dialog box (Figure 253) are two check boxes. If 
the Preview checkbox is checked, the selected graphic file is previewed in a pane, 
as shown in Figure 253, so you can verify that you have the correct file. The Link 
checkbox is discussed below.

Linking a graphic file

If the Link checkbox in the Insert picture dialog box is checked, OOo will create a link to the 
file containing the graphic, instead of saving a copy of the graphic in the document. The 
result is that the figure will be displayed in the document, but when the document is saved, it 
will contain only a reference to the graphic file but not the graphic itself. The document and 
the image remain as two separate files, and they are merged together only when you open the 
document again.

Linking an image has two advantages and one disadvantage:

• Advantage – Linking can reduce the size of the document when it is saved because the 
image file itself is not included.

• Advantage – You can modify the image file separately without changing the document 
because the link to the file remains valid, and the modified image will appear when 
you next open the document.

• Disadvantage – If you send the document to someone else, you must also send the 
image file, or the receiver will not be able to see the linked image.

Resizing a graphic
It is possible, and quite likely, that the inserted image will not fit perfectly into the document 
because it is too big or too small. Therefore, you will probably need to resize the image.

The position of the image is not relevant for now. Changing the position of an image relative 
to the text is discussed in “Positioning graphics within the text” on page 236.
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You can modify the size of a graphic in two ways:

• Unscaled resize

• Scaled resize

Figure 254 shows three examples of an image inserted into a document and resized.

Figure 254. Three examples of  resized images, plus the original image

Unscaled resize

In Example 1, the image is in its natural size. When you add a new graphic (and also when 
you select an existing one by clicking on it), it displays some square points along its 
perimeter; these are called handles. To resize the graphic:

1) Move the cursor onto a point.

2) Click the left mouse button.

3) Drag the mouse to modify the size of the figure.

This basic resizing process is useful if you need to specify the size and the height 
independently of each other. The problem with this method, as demonstrated in Example 3, is 
that when the graphic is not changed to scale, it will be distorted.

You need to either carefully measure and calculate how much the image needs to be adjusted 
in both the horizontal and vertical directions in order to maintain the correct proportions or 
use the scaled resize method described below.
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Scaled resize

A scaled resize is usually the best option, because it automatically maintains the proportions 
of the graphic. To perform a scaled resize:

1) Press and hold the Shift key.

2) Click and drag a handle of the graphic. It will resize proportionally, as shown in 
EXAMPLE 2.

3) Release the mouse button to complete the resize.

Inserting images from other sources
You can insert images from sources other than a file. The possible sources for images are:

• Graphics program
• Scanner
• OOo Gallery

From a graphics program

You can use many different graphics programs to edit a graphic file. In these programs, you 
can select, copy, and paste an image or part of a graphic into an OpenOffice.org document. 
Figure 255 shows an example of this procedure, which can be recreated with these steps:

1) In the imaging program window, select an area of the image to be copied. (The 
program used in the example is Paint Shop.)

2) Move the cursor over the selected area and press Control+C to copy.

Figure 255. Using a graphics program
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3) Switch to the OpenOffice.org Writer window.

4) Click to insert the cursor where the graphic is to be inserted.

5) Press Control+V to paste.

Scanner

If a scanner is connected to your computer, OpenOffice.org can call the scanning application. 
The scanned item will then be added into the OOo document page as an image. To start this 
procedure, on the main menu select Insert > Picture > Scan > Select Source.

OpenOffice.org Gallery

The Gallery is available in all components of OpenOffice.org. For an introduction to the 
Gallery, see Chapter 14 (Working with the Gallery) in the Getting Started guide.

You can select a graphic from the Gallery and drag it into the document. The Gallery icon is 
located in the right side of the Function Bar. Proceed as follows:

1) Click on the Gallery icon .

2) Select the theme containing the image you want to insert.

3) Click on the image with the left mouse button and, holding the button pressed, drag 
the image into the document.

4) Release the mouse button.

Figure 256 shows an example of an image dragged from the Gallery.

Figure 256. Inserting an image from the Gallery
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Adding an image to the Gallery

You may wish to add to the Gallery any images that you use frequently, for example, a 
company logo. You can then very easily insert these graphics into a document later.

To add images to the Gallery, proceed as follows:

1) Open the Gallery.

2) Select the theme where you want to add images, or you can create a new theme. To 
create a new theme:

• Click the New Theme button above the list box of Themes. The Properties of 
New Theme dialog box opens, which is similar to the one shown in Figure 257.

• Select the General tab and enter an appropriate name for the new theme in the 
text box.

• Select the Files tab, skip step 3, and continue with step 4.

3) Right-click on the desired theme and select Properties in the pop-up menu. This will 
display a window from which to select the files to be added (see Figure 257).

Figure 257. Gallery properties dialog box

4) On the Files page, click the Find Files button. The Select path dialog box opens.

5) You can enter the path for the file's directory in the Path text box, or you can navigate 
to locate the file's directory.

6) Use the File type drop-down list to help limit the search.
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7) Press the Select button to start the search.

8) A list of graphic files will be displayed in the window. You can use the File type filter 
again to further limit the search.

9) Select the files to add. To select more than one file, hold the Control key down while 
you click on each file.

10) Finally, click Add.

11) When you have finished working with the Gallery, you can click on its icon  to 
close it.

Note This procedure assumes that the graphic files for the themes already exist. You may 
need to import some graphics or to create your own onto your computer if the 
existing files are insufficient.

Note Similar to the file search function on various operating systems, Find Files searches 
for graphic files in any subfolders of the directory selected in step 5.

Modifying an image

When you insert a new image or select one already present in the document, the Picture 
toolbar appears. This toolbar can be either floating or docked.  shows what the Picture toolbar 
looks like when it is floating. Two other toolbars can be opened from this one: the Graphic 
Filter toolbar, which can be torn off and placed elsewhere on the window and the Color 
toolbar, which opens as a separate floating toolbar.

From these toolbars, you can apply small corrections to the graphic or obtain special effects.

Note For more sophisticated adjustments, it is better to use an image manipulation 
program, such as GIMP. GIMP is an open-source graphics program which can be 
downloaded from http://www.gimp.org/downloads/.

You can find out more information about the graphic filter and what its elements do by 
selecting the Find tab in Help (Help > OpenOffice.org Help), pressing the F1 key, or by 
clicking on an element that has a dialog box and selecting Help. Then, type Graphic Filter 
Bar into the Search term text box and press Find.
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Note: Graphics mode (3) can be Default, Grayscale, Black/White, or 
Watermark.

Figure 258. Picture toolbar plus tear-off Graphic Filter toolbar 
and floating Color toolbar

  1 From File
  2 Filter
  3 Graphics mode
  4 Color
  5 Transparency
  6 Flip Horizontally
  7 Flip Vertically
  8 Graphics Properties
  9 Invert
10 Smooth
11 Solarization
12 Aging
13 Charcoal Sketch
14 Relief
15 Mosaic
16 Posterize
17 Pop Art
18 Sharpen
19 Remove Noise
20 Red
21 Green
22 Blue
23 Brightness
24 Contrast
25 Gamma

Figure 259 provides examples of some of the changes available on the Picture toolbar.

Original Image Mirrored 
Vertically

Mirrored 
Horizontally

Light 50%

Contrast 50% Red 50% Green 50% Blue 50%

Figure 259. Some graphic effects that can be changed from the Picture toolbar
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Positioning graphics within the text

When you add a graphic to a text document, you need to choose how to position the graphic 
with respect to the text and other graphics.

Graphic arrangement refers to the placement of a graphic behind or in front of other graphics 
or text. Alignment refers to the vertical or horizontal placement of a graphic in relation to the 
page, frame, paragraph, or character to which it is anchored. Text wrapping refers to the 
relation of graphics to surrounding text, which may wrap around the graphic on one or both 
sides, be overprinted behind or in front of the graphic, or treat the graphic as a separate 
paragraph or character.

Arranging and aligning graphics
You can arrange and align graphics using commands from:

• The main menu: Format > Alignment (or Arrange, Wrap, Anchor, Flip, ...)

• By right-clicking on the picture, then Format > Alignment (or Arrange, Wrap, or 
Anchor)

• Frame (with the Graphics frame style applied) toolbar

• Picture dialog box

Frame toolbar

When you select a graphic, the Frame toolbar (shown in Figure 260) may be displayed.

Here you can click icons to apply many arrangement, alignment, wrapping, anchoring, 
formatting, and other choices.

1 Apply Style 6   Center Horizontal 11 Borders 16 Bring to Front
2 Wrap Off 7   Align Right 12 Line Style 17 Send to Back
3 Page Wrap 8   Top 13 Line Color (of the border) 18 Change Anchor
4 Wrap Through 9   Center 14 Background Color 19 Link Frames
5 Align Left 10 Bottom 15 Frame Properties 20 Unlink Frames

Figure 260. Frame toolbar (Graphics object)

Picture dialog box

Click on the graphic to select it and then click Format > Picture, or right-click on the 
graphic and then click Picture on the pop-up menu, to display the Picture dialog box (Figure
263). Here you can specify the characteristics of the graphic and its placement in detail.
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Wrapping text around graphics
On the main menu, click Format > Wrap. The Wrap menu options provide several 
possibilities:

• Alternate paragraphs and graphics, maintaining a separation between them (Wrap Off).

• Wrap text around the graphics (Page Wrap or Optimal Page Wrap).

• Put a semi-transparent graphic over the text (Wrap Through).

• Add a graphic in the background (In Background).

Often you need to insert graphics with no text around them, as in this chapter. To set the 
position of an image to the Wrap Off format, follow these steps:

1) Select a graphic by clicking on it.

2) Right-click to display the context menu and move the mouse pointer to Wrap to 
display the various wrap modes.

3) Select No Wrap.

Figure 261 shows an example of this operation.

Figure 261. Changing the wrap of a graphic

When formatting some documents, such as newsletters, you may want to put photos mixed 
with text or just want to add some decorative images. The Page Wrap option may satisfy this 
need. Figure 262 shows an example of a graphic insertion with the Page Wrap option.

When an image is inserted with the Page Wrap option, you can move it anywhere on the 
page. The text will be automatically adjusted around the image, like water around a sailing 
boat.

The Optimal Page Wrap option is similar to Page Wrap, but it maintains the text positioned 
beside the image. The position is decided automatically in order to optimize the relative 
position between text and image.
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Figure 262. Inserting a graphic using the Page Wrap option

Double-clicking on an image pops up the Picture dialog box where you can set all the 
parameters affecting the image (see Figure 263). On the Wrap page, you can change the 
setting for the optimal page wrap.

Figure 263. The Wrap page of the Picture dialog box

The Wrap Through option lets you also insert an image overlapping the text. In this case, 
some part of the text will be hidden, unless you change the transparency of the image.

After changing the transparency, the final result looks like a decal applied over the text, as in 
Figure 264, where the transparency has been set to 48% in the Transparency spinbox in the 
Picture toolbar. The words under the image are visible but appear lighter than the rest of the 
text.
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Figure 264. Transparent image added over the text

You can obtain a similar result if you set a graphic’s wrap to the In Background format. In 
this case all the text will be clearly readable, with characters that have the same intensity. 
However, the background graphic should not be dark; otherwise, the text could be difficult to 
read. You can also use the Transparency spinbox to control the “transparency”.

Anchoring graphics and drawing objects

You can anchor graphics as a character or to a page, paragraph, or character. You can also 
place graphics in a frame and anchor the frame to a page, paragraph, or character. Which 
method you choose depends on what you are trying to achieve.

Here are the ways you can anchor graphics or drawing objects:

To Page
The graphic keeps the same position in relation to the page margins. It does not move as you 
add or delete text or other graphics. This method is useful when the graphic does not need to 
be visually associated with a particular piece of text. It is often used when producing 
newsletters or other documents that are very layout intensive.

Caution If you plan to use a document within a master document, do not anchor graphics 
To Page, because the graphics will disappear from the master document. See 
Chapter 13 (Working with Master Documents) for more information.

To Paragraph
The graphic is associated with a paragraph and moves with the paragraph. It may be placed in 
the margin or another location. This method is useful as an alternative to a table for placing 
icons beside paragraphs.
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To Character
The graphic is associated with a character but is not in the text sequence. It moves with the 
paragraph but may be placed in the margin or another location. This method is similar to 
anchoring to a paragraph but cannot be used with drawing objects.

As Character
The graphic is placed in the document like any other character and, therefore, affects the 
height of the text line and the line break. The graphic moves with the paragraph as you add or 
delete text before the paragraph. This method is useful for keeping screenshots in sequence in 
a procedure or for adding a small icon in sequence in a sentence.

To Frame
If the graphic has been placed in a frame, you can anchor the graphic in a fixed position 
inside the frame. The frame can then be anchored to the page, a paragraph, or a character, as 
required.

Adding captions to graphics

You can add captions to graphics in three ways: automatically, by using the Caption dialog 
box, or manually.

Adding captions automatically
You can set up OOo to add captions automatically whenever you insert a graphic, a table, or 
other objects into a document. You can choose which objects are captioned automatically, 
what the sequence name is for each caption (for example, “Table” or “Illustration”), and the 
position of the caption.

To set up automatic captions:

1) Click Tools > Options > OpenOffice.org Writer. Click on the + sign to open the 
different options. The Options – OpenOffice.org Writer – AutoCaption dialog box 
opens.

2) Select AutoCaption. Now you can see several choices at the right of the dialog box 
for adding captions automatically.

3) On the AutoCaption dialog box, choose which objects will be automatically captioned 
and specify the characteristics of the captions.

For more information, see “AutoCaption options” in Chapter 2 (Setting up Writer).

When you insert a graphic, if automatic captioning is enabled, the graphic will be placed in a 
frame along with a caption containing the default sequence name for graphics―Illustration. 
Position the cursor in the caption area and type the text for the caption. You can change the 
sequence name by selecting one from the drop-down Category list.
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Note You can specify where to place an automatic caption for any object except a picture; 
picture captions can only be automatically placed below the picture. If you need a 
caption above the picture (for example, for data plots in scientific publications), you 
must add the captions manually, as described in “Adding captions manually” on 
page 242.

Tip A common sequence name—Figure—is not one of the names provided: <None>, 
Drawing, Illustration, Table, and Text. If you want a custom name for your 
graphics, do the following:

1. Open the Options – OpenOffice.org Writer—AutoCaption dialog box, 
described above.

2. Under the Add captions automatically when inserting section, check 
OpenOffice.org Writer Picture.

3. With the mouse, highlight the text Add captions automatically when 
inserting, if it is not already highlighted. This actives the Caption area in 
the dialog box for pictures (graphics).

4. Under the Category drop-down list, enter the name that you want added 
(say, Figure), by overwriting any sequence name in the list. (Overwriting 
the term will not delete it from the drop-down list.) You can also set some 
options for the number style and for a separator between the name and the 
number, if desired. Click OK to save the changes.

Using the Caption dialog box
To add captions using the Caption dialog box:

1) Insert the graphic, then select it and click Insert > Caption.

2) Under Properties on the Caption dialog box (Figure 265), make your selections for the 
Category, Numbering, and Separator fields (Illustration, Arabic (1 2 3), and a colon 
(:), respectively, for the example in Figure 265) and type your caption text in the 
Caption text box at the top. Whatever text you enter for the caption appears in the box 
at the bottom, after the sequence name, number, and separator.

3) Click OK. The graphic and its caption are placed in a frame, as shown in Figure 266.

Tip In the Category box, you can type any name you want, for example, Figure. OOo 
will create a numbering sequence using that name.
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Figure 265. Defining the caption for an illustration

Tip In the Category box, you can type any name you want, for example, Figure. OOo 
will create a numbering sequence using that name.

Illustration 1. An example

Figure 266. An example of a graphic and its caption contained in a frame. The outer box 
shows the edge of the frame; this border is normally set to be invisible.

Adding captions manually
You can add a caption to a graphic manually in two ways.

Method 1: Override the category and positioning defaults for captions

1) Select the picture, right-click on it, and select Caption.

2) On the Caption dialog box (Figure 265), select <None> in the Category list and click 
OK.

3) Right-click on the picture and select Caption. Now you can select a caption type (or 
type your own sequence category) in the Category drop-down list and, optionally, 
select Above in the Position list. (If you want the caption to appear at the top, you 
must add the caption manually.) You can type the actual caption in the box under 
Caption or you can fill it in later—after the (incomplete) caption is inserted.

4) Click OK.
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Note If you want the caption to appear at the bottom, you can skip skip 2 and the first 
part  of step 3.

Method 2: Place the graphic and its caption in separate paragraphs

1) Insert the graphic and anchor it to its paragraph as a character. Press Enter to create a 
new paragraph for the caption.

2) In the caption paragraph, type, for example, Figure and add a space.

3) To insert the figure number, click Insert > Fields > Other and select the Variables tab.

4) Select Number range in the Type list. Select Figure in the Selection list and choose, 
for example, Arabic (1 2 3) in the Format drop-down list. Click the Insert button.

5) A number will appear after the word “Figure” in the caption. Now, type the text of the 
caption.

Tips If you are manually adding captions to a lot of figures using Method 2, you might 
want to make an AutoText entry containing, for example, Figure and a space, the 
figure-number field, and an optional separator and a space after it.

You can also place the caption paragraph before (above) the picture paragraph. Using 
AutoText can be a convenient way to deal with the lack of automatic captioning 
above pictures.

Using Writer’s drawing tools

You can use Writer’s drawing tools to create graphics, such as simple diagrams using 
rectangles, circles, lines, text, and other objects. Group the drawing objects to make sure they 
stay together the way you intended.

You can use the drawing tools to place drawing objects directly on a page in your document, 
or you can insert the drawing objects into a frame.

You can also use the drawing tools to annotate photographs, screen captures, or other 
illustrations produced by other programs, but this is not recommended because:

• You cannot include graphics in a group with drawing objects, so they may get out of 
alignment in your document.

• If you convert a Writer document to another format, such as HTML, the drawing 
objects and the graphics will not remain associated; they will be saved separately.

Instead, use OOo Draw or another graphics program to annotate illustrations.

Creating drawing objects
To begin using the drawing tools, display the Drawing toolbar (Figure 267), by clicking 
View > Toolbars > Drawing.
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If you are planning to use the drawing tools repeatedly, you can tear off this toolbar and move 
it to a convenient place on the window.

1 Select 5 Freeform Line   9  Symbol Shapes 13 Stars
2 Line 6 Text 10  Block arrows 14 Points
3 Rectangle 7 Callouts 11  Flowcharts 15 Fontwork Gallery
4 Ellipse 8 Basic Shapes 12  Callouts 16 From File

17 Extrusion On/Off
Figure 267. The Drawing toolbar

To use a drawing tool:

1) Click in the document where you want the drawing to be anchored. You can change 
the anchor later, if necessary.

2) Select the tool from the Drawing toolbar (Figure 267). The mouse pointer changes to a 

drawing-functions pointer .

3) Move the cross-hair pointer to the place in the document where you want the graphic 
to appear and then click-and-drag to create the drawing object. Release the mouse 
button. The selected drawing function remains active, so you can draw another object 
of the same type.

4) To cancel the selected drawing function, press the Esc key or click on the Select icon 
(the arrow) on the Drawing toolbar.

5) You can now change the properties (fill color, line type and weight, anchoring, and 
others) of the drawing object using either the Drawing Object Properties toolbar 
(Figure 268) or the choices and dialog boxes reached by right-clicking on the drawing 
object.

Setting or changing properties for drawing objects
To set the properties for a drawing object before you draw it:

1) On the Drawing toolbar (Figure 267), click the Select tool.

2) On the Drawing Object Properties toolbar (Figure 268), click on the icon for each 
property and select the value you want for that property.

3) For more control, or to define new attributes, you can click on the Area or Line icons 
on the toolbar to display detailed dialog boxes.

The default you set applies to the current document and session. It is not retained when you 
close the document or close Writer, and it does not apply to any other document you open. 
The defaults apply to all the drawing objects except text objects.
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1 Line 5 Line Color   9 To Foreground 13 Alignment
2 Arrow Style 6 Area 10 To Background 14 Change Anchor
3 Line Style 7 Area Style / Filling 11 Bring to Front 15 Ungroup
4 Line Width 8 Rotate 12 Send to Back 16 Group

Figure 268. Drawing Object Properties toolbar

To change the properties for an existing drawing object:

1) Select the object.

2) Continue as described above.

You can also specify the position and size, rotation, and slant and corner radius properties of 
the drawing object:

1) Right-click on the drawing object and then click Position and Size from the pop-up 
menu. The Position and Size dialog box is displayed.

2) Choose any properties, as required.

Grouping drawing objects
1) Select one object, then hold down the Shift key and select the others you want to 

include in the group. The bounding box expands to include all the selected objects.

2) With the objects selected, hover the mouse pointer over one of the objects and click 
either Format > Group > Group or right-click and then click Group > Group on the 
pop-up menu.

Note You cannot include an embedded or linked graphic in a group with drawing objects.
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Graphic file types supported

OpenOffice.org Writer can open the file types listed in Table 4. Many of these file types are 
hyperlinked to Wikipedia for their definitions and other information.

Table 4. Graphic file types supported by OpenOffice.org Writer

File extension File type

BMP Windows Bitmap

DXF AutoCAD Drawing Interchange 
(Exchange) Format

EMF Enhanced Metafile

EPS Encapsulated PostScript

GIF Graphics Interchange Format

JPG, JPEG, JFIF, JIF Joint Photographic Experts Group

MET OS/2 Metafile

PBM Portable Bitmap

PCD Kodak Photo CD

PCT Macintosh QuickDraw PICT

PCX Zsoft PC Paintbrush

PGM Portable Graymap

PNG Portable Network Graphics

PPM Portable Pixelmap

PSD Adobe Photoshop Document

RAS Sun Raster Image

SGF StarWriter Graphics Format

SGV StarDraw 2.0

SVM StarView Metafile

TGA Truevision Targa

TIF, TIFF Tagged Image File Format

WMF Windows Metafile

XBM X Bitmap

XPM X PixMap
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Introduction

Tables are a useful way to organize and present large amounts of information, for example:

• Technical, financial, or statistical reports

• Product catalogs showing descriptions, prices, characteristics, and photographs of 
products

• Bills or invoices

• Lists of names with address, age, profession, and other information

Tables can often be used as an alternative to spreadsheets to organize materials. A well-
designed table can help readers understand better what you are saying. While you would 
normally use tables for text or numbers, you could put other objects, such as pictures, in 
cells.

Tables can also be used as a page-layout tool to position text in areas of a document instead 
of using several Tab characters. For example, the descriptions under Figure 269 were created 
in a table with invisible borders. Another, perhaps better example would be in headers and 
footers to support independent positioning of different elements, such as page number, 
document title etc. This use of tables is described in Chapter 4 (Formatting Pages).

The Table menu and toolbar

Table commands are located in the main Table menu and on the Table toolbar, shown in 
Figure 269. Table 5 describes the functions of these commands and icons. When you create a 
table or select an existing table, the Table toolbar may be displayed automatically, or you can 
manually display the Table toolbar by clicking View > Toolbars > Table. The toolbar can 
float on top of the main Writer window (as illustrated in Figure 269), or it can be docked 
along any edge of the main window.

1 Table 7 Split Cells 13 Insert Column 19 AutoFormat
2 Line Style 8 Optimize 14 Delete Row 20 Table Properties
3 Line Color (border) 9 Top 15 Delete Column 21 Sort
4 Borders 10 Center (vertical) 16  Select Table 22 Sum
5 Background Color 11 Bottom 17  Select Column
6 Merge Cells 12 Insert Row 18  Select Row

Figure 269: Table toolbar
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Table 5: Functions of the icons on the Table toolbar

Icon Name Description

Table Opens the Insert Table dialog box where you can set up and insert a table 
into the document, name the table for use with the Navigator, and set 
some options. You can also use the mouse to click the arrow at the right, 
drag to select the number of rows and columns to include in the table, and 
then release the mouse button on the last (lower right) cell.

Line Style Opens the Border Style toolbar where you can modify the border line 
style.

Line Color (border) Opens the Border Color toolbar where you can modify the border color.

Borders Opens the Borders toolbar where you can select sides to have a border.

Background Color Opens the Background toolbar where you can select the background color.

Merge Cells Combines the selected cells into a single cell. Refer to “Merging and
splitting cells” on page 253 for an example of using this button.

Split Cells Opens the Split Cell dialog box where you can define how to split a cell. 
Refer to “Merging and splitting tables” on page 254 for an example of 
using this button.

Optimize Opens the Optimize toolbar where you can distribute the columns or rows 
evenly or optimize the row height or column width.

Top Aligns the contents of the selected cells to the top of the cell.

Center (vertical) Aligns the contents of the selected cells to the vertical center of the cell.

Bottom Aligns the contents of the selected cells to the bottom of the cell.

Insert Row Inserts a row below the selected row.

Insert Column Inserts a column after the selected column.

Delete Row Deletes the selected row(s) from the table.

Delete Column Deletes the selected column(s) from the table.

Select Table Selects the entire table.

Select Column Selects the column in which the cursor is positioned.

Select Row Selects the row in which the cursor is positioned.

AutoFormat Opens the AutoFormat dialog box where you can select among several 
predefined formatting sets. Each set is characterized by its own fonts, 
shading, and borders styles. You can also select AutoFormat from the 
Insert Table dialog box.

Table Properties Opens the Table Format dialog box where you can modify various 
properties for the table—for example: name, alignment, spacing, column 
width, borders, and background.

Sort Opens the Sort dialog box where you can specify the sort criteria for the 
selected cells.

Sum Activates the sum function. Refer to “Using spreadsheet functions in a
table” on page 268 for an example of using this function.
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Creating a table

Before you insert a table into a document, it is beneficial to have an estimate of the number 
of rows and columns required. However, if necessary, you can easily make changes later.

Inserting a new table
To insert a new table, position the cursor where you want the table to appear, then use any of 
the following methods to open the Insert Table dialog box (shown in Figure 270):

• From the main menu, select Table > Insert > Table.

• Press Control+F12.

• From the Standard toolbar, click the Table icon .

Figure 270: Inserting a new table using the Insert Table dialog box

Here you can specify the properties for the new table.

Under Name, you can enter a different name than the OOo-generated default for the table. 
This might come in handy in case you want the tables displayed in the Navigator in a certain 
(sorted) way.

Under Size, specify the initial number of columns and rows for the new table. You can change 
the size of the table later, if necessary.

Under Options, set up the initial table characteristics. Selecting the check boxes in this 
section of the dialog produces the following results:

• Heading — Defines the first row(s) in the table as headings. The default Table 
Heading paragraph style is applied to the heading rows and thus makes the text 
centered, bold, and italic. The OOo predefined Table Heading paragraph style may be 
modified in the Styles and Formatting window, if desired.
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• Repeat heading — Repeats the heading row(s) of the table at the top of subsequent 
pages if the table spans more than one page.

The first ... rows —Specifies the number of rows to be repeated. Default is 1.

• Don’t split table — Prevents the table from spanning more than one page. This can be 
useful if the table starts near the end of a page, and would look better if it were 
completely located on the following page. If the table becomes longer than would fit 
on one page, you will need to either de-select this check box or manually split the 
table.

• Border — Surrounds each cell of the table with a border. This border can be modified 
or deleted later.

The AutoFormat button opens a dialog from where it is possible to select one of the many 
predefined table layouts. See “AutoFormatting tables” on page 263 for more information.

After making your choices, click OK. Writer creates a table as wide as the page margins, 
with all columns the same width and all rows the same height. You can then adjust the 
columns and rows later to suit your needs.

Tip To directly insert a table with the default properties, click on the little arrow next to 
the Table icon on the Standard toolbar. A graphic appears where you can choose the 
table’s size (rows and columns). To create the table, click on the cell that you want 
to be on the last row of the last column. Holding down the mouse button over the 
Table icon will also display the graphic.

Creating nested tables
With OpenOffice.org 2.0 it became possible to create tables within tables, nested  to a depth 
only limited by imagination and practicality. Figure 271 demonstrates a simple, 2 level 
example.

To achieve this, simply click in a cell of an existing table and use any of the methods 
mentioned in “Inserting a new table” above.

Figure 271: Nested table example. The shaded table is nested in a cell of the larger table.

Using AutoCorrect to create a table
You can also create a table by typing a series of hyphens (-) or tabs separated by plus signs. 
For example, type: +------+---+ and then press Enter. Plus signs indicate column dividers, 
while hyphens and tabs indicate the width of a column. 
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For example, this character sequence:

+-----------------+---------------+------+

creates a table like this:

Note This function can be disabled or enabled in Tools > AutoCorrect. On the Options 
tab, deselect or select the Create table check box. This function does not operate 
when creating nested tables.

Caution Always be careful when using tabs that you (a) know how wide they are set and (b) 
make sure that the tabs are set to the same values if used with other documents or by 
other users.

Formatting a table

Default parameters
If you create a table using the Insert Table dialog box or the Table icon on the Standard 
toolbar, the following defaults are set:

• The cells in the first row use the Table Heading paragraph style. In the default 
template, the text is centered and set with a bold and italic font.

• The remaining cells use the Table Contents paragraph style, which, in the default 
template, is identical to the Default paragraph style.

Formatting individual cells
You can format each cell independently of other cells. For example, you can:

• Format the characters — change the font, the font style, and the background colors.

• Set different indentation values — when you select a cell, the horizontal ruler shows 
the indentation points with gray pentagons. Vary the indentation by clicking and 
dragging these points.

• Change the text alignment — for example, a number can be aligned to the right, while 
text on another line in the cell is aligned to the left or centered.

To change the format of a cell or range of cells:

1) Select the cell or range of cells to be modified. You can select a single cell by clicking 
in it, select a range with click and drag, or select a row or column using menu or 
toolbar choices.
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2) Right-click the selection and select Table, or select Table > Table Properties from the 
menu bar.

3) From the Table Format dialog box, select the property to modify.

Figure 272 shows some examples.

Figure 272: Formating the contents of individual cells: The 0 is right-aligned; the 4 is  
centered and the indentation in that cell has been increased; the 5 is left-aligned.

Inserting rows and columns
To insert any number of rows or columns:

1) Place the cursor in the row or column where you want new rows or columns to be 
inserted and right-click. On the pop-up menu, select Row > Insert or Column > 
Insert. This will display a dialog box where you can select the number of rows or 
columns to add before or after the selected one.

2) Set Amount to the number of rows or columns to insert and Position to Before or 
After. Click OK to close the dialog box.

Notes Clicking on the Insert Row icon on the Table toolbar inserts one row below the 
selected one. Clicking on the Insert Column icon on the Table toolbar inserts a 
column after (to the right of) the selected one.

Regardless of how they are inserted, new rows or columns have the same 
formatting as the row or column where the cursor was when the insert command 
was issued.

Merging and splitting cells
To merge a group of cells into one cell:

1) Select the cells to merge.

2) Right-click and select Cell > Merge on the pop-up menu, or select Table > Merge 
Cells from the menu bar.
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To split a cell into multiple cells:

1) Position the cursor inside the cell.

2) Right-click and select Cell > Split on the pop-up menu, or select Table > Split Cells 
from the menu bar.

3) Select how to split the cell. A cell can be split either horizontally (create more rows) or 
vertically (create more columns), and you can specify the number of new cells to 
create.

Merging and splitting tables
A whole table can be split into two tables, and two tables can be merged into a single table. 
Tables are split only horizontally (the rows above the split point are put into one table, and 
the rows below into another).

To split a table:

1) Place the cursor in a cell which will be in the top row of the second table after the split 
(the table splits immediately above the cursor).

2) Right-click and select Split Table in the pop-up menu. You can also use Table > Split 
Table from the menu bar.

3) A Split Table dialog box will pop up regarding the heading. You can select No 
heading or an alternative formatting for the heading—the top row(s) of the new table.

The table is then split into two tables separated by a blank paragraph.

To merge two tables:

1) Delete the blank paragraph between the tables. You must use the Delete key (not the 
Backspace key) to do this.

2) Select a cell in the second table.

3) Right-click and select Merge Tables in the pop-up menu. You can also use Table > 
Merge Table from the menu bar.

Tip To see clearly where the paragraphs are and to delete them easily, select View > 
Nonprinting Characters (Ctrl+F10) or click the ¶ button in the Standard toolbar.

Choosing table spacing and alignment
You can specify how the table is aligned on the page and what space to leave around the 
table.

Right-click anywhere in the table and select Table from the pop-up menu or select Table > 
Table Properties from the menu bar. On the Table Format dialog box, select the Table tab.
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Figure 273: Table Format dialog box: Table page

On this page, you can:

• Set a name for the table. This has no effect on the display but makes the table easier to 
find when using the Navigator. This can be very useful if your document has a number 
of tables. A table name cannot have any spaces. To make a meaningful name, you 
could use underscores or hyphens (for example, Table-1_Doll_House_Inventory).

• Set the overall width of the table, either absolute or relative to the page width. This 
option is available only if the Alignment is not set to Automatic. (See below.)

• Specify how the table is aligned if it does not fill the width of the page (between the 
margins). Under Alignment:

• Left aligns the table with the left margin.

• Right aligns the table with the right margin.

• From Left lets you specify under Spacing exactly how far from the left margin 
the table is placed.

• Center aligns the table in the middle between the left and right margins. If the 
table width is less than the space between the margins, the excess is evenly 
distributed on both sides of the table. If the table width is greater, the table will 
extend outside of the margins.

• Manual lets you specify the distances from both left and right margins under 
Spacing.

• Under Spacing: Above and Below, specify the distances to leave above and below the 
table.
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Specifying text flow

Figure 274: Table Format dialog box: Text Flow page

On the Text Flow page of the Table Format dialog box (Figure 274), you can:

• Insert a page or column break either before or after the table. Use the Text Flow: 
Break check box, combined with the Page or Column and the Before or After 
buttons.

If you insert a page break before the table (that is, start the table on a new page), you 
can also change the page style that will go with it by checking the With Page Style 
box and selecting a new page style. As with any page break, you can also reset the 
page numbers using the Page number box.

• Keep a table on one page by deselecting the Allow table to split across pages and 
columns check box. If this item is deselected, the next item is not active.

• Keep each row on one page by deselecting the Allow row to break across pages and 
columns check box.

• Use the Repeat heading check box and the numbers box to select the number of table 
heading rows that will be repeated on each page. A complicated table may need two or 
three heading rows to be easily read and understood.

• Use the Text direction list to select the direction for the text in the cells. The most 
common setting is Left to right for Western languages. Note: The phrase Use 
superordinate object settings means “use the formatting settings from the paragraph 
before the table.”
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• Select the vertical alignment of the text in the table or the selected cells; the choices 
are to align with the top of the cell, the center of the cell, or the bottom of the cell. This 
alignment is in addition to the Left-Right alignment options available under Table > 
Table Properties > Table or by right-clicking and choosing Table > Table.

Note A Table Heading row may not span two pages, but any other row may. A one-row 
table (often used for page layout purposes), if set up with the default of including a 
heading, will not break across pages. The cure is to make sure the table is defined 
without a heading row.

Resizing rows and columns
You can adjust the height of rows and the width of columns in a table in several ways.

You can manually resize rows and columns by dragging them to the desired size. When the 
cursor is in the table, a pair of thin gray lines (||) appear in the rulers.

The horizontal ruler shows the column dividers, and the vertical ruler shows the row dividers.

To change the width of a column or height of a row, use one of these methods:

• Hold the mouse button down on a cell border, so a double-headed arrow appears, and 
and drag the border to the desired position.

• To change the column width using the ruler, hold the mouse button down on the 
appropriate column divider (double vertical line) so that a double-headed arrow 
appears and drag the divider to a new location.

• To change the row height using the ruler, hold the mouse button down on the 
appropriate row divider (double horizontal line) so that a double-headed arrow appears 
and drag the divider to a new location.

Selecting Table > Autofit from the main menu offers some shortcuts to resizing:

• Optimal column width or row height will make the columns or rows as narrow as 
possible while still fitting their contents.

• Columns and rows can be distributed evenly to quickly bring them back to all being 
the same width or height.

For greater control over the width of each column, use the Columns page of the Table format 
dialog box (Figure 275).

Right-click on the table and select Table from the pop-up menu or select Table > Table 
Properties from the menu bar. On the Table Format dialog box, select the Columns tab.

• Adapt table width: If a table already stretches to the page margins, it cannot stretch any 
wider and the Adapt table width option is not available. If the table is narrower, 
increasing the width of a column will increase the width of the whole table. 

If the table width already extends pasts the margins with the Adapt table width option 
checked, attempting to change a column width will automatically decrease that 
column’s size so that the table will now shrink to the page margins while keeping any 
other column sizes intact.
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• Adjust columns proportionally results in all columns changing their widths by the 
same amount when one is changed.

• Remaining space shows how much farther the table can expand before hitting the limit 
of the margins. This value cannot be edited and will not be negative in the event that 
the table width is already larger than the space between the left and right margins.

• Under Column width, each individual column can be adjusted. If you have more than 
six columns, use the arrows at the right and left to view them all.

Figure 275: Table Format dialog box: Columns page

Specifying table borders
On the Table Format dialog box, select the Borders tab (Figure 276).

Here you can set borders for a whole table or groups of cells within a table. In addition, a 
shadow can be set for the whole table.

Borders have three components: where they go, what they look like, and how big a space is 
left around them.

• Line arrangement specifies where the borders go. If a group of cells is selected, the 
border will be applied only to those cells. You can specify no border or any 
combination of border for the outside edges and the cell divisions—either by 
selecting a default arrangement or by clicking on the lines in the User-defined area to 
get exactly what you want.

• Line specifies what the border looks like: the style and color. There are a number of 
different styles and colors to choose from.

• Spacing to contents specifies how much space to leave between the border and the cell 
contents. Spaces can be specified to the left, right, above, and below. Check 
Synchronize to have the same spacing all the way round.

Shadows always apply to the whole table. A shadow has three components: where it is, how 
thick it is, and what color it is. Set each of these under Shadow style on the dialog box.
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Figure 276: Table Format dialog box: Borders page

If Merge adjacent line styles is checked, two cells sharing a common border will have their 
borders merged, rather than being side by side.

Tip To reset everything if you are having problems with borders, right-click in the table 
and select Table > Borders or select Table > Table Properties > Borders and then 
select the Set no borders icon under Line arrangement: Default (the box on the 
left).

Selecting background colors and graphics
The background of a table, a cell, or a group of cells can be set to a color or a background 
graphic. If you select an image, you can position it in the cell (or group of cells), stretch it to 
fill the space, or tile the image across the cells. You can set the background for the whole 
table in the same way.

To set the background for a cell, row, or table:

1) Select the cells you wish to work with. If you are changing the background for a row 
or table, just place the cursor anywhere inside the row or table to be changed.

2) Right-click and select Table from the pop-up menu, or select Table > Table 
Properties from the main menu.

3) In the Table Format dialog box, select the Background tab.
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4) In the For section, chose whether to apply the settings to cell, row, or table. If you 
choose Cell, any changes apply to all the selected cells.

5) In the As section, choose whether the background is a color or a graphic.

6) To apply a color, select the color and click OK.

7) To apply a graphic, first select the graphic to use. This must be a graphic file 
accessible from your computer. (Writer supports a large number of graphics formats.)

• You have the option with the Link check box to link the graphic file. If it is linked, 
changes to the graphic (for example, if you edit it in a different package) will be 
reflected in your document. However, you also need to keep the linked graphic file 
with the document file. If, for example, you email the document without the 
graphic file, the graphic will no longer be visible.

• Under Type, select the type of placement for the graphic. If you choose Position, 
you can select where to position the graphic within the cells, row, or table. If you 
choose Area, the graphic is stretched to fill the whole area. If Tile, the graphic is 
tiled (repeated horizontally and vertically) to fill the area.

• If the Preview check box is checked, the graphic displays in the pane above the 
check box.

• To apply the graphic, click OK.

See Figure 277 for an example of a background for a cell using an unlinked graphic which 
can be viewed in the Preview pane.

Figure 277: Table Format dialog box: Background page
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Vertical alignment
The default for text entered into table cells is for it to be aligned horizontally to the left, and 
numbers are aligned to the right. In addition, if more than one row of text is entered or if a 
graphic is used, text aligns vertically to the top of the cell and numbers to the bottom.

To vertically center align all of the text and numbers in the table:

1) Move the cursor to the upper left-hand cell under the table heading and click and drag 
to the lower left hand cell.

Note By selecting all cells, the images will also be aligned.

2) Right-click in the selected area and select Cell > Center in the pop-up menu.

Number formats
The number format can be set for a whole table or group of cells. For example, cells can be 
set to display in a particular currency, to four decimal places, or in a particular date format.

Number recognition specifies that numbers in a text table are recognized and formatted as 
numbers. If number recognition is not selected, numbers are saved in text format and are 
automatically left-aligned. Number recognition can be set on or off under Tools > Options > 
OpenOffice.org Writer > Table.

Select the cells to format, then right-click and select Number Format from the pop-up menu. 
The Number Format dialog box opens for you to set options for various categories of 
numerical data.

• In the Category drop-down list, select the category you want, such as currency, date, 
or text.

• In the Format drop-down list, choose a format for the category you just selected.

• For some categories, such as date, you may wish to change the language using the 
Language list.

• Additional options are available for different categories.

Adding a caption
You can easily add a caption to any table. Writer will keep track of all your captioned tables, 
automatically number them, and update any links to them.

To add a caption to a table:

1) Place the cursor in the table.

2) Right-click and select Caption from the pop-up menu.

3) Enter the text for your caption, the numbering style, and separator.

4) Click OK.
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To automatically caption all your tables:

1) Place the cursor in a table.

2) Right-click and select Caption from the pop-up menu.

3) Select AutoCaption.

4) Select OpenOffice.org Writer Table and select the settings you want and click OK. 
This dialog box is covered in more detail in Chapter 2 (Setting up Writer).

When AutoCaption is enabled for tables, all tables will be captioned; you will need to add the 
text for each caption onto the table manually.

Writer supplies five different category labels:

• <None>

• Drawing

• Table

• Illustration

• Text

You can create your own category labels, formating, and separators—either under Insert > 
Caption or under Tools > Options > OpenOffice.org Writer > AutoCaption > OpenOffice 
Writer Table.

In either case, simply highlight a label and type in the new name. In the example below, we 
used Fantasia.

You can also change the separator or the format of the category label. For example, you 
might want your tables to be labeled as Fantasia and formated in bold type and using a period 
(‘.’) as a separator, as follows:

Fantasia 1. Interesting data

Fantasia 2. More interesting data

Fantasia 3. Yet more interesting data

To do this, you can highlight and replace a separator and then select Insert > Caption > 
Options > Character Style and assign a style, or you can set this up in the AutoCaption 
dialog box.

The format and separator if used under Insert > Caption only works for that specific table. 
However, it will work for that and all following tables if it is set up under AutoCaption.

When using AutoCaption, you need to remove the ‘.’ under Numbering captions by chapter 
> Separator if you are not using Chapter numbering to avoid having an extra punctuation 
mark added to the category label.
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Cross-referencing a table
You can insert a cross-reference to a captioned table. Clicking on the cross-reference takes 
the reader directly to the table.

1) Position the cursor where you want the cross reference.

2) Select Insert > Cross-reference from the main menu.

3) Set the Type to Table. A list of captioned tables will be shown in the Selection panel; 
select the one you want to reference.

4) In the Format pane, choose how the cross reference will appear. For example, 
Category and Number will show up as Table 1 for the first table, while Numbering 
produces only 1, and Above/Below inserts one of those words as the reference.

5) Click Insert to add the cross-reference and click Close to exit the dialog box.

AutoFormatting tables
You can use AutoFormat to make your table formats consistent. You can also create and add 
your own table autoformats. Here is how:

1) Create a table and manually format it as you wish, including borders, spacing of text 
from the top and bottom borders, fonts to be used in the table heading and data cells, 
and background colors.

Note To use background colors in a new format, color the cells rather than the table. That 
is, select the cell or cells you wish to color, select Table > Table Properties > 
Background (or right-click Table > Background), choose a color, and specify As: 
Color, For: Cell.

2) Position the cursor anywhere in the table and then click Table > AutoFormat.

3) On the AutoFormat dialog box (Figure 278), click Add and give the table format a 
name in the AddAutoFormat dialog box and click OK.

4) The newly named autoformat now appears as an available format. Click OK to close 
the AutoFormat dialog box.

Tip This technique does not include table and column widths in the table format. To 
insert a table with predefined full formatting, save it as AutoText.
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Figure 278: AutoFormat dialog box

Create a heading row in an existing table
To create a heading row in an existing table that does not have one, you need to apply an 
autoformat that does have a heading defined. (Here is where having some personalized table 
formats could come in very handy.) Place the cursor anywhere in the table and then click 
Table > AutoFormat. Choose a format. Click OK.

Rotating text in a table cell
You can rotate text in a table cell by 90 or 270 degrees. Text rotation is useful when you have 
long headings for narrow columns. Select the text to be rotated and then click Format > 
Character. On the Position page, in the Rotation / scaling section, choose the rotation angle 
and click OK.

Displaying or hiding table boundaries
A table boundary is a set of pale (usually gray) lines around the cells when viewed on-screen 
in OOo. These boundaries do not print and do not appear in PDFs; their only function is to 
help you see where the table cells are.

To display the table the same way on the screen as on the printed page, with no boundary 
lines, right-click on the table and select Table Boundaries from the pop-up menu. Repeat 
this to have the boundaries appear again.

Note Turning boundaries off does not hide the borders that the table may have.
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Tip You can also turn table boundaries on and off through Tools > Options > 
OpenOffice.org > Appearance. On that page, you can display or hide boundaries 
around text, pages headers and footers, figures, and other parts of a document.

Data entry in tables

Moving between cells
Within a table, you can use the mouse, the cursor keys, or the Tab key to move between cells.

The cursor keys move to the next cell only if there is no text in the way. For example, 
pressing the right cursor key will move the cursor to the right within the text in the current 
cell, then to the next cell.

The Tab key moves directly to the next cell and, if the cursor is in the last cell in the table, 
creates a new row. Pressing Shift+Tab moves the cursor back a cell.

Tip To enter a Tab character as part of the text of the cell, press the Control and Tab 
keys at the same time.

Number recognition
If number recognition is turned on, when you type a number in a table, Writer aligns it to the 
right of the cell and strips off any trailing zeros. For example, 4.0 is changed to 4 and aligned 
to the right.

To turn number recognition on or off, right-click on the table and select Number 
Recognition in the pop-up menu.

Converting between table and text
Writer makes it easy for you to convert from a table to text (that is, replace a table with its 
data) or vice versa.

To convert plain text data into a table, select the data and then select Table > Convert > Text 
to Table from the main menu bar. In the Convert Text to Table dialog box, you must select 
the field delimiter (tab, paragraph marker, comma, or other printing or non-printing 
character) that Writer should use to divide data into different cells. Click OK to perform the 
conversion.

To convert from a table to plain text, select the table and then select Table > Convert > 
Table to Text. The data in the table will be converted to plain text with the field delimiter of 
your choice. Click OK to perform the conversion.
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Sorting data in a table
Just as in a spreadsheet, Writer allows data in a table to be sorted. Up to three levels of 
sorting can be specified (for example, sort first by age, then by name within each age).

To sort data in a table:

1) Select the table (or part of the table) to be sorted.

2) From the menu bar, select Table > Sort.

3) In the Sort dialog box:

• Decide whether you want to sort in the direction of rows or columns. The default 
sorting direction is by rows, which results in sorting the data in a column.

• Select up to three keys to sort on, in the correct order.

• For each key, select which column or row to sort on, whether the sort is Numeric 
or Alphanumeric and whether it is Ascending or Descending.

• Click OK to perform the sort.

Note You have to select all cells that might be affected by the sorting. For example, if 
you select only the cells of one column, the sort affects that column only, while the 
others remain unchanged. In such a case, you risk mixing the data of the rows.

Deleting, copying, and moving a table

Deleting a table
To delete a table:

1) Click somewhere in the table.

2) Select Table > Delete > Table from the main menu.

Or:

1) Select from the end of the paragraph before the table to the start of the paragraph after 
the table.

2) Press the Delete or the Backspace key.

Note The second method also merges the paragraph after the table with the paragraph 
before the table, which may not be what you want.
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Copying a table
To copy a table from one part of the document and paste it into another part:

1) Click somewhere in the table.

2) From the main menu select Table > Select > Table.

3) Press Control+C or click the Copy icon on the Standard toolbar.

4) Move the cursor to the target position and click on it to fix the insertion point.

5) Press Control+V or click the Paste icon in the Standard toolbar.

Moving a table
To move a table from one part of a document to another part:

1) Click somewhere in the table.

2) From the main menu, select Table > Select > Table.

3) Press Control+X or click the Cut icon in the Standard toolbar.

4) Move the cursor to the target position and click on it to fix the insertion point.

5) Press Control+V or click the Paste icon in the Standard toolbar.

6) Return to the original table, click somewhere in it and then select Table > Delete > 
Table from the main menu.

Using tables as a page layout tool

Tables may be used as a page layout tool to position text in a document instead of using tabs 
or spaces. For example, the Tips below are formatted as a table.

For more information and tips about using tables in page layout, see Chapter 4 (Formatting 
Pages).

Tips When inserting a table used for layout, you may wish to deselect the check boxes 
for Heading and Border (see Figure 270 on page 250).

To remove the borders from an existing table, right-click on the table, select Table 
from the pop-up menu, select the Borders tab (see Figure 276 on page 259), and 
select the icon for no borders.
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Using spreadsheet functions in a table

In a table in a Writer document, you can use some of the mathematical functions that are 
normally implemented by OpenOffice.org Calc. For many simpler functions, Writer tables 
can be used as a basic spreadsheet.

Just as in a spreadsheet, each table cell is identified by a letter (for the column) and a number 
(for the row). For example, cell C4 is the cell in the third column from the left and fourth row 
from the top. When the cursor is in a cell, this cell reference is displayed on the status bar (in 
its default position at the bottom right corner of the screen).

Tip Basic spreadsheet functions in tables are much the same as in OpenOffice.org Calc. 
The main difference is that cell references are formatted differently. Cell A2 (first 
column, second row) is referred to in Calc as A2 (or $A$2 for an absolute 
reference). In Writer tables, it is referred to as <A2>.

For example, suppose you had two numbers in cells <B1> and <C2> and wanted to display 
the sum of the two in cell <A1>, as shown in Figure 279.

Figure 279: Using spreadsheet functions in a table

Do the following:

1) Click in cell <A1> and press the = key. The Formula bar appears automatically, near 
the top of the screen. In the leftmost side of the bar, you can see the coordinates of the 
selected cell.

2) Click in cell <B1>. The identifiers of this cell are automatically displayed in the 
Formula bar and inserted into cell <A1>.

3) Press the + key.
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4) Click on cell <C2>. You can see the final formula = <B1>+<C2> displayed both in the 
selected cell and in the Object bar.

5) Press the Enter key or click the green tick (checkmark) on the Formula Bar.

Tip To display the list of the mathematical functions that you can use in a table:

1) Display the Formula toolbar by pressing F2 or select a blank cell and press the = 
key.

2) Click and hold the Formula f(x) icon.

In our example, this gives the result 9 in the top left cell. For contiguous cells, you can 
simply select the cells in the row, column, or the rectangle of rows and columns. Thus, for 
example, to add a column of numbers, do this:

1) Type an equals sign = in an empty cell.

2) Select the cells to be added together—in this case the cells from A2 to A5. The 
formula should be something like =<A2:A5>.

3) Press the Enter key or click the green tick (checkmark) on the Formula Bar.

4) The answer appears in the cell you have selected.

When using a function, you can enter the cells manually or by selecting them. Thus, to add 
up the four numbers that we added above (A2, A3, A4, A5), do this:

1) Type an equals sign = in an empty cell.

2) Type sum or select it from the function list f(x).

3) Select the cells to be added together. The formula should be something like 
=sum<A2:A5>.

4) Press the Enter key or click the green tick (checkmark) on the Formula Bar.

5) The answer appears in the cell you have selected.
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Introduction

A template is a model that you use to create other documents. For example, you can create a 
template for business reports that has your company’s logo on the first page. New documents 
created from this template will all have your company’s logo on the first page.

Templates can contain anything that regular documents can contain, such as text, graphics, a 
set of styles, and user-specific setup information such as measurement units, language, the 
default printer, and toolbar and menu customization. 

All documents in OpenOffice.org (OOo) are based on templates. If you do not specify a 
template when you start a new Writer document, the document is based on the default 
template for text documents. If you have not specified a default template, Writer uses the 
blank template for text documents that is installed with OOo. See “Setting a default
template” on page 278 for more information.

This chapter shows you how to:

• Use a template to create a document.

• Create a template.

• Edit a template.

• Set a default template.

• Organize templates.

Using a template to create a document

To use a template to create a document:

1) From the main menu, choose File > New > Templates and Documents. The 
Templates and Documents dialog box opens. (See Figure 280.)

2) In the box on the left, click the Templates icon if it is not already selected. A list of 
template folders appears in the center box.

3) Double-click the folder that contains the template that you want to use. A list of all the 
templates contained in that folder appears in the center box.

4) Click the template that you want to use. You can preview the selected template or view 
the template’s properties:

• To preview the template, click the Preview icon. (For the location of the Preview 
icon, see Figure 280.) A preview of the template appears in the box on the right.

• To view the template’s properties, click the Document Properties icon. (For the 
location of the Document Properties icon, see Figure 280.) The template’s 
properties appear in the box on the right.
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5) Click Open. The Templates and Documents dialog box closes and a new document 
based on the selected template opens in Writer. You can then edit and save the new 
document just as you would any other document.

Figure 280. Templates and Documents window

Creating a template

You can create your own templates in two ways:

• From a document

• Using a wizard

Creating a template from a document
To create a template from a document:

1) Open a new or existing document you want to make into a template.

2) Add the content and styles that you want.

3) From the main menu, choose File > Templates > Save. The Templates dialog box 
opens (see Figure 281).

4) In the New template field, type a name for the new template.
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5) In the Categories list box, click the category to which you want to assign the template. 
(The category is simply the template folder in which you want to save the template. 
For example, to save the template in the “My Templates” folder, click the My 
Templates category.)

To learn more about template folders, see “Organizing templates” on page 279.

6) Click OK. Writer saves the new template and the Templates dialog box closes. 

Note OOo 1.X used a “Default” folder in place of the 2.x “My Templates” folder.

Figure 281. Saving a new template

Any settings that can be added to or modified in a document can be saved in a template. For 
example, below are some of the settings (although not exhaustive) that can be included in a 
Writer document and then saved as a template for later use:

• Printer settings: which printer, single-sided or double-sided, paper size, etc.

• Styles to be used, including character, page, frame, numbering, and paragraph styles.

• Format and settings regarding indexes, tables, bibliographies, table of contents.

Creating a template using a wizard
You can use wizards to create these types of Writer templates:

• Letter

• Fax

• Agenda

For example, the Fax Wizard steps you through the following choices:

• Type of fax (business or personal)

• Document elements like the date, subject line (business fax), salutation, and 
complimentary close
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• Options for sender and recipient information (business fax)

• Text to include in the footer (business fax)

To create a template using a wizard:

1) From the main menu, choose File > Wizards > type of template required (Figure 282).

Figure 282: Creating a template using a wizard

2) Follow the instructions on the pages of the wizard. This process is slightly different for 
each type of template, but the format is similar for all of them.

3) In the last section of the wizard, you can specify the name and location for saving the 
template. The default location is your user templates directory, but you can choose a 
different location if you prefer. 

4) Finally, you have the option of creating a new document from your template 
immediately, or manually changing the template. For future documents, you can re-use 
the template created by the wizard, just as you would use any other template.

Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the 
template’s styles to documents that were created from that template. 

Note You can only reapply styles. You cannot reapply content.

To edit a template:

1) From the main menu, choose File > Templates > Organize. The Template 
Management window opens (see Figure 283).
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Figure 283. Template management window

2) In the box on the left, double-click the folder containing the template that you want to 
edit. A list of all the templates contained in that folder appears underneath the folder 
name.

3) Click the template that you want to edit.

4) Click the Commands button. 

5) From the drop-down menu, choose Edit. The Template Management window closes 
and the selected template opens in Writer.

6) Edit the template just as you would any other document. To save your changes, choose 
File > Save from the main menu.

The next time that you open a document that was created from the changed template, the 
following message appears.

Figure 284. Apply current styles message 

Click Yes to apply the template’s changed styles to the document. Click No if you do not 
want to apply the template’s changed styles to the document. Whichever option you choose, 
the message box closes and the document opens in Writer.
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Note Automatic updating from a template did not work in OOo2.0.2. This bug was fixed 
in OOo 2.0.3. To re-enable updating in files created using OOo 2.0.2:

1) Use Tools > Macros > Organize Macros > OpenOffice.org Basic. Select the 
document from the list, click the +, and select Standard. If Standard has a + 
beside it, click that and select a module.

2) Name the macro. For example, you could call it FixDocument. If the Edit button is 
active, click it. If the Edit button is not active, click New, type a module name in 
the pop-up dialog, and click OK.

3) In the Basic window, enter the following:
Sub FixDocument
TemplateName = ThisComponent.DocumentInfo.Template
  if TemplateName <> "" then
  ThisComponent.DocumentInfo.Template = TemplateName
  end if
End Sub

4) Click the Run BASIC icon, then close the Basic window.

5) Save the document.

Next time when you open this document you will have the update from template 
feature back.

Adding templates with Extension Manager

A new feature in OOo 2.0.4 was the Package Manager, called the Extension Manager in OOo 
2.1. This feature provides an easy way to install collections of templates, graphics, macros, or 
other add-ins that have been “packaged” into files with a .OXT extension.

1) After you download a package, select Tools > Extension Manager from the menu bar. 
In the Extension Manager dialog (Figure 285), click Add.

Figure 285: Installing a package of templates
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2) A file browser window opens. Find and select the package of templates you want to 
install and click Open.

3) On the Extension Manager dialog (Figure 286), select the package you just added and 
click Enable.

Figure 286: Enabling a newly-added package of templates

Setting a default template

If you create a document by choosing File > New > Text Document from the main menu, 
Writer creates the document from the Default template. You can, however, set a custom 
template to be the default. You can reset the default later if you choose.

Setting a custom template as the default
You can set any template to be the default, as long as it is in one of the folders displayed in 
the Template Management window. 

To save a template in one of these folders, do one of the following:

• Create and save the template as described in “Creating a template” on page 273.

• Import the template into the desired folder as described in “Importing a template” on 
page 280.

To set a custom template as the default:

1) From the main menu, choose File > Templates > Organize. The Template 
Management window (Figure 283) opens.

2) In the box on the left, double-click the folder that contains the template that you want 
to set as the default.
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3) Click the template that you want to set as the default.

4) Click the Commands button. 

5) From the drop-down menu, choose Set as Default Template. The next time that you 
create a document by choosing File > New > Text Document, the document will be 
created from this template.

Resetting Writer’s Default template as the default
To reset Writer’s Default template as the default:

1) From the main menu, choose File > Templates > Organize. The Template 
Management window (Figure 283) opens.

2) In the box on the left, click any folder.

3) Click the Commands button.

4) From the drop-down menu, choose Reset Default Template > Text Document. The 
next time that you create a document by choosing File > New > Text Document, the 
document will be created from Writer’s Default template.

Organizing templates

Writer can only use templates that are in OOo template folders. You can, however, create new 
OOo template folders and use them to organize your templates. For example, you might have 
one template folder for report templates and another for letter templates. You can also import 
and export templates. 

To begin, choose File > Templates > Organize from the main menu. The Template 
Management window (Figure 283) opens.

Creating a template folder
To create a template folder:

1) In the Template Management window, click any folder.

2) Click the Commands button. 

3) From the drop-down menu, choose New. A new folder called Untitled appears.

4) Type a name for the new folder, and then press Enter. Writer saves the folder with the 
name that you entered.

5) To close the Template Management window, click Close.
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Deleting a template folder
To delete a template folder:

1) In the Template Management window, click the folder that you want to delete.

2) Click the Commands button. 

3) From the drop-down menu, choose Delete. A dialog box appears and asks you to 
confirm the delete.

4) Click Yes. The dialog box closes and the selected folder is deleted.

Moving a template
To move a template from one template folder to another template folder:

1) In the Template Management window, double-click the folder that contains the 
template that you want to move. A list of all the templates contained in that folder 
appears underneath the folder name.

2) Click the template that you want to move and drag it to the desired folder.

Deleting a template
To delete a template:

1) In the Template Management window, double-click the folder that contains the 
template that you want to delete. A list of all the templates contained in that folder 
appears underneath the folder name.

2) Click the template that you want to delete.

3) Click the Commands button.

4) From the drop-down menu, choose Delete. A dialog box appears and asks you to 
confirm the delete.

5) Click Yes. The dialog box closes and the selected template is deleted.

Importing a template
If the template that you want to use is in a different location, you must import it into an OOo 
template folder.

Tip When you download a template from a website or CD, you can save it anywhere on 
your computer and then import it into OOo as described here. 

To import a template into a template folder:

1) In the Template Management window, double-click the folder into which you want to 
import the template.

280 Chapter 10  Working with Templates



Organizing templates

2) Click the Commands button.

3) From the drop-down menu, choose Import Template. The Open dialog box opens.

4) Find the template that you want to import and click Open. The Open dialog box closes 
and the template appears in the selected folder. 

5) If you want, type a new name for the template, and then press Enter.

Exporting a template
To export a template from a template folder to another location:

1) In the Template Management window, double-click the folder that contains the 
template that you want to export. A list of all the templates contained in that folder 
appears underneath the folder name.

2) Click the template that you want to export.

3) Click the Commands button.

4) From the drop-down menu, choose Export Template. The Save dialog box opens.

5) Find the folder into which you want to export the template and click Save. Writer 
exports the template to the selected folder, and the Save dialog box closes.

Note All the actions made by the Commands button in the Template Management window 
can be made as well by simply right-clicking on the templates or the folders.
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What is mail merge?

OpenOffice.org (OOo) Writer provides very useful features to create and print:

• Multiple copies of a document to send to a list of different recipients (form letters)

• Mailing labels

• Envelopes

All these facilities, though different in application, are based around the concept of a 
registered “data source”, from which is derived the variable address information necessary to 
their function.

This chapter describes the entire process. The steps include:

1. How to create and register a data source.

2. How to create and print form letters, mailing labels, and envelopes.

3. Optionally, how to save the output in an editable file instead of printing it directly.

Creating the data source

A data source is a database containing the name and address records (and optionally other 
information) from which a mailing list may be derived. Although you can create and print 
mailing labels and envelopes without using a data source, in most cases using one is the best 
approach. This chapter assumes that you are using a data source.

OOo can access a wide variety of data sources, including spreadsheets, text files and 
databases such as MySQL, Adabas, and ODBC. If the information to be used in the mail 
merge is currently in a format that OOo cannot access directly, you need to convert it, for 
example by exporting it to a comma-separated values (CSV) file.

For the following example we use a spreadsheet with the following column (field) headers: 
Title, First name, Last name, Address, State/County, Country, Post Code, Sex, Points. A 
sample data source is shown in Figure 287.

Figure 287: Spreadsheet data source
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Registering a data source

For a data source to be directly accessible from within an OOo document, it must first be 
registered as described below.

1) Click File > Wizards > Address Data Source.

Figure 288: Starting the Address Data Source wizard

2) Select the appropriate type of external address book (in this case, Other external data 
source). Click Next.
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Figure 289: Select type of external address book

3) On the next page of the Wizard (Figure 290), click Settings.

Figure 290: Starting the Settings part of the Wizard
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4) In the Data Source Properties dialog (Figure 291), select the Database type (in this 
case, Spreadsheet). Click Next.

Figure 291: Selecting the database type

5) In the next dialog (Figure 292), click Browse and navigate to the spreadsheet that 
contains the address information. Select the spreadsheet and click Open to return to 
this dialog. At this time you may wish to test that the connection has been correctly 
established by clicking on the Test Connection button.

Figure 292: Selecting the spreadsheet document

6) Click Finish.

7) In the following dialog (Figure 293), click Next. (Do not click Field Assignment.)
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Figure 293: Because this is a spreadsheet, do not click Field Assignment.

8) Name the file in the Location field. The default is ...\Addresses.odb; but you may 
replace Addresses with another name if you wish. You may also change the name in 
the “Address book name” field. In our example, the name “Points” was used for both.

Figure 294: Name the .odb file and the address book. 

9) Click Finish. The data source is now registered.
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Creating a form letter

Example: Sending a letter to your customer base

A mail order company organized a campaign to assign credit points to their 
customers according to the quantity of goods they buy during one year.

At the end of the year, they want to send a letter to each customer to show the total of 
credit points collected.

You can create a form letter manually, which is the simplest and most comprehensive method 
and is described here, or you can use the Mail Merge wizard as described in “Using the Mail
Merge Wizard to create a form letter” starting on page 304. If you elect to use the wizard, pay 
close attention to its current (OOo V2.3) limitations, as identified within its description.

1) Create a new text document: File > New > Text Document, or open a pre-existing 
form letter with File Open.

2) Display the registered data sources: View > Data sources (or press F4).

3) Find the data source that you wish to use for the form letter, in this case Points. 
Expand the Points and Tables folders, and select Sheet1. The address data file is 
displayed. (See Figure 295.)

Figure 295: Selecting the data source.

4) Now create or modify the form letter by typing in text, punctuation, line breaks, and so 
on that will be present in all of the letters, and adding fields where needed by clicking 
in the field heading and dragging to the appropriate point in the letter. (See Figure
296.)

Note that address lines should be in individual paragraphs, not separated by line 
breaks as might seem preferable. The reason for this will be made clear in the next 
paragraph.
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Figure 296: Dragging fields to the body of the form letter

5) Continue until you have composed the entire document. (See Figure 297 for an 
example.) At this time you may wish to consider suppressing any blank lines that may 
appear in the resulting letters. If not, skip ahead to Step 7.

Figure 297: The completed form letter
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6) To suppress blank lines:

a) Click at the end of the first paragraph to be suppressed and then select 
Insert > Fields > Other. 

b) Select the Functions tab and then click on Hidden Paragraph in the Type column.

c)  Now click in the Condition box and enter the details of the condition that defines 
a blank address field. It has the general form of:
![Database.Table.Database field]
where the ‘!’ (NOT) character indicates the negative case and the square brackets 
delineate the condition.

For example, in our Points database the condition to test if the Last Name field is 
empty would be:
![Points.Sheet1.Last Name] as illustrated in Figure 304

d) To test for multiple conditions use the operators AND and/or OR between the 
conditional statements, for example:
![Points.Sheet1.Title]AND![Points.Sheet1.Last Name].

e) Click Insert, but do not close the dialog until all lines have been amended.

7) The document is now ready to be printed. Click File > Print and respond with Yes in 
the resulting dialog.

Figure 298: Mail Merge advisory dialog

8) In the Mail Merge dialog (Figure 299), you can choose to print all records or selected 
records. To select records to be printed, use Ctrl+click to select individual records. To 
select a block of records, select the first record in the block, scroll to the last record in 
the block, and Shift+click on the last record.
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Figure 299: The Mail Merge dialog

9) Click OK to send the letters directly to the printer.

If you prefer to save the letters to a file, perhaps to allow proofreading or some later 
editing such as changing the typeface or paragraph format, then you should select File 
in the output section of the Mail Merge dialog, instead of using the default Printer 
selection. This changes the dialog to display the Save merged document section, where 
Save as single document is pre-selected. You can choose to save each letter as a 
single, individual document, if preferred.

In this case, clicking OK brings up the Save as dialog (Figure 300), where a file name 
can be entered for the saved letters. They will be saved consecutively in the single 
document, or numbered consecutively in individual files if saved as single documents.

If you have not saved the original, prototype form letter document (template) 
previously, then you will be prompted to do so now by another Save as dialog. This 
could greatly simplify the creation of other form letters in the future and is highly 
recommended.
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Figure 300: Mail Merge Save as dialog

Printing mailing labels

Before beginning this process, note the brand and type of labels you intend to use.

To print mailing labels:

1) Click File > New > Labels.

2) On the Options tab, ensure that the Synchronise contents checkbox is selected.

3) On the Labels tab (Figure 301), select the Database and Table. Select the Brand of 
labels to be used, and then select the Type of label.

Tip If the type of label you wish to use is not on the list, you need to use the Format tab 
to define a new Brand and Type. This is beyond the scope of this document, but is 
relatively simple to implement, given knowledge of the dimensions of the label .
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Figure 301: Select Database, Table, label Brand, and label Type.

4) Click the dropdown arrow under Database field. Select the first field to be used in the 
label (in this example, Title). Click the left arrow button to move this field to the 
Label text area (Figure 302).

Figure 302: Move fields from Database field list to Label text area.

5) Continue adding fields and inserting desired punctuation, spaces, and line breaks until 
the label is composed. Figure 303 shows the completed label.
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Figure 303: The completed label.

6) Click New Document. You now have a new, single-page document containing a series 
of frames, one for each label of the selected type and filled with the data source 
address fields that you selected. Quite often some of the fields in your address data 
source will be unused, leading to blank lines in your labels. If this is not important, 
you can skip the next few paragraphs and go straight to Step 7, otherwise continue as 
described here.

a) First ensure that the label frames are showing the field contents (data source 
headings), rather than their underlying field names. If this is not the case, then 
either press Ctrl+F9 or select View>Field Names to toggle the view.

b) Next, ensure that you can see non-printing characters, such as paragraph marks, 
line breaks and so on. If these are not already visible, select View > 
Nonprinting Characters from the menu bar, or press Ctrl+F10, or click on the 
paragraph icon  in the Standard toolbar.

You will now see that address field separation is created by line breaks , rather 
than paragraphs . As the suppression of blank address fields depends on hiding 
paragraphs, not lines, you need to replace line breaks with paragraphs as follows.

c) Click in the first label, at the end of the first data source address field. Press Delete 
to remove the new line and then press Return (or the Enter key) to insert a 
paragraph. Repeat this action for each data source address field.
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If the line spacing in the first label is not satisfactory, you may wish to correct this 
before proceeding, by modifying the paragraph style associated with the address. 
Unless you have changed it, the address uses the Default style.

Caution The objective of step c) is to replace all line breaks at the end of data source address 
fields with paragraphs. Sometimes the address data field may be longer than the 
width of the label and will wrap to the next physical line: make sure that you are not 
misled by this into deleting and replacing anything other than line break characters.

d) Click again at the end of the first paragraph to be suppressed and then select Insert 
> Fields > Other. Select the Functions tab and then click on Hidden Paragraph in 
the Type column. Now click in the Condition box and enter the details of the 
condition that defines a blank address field. It has the general form of:
![Database.Table.Database field]
where the ‘!’ (NOT) character indicates the negative case and the square brackets 
delineate the condition.

For example, in our Points database the condition to test if the Last Name field is 
empty would be ![Points.Sheet1.Last Name] as illustrated in Figure 304.

To test for multiple conditions, use the operators AND and/or OR between the 
conditional statements, for example:
![Points.Sheet1.Title]AND![Points.Sheet1.Last Name].

Click Insert, but do not close the dialog until all lines have been amended.

Figure 304: Hidden paragraph insertion
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e) Repeat for each paragraph to be conditionally suppressed, remembering to advance 
the cursor to the end of the line in question before changing the last element of the 
condition and Inserting the result.

Caution The last paragraph of the label address block ends with a special field, 
Next record:Database.Table (Next record:Points.Sheet1 in our example), and the 
Hidden paragraph field MUST be inserted before this field. This can generally be 
accomplished by clicking at the end of the paragraph and then using the Left Arrow 
key once to skip back over it.

A clue that you omitted this action is the observation that some records have been 
skipped and are missing from the final output.

f) Remembering that we selected Synchronise 
contents earlier, you should now be able to see a 
small window containing a button labelled 
Synchronise Labels. Click on this button and 
the hidden paragraph fields are propagated to all the labels in your document.

You now have a template suitable for future use with the same data source and 
type of label. If you wish to save it, use either File > Templates > Save as, or 
save it as an Open Document Text Template (.ott) into the private template 
directory (folder) that you have previously defined in 
Tools > Options > OpenOffice.org > Paths > Templates.

7) Click File > Print. The following dialog appears. Click Yes.

Figure 305: Mail Merge advisory dialog

8) In the Mail Merge dialog (Figure 306), you can choose to print all records or selected 
records. To select records to be printed, use Ctrl+click to select individual records. To 
select a block of records, select the first record in the block, scroll to the last record in 
the block, and Shift+click on the last record.
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Figure 306: Mail Merge dialog

9) Click OK to send the labels directly to the printer.

If you prefer to save the labels to a file, perhaps to allow some later editing such as 
changing the typeface or paragraph format, then you should select File in the output 
section of the Mail Merge dialog, rather than using the default Printer selection. This 
changes the dialog to highlight the Save merged document section, where Save as 
single document is pre-selected.

In this case, clicking OK brings up the Save as dialog shown in Figure 300, where a 
file name can be entered for the saved labels.

If you did not save the prototype label fields document (template) in step 6f, then you 
are prompted to do so now by another Save as dialog.

In either case, whether printing or saving to file, despite there apparently being only one page 
of labels, the printed or saved output will be expanded to include all of the selected records 
from the data source.

Editing a saved file of mailing labels
To edit a saved file of mailing labels, open the saved label 
file in the normal way. You will be prompted as to whether 
you wish to update all links. Choose No for the following 
reason: The first label on the page is termed the “Master 
Label” and all other labels are linked to it: if you update the 
links then all labels will end up containing the same data, 
which may not be what you want.
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You can edit individual records in the normal way, by 
highlighting and changing the font name, for example.

However, you cannot edit all labels globally (for example, to 
change the font name for all records) by the technique of 
selecting the entire document. To achieve this result you have to 
edit the paragraph style associated with the label records as 
follows:

1) Right-click any correctly spelled word in a label record. 
Select Edit Paragraph Style from the pop-up menu. 
(Note: If you click on a misspelled word, a different menu 
appears.)

2) Then from the Paragraph Style dialog, you can make 
changes to the font name, the font size, the indents, and 
other attributes.

Printing envelopes

Instead of printing mailing labels, you may wish to print directly onto envelopes. There are 
two basic ways to create envelopes, one where the envelope is embedded within a letter, 
generally as the first page (Insert in the Envelope dialog), and another where the envelope is 
an independent document (New Doc. in the dialog). In each case the addressing data may be 
manually entered, for example by copying and pasting from the letter with which it is 
associated, or it may originate within an address data source.

This section assumes the use of an address data source and, for convenience, a free-standing 
envelope.

The production of envelopes involves two steps, set-up and printing, as described in this 
section.

Setting up envelopes for printing
1) Click Insert > Envelope from the menu bar.

2) In the Envelope dialog, select the Format tab (Figure 307), where you can select the 
envelope format to use. You can then arrange the layout of the envelope to suit your 
requirements, together with the character and paragraph attributes to be used in the 
Sender and Addressee areas. These attributes are accessed using the Edit buttons to 
the right of the dialog, next to the word Format.

Tip At this stage it is not possible to vary the dimensions of the frames that will hold the 
Sender and Addressee information, but once the envelope has been created this will 
become possible and you may wish to make some cosmetic adjustments.
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Figure 307: Envelope formatting dialog

3) The next step is to select the Printer tab (Figure 308), from where you may choose 
the printer you intend to use, its setup—for example, specification of the tray holding 
envelopes--and other printer-related options such as envelope orientation and shifting. 
You may need to experiment with these settings to achieve the best results with your 
printer.

4) You now have the choice of creating the Addressee fields by dragging and dropping 
from the data source headings (as described in “Creating a form letter” on page 289, 
and in particular in Figure 296) or using the facilities of the Envelope tab. 

If you prefer dragging and dropping, than click New Doc., drag your data source 
headings into the Addressee area on your new envelope and skip to step 7), otherwise 
continue with steps 5 and 6.

300 Chapter 11  Using Mail Merge



Printing envelopes

Figure 308: Choosing printer options for an envelope

5) Select the Envelope tab (Figure 309). Verify, add, or edit the information in the 
Addressee and Sender boxes (Sender is the “from” on the envelope). You can use the 
right-hand dropdown lists to select the database and table from which you can access 
the Addressee information, in a similar fashion to that described for “Printing mailing
labels”, paragraphs 3, 4 and 5 on page 293. The similarity of the method with Figure
302 and Figure 303 will be clear.

6) When you have finished formatting, click either the New Doc. or Insert button to 
finish. As might be expected, New Doc creates only the envelope template in a new 
document, whereas Insert inserts the envelope into your current document as page 1.

If you don’t want to proceed with this envelope, click Cancel or press the Esc key. 
You can also click Reset to remove your changes and return to the original settings 
extant when the dialog opened.
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Figure 309: Choosing addressee and sender information for envelopes

6) Quite often some of the fields in your address data source will be unused, leading to 
blank lines in your envelope Addressee area. If this is not important, you can skip the 
next few paragraphs and go straight to “Merging and printing the envelopes” on page 
303, otherwise continue as described here.

Tip The following procedure is very similar to that used for a similar purpose in the 
section on printing mailing labels. It is reproduced here for purposes of clarity.

a) First ensure that the envelope is showing the field contents (data source headings), 
rather than their underlying field names. If this is not the case, then either press 
Ctrl+F9 or select View > Field Names to toggle the view.

b) Next, ensure that you can see non-printing characters, such as paragraph marks, 
line breaks and so on. If these are not already visible, select View > 
Nonprinting Characters from the menu bar, or press Ctrl+F10, or click on the 
large paragraph icon  in the Standard toolbar.

You will now see that address field separation is created by line breaks , rather 
than paragraphs . As the suppression of blank address fields depends on hiding 
paragraphs, not lines, you need to replace line breaks with paragraphs as follows.

c) Click at the end of the first data source address field. Press Delete to remove the 
new line and then press Return (or the Enter key) to insert a paragraph. Repeat this 
action for each data source address field.
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If the line spacing in the Addressee area is not satisfactory, you may wish to 
correct this before proceeding, by modifying the paragraph style associated with 
the address. Unless you have changed it, the address uses the Default style.

Caution The objective of c) above is to replace all line breaks at the end of data source 
address fields with paragraphs. 

d) Click again at the end of the first paragraph to be suppressed and then select Insert 
> Fields > Other. Select the Functions tab and then click on Hidden Paragraph in 
the Type column. Now click in the Condition box and enter the details of the 
condition that defines a blank address field. It has the general form of:
![Database.Table.Database field]
where the ‘!’ (NOT) character indicates the negative case and the square brackets 
delineate the condition.

For example, in our Points database the condition to test if the Last Name field is 
empty would be: ![Points.Sheet1.Last Name] as illustrated in Figure 304.

To test for multiple conditions, use the operators AND and/or OR between the 
conditional statements, for example:
![Points.Sheet1.Title]AND![Points.Sheet1.Last Name].

Click Insert, but do not close the dialog until all lines have been amended.

e) Repeat for each paragraph to be conditionally suppressed, remembering to 
advance the cursor to the end of the line in question before changing the last 
element of the condition and Inserting the result.

Merging and printing the envelopes
To merge addresses and print the envelopes:

1) Choose File > Print. The following dialog appears. Click Yes.

Figure 310: Confirmation dialog for merging database fields

2) The Mail Merge dialog (Figure 311) appears. As with form letters and mailing labels, 
you can choose to print envelopes for one, several or all address records in the 
database. 
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3) Make your selections and then click OK to print direct to the printer. If you wish to 
check the envelopes before printing them, see Step 9) of “Creating a form letter” on 
page 292 for instructions.

Figure 311: Choosing records to use when printing envelopes

Using the Mail Merge Wizard to create a form 
letter

The recommended way to create a form letter is the manual method described in “Creating a
form letter“ on page 289. If however you prefer to use the Mail Merge wizard, the technique 
is described below.

Before starting you should note the following limitations, current in OOo V2.3:

• In Step 4 creating the salutation will only allow the sex-related Mr. and Mrs. It makes 
no allowance for Miss, nor does it permit sexless addressing such as Dr., or The Right 
Honourable.

• Still in Step 4, it is possible to bodge something like Dr. Crippen, but only by creating 
an impossible trigger for recognising a female recipient, such that the merge defaults 
to male. Of course one cannot have a prefix such as ‘Dear’ in this case and it has to be 
manually entered in Step 6.

• Again in Step 4, the General salutation is not editable and the default values are 
somewhat limited.

• In Step 5 the layout is idiosyncratic, with paragraph marks all over the place so as to 
space the address block frame and salutation. To create a professional looking 
document will require significant editing.
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If the above limitations are not a hindrance to you, then open a new document with 
File > New > Text Document and start the Mail Merge wizard using 
Tools > Mail Merge Wizard. The wizard opens, as shown in Figure 312.

Step 1: Select starting document
The wizard gives various options to select your starting document:

• Use the current document.

• Create a new document.

• Use a template.

• Use an existing document.

For the purposes of this description we assume that you opened a new text document. This 
will ensure that all the steps in the wizard are fully explored, although with experience you 
may find it more practical to use a draft you prepared earlier, which will allow skipping some 
steps.

Select Use the current document and click Next.

Figure 312:  Select starting document
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Step 2: Select document type
The wizard can produce letters or, if a Java Mail connection exists, email messages. You can 
see these options in Figure 313. In this example, we are producing a letter. Select Letter and 
click Next.

Figure 313:  Choose document type

Step 3: Insert address block
This is the most complex step in the wizard. In this step (Figure 314) you will do three 
things:

1) Tell the wizard which data source to use. The data source must be an existing file; in 
this example it is the “Points” spreadsheet created earlier. 

2) Select the address block to use in the document. This means choosing which fields 
appear (for example, whether the country is included) and how they look.

3) Make sure that the fields all match correctly. This is very important. For example, the 
wizard has a field called <Last Name>. If your spreadsheet has a column called 
“Surname”, you need to tell the wizard that <Last Name> and “Surname” are 
equivalent. This is described in “Matching the fields” on page 310.
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Figure 314: Insert address block

Selecting the data source (address list)

1) If the current address list, identified beneath the “Select Different Address List...” 
button in section 1, is not the one you wish to use click the button to open the Select 
Address List dialog (Figure 315) for choosing a data source.

2) If you have not already created the address list, you may click Create to do so now. 
This step will allow you to create a CSV (Comma Separated Values) file with a new 
list of address records.

If you already have an address list, as we have in the “Points” spreadsheet example, 
but which is not the one you wish to use, click Add and select the file in which it 
resides.

In each of the above cases a new data source will be created and registered.
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Figure 315: Select address list dialog

3) Select the address list and click OK to return to step 3 of the wizard. For this example, 
the preceding steps are all you need to do. The wizard can also exclude certain records; 
click Filter to choose them. 

Selecting the address block

1) In step 3 of the wizard (shown in Figure 314), look at section 2. This is where you 
select the address block to appear on the letter, and define its appearance and the fields 
it contains. The main page gives two examples. If neither of those is exactly what you 
want, click More to see more choices, in the Select Address Block dialog (shown in 
Figure 316).

2) The Select Address Block dialog offers six choices for the format of the address block 
(scroll down to see the last two choices). You can also optionally include or exclude 
the country (for example, only include the country if it is not England). The six 
formats provided are relatively common, but they might not exactly match your 
preference. If this is the case, select the address block that is closest to what you want 
and click Edit, which opens the New Address Block dialog.
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Figure 316: Select address block

3) In the New Address Block dialog (Figure 317), you can add or delete address elements 
using the arrow buttons on the left. To move elements around, use the arrow buttons 
on the right. For example, to add an extra space between first and last names in Figure
317, click <Last Name> and then click the right arrow button.

Figure 317: New address block
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Matching the fields

Finally, it is time to match the wizard’s fields with the spreadsheet fields, so that items like 
<Last Name> and “Surname” match correctly.

1) Look at section 3 of step 3 of the wizard (shown in Figure 314 on page 307). The box 
at the bottom displays one record at a time, using the address block format you 
selected. Use the right and left arrow buttons below that address box to step through 
the addresses, checking that they display correctly. Do not assume that all the records 
display correctly, just because one or two do. Check them all if you can, or at least a 
good proportion.

2) If the addresses do not display correctly (and they probably will not right away), click 
Match Fields. The Match Fields dialog opens, as shown in Figure 318.

Figure 318: Match fields dialog

The Match Fields dialog has three columns.

• Address Elements are the terms the wizard uses for each field, such as <First 
Name> and <Last Name>.

• The Matches to Field column allows you to select, for each address element, 
the field from your data source that matches it.

• The Preview column shows what will be shown for this field from the selected 
address block, so you can double-check that the match is correct.
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3) When you have matched all the fields, click OK to return to step 3 of the wizard. Now, 
when you use the arrow buttons to look at all the addresses, they should all look 
correct. If not, go back and change anything you’re not happy with, before clicking 
Next to move to step 4.

Note that you will not be able to continue until you have correctly matched all the 
fields in your chosen address block. If you see <not available> in a field position it 
indicates that the field in question is not correctly matched.

Step 4: Create salutation
The salutation is the initial greeting, for example, Dear Mr Jones. In step 4, select the 
salutation that will appear in the letter.

Figure 319: Create a salutation

You can use a different greeting for men and women. To do this, Writer must have some way 
of knowing whether a person is male or female. In our spreadsheet we had a column called 
Sex. In the section Address list field indicating a female recipient, set the field name to Sex 
and the field value to F. The male salutation is then printed for all men and the female 
salutation for all women.

Note You do not need to tell OOo who is a male, because it assumes that all non-female 
records are males.
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If you do not select Insert Personalized Salutation, you can use a more general salutation 
without referring to the recipient directly, such as “To whom it may concern”.

As in step 3, step 4 of the wizard has a preview pane at the bottom. You should check more 
than one record to ensure that other records look the way you expect.

Step 5: Adjust layout
In step 5, you can adjust the position of the address block and salutation on the page. You can 
place the address block anywhere on the page. The salutation is always on the left, but you 
can move it up and down the page. Use the buttons shown in Figure 320 to move the 
elements.

A point to note here is that the address block positional dimensions are shown in the Metric 
system, irrespective of the chosen measurement system in the rest of OOo. This is a reported 
error in V2.3.

Figure 320: Adjust layout
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Step 6: Edit document and insert extra fields
In step 6 you have another opportunity to exclude particular recipients from the mail merge, 
as shown in Figure 321.

Figure 321: Edit document

You can also edit the body of the document. If you started with a blank document, you can 
write the whole letter in this step. Click Edit Document to shrink the wizard to a small 
window (Figure 322) so you can easily edit the letter.

Figure 322: Minimized mail merge wizard

You need to perform another important task in this step. The wizard only inserts information 
from the name and address fields, but you may wish to add additional data. In our example, 
we want to tell each person how many points they had accumulated during the year; that 
information is in the spreadsheet. 
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To do this:

1) Click Edit Document in step 6 of the wizard.

2) Select Insert > Fields > Other. The Fields dialog opens, as shown in Figure 323.

Figure 323: Insert mail merge fields dialog

3) Click the Database tab.

4) On the left hand side, select Mail merge fields.

5) Under Database selection find your data source (in this example, it is a spreadsheet). 
Expand it to see the fields.

6) Click the field you want to insert, then click Insert to insert the field.

You can insert any number of fields any number of times into your mail merge 
document.

7) Click Close when you are done.

Note The Database selection lists the data source you selected in step 3. All the 
information you need for the letter must be contained in that data source.
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Step 7: Personalize documents
In step 7, OOo creates all your letters, one per recipient.

Clicking the Edit individual Document button here is similar to step 6. The difference is 
that you now edit a long file containing all of the letters, so you can make changes to a 
particular letter to one person. In this step of the Mail Merge wizard (Figure 324), click Find 
to open a dialog that allows searches within the document, perhaps for an individual 
addressee.

Figure 324: Personalize document

As with step 6, when editing the document, the wizard shrinks to small window. Click on this 
window (see Figure 322 on page 313) to expand the wizard to its full size.
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Step 8: Save, print or send
You have now completed the mail merge process. The last step is to do something with it. In 
step 8, you can save the original sample letter, save the merged document, print the letters 
right away or, if you created email messages, send them.

Figure 325: Save,print or send

You probably want to save the starting (prototype) document and the merged document. To 
do this, select Save starting document  to reveal the Save starting document section 
containing the Save starting document button. This button will be active only if the 
document has not already been saved. Clicking on this button brings up the standard Save as 
dialog. Once you have named and saved the document you return to the Step 8 dialog as 
shown in Figure 326.

The merged document can now be saved by selection of Save merged document. This will 
reveal the Save merged document settings section, from which you can select to save either 
as one large file containing all the individual, generated letters or as a separate file for each 
letter.

When you have saved the merged document, you can print the final letters now or later; and 
you can still manually check and edit the letters if necessary. If you elect to print at this stage, 
the dialog shown in Figure 327 appears; it should be self-explanatory.
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Figure 326: Step 8: Save, print or send

Figure 327: Printing the merged document
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Introduction

Introduction

This chapter shows you step-by-step how to create and maintain a table of contents, an index, 
and a bibliography for a text document using OpenOffice.org Writer. To understand the 
instructions, you need to have a basic familiarity with Writer and styles.

Creating a table of contents

Writer’s table of contents feature lets you build an automated table of contents from the 
headings in your document. Before you start, make sure that the headings are styled 
consistently. For example, you can use the Heading 1 style for chapter titles and the Heading 
2 and Heading 3 styles for chapter subheadings.

This section shows you how to:

• Create a table of contents quickly, using the defaults.

• Customize a table of contents.

Note You can use custom styles for the different levels in the table of contents as well. 
This document uses the default styles for simplicity.

Creating a table of contents quickly
Although tables of contents can be customized extensively in Writer, most of the time you 
will probably find the default to be fine. Creating a quick table of contents is simple:

1) When you create your document, use the following paragraph styles for different 
heading levels (such as chapter and section headings): Heading 1, Heading 2, and 
Heading 3. These are what will appear in your table of contents. You can use more 
levels of headings, but the default setting is to use only the first three levels in the 
table of contents. It could look like Figure 328 if you used the default styles.

2) Place the cursor where you want the table of contents to be inserted.

3) Select Insert > Indexes and Tables > Indexes and Tables.
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Figure 328: Headings example

4) Change nothing in the Insert Index/Table dialog box (Figure 330). Click OK. The 
result will look like Figure 329.

Figure 329: Table of contents example
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If you add or delete text (so that headings move to different pages) or you add, delete, or 
change headings, you need to update the table of contents. To do this:

1) Place the cursor within the table of contents.

2) Right-click and select Update Index/Table from the pop-up menu.

Note If you cannot place your cursor in the table of contents, choose Tools > Options > 
OpenOffice.org Writer > Formatting Aids, and then select Enable in the Cursor 
in protected areas section.

Tip You can customize an existing table of contents at any time. Right-click anywhere 
in it and select Edit Index/Table from the pop-up menu. Continue as described in 
the next section, “Customizing a table of contents”.

Customizing a table of contents
To insert a customized table of contents into your document:

1) Place the cursor where you want to insert the table of contents.

2) From the main menu, choose Insert > Indexes and Tables > Indexes and Tables. 
The Insert Index/Table dialog box opens.

Figure 330. Index/Table page of Insert Index/Table dialog box
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The Insert Index/Table dialog box (Figure 330) has five pages. Any or all of them can be 
used when creating or editing a table of contents:

• Use the Index/Table page to set the attributes of the table of contents.

• Use the Entries and Styles pages to format the entries in the table of contents.

• Use the Columns page to put the table of contents into more than one column.

• Use the Background page to add color or a graphic to the background of the table of 
contents.

You can display a preview box, located on the left-hand side of each tab, to show as you 
work how the table of contents will look. (If you do not see the preview box, select the 
Preview checkbox in the lower right-hand corner of the dialog box.) The illustrations in this 
chapter show the dialog box as it appears with the preview box hidden.

After making all your changes, click OK to save the table of contents so it appears in your 
document.

Using the Index/Table page
Use the Index/Table page, pictured in Figure 330, to set the attributes of the table of contents.

Adding a title

To give the table of contents a title, type it in the Title field. (You can change an existing title 
by typing over it.) To delete the title, clear the Title field.

Setting the type of index

You can create several types of indexes. They include:

• Table of Contents

• Alphabetical Index

• Illustration Index

• Table of Objects

• Bibliography

You can also create user-defined indexes.

Note You can only change the type of index when you first create it. Once you define an 
index type (for example, make a table of contents) you cannot change the type.

Choosing the scope of the table of contents

From the for drop-down list in the Create index/table area, select Entire document. There is 
an additional option to create a table of contents for just the current chapter. For more 
information, refer to Help > OpenOffice.org Writer > Contents.
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Creating a table of contents from an outline

This selection creates the table of contents using outline levels; that is, paragraphs formatted 
with one of the predefined heading styles (Heading 1-10) are added to the table of contents in 
order.

Click on the (...) button next to the checkbox to change the numbering properties of the table 
of contents. This can be useful if you want to put numbers in front of each level of the 
contents, as in Figure 331.

Figure 331: Table of contents with numbers

Creating from index marks

This selection adds any index entries that you have inserted into the document by using 
Insert > Indexes and Tables > Entry. Normally you would not use this selection for a table 
of contents.

Protecting against manual changes

To stop the table of contents being changed accidentally, select the Protected against 
manual changes checkbox. If this box is checked, the table of contents can only be changed 
using the context menu or the Insert Table/Index dialog box. If the box is not checked, the 
table of contents can be changed directly on the document page, just like other text.

Tip Any manual changes to a table of contents are lost when you update it.

Changing the number of levels included

Writer displays a default setting of 10 levels of headings when it builds the table of contents 
(or the number of levels used in the document, whichever is smaller). To change the number 
of levels, enter the required number in the Evaluate up to level box.

Creating from additional styles

Writer automatically assigns to the table of contents all paragraphs formatted with the default 
heading styles (Heading 1, Heading 2, and so on). To assign paragraphs formatted with other 
styles, including custom styles:

1) In the Create from area, select the Additional Styles checkbox.

2) Click the (...) button to the right of the checkbox. The Assign Styles dialog box (Figure
332) opens.
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Figure 332. Assign Styles dialog box

3) In the Not applied column, click the style that you want to assign to the table of 
contents.

4) Use the >> button to move the selected style to the desired outline level. For example, 
to have paragraphs formatted with the selected style to appear as top-level entries in 
the table of contents, click the >> button once to move the style into the 1 column. To 
move the style in the opposite direction, use the << button.

5) Click OK to save your changes and return to the Index/Table tab or click Cancel to 
return without saving your changes.

Note If the Outline box is checked, any changes you make to the position of one of the 
predefined Heading styles will be superseded by the default outline structure.
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Using the Entries page
Use the Entries page, pictured in Figure 333, to define and format the entries in the table of 
contents. For each outline level, you can add and delete elements such as chapter (heading) 
numbers, and you can also apply character styles to individual elements.

Figure 333. Entries page of Insert Index/Table dialog box

To begin, click a level number in the Level column to select the outline level whose elements 
you want to format. (You will be able to apply changes to all outline levels later.) The 
Structure line displays the elements for entries in that level. Each button on the Structure line 
represents one element:

• The E# button represents the “chapter number”, which means the heading number, not 
just for chapters but also for other levels of headings.

• The E button represents the entry text.

• The T button represents a tab stop.

• The # button represents the page number.

• The LS button represents the start of a hyperlink. (This button does not appear on the 
default Structure line.)

• The LE button represents the end of a hyperlink. (This button does not appear on the 
default Structure line.)
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Each white field on the Structure line represents a blank space. You can add custom text if 
you desire.

Note On some operating systems, such as Windows XP, the E# and E buttons display as 
F# and F, and the LS and LE buttons display as IS and IF (the bottom of the 
displayed E or L character is cut off). This problem will be fixed in a future release 
of OpenOffice.org.

Note If the chapter number defined for your document includes the word “Chapter” 
before the number itself, then the E# field in the table of contents will also include 
the word “Chapter”. If you want to include the chapter number with the page 
number (for example, in the style “1-1, 1-2, ...”) , you will find that the page 
number appears in the table of contents as “Chapter 1-1”, which is probably not 
what you want.

Changing elements

To change an element in the Structure line, click the button representing that element and 
then click the element that you want to substitute in the row of buttons just below the 
Structure line. For example, to change a chapter number to a tab stop, click the E# button on 
the Structure line (it shows then as being pressed) and then click the Tab stop button in the 
row of available elements.

Deleting elements

To delete an element from the Structure line, click the button representing that element and 
then press the Delete key on your keyboard. For example, to delete a tab stop, click the T 
button and then press the Delete key.

Adding elements

To add an element to the Structure line:

1) Place the cursor in the white field to the left of where you want to insert the element.

2) Click one of the five buttons just below the Structure line. (For example, to add a tab 
stop, click the Tab stop button.) A button representing the new element appears on the 
Structure line.

Hyperlinking an entry

To change the default Structure line so that the chapter number and the entry text form a 
hyperlink, follow these steps:

1) On the Structure line, place the cursor in the white field to the left of the E# button. 

2) Click the Hyperlink button. An LS button, representing the start of the hyperlink, 
appears on the Structure line.

3) On the Structure line, place the cursor in the white field to the right of the E button. 

4) Click the Hyperlink button again. An LE button, representing the end of the 
hyperlink, appears on the Structure line.
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Figure 334 represents the completion of the above steps. The number and the text of the 
entries on that level will now be hyperlinks.

Figure 334: Hyperlink in table of contents

Applying character styles

To apply a character style to an element:

1) On the Structure line, click the button representing the element to which you want to 
apply a style.

2) From the Character Style drop-down list, select the desired style. Writer applies the 
selected style to the selected element.

To view or edit the attributes of a character style, select the style from the Character Style 
drop-down list and then click the Edit button.

Tip The default character style for hyperlinks is Internet Link, which by default is 
underlined and shown in blue. If you want the table of contents entries to work as 
hyperlinks, but not have them underlined and blue, you can change the attributes of 
the Internet Link character style. However, this changes the attributes of all 
hyperlinks in the document.

If you want other hyperlinks (for example, website addresses) to remain in the 
default style, change the character style selection for table of contents entries to 
Index Link (in Figure 334). If necessary, change the attributes for Index Link to 
what you want.
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Applying changes to all outline levels

To apply the displayed structure and formatting to all outline levels, click the All button.

Tab position relative to Paragraph Style indent

When this checkbox is selected, entries are indented according to the settings of their 
individual formats. Where a paragraph style with an indent on the left is in use, tab stops will 
be relative to this indent. If this checkbox is not selected, tab stops will be relative to the left 
margin position.

Using the Styles page
Use the Styles page, pictured in Figure 335, to apply paragraph styles to the table of contents. 
You can apply a different paragraph style to each outline level of the table.

Figure 335. Styles page of Insert Index/Table dialog box

To apply a paragraph style to an outline level:

1) In the Levels list box, select the desired outline level by clicking it.

2) In the Paragraph Styles list box, click the paragraph style to apply.

3) Click the < button to apply the selected paragraph style to the selected outline level.

The styles of the level appears in the square brackets in the Levels list.
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To remove paragraph styling from an outline level:

1) In the Levels list box, select the desired outline level by clicking it.

2) Click the Default button.

To view or edit the attributes of a paragraph style, click the style in the Paragraph Styles list 
box and then click the Edit button.

Note Changes to a paragraph style will affect any text in the document that is formatted 
using this style, not just the format of the table of contents.

Using the Columns page
Use the Columns page (Figure 336) to change the number of columns for the table of 
contents.

Figure 336. Columns page of the Insert Index/Table dialog box

Adding multiple columns

To display the table of contents in more than one column:

1) Either enter the number of columns desired in the box labeled Columns or select the 
icon representing the number of columns.
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2) To evenly distribute the columns according to the page width, check the AutoWidth 
box. If it is unchecked, you can manually set each of the following by altering the 
associated spin box:

• Width between each of the columns

• Spacing between each of the columns

3) You can choose to have a separator line between the columns:

• Line: The width of the line.

• Height: The height of the line.

• Position: Relative position of the line to the table (top, middle, or bottom) if the 
height is less than 100%.

Using the Background page
Use the Background page, pictured in Figure 337, to add color or a graphic to the background 
of the table of contents.

Adding color

To add color to the background of the table of contents, select from the color grid.

Note Even though the table of contents may have a shade behind it while editing, it is 
actually not shaded by default. It appears shaded because it is a field and will 
appear to have the same shading all fields have.

Figure 337. Background page of Insert Index/Table dialog box, showing Color choices
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Adding a graphic

To add a graphic to the background of the table of contents:

1) From the As drop-down list, select Graphic. The Background tab now displays the 
graphics options, as shown in Figure 338.

2) Click the Browse button. The Find graphics dialog box opens.

3) Find the graphic file you want and then click the Open button. The Find graphics 
dialog box closes and the selected graphic appears in the graphic preview box on the 
right-hand side of the Background tab. (If you do not see the graphic, select the 
Preview checkbox.)

4) To embed the graphic in your document, clear the Link checkbox. To link the graphic 
to the document but not embed it, select the Link checkbox.

5) In the Type area of the Background tab, choose how you want the background graphic 
to appear:

• To position the graphic in a specific location, select Position and then click the 
desired location in the position grid.

• To stretch the graphic to fill the entire background area, select Area.

• To repeat the graphic across the entire background area, select Tile.

Figure 338. Graphic options on the Background page of the Insert Index/Table dialog box
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Deleting color or graphics

To delete color or graphics from the table background:

1) From the As drop-down list, select Color.

2) Click No Fill on the color grid.

Maintaining a table of contents
This section shows you how to:

• Edit an existing table of contents.

• Update a table of contents when changes are made to the document.

• Delete a table of contents.

Editing a table of contents

To edit an existing table of contents:

1) Click anywhere in the table of contents and then right-click.

Tip If you cannot click in the table of contents, it is probably because it is protected. To 
disable this protection, choose Tools > Options > OpenOffice.org Writer > 
Formatting Aids, and then select Enable in the Cursor in protected areas section. 
If you wish to edit the table of contents without enabling the cursor, you can access 
it from the Navigator as explained on page 333.

2) From the pop-up menu, choose Edit Index/Table. The Insert Index/Table dialog box 
(Figure 330 on page 322) opens and you can edit and save the table as described in the 
previous section.

You can also access the Index/Table dialog box from the Navigator (Figure 339).

1) Open the Navigator (press F5).

2) Click the + sign next to Indexes.

3) Right-click on the desired index.

4) Select Index > Edit.

Updating a table of contents

Writer does not update the table of contents automatically, so after any changes to the 
headings, you must update it manually. To update a table of contents when changes are made 
to the document:

1) Click anywhere in the table of contents and then right-click.

2) From the pop-up menu, choose Update Index/Table. Writer updates the table of 
contents to reflect the changes in the document.
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Figure 339: Access an index from the Navigator

Note You can also update the index from the Navigator by selecting Index > Update 
from the menu in Figure 339.

Deleting a table of contents

To delete the table of contents from a document:

1) Click anywhere in the table of contents and then right-click.

2) From the pop-up menu, choose Delete Index/Table. Writer deletes the table of 
contents.

Note Writer will not prompt you to confirm the delete! Use caution when deleting a table 
of contents.

You can also delete the index from the Navigator by selecting Index > Delete from 
the menu shown in Figure 339.
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Creating an alphabetic index
An alphabetical index (referred to as an index) is a list of keywords or phrases used 
throughout a document that, if listed in order, may help the reader find information quickly. 
Generally an index is found in the back of book or document and lists several keywords or 
phrases in alphabetical order with page numbers.

This section describes how to:

• Add index entries.

• Create an alphabetic index quickly.

• Customize the display of index entries.

• View and edit existing index entries.

Adding index entries
Before you create an index, you must create some index entries.

1) Either highlight the word or phrase to add to the index or place the cursor at the 
beginning of the word or phrase. (If you want to add multiple words as one entry it 
will generally be better to highlight the entire phrase.)

2) Click Insert > Indexes and Tables > Entry to display a dialog box similar to that 
shown in Figure 340. You can accept the word or phrase shown in the Entry box or 
change it to whatever you want. If you placed the cursor at the beginning of a word, 
clicking on the Entry text box inserts the word into the text box.

3) Click Insert to create the entry.

Figure 340. Inserting an index entry

4) You can create multiple entries without closing the dialog box. For each one:

• Click at the location in the document that you want to index.

• Click again on the dialog box.

• Change the entry if needed, and click Insert.
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5) When you are satisfied with the entries, click Close.

Note If field shading is active (see Tools > Options > OpenOffice.org> Appearance > 
Text Document > Field shadings), when a selected word or phrase has been added 
to the index, it is shown in the text with a gray background. Index entries whose 
text is different from the text in the document are marked by a small gray rectangle.

Tip You can also open the Insert Index Entry dialog box by clicking the Entry icon on 
the Insert toolbar, as shown in Figure 341.

Figure 341. Entry icon on Insert toolbar

Creating an alphabetic index quickly
Now that there are index entries, you can create the index.

Although indexes can be customized extensively in Writer, most of the time you will need to 
make only a few choices. To create an index quickly:

1) Place the cursor where you want to add the index and click Insert > Indexes and 
Tables > Indexes and Tables.

2) In the Type box on the Index/Table page of the Insert Index/Table dialog box (Figure
342 on page 338), select Alphabetical Index.

3) In the Options section, you may want to uncheck the Case sensitive checkbox.

4) Click OK.

If you add, delete, or change the text of index entries, you need to update the index. Writer 
does not update an index automatically. To do this, follow the steps outlined in “Updating a
table of contents” on page 333.

Customizing index entries
Below is a brief explanation of the fields in the Insert Index Entry dialog box and how to use 
them.

• Index – The type of index this entry is for. The default is Alphabetical Index, but you 
can use this field to create extra entries for a table of contents or user-defined indexes 
or lists of almost anything. For example, you might want an index containing only the 
scientific names of species mentioned in the text, and a separate index containing only 
the common names of species. See “Creating and using other types of indexes” on 
page 342.

336 Chapter 12  Creating Tables of Contents, Indexes and Bibliographies



Creating an alphabetic index

• Entry – The word or phrase to be added to the selected index. This word or phrase 
does not need to be in the document itself; you can add synonyms and other terms that 
you want to appear in the index.

• 1st key – An index key is an index entry that has no associated page number and has 
several subentries that do have page numbers. Keys are useful ways of grouping 
related topics. (See “Example of using an index key” on page 337.)

• 2nd Key – You can have a three-level index, where some of the first-level keys have 
level-2 entries that are also keys (without page numbers). This degree of index 
complexity is not often necessary.

• Main entry – When the same term is indexed on several pages, often one of those 
pages has more important or detailed information on that topic, so it is the main entry. 
To make the page number for the main, or most important, entry stand out, select this 
checkbox and then define the character style for the page number of a main index 
entry to be bold, for example.

• Apply to all similar texts – Select this checkbox if you want Writer to automatically 
identify and mark any other word or phrase that matches the current selection. The 
Match case and Whole words only checkboxes become available if this checkbox is 
selected.

Example of using an index key

An index key is a primary entry under which subentries are grouped. For example, you might 
want to create a grouping similar to this:

OpenOffice.org
Writer...........5
Calc............10
Impress......15

In this example, OpenOffice.org is the 1st key. The subentries (with the page numbers 
showing) are the indexed entries. To insert an index entry for the topic Writer, on the Insert 
Index Entry dialog box (Figure 340 on page 335), type “Writer” in the Entry box and 
“OpenOffice.org” in the 1st key box.

Customizing the appearance of an index
The Insert Index/Table dialog box (Figure 342 on page 338) has five pages. Any or all of 
them can be used to customize the appearance of an index.

• Use the Index/Table page to set the attributes of the index.

• Use the Entries and Styles pages to format the entries in the index.

• Use the Columns tab to put the index into more than one column.

• Use the Background tab to add color or a graphic to the background of the index.

The preview box, located on the left-hand side of the dialog box, shows as you work how the 
index will look. (If you do not see the preview box, select the Preview checkbox in the lower 
right-hand corner of the dialog box.)
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After making your changes, click OK to save the index so it appears in your document.

Using the Index/Table page

Use the Index/Table page (Figure 342) to set the basic attributes of the index.

Figure 342. Index/Table page of Insert Index/Table dialog box

1) To give the Index a title, type it in the Title field. (You can change an existing title by 
typing over it.) To delete the title, clear the Title field.

2) To prevent the index from being changed accidentally, check the Protected against 
manual changes checkbox. If this box is checked, the index can only be changed 
using the context menu or the Insert Table/Index dialog box. If the box is not checked, 
the index can be changed directly on the document page, just like other text.

Tip Any manual changes to an index are lost when you update it.

3) From the drop-down list in the Create index/table area, select Entire document. You 
can also choose to create an index for just the current chapter. 

4) Various other options determine how the index handles entries:

• Combine identical entries. Defines how identical entries are dealt with. Normally 
each page number of an indexed word or phrase will be shown in the index; 
however these can be combined using the Combine identical entries with p or 
pp. If you want a page range displayed, select Combine with – (which will 
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produce something similar to 23–31). If you want different entries based on what 
letters are capitalized, select Case sensitive. 

• AutoCapitalize entries. Automatically capitalizes the first letter of each entry 
regardless of how they show within the document itself.

• Keys as separate entries. For the keys to have their own page numbers, select this 
option.

• Concordance file. Enables a list of words in an external file to be imported (select 
using the File button) and then used within the index. The concordance file has a 
special file format; for further information, refer to concordance file in Help > 
OpenOffice.org Help. Using a concordance file can speed up production of an 
index, but unless the words are very carefully selected and you edit the index 
afterwards, the resulting index can be full of entries for minor mentions of a term, 
making it less useful than a more selective index.

• Sort. Defines how the entries are sorted when displayed. The only option is 
alphanumeric, but you can define which language alphabet will be used.

Using the Entries page

Use the Entries page to set exactly how and what will be displayed for each of the entries. 
The dialog box is similar to Figure 343.

Figure 343. Entries page for creating an alphabetical index
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To begin, click a number in the Level column to select the index level whose elements you 
want to format. (You will be able to apply your changes to all index levels later.) The 
Structure line displays the elements for entries in that level. Each button on the Structure line 
represents one element:

• The E button represents the entry text.

• The T button represents a tab stop.

• The # button represents the page number.

• The CI button represents chapter information. This may not be displayed immediately, 
but can be added.

Each white field on the Structure line represents a blank space. You can add custom text if 
you desire.

Note On some operating systems, the E# and E buttons display as F# and F, and the LS 
and LE buttons display as IS and IF (the bottom of the E and L are cut off).  This 
problem will be fixed in a future release of OpenOffice.org.

Changing elements

To change an element in the Structure line, click the button representing that element and 
then click the element that you want to substitute in the row of buttons just below the 
Structure line. For example, to change entry text to a tab stop, click the E# button on the 
Structure line (it shows then as being pressed) and then click the Tab stop button in the row 
of available elements.

Deleting elements

To delete an element from the Structure line, click the button that represents that element and 
then press the Delete key on your keyboard. For example, to delete a tab stop, click the T 
button and then press the Delete key.

Adding elements

To add an element to the Structure line:

1) Place the cursor in the white field to the left of where you want to insert the element.

2) Click one of the buttons below the Structure line. (For example, to add a tab stop, click 
the Tab stop button.) A button representing the new element appears on the Structure 
line.

Applying character styles

Each of the items that can be added to the Structure line may have additional formatting. For 
example, you may want the page number to be a different size from the rest of the index text. 
To do this, apply a character style to one of the elements in the Structure line.

To apply a character style to an element:

1) On the Structure line, click the button representing the element to which you want to 
apply a style.
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2) Select the desired style from the Character Style drop-down list. Writer applies the 
style to the selected element.

To view or edit the attributes of a character style, select the style from the Character Style 
drop-down list and then click the Edit button.

Formatting entries

Apply additional formatting using the options in the Format section.

• Alphabetical delimiter. This will display, as a means of separating index entries, the 
first letter of all the subsequent index entries. For example:

A
apple,  4
author, 10

B
break,  2
bus, 4

• Key separated by commas. Arranges the entries in the index on the same line but 
separated by commas.

• Tab position relative to Paragraph Style indent. When checked, entries are indented 
according to the settings of their individual formats. Where a paragraph style with an 
indent on the left is in use, tab stops will be relative to this indent. If this checkbox is 
not selected, tab stops will be relative to the left margin position.

Using the Styles, Columns and Background pages

Refer to “Using the Styles page” on page 329, “Using the Columns page” on page 330, and 
“Using the Background page” on page 331.

Maintaining an index
To modify the appearance of an index:

1) Click anywhere in the index and then right-click.

2) From the pop-up menu, choose Edit Index/Table. The Insert Index/Table dialog box 
opens and you can edit and save the index using the five tabs described in the previous 
section.

To update or delete an index, follow the process described in the sections “Updating a table
of contents” and “Deleting a table of contents” on page 333.
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Viewing and editing existing index entries
Once you have added the initial entries, you can make some amendments or add some new 
ones. You can view and edit these using the following steps:

1) Ensure that field shading is active (Tools > Options > OpenOffice.org> Appearance 
> Text Document > Field shadings), so you can locate index entries more easily.

2) Place the cursor immediately to the left of an existing index entry in the body of your 
document and select Edit > Index Entry. Alternatively, right-click on the word or 
phrase and from the context menu select Index Entry.

3) A dialog box similar to Figure 344 appears. You can move through the various index 
entries using the forward and back arrow buttons. If there is more than one entry for a 
single word or phrase, then you can scroll through each of the entries.

4) Make the necessary modifications or additions to the index entries and, when finished, 
click OK.

Figure 344. Viewing and editing index entries

Creating and using other types of indexes

An alphabetical index is not the only type of index that you can build with Writer. Other 
types of indexes supplied with Writer include those for illustrations, tables, and objects, and 
you can even create a user-defined index. For example, you might want an index containing 
only the scientific names of species mentioned in the text, and a separate index containing 
only the common names of species. 

To create other indexes:

1) Place the cursor where you want the index created.

2) Select Insert > Indexes and tables > Indexes and tables from the menu bar.

3) On the Insert Index/Table dialog box (Figure 345), in the Type dropdown list, select 
the index wanted.
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4) Modify the various pages, which are very similar to those discussed in previous 
sections.

5) Select OK when everything has been set.

Figure 345. Creating other types of indexes

Creating a bibliography

A bibliography is useful for displaying references used throughout a document. These 
references are either stored in a bibliographic database or within the document itself. 

This section shows you how to:

• Create, add, and maintain entries within a bibliographic database.

• Add a reference into a document.

• Format the bibliography.

• Update and edit an existing bibliography.

For most of this section, the database table used is the sample one that comes with Writer. For 
information on creating a new table in the bibliographic database, see Chapter 10 (Getting 
Started with Base) in the Getting Started book.
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Creating a bibliographic database
Although you can create references within the document itself, creating a bibliographic 
database allows reuse in other documents and saves a lot of time.

Follow these steps to create a bibliographic database:

1) Select Tools > Bibliography Database. A window similar to that in Figure 346 is 
shown. 

Figure 346. Bibliography Database main window

2) You can use the top portion of this window to:

• Filter for specific records within the database (see “Filtering records” below).

• Change some details of columns in the database (see “Changing column details”).

• Select an alternative data source (another database or table) or change details of the 
fields in the database.

The middle portion of the window shows each of the records in a table layout similar to that 
of a spreadsheet. Additional fields can be viewed by scrolling the table to the right.
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The bottom portion of the window shows the contents of the selected record.

Filtering records

To set up a filter for specific records within the bibliographic database, select Tools > Filter 
from the Bibliographic Database menu bar. On the Standard Filter dialog box (Figure 347), 
choose the fields, conditions and values for the filter and click OK.

Figure 347. Setting up a filter for the bibliographic database

Changing column details

To change the details of columns in the bibliographic database, select the Column 
Arrangement button near the top of the window. The Column Layout for Table biblio dialog 
box (Figure 348) is displayed.

Figure 348. Changing column layout for bibliographic database

Changing field details

You can make changes to the bibliography database (for example, rename fields or change 
the length of fields) by doing the following:

1) In the main document (not the Bibliography Database screen), press F4 or click View 
> Data Sources to open the data source window, similar to Figure 349.

2) Make sure that the Bibliography database is selected as well as the correct table. You 
may have to expand some levels to be able to select the correct ones.
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Figure 349. Data Source view of Bibliography database

3) Right-click on the table entry (biblio in the example) and select Edit Database File 
from the pop-up menu. This opens a window similar to Figure 350, which is the main 
menu for Base, the database component of OpenOffice.org.

Figure 350. Main window for working with databases

4) If Tables (under the Database view) is not selected, select it now. 

5) Right-click on the biblio table name in the Tables section and select Edit from the 
context menu to display a window similar to that shown in Figure 351.

6) You can now select each of the rows and modify the Field Properties as required.

7) When finished, you will be asked to confirm that you want the changes saved.
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Note For more information on how to use OOo’s database features, see Chapter 10 
(Getting Started with Base) in the Getting Started book.

Figure 351. Modify table properties window

Adding entries to the database
To add entries to the database:

1) You can add records directly into the database using the lower portion of the window 
shown in Figure 346 on page 344.

2) Complete each of the fields as required. Use the Tab key to move between fields.

3) It is best to use a unique name in the Short name field. This is used when inserting 
entries into documents.

4) To complete the entry move to the last field and press Tab once more.

Notes The Identifier column in the upper portion of the Bibliography Database window is 
labeled Short name in the lower portion of the window.

If your document requires [Author, date] style citations, use the Identifier (Short 
name) field of the database to record the information in the required format. If you 
are using a simple citation numbering system (e.g., [1],[2],...), use a unique 
reference of some sort in the Identifier (Short name) field. Writer will auto-number 
entries based on the position within the document.
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Maintaining entries in the database
To maintain entries in the database, use the Bibliography Database window as in the previous 
section. Click on the appropriate field and modify the text as appropriate.

Modified entries will be saved automatically to the database when the cursor moves off the 
record.

Adding a reference (citation) into a document
Writer supports two ways of showing references (citations) in the text of a document:

• Using authors’ names and dates of the referenced documents, for example [Smith, 
2004], as recorded in the Identifier (Short name) of each bibliographic entry.

• By numbering the referenced documents in the sequence they occur in the text, for 
example [1].

Tip To specify which citation style is used in the document, use the Index/Table page on 
the Insert Index/Table dialog, described on page 349.

To add references from the bibliographic database into a document:

1) Place the cursor where you want the reference to appear.

2) From the main menu, choose Insert > Indexes and tables > Bibliographic entry.

3) In the Insert Bibliographic Entry dialog box, shown in Figure 352, choose From 
bibliography database at the top of the dialog box. (You can also insert a reference 
from the document itself by selecting From document content, but that method is not 
covered in this chapter.)

Figure 352. Inserting bibliographic entries into a document

4) Select the reference from the Short name dropdown list near the bottom of the dialog 
box. The Author and Title of the selected reference are shown in the middle of the 
dialog box, to help you verify that it is the reference you want.
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5) To insert the reference into the document, click Insert.

6) You can keep the dialog box open and insert another reference into the document; you 
don’t need to close and reopen it.

7) When you have finished inserting all the references, select Close.

Formating the bibliography
Formatting the bibliography involves choices made in two places:

• Insert Index/table dialog (covered in this section)

• Bibliography 1 paragraph style (see page 351)

To create the bibliography:

1) Place the cursor at the point where you wish to insert the bibliography.

2) Select Insert > Indexes and tables > Indexes and tables and change the Type to 
Bibliography, to see a dialog box similar to that shown in Figure 353.

Figure 353. Inserting a bibliography

The Insert Index/Table dialog box has five pages.
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Using the Index/Table page

The basic settings are selected on this page.

1) To give the bibliography a title, enter it in the Title field. (A title is not required.)

2) You can protect the bibliography from being changed accidentally, by checking the 
Protected against manual changes checkbox.  If this box is checked, the 
bibliography can only be changed using the context menu or the Insert Table/Index 
dialog. If the box is not checked, the bibliography can be changed directly on the 
document page, just like other text.

3) To have the bibliographic entries numbered within the body of the document (for 
example, [1], [2], ...), select Number entries. If, however, you wish to have the field 
Identifier (from the database) appear in the document, clear this checkbox.

4) Select the type of brackets that you want for the referenced entries shown within the 
body of the document.

5) Define the sorting you require. Currently only alphanumeric sorting is supported. 
Sorting by the the sequence that entries appear in the text is done on the Entries tab.

Using the Entries page

The structure of this page is similar to that of the previous sections (see Figure 354).

Figure 354. Entries page for bibliographies

You can define how the entry will appear based on the Type of the entry, or simply apply the 
same format to all entries by selecting the All button.
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The Structure of the entry is based on the fields available in the bibliographic database. The 
ones shown by default are:

• Au – Author

• Ti – Title

• Ye - Year

To determine how entries are sorted, modify the Sort by options. To sort by the sequence that 
entries appear in the text, choose Document position. To sort alphanumerically, choose 
Content. Use Sort keys to group similar references. 

Using the Styles, Columns and Background pages

Refer to “Using the Styles page” on page 329, “Using the Columns page” on page 330, and 
“Using the Background page” on page 331.

Generating the bibliography

To generate the bibliography so that it appears in your document, click OK. The Insert Index/
Table dialog box closes and the bibliography appears in your document. 

Defining the paragraph style for the bibliography
You can modify the Bibliography 1 paragraph style to suit your requirements. For example, 
to number the entries in the bibliography list, you need to define a numbering style and link 
that numbering style to the Bibliography 1 paragraph style. To do this:

1) On the Styles and Formatting window, click on the List Styles icon. You can either 
define a new list style or modify one of those supplied. In this example, we will 
modify the Numbering 1 style. Right-click on Numbering 1 and choose Modify from 
the pop-up menu. (See Figure 355.)

Figure 355: Modify a numbering style

2) On the Numbering Style dialog, go to the Options page. In our example we want to 
have the numbers enclosed in square brackets. To do this, type [ in the Before box 
and ] in the After box, as shown in Figure 356.
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Figure 356: Specifying square brackets before and after the number in a list

3) Now go to the Position tab of the Numbering style dialog. In the Spacing to text box, 
specify how much indentation you want for the second and following lines of any item 
in the bibliography list of your document. Often you will need to experiment a bit to 
see what is the best setting. In our example (Figure 357), we have chosen 0.80 cm.

Figure 357: Setting the spacing between the margin and the text
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4) Click OK to save these settings and close the Numbering Style dialog. Return to the 
Styles and Formatting window, click on the Paragraph Styles icon, choose All Styles 
from the list at the bottom of that window, then right-click on Bibliography 1 and 
choose Modify.

5) On the Paragraph Style dialog, go to the Numbering tab and select Numbering 1 from 
the drop-down list. (See Figure 358.) Click OK to save this change to the 
Bibliography 1 paragraph style.

Figure 358: Applying a numbering style to a paragraph style

Now when you generate the bibliography, the list will look something like the one shown in 
Figure 359.

Figure 359: Result of settings for Bibliography 1 paragraph style
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Updating and editing an existing bibliography
To modify the display of bibliography entries:

1) Click anywhere in the bibliography and then right-click.

2) From the pop-up menu, choose Edit Index/Table. The Insert Index/Table dialog box 
opens and you can edit and save the table using the five pages described in the 
previous section. 

To update or delete the bibliography, follow the same process as described in the sections 
“Updating a table of contents” and “Deleting a table of contents” on page 334.
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Why use a master document?

Master documents are typically used for producing long documents such as a book, a thesis, 
or a long report. A master document is especially useful when graphics, spreadsheets, or other 
material causes the file size to become quite large. Master documents are also used when 
different people are writing different chapters or other parts of the full document, so you 
don’t need to share files. A master document joins separate text documents into one larger 
document, and unifies the formatting, table of contents (ToC), bibliography, index, and other 
tables or lists.

Yes, master documents do work in OOoWriter. However, their use is full of traps for 
inexperienced users. Until you become familiar with the traps, find out whether they affect 
what you are doing, and learn how to avoid (or work around) them, you may think that 
master documents are unreliable or difficult to use. In fact, avoiding or working around most 
of the traps is quite easy to do.

You can use several methods to create master documents. Each method has its advantages 
and disadvantages. Which method you choose depends on what you are trying to accomplish. 
The different methods are described in this chapter, along with suggestions on when to use 
each one.

Styles and master documents

Styles that are used in subdocuments, such as paragraph styles, are automatically imported 
into the master document after you save the master document. When you modify the style in 
the master document, the style in the subdocument remains unaffected. That is, the style in 
the master document takes precedence over the style in the subdocument.

Note Use the same document template for the master document and its subdocuments. 
When you modify or create a style, add it to the document template, and then reload 
the styles from the template into the master document and the subdocuments. This 
way the subdocuments will look the same when they are loaded into the master 
document as they do when viewed as individual files.

Using the Navigator

The Navigator is a very useful tool that helps you move quickly to specific parts of your 
document. It also provides information about the content of the document and enables you to 
reorganize some of the content. For example, if each chapter in your final book is a separate 
document, then in the master document they can be reordered, and the references are 
renumbered automatically and the table of contents and index can be updated.

In Writer, the Navigator has two distinct forms. One form is used in ordinary text documents 
and the other in master documents.
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In an ordinary text document, the Navigator displays lists of the graphics, tables, index 
entries, hyperlinks, references, and other items in the document, as shown in Figure 360. 
Click the + sign by any list to display the contents of the list. You can double-click an entry 
in the Navigator and jump immediately to that place in the document.

Figure 360. The Navigator for a text document

In a master document, the Navigator lists the subdocuments and text sections, as shown in 
Figure 361. The use of the Navigator in a master document is covered in more detail later in 
this chapter (see “Step 5. Insert the subdocuments into the master document” on page 365 
and “Cross-referencing between subdocuments” on page 369).

Figure 361. The Navigator for a master document
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Creating a master document

The three most common scenarios for creating a master document depend on the current state 
of your document:

• You have one existing document (a book) that you want to split into several 
subdocuments (chapters) that will be controlled by the master document.

• You have several existing documents (chapters) by one or more authors that you want 
to combine into one book, controlled by the master document.

• You have no existing documents but intend to write a long book containing several 
chapters, possibly by multiple authors.

We will look at each of these scenarios in turn.

Splitting one document into a master document and 
subdocuments
When you have one existing document that you want to split into several subdocuments that 
will be controlled by the master document, you can split the document automatically.

Use this method if the original document uses only the Default page style, is numbered 
sequentially from the first page, and uses the Heading 1 style to identify the start of each 
chapter. In these conditions, this method will work well.

Advantages: This method is quick and easy, and any existing cross-references between 
chapters are preserved. Although cleanup work may be necessary, once you have done the 
cleanup, the document will behave itself.

Disadvantages: If the original document was complex, you may have major cleanup work to 
do because some formatting will be lost—for example, page styles, page breaks, restarted 
page numbering.

How to do it: Open the document and click File > Send > Create Master Document to split 
the document. You will find that each of the subdocuments begins with a Heading 1 and the 
file names are all maindocnameX.odt, where X is 1, 2, 3, and so on. If you have a Preface or 
other “chapter” starting with a Heading 1 before Chapter 1, the file names will not directly 
correspond to the chapter numbers.

Combining several documents into a master 
document
This method works best when all of the documents were created from the same template, but 
you can also use it when the documents were created from different templates.

Use one of the techniques described in “Starting with no existing documents” to create a 
blank master document and insert the other documents as subdocuments of the master 
document.
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This method is especially useful if the subdocuments are created or maintained by multiple 
writers. All writers on the project can work on their subdocuments without fear of version 
control issues that can occur when multiple people work on the same document.

Starting with no existing documents
The ideal situation is to start with no existing documents, because you can do everything the 
way you want from the beginning. Writer provides three ways to create a master document:

Method 1. Quick and easy, but not recommended

Method 2. Not too complicated, but with restrictions

Method 3. Complete control

In each case, you need to have a disciplined approach to make sure the master document 
works correctly and reliably. Each method below describes the steps to take. Be sure to do the 
steps in the order given.

Method 1. Quick and easy, but not recommended

Writer provides a quick and easy way to create a master document, but the master document 
is not associated with a template, so changes to styles and formatting are more difficult to 
apply reliably.

Note If the subdocuments were all created with the same template and the styles were not 
modified in the documents, then the styles are imported into the master document 
with the subdocuments, and styles and formatting should be correct in the master 
document. This method works best when these conditions are met.

How to do it: 

1) Click File > New > Master Document.

2) Use the Navigator to insert new documents or existing files into the master document, 
as described in “Step 5. Insert the subdocuments into the master document” on page 
365.

Method 2. Not too complicated, but with restrictions

This technique works well if you want to use sequential page numbering throughout the final 
document (not restarting at 1 at any point), and each chapter starts with a Heading 1 on a new 
page. If you want to restart page numbering anywhere in the document, use Method 3.

How to do it: Follow the instructions in the next section (Method 3. Complete control), but 
do not put in the text sections between the subdocuments or try to change the page 
numbering.
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Method 3. Complete control

This method gives you complete control over complex documents with several page styles or 
restarted page numbering. It is a bit more work to set up, but works reliably.1

How to do it: Follow these steps, in the order given. Each step is explained in detail in the 
following subsections.

Step 1. Plan the project

Step 2. Create a template containing the required styles, fields, and other elements

Step 3. Create the master document and subdocuments from the same template

Step 4. Insert some information directly into the master document

Step 5. Insert the subdocuments into the master document

Step 6. Add a table of contents, bibliography, or index

Step 1. Plan the project

Although you can make changes at most steps in this process, the more you can plan before 
you start, the less work you will have to do to correct any problems later. Here are some 
things you need to plan:

● Parts of book or report required, and the page numbering to be used in different parts of 
the book. Consider as an example a book with these parts:

Part Length Page numbering
Title (cover) page 1 page no page number
Copyright page 1 page (back of title page) no page number
Table of Contents unknown length start with i
Preface (Foreword) 2 pages continue from ToC
Chapters 1 to 8 unknown length start with 1
Appendixes A, B unknown length continue from Chapter 8
Index unknown length continue from Appendix B

● What pages will be in the master document and what will be in the subdocuments. The 
ToC and index must be in the master document. A typical arrangement would be:

Part Location
Title (cover) page In master document
Copyright page In master document
Table of Contents In master document
Preface (Foreword) Subdocument
Chapters 1 to 8 Subdocuments
Appendixes A, B Subdocuments
Index In master document

1 However, the method does not work in some situations. See “Problem solving” on page 373 for details.
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● Page, paragraph, character, frame, and numbering styles. See Chapter 6, “Introduction to 
Styles” and Chapter 7, “Working with Styles” for instructions on how to create or modify 
styles. Some styles for the example book are:

Page styles

Name Characteristics Next page style

Title page No header, footer or page numbers; layout 
different from other pages

Copyright page

Copyright page No header, footer or page numbers; layout 
different from other pages

Front matter first page

Front matter first 
page

No header; page number in footer, Roman 
numbers (i, ii, iii); layout different from 
following pages

Front matter left page

Front matter left 
page

Header and footer, one containing the 
page number (Roman)

Front matter right page

Front matter right 
page

Margins mirrored from Front matter left 
page; Roman page number

Front matter left page

First page No header; page number in footer, Arabic 
numbers (1, 2, 3); layout same as Front 
matter first page

Left page

Left page Layout as for Front matter left page, but 
Arabic page numbers

Right page

Right page Layout as for Front matter right page, but 
Arabic page numbers

Left page

Paragraph styles

Name Characteristics Next paragraph style

Heading 1 18 pt, bold, 0.30” above, 0.15” after, page 
break before

Body text

Heading 2 14 pt, bold, 0.30 “ above, 0.15” below Body text

Body text 12 pt, double space, 0.25” indent before Body text

Page break 6 pt, no space before or after, page break 
before

Body text

Character styles

Name Characteristics

Emphasis 12 pt, italic

Body text 12 pt

● Insert fields and AutoText entries as required. See other chapters in this book for ideas.
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Step 2. Create a template containing the required styles, fields, and 
other elements

You can create your template from an existing document or template that contains some or all 
of the styles you want for this document, or you can create the template from a blank 
document. For more about templates, see Chapter 10, “Working with Templates”.

If you use an existing document or template, delete all the text from it except for fields in 
headers and footers before saving it as the template for this project. It will still have all the 
styles you defined, even if the text is not there. You can change the styles in the template as 
your project develops.

Be sure to use File > Templates > Save when creating the template.

Step 3. Create the master document and subdocuments from the same 
template

If you are starting a new project, create the master document and all the subdocuments from 
the same template. Not using the same template could create style inconsistencies that require 
time and effort to correct. For example, if two subdocuments have a style with the same name 
that is formatted differently in each document, the master document will use the formatting 
from the first subdocument that was added. This could cause your document not to look like 
you expect. Using the same template for all subdocuments saves time and frustration.

It does not matter in what order you create the master and subdocuments, and you do not 
have to create all the subdocuments at the same time, when you are starting the project. You 
can add new subdocuments at any time, as you need them—as long as you always create 
them from the same template.

Create the master document
Follow this process to create the master document. You can use other methods, but each 
method (including this one) has its drawbacks.

1) Open a new document from the template you created in Step 2, by clicking New > 
Templates and Documents, then selecting the template you created. Be sure the first 
page of this new document is set to the page style you want for the first page of the 
final document; if it is not, change it. In our example, the style for the first page is 
Title page.

2) If any text or page breaks came into this document from the template, delete the text. 
(Fields in headers and footers can stay.) 

3) Click File > Send > Create Master Document. Save the master document in the 
folder for this project, not in the templates foldert. We will return to this master 
document later. For now, you can either leave it open or close it, as you prefer.

Create subdocuments
A subdocument is no different from any other text document. It becomes a subdocument only 
when it is linked into a master document and opened from within the master document. Some 
settings in the master document will override the settings in a subdocument, but only when 
the document is being viewed, manipulated, or printed through the master document.
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Create a subdocument in the same way as you create any ordinary document:

1) Open a blank document based on the project template (very important) by clicking 
New > Templates and Documents, then selecting the template.

2) Delete any unwanted text, and set the first page to the page style you specified for the 
first page of a chapter.

3) Click File > Save As. Give the document a suitable name and save it in the folder for 
this project.

If you already have some of the chapters written, the files are probably not based on the 
template you just created for this project. You will need to change the template attached to 
the existing files. The only way to do this is:

1) Open a blank document based on the project template.

2) Copy the contents of the original document into this new document. Use File > Paste 
Special to avoid copying the styles from the original documents to the new document.

3) Apply the template styles throughout the document.

4) Click File > Save As and save the new document in the project folder with a suitable 
name.

5) Rename the original chapter file so you do not use it by mistake.

Step 4. Insert some information directly into the master document

The instructions in steps 4 and 5 use the page numbering requirements given in Step 1. If 
your book has different requirements, change these instructions to suit.2

These instructions are fairly tedious, but once you have the master document set up, you 
should not have to change it, and with a bit of practice setting it up goes quickly.

1) Open the master document and do the following.

• Make sure paragraph marks are showing (you can set them in Tools > Options > 
OpenOffice.org Writer > Formatting Aids, or click the Nonprinting characters 

icon ).

•  Show text boundaries, table boundaries, and section boundaries (Tools > Options 
> OpenOffice.org > Appearance). 

2) Type the contents of the title page (or leave placeholders and fill in later). With the 
insertion point in the last blank paragraph on the page, click Insert > Manual Break. 
On the Insert Break dialog box (Figure 362), select Page break and the page style for 
the second page (Copyright page in our example), and leave the Change page 
number checkbox deselected. Click OK.

2 See “Problem solving” on page 373 for one example.
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Figure 362. Inserting a page break between the title page and the copyright page

3) Type the contents of the copyright page (or leave placeholders). Insert another manual 
page break, this time setting the page style to Front matter first page. Select the 
Change page number checkbox and choose 1 in the box below that, as shown in 
Figure 363. This number 1 will show in your document as i, because the page style is 
defined to use Roman numerals.

Figure 363. Inserting a page break before the first page of the front matter

4) Let’s assume the third page is for the Table of Contents. Leave a blank paragraph or 
two on this page and insert another page break, with the next page again set to the 
Front matter first page style, which we want to use for the first page of the Preface. 
Because we want the page numbering for the Preface to continue from the page 
numbers of the Table of Contents, do not select the Change page number checkbox 
this time. Notice that the Navigator shows one item, labeled Text.
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Step 5. Insert the subdocuments into the master document

At last we are ready to add the subdocuments.

Tip Subdocuments are inserted into a master document before whatever item is 
highlighted in the Navigator. If you insert the last subdocument first, and then insert 
the other subdocuments before the last one, they will end up in the correct sequence 
without the necessity of moving them up or down in the list.

1) Display the Navigator (click Edit > Navigator, or press F5, or click the Navigator 
icon   .

2) On the Navigator, select Text, then long-click on the Insert icon and click File.

Figure 364. Inserting a subdocument into a master document using the Navigator

A standard File Open dialog box appears. Select the required file (which you created 
in Step 3) and click OK. This example uses six chapters and a preface; we will load 
Chapter 6 first, as suggested in the Tip above.

The inserted file is listed in the Navigator before the Text item, as shown in Figure
365. 

Figure 365. Navigator after inserting one subdocument

3) Because the Text section contains the title page and other material you have already 
inserted, highlight it and click the Move Up icon to move it to the top of the list.

4) Highlight the subdocument you just inserted (Chapter 6), then long-click on the Insert 
icon and click File to insert the first subdocument; in this example, Preface. Chapter 6 
remains highlighted. Repeat with Chapter 1, Chapter 2, and so on until all the 
subdocuments have been added to the list. The Navigator will now look something 
like Figure 366.
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Figure 366. The Navigator showing a series of files in a master document 

5) Save the master document again. Now highlight each chapter in turn and insert a Text 
section before it. When you are done, the Navigator should look like Figure 367.

Figure 367. The Navigator showing a series of files and text  
sections 

Tip You can define your Heading 1 paragraph style to start on a new page, and thus avoid 
inserting manual page breaks between chapters, but this causes a page numbering 
problem if you want to restart page numbering at the beginning of Chapter 1.

To restart page numbering, you must insert a manual page break; but because the 
Heading 1 style on the first page of Chapter 1 forces yet another page break, you end 
up with one or more unwanted blank pages before the first page of Chapter 1. The 
technique described in this chapter avoids this problem.
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6) Check whether the first page of the master document has the correct page style. If not, 
change it to the correct style (Title page in this example).

Scroll to the place where the first subdocument begins. Check whether its page style is 
correct, and change it if necessary (Front matter first page in this example).

The first subdocument (Figure 368) has a blank paragraph at the top of the page; this 
was inserted as part of the manual page break. Set this paragraph to the PageBreak 
style you created in Step 2.

Paragraph marker Section marker

Protected section 
containing 
subdocument

Figure 368. Page break before subdocument, which is in a protected section

7) Notice that the document is in a protected section. That means you cannot change any 
of the contents of this subdocument from within the master document. (If you remove 
the section, the contents become part of the master document itself; they are no longer 
in a subdocument. If you make changes in either the master document or the 
subdocument, those changes are not made in the other document. For more about 
sections, refer to the online help or to Chapter 4, “Formatting Pages”.)

Scroll down until you find the beginning of Chapter 1. You will find that it is on the 
same page as the end of the Preface, and there is a blank paragraph in the text area 
between the two sections (the Preface and Chapter 1), as shown in Figure 369.

Click on this blank paragraph and insert a page break, specifying the First Page style 
and the page number to start at 1. Click OK.

Section marker at 
start of next section

Section marker at end 
of previous section

Text area in master document, between sections

Figure 369. A text area between two sections of a master document
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8) Scroll to the first page of Chapter 2. You’ll find that it is on the same page as the end 
of Chapter 1, and there is a blank paragraph in the text area between the two chapters.

Click on this blank paragraph and insert a page break, specifying the First Page style, 
but do not select the Change page number checkbox.

Repeat for all of the chapters, so that each chapter starts on a new first page.

9) Save the master document again.

Step 6. Add a table of contents, bibliography, or index

You can generate a table of contents, bibliography, or index for the book, using the master 
document. You must insert these items into a text section in the master document. For more 
about these document elements, see Chapter 12, “Creating Tables of Contents, Indexes, and 
Bibliographies”.

Put the insertion point on the page in the first text section where the table of contents is to go 
and create the table of contents.

If you do not have a Text section at the end of the master document, insert one before the last 
subdocument, then move it down so it is after the last subdocument. Now, if you have 
included bibliographic entries in your subdocuments, you can put the insertion point on the 
page in this last text section where the bibliography is to go and create the bibliography.

If you have included index entries in your subdocuments, put the insertion point on the page 
in the last text section where the index is to go and create the index.

Editing a master document

After creating a master document, you may want to change its appearance or contents.

Changing the appearance of the document
You can change the styles in the template as your project develops. Do not make changes to 
styles in the master document or in any of the subdocuments—make those changes in the 
template.

To update the master document (and all of the subdocuments) with changes to the template, 
just open the master document. You will get two messages: first, to ask if you want to update 
all links; and second, if you want to apply the changed styles. Answer Yes to both of these 
messages.

Editing subdocuments
You cannot save edits made to a subdocument from within the master document. Instead, you 
must open the subdocument, either by double-clicking on it in the master document’s 
Navigator, or by opening it from outside the master document. Then you can edit it just as 
you would edit any other document. Just one rule: if you make any changes to the styles 
while editing a subdocument, you must copy those changed styles to the template so they are 
available to all of the subdocuments and to the master document.
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If you change the contents of any subdocument, you need to manually update the table of 
contents, bibliography, and index from within the master document.

Cross-referencing between subdocuments

The methods described earlier in this chapter are all most writers will need when using 
master documents. However, you might need to automatically update cross-references 
between subdocuments. This section describes how to do this.

The process to create cross-references between subdocuments is tedious, but it works. (An 
alternative is to use Ian Laurenson’s OutlineCrossRef3 macro, available from 
http://homepages.paradise.net.nz/hillview/OOo/OutlineCrossRef3-fr-3.odt.)

1) First set references in each subdocument, just as you would when you are cross-
referencing within a single document. When you do this, select the entire text you 
want to use as the reference, such as a a heading or figure number. Keep a list of what 
you have named the reference fields, and be sure every name is unique. One way to 
keep track of this information is by putting it in a separate text file or a spreadsheet.

The field names are case-sensitive. You can check the field name by holding the cursor 
over the referenced item. In our example (Figure 370), the heading has the field name 
word count.

Figure 370. Finding the field name for a heading

2) Open the master document. In the Navigator (Figure 371), select a subdocument and 
click the Edit icon (or right-click and choose Edit from the pop-up menu). The 
subdocument opens for editing.

3) In the subdocument, place the cursor where you want the cross-reference to appear. 
Click Insert > Cross Reference.

4) In the Fields dialog box, on the References page, select Insert Reference in the Type 
list on the left hand side (Figure 372). The Selection list in the middle column shows 
only the reference field names for the subdocument you are using, so ignore that list 
and check the list you created manually in step 1.
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Figure 371. Selecting a subdocument in the Navigator

5) In the Name field in the lower right hand column, type the name of the reference you 
set in the subdocument you are referring to. In our example, the reference is in Chapter 
3, and its name is word count.

Figure 372. Fields dialog box showing manual entry of field name
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6) Click Insert, type any text you want to appear between the reference and page number 
(such as “on page”), and then insert another reference with the Page format. Nothing 
will appear in the subdocument except tiny gray bars indicating the fields. If you hover 
the mouse pointer over one of these fields, you should see the field name (Figure 373). 

Figure 373. Viewing the field name

(You can turn on the display of field codes by clicking View > Field Names. The two 
fields shown as gray lines in Figure 373 now look like Figure 374.)

Figure 374. Displaying field codes

7) After you have inserted all the cross-references required in the subdocument, save and 
close it and return to the master document window.

Within the master document, navigate to the page of the subdocument on which you 
inserted the cross-reference field. You should now see the text of the cross-reference 
appear in the spot where you inserted it (Figure 374), because within the master 
document, the subdocument can find the target of that field reference. 

Figure 375. Field contents showing where inserted in file

This technique also works if you open a subdocument directly in step 2 (that is, not from 
within the master document) and insert a cross-reference field.
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Creating one file from a master document 
and its subdocuments

Master documents are .odm files containing linked subdocuments, which are in .odt format. 
Although linked files are very useful when writing and editing a large document such as a 
book, sometimes you might need to have a copy of the entire book in one file.

To export a master document to a .odt file (without affecting the original .odm file), do this:

1) Open the master document and choose File > Export from the menu bar.

2) On the Export dialog (Figure 376), type a name for the exported .odt file and choose 
OpenDocument Text (.odt) from the File format list. Click Export. This step changes 
the .odm file into a .odt file.

Figure 376: Exporting a master document to an OpenDocument Text (.odt) file

3) Close the master document and open the new .odt file, updating all links.

4) Choose Edit > Links from the menu bar.

5) The Edit Links dialog (Figure 377) shows all the linked files. Select all the files in the 
Source file list and click Break Link. This step embeds (includes) the contents of all 
the subdocuments into one single file.

Figure 377: Breaking links to include files in one document
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Problem solving

Some combinations of choices do not work together. This section describes some problems 
and what to do about them.

Including a chapter reference in the header of the 
first page

The problem

If you use the method described in “Step 5. Insert the subdocuments into the master
document” beginning on page 365 (putting a page break paragraph into the master document 
between the subdocuments), and you put a cross-reference to the chapter name and number 
in the header of the first page of each chapter, then the cross-reference field on the first page 
will pick up the chapter name and number from the previous chapter. This happens because 
with this method the first (blank) paragraph on those pages is actually the last paragraph of 
the previous chapter. The example did not include a cross-reference to the chapter name and 
number in the header of the first page, so it did not have this problem.

First page footers do not have this problem; they correctly pick up the current chapter’s name 
and number.

The solution

The cure for this problem is as follows:

1) Use File > Templates > Edit to open the template used for the master document and 
its subdocuments.

2) Modify the style for the chapter title (usually Heading 1) to enable a page break 
before, using the page style you want for the first page of each chapter. Save and close 
the template.

3) When you reopen the master document, it should ask two questions: “Update all 
links?” and “Your styles don’t match the template. Do you want to update your files?” 
Be sure to answer Yes to both questions.

4) Modify the chapter title style (Heading 1) in the master document file as you did in the 
template file in step 2. Save the master document.

5) Open the Navigator in Master Document view and delete the Text sections between 
the chapters. Update all links.

The headers on the first page of each chapter will now display the correct chapter name and 
number.
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The problem with the solution—and a workaround

This solution creates another problem, if you want to restart page numbering at 1 on the first 
page of the first chapter and have pages numbered sequentially through all the chapters.

Normally you would restart numbering by specifying the starting page number when you 
modify the Heading 1 style to start on a new page. However, if you do that, then each chapter 
restarts page numbering at 1. (Sometimes this is what you want, but often it is not.)

In this case, you will have to include an “offset” in the page number field—that is, you tell 
OOoWriter how many pages to subtract to make the first page of the first chapter to be page 
number 1. Of course, to make this work, you need to know how many pages are in the front 
matter, and you may not know that until after you have finished the entire book. If you add or 
delete some pages (for example, if the table of contents grows from 4 pages to 5), you will 
need to adjust the offset accordingly. Therefore, this adjustment is best made at the end of the 
project.

Here is how to do it.

1) In the master document itself—not in the subdocument—place the cursor just in front 
of the Page field on the first page of the first chapter. Right-click and choose Fields 
from the pop-up menu.

2) In the Edit Fields dialog box (Figure 378), type a negative even number (–2, –4, etc.) 
in the Offset box. Click OK to save this change.

Figure 378. Using an offset to start at a different page number

3) You might need to make the same change on the second page of the first chapter.
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Including landscape pages in a portrait-oriented 
master document

The problem

Master documents ignore manual page breaks in subdocuments if the manual break specifies 
the following page style. Landscape pages are inserted into portrait-oriented documents by 
inserting a manual page and specifying a landscape page style (and then changing back to 
portrait orientation by inserting another manual break and specifying the following page 
style). This technique works fine until the document becomes a subdocument within a master 
document. At that point the landscape pages become portrait pages and the page break itself 
is ignored.

The solution

1) Remove the landscape pages from the subdocument and put them in a separate 
document. Note that if the landscape pages are in the middle of the original 
subdocument, you will end up with at least three documents: (a) the portion of the 
subdocument before the landscape pages, (b) the landscape pages themselves, and (c) 
the portion of the subdocument after the landscape pages.

2) Insert documents (a) and (c) individually into the master document.

3) Then do one of the following:

• Insert a text section into the master document itself between documents (a) and (b). 
In the text section, insert a manual page break (specifying the landscape page 
style), and then paste the contents of document (b)—the landscape pages—into the 
master document. If necessary, insert another manual page break (specifying one of 
the relevant portrait page styles) before document (b). 

or

• Insert document (b) into the master document as a subdocument, using the method 
described on page 365 to include a manual page break in a text section before and 
after the landscape document.

When deciding which method to use, you need to consider the placement of headers and 
footers (if any) that appear in your document. If you want portrait headers and footers on the 
landscape pages, use the technique described in Chapter 4, “Formatting Pages”.
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Anchoring pictures to a page

The problem

A picture (graphic) anchored “to page” in a subdocument is not displayed in the master 
document although it always appears correctly in the subdocument. 

Because the master document reorganizes the page flow, page numbers, and cross-references 
when it collates all the subdocuments together, the absolute reference to a page X in a 
subdocument is lost in the master document. The picture loses its anchor reference and 
simply disappears.

The solution

To avoid this problem but keep pictures positioned precisely on a particular page, anchor the 
pictures as follows:

1) Right-click on the picture and choose Picture from the pop-up menu. 

2) On the Type tab of the Picture dialog box (Figure 379), set the anchor to To character 
or To paragraph.

Figure 379. Anchoring a graphic and setting its position on a page

3) Under Position, choose suitable horizontal and vertical references to the page.
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Introduction to fields

Fields are extremely useful features of Writer. They are used for data that changes in a 
document, such as the current date or the total number of pages. This chapter describes how 
to use a few of them.

Tip Fields have a gray background when viewed on screen, unless you have deselected the 
Field shadings checkbox or changed the color of field shadings on the Appearance 
page of the Options – OpenOffice.org dialog box. This gray background will not show 
when you print the file to hardcopy or PDF.

To turn field shadings on or off quickly, choose View > Field Shadings or press 
Control+F8.

Quick and easy field entry

You can quickly insert common fields into your document by choosing Insert > Fields from 
the menu bar and selecting the required field from the list, as shown in Figure 380.

Figure 380: Inserting common fields

Using document properties to hold 
information that changes

The Properties dialog box for any document contains locations on the Description tab (Figure
381) and the User Defined tab (Figure 382) for information that you might want to include in 
your document, especially if it is information that might change during the course of the 
project. To display this dialog box, click File > Properties.

Later in this chapter, we will see how to use this information in fields. You can return to this 
dialog box at any time and change the information you entered. When you do so, all of the 
references to that information will change wherever they appear in the document. For 
example, you might need to change the contents of the Title field from the draft title to the 
production title.
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Figure 381: The Description tab of the document’s Properties dialog box

The User Defined tab provides four fields for you to use, as required. You can change the 
default names for these fields to more meaningful names. The example in Figure 382 shows 
that three of the defaults have been changed: Info 1 to Chapter subtitle, Info 2 to Chapter 
number, and Info 3 to Name of guide.

Figure 382: The User Defined tab of the document’s Properties dialog box

To change these field names, click the Info fields button near the bottom of the dialog box. In 
the small pop-up dialog box (Edit Field Names, not shown here), type the field names you 
want and then click OK.
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Using other fields to hold information that 
changes

One way that people use fields is to hold information that is likely to change during the 
course of a project. For example, the name of a manager, a product, or even your entire 
company may change just before the document is due to be printed. If you have inserted the 
changeable information as fields, you can change the information in one place, and it will 
automatically change in all the places where that field occurs.

Writer provides several places where you can store the information referred to by a field. We 
will look at some of them here.

Seven document properties (Time, Date, Title, Subject, Author, Page Number, and Page 
Count) are on the Insert > Fields menu (Figure 380). To insert one of these fields, click on it 
in the menu.

Other document properties are on the DocInformation and Document tabs of the Fields dialog 
box (Figure 383 and Figure 384), reached by clicking Insert > Fields > Other.

To insert one of these fields, select it in the Type list and then select from the Select and 
Format lists if choices appear. Finally, click Insert.

Figure 383: Inserting a Date Modified field using the DocInformation tab of the 
Fields dialog box
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Figure 384: Inserting a File name field using the Document tab of the Fields dialog box

Some of these items are picked up from the User Data page of the Options dialog box, so 
make sure the information on that page is correct.

Tip Although these fields are often used to hold information that changes, you can make 
the content unchangeable by selecting the Fixed content checkbox (visible in Figure
383) when inserting the field. If necessary, you can come back to this dialog box later 
and deselect this checkbox to make the field variable again.

Using AutoText to insert often-used fields

If you use the same fields often, you will want a quick and easy way to insert them. Use 
AutoText for this purpose. To define an AutoText entry for a field:

1) Insert a field into your document, as described previously.

2) Select the field, and then click Edit > AutoText (or press Ctrl+F3).

3) On the AutoText dialog box (Figure 385), choose the group where this new entry will 
be stored (in this example, it is going into My AutoText), type a name for the entry, and 
change the suggested shortcut if you wish.

4) Click the AutoText button and click New to have the entry inserted as a field. Do not 
choose New (text only) because the AutoText entry will be plain text, not a field. 
Click Close to close the AutoText dialog box.

5) Now whenever you want to insert this field at the cursor position, type the shortcut, 
and then press F3.
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Figure 385: Creating a new AutoText entry

Defining your own numbering sequences

You may want to define your own numbering sequences to use in situations where you do not 
always want the number at the start of the paragraph or where you want more control than the 
built-in numbering choices give you.

This topic describes how to create and use a numbering sequence, using a “number range 
variable” field.

Create a number range variable
To create a number range variable using Arabic (1, 2, 3) numbers:

1) Place the insertion point in a blank paragraph in your document.

2) Click Insert > Fields > Other and select the Variables tab (Figure 386).

3) In the Type list, select Number range. In the Format list, select Arabic (1 2 3). Type 
whatever you want in the Name field. (I have used Step in this example.)

4) Click Insert. The name of the variable (Step) now appears in the Selection list, and a 
number field (showing 1) appears at the insertion point in your document. The Fields 
dialog box remains open, so you may need to move it out of the way to see the field in 
the document.

5) Hover the mouse pointer over this number field and you will see the field code of 
Step = Step+1. If you click several more times on the Insert button in the Fields 
dialog box, the numbers 2, 3, 4, and so on will appear in the document.

6) Now you may want to create another field to restart the Step sequence at 1, so you can 
use the same sequence name more than once in your document (for example, to begin 
each set of instructions).
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Figure 386: Defining a number range variable

7) To create this new field, open the Fields dialog box to the Variables tab. Make sure the 
variable name Step appears in the Name box. In the Value box, type Step=1, as shown 
in Figure 387. Click Insert. Now hover the mouse pointer over the new field in your 
document and you will see the field code of Step = Step=1.

Figure 387: Defining a field to restart a number range variable
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Use AutoText to insert a number range field
You certainly do not want to go through all of that every time you want to put in a step 
number. Instead, create two AutoText entries, one for the Step = Step=1 field (call it Step1, 
for example) and one for the Step = Step+1 field (StepNext). See “Using AutoText to insert
often-used fields” on page 381.

You can create similar fields for substeps or other sequences that you want to be numbered 
with letters (a, b, c), Roman numerals (i, ii, iii), or some other sequence. In the Fields dialog 
box, choose the required format in the Format list when creating the field codes.

Tip
If a user-defined variable is not in use in the document, the  icon next to the Value 
box is active. You can delete the variable by clicking this icon. To remove a variable 
that is used in the current document, first delete from the document all fields using 
that variable, and then remove the variable from the list.

Using automatic cross-references

If you type in references to other parts of the document, those references can easily get out of 
date if you reword a heading, add or remove figures, or reorganize topics. Replace any typed 
cross-references with automatic ones and, when you update fields, all the references will 
update automatically to show the current wording or page numbers. The References tab of the 
Fields dialog box (Figure 388) lists some items, such as bookmarks, figures, tables, and user-
defined number range variables. Other items that you might expect to be listed, such as 
headings, are not shown.

Figure 388: The References tab of the Fields dialog box
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Prepare items as targets for cross-referencing
Before you can insert a cross-reference to anything that is not automatically shown on the 
References tab, such as a heading, you must prepare or “set” that heading as an item to be 
referenced. To do this, you can either use bookmarks or set references.

Using bookmarks

Bookmarks are listed in the Navigator and can be accessed directly from there with a single 
mouse click. In HTML documents, bookmarks are converted to anchors that you can jump to 
via hyperlink.

1) Select the text you want to bookmark. Click Insert > Bookmark.

2) On the Insert Bookmark dialog box (Figure 389), the larger box lists any previously 
defined bookmarks. Type a name for this bookmark in the top box. Click OK.

Figure 389: Inserting a bookmark

Setting references

1) Click Insert > Cross reference.

2) On the References tab of the Fields dialog box (Figure 390), click Set Reference in the 
Type list. The Selection list shows any references that have been defined.

You can leave this page open while you set many headings as references.

3) Click in the document and highlight the text of the first heading to be used as a target 
for a cross-reference. Click on the Fields dialog box. The text of the heading will 
appear in the Value box in the lower right of the dialog box. In the Name box, type 
some text by which you can identify this heading.

4) Click Insert. The text you typed in the Name box now appears in the Selection list.

5) Repeat steps 3 and 4 as often as required.
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Figure 390: Setting text to be used as a target for a cross-reference

Insert cross-references
To insert a cross-reference to a heading or other text:

1) In your document, place the cursor where you want the cross-reference to appear.

2) If the Fields dialog box is not open, click Insert > Cross Reference. On the 
References tab of the Fields dialog box (Figure 391), in the Type list, click Insert 
Reference or Bookmarks (depending on how you set your references).

You can leave this page open while you insert many cross-references.

3) Click on the required item in the Selection list, which shows the bookmarks or 
references that have been defined. In the Format list, choose the type of reference 
required. Usually this will be Reference (to insert the full text of the reference or 
bookmark) or Page (to insert the number of the page the referenced or bookmarked 
text is on). Click Insert.
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Figure 391: Inserting a cross-reference to a heading

To insert a cross-reference to an item (such as a figure caption) that you have previously 
inserted into the document as a numbering-sequence field:

1) In your document, place the cursor where you want the cross-reference to appear. If 
the Fields dialog box is not already open, click Insert > Cross-reference.

2) On the References tab of the Fields dialog box (Figure 388), select Figure in the Type 
list.

3) Click on the required item in the Selection list, which shows the list of figures that 
have previously been inserted into the document. The Format list shows different 
choices from those given for headings. Choose the type of reference required. Usually 
this will be Category and Number (to insert the word “Figure” and its number), 
Reference (to insert the word “Figure” with its number and the full text of the 
caption), or Page (to insert the number of the page the figure is on).

4) Click Insert.
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Using fields in headers and footers

You can insert fields into headers or footers, using techniques described earlier in this 
chapter:

• To insert a page number, document title, author, creation date and time, current date and 
time, or total page count field, use document properties (see page 378).

• You can insert a cross-reference to a bookmark or a set reference.

• If you have used Heading 1 for your chapter titles, you can use a document field to insert 
the current chapter title, so it changes from one chapter to the next. See Figure 392, which 
calls chapter titles “names”. If you have used outline numbering on your Heading 1, you 
can choose whether to include these numbers in the field.

• You can insert cross-references to other heading levels by specifying a value in the Layer 
box in the lower right of the Document tab of the Fields dialog box (Figure 392). That is, 
Layer 1 = Heading 1, Layer 2 = Heading 2, and so on.

A cross-reference field in the header of a page picks up the first heading of that level on the 
page, and a field in the footer picks up the last heading of that level.

Figure 392: Inserting the current chapter name and number into your document

• To include the chapter number with the page number, position the cursor just before the 
Page field you inserted. Click Insert > Fields > Other. On the Document tab of the Fields 
dialog box, select Chapter in the Type column and Chapter number without separator 
in the Format column. Click Insert.
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Go to the header or footer where you inserted this field, type the character you want to 
appear between the chapter number and the page number—for example, a period or a dash. 

The table of contents will not automatically pick up these chapter numbers, so you will 
need to make a change on the Indexes and Tables menu item, as described in Chapter 12, 
“Creating Tables of Contents, Indexes, and Bibliographies”.

• You can add a page count to the footer—for example “Page 9 of 12”. Type the word 
“Page” and a space in front of the Page field. Type a space, the word “of”, and a space 
after the Page field. Then click Insert > Fields > Page Count.

Using fields instead of outline numbering for 
chapter numbers

The technique in “Using fields in headers and footers” on page 388, combined with outline-
numbered chapter headings (described in Chapter 7, “Working with Styles”), works well 
when you want the field to show information for the current chapter. But what if you want to 
use a cross-reference to refer to a different chapter? You cannot bookmark or set a reference 
to the chapter number part of a heading created using outline numbering.

Tip If you use this technique, some other features will not work because Writer does not 
recognize the field as chapter numbers. For example, you will not be able to include 
chapter numbers with the page numbers in headers or footers, or the table of contents, 
using the technique described in “Using fields in headers and footers” on page 388.

To have chapter numbers that update automatically and can be used in cross-referencing, use 
a number range field.

1) Define your number range variable, as described in “Defining your own numbering
sequences” on page 382. I have called this variable Chapter.

2) To insert the field into your Heading 1, type Chapter<space>. Click Insert > Fields 
> Other. On the Variables tab, pick Number range, Chapter, Arabic (1 2 3). Click 
Insert. You will need to do this manually for each Heading 1.

3) Select the entire text of the first Heading 1, including the word “Chapter” and the 
chapter number, and set a reference to it.

4) You can now insert a cross-reference to this heading anywhere in your document.

Tip You can also use this technique for easier management of appendix numbering. Keep 
your appendix headings in the Heading 1 style, define a separate number range 
sequence for appendix numbers (choosing “A,B,C” for the number format), and type 
Appendix<space><insert appendix number field> in the Heading 1 paragraph. You 
can then use the same page styles for chapters and appendixes, and the same field in 
the header or footer of chapters and appendixes.
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Tricks for working with fields

Keyboard shortcuts for fields
Here are some handy keyboard shortcuts to use when working with fields:

Ctrl+F2 Open the Fields dialog box.

Ctrl+F8 Field shadings on/off.

Ctrl+F9 Show/hide field names.

F9 Update fields.

Fixing the contents of fields
You can specify Fixed content for many items on the Document and DocInformation tabs so 
the field contents do not update. For example, you might use a field to insert the creation date 
of a document, and you would not want that date to change. In another place you might use a 
date field to show the current date, which you do want to change; in that case, deselect Fixed 
content when you insert the field.

Converting fields into text
Writer does not provide any easy way to convert field contents into text. To do this, you need 
to copy the field contents and paste them back as unformatted text. This is not a very good 
solution if you have hundreds of fields that you want to change, but you could use a macro to 
automate the process.

Developing conditional content

Conditional content is text and graphics that are included or excluded depending on a 
condition you specify.

A simple example is a reminder letter for an overdue account. The first and second reminders 
might have a subject line of “Reminder Notice”, but the third reminder letter might have the 
subject “Final Notice” and a different final paragraph.

A more complex example is a software manual for a product that comes in two versions, Pro 
and Lite. Both product versions have much in common, but the Pro version includes some 
features that are not in the Lite version. If you use conditional content, you can maintain one 
file containing information for both versions and print (or create online help) customized for 
each version. You do not have to maintain two sets of the information that is the same for 
both versions, so you will not forget to update both versions when something changes.
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Choose the types of conditional content to use
This section describes several Writer features that can help you design and maintain 
conditional content. You can use one or any combination of these features in the same 
document.

Conditional text

With conditional text, you can have two alternative texts (a word, phrase, or sentence). One 
text will be displayed and printed if the condition you specify is met, and the other will be 
displayed and printed if the condition is not met. You cannot include graphics or edit the text 
except in the field dialog (not in the body of the document). You also cannot format part of 
the text (for example, bolding one word but not the others), but you can format the field to 
affect all of the field contents (for example, bolding all of the words). You cannot include a 
cross-reference or other field in the text.

Hidden text

With hidden text (a word, phrase, or sentence), you have only two choices: show or hide. If 
the condition you specify is met, the text is hidden; if the condition is not met, the text is 
displayed. The disadvantages are the same as for conditional text: you cannot include 
graphics, edit the text in the body of the document, format part of the text, or include a field.

Hidden paragraphs

Hidden paragraphs are like any other paragraogs, but you can specify a condition under 
which the paragraph is not displayed or printed. A blank paragraph can also be hidden—for 
example, if a database field has no content for the current record. This is very useful when 
merging an address into a letter: if you allow two lines for the street address and the database 
record uses only one line, you can prevent the blank line from appearing in your document. 
You can include graphics, edit the text in the body of the document, format any part of the 
text, and include fields.

Hidden sections

Hidden sections are like hidden paragraphs, but they can include more than one paragraph—
for example, a heading plus one or more paragraphs. However, a section cannot contain less 
than a paragraph, so you cannot use this method for single words or phrases. The contents of 
a hidden section behave just like the contents of any other part of the document, but you can 
specify a condition under which the section is not displayed or printed. In addition, you can 
password protect a section.

Plan your conditional content
Conditions are what programmers call logical expressions. You must formulate a logical 
expression for each condition because a condition is always either true (met) or false (not 
met). You can use the same condition in many places in your document, for different types of 
conditional content.
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To make conditional content work, you need to:

1) Choose or define a variable.

2) Define a logical expression (condition) involving the selected variable.

Choose or define a variable

You can use the following variables in your condition:

• User-defined variables

• Predefined OpenOffice.org variables, which use statistical values from the document 
properties

• User data

• Database field contents—for example from your address book

You cannot use internal variables (for example, page number or chapter name) to formulate 
conditions.

The examples in this chapter use user-defined variables.

Define a logical expression (condition) involving the selected variable

The condition compares a specified fixed value with the contents of a variable or database 
field.

To formulate a condition, use the same elements as you would to create a formula: operators, 
mathematical and statistical functions, number formats, variables, and constants. The 
possible operators are given in the online help; look in the index under “operators: in 
formulas”. You can define quite complex expressions, but in most cases a simple condition 
will do the job.

Create the variable
To create your variable, click Insert > Fields > Other. You can use choices found on the 
DocInformation, Variables, and Database tabs.

DocInformation fields

“Using document properties to hold information that changes” on page 378 described how to 
set up a user-defined document property. You can use that document property as the variable 
in your condition statement, or you can create another document property field specifically 
for conditions.

User-defined variable field

To set up a variable or user field:

1) Place the cursor where you want the field to be inserted.

2) On the Fields dialog box, select the Variables tab (Figure 393).
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3) Select Set variable in the Type list and Text in the Format list. Type a name for the 
variable in the Name box, and a value in the Value box. I have chosen “ProLite” for 
the name (to remind me that this variable is related to the two product versions), and I 
set the value as “Lite” because I can remember “If it is the Lite version, then this text 
should be hidden.”

4) Select Invisible so the field does not show in the document. Click Insert, then click 
Close.

Figure 393: Defining a variable to use with conditional content

5) A small gray mark should be visible where you inserted the field. Hover the mouse 
pointer over this mark and you will see the field formula ProLite = Lite. We will come 
back to this field later.

Tips Because the gray mark is so small, you may have trouble finding it again, especially if 
you have other fields in the document. You may prefer to leave the variable field visible 
while you work, and change it to invisible just before you create final copy.

At any time, you can place the insertion point just before the field and click Edit > 
Fields or right-click the field, and then click Fields on the pop-up menu. On the Edit 
Fields dialog box (Figure 397), select or deselect the Invisible checkbox.
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Apply the condition to the content
Now that you have defined the variable, you can use it in a condition statement. This topic 
describes some of the possibilities.

Conditional text

First, let us set up some conditional text that will insert the words “Great Product Lite” into 
the Lite version and “Great Product Pro” into the Pro version of the manual. You would use 
this field whenever you want to mention the name of the product.

1) Place the cursor where you want one of these phrases to appear. (You can move or 
delete it later, if you wish.)

2) Open the Fields dialog box by clicking Insert > Fields > Other, select the Functions 
tab, and select Conditional text in the Type list.

3) As shown in Figure 394, type ProLite EQ "Lite" in the Condition box, Great 
Product Lite in the Then box, and Great Product Pro in the Else box.

Note These fields are case-sensitive, and quotation marks are required around a text 
value such as Lite.

Figure 394: Inserting conditional text

4) Click Insert to insert the field, then click Close. You should see Great Product Lite 
in your text.

Tip If you want to insert this field into your text in many places (as you probably would for 
a product name), create an AutoText entry for it. See “Using AutoText to insert often-
used fields” on page 381 for instructions.
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Hidden text

You might use hidden text for words or short phrases that describe features of Great Product 
Pro that are not found in the Lite version. You can reuse the same field in several places in 
your document—for example, by copying and pasting it.

To create a hidden text field:

1) Click Insert > Fields > Other and select the Functions tab.

2) Select Hidden text in the Type list, as shown in Figure 395.

3) Type ProLite EQ "Lite" in the Condition box and type the required text in the 
Hidden text box. Remember, this is the text that is hidden if the condition is true.

4) Click Insert to create and insert the field.

Figure 395: Creating a condition for hidden text

Hidden paragraphs

Tip To enable hidden paragraphs, remove the check mark from View > Hidden 
Paragraphs. When this option is selected, you cannot hide any paragraph. 

A paragraph is hidden if the condition is true. To hide a paragraph:

1) Click in the paragraph to be hidden.

2) Click Insert > Fields > Other and select the Functions tab (Figure 395).

3) Select Hidden paragraph in the Type list.

4) For this example,type ProLite EQ "Lite" in the Condition box.

5) Click Insert to create and insert the field. If an extra paragraph mark appears, delete it.
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Hidden sections

A conditional section is hidden if the condition is true. To create a conditional section:

1) Select the text that you want to be included in the conditional section. (You can edit 
this text later, just as you can edit any other text.)

2) Click Insert > Section. On the Insert Section dialog box (Figure 396), select the Hide 
checkbox and enter the condition in the with Condition box. You can also give the 
section a name, if you wish. Click Insert to insert the section into your document.

Figure 396: Creating a section to be hidden when a specified condition is met

To show the hidden section so you can edit it:

1) Click Format > Sections.

2) On the Edit Sections dialog box, select the section from the list.

3) Deselect the Hide checkbox, and then click OK. You can now edit the contents of the 
section. Afterwards, you can click Format > Sections again and select the Hide 
checkbox to hide the section again.

To make the hidden section a normal part of the document (that is, to remove the section 
markers, but not the contents of the section):

1) Show the hidden section, as described above.

2) On the Edit Sections dialog box, select the section from the list.

3) Click Remove. The contents of the section are now a normal part of the document.
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Change the value of the variable
1) Find the variable field you created in “Create the variable” on page 392.

2) Click once just in front of this field, then right-click and click Fields on the pop-up 
menu.

3) On the Edit Fields: Variables dialog box (Figure 397), change the value of the variable 
to Pro.

4) If you have set fields to update automatically, all of the conditional and hidden text 
that uses this variable as a condition will change.

Figure 397: Changing the value of the variable

Tip To turn on automatic updating of fields, click Tools > Options > OpenOffice.org 
Writer > General, and select Fields under Update: Automatically.

Editing hidden paragraphs and sections
To show all the hidden paragraphs and sections so you can edit their contents, change the 
value of the variable to something that the conditions will not recognize. In our example, you 
could change the value  to 1.

The technique does not affect the display of hidden and conditional text, which can only be 
edited in the Edit Fields dialog. 
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Using placeholder fields

A placeholder field prompts you to enter something (text, a table, a frame, a graphic, or an 
object).

To insert a placeholder field into a document:

1) On the Functions tab of the Fields dialog box, select Placeholder in the Type column 
and select what the placeholder is for in the Format column.

2) In the Placeholder box, type the text that you want to appear in the placeholder field.

3) In the Reference box, type the text that you want to display as a help tip when you rest 
the mouse pointer over the field.

Figure 398 shows the results of inserting a placeholder field for a graphic. 

Figure 398: Inserting a placeholder field

Because the <Logo> field is a graphics placeholder, when you click on the field in the 
document, the Insert picture dialog box opens, prompting you to select a graphic (picture). 
When you select a picture and click Open, the picture replaces the field in the document.

Similarly, clicking on a table placeholder field opens the Insert Table dialog box, clicking on 
a frame placeholder field opens the Frame dialog box, and clicking on an object placeholder 
field opens the Insert OLE Object dialog box. The text placeholder field is different: you 
simply click on it and type some text in the Placeholder box, which replaces the field.
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Introduction

This chapter covers the use of forms within Writer documents. Most of the information here 
also applies to forms in other OpenOffice.org components, but there are some differences.

The chapter presents information on using forms in four main sections: setting up a basic 
form, an example for creating a form, linking a form to a data source and finally some 
advanced techniques.

OpenOffice.org forms cover a lot of ground and not everything is included here. Notable 
omissions are using forms in HTML documents and writing macros to link to form controls.

When to use forms

A standard text document displays information: a letter, report or brochure, for example. 
Typically the reader may edit everything or nothing in any way. A form has sections that are 
not to be edited, and other sections that are designed for the reader to make changes. For 
example, a questionnaire has an introduction and questions (which do not change) and spaces 
for the reader to enter answers.

OpenOffice.org offers several ways to fill information into a form, including checkboxes, 
option buttons, text boxes, pull-down lists and spinners.

Forms are used in three ways:

• To create a simple document for the recipient to complete, such as a questionnaire sent 
out to a group of people who fill it in and return it.

• To link into a database or data source and allow the user to enter information. 
Someone taking orders might enter the information for each order into a database 
using a form.

• To view information held in a database or data source. A librarian might call up 
information about books.

Using forms to access a database offers a fast and easy way to build up complex graphical 
front ends. Your form can include not only the fields that link up to the data source but also 
text, graphics, tables, drawings and other elements.

Alternatives to using forms in Writer
In OpenOffice.org version 1.x, forms were the only way to access a data source. In version 
2.0 the Base component provides an alternative way of achieving this. There are a lot of 
similarities between forms in Base and Writer, but it may be that one is better for a particular 
task than the other. Base is appropriate only if the form accesses a data source; you would not 
use it for simple forms.

Most other OpenOffice.org components—Calc, Impress and Draw—also support forms in 
almost exactly the same way as Writer does.
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Creating a simple form

This section explains how to create a simple form without any links to a data source or 
database and without advanced customization.

Create a document
There is nothing special to be done when creating a document to use as a form. Create a new 
Writer document with File > New > Text document.

Form toolbars
Two toolbars control form creation: Form Controls and Form Design. Select View > 
Toolbars > Form Controls and View > Toolbars > Form Design to show them both. See 
“Form controls reference” on page 404 for a summary of the tools on these toolbars.

Tips The Form Design toolbar can also be launched from the Form Controls toolbar. 
Some of the less commonly used controls are on a third toolbar—More Controls—
also launched from the Form Controls toolbar.

You can dock these toolbars in different places on the Writer window, or leave them 
floating.

Figure 399: The three form design toolbars

The Form Controls toolbar has a button for each of the most commonly used types of control. 

Note In OpenOffice.org form controls are the text boxes, list boxes, option buttons, push 
buttons and other items that can be placed in forms.
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Design Mode
When creating a form, you will want to check that all the parts of the form work correctly. If 
design mode is off, the form behaves as it would for the end user. Buttons can be pressed, 
checkboxes checked and list items selected. If design mode is on, clicking on a control item 
selects it for editing.

Click the Design Mode On/Off button on the Form Controls toolbar to turn design 

mode on and off.

Tip If the Design Mode button is not available, click on the Select button. This activates 
most of the tools on the three toolbars.

Insert form controls
1) To insert a form control into the document, click the control’s icon to select it. The 

mouse pointer changes to look like this: 

2) Click in the document where you want the control to appear. (You can move it later.)

3) Holding the left mouse button down, drag the control to size it.

4) The control button remains active, so you can insert several controls of the same type 
without needing to go back to the toolbar.

5) To change to another tool, click its icon on the toolbar. 

To stop inserting controls, click on the Select button  on the Form Controls 
toolbar, or click on any of the controls you have just inserted. The mouse pointer 
changes back to its normal appearance.

Tip Holding down Shift when creating a form control makes the control square. If you 
press Shift when resizing an existing control, its proportions are kept the same.

Note When you insert a group box, list box or combo box, a wizard is launched to guide 
you through the setup. If you prefer not to run the wizard, click the Wizards 
On/Off button  on the Form Controls toolbar.

Configure controls
Having inserted the controls, you need to configure them to look and behave as you want. 
Right-click on a form control within your document and select Control from the pop-up 
menu.

402 Chapter 15  Using Forms in Writer



Creating a simple form

The Form Control dialog box (Figure 400) has three pages: General, Data and Events. For 
simple forms, only the General page is of any interest. On this page you can set the look and 
feel of the control.

Some controls have other useful options:

• Some controls have visible labels, such as Push Button and Option Button. The label 
text can be set.

• The List Box contains a list of options to choose from. Set these in the List entries 
box.

Tip Double-clicking on a control also brings up the Control Properties dialog box.

Figure 400: Control Properties dialog box

Using the form

To use the form, leave design mode by clicking the Design Mode On/Off button . 

A typical way to use a form is:

1) You design the form, then save it when you are happy with it.

2) You send the form to others (for example, by email).

3) They fill in the form, save it and send it back to you.

4) You open the form and see what their answers are.

Tip By using a data source, or setting a form to update over the web, you can 
automatically gather data. However, both of those are more complex and you might 
prefer to keep things simple.
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Form controls reference

Form Control toolbar

 Select
Select a form control to perform some other action on it.

 Design mode on/off
Toggle between design mode on (to edit forms) and design 
mode off (to use forms).

 Control 
Launch form control properties dialog box. This dialog box 
can be kept open as different controls are selected.

 Form 
Launch form properties dialog box, controlling properties 
for the form as a whole, such as which data source it 
connects to.

 Check Box 
A box that can be selected or deselected on the form. You 
can label the box.

 Text Box 
Control to create a box into which the form user can type 
any text. 

 Formatted Field 
Control allowing numeric formatting options. For example, 
you can set maximum and minimum values for the number 
entered, or the number type (decimal places, scientific, 
currency). 

 Push Button 

Creates a button that can be linked to a macro. The label is 
the name that appears on the button. 

 Option Button 
Creates an option or radio button. When multiple buttons 
are grouped together, only one can be selected at a time. 
The easiest way to group multiple buttons is to use the 
Group Box button on the More Controls toolbar, with 
wizards enabled.

 List Box 
Creates a list of options, as a pull-down menu, that the user 
can choose from. If wizards are on, creating a list box 
launches the List Box Wizard. This wizard is only useful if 
your form is linked to a data source.

If not linked to a data source, turn wizards off and create an 
empty list box. Then click the Control button and, in the 
List Entries option on the General tab, enter the options 
you want to appear on the list.

 Combo Box 
As with a List Box, you set up a list of choices. In addition 
a panel at the top either displays the choice made or allows 
the form user to type in something else.   Otherwise this 
works the same as the List Box.

 Label Field 

A text label. The difference between this and just typing on 
the page is that, as a control, you can link a label field to 
macros so, for example, something happens when the 
mouse passes over it or clicks on it.
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Form Control toolbar

 More Controls
Launch the More Controls toolbar.

 Form Design 
Launch the Form Design toolbar (which can also be opened 
with View > Toolbars > Form Design).

 Wizards On/Off
Some form controls (List Box and Combo Box) have 
optional wizards. If you do not want the wizard to launch 
when you create one of these controls, use the Wizards On/
Off button to switch wizards off. 

More Controls toolbar

 Spin Button 

A spin button allows form users to choose a number by 
cycling through the numbers. Specify maximum, 
minimum, default and the step between numbers. 

This control is not commonly used in Writer, as the number 
is not displayed. In Calc, however, a Data tab appears on 
the Control Properties dialog box, allowing you to link the 
spin button to a cell.

 Scrollbar
Creates a scrollbar, with a number of options to define the 
exact appearance. 

This control is not commonly used in Writer. In Calc, a 
Data tab appears on the Control Properties dialog box, 
allowing you to link the scroll bar to a cell.

 Image Button
Behaves exactly like a push button, but displays as an 
image. Choose the image in the Graphics option on the 
General tab in the Control Properties dialog box.

 Image Control
Only useful when the form is connected to a data source 
and a field in the data source exists that can hold images. 
You can add new images to the database or retrieve and 
display images from it.

 Date Field
Holds a date. Configure the earliest and latest dates the 
field will accept, the default date and the date format. You 
can add a spinner.

 Time Field
Works like a date field, specifying a time.

 File Selection
Allows a user to select a file, either by typing the path and 
name directly or by clicking on a Browse button and 
choosing the file from a dialog box.

 Numeric Field 
Displays a number. Specify formatting, maximum, 
minimum and default values. You can add a spinner.

 Currency Field
Works like a numeric field; additionally you can add a 
currency symbol.
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More Controls toolbar

 Pattern Field 
Pattern fields are useful when the form links into a data 
source. Specify an Edit Mask to restrict what a user can 
enter into the field. Specify a Literal Mask to restrict which 
data is displayed from the data source. 

 Group Box
The group box control has two different uses depending on 
whether wizards are on or off. 

If wizards are on, creating a group box launches the Group 
Element wizard. This creates a group of option buttons (in 
which only one may be selected at a time). In most cases, 
using a group box is the best way to create a set of option 
buttons.

If wizards are off, a group box is simply a visual box to 
group together different controls. It has no effect on the 
way the controls operate.

 Table Control 
Table Control is only useful with a data source.  If no data 
source is specified, you will be prompted to choose one in 
the Table Element Wizard. 

You then pick the fields to display and, when design mode 
is off, the data appears in the table. The table also includes 
controls to step through the records.

Records can be added, deleted and modified in the table.

 Navigation Bar
A navigation bar is the same as the Form Navigation 
toolbar (View > Toolbars > Form Navigation), but can be 
placed anywhere in the document and be resized.

Form Design toolbar

 Select
Select a form control to perform an action on it.

 Design mode on/off
Toggle between design mode on (to edit forms) and design 
mode off (to use forms).

 Control 
Launch form control properties dialog box. This dialog box 
can be kept open as different controls are selected.

 Form 
Launch form properties dialog box, controlling properties 
for the form as a whole, such as which data source it 
connects to.

 Form Navigator
The Form Navigator is a nice utility, displaying all the 
forms and controls in the current document, allowing you 
to edit and delete them easily. 

If you use the Form Navigator, it's a good idea to give your 
controls names (in the properties dialog box). The name 
appears in the navigator so, for example, if you have ten 
text boxes, you can tell which is which.
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Form Design toolbar

 Add Field 
Add Field is only useful if you have specified a data source 
for the form. If no data source is specified, an empty box 
opens.

If you have specified a data source, Add Field opens a list 
of all the fields in the specified table, which you can then 
drag and drop onto the page. The fields are placed on the 
page with the name of the field before them.

This is a quick and easy way to create a form from a data 
source.

 Activation Order 

Allows you to specify the order in which focus shifts 
between  controls. You can test the order by leaving design 
mode and using Tab to switch between the controls.

 Open in Design Mode
Open the current form in design mode (to edit the form 
rather than entering data into it).

 Automatic Control Focus
If activated, focus is set to the first form control.

 Position and Size
Launches the Position and Size dialog box, allowing you to 
specify both by typing in precise values, rather than 
dragging the control. You can also lock the size or position, 
so they do not get changed accidentally. For some controls, 
you can rotate and set the slant and corner radius.

 Change Anchor

Just as with a frame, any form control can be anchored to 
page, paragraph or character and also anchored as a 
character (meaning that it behaves like any other character 
on the page).

 Alignment
The Alignment button is disabled unless the control is 
anchored as a character. You can align a control in different 
ways, for example so the top of the control lines up with 
the top of the text or the bottom lines up with the bottom of 
the text.

 Display Grid
Display a grid of dots on the page, to help you line up 
controls. 

 Snap to Grid
When a control is brought close to a grid point or line, it 
will snap to the grid. This makes it easier to line up 
controls.

 Guides when Moving
When a control is being moved, lines extend from the 
control horizontally and vertically to help you position it 
accurately.
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Example: a simple form

Create the document
Open a new document (File > New > Text Document). It is a good idea to write down the 
outline of the document, without form controls, though of course it can easily be changed 
later.

Figure 401: Initial document without form controls

Add form controls
The next step is to add the form controls to the document. We will have four controls:

• Name is a text box 

• Sex is two option buttons, male or female.

• Favourite shape is a list of options.

• All shapes you like is a series of check boxes.

To add these controls:

1) Select View > Toolbars > Form Controls to open the Form Control toolbar.

2) If the tools are not active, click the Form Navigator button (on the Form Control 
toolbar) to activate them. If necessary, also click the Design Mode On/Off button.

3) Click the Text Box button , then click in the document and, with the left mouse 
button held down, drag the shape of the Name text box to approximately the size you 
want.

4) Make sure the Wizards On/Off button is on (shaded with a border). Click the 

More Controls button  to launch the More Controls toolbar.
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5) On the More Controls toolbar, click the Group Box button . Draw a group box by 
the Sex: entry to launch the Group Element Wizard.

6) On the first page of the wizard, enter two names for the options fields: Male and 
Female. Click Next>> three times, delete the caption and click Finish.

7) Now create the list box. On the Form Controls toolbar, click the Wizards On/Off 

button  to turn wizards off. Click the List Box button  and draw a list box by 
Favourite Shape: in the document. This will just be an empty pane for now.

8) Finally create four check boxes by All the shapes you like. Click on the Check Box 

button  and then draw out four check boxes, side by side across the page.

You should now have a document looking something like this:

Figure 402: Document with form controls

Configure form controls
No further configuration is required to the Name and Sex fields (though, of course, there is 
configuration that could be done if you wanted, such as giving a name to each control and 
changing the appearance of the controls).

The list box must be configured to add the list of options. The check boxes must be 
configured to add in the names (instead of Check Box, Check Box1...)

1) Click on the List Box control within the document  and then the Control button  
on the Form Design toolbar to launch the control properties dialog box. Select the 
General tab.

2) In the List Entries box, enter the names of the shapes: Circle, Triangle, Square and 
Pentagon. Type in one shape and press Enter. Then position the cursor at the end of the 
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line to type in the next shape. You should end up with a line saying 
“Circle”;”Triangle”;”Square”;”Pentagon”.

3) Click on the first Check Box. The Properties dialog box stays open but changes to 
show the properties for the check box.

4) Change the Label to Circle and press Enter. The label on the check box will change 
immediately.

5) Click on each of the other three check boxes in turn. Change the Label in the 
Properties dialog box to Triangle, Square and Pentagon in turn.

6) Close the Properties dialog box.

7) Turn Design Mode off  and close the two Controls toolbars.

You have now completed the form and your form hopefully looks something like this:

Figure 403: Completed form

Finishing touches
The form is complete, but you are free to make further changes to the document. If you were 
sending this out to other people to complete, you would probably want to make the document 
read-only. The effect would be that users would be able to fill in the form, but not to make 
any other changes to the document.

To make the document read-only, select Tools > Options > OpenOffice.org > Security > 
Open this document in read-only mode.

Note If the document is read-only, anyone filling in the form will need to use File > Save 
as to save the document.
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Accessing data sources

The most common use for a form is as the front end of a database. You can provide a form 
that allows users to enter information into a contacts database and, because it is part of a 
Writer document, the form can contain all the graphics, formatting, tables and other elements 
to make it look just the way you want. Even better, modifying the form is as simple as editing 
a document.

OpenOffice.org can access numerous data sources. These include ODBC, MySQL, Oracle 
JDBC, spreadsheets and text files. As a general rule, databases can be accessed for read and 
write; other data sources (such as spreadsheets) are read-only. 

Tip To see the full list of supported data source types, select File > New > Database. 
Click Connect to an existing database and then click the triangle next to the list box.

Creating a database
Chapter 10 (Getting Started with Base) in the Getting Started guide covers in more detail 
how to create a database. We will give a short guide here to creating a very simple database 
with OOo Base.

1) Select File > New > Database to start the Database Wizard (Figure 404).

2) Select Create a new database and click Next.

3) On the next page, select Yes, register the database for me and Open the database 
for editing. Registering the database just means that it can be accessed from other 
OOo components such as Writer and Calc. You need to do this if you want to link your 
forms into it.

4) Click Finish and save your new database, giving it a name. Unlike creating other 
documents in OOo, databases must be saved when you first create them.

After saving the database, you should see the main Base window (Figure 405), which 
contains three panels. The left-hand panel is Database, with icons for Tables, Queries, Forms 
and Reports.
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Figure 404: Database Wizard

Figure 405: Main Base window
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The next step is to create a table. Again, this is covered in more detail in Chapter 10 (Getting 
Started with Base) in the Getting Started guide. Here we are going to create a small table as 
an example.

1) Choose Tables in the left-hand column, then choose Create Table in Design View 
under Tasks.

2) Use the Table Design window (Figure 406) to tell Base which fields to create. We will 
have just three fields: Name, Address and Telephone.

3) On the first line, enter under Field Name ID and set the Field Type to Integer 
[INTEGER].  In the gray box at the left of the line, right-click and select Primary 
Key, bringing up a key icon in the box. In the Field Properties at the bottom of the 
window is an Auto Value option; change this to Yes.

Tip Setting up the Primary Key field with Auto Value set to Yes is an important step. If 
this is not done, the form you create later will be much trickier to use and may 
generate errors for the user. Make sure you get this step right!

4) On three lines, enter under Field Name Name, Address and Telephone. Accept the 
default Field Type of Text [VARCHAR] and leave Description blank.

5) Save the table (File > Save). You will be prompted to name it (the name can be 
anything you like).

6)  Finally, save the whole database from the main Base window (File > Save).

Figure 406: Database table design
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Accessing an existing data source
If you have an existing data source, such as a spreadsheet or database, you simply need to tell 
OpenOffice.org about it. This is called registering a data source.

To register an existing data source:

1) Select File > New > Database to launch the Database Wizard (Figure 407).

2) Select Connect to an existing database and choose the type from the drop-down list.

Figure 407: Using the Database Wizard to connect to an existing database

3) Click Next and follow the instructions to select the database to register (the exact 
process varies between different types of data source).

4) In Step 3: Save and proceed, check that Yes, register the database for me is selected. 
Deselect Open the database for editing – you just need to register it, not edit it 
through Base.
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Creating a form for data entry
Whether you created a new database, or already had a data source, it must be registered with 
OpenOffice.org (see above). Once it is registered, linking your form to the data source is 
simple. Follow these steps to create a new form and link it to a registered data source.

1) Create a new document in Writer (File > New > Text Document).

2) Design your form, without putting in the actual fields (you can always change it later).

3) Show the Form Controls toolbar (View > Toolbars > Form Controls).

4) Click the Design Mode On/Off button  to put the document into design mode, if 
necessary. With design mode off, most of the toolbar buttons are greyed out. If the 
Design Mode button is also grayed out, click on the Select button to activate it.

5) Click the Text Box button . Click in the document and, holding down the left 
mouse button, drag the mouse to create a text box for the first form field (for example, 
Name, if you are linking to the database created above).

6) Click the Text Box button again and drag the mouse to draw another field. 
Additional fields, of any type, can be added in the same way (click and drag).

So far you have followed the same steps you used before when you created your first form. 
Now you link your form with the data source you registered.

1) Launch the Form Properties dialog box. You can do this by clicking on the Form 

button  in the Form Controls toolbar or by right-clicking on any of the fields you 
inserted and selecting Form. The form button is grayed out unless you have one of the 
form elements selected. As soon as you select a form element in your document, the 
Form button becomes clickable.

2) In the Form Properties dialog box, click on the Data tab (Figure 408).

• Set Data Source to be the data source you registered.

• Set Content Type to be Table.

• Set Content to be the name of the table you want to access.

• Close the dialog box.

3) For each form control in turn, launch the Properties dialog box. Click on the control 
to select it (so small green boxes appear around it). Then either right-click and select 

Control or click on the Control button  on the Form Controls toolbar.
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Figure 408: Form properties, connecting to a data source

4) In the Properties dialog box, click on the Data tab (Figure 409). If you set up the 
form correctly, the Data Field option will contain a list of the different fields in the 
data source (for example, Name, Address and Telephone). Select the field you want.

Figure 409: Form control properties, Data tab

5) Repeat for each control in turn until every control that should be has been assigned to 
a field.

Tip If you created a database in OOo Base and your Primary Key field had Auto Value 
set to Yes, that field does not need to be part of the form. If Auto Value was set to 
No, you will have to include it and have your users enter an unique value into that 
field whenever they make a new entry—not something you want. 
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Entering data into a form
Once you have created a form and tied it to a database, you want to use it to enter data into 
your data source, or modify data already there.

1) Make sure that the form is not in design mode. In the Form Controls toolbar, click on 

the Design Mode On/Off button . If design mode is off, most of the buttons on 
the toolbar will be grayed out.

2) Make sure that the Form Navigation toolbar is on (View > Toolbars > Form 
Navigation). This toolbar normally appears at the bottom of the window.

Figure 410: Form Navigation toolbar

3) If there is existing data in the data source, use the control buttons on the Form 
Navigation toolbar to look at different records. You can amend data in a record by 
editing the values in the form. To submit the changes, press the Enter key with the 
cursor in the last field. The record is saved and the next record is displayed.

4) If there is no data in the form, you can enter it. To submit the new record, press the 
Enter key with the cursor in the last field.

5) Other functions can be performed from the Form Navigation toolbar, including 
deleting a record and adding a new record.

Advanced form customization

Linking a macro to a form control
You can set any form control (for example, text box or button) to perform an action when 
triggered by some event. To see the full list of events, right-click on the form control when 
the design mode is on, select Control and click on the Events tab (Figure 411).

To assign a macro to an event:

1) Create the macro. (See Chapter 17, “Getting Started with Macros” in the Getting 
Started guide.)

2) Right-click on the form control, select Control and click on the Events tab.

3) Click the ... button to the right of the event to bring up the Assign action dialog box 
(Figure 412).

4) Click Assign and select the macro.
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Figure 411: Control properties events tab

Macros can also be assigned to events relating to the form as a whole. To assign these, right-
click on a form control in the document, select Form and click on the Events tab.

Figure 412: Assign action dialog box

418 Chapter 15  Using Forms in Writer



Advanced form customization

Read-only documents
Having created your form, you want whoever is using it to be able to access the information 
stored in the database, or complete the form, without changing the layout. There is an easy 
way to do this: make the document read-only. 

Select Tools > Options > OpenOffice.org > Security> Open this document in read only 
mode.

Fine-tuning database access permissions
By default, when a database is accessed from a form, any changes can be made to it: records 
can be added, deleted and amended. You may not want that behaviour. For example, you may 
want users to be able only to add new records or to be prohibited from deleting existing 
records.

In design mode, right-click on a form control and select Form from the pop-up menu. On the 
Data tab of the Form Properties dialog box are a number of options: Allow additions, Allow 
deletions, Allow modifications and Add data only. Set each of these to Yes or No to control 
the access users have to the data source.

Individual fields can also be protected. This might be useful if you wanted a user to be able to 
modify some parts of a record but only view others, such as a stock list where item 
descriptions are fixed and quantities can be modified.

To make an individual field read-only, in design mode, right-click on the form control within 
the document and select Control from the pop-up menu. Select the General tab and set 
Read-only to Yes.

Form control formatting options
You can customize the way form controls look and behave in a number of ways. These are all 
accessed in Design mode. Right-click on the form control, select Control from the pop-up 
menu and select the General tab in the Properties dialog box.

• Set a label for the control in the Label field. Some form controls, such as push buttons 
and option buttons, have visible labels that can be set. Others, such as text boxes, do 
not.

• Set whether the form control will print out if the document is printed with the Print 
option.

• Use the Font setting to set the font, typeface and size for a field.

• For a text box, you can set the maximum text length. This is very useful when adding 
records into a database. Every database text field has a maximum length and, if the 
data entered is too long, OOo displays an error message. By setting the maximum text 
length of the form control to be the same as that of the database field, this error can be 
avoided.
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• You can set the default option for a form control. By default, a control is blank, or has 
every option unselected. You can set the control to start with a particular option or list 
item selected.

• For controls where a password is being entered, setting the Password character (for 
example to *) displays only that character, but saves what the user really types.

• You can add additional information and help text for a form control.

• Other formatting controls such as background color, 3-D look, text formatting, scroll 
bars and borders allow you to further define how the control appears.

XForms

XForms are a new type of web form, developed by the World Wide Web Consortium (W3C). 
OpenOffice.org 2.0 supports the XForms 1.0 open standard for creating web forms with 
XML. 

In OpenOffice.org, an XForms document is a special type of Writer document. XForms use 
the same controls as the ordinary forms described in this chapter.

After you create and save an XForms document, you can open the document, fill out the 
form, and submit the changes to a server.

A detailed discussion of XForms is beyond the scope of this chapter.
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Introduction

Introduction

OpenOffice.org (OOo) has a component for mathematical equations.  It is most commonly 
used as an equation editor for text documents, but it can also be used with other types of 
documents or stand-alone. When used inside Writer, the equation is treated as an object inside 
the text document.

Note The equation editor is for writing equations in symbolic form (as in equation 1). If 
you want to evaluate a numeric value, see the Calc Guide.

df x 
dx

=ln  x tan−1
 x2
  

(1)

Getting started
To insert an equation, go to Insert > Object > Formula.

The equation editor opens at the bottom of the screen, and the floating Selection window 
appears. You will also see a small box (with a gray border) in your document, where the 
formula will be displayed.

Figure 413. Equation Editor, Selection window, and location of resulting 
equation.

The equation editor uses a markup language to represent formulas. For example, %beta 
creates the Greek character beta (  ). This markup is designed to read similar to English 

whenever possible. For example, a over b produces a fraction: 
a
b

.

422 Chapter 16  Math Objects



Entering a formula

Entering a formula

There are three ways to enter a formula:

• Select a symbol from the Selection window.

• Right-click on the equation editor and select the symbol from the context menu.

• Type markup in the equation editor.

The context menu and the Selection window insert the markup corresponding to a symbol. 
Incidentally, this provides a convenient way to learn the OOoMath markup.

Note Click on the document body to exit the formula editor.

Double-click on a formula to enter the formula editor again.

The Selection window
The simplest method for entering a formula is the Selection window, shown in Figure 414.

Figure 414. Symbols are divided into categories

The Selection window is divided into two main portions.

• The top shows the symbol categories. Click on these to change the list of symbols.

• The bottom shows the symbols available in the current category.

Tip You can hide (or unhide) the Selection window with View > Selection.
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Example 1: 5×4

For this example we will enter a simple formula: 5×4 On the Selection window:

1) Select the top-left button of the categories (top) section (Figure 415).

2) Click on  the multiplication symbol (shown in Figure 415).

Figure 415. Unary/binary operators

When you select the multiplication symbol on the Selection window, two things happen:

• The equation editor shows the markup: <?> times <?>

• The body of the document shows a gray box with the figure: ×

Figure 416. The multiplication symbol

The “ <?> ” symbols (Figure 416) are placeholders that you can replace by other text. The 
equation will update automatically, and the result should resemble Figure 417.

Figure 417. Result of entering “5” and “4” next to the “times” operator
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Tip To keep the equation from updating automatically, select View > AutoUpdate 
display. 

To update a formula manually, press F9 or select View > Update.

Right-click menu
Another way to access mathematical symbols is to right-click on the equation editor. This 
produces a menu as shown in Figure 418.

Figure 418. Right-click menu

Note The entries in this menu correspond exactly to those in the Selection window.

Markup
You can type the markup directly in the equation editor. For example, you can type “5 times 
4” to obtain 5×4 . If you know the markup, this can be the fastest way to enter a formula.

Tip As a mnemonic, the formula markup resembles the way the formula reads in English.

Below is a short list of common equations and their corresponding markup.

Display Command Display Command

a=b a = b a sqrt {a}

a2 a^2 an a_n

∫ f x dx int f(x) dx ∑ an
sum a_n

a≤b a <= b ∞ infinity

a×b a times b x⋅y x cdot y
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Greek characters

Greek characters (  , ,  , , etc) are common in mathematical formulas. These characters 
are not available in the selection box or the right-click menu. Fortunately, the markup for 
Greek characters is simple: Type a % sign followed the name of the character, in English.

• To type a lowercase character, write the name of the character in lowercase.

• To type an uppercase character, write the name of the character in uppercase.

See the table below for some examples:

Lowercase Uppercase

%alpha   %ALPHA  A

%beta   %BETA  B

%gamma   %GAMMA  

%psi    %PSI   

%phi    %PHI   

%theta   %THETA  

Note A complete table of Greek characters is included in page 444.

Another way to enter Greek characters is by using the catalog window. Go to Tools > 
Catalog. The catalog window is shown in Figure 419. Under “Symbol Set” select “Greek” 
and double-click on a Greek letter from the list.

Figure 419. Catalog - used for entering Greek characters
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Example 2:  ≃ 3.14159
For this example we will suppose that:

• We want to enter the above formula (the value of pi rounded to 5 decimal places).

• We know the name of the Greek character (“pi”).

• But we do not know the markup associated with the ≃  symbol.

Step 1: Type “%” followed by the text “pi”. This displays the Greek character  .

Step 2: Open the Selection window (View > Selection).

Step 3: The ≃  symbol is a relation, so we click on the relations button . If you hover the 
mouse over this button you see the tooltip “Relations” (Figure 420).

Figure 420. Tooltip indicates the “Relations” button.

Step 4: Delete the <?> text and add “3.14159” at the end of the equation. Hence we end up 
with the markup “ %pi simeq 3.14159 ”. The result is shown in Figure 421.

Figure 421. Final result
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Customizations

Formula editor as a floating window
As seen in Figure 413, the formula editor can cover a large part of the Writer window. To turn 
the formula editor into a floating window, do this:

1) Hover the mouse over the editor frame, as shown in Figure 422.

2) Hold down the Control key and double-click.

Figure 422. Hold down the Control key and double-click on the 
border of the math editor to turn it into a floating window.

Figure 423 shows the result. You can make the floating window back into an embedded 
frame, using the same steps. Hold down the Control  key and double-click the window frame.

Figure 423. Equation editor as a floating window

How can I make a formula bigger?
This is one of the most common questions people ask about OOoMath. The answer is simple, 
but not intuitive:

1) Start the formula editor and go to Format > Font size.
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Figure 424. Changing the font size for a formula

2) Select a larger font size under “Base Size” (top-most entry), as shown in Figure 425.

Figure 425. Edit “Base size” (top) to make a formula bigger.

The result of this change is illustrated in Figure 426.

Figure 426. Result of changing the base font size.

Formula layout

The most difficult part of using OOoMath comes when writing complicated equations. This 
section provides some advice about writing complex formulas.
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Brackets are your friends
OOoMath knows nothing about order of operation. You must use brackets to state order of 
operations explicitly. Consider the following example:

Markup Result

2 over  x + 1 2
x
1

2 over {x + 1} 2
x1

Equations over more than one line

Suppose you want to type an equation covering more than one line. For example:
x=3
y=1

Your first reaction would be to simply press the Enter key. However, if you press the Enter 
key, though the markup goes to a new line, the resulting equation does not. You must type the 
newline command explicitly. This is illustrated in the table below.

Markup Result

x = 3

y = 1

x=3 y=1

x = 3 newline

y = 1

x=3
y=1
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Common problem areas

How do I add limits to my sum/integral?
The “sum” and “int” commands can (optionally) take in the parameters “from” and “to”. 
These are used for lower and upper limits respectively. These parameters can be used singly 
or together. Limits for integrals are usually treated as subscripts and superscripts.

Markup Result

sum from k = 1 to n a_k

∑
k=1

n

ak

int from 0 to x f(t) dt

or 

int_0^x f(t) dt

∫
0

x

f t  dt  or  ∫0

x
f t dt

int from Re f ∫
ℜ

f

sum to infinity 2^{-n}
∑
∞

2−n

Note For more details on integrals and sums, see the table on page 438.

Brackets with matrices look ugly!
For background, we start with an overview of the matrix command:

Markup Result

matrix { a # b ## c # d } a b
c d

Note Rows are separated by two #’s and entries within each row are separated by one #.

The first problem people have with matrices is that brackets do not “scale” with the matrix:

Markup Result

(  matrix { a # b ## c # d }  ) 
a b
c d



OOoMath provides “scalable” brackets. That is, the brackets grow in size to match the size of 
their contents. Use the commands left( and right) to make scalable brackets.
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Markup Result

left(  matrix { a # b ## c # d }  right)

a b
c d 

Tip Use left[ and right] to obtain square brackets.

How do I make a derivative?
Making derivatives essentially comes down to one trick: Tell OOo it’s a fraction.

In other words, you have to use the “over” command. Combine this with either the letter 
“d” (for a total derivative) or the “partial” command (for a partial derivative) to achieve the 
effect of a derivative.

Markup Result

{df} over {dx} df
dx

{partial f} over {partial y} ∂ f
∂ y

{partial^2 f} over {partial t^2} ∂2 f

∂ t 2

Note Notice that we had to use squiggly brackets to make the derivative.

Numbering equations
Equation numbering is one of OOoMath’s best hidden features. The steps are simple, but 
obscure:

1) Start a new line.

2) Type “fn” and then press F3.

The “fn” is replaced by a numbered formula:

E=mc2  (2)

Now you can double-click on the formula to edit it. For example, here is the Riemann Zeta 
function:

 z =∑
n=1

∞ 1

nz
 (3)
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You can reference an equation (“as shown in Equation (2)”) with these steps:

1) Insert > Cross-reference.

2) Click on the References tab (Figure 427).

3) Under Type, select Text.

4) Under Selection, pick the equation number.

5) Under Format, choose Reference.

6) Click Insert.

Done! If you later add more equations to the paper before the referenced equation, all the 
equations will automatically renumber and the cross-references will update.

Figure 427. Inserting a cross-reference to an equation number.

Tip To insert the equation number without parenthesis around it, choose Numbering 
under Format instead of Reference.
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Unary / binary operators

Operation Command Display

+sign +1 1

–sign –1 −1

+/– sign +–1 ±1

–/+ sign –+1 ∓1

Boolean not neg a ¬a

Addition + a + b ab

Multiplication dot a cdot b a⋅b

Multiplication (X) a times b a×b

Multiplication (*) a * b a∗b

Boolean and a and b a∧b

Subtraction (–) a – b a−b

Division (fraction) a over b a
b

Division (operand) a div b a÷b

Division (slash) a / b a /b

Boolean or a or b a∨b

Concatenate a circ b a°b

434 Chapter 16  Math Objects



Math commands - Reference

Relational operators

Operation Command Display

Is equal a = b a=b

Is not equal a <> b a≠2

Approximately a approx 2 a≈2

Divides a divides b a∣b

Does not divide a ndivides b a∤b

Less than a < 2 a2

Greater than a > 2 a2

Similar to or equal a simeq b a≃b

Parallel a parallel b a∥b

Orthogonal to a ortho b a⊥b

Less than or equal to a leslant b ab

Greater than or equal to  a geslant b ab

Similar to a sim b a~b

Congruent a equiv b a≡b

Less than or equal to a <= b a≤b

Greater than or equal to a >= b a≥b

Proportional a prop b a∝b

Toward a toward b a b

Arrow left a dlarrow b a⇐b

Double arrow left and 
right

a dlrarrow b a⇔b

Arrow right a drarrow b a⇒b
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Set operations

Operation Command Display

Is in a in B a∈B

Is not in a notin B a∉B

Owns A owns b A∋b

Empty set emptyset ∅

Intersection A intersection B A∩B

Union A union B A∪B

Difference A setminus B A ∖B

Quotient A slash B A/B

Aleph aleph ℵ

Subset A subset B A⊂B

Subset or equal to A subseteq B A⊆B

Superset  A supset B A⊃B

Superset or equal to A supseteq B A⊇B

Not subset A nsubset B A⊄B

Not subset or equal A nsubseteq B A⊈B

Not superset A nsupset B A⊅B

Not superset or equal A nsupseteq B A⊉B

Set of natural numbers setN ℕ

Set of integers setZ ℤ

Set of rational numbers setQ ℚ

Set of real numbers setR ℝ

Set of complex numbers setC ℂ
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Functions

Operation Command Display

Exponential func e^{a} ea

Natural logarithm ln(a) ln a 

Exponential function exp(a) exp a 

Logarithm log(a) log a 

Power a^{b} ab

Sine sin(a) sin a 

Cosine cos(a) cos a 

Tangent tan(a) tan a

Cotangent cot(a) cot a

Square root sqrt{a} a

Arcsine arcsin(a) arcsin a

Arc cosine arccos(a) arccosa

Arctangent arctan(a) arctan a

Arc cotangent arccot(a) arccot a

nth root nroot{a}{b} a
b

Hyperbolic sine sinh(a) sinh a 

Hyperbolic cosine cosh(a) cosh a

Hyperbolic tangent tanh(a) tanh a

Hyperbolic cotangent coth(a) coth a 

Absolute value abs{a} ∣a∣

Arc hyperbolic sine arsinh(a) arsinh a

Arc hyperbolic cosine arccosh(a) arcosh a 

Arc hyperbolic tangent arctanh(a) artanh a

Arc hyperbolic cotangent arccoth(a) arcoth a

Factorial fact{a} a!   
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Operators
All operators can be used with the limit functions (“from” and “to”).

Operation Command Display

Limit lim{a} lim a

Sum sum{a} ∑ a

Product prod{a} ∏ a

Coproduct coprod{a} ∐ a

Upper and lower bounds 
shown with integral

int from {r_0} to {r_t} a
∫
r0

r t

a

Integral int{a} ∫ a

Double integral iint{a} ∬a

Triple integral iiint{a} ∭ a

Lower bound shown with 
summation symbol 

sum from{3}b ∑
3

b

Contour integral lint a ∮a

Double curved integral llint a ∯a

Triple curved integral lllint a ∰a

Upper bound shown with 
product symbol

prod  to{3} r
∏

3

r
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Attributes

Operation Command Display

Acute accent  acute a a

Grave accent grave a a

Reverse circumflex check a a

Breve breve a a

Circle circle a å

Vector arrow vec a a

Tilde tilde a a

Circumflex hat a a

Line above bar a a

Dot dot a ȧ

Wide vector arrow widevec abc abc

Wide tilde widetilde abc abc

Wide circumflex widehat abc abc

Double dot ddot a ä

Line over overline abc abc

Line under underline abc abc

Line through overstrike abc acb

Triple dot dddot a a

Transparent (useful to get a 
placeholder of a given size)

phantom a

Bold font bold a a

Italic font3 ital “a” a

Resize font size 16 qv qv
Following item in sans serif 
font4

font sans qv qv

Following item in serif font font serif qv qv

Following item in fixed font font fixed qv qv

Make color of following text 
cyan5

color cyan qv qv

3 Unquoted text that is not a command is considered to be a variable. Variables are, by default, italicized.

4 There are three custom fonts: sans serif (without kicks), serifs (with kicks), and fixed (non-proportional). To 
change the actual fonts used for custom fonts and the fonts used for variables (unquoted text), numbers and 
functions, use Format > Fonts.
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Operation Command Display

Make color of following text 
yellow

color yellow qv qv

Make color of following text 
white

color white qv qv

Make color of following text 
green

color green qv qv

Make color of following text 
blue

color blue qv qv

Make color of following text 
red

color red qv qv

Make color green returns to 
default color black

color green X qv X qv

Brace items to change color 
of more than one item

color green {X qv} X qv

5 For all coloring, the color will apply only to the text immediately following the command until the next space is 
encountered. In order to have the color apply to more characters, place the text you want in color in curly 
brackets.
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Miscellaneous

Operation Command Display

Infinity infinity ∞

Partial partial ∂

Nabla nabla ∇

There exists exists ∃

For all forall ∀

H bar hbar ℏ

Lambda bar lambdabar ƛ

Real part re ℜ

Imaginary part im ℑ

Weierstrass p wp ℘

Left arrow leftarrow 

Right arrow rightarrow 

Up arrow uparrow 

Down arrow downarrow 

Dots at bottom dotslow 

Dots at middle dotsaxis ⋯

Dots vertical dotsvert ⋮

Dots diagonal upward dotsup ⋰

Dots diagonal downward dotsdown ⋱
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Brackets

Operation Command Display

Round Brackets (a) a 

Square Brackets [b] [b]

Double Square Brackets ldbracket c rdbracket 〚c〛

Single line lline a rline ∣a∣

Double line ldline a rdline ∥a∥

Braces lbrace w rbrace {w }

Angle Brackets langle d rangle 〈d 〉

Operator Brackets langle a mline b rangle 〈a∣b 〉

Group brackets (used for 
program control)

{a} a

Scalable round brackets
(add the word “left 
before a left bracket and 
“right” before a right 
bracket)

left ( stack{a # b # z} right )


a
b
z 

Square brackets scalable

(as above)

left [ stack{ x # y} right ] [ xy ]
Double square brackets 
scalable

left ldbracket c right 
rdbracket 

〚c 〛

Line scalable left lline a right rline ∣a∣

Double line scalable left ldline d right rdline ∥d∥

Brace scalable left lbrace e right rbrace {e }

Angle bracket scalable left langle f right rangle 〈 f 〉

Operator brackets 
scalable

left langle g mline h right 
rangle 

〈 g∣h 〉

Over brace scalable {The brace is above} 
overbrace a The brace is above

a

Under brace scalable {the brace is 
below}underbrace {f}

the brace is below
f
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Formats

Operation Command Display

Left superscript a lsup{b} ab

Center superscript a csup{b}
a
b

Right superscript a^{b} ab

Left subscript a lsub{b} ab

Center subscript a csub{b} a
b

Right subscript a_{b} ab

Align character to left (text 
is aligned center by default) 

stack { Hello world # alignl (a) } Hello world
a 

Align character to center stack{Hello world # alignc(a)} Hello world
a

Align character to right stack { Hello world # alignr(a)} Hello world
a 

Vertical stack of 2 binom{a}{b} a
b

Vertical stack, more than 2 stack{a # b # z} a
b
z

Matrix stack matrix{a # b ## c # d} a b
c d

Common mathematical 
arrangement

matrix{a # "="b ## {} # "="c} a = b
= c

New line asldkfjo newline sadkfj asldkfjo
sadkfj

Small gap (grave) stuff `stuff stuff stuff

Large gap (tilde) stuff~stuff stuff stuff
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Math commands - Reference

Characters – Greek

%ALPHA A %BETA B %CHI X %DELTA  %EPSILON E

%ETA H %GAMMA  %IOTA I %KAPPA K %LAMBDA 

%MU M %NU N %OMEGA  %OMICRO
N

O %PHI 

%PI  %PSI  %RHO P %SIGMA  %THETA 

%UPSILO
N  %XI  %ZETA Z

%alpha  %beta  %chi  %delta  %epsilon 

%eta  %gamma  %iota  %kappa  %lambda 

%mu  %nu  %omega  %omicron  %phi 

%pi  %rho  %sigma  %tau  %theta 

%upsilon  %varepsilo
n 

 %varphi  %varpi  %varrho ϱ

%varsigma  %vartheta  %xi  %zeta 

Characters – Special

%and ∧ %angle ∢ %element ∈ %identical ≡

%infinite ∞ %noelement ∉ %notequal ≠ %or ∨

%perthousand  %strictlygreaterthan ≫ %strictlylessthan ≪ %tendto 
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Shortcut keys – Introduction

Shortcut keys – Introduction

You can use OpenOffice.org (OOo) without requiring a pointing device, such as a mouse or 
trackball, by using its built-in keyboard shortcuts. Tasks as varied and complex as docking 
and un-docking toolbars and windows, or changing the size or position of objects can all be 
accomplished with only a keyboard. Although OOo has its own extensive set of keyboard 
shortcuts, each component provides others which are specific to its work.

For help with OOo’s keyboard shortcuts, or using OOo with a keyboard only, search the OOo 
On-line Help using the “shortcut” or “accessibility” keywords.

Assigning shortcut keys

To adapt shortcut keys to your needs, use the Customize dialog box. You can assign shortcuts 
to standard Writer functions and/or macros and save them for use with Writer only, or with 
the entire OpenOffice.org suite.

Caution Be careful when reassigning your operating system, or OOo’s predefined shortcut 
keys. Many key assignments are universally understood shortcuts, such as F1 for 
Help, and are always expected to provide certain results. Although you can easily 
reset the shortcut key assignments to the OOo defaults, changing some common 
shortcut keys can cause confusion, frustration and possible data loss or corruption, 
especially if other users share your computer.

As an example, suppose you wish to apply a particular character style during document 
creation or editing, for example to add emphasis to a word, or words, and would like to do 
this via a shortcut key combination, rather than using the rather more long-winded menu 
access. You could assign Shift-F4 as a shortcut for this purpose, as described below:

1) Select Tools > Customize > Keyboard. The Customize dialog box (Figure 428) 
opens.

2) To have the shortcut key assignment available only with Writer, select the Writer 
button  ( located at the upper right corner of the Keyboard tab), otherwise select the 
OpenOffice.org button which will make it available to every component.

3) Next select Styles > CharacterStyles in the Category list and Strong Emphasis in 
the Function list.

4) Now select the shortcut keys Shift+F4 in the Shortcut keys list and click the Modify 
button at the upper right.

5) Click OK to accept the change. Now the Shift+F4 shortcut will apply the Strong 
Emphasis style to any selection.
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Assigning shortcut keys

Notes 1. All existing shortcut keys for the currently selected Function are listed in the 
Keys box. Since there is no currently assigned shortcut for the 
Styles > CharacterStyles function the Keys list is empty. If it were not, and 
you wished to reassign a shortcut key combination that is already in use, you 
must first Delete the existing Key.

2. Shortcut keys that are greyed-out in the listing on the Customize dialog box, 
such as F1 and F10, are not available for reassignment.

3. Remember, since the Writer button was selected at the start of this 
procedure, the newly assigned shortcut key will only work within the Writer 
component. To set this shortcut for use by all of the components within the 
suite, repeat this procedure after first selecting the OpenOffice.org button.

Figure 428: Customize dialog box
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Saving changes to a file
Changes to the shortcut key assignments (and other configurations) can be saved in a 
keyboard configuration file for use at a later time, thus permitting you to create and apply 
different configurations as the need arises. To save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button at the bottom 
right of the Customize dialog box (Figure 428).

2) In the Save Keyboard Configuration dialog box, select All files from the Save as Type 
combo box.

3) Next enter a name for the keyboard configuration file in the File name text box, or 
select an existing file from the listbox. If you need to, browse to find a file from 
another location.

4) Click Save. A confirmation message will appear if you are about to overwrite an 
existing file, otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the 
Load button at the bottom right of the Customize dialog box (Figure 428). Then select the 
configuration file from the Load Keyboard Configuration dialog box.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the Reset button at the 
bottom right of the Customize dialog box (Figure 428). Use this feature with care as no 
confirmation message will be displayed; the defaults will be set without any further notice or 
user input.

Running macros
You can also define shortcut key combinations that will run macros. These shortcut keys are 
strictly user-defined; none are built in. To terminate a macro that is currently running, press 
Shift+Control+Q.
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Shortcut keys for OpenOffice.org Writer

Table 6: Writer shortcut keys

Shortcut Keys Effect

Ctrl+A Select All

Ctrl+J Justify.

Ctrl+D Double Underline.

Ctrl+E Centred.

Ctrl+F Find and Replace.

Ctrl+Shift+P Superscript.

Ctrl+L Align Left.

Ctrl+R Align Right.

Ctrl+Shift+B Subscript.

Ctrl+Y Redo last action.

Ctrl+0 (zero) Apply Default paragraph style.

Ctrl+1 Apply Heading 1 paragraph style.

Ctrl+2 Apply Heading 2 paragraph style.

Ctrl+3 Apply Heading 3 paragraph style.

Ctrl+5 1.5 Line Spacing.

Ctrl+ Plus Key(+) Calculates the selected text and copies the result to the 
clipboard.

Ctrl+Hyphen(-) Custom hyphens; hyphenation set by you.

Ctrl+Shift+minus sign (-) Non-breaking dash (is not used for hyphenation).

Ctrl+multiplication sign * 
(only on number pad)

Run macro field.

Ctrl+Space Non-breaking spaces. Non-breaking spaces are not used for 
hyphenation and are not expanded if the text is justified.

Shift+Enter Line break without paragraph change.

Ctrl+Enter Manual page break.

Ctrl+Shift+Enter Column break in multi-columnar texts.

Alt+Enter Inserting a new paragraph without numbering.

Alt+Enter Inserting a new paragraph directly before or after a section 
or a table.

Arrow Left Move cursor to left.

Shift+Arrow Left Move cursor with selection to the left.

Ctrl+Arrow Left Go to beginning of word.

Ctrl+Shift+Arrow Left Selecting to the left word by word.
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Shortcut Keys Effect

Arrow Right Move cursor to right.

Shift+Arrow Right Move cursor with selection to the right.

Ctrl+Arrow Right Go to end of word.

Ctrl+Shift+Arrow Right Selecting to the right word by word.

Arrow Up Move up one line.

Shift+Arrow Up Selecting lines in an upwards direction.

Arrow Down Move cursor down one line.

Shift+Arrow Down Selecting lines in a downward direction.

Home Go to beginning of line.

Shift+Home Go and select to the beginning of a line.

End Go to end of line.

Shift+End Go and select to end of line.

Ctrl+Home Go to start of document.

Ctrl+Shift+Home Go and select text to start of document.

Ctrl+End Go to end of document.

Ctrl+Shift+End Go and select text to end of document.

Ctrl+PageUp Switch cursor between text and header.

Ctrl+PageDown Switch cursor between text and footer.

Insert Insert mode on/off.

PageUp Screen page up.

Shift+PageUp Move up screen page with selection.

PageDown Move down screen page.

Shift+PageDown Move down screen page with selection.

Ctrl+Del Delete text to end of word.

Ctrl+Backspace Delete text to beginning of word.

Ctrl+Shift+Del Delete text to end of sentence.

Ctrl+Shift+Backspace Delete text to beginning of sentence.

Ctrl+Tab Next suggestion with Automatic Word Completion.

Ctrl+Shift+Tab Use previous suggestion with Automatic Word Completion.

Alt+W Spell checker dialog box: Call back the original unknown 
word into the text box.

Ctrl+ double-click or 
Ctrl+Shift+F10

Use this combination to quickly dock or un-dock the 
Navigator, Styles and Formatting window, or other 
windows.
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Shortcut keys for tables

Table 7: Shortcut keys for tables in OpenOffice.org Writer

Shortcut Keys Effect

Ctrl+A If the active cell is empty Ctrl+A selects the whole table; 
otherwise it selects the contents of the active cell. 
Depressing Ctrl+A a second time selects the entire table.

Ctrl+Home If the active cell is empty Ctrl+Home moves the cursor to 
the beginning of the table. Depressing Ctrl+Home again 
moves the cursor to the beginning of document.

If the active cell is not empty Ctrl+Home moves the cursor 
to the beginning of the active cell. A second depression of 
Ctrl+Home moves the cursor to the beginning of the 
current table. A third depression moves the cursor to the 
beginning of the document.

Ctrl+End If the active cell is empty Ctrl+End moves the cursor to the 
end of the table. Depressing Ctrl+End again moves the 
cursor to the end of document.

If the active cell is not empty Ctrl+End moves the cursor to 
the end of the active cell. A second depression of Ctrl+End 
moves the cursor to the end of the current table. A third 
depression moves the cursor to the end of the document.

Ctrl+Tab Inserts a tab stop (only in tables). Depending on the 
Window Manager in use, Alt+Tab may be used instead.

Ctrl+Shift+Arrow Up Jump to start of table

Ctrl+Shift+Arrow Down Jump to end of table

Alt+Arrow Keys Increases or decreases the size of the column or row on the 
right or bottom cell edge

Alt+Shift+Arrow Keys Increase or decrease the size of the column or row on the 
left or top cell edge

Ctrl+Alt+Shift+Arrow Keys Like Alt, but only the active cell is modified

Alt+Insert Provides 3 seconds in Insert mode, during which time an 
Arrow Key will insert a row or column, or Ctrl+Arrow Key 
will insert a cell.

Alt+Del Provides 3 seconds in Delete mode, during which time an 
Arrow key will delete a row or column, Ctrl+Arrow Key 
will merge the active cell with the neighbouring cell.

Ctrl+Shift+T Removes cell protection from all selected tables. If no table 
is selected, then cell protection is removed from all of the 
tables in the document.
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Shortcut Keys Effect

Ctrl+Shift+Del If nothing is selected, the contents of the next cell will be 
deleted. If cells are selected, the whole row(s) of the 
selection will be deleted. If all rows are selected completely 
or partially, the entire table will be deleted.

Shortcut keys for paragraphs and heading 
levels

Table 8: Shortcut keys for paragraph and heading levels

Shortcut Keys Effect 

Ctrl+Alt+Up Arrow or 
Ctrl+Up Arrow

Move the active paragraph or selected paragraphs up one 
paragraph.

Ctrl+Alt+Down Arrow or 
Ctrl+Down Arrow

Move the active paragraph or selected paragraphs down one 
paragraph.

Tab The heading in format Heading X (X = 1–9) is moved down 
one level in the outline.

Shift+Tab The heading in format Heading X (X = 2–10) is moved up 
one level in the outline.

Ctrl+Tab At the start of a heading: Inserts a tab stop. Depending on 
the Window Manager in use, Alt+Tab may be used instead.

To change the heading level with the keyboard, first 
position the cursor in front of the heading.
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Index

A 
accepting or rejecting changes 81
address book 286
address data source 285
align cells in table 249
aligning graphics 236
alphabetic index 

adding index entries 335
creating 335

anchoring frames 105
anchoring graphics 239
antialiasing screen font 29
appearance options 36
Apply Style list 190
arranging graphics 236
Asian languages 51
Assign action dialog (form) 418
attribute commands (Math) 439
AutoCaption 49, 240
AutoCorrect 44, 54, 66, 75
Autofit 257
AutoFormat 54
AutoFormat dialog box 264
autoformat table 249
autoformatting 66
automatic caption 49, 262
automatic page or column breaks 200
AutoText 76
AutoText dialog box 382
AutoText for entering fields 381
autoupdate styles 194

B 
Base main window 412
bibliographic database 

adding entries 347
columns 345
creating 344
fields 345
filter 345

bibliography 
creating 343
creating database 344
editing 354
formating 349
master document 368
paragraph style 351
references 348

book preview 21, 137
booklet printing 138
bookmarks 84, 384, 385
brackets (Math) 430
brackets commands (Math) 442

brochure printing 138
bulleted list 66, 68
Bullets and Numbering toolbar 68, 216

C 
Caption dialog box 241
captions 240
captions, manual 242
cells in table, formatting 252
change tracking options 47
chapter numbers 389
character formatting 66
character styles 

applying 179
undoing 179
using 178

characters –  special (Math) 444
characters – Greek (Math) 444
citations 348
clipboard 31
closing a document 22
closing Writer 23
color options 33
column width in table 257
column, inserting in table 249
columns 

changing the number 101
defining 98
distributing text evenly 99
formatting 100
newspaper-style 99
separator lines 100

command line, starting Writer 8
comments 80
comparing documents 79, 83
compatibility options 48
complex text layout languages 51
conditional content 390, 392
conditional text 391, 394
convert colors to grayscale 45
converting between table and text 265
counting words 87
create document from template 272
creating a document 16
cross-reference 129
cross-references 

between documents 369
in headers or footers 388
inserting references 386
overview 84, 384
preparing headings as targets 385
setting references 385

cutting and copying text 57

Writer Guide 453



Index

D 
dashes 64
data entry in tables 265
data source 

accessing existing 414
accessing using a form 411
definition 284
registering 285

database 
access permissions 419
creating 411
Table Design window 413

Database Wizard 412, 414
default file format 38
default template 278
derivative markup (Math) 432
dictionaries 51
dictionary 71
different first page 93
digital rights management (DRM) 149
digital signature 153
direct cursor 44
distribute columns or rows in table 249
dithering 30
DocInformation field 392
dockable/floating windows 13
document 

closing 22
create from template 272
creating 16
opening 17
printing 19
saving 18
saving as a Microsoft Word 18

document status 28
document views 12
double-sided printing 45
Drawing Object Properties toolbar 244
drawing objects 

anchoring 239
grouping 245
properties 244

Drawing toolbar 244
drawing tools 243
duplex printer 45

E 
e-mail options 50
e-mailing 

Mail Merge Wizard 151
several recipients 150
Writer document as attachment 150

edit document properties before saving 38
Edit Fields dialog box 397
en and em dashes 64
endnotes 69, 117
envelope 

formatting address blocks 139
Mail Merge dialog 303
mail merge from database 139
printing 138

envelope printing 138
EPS images in PDF 146
equation 

inserting 422
layout 429
numbering 432

equation editor 422
brackets 430
derivative markup 432
equations over more than one line 430
floating window 428
font size 429
formula layout 429
limits to sum/integral 431
markup 425
matrix markup 431
right-click menu 425
Selection window 423

export directly as PDF 21, 145
exporting to PDF 21, 145
extended tips 22, 27
Extension Manager 277

F 
facing pages 169
fax icon, adding to toolbar 143
fax sending 143
Fax Wizard 274
FDF 147
features 2
field names, show/hide 390
field shadings on/off 390
fields 

automatic updating 397
AutoText entry 384
AutoText for entering 381
bookmark 84, 385
bookmarks 384
converting into text 390
cross-reference 84, 384
DocInformation 392
document properties 380
document title 388
entering 378
fixed content 381, 390
gray background on screen 378
hidden text 395
in headers and footers 388
keyboard shortcuts 390
number range variable 382
page count 389
page number 378, 388
placeholder 398
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updating 390
user-defined variable 384, 392

Fields dialog box 
DocInformation tab 380
Document tab 381, 388
Functions tab: conditional text 394
Functions tab: hidden text 395
Functions tab: placeholder field 398
open using keyboard 390
References tab 384, 386, 387

file locations 32
file sharing options 35
Fill Format mode 190
finding and replacing text 59
floating toolbars 10, 11
floating/dockable windows 13
font family 44
font history 30
font options 34
font preview 30
font replacements 34
font size, relative 202
fonts, default 44
footnote (or endnote) marker 70
footnote formatting 70
footnotes 69, 115
form 

accessing data sources 411
adding form controls 408
configuring controls 402
configuring form controls 409
control formatting options 419
creating 401
customization, advanced 417
data entry form creation 415
database access permissions 419
Design Mode 402
entering data 417
example of creating a form 408
form controls reference 404
form properties 416
Form Properties dialog 416
inserting form controls 402
linking macro to a control 417
read-only  419
toolbars 401
using the form 403
when to use 400
XForms 420

Form Control dialog 403
Form Controls toolbar 401
Form Design toolbar 401, 406
form letter 

creating with wizard 305
Form Properties dialog 416
formats commands (Math) 443
Formatting Aids options 43
formatting, finding and replacing 61

formula 
inserting 422
layout 429
numbering 432

formula editor 
brackets 430
derivative markup 432
equations over more than one line 430
floating window 428
font size 429
limits to sum/integral 431
markup 425
matrix markup 431
right-click menu 425
Selection window 423

frame 
anchoring 105
border 104
creating 102
linking 106
moving, resizing, and changing attributes 103

Frame dialog box 104, 107
frame styles 

applying 221
formatting 220
overview 219

Frame toolbar 236
function commands (Math) 437

G 
Gallery 

adding an image 233
opening 232

general options 27
general options for Writer 41
GNOME 3, 4
graphics 

adding 233
adding captions 240
adding from file 228
alignment 236
anchoring 239
arrangement 236
file types supported 246
GIMP 234
linking 229
modifying 234
positioning 236
resizing 229
wrapping text around 237

Greek characters 426
grid intervals 44

H 
header 

different on right and left pages 177
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headers 173
headers and footers 121, 388
Help 22, 27
Help Agent 22, 28
hidden paragraphs 391
hidden section 114
hidden sections 391
hidden text 391, 395
high contrast 28
horizontal lines 66
HTML compatibility 40
HTML documents 44
hyperlinks 

editing 86
inserting 84

hyphenation 73

I 
icon size and style 29
icons in menus 29
images 

adding from file 228
anchoring 239
linking 229
resizing 229
scanned 232
wrapping text around 237

indent distance 42
indents 65
index 

capitalizing entries 339
creating 335
customizing 337
figures, tables, and other 342
key 337, 339
sorting entries 339

index entries 335
customizing 336, 339
editing 342

Index Link character style 328
Insert Bookmark dialog box 385
Insert Index Entry dialog 336
Insert Index/Table dialog 322
insert mode 87
Insert Section dialog box 111, 396
interface, Writer 9
Internet Link character style 328

K 
KDE 3, 5, 8
KDocker 8
kerning text 205
keyboard shortcuts 

customizing 191
select nonconsecutive items 57

keyboard shortcuts for fields 390

L 
label printing 141
labels 

printing 141
landscape page in portrait document 96
landscape pages 95, 130
language selection for paragraph styles 203
language settings 51
limits to sum/integral 431
line numbering 77
lines 66
linking frames 106
Linux 3, 4, 5, 8
list (numbering) styles 

Bullets and Numbering toolbar 216
overview 213

load/save options 37
loading styles 198
locale settings 51
logical expressions 391
long-click buttons 10

M 
Mac OS X 3, 6
Macintosh 56
macro 

linking to a form control 417
mail merge 

Adjust Layout dialog 312
Create Salutation dialog 311
edit saved file 298
envelopes 303
Mail Merge dialog 291, 303
Match Fields dialog 310
New Address Block dialog 309
overview 284
personalize documents 315
save, print or send 316
Select Address Block dialog 308
Select Address List dialog 307

Mail Merge dialog 291, 303
mail merge e-mail options 50
Mail Merge Wizard 

e-mailing Writer document 151
mailing labels 293
manual formatting, removing 66
manual page breaks 171
marginal notes 108
margins, changing 97
master document 

anchoring pictures to page 376
bibliography 368
breaking links 372
changing styles 368
chapter reference in header 373
combining several documents 358
creating 358
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creating one file 372
cross-referencing between subdocuments 369
editing 368
editing subdocuments 368
exporting to .odt file 372
index 368
landscape pages in portrait document 375
Navigator 356
no existing documents 359
planning 360
splitting one document 358
styles 356, 361
subdocument creation 362
subdocument inclusion 365
table of contents 368
template 362
title page 363

Match Fields dialog 310
Math commands reference 434
mathematical equations 422
mathematical markup 425
mathematical symbols 423
matrix markup (Math) 431
measurement unit 65
menus 9
merge cells in table 249
merging and splitting cells in table 253
merging and splitting tables 254
merging documents 83
Microsoft Office file conversion 39
Microsoft Word 7, 48
middle mouse button function 31
mirrored margins 169
miscellaneous commands (Math) 441
More (Form) Controls toolbar 401, 405
mouse positioning 31

N 
name and initials of user 26
Navigator 

in master document 356
in normal document 14

nested tables 251
New Address Block dialog 309
newsletter layout 91
Next Style 94
no wrap 237
non-breaking hyphen 64
non-breaking spaces 63
non-consecutive items, selecting 56
notes 80
Number Format dialog box 110
number formats in tables 261
number range variable 382
number recognition 47, 110, 261, 265
numbered lists 66, 68
numbering equations 432

numbering pages 125
numbering pages by chapter 131
numbering sequence, defining 382

O 
Office Assistant 28
Open/Save dialog boxes 28
OpenGL 30
operator commands (Math) 438
optimal page wrap 237
organizing templates 279
orientation of page 95
orphan control 200
OutlineCrossRef3 macro 369
overwrite mode 87

P 
page break, manual 92
page breaks 171, 199
page count in header or footer 389
page count, problem 127
page headers 212
page layout 

choosing best method 90
different first page 93
headers and footers 121
landscape page 95
landscape page in portrait document 96
margins, changing 97
newsletter 91
orientation 95
portrait headers on landscape pages 122
snaking columns 91
using columns 98
using frames 102
using sections 111
using styles 92
using tables 108

page number 
automatic 125
format, changing 127
numbering by chapter 131
odd and even 177
restarting 126, 175
restarting, problems 127
starting with page number greater than 1 130

page numbers 173, 378
Page Preview 20, 137
page style 

book sequence 172
current 168
facing pages 169
inserting a page with special formatting 172
mirrored margins 169
modifying 169
Next Style property 170
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page styles 92
overview 222

page wrap 237
pages, total number of 125
paragraph 

formatting 64
moving 58
spacing at tops of pages 49

paragraph ends 43
paragraph markers 101
paragraph styles 

conditional 216
custom 163
features 199
finding and replacing 62
kerning text 205
language selection 203
linked 162
next style 164
orphan and widow control 200
outline levels 206
page headers 212
rotating text 204

password 79
password-protect PDF 149
pasting text 57
path options 32
PDF 

blank page export 147
digital rights management (DRM) 149
encrypt 149
EPS images 146
export documents to 21, 145
form 147
image compression and resolution 146
initial view selection 147
pages to export 145
password-protect 149
security settings 149
tagged 146
user interface settings 147

PDF Options dialog 145
Picture dialog box 236
pictures 

adding 233
adding from file 228
anchoring 239
linking 229
resizing 229
wrapping text around 237

placeholder field 398
preview of fonts 30
previewing pages 20
Print dialog 19
Print dialog box 134
print file directly 134
print options 31, 45
printer metrics 48

Printer Options dialog 135
printer settings 38
printer warnings 31
printer, specifying 20
printing 

black and white on color printer 136
book preview 137
booklet 138
brochure 138
choosing what to print 134
default settings 136
envelopes 138
grayscale on color printer 136
labels 141
overview 19
previewing 137
print options 20, 135
printer selection 134

Properties dialog box 379
protecting a document 79

Q 
Quickstarter 

Linux 8
Windows 7

R 
read-only forms 419
recording changes 79, 80
redlines 79
redo 79
regular expressions 60
rejecting changes 81
relational operator commands (Math) 435
relative font size 202
replacement table (font) 34
reverse order printing 45
revision marks 79
rotating text 204
rotating text in a table cell 264
row height in table 257
row, inserting in table 249
rulers 12, 65
rulers, changing margins 98

S 
Save 18
scaled resizing of graphics 231
scaling factor 29
scanner 232
screen font antialiasing 29
searching in Japanese 51
section 

boundaries 36
conditional 396
creating 111
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deleting 118
editing the format 119
hidden 396
hiding 114
linking 112
links, updating 120
naming 112
password-protecting 113
saving 117
selecting 117
uses of 111
write-protecting 113

security options 35
Select Address Block dialog 308
Select Address List dialog 307, 308
selecting text 56
selection clipboard 31
send document as e-mail 150
set operations commands (Math) 436
set reference 128
shortcut keys, assigning styles 191
sideheads 108
size optimization 38
snaking columns 91
snap to grid 44
Solaris 58
sorting data in a table 249, 266
spacing at tops of pages 49
spacing between paragraphs and tables 48
special characters 63
spelling 71
spelling options 53
split cells in table 249
spreadsheet functions in table 268
starting Writer 

from an existing document 7
from the command line 8
from the system menu 3
preloading OOo under Linux/KDE 8
Quickstarter 8

Style dialog box 192
styles 

applying 159, 188
AutoUpdate 194
book chapter sequence of pages 222
changing formatting 166
character 178
copying 196
creating by drag and drop 196
creating from selection 195
custom 163
definition 156
deleting 198
example of use 156
linked 162
linking 195
list (numbering) styles 213
loading from template or document 198

modifying 159, 192
moving 196
next style 164
overview 188
page styles 168, 222
paragraph styles 158
relative font size 202
Style dialog box 194
tab stops 201
types 157, 188
updating from document or template 194
updating from selection 193

Styles and Formatting window 157, 189
subdocuments 358, 362
sum cells in table 249
superordinate object settings 256
system font for user interface 29
system menu, starting from 3

T 
tab stops 42, 65, 201
table 

alignment on page 254
allow to break across pages 256
AutoCorrect to create 251
autoformat 249
automatic caption 262
background colors and graphics 259
borders 258
boundaries 36, 264
caption 261
column width 257
columns and rows 249
converting between table and text 265
copying 267
creating 250
creating using AutoCorrect 251
cross-reference to caption 263
data entry 265
deleting 266
do not split 251
formatting 252
formatting cells 252
heading 250
heading, creating in existing table 264
inserting 250
line arrangement (borders) 258
linking graphic file 260
merging and splitting 253
moving 267
moving between cells 265
nested table 251
number formats 261
number recognition 261, 265
page layout using 108
page or column break 256
properties 250
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repeat heading 251
resizing rows and columns 257
rotating text 264
row height 257
rows 253
sort cells 249
sorting data 266
spacing at tops of pages 49
spacing on page 254
spacing to contents 258
spreadsheet functions 268
sum cells 249
text flow 256
vertical alignment of cells 261
vertical alignment of text in cells 257
when to use 248

Table Design window 413
Table Format dialog box 110

Background tab 260
Borders tab 259
Columns tab 258
Table tab 255
Text Flow tab 96, 256

Table menu and toolbar 248
table of contents 

accessing from the Navigator 334
adding or changing elements 327
background 331
changing number of levels included 324
character styles 328
columns 330
creating 320
creating from additional styles 324
creating from an outline 324
creating from index marks 324
customizing 322
deleting 334
editing 333
formating entries 326
graphic in background 332
hyperlinking entries 327
including chapter numbers 327
Index Link character style 328
Internet Link character style 328
paragraph styles 329
protecting against manual changes 324
scope  323
Tab position relative to Paragraph Style indent 329
updating 333

table options 46
tabs vs tables 248
tear-off toolbars 10
template 

create document from 16, 272
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