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sudo add-apt-repository ppa:libreoffice/ppa

sudo apt-get update

sudo apt-get install libreoffice

NEW 
SERIES!
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In my last article, I wrote about 
changing the layout of 
paragraphs to format your 
document. While this 

approach is okay on short 
documents, it creates a lot of work 
should you decide to change 
something in a large document. 
This is where the use of styles will 
make things easier. 

LibreOffice writer has five 
different style types: paragraph, 
character, frame, page, and list. 
You can access all the styles by 
clicking on the Styles and 
Formatting button on the 
formatting toolbar. This will pop 
up the Styles and Formatting 
window. You can dock the Styles 
and Formatting window on the left 
by holding down the Ctrl key and 
double-clicking the empty space in 
the Styles and Formatting window 
toolbar. 

The styles toolbar (right)has 
seven icons. The first five give you 
access to the different style types. 
In order from the left, they are 
paragraph, character, frame, page, 
and list. We will concentrate on 

paragraph and character styles in 
this article. 

Open a new text document and 
type in a title. Open the Styles and 
Formatting window. The 
paragraph icon should be selected 
by default. At the bottom of the 
Styles and Formatting Window is a 
drop-down box. Click on the box 
and select Chapter Styles. Double-

click “title”. Your title will center, 
enlarge, and become bold. Now, 
let's change the default styling for 
titles. In the Styles and Formatting 
window, right-click on the “title” 
style and select modify. The dialog 
that pops up looks a lot like the 
dialog from the last article, but 
there are a few new tabs that are 
not in the standard paragraph 
dialog. The first is the organizer. 
The organizer (below) shows you 
the name for the style, the next 
style to use, and the linked style. 
You will see that the next style is 
“subtitle”, but we don't want to 
use a subtitle, so we will change 
this to the “text body” style. This 
makes it so that when we hit Enter 
to start a new paragraph the next 
paragraph will use the “text body” 

style. The “title” style is linked 
with the “Heading” style. When 
styles are linked, any changes to 
the parent style affects the styles 
linked to it. As an example, if you 
change the text in the “Heading” 
to blue, all the styles linked to it 
will have blue text as well. 

Now, let's format our title 
differently from the default. Click 
on the Font Effects tab. The Font 
Effects (next page, top left) allow 
you to change the look of the font, 
including color, strike-through, 
underline, shadow, and relief. The 
dialog shows you how the effects 
make your text look. Change the 
color to blue, underlining to 
Double Wave, and underline color 
to blue. Click OK.
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Press Enter to start a new 
paragraph. Notice the style 
changed to “text body” just like we 
set up in the organizer tab. Now, 
type in three paragraphs of text to 
use for our example document. 

Next, we will modify the “text 
body” style and create two new 
ones based on the “text body” 
style. Back in the Styles and 
Formatting window, click the drop-
down box and select the Text 
Styles category. Right-click on 
“text body” and select modify. On 
the Indents & Spacing tab, change 

the line spacing to 1.5 lines, and 
the First Line to 0.50. Click OK. 
Notice that our changes affected 
all three paragraphs. 

Now, let's create a paragraph 
for long quotes. Move the cursor 
to anywhere in the second 
paragraph. In the styles window, 
right-click text body and select 
New. On the organizer tab, give it 
the name of “Blockquote.” Change 
the next style to “text body”, as 
we rarely have two long quotes in 
a row. You will notice that because 
we created the new style by right-
clicking on text body, it is 

automatically linked to “text 
body”. To create a new style not 
linked to another, change the 
Linked with to “None”.

Now, let's change the 
formatting of our new style. On 
the Indents & Spacing tab, change 
the “before text” and “after text” 
to 0.50. Change the First Line back 
to 0.00. On the Font tab, change 
the typeface to italic. Click OK, and 
you will notice a new paragraph 
named “Blockquote” has been 
added to your list. Again, move 
your cursor to anywhere in the 
second paragraph and double-click 
“Blockquote.” Now, you will see 
the first line indent has been taken 
away, the paragraph is indented on 
both sides, and the text is 
italicized. 

Now, we want to change the 
first paragraph, giving it some 
drop caps. Since we want the first 
paragraph of each chapter to look 
this way, we will create another 
style. Again, right-click on “text 
body” and select New. Name the 
new style “First Paragraph”, and 
change the next style to “Text 
Body.” On the Indents & Spacing 
tab, change the First Line back to 
0.00. On the Drop Caps tab (shown 
below), check “Display drop caps”, 
set “Number of characters” to 1 
and set “Lines” to 2. Click OK. 
Again, no changes are seen yet. 
Move your cursor into the first 
paragraph and double-click your 
new style. 

We need this new paragraph 
style to follow every new chapter 
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title. Modify the “title” style so the 
next style is “First Paragraph.”

Character styles affect only 
selected text rather than entire 
paragraphs. In the third paragraph, 
select some of the text. Click on 
the character style icon in the 
styles window, and double-click 
“Emphasis.” This will italicize the 
text you have selected. You can 
modify the character styles much 

in the same way you do the 
paragraph styles.

The key advantage to styles is 
making the formatting of like text 
the same throughout a document. 
In the next article, we will talk 
about adding frames to your
document. 

Elmer Perry is a children's minister 
in Asheville, North Carolina whose 
hobbies include web design, 
programming, and writing.
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In the last article we used 
paragraph styles to format 
our document by creating 
reusable styles for 

consistency in our document. In 
this article we will create a more 
advanced layout using frames. 
While there are programs, like 
Scribus, which are designed more 
specifically toward more advanced 
layouts, LibreOffice gives us 
several tools which allow us to 
produce documents with more 
than just a simple, letter-style 
layout. One of the most useful of 
these tools is the frame. 

You can think of frames as 
boxes used to control the flow of 
text, graphics, and other elements 
in your document. One of the key 
features of frames is their ability 
to link together. When two frames 
are linked, the text from one 
frame automatically flows into the 
other, even if the two frames are 
on different pages. This feature 
makes frames ideal for 
newsletters and other article-
based documents. 

We will create the beginning 
article layout, shown in figure 1, 
using frames to control the flow of 

the article text. Start by creating a 
new document. Now, in the 
menus, go to Insert > Frame. The 
frame dialog will pop up. On the 
type tab, check Relative for both 
Width and Height. Set the Width 
to 100% and the Height to 25%. In 
the position section, set the 
Horizontal to From Left by 0.00” to 
Paragraph area. Set the Vertical 
position to From Top by 0.00” to 
Margin.

On the Options tab, name the 
frame “Article Header.” The frames 
are automatically named using the 
format “Frame#” where # is the 
number of frames in the 
document. It is a good practice to 
give your frames meaningful 
names to help you remember their 
purpose. 

By default, frames have a 
border on all four sides, but we 
want a border only at the bottom 
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of our frame. On the Borders tab, 
select the first box under the Line 
Arrangement defaults. This will 
clear all the borders. Check at the 
bottom of the the User-defined 
box to create a bottom border.

We are now done with the 
setup of this frame. We will come 
back to it when we are ready to 
link our frames together. For now, 
click on OK. You will see your new 
frame in your document.

Now, let’s create a frame for 
the bottom half of the article. Click 
below the header frame. Once 
again in the menus, choose Insert 

> Frame. Again, we want a relative 
width and height. Set the width to 
100% and the height to 75%. Set 
the horizontal position to From 
Left by 0.00” to Paragraph area. 
On the Options tab, name the 
frame “Article Body.” On the 
Borders tab, clear all the borders.

Now, we need the body of our 
article to have two columns. This is 
done on the Columns tab. Change 
the number of columns to 2, and 
set the spacing to 6%. Click on OK, 
and your new frame appears. You 
may need to manually adjust the 
position of your frames to get 
them to line up correctly. You 
adjust the frames position by 
clicking on the border of the 
frames. You will see green handles 
appear on the border. The green 
handles are used to adjust the size 
of the frame. We shouldn't need to 
change the size - just tweak the 
position. Click and drag on the 
border where there are no handles 
to adjust the position of the 
frames. To make fine adjustments 
to the position of your frame use 

the Alt+Arrow keys.

We now have our frames where 
we want them. Before we start 
writing our article, we need to link 
the two frames together. Double-
click on the border of the header 
frame (the first frame we created).
This displays the frame dialog. On 
the Options tab, click the drop-
down box for next link and select 
the “Article Body” frame. This links 
our two frames together. Click OK 
to accept this change and return 
to the document. 

In the document, click inside 
the header frame. Format a title 
and byline using any of the 
methods discussed in previous 
articles. Now, begin to type the 
paragraphs for your document. 
You will notice that when you get 
to the bottom of the first frame, 
Writer will automatically move you 
to the lower frame, and when you 
reach the bottom of the first 
column, writer will take you the 
top of the second. If your article is 
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more than one page long, you 
could link “Article Body” frame to 
a frame on another page. This 
linking is a powerful way to control 
the layout and flow of an article to 
create a very professional looking 
document. 

Let's add a graphic to our 
header frame: Insert > Picture > 
From File. Select the graphic you 
want to insert, and click Open. If 
the image is too big for your 
document, you will want to resize 
it. To keep from distorting the 
image, hold the Shift key while 
dragging the handles. To put the 
image into the frame drag it to the 
lower right corner of the frame, 
right-click, and Anchor > To Frame. 

Double-click the image to bring up 
its properties dialog. On the Wrap 
tab, increase the left spacing to 
give the image some white space.

Graphics in LibreOffice are 
actually frames. When you double-
click on a graphic in a document, 
you get a frame dialog with two 
new tabs: Picture and Crop. On the 
Picture tab, you can flip the image 
vertically or horizontally. You can 
specify whether the flip happens 
on just certain pages or on all 
pages. On the Crop tab, you can 
adjust the left, right, top, and 
bottom to crop out certain parts 
of the image. This is handy when 
you need only a part of the image, 
or need to force the image to a 
certain size without distorting the 

image’s aspect ratio. Also, you can 
scale the image to a certain size 
based on a percentage of the 
original image size. You can see or 
change the image size by 
measurement units as well.

On the right-click menu of an 
image, you can add a description 
or caption to the image. Adding a 
caption creates a text frame 
around the image with the text at 
the bottom. This feature is useful 
for marking illustrations or 
diagrams in your document. Once 
you have created the caption, you 
can highlight it and format it just 
like you would any other text in a 
document. 

Hopefully, you have gotten 
some idea of the power of using 
frames. While our example was 
fairly simple, you could easily 
create a more complex document 
layout using frames. With the 
ability to link frames, you can 
create a newsletter layout where 
articles start on one page, jump to 
another, and end on yet another. 

Next time, we will look at 
another powerful layout feature 
available in LibreOffice Writer: 
Sections.

Elmer Perry is a children's minister 
in Asheville, North Carolina whose 
hobbies include web design, 
programming, and writing.
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In the previous part of this 
series, we discussed using 
frames for document layout. 
In this part, we will turn to 

another useful layout tool in 
LibreOffice Writer: Sections. 
Sections differ from frames in 
several respects, but, in some 
ways, they can achieve the same 
results. While both will allow you 
to divide a portion of your 
document into columns, when you 
use sections, you have no control 
over the width. Sections will take 
the entire width from the left 
margin to the right margin. 
Sections also cannot break in the 
middle of a paragraph. You cannot 
link sections together the way you 
link frames. While you cannot link 
sections together, sections give 
you the ability to link to other 
documents, or to a section in 
another document. 

Perhaps the best way to think 
about sections is as a way to divide 
your document into different 
pieces like introduction, argument 
1, argument 2, etc. Sections can 
also allow you to separate a 
portion of a document for use in 

another document. Sections can 
become a powerful tool for 
allowing you to pull content from 
other documents. 

Using Sections

For our example, we will import 
quotations from a document of 
quotes. Start a new document, and 
add a list of different quotes. Do 
the following for each of the 
quotes: 

Select the entire quote. 

On the menus, got to Insert > 
Section. 

Give the quote a name that will 

remind you what the quotation is 
about. (For example, one of my 
quotes is from Albert Einstein on 
science. I named it quote_science.)

Once you have made each of 
the quotes its own section, save 
the file as quotes.odt.

Next, let's create a new 
document, and add some 
paragraph body text. (Hint: You 
can add dummy text to your 
document by typing “dt” and 
pressing the F3 key.) Write a lead-
in to your quote, and press enter. 
To get our quote from our quotes 

document, Insert > Section. As
always, give the section a name 
that helps you remember what it 
is. Select the Link checkbox. Click 
on the file browser button (…) 
next to File name. Select the 
document containing your quotes, 
and Open. Use the Section 
dropdown box to select the quote 
you want to insert into your 
document. If you want to write-
protect your quote from editing, 
check Protected under Write-
protection. You can also protect 
the section from editing with a 
password. (NOTE: Write 
protection, even with a password, 
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does not guarantee someone 
cannot hack your document and 
change its content.) You can add 
the other quotes from your quote 
document using the same method.

 

Editing Sections

Now that we have added our 
quotes, let's make them stand out 
by indenting them and giving them 
a background color. Format > 
Sections. The edit Sections dialog 
presents you with a list of sections 
in your document. Select the 
section you want to edit. In the 
main window of the dialog, we can 
change the link document, or the 
section in the document the 
section is linked to. Here we can 
also change the write-protection 
and visibility of the section. (I can't 
think of any practical reason why 
you would hide a portion of the 

document, but the option is there 
should you need it.) 

Click the Options... button to 
bring up the options dialog. On the 
Indents tab, change the Before 

section and After section to 0.30”. 
On the Background tab, select a 
color for the background of your 
quote. Click OK. Change the other 
quotation sections, and then click 
OK on the Edit Sections dialog. 
Your quotes now have an 
indentation and a background 
color. 

Changes Made in 
Linked Document

If you need to change the 
information in a section linked to 
another document, you might ask 
whether it is better to change the 
original document or within the 

new document. Both are possible. 
The choice is really yours. The one 
thing to remember is changing a 
linked section in a document will 

not be reflected in the original 
document, but changes in the 
original document may be 
reflected in the linking document.

You can control how updates 
are done in the LibreOffice Writer 
options: Tools > Options > 
LibreOffice Writer > General. 
Under Update, you can choose to 
have links updated automatically, 
manually, or never. Automatically 
will update the links when a 
document with links is opened. 
Manually will ask you whether you 
want to update links. Never will 
not update links when a document 
with links is opened. 

Manually Updating 

LIBRE OFFICE - PART 5



full circle magazine #50 16 contents ^

LIBRE OFFICE - PART 5

Links

If you make changes in the 
original document, and you want 
to update the linked document to 
reflect those changes, you have 
two ways to update the linked 
document. Edit > Links... will 
display the Edit Links dialog. Here 
you can select individual links and 
update them. To update all the 
links at once, use Tools > Update > 
Links. 

Frames or Sections?

In some cases, whether you use 
frames or sections matters little. 
There are situations where either 
can accomplish the tasks. 
However, taking the time to 
consider the functionality of each 
can help you make the best choice. 
For example, if you are doing a 
research paper, and you have 
compiled your quotes and data 
into a Writer document, sections 
would probably be your best 
choice for inserting pieces of the 
data into your paper. However, if 
you need to start an article on a 
page, skip a page, and finish it on 
another page, linked frames is a 
better choice. Taking some time to 
think about the purpose, layout, 

and content sources of your
document, and the functionality of 
frames and sections, will help you 
decide the best tool for your 
document. 

While frames and sections are 
similar in many ways, they have 
different functionality that makes 
them suitable for different 
purposes. The powerful ability to 
link to portions of another 
document makes sections unique. 
Remember to plan your layout and 
decide ahead which tools you will 
use to accomplish the task.

In the next article, we will 
look at page styles, headers, and 
footers in Writer documents. 

Elmer Perry is a children's minister in 
Asheville, North Carolina whose 
hobbies include web design, 
programming, and writing. His 
website is eeperry.wordpress.com

Z e r o  D o w n t i m e

Below Zero is a Co-located Server Hosting specialist in the UK.

Uniquely we only provide rack space 
and bandwidth. This makes our service 
more reliable, more flexible, more 
focused and more competitively 
priced. We concentrate solely on the 
hosting of Co-located Servers and their 
associated systems, within Scotland's 
Data Centres.

At the heart of our networking 
infrastructure is state-of-the-art BGP4 
routing that offers optimal data 
delivery and automatic multihomed 
failover between our outstanding 
providers. Customers may rest assured 
that we only use the highest quality of 
bandwidth; our policy is to pay more for the best of breed providers 
and because we buy in bulk this doesn't impact our extremely 
competitive pricing.

At Below Zero we help you to achieve Zero Downtime.

w w w. ze ro d ow n t i m e .co. u k



full circle magazine #51 15 contents ^

HHOOWW--TTOO
Written by Elmer Perry LLiibbrree  OOffffiiccee  --  PPaarrtt  66

In this month's article, we will 
discover a few new ways to 
format our documents using 
page styles, headers and 

footers. In past articles, I have 
discussed the use of paragraph 
and character styles. Page styles 
are similar, but deal with the 
overall geometry and formatting 
of the entire page. Headers and 
footers are the area at the top and 
bottom of the page, and are 
usually the same on every page of 
the same style.

We will start by setting up our 
document and styles. Start a new 
writer document, File > New. In 
order to have access to the 
document's title, we will change 
some of the document's 
properties, File > Properties. On 
the description tab, put “This Is 

The Title” as the title of the 
document. We will use this later 
when we start creating our 
headers and footers. Click OK to 
save your changes.

Now, we need to set up our 
page styles. We will use three page 
styles, First Page, Normal Page, 
and Landscape. First Page and 
Landscape already exist, but we 
will modify them. We will create 
our Normal Page style first. For 
our normal page style, we want a 
header area at the top with a light 
gray background. Open the Styles 
and Formatting dialog, Tools > 
Styles and Formatting, or 
click on the Style and
formatting button (right). 
Click on the page styles button 
(right), right-click in the 
window, and select new. 
The Page Style dialog 
appears. On the Organizer tab, 
name the style “Normal Page.” 
Change the next style to Normal 
Page. This tells Writer that when 
we get to the end of the page, it 
will create a new page with the 
same style. On the Header tab, 
check Header On. This inserts a 

header area on the page. Still on 
the Header tab, click the More 
button. A new dialog comes up. 
This dialog allows us to add 
borders and background colors to 
our header. On the Background 
tab, pick the light gray color for 
the background. Click OK on both 
dialogs, and we are finished with 
our Normal Page style.

For our First Page, we will 
modify the one that already exists. 
We want a 3” (7.5cm) margin at the 
top (for first page graphics added 
at another time), and a light gray 
footer area at the bottom. Right-
click the First Page style in the 
Styles and Formatting dialog, and 
select modify. On the organizer 
tab, make our Normal Page the 
next style. The Page tab allows us 
to change the margins for the 
page. Make the top margin 3” 
(7.5cm). This time we will go to the 
footer tab, check Footer On, click 

on the More button, and choose 
our light gray background.

For our Landscape page style, 
we will modify the existing 
Landscape style. For our 
Landscape style, we will add both 
a header and footer. Right-click on 
the Landscape style and modify. 
Take a few moments to look at the 
page tab and notice the 
orientation for the page is 
landscape, which is exactly what 
we wanted. Turn on the header 
and footer on their respective 
tabs, and select the light gray 
background for both.
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Now, we are ready to create 
our document. Double-click the 
First Page style, and the page in 
your document will change to the 
formatting we added. You will 
notice the light gray footer area at 
the bottom. Click inside the box to 
edit the footer. We will first add 
our title, Insert > Fields > Title. 
This inserts the title we added in 
the document properties. You can 
use this method to insert the title 
of the document anywhere you 
need it. If you change your title 
later in the document properties, 
you can update all instances of the 
inserted field with Tools > Update 
> Fields or by pressing F9 on your 
keyboard. Type “ Page “, 
remembering to put spaces on 
either side of the word Page, and 
insert the page number, Insert > 
Fields > Page Number. Move your 
cursor to the beginning of “Page” 
and press the tab key on your 
keyboard until the page number is 

flush against the right side of the 
footer area. Click out of the footer 
area into the main body of the 
page.

Once this is done, you can 
begin to type in your text. Once 
you reach the end of the page and 
a new page is inserted, you will 
notice it is formatted with the 
Normal Page style with a header 
area at the top. Fill in the header 
information just like we did for the 
footer of the first page. Make sure 
you use the fields, especially on 
the page number. The page 
number field comes in handy when 
we get to the third page. You will 
then notice the header 
information has been copied for 
you and the page number updated 
to reflect the current page.

Next, we will insert a Landscape 
page. Before you get to a new 
page, Insert > Manual Break. 
Select Page Break, and under the 
style, select Landscape. This will 

take you to a new page with a 
Landscape layout. Because this is a 
different style from our Normal 
Page style, we will need to fill in 
our header and footer 
information. This is handy should 
you need different header or 
footer information on some pages, 
just insert a page with a different 
page style. Once you have 
completed your landscaped page, 
create another page break (Insert 
> Manual Break) with a style of 
Normal Page. You will notice your 
page numbering continues, 
including the inserted landscaped 
page(s). If you do not want the 

inserted landscape pages included 
in the page count, you can 
manually adjust the page number 
in the Manual Break dialog. 

Writer makes it easy to add 
pages with different styles and 
orientation, as well as automatic 
headers and footers. You can make 
the headers and footers as big as 
you want, and they can contain 
whatever information you want to 
put in them. Fields help keep 
certain information consistent in 
your document, and let you write 
without worrying about page 
numbers. 

In my next article, I will move 
away from Writer and show you 
how to make a poor man's 
database using a Calc spreadsheet. 
After that, we will use our 
spreadsheet to create a form 
letter. 

“ Writer makes it easy 
to add pages with 
different styles and 
orientation, as well 
as automatic 
headers and footers.
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Up until now we have 
been working in 
LibreOffice Writer, but 
today we will step away 

for just a second to do something 
a little different. We're going to 
create a poor man's database in 
Calc and then return to Writer and 
create a mail merge. This will give 
you some ideas about how you can 
use a spreadsheet as a database. In 
order to do a mail merge, we need 
to work with some sort of 
database. We could create our own 
in Base, but for a simple address 
book, Calc is an easier solution. 

We will start by opening 
LibreOffice and clicking on 
Spreadsheet. This will open Calc 
with a blank spreadsheet. We 
won't go into a lot of details about 
the layout of Calc; we'll save that 

for another day. What you do need 
to know is that a spreadsheet is 
laid out as a series of columns and 
rows. The columns are labeled 
above with letters (A,B,C,...) and 
the rows are down the left side 
labeled with numbers (1,2,3,...). 
When we use Calc as a database, 
the first row must contain the field 
titles for the database. These are 
the database field headers. We will 
put the following field headers in 
the first row: Title, First Name, 
Last Name, Street Address, City, 
State, Postal Code, and Country. 
Each field must be in a separate 
column starting at column A, so 
put the cursor in column A of the 
first row and type in Title. You can 
use the right arrow key on the 
keyboard to move to the next 
column, and fill in the rest of the 
fields. 
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Starting with the second row, 

we begin to fill in our data. Each 
row is a record. Think of a record 
as all the information on one 
person. For our purposes today, 
you don't need to worry too much 
if the data is wider than the 
columns. If you want to adjust the 
width of the columns while you 
input your information, just place 
your mouse over the line 
separating the two columns. The 
cursor will become a double arrow, 
and you can click and drag to 
increase or decrease the width of 
the column. Once we have entered 
all our data, we need to save the 
spreadsheet. I saved mine as 
Poorman_db.ods. Once it is saved, 
close it. 

Before we can use our poor 
man's database, we need to 
register it in LibreOffice. File > 
New > Database will bring up the 
database wizard. Select “connect 
to an existing database”, and in 
the drop-down box, select 
spreadsheet. Click the Next 
button. Use the Browse button to 
find your spreadsheet. Click Next. 
Make sure “Yes, register the 
database for me” is selected, and 
uncheck “Open database for 
editing.” Click Finish, and give the 
database a name (I named mine 

Addresses). The database you just 
created is linked to the 
spreadsheet. Any updates you 
make to the spreadsheet will show 
in the database. The only catch is 
you cannot edit the spreadsheet 
when you have Writer opened. 
Basically, your spreadsheet 
database can be the only 
LibreOffice document open. 
Otherwise, LibreOffice will open 
the spreadsheet in read-only 
mode. 

Now that we have created our 
database, and registered it in 
LibreOffice, we can use it to create 
a mail-merge. Mail-merge is great 
for sending form letters to 
customers or prospects. The cool 
thing is you can put any kind of 
data you want in your database 
and then use it in the letter. For 
example, if you have a rewards 
program for your customers, you 
could have a field for points, and 

include the points each 
customer has earned in 
the letter, but you 
would have to type the 

letter only once. 

Click on the Data Sources icon 
(shown left), View > Data sources, 
or press F4. This will display the 
registered databases below the 

formatting toolbar. In the left part 
of the data sources, Addresses (or 
whatever you named your 
database) > Tables > Sheet1. On 
the right side, you will see your 
data laid out much like you 
entered it in the spreadsheet. We 
insert the fields into the document 
by clicking on the field header and 
dragging it into the document. 
This will create a field placeholder 
for every field you drag into the 
document. Make sure you drag the 
field header and not a data block 

in a record. 

Now, you can type the body of 
your letter. When you need a field 
from the database in your letter, 
you can drag it into the document. 
The database fields can be used 
any place in the document. As I 
said before, your database can 
contain whatever information you 
need it to contain. A teacher could 
even use it to report students' 
grades in a letter to parents. 
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Once you have finished typing 
your letter, you can print or send 
to a file. You might want to send a 
letter to file when you need to go 
back and add personal information 
for certain individuals. Like a 
teacher might want to request a 
parent-teacher conference for a 
student failing the class. File > 
Print, just like you would for a 
normal document. However, 
LibreOffice will tell you that your 
document contains address 
database fields and asks you if you 
want to print a form letter. Answer 
yes. The Mail Merge dialog will 
appear. In the dialog, you can 
choose to print to the printer or to 
a file. Also, you can choose to print 
a letter only for selected records 
or a range of records. You select 
records by clicking on the gray box 

at the beginning of the record, or 
use CTRL-click to select only 
certain records, or SHIFT-click to 
select a series of records. When 
you print to a file, you can choose 
to print to one file, in which case 
each letter will begin on a new 
page, or save as individual files, in 
which case each letter should have 
its own file. You can select which 
database field to use for the file 
name. On my version of 
LibreOffice (3.3.3), I got one 
document whichever I chose. 
Apparently, they are still working 
on this feature. 

You can also use your database 
to generate labels. File > New > 
Labels opens the labels dialog. 
Select your database and table. 
Move the fields over into the label 

information box. Select your label 
type and click New Document. As 
with the form letters, when you 
get ready to print, you will have an 
opportunity to select the records 
you want to print, and you can 
print to a printer or a document. 
You can also create envelopes 
much in the same manner. 

There is another way to create 
a form letter, using the Mail Merge 
Wizard: Tools > Mail Merge Wizard. 
The wizard has some restrictions, 
and when I tried to use the wizard, 
I found it more difficult to get 
good results. I found the manual 
method I have described here to 
give better results, giving the 
creator more control over the 
output.

Mail merge is a great time 
saver. Bang out your letter, drop in 
some database fields, and print. 
Sure beats typing 100s of letters 
or manually editing each one to 
change the information. In my next 
article, we will start to learn more 
about Calc by creating a simple 
budget spreadsheet.


