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Preface
Over the years I have frequently referred people to the eight part Scribus
series from Full Circle magazine which started in FCM#01 (June 2007) by
Ronnie Tucker.
Lately I've found a number of people contacting me saying “It doesn't work!”
to which I've replied “It does but...” The 'but' is that Scribus has evolved and
changed over the years. The layout of some things have changed and
others have moved and/or the way that they work has become more 'user
friendly'. The first obvious change is the toolbars.
I've tried to pull all eight parts of the series together and updated the
graphics. As far as possible I haven't altered the original text unless it has
been necessary or accidental. Unfortunately it was only possible to extract
the original text from two of the articles – the other six had to be copied from
the screen letter by letter.
The first three parts of the series were published in a two column magazine
format. The remaining five parts used a three column landscape format. The
magazine still uses a landscape layout but now uses four columns. If this is
published I don't know how many columns will be used!
At the time of original writing the Scribus version was 1.3.3.8. Now, Ubuntu
11.10 has the current stable release 1.4.0 RC3 although Ubuntu 10.04 uses
version 1.3.3.13svn
Note: Newer Scribus versions can open an older version's file, but the
opposite is not true. Scribus 1.3.3.13 cannot open Scribus 1.4.0 files. There
is no way to convert the file back once you switch it to the newer branch.
However, you can run both branches in parallel to test the new functionality.

Contents

Original text and screens: Ronnie Tucker
Special Edition compilation and updated screens: Brian
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aHow To: Use Scribus Part 1
By the end of this series of Scribus
tutorials you'll be able to create a
full­ fledged publication. Whether it
be a color booklet or a black and
white newsletter, the basics are the
same. So first we need to learn
those basics! As I write this, the
latest version in the Ubuntu
repositories is 1.3.3.8 and is named
scribus­ng, that is exactly what I'll be
using in these tutorials.

Here we either start a new document
or open a previous one. In this first

part of the series we'll just be playing
around with the most widely used
options so we have no need (yet!) to be
picky here, just keep the defaults by
clicking OK

This is our blank page, ready to be
edited.
The red outline is the very edge of
the page. Anything outside that red
border will not be printed. The blue

lines warn you that should you put
anything outside the blue lines (ie:
between the blue lines and the red
outline) you run the risk of it either
being chopped off at the printers or
that your printer may not be able to
print anything in that area. For now,
just think of them as the borders
you'd see on a lined A4 writing pad.
So lets get started. First thing you
need on a page is some nice header
text, so click the Insert Text Frame
button :
Your pointer will change to a small
page with a cross symbol. What we
need to do here is hold down the left
mouse button and draw a box where
we want the text to go. When you're
happy with the size and shape of the
box, release the left mouse button.

That's my box drawn out but where's
the text?
Double left click inside the text box
to add/edit text. Single left click
outside the page to stop editing text.
Let's say we want to move the text.
Easy, just click on the pointer icon at
the top of the screen : ......then, with
your pointer over the text box, which
will change to a grabbing hand icon,
hold down the left button and move
the mouse! To release the text,
release the mouse button.
But our text is a bit small. We need
to open the Properties window to
gain access to the text box
properties. This will let us alter the
size and color of the text. So, go to
the Windows menu and click
Properties...

This is our Properties window.
Everything is greyed out since
we've not selected anything. From
here on in, whenever we select
something on our page, tabs will be
highlighted in the Properties window
to let us know we can edit settings
here.

Let's enlarge the
text size and
alter its color
Highlight the text
and single left
click on the
header text box.
You'll see the
Properties box
spring to life.
Click the Text tab
in the Properties
window.
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TIP At any time you can right click on
any box and select Properties.

Now we're in business! Let's play
around with a few of these options to
get you familiar with editing text.
First enlarge the text by repeatedly
left clicking on the up arrow beside
Font Size (or enter a size value if
you want).

Next, lets center
the text within
the box. Click
the Align Text
Center button
(same choices

as most word processing programs)
Looking good!
Still a bit plain
though, lets put a
splash of color in
there. Left click
Color & Effects,

scroll up/down through the colors
and left click on the color you like.
So we've got a header, we need
actual content text now. So drag out
another text box but this time make it
half the width of the page and quite
tall :

Rather than spend time typing in
filler text (assuming you don't have
the actual article yet) we can have
Scribus fill in text for us. With the text
box still selected go to the Insert
menu and click Sample Text.

Here we can pick the language of
our filler text and number of
paragraphs needed. I've just elected
Standard Lorem Ipsum (Latin) and
ten paragraphs (the default). And
click OK.

But wait, that's not ten paragraphs!
Why was the command ignored?
The reason is because the text is
actually flowing out the bottom of the
text box. If you look closely at the
bottom right of the text box, you'll
see a small box with an 'X' in it.
This symbol tells us that there is not
enough space in the box for all the
text. We either need to enlarge it or
have it flow into another box,
otherwise, it will not be visible.
Drag out a new text box on the right
half of the page, again, make it tall.
This is where the magic happens.

Left click once, on the left column of
text, this is where the text is to flow
from Now click the "Link Text
Frames” button :.. and single left
click on the right text box

Voila! Don't forget to click the Link
Text Frames button again to turn it
off, otherwise Scribus will think you
want to continue linking boxes.
I should mention that the small red
squares which show up on the
corners of your text boxes are
handles, they allow you to resize
your text box. Play around with those
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handles and you'll see your
text automatically update itself
within the two linked text boxes...
Ok, time to save ­ and export – your
work. From the menu, Select File­>
Save as:... and enter a name for the
document
To export the document as a PDF...
Select File­>Export from the menu,
then chose "Save as PDF"
The Preflight Verifier Window
should pop up.

Don't worry, this is the Preflight
Verifier window. It checks your
document for possible errors before
you package it up as a PDF. In this
case it's telling me that there's a
text overflow on page 1. Fine, thats
my ten paragraphs of Lorem Ipsum
that doesn't fit into the two text
boxes, no problem. Keep an eye on

this Preflight Verifier window, it will
save you getting a lot of phone calls
from printers saying that there are
things missing, or wrong, in your
PDF! So in this case we click Ignore
Errors and continue...

The Save as PDF window has a ton
of options that relate to how the PDF
file should look and what should be
packaged inside the PDF file. We'll
get into all that in a later part of this
series for now, give your PDF file a
name and click Save.
A window may briefly flash up, thats
just Scribus converting the page to
PDF, later, we'll see how with several
pages it can take a few moments
longer to convert to PDF. So, let's
look at out handy­work so far in a
PDF viewer :

Beautiful! the screenshot shows the document in Document Viewer, but
since it is PDF it will look the same regardless of what viewer you chose.
I hope you enjoyed the first part of the article, “Using Scribus.” In the next
part we'll add some images to our little sample page.

Based on the original article by Ronnie Tucker in Issue 1 of Full Circle
Magazine
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aHow To: Use Scribus Part 2
In part one we created a new
document, added some filler text
then went on to add columns and
also link the columns together to
have our text automatically from
one column to the next. In this part
we will focus on adding images to
our document.

First the technical bit : JPG images
use compression to keep the f ile

size small. While this may seem like a
good idea at first it comes at a cost:
your image may show “artifacts.”
Artifacts are small squares squares you
sometimes see in images – mainly on
on web pages which often use highly
compressed images – and while this
may look good on a web page, it looks
bad in a document, especially if it's to
be professionally printed. Gif images,
on the other hand, have a limited color
palette. While this may be good for a
two color logo it's not so good when
you try and drop a full­color image to
256 colors. So I suggest you use PNG
images. Do not fall into the trap of
simply converting a bad quality
JPG/GIF to a PNG: this won't repair the
image. Always start with the best­
quality image you can find.
So without further ado, let's load up
our text document from the

previous section.

To place an image into the document
we click the Insert Image Frame
button: and draw out a box, just
like we did for a text box:

To choose an image, right click on the
image frame and choose Get Image:

A file dialog box will appear and from
there you choose which image you
want to insert into the image frame
and click the Open button:

OK, there's a problem... as you can

see from the screenshot, the image
is badly cropped in that we can only
see a small portion of the image.
We need to make a decision here.
Do we make the image frame the
same size as the original image? Or
do we resize the image to the
image frame? For demonstration
purposes we'll do both.
First, to make the image frame the
same size as the original image we
could drag out the image frame
box. Easier still is to right click the
image frame and choose Adjust
Frame to Image:

But now the image is too big,
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time to reduce its size. In the
Properties window click the Image
tab.
This shows the size of the image,
but let's not guess sizes. Let's

resize in the
document itself.
Select the Scale
to Frame Size
option. This will
allow us to
resize the
image by
resizing the
image frame.
Be sure to have
Proportional
ticked as this

will stop us from stretching the
image out of proportion.
Click the image frame and resize it.
And of course you can move the

image frame to position the image
where you please.
The only problem we have now is the
image obscuring the text behind it.
Solution: have the text flow around
the image.
To do this, select the image frame
and in your Properties window, select

the Shape tab.
The Shape tab
is new to us but
all we want to
do for now is
select the Text
Flows Around
Frame Use
Frame Shape
option.

There we go!
The image now
displaces the

text around its edges!

Try moving the image frame on the
page and you'll see the text update
itself automatically. Just like magic!
The only problem we're still left with is
that the text is a bit too close to the
right side of the image. This is easily
fixed.
With the image frame still selected
and in the Shape tab (in the
Properties window) we select Use

Contour Line. Next
click Edit Shape
and a new window
will appear.
Don't panic! We
aren't going to use
most of this window,
but notice that your
image frame now
has a blue outline.
In this new window,

tick the Edit Contour Line option,
our blue outline now has a tiny blue
bob on either corner, left click and
drag those blue bobs. You'll see the
contour line move and your text
with it. Play around with this contour
line to get the text to your liking.
When you're done, click the Edit
Contour option again to turn it off
and click End Editing to close that
window.

And that's pretty much all you need
to know about images!
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aHow To: Use Scribus Part 3
In this third part in the Scribus series
we will discuss formatting text and
creating 'paragraph styles' which will
allow us to format text quickly and
easily at the click of a mouse button.

Anyone who has used OpenOffice
extensively will know how time

consuming it can be select chunks of
text, applying bold, scrolling down,
select ing more text, maybe changing the
font type, font size and so on. Within
Scribus we can set up 'Paragraph Styles
for text, for now, think of a paragraph
style as just being a shortcut that will do
most of the work for you.
Let's create a paragraph style.
Here's my document from last
month.

Now in the Scribus menu choose
Edit > Styles > Paragraph Styles

Note that I have minimized the
paragraph list.
This window allows us to create ­
and edit ­ paragraph styles that we
will use in our document, Click New.

From this window we can edit all of
the styles properties. Everything
from font style, distance between
paragraph lines , bold, italic,
paragraph orientation and color.
Have a play around with the settings
to get a paragraph style you like :

Ok, I've picked a rather garish
looking font, orientation and coloring
but it's to make it stand out more in
the screenshots, you would
obviously choose something a bit
more pleasing on the eye!
With your style chosen, it's time to
save it. At the top of the window
you'll see a text entry box that
currently says 'New Style' in here
type a meaningful name. I'll call mine
'My style' and I'll use it for important
text. Click OK and there it shows in
our list of Paragraph Styles.

Click Apply, click Done to safely
close that window.
Now the important thing about
Paragraph Styles is that it works on
paragraphs. I hate to state the
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obvious but as you can see in our
documents so far there are no
paragraphs. So to add some
paragraphs I'll edit the text and add
a few carriage returns (Enter key).

You can see that I have a definite
paragraph in the right column, so for
this example I want to make that
paragraph have a different style from
the rest of the text. Normally I'd have
to select the block of text to alter the
font type, size and soon, but not
now! We have a paragraph style
ready to do all the work for us. To
apply our style to our paragraph we
simply double click on our text box
(to begin editing it) and place our
flashing cursor we want to apply the
style to. In the Properties window,
click the Text tab. You'll see a
dropdown menu titled Style, click
where it says 'No Style' or on the
down arrow and you'll see your
paragraph style.

Click the name
of your
paragraph style
and your
paragraph will
suddenly take
on the
properties of
yor paragraph
style.
You can also
click on a
column and
apply a

paragraph style to the entire column.

The other good thing about
Paragraph Styles is that any
changes you make to the style is
automatically applied within your
whole document!
If I do Edit > Paragraph Styles, click
my style name and click on the Edit
button and change a few things:

Click Apply to accept those changes
and click Done to change the
Paragraph Styles window....

Voila! It automatically changes all
instances of that paragraph style!
Play around with all the options in
the Paragraph Styles window as it
makes a big difference to your
layout. A lot of publications
effectively use a blank line after each
line of text (to make for easier
reading) so edit your line spacing to

about the height of your text to get
that effect. Some publications will
have their words spread out to cover
the full width of the column which
can look good but can also fail
miserably if your last line has only
three short words and they are
spread out across a wide area so be
careful with that.
Paragraph styles are a great time
saver and you will need them within
your publication for various types of
text. For example on this page that
you are reading now, it has a
paragraph style for the small
introductory text (at the top of the
page) and a style for the main body
of the article. Some pages have a
style for the small captions under
photographs.
Similarly to standardize your colors
within the publication you can create
Color Styles, but we'll discuss that in
Part 4.
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aHow To: Use Scribus Part 4
In this fourth article in the Scribus
series we will discuss creating 'color
styles' which will allow us to quickly
and easily alter various text or shape
colors at the click of a button and
with zero guess work.

Having continuity in your
publications is essential to ensure

that all your pages come together to
form a single publication. Last month
we saw how to create Paragraph Styles
this means that with one click of a
button you can assign the same font,
color and settings every time with
minimal work and, more importantly, no
guess work. This month we look at
Colors, this menu option will do a
similar thing to Paragraph Styles but
with boxes, lines and so on.
This is where we left off in Part 3,
Paragraph Styles:

Imagine this: you are on page fifty of
your publication and you want your
image to have a border which has
the same color and style as the
image on page one. You could easily
scroll, or jump' to page one but
wouldn't it be easier to just have a
palette of colors, with names, that
you can call upon? Well with Scribus'
Colors settings, you can.
First let's make a named color
Click on the Edit > Colors menu
option.

That list is the default colors that
Scribus creates for almost every
document, you can keep them all
and start afresh. But wait! What if I
delete the colors used in my header

and text? To save that happening,
click the Remove Unused button.
Here's my list now.

So let's create a new color for our
palette. Click the New button.

You'll see some text at the top left
which says 'New Color', change that
to what you want to call this color I'm
going to call it 'Photo Border'. Below
that it says 'CMYK'. You can change
that to RGB or Web Safe. If you're

going to send your document to a
professional printer then use CMYK
(same for images too!) but since this
is for a PDF (and not being printed
professionally) I'll choose RGB. The
menu at the top right will give a list of
pre­made palettes if you want this
but I'm going with my custom
palette.

I've chosen my color from the
rainbow box in the right of the
window and
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now click OK.
And there's my custom made color
in the list. Click OK to return to
document editing.
Remember, same as with Paragraph
Styles: if you change a color that is
used in your document, all instances
of that color will change to the new
value.

Next I need a
border around
my image so
select the image
and look at the
Color tab in the
Properties
window
You see the two
icons? On the
right is the 'Fill'
button, this is
what you want

your Shape colored as (it won't do
anything to an image but it will color
the inside of other shapes such as
rectangles, circles and such like) and
below the fill icon is the color that fill
is using in this case, none. To the left
is the Line Colour, this is what
controls the border color, this is what
controls the border color, at the
moment it is set to none, so left click
on our Photo Border color Although

there probably looks like there's no
change, remember that just clicking
the image alone gives it a red border
to show selection so click on

a blank place on the page.
I've got a blue border but I'd like it a
bit thicker. To control the line
thickness and type, click on the
image (remember, all this will also
work for any shapes you draw too)
and click the Line tab in the
Properties window.

Clicking the
'Type of Line'
menu will let you
choose from a
range of styles.
I'll choose the
dashes. If you've
drawn a line this
is also where you
can choose to
have an arrow

head on it. 'Line Width' is the
thickness of the line. I'll go for a
setting of three to make sure it
shows on the screenshots. 'Edges'
and 'Endings' edit either the
start/end of a line or the corners of a
shape. Unless you have particularly
wide shapes you probably won't
notice a great deal of change when
you play with these settings. OK, I'm
happy with that. How does it look?
Again, I click on a blank piece of the
page to deselect the image (or
shape!)

To prove my point: click the 'Insert
Shape' button. Click, hold and drag
out a rectangle (or whichever shape
you have chosen) and release the
mouse button. You'll probably see an
unfilled shape:
These are the default color settings
for a shape but keep the shape
selected and click the Colors tab in
the Properties window. Click the Fill

icon and choose a color and click the
Line icon and choose a color for it
too. Again, same as with the image,
you can click the Line tab and alter
the thickness of the line.

Play around with the shapes,
borders and colors within your
document. Shapes are good for
banners or to put text in, and
remember: you can color the inside
of a shape as transparent by
choosing 'None' for the color
Normally you don't want to go crazy
with colors Same as the Paragraph
Styles: choose maybe six or seven
and stick with them. Too many colors
and text styles will make your
document look confusing and
unprofessional.
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Last issue we looked at creating a set of
colors for use in a document, this month
we will discuss a very powerful feature
of Scribus: layers. Just like in GIMP and
Photoshop, layers can be switched
off/on to hide/reveal whatever items
were placed in that layer. This can help
enormously in a large document to hide
articles that are not needed at the present
time with a further advantage that the
less there is visible, the more responsive
Scribus will continue to be.
So this is where we left off last issue:

We created some color styles,
added a rectangle and applied

one color to fill the rectangle and
another color to create a colored outline
to the shape.
The big problem is that the box is
obscuring the image. What if we
could shuffle their front to back

aHow To: Use Scribus Part 5
placement, wouldn't that fix this
problem? Yes, and that's the first
thing we'll go into with layers. In the
old days of animation everything was
painted on a sheet of clear plastic.
So you would have a foreground, a
background, a character and a
middle ground. Now obviously they
are in the wrong order and they need
to be sorted in the order of
background, middle ground,
character then foreground. This is
exactly the same with our page here.
We created the text boxes first, then
the image and lastly the rectangle so
that is the front to back order they
will stay in until we say otherwise.
Left click on the rectangle to select it.
There's two ways of getting the
same result here, we can right click
on the selected rectangle and
choose Level > Lower

or we can go to the main menu and
choose Item > Level > Lower. Both
give the same result.

Much better. Our rectangle is now on
a lower level than the image. Let's
enlarge the rectangle by clicking on
it and dragging one of the handles to
make it taller.

ow it's covering our text. Again all we
have to do is to select the text box
and lower it, right? No, not quite.

Think about it. The rectangle is
covering the text, so the text is
already on a lower level than the
rectangle, we need to either raise
the text above the rectangle level or
lower the rectangle again to put it
behind the text.

This is pretty much everything for
levels. As well as Raise and lower,
you can also choose Raise to Top
and Lower to Bottom. These are just
quick ways to move from one
extreme to another rather than have
to click the menus dozens of times to
make an item the absolute highest or
lowest.
Now to layers themselves.
Layers work in exactly the same way
as my analogy with the traditional
animation, think of layers as being
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sheets of clear plastic that we can
put items on. First thing we need to
do is show the list of layers that we
currently have. In the main menu,
click Windows > Layers and you'll
see the layers Window

At the moment we have one layer
called Background. The layers
Window has five buttons, from left to
right these are: Add Layer, Delete
Layer, Duplicate the Current Layer,
Raise Layer and Lower Layer. You'll
notice that we have a Raise and
Lower here too just like we have with
Levels, this is because layers also
have a level and this is separate
from the item level but we'll come to
that in a moment. For now, click the
button and Add a New Layer, double
left click there and give it a name.
I've called mine 'My New Layer'. Add
some text and maybe a shape to this
new layer. Make sure that you have
this new layer selected in your
Layers Window otherwise you'll be

putting your items in the wrong layer.
TIP: at the bottom of the Scribus
window, there's a drop down menu
which lists your layers. This is a
quick way to select your layers when
you may have the Layers Window
closed to give you more work space.

Okay, I've added my bits and bobs to
my layer. This is where the magic
happens. Above and to the left of
your new layer you'll see five icons,
on the left is an eye, in the next a
printer and in the middle a padlock.
Now we have very little on our page,
but you imagine you're making a
magazine, like this, where you have
dozens of pages and articles (each
article consisting of text and possibly
some images.) Let me assure you, it
can get very confusing! But not if you
use layers to your advantage. Here's

how I use layers in the creation of
this magazine: I create a layer per
article and on that layer I put all the
text and images for that article.
Why? Because by doing that I can
lock and/or hide articles to make
things less cluttered and keep
Scribus up to speed. Let me show
you how...
In the Layers Window, click the
middle empty box of the Background
layer, this is in the padlock column.

Try selecting your image or filler text!
You can't. It's locked. Un­tick the
padlock to allow access to that layer
again. Uncheck the box below the
eye for the Background layer.

Don't panic! The layer is hidden from
view. Check the box to enable the
layer again.
Make sure the Background layer is
selected, right click on the image
and select Cut! Now select the new
layer, right click anywhere you like
and choose Paste. That image is
now on the new layer. If you don't
believe me try turning the new layer
off then on and you'll see.

Now for an interesting effect: select
the new layer and click the Lower
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button in the Layers Window.
Our text is overwriting the image!
Why? Because all effects work from
the top down, whether it be levels or
layers. The image which pushed the
text aside is now below the text and
has no effect on

it. This is something to remember
when you use multiple layers per
article, and that's why I keep it
simple and use one layer per article.
We're almost at the point where we
can put all these articles together to
form enough knowledge to create
any publication, but one last thing we
need to know before we start adding
pages and thinking about exporting
to PDF is templates. Templates are
similar to Paragraph Styles.
Templates are page layouts which
we can apply to pages and like
Styles, if we alter a template, all
instances of that template will update

accordingly. Templates are
absolutely crucial to a good layout.
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aHow To: Use Scribus Part 6
In this part we're going to discuss Templates.
Templates are crucial to a good layout. Your
Template will lie behind your content and auto­
generate page numbers. It is essential to plan
your layout carefully because all your pages
need to work together to form a single magazine,
not look like they've all come from different
magazines

First of all, let's add a page to our
current page. On the main menu,
click Page > Insert

here you can insert a single, or
several, pages and insert them
before or after a certain page or just
insert them at the end. Here, I'm
choosing to insert two pages at the
end. Don't worry about the Master
Pages bit, we're going to create
those Master Pages soon enough.
Size and orientation usually never
need to be touched unless you're
creating a publication with different
sized pages.

So now we have three pages but
wouldn't it be better if we had them
side by side like having a real
magazine lying open? Well, we can
but just remember that page one is
the cover and will always be by itself
but pages two and three will be side
by side.
In the main menu, click File >
Document Setup

This is where the settings for the
entire document are stored, from the

items down the left side of the
window you can fill in author
information, set guides, default fonts
and all that other fun stuff. For now
though, choose Double Sided in the
Document Layout box and below
that the drop down menu should say
that First Page is : Right Side, this
means that page two will be on a left
page and page three will be
a right side page, in other words:
what most left to right readers will be
used to. Now click OK.

I've zoomed out in the above screen
but you can see that page one is the
cover, the magazine sitting closed,
and pages two and three are side by
side just like a magazine being
opened. Why? Because your
template can have a left page and a
right page so you can make a nice
layout that could span across two

pages. But let's get to making
template pages. In the main menu,
click Edit > Master Pages.

The extra little window that popped
up is your list of Master Pages (aka:
Templates). For now you only have
the one, called Normal, so we'll edit

that for now. Now this is important:
you are not editing any text or
images of content. You're only
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editing things that are going to
decorate the page which are not
content, you'll see what I mean in a
moment. For now let's just add some
shapes, fade them and see what
happens.
So I've created some shapes and
made them transparent. So let's see
what happens when we return to
normal content editing mode. To
return to content editing simply close
the Edit Master Pages window.

As expected, the Normal Master
Page applies to all pages in the
publication so if you try and move
those shapes around, you'll see you
can't, they're locked in place and
only editable in the Master Pages
section of Scribus. Nifty!
Let's create left and right Master
Pages to show you how to apply
them. Again, we click Edit > Master
Pages, now in the Master Pages

window click the top left button,
looks like a single sheet of paper,
this will create a new Master Page
layout.

I'm calling mine My Left Page, and in
the drop down menu below the
name it says Left Page. Make
sure this matches what you're
creating, otherwise the left page you
create will end up on the right pages.
If that happens just edit that drop
down menu to fix things.
So I've created a large shape for my
left page layout, for my right, I just
create another Master Page
but this time: I make sure that my
drop down menu says Right Page.

Although the page has gone blank
don't panic. If you click the My Left
Page you'll see that your left page is
indeed still there, safe and sound.
So I'll create my right page now.
And again close the Edit Master
Pages window to go back to content
editing mode.
To apply a Master Page to a
document page, simply right click on
the page and choose Apply Master
Page

Notice at the top of the window is
where we choose a Master Page to
apply, I'll apply my left page here and
if my document had many pages
then I could choose to apply it to all
even pages, since my left page here
is page two, an even page. And click
OK.

Job done! Do the same for page
three and we're almost there. Now
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remember: you can be as elaborate
as you like with your layout. I've only
used a single simple shape per page
but you can have faded images on
there, nice colorful boxes and what
not so be creative. Just remember
that your text will have
to go on top of this template so make
sure you won't have black text on a
dark piece of background, there's
nothing worse!
One of the things your Master Pages
will need is guides. Guidelines
essentially. These can change from
Master Page to Master Page but it's
usually best to choose one versatile
guide set up and stick with it. If you
want to do this it's best that you put
your guides on one Master Page
then duplicate the Master Page, by
clicking the little button that looks like
two sheets of paper, then add your
left and right designs. Here I'll add
some guides to my left page. First
we go back in to Edit > Master
Pages then go to Page > Manage
Guides.
Here we set up guidelines which we
can snap to which can help us align
text, images and other things. I'll set
up a three column page, like we do
with Full Circle.

In the window I click to have two
verticals (three columns), then I tick
Use Gap and have a value of 30 in
there then click Refer to Margins. So
I could use that for my text, but I'd
like a horizontal line across the
page, roughly a third of the way
down for my header stuff. Easy
done, we just select Single Tab and
click Add where it says Horizontal
(pt), give it a value of 200 and we're
almost done .

One of the last thing s to do though
is to tick the box on the right to Lock

Guides and, if need be, Apply To All
Pages. I'm done, so I click the Close
icon
But where are my guides? Well
sometimes they are turned off.
Simply go to the main menu and
click View > Show Guides. If you
want your items to snap, or jump and
align to, your guides then click Page
> Snap To Guides.

Now, lastly, the all important page
numbers. This is easy. Go in to Edit
Master Pages again and click on
which page you'd like to have a
number. I'll put one on my left page.
Click the Insert Text Frame button –
just as though you were putting
content on a page – and again as we
did before, double click the text box
to add text but, rather than type in
text, go to the main menu and click
Insert > Character > Page
Number and you'll see a hash
symbol (#) appear in your text box.
That's fine.

TIP Don't forget to format the page
number too, give it color and size.
(For older versions only ­ If you
intend to have ten or more pages
then make sure you do that insert
piece twice to get two hash (#)
symbols.)
Now close the Edit Master Pages
window. Scroll down and there you
have it, one page number.
Wherever that Master Page is used
it will auto­generate the page
number. Put one on your right page
and you'll see.

Be creative with your Master Pages
but also be aware that when people
view a PDF they can usually over
ride your double page setting and
view the document page by page so
don't rely on a double page layout to
make your magazine look flashy, a
lot of times the user will view page
by page, certainly on slower
machines.
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aHow To: Use Scribus Part 7
This month we will discuss linking. You can
have two types of links, one is where you link
internally within your own document or
externally where you link to something like a
web page. I've made my page look nice and tidy
for this one just to show you a few nice tricks.

Here is how my page now looks:

What I'll do first is show you how
to create a basic link to a web

page. First we need to create a 'hot spot'
around the piece of text that will become
the link. At the righthand end of the
menu bar depending on your monitor
you will see either

which expands to

or

We want the 'Insert Link Annotation'
option which looks like two
footprints. So click that and then
draw a box around the text (or
image) you want to be the link.

Now I have a PDF 'Link' box around
my text, incidentally you can put this

box around anything as it will always
be on the top so you could surround
an image and some text if you wish.
Double click inside the box to get to
its properties

This is the Annotation Properties
Window. At the moment it says the
Type is 'Link', click that sown arrow
and make it 'External Web­Link' this
now gives a place to type in a web
address so now type one in and click
OK.

Nothing seems to have changed but
you will see later that it will create a
link. But how will people know it's a
link? I can tell you now that in the
final PDF the reader won't know the
link from ordinary text so won't know
there is a link there, what I usually
do is to make the text blue and
underlined just to pretend it's a web
link.
Double click on the text box, select
the piece of text that is going to be
the link, give it a color and make it
underlined.

That looks more like a link you would
expect to see.
Let's add a few pages to the
document just to show how an
internal link works. In the main menu
click Page > Insert and choose to
add four new pages.
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So my document now has a total of
five pages. I'm just going to put
some large numbers on each page
so we can distinguish them from one
another.

So let's return to page one and put in
a link that will make the reader jump
to page 5.
Again, click the PDF button in the
menu and choose 'Link', draw the
box around some text and again
double click the PDF box.

This time keep the Type as 'Link' and
make the page number show as five.
You'll see the page preview on the
right change to show your page five.
The X and Y position is to let you
give the exact location on the
landing page. I'm going to make
each of them zero which will make
the top of the PDF viewer's display
area making the page display fully.
So let's give that a quick test by
exporting the document to a PDF
file.
In the main menu click File > Export
> Save As PDF
If you see the pre­Flight Verifier
window, just click 'Ignore Errors' for
now, we'll go into more detail soon. If
you don't see it don't panic! It means
that no errors were detected!
Congratulations!

That is your 'Save As PDF' now
which has all the options you need to
fine tune your PDF file but for now
choose a save location at the top of
the window then click Save.

This is my exported PDF file in
Document Viewer with the active
external web link, and if I click the
second link:

[
it jumps to page five as expected.
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aHow To: Use Scribus Part 8
In this, the last part of the Learning Scribus
series, we will discuss exporting to the Adobe
PDF format. While PDF is not exactly an 'open'
file format it is easily the most widely used file
format and means that your file will be viewable
in Linux, Mac and Windows. Many professional
print houses also accept PDF for printing.

As ever, Let's see what we have in
Scribus first:

To export to PDF we go to main
menu and choose File > Save as

PDF

Which gives us the Pre­ Flight
Verifier:

This window may seem like a pest at
times, always interrupting your PDF
exports, but it is absolutely crucial
that your document is created and
exported properly to get a valid, and
usable PDF.
The drop down menu at the top right
of the Pre­Flight Verifier window is to
let you choose which version (or
Profile) of PDF you want to export to.
'PDF 1.4' is about the best option to
choose here. If you choose 'PDF 1.3'
or any other option you run the risk
of losing any fancy transparency you
may have done.
Below the drop down menu is a list

of your document pages and any
conflicts that Scribus finds between
your document and the PDF Profile
you have chosen in the drop down
menu. Here I've chosen the profile
for 'PDF 1.3' and you can see it has
given me a long list of errors, this is
due to the semi­transparent numbers
I put on the blank pages in a
previous tutorial.

When I change the profile back to
'PDF 1.5' I only have one error and
that is a text overflow on page one.
That is acceptable as the text is
indeed too long for the text boxes on
page one but it is only filler text and
not important. You will also get
warnings if any shape objects are
not on a page properly.

So that's my one error and it's totally
acceptable so I click th 'Ignore
Errors' button.
TIP You can call up the Pre­Flight
Verifier window any time by clicking
its button

Now we have the actual export
settings:

At the top of the window is 'Output to
File'. This is where you will save the
PDF and what you want to name it. If
you wish you can export each page
as a separate file by simply checking
the box below the file location box.
This window has seven tabs (a



21 Contents

seventh will be available if you
choose the 'PDF/X­3' Profile) we'll
work through these from left to right
starting with the General tab.

Export range lets you export the
entire document (All Pages) or
export selected pages (Choose
Pages), with the button checked for
Choose Pages you can enter
something like: 1­3,5. That would
export pages one through three and
also print page five. Rotation, as it
sounds, lets you rotate the pages in
the exported PDF.

File options lets you choose a new
PDF Profile (Compatability) and a
margin for binding. You can then
check boxes for generating
thumbnails, including bookmarks
and so on. Last option hee is the
resolution for EPS 9vector) graphics,
300 dpi is for professional quality
printing.. If you are creating a
document for viewing on screen or
want to keep your file size down you
could set this to 100dpi.
Compress Text and Vector Graphics
will dramatically change your file
size. Compression Method is set. By
default, at Automatic and quality is
set at Maximum. Again, these are for
professional quality printing. I can't
say choose 'Lossy JPG' for the best
method but if you have to change it
from Automatic I'd say choose
'Lossless ZIP', For quality I'd
recommend you keep it at Maximum
as otherwise it will start to heavily
compress your images and your
PDF will look quite dirty and grainy.
Fonts is the tab where we can see
which fonts we've used and most

importantly which fonts will be
embedded into the PDF.

If a font you've used is not available
on the reader's computer then you'd
hit problems, thankfully this is
overcome by embedding the fonts
into the PDF file so it is important to
click the Embed All button to save
getting errors.
Be careful here as you cannot
embed all fonts, some bought fonts
come with licenses that do not allow
embedding.

The Extras tab gives access to
presentation effects:
This is to effectively create a PDF
slide­show. Something I doubt would
be welcome at your local print shop!

The viewer tab is very important for
the display of your document.
Some PDF files will come as 'Single
Page' where you scroll down viewing
one page at a time. But some
documents come displayed as an
open book (Double Page) with two
pages on screen at once. Document
Layout is where this setting is
selected. Double Page has a Left
and Right option, this is where your
front page will be. Right is what most
European publications would use.
Visual Appearance is where you can
use the PDF viewer applications'
default settings or force other
options such as full screen, display
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thumbnails and so on. Special
Actions is rarely used but may come
in handy if you want to execute
some java­script on opening a PDF.
Security is where you can encrypt
your PDF with a password.

You can also allow or prevent such
things as printing, copying text and
such like. {seems like that function
was used a lot in this series}
Colour tab has some settings for
either 'Screen/Web', 'Printer' or
'Grayscale'. Most of the time you will
use Screen/Web.

Pre­Press is for adding the
information that professional printers
need and cannot be fully used
unless you activated color
management and used PDF/X­3. If
you aren't using a commercial printer
just ignore it.
After you have sifted through the
options you click Save and hope for
the best! {¾ fail in this series ­
blocked copy!!!!!} If it's your first
time exporting a document to PDF
then it will take a few tries to get it
just the way you want it.
In closing, there are some things you
must remember while exporting your
document:
Do not rely on user changeable
options – such as menu bars – for
presentations as the user can easily
turn these back on again possibly
making your document look ugly.
It is best not to let your document go

full screen as some viewer
applications may not ask or give a
warning which may frighten viewers
when the screen goes blank and
flickers!
The Pre­Flight Verifier is your friend,
heed its warnings! You can click on
an error in the Verifier window and it
will jump to that page and highlight
what, or where, the error is located.
Think about your readers, if they are
viewing your document on a slow
computer or n old laptop then you
really do not want to use the 'open
book' format as their machine may
be too old to quickly display two
pages at once.
To edit what is checked or
unchecked in this document's Export
PDF window you can do the File >
Document Set­up menu.
And that brings us to the end of my
Learning Scribus series. I hope
you've enjoyed it. I've seen some
great things.
Ref:
http://showmedo.com/videotutorials/
series?name=NfUrduNov
Scribus video tutorials.

http://showmedo.com/videotutorials/series?name=NfUrduNov
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Looking at these scrrenshots you can
understand why I got calls saying

"It doesn't work"
In these pages there isn't anything
used that isn't in the guide. Scribus
works but............it will continue to
change and improve.

New Page
v 1.3.3.13 v 1.40RC3 v 1.3.3.13 v 1.40RC3 v 1.3.3.13 v 1.40RC3

Guide Lines

Paragraph Style

Text

Color

Shape

Line

Image

Some differences between versions.
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Scribus release notes
http://wiki.scribus.net/canvas/1.4.0_Release
Scribus video tutorials.
http://showmedo.com/videotutorials/series?name=NfUrduNov
Original Tutorial
http://docs.scribus.net/index.php?lang=en&page=tutorials/freedomyug/scribustutori
al
Scribus Howtos
http://wiki.scribus.net/canvas/Working_with_Scribus:_How_to_begin
http://wiki.scribus.net/canvas/Working_with_text_frames
http://wiki.scribus.net/canvas/Laying_out_articles
http://documentation.scribus.net/index.php/Page_Numbering
http://wiki.scribus.net/canvas/Working_with_Story_Editor#Opening_Story_Editor
Links to Success Stories
http://wiki.scribus.net/canvas/Category:Publications
Some older interesting links.
http://w3.linux­magazine.com/issue/49/Linux_for_Layout_Part_1_Scribus.pdf
http://w3.linux­magazine.com/issue/50/Linux_for_Layout_Part_2_Scribus.pdf
http://w3.linux­
magazine.com/issue/51/Linux_for_Layout_Part_3_Preparing_for_Press.pdf
Recent articles
http://www.linuxjournal.com/content/four­hidden­tools­scribus
http://www.linuxjournal.com/content/tweaking­text­scribus
http://www.linuxjournal.com/content/printing­scribus
For Professional Printing
http://wiki.scribus.net/canvas/How_to_legally_obtain_spot_colour_palettes_for_use
_in_Scribus_1.3.3.x_and_later_versions

Full Circle Magazine ran a series of tutorials on Scribus starting in Issue 1.
http://fullcirclemagazine.org/downloads/
Issue 1 p19 Create document. Create text box. Create Columns. Insert filler
text. Link columns and flow text.
Issue 2 p17 Add Graphics. Flow text round graphics.
Issue 3 p12 Paragraph Styles.
Issue 4 p13 Colour Styles.
Issue 5 p20 Layers.
Issue 6 p14 Templates and Page Numbers.
Issue 7 p13 Create links.
Issue 8 p16 Export to PDF and Pre Flight Verifier.

Some Links

http://wiki.scribus.net/canvas/1.4.0_Release
http://showmedo.com/videotutorials/series?name=NfUrduNov
http://docs.scribus.net/index.php?lang=en&page=tutorials/freedomyug/scribustutorial
http://wiki.scribus.net/canvas/Working_with_Scribus:_How_to_begin
http://wiki.scribus.net/canvas/Working_with_text_frames
http://wiki.scribus.net/canvas/Laying_out_articles
http://documentation.scribus.net/index.php/Page_Numbering
http://wiki.scribus.net/canvas/Working_with_Story_Editor#Opening_Story_Editor
http://wiki.scribus.net/canvas/Category:Publications
http://fullcirclemagazine.org/downloads/
http://w3.linux-magazine.com/issue/49/Linux_for_Layout_Part_1_Scribus.pdf
http://w3.linux-magazine.com/issue/50/Linux_for_Layout_Part_2_Scribus.pdf
http://w3.linux-magazine.com/issue/51/Linux_for_Layout_Part_3_Preparing_for_Press.pdf
http://www.linuxjournal.com/content/four-hidden-tools-scribus
http://www.linuxjournal.com/content/tweaking-text-scribus
http://www.linuxjournal.com/content/printing-scribus
http://wiki.scribus.net/canvas/How_to_legally_obtain_spot_colour_palettes_for_use_in_Scribus_1.3.3.x_and_later_versions



